От редактора русского издания

Как мало нужно человеку для счастья!..

Любимый Game.EXE существует почти вечность, пять лет и два месяца, и все это время мы, его корреспонденты, редакторы, дизайнеры, рекламные менеджеры и труженики славного отдела подписки и распространения, мечтали о том, чтобы стать чем-то большим, нежели обычное средство массовой информации. Правда-правда, идея издавать в виде приложения к журналу то сборники прохождений лучших игр, т.н. гайдов, то дайджесты (эдакие итоговые «расширенные, углубленные и переосмысленные по прошествии времени» 13-е номера) самого-самого, что было опубликовано в .ЕХЕ в ушедшем году, то еще что (ну... вы догадались, сборники того, что у нас принято беззаветно давить, - чит-кодов и прочей casualis ереси), возникала с периодичностью раз в полгода, мужала, набиралась ума, обстоятельности и, выйдя на приличную скорость, всякий раз... билась головой о стену. Стену экономики. Да так, что обычно не вставала. Экономика - страшная вещь. Особенно наша, страны березового ситца.

Шли годы. Наши желанья поневоле становились спокойней. Блеск в глазах сворачивался в черную дыру. Мечты утрачивали хрустальность.

Но однажды, на излете до неприличия холодной осени 99-го, в закоченевшую редакцию постучались два добрых розовощеких самаритянина Сергей Гладков и Роман Пыхов из славной не только помыслами, но и делами компании «Логрус» и, чинно отряхнув от снега крылья, валенки и шапки-ушанки, сказали:

- Мечтаете? Хотите? Будете?

- Угу-гу... - не попадая зуб на зуб, ответили мы, ничему, впрочем, не веря.

- Тогда - решено. «Библиотека журнала Game.EXE». Неплохое название, верно? Распишитесь вот тут, тут и тут. Счастье для всех, даром, и пусть никто не уйдет обиженный! - Нимбы над их головами сверкнули тысячью гало, самаритяне расправили крылья и были таковы, оставив после себя стойкий запах дорогого мужского одеколона «Pasha De Cartier», да вот эту толстенную книгу с совершенно невразумительным и, более того, неродным названием «Game design. Secrets of the sages».

С тех пор давным-давно вышедший из репродуктивного возраста редакционный фикус цветет не переставая, а мы - счастливы самым непристойным и безответственным образом. Особенно сейчас, когда работа над русским изданием «Компьютерных игр: как это делается», ПЕРВОЙ КНИГИ ИЗ СЕРИИ «БИБЛИОТЕКА ЖУРНАЛА GAME.EXE» (yes!!!), подошла к концу, а сама книга, как нам кажется, получилась очень и очень симпатичной.

Ах да, что же это за книга? на кого она рассчитана? насколько актуальна?..

Очень, очень коротко и строго по существу, потому что и название у нее весьма многоговорящее, и содержание - вот оно, перед вами: подготовка проекта, игровые жанры и типы перспективы, общие принципы создания игр, создание персонажей, эскизов, проектной документации, уровней и миссий, программирование, искусственный интеллект, художественное оформление игры, музыка в играх, тестирование, маркетинг и работа с прессой... И т.д. и т.п. Какие еще комментарии здесь нужны? Разве что вот такие: автор этого впечатляющего труда Марк Зальцман, встретившийся со 144 (!) представителями индустрии и скрупулезно записавший их рассуждения, советы, воспоминания, сумел привести весь этот огромный разнокалиберный, разножанровый материал к общему знаменателю - текст читается на одном дыхании, текст интересен как праздным любителям компьютерных игр, так и профессионалам-разработчикам (это проверено и сомнению не подлежит), текст появился именно тогда, когда пришло его время. Это что касается вопросов «для кого» и «насколько актуально».

А теперь по сути. Первое: книга, которую вы держите в руках, уникальна. Ничего подобного прежде не выходило. А выйдет ли в будущем - большой вопрос. Она подытоживает романтический период развития компьютерных игр, период их становления как высокотехнологичного, очень трудоемкого и сложного, весьма образного, активного и демократичного синтетического искусства, всей своей сущностью устремленного в будущее. Здесь есть все: и теория, и практика, и даже, простите, публицистика (в том смысле, что игра вообще, а компьютерная игра в частности - неотъемлемая часть культуры и социальной жизни человека). В то же время это прекрасный в своей подробности портрет молодой профессии, молодой индустрии, которой мы служим. Наконец, это, если угодно, полноценный вузовский учебник по курсу «Введение в специальность», будь вузы (например, многоуважаемый МГУ, факультет ВМиК) столь смелы, чтобы открыть у себя соответствующее отделение.

А ведь это еще и исторический документ, вдруг подумал я... Через пару сотен лет историки культуры, специализирующиеся на 20 веке, будут благодарны Марку Зальцману за то, что он открыл им глаза на древние компьютерные игры и их творцов. И вот еще что: слово «Doom»... теперь они точно знают: бога с таким именем не было.

Второе и последнее, главное: эта книга впервые столь подробно, осмысленно и аргументированно, не оставляя никаких сомнений и кривотолков, отвечает на вопрос, что есть компьютерные игры.

Компьютерные игры - это адский труд, заслуживающий, право же, самого серьезного уважения. Компьютерные игры - это искусство. Главнейшее и лучшее из искусств, как нам кажется. И эта книга - самое яркое тому подтверждение.

Еще раз низкий поклон Марку Зальцману, нашим добрым коллегам-самаритянам, переводчикам, редакторам и всем вам, дорогие читатели.

Игорь Исупов, гл. редактор журнала Game.EXE, апрель 2000 г.

P.S. Что впереди? Новые книги. Скорее всего, это будут подробные, написанные настоящими профессионалами, прекрасно иллюстрированные прохождения самых популярных компьютерных игр, которые, как мы планируем, будут выходить одновременно с появлением игры в продаже. Следите За рекламой - объявлениями в журналах Game.EXE, «Компьютерра» (спасибо Евгению Козловскому), «Домашний компьютер» (спасибо Алексею Поликовскому) и «Инфо-бизнес» (спасибо Дмитрию Мендрелюку, Денису Викторову и Игорю Гордиенко).

P.P.S. Жизнь удалась.

P.P.P.S. Заранее благодарим тех читателей этой книги, которые найдут возможность так или иначе откликнуться на ее выход и прислать свои критические замечания, пожелания, вопросы. Пишите по адресу: post@game-exe.ru.


От издательства

Нет в жизни счастья, а есть только покой и воля.

Логрус существует давно. Точнее, Логрус существовал всегда - так записано в Хрониках Эмбера. Хроники утверждают, что Логрус оказывает влияние на все сущее во всех отражениях. Так это или нет - отсюда трудно сказать, но по крайней мере в нашем отражении Логрус оказал совершенно конкретное влияние на русские версии Windows 95, Windows 98, Office 95, Office 97, Windows 2000, Office 2000 и еще примерно 60 продуктов, выпущенных в России в течение последних семи лет... Когда вышла русская версия Windows 95, в одном из журналов, уж теперь трудно припомнить, где именно, один из интервьюируемых (по другому совершенно поводу) выразился вскользь в том духе, что «наконец-то Майкрософт выпустил русскую версию операционной системы, с которой можно работать и которую не противно устанавливать на свой компьютер». В то время еще каждый второй заявлял, что приятнее работать с английской версией, так что «не противно» - это был высший балл.

С тех пор планка только поднималась. И надо ведь постоянно соответствовать и проходить над, а не под. Но мы были уверены, что можем абсолютно все. А тем, кто сомневался и говорил, что технический перевод дело нехитрое, а вот попробуйте-ка перевести художественный текст, мы дарили коробки переведенных нами игр «Розовая Пантера» и «Шизариум». И советовали поиграть и убедиться лично. Чаще всего больше мы от них ничего не слышали...

За эту, найденную в далеких отражениях книгу, мы взялись совершенно не случайно. Это ведь не что иное, как библия игровой индустрии. Или, по крайней мере, жития святых. Поэтому она будет интересна разработчикам и дизайнерам, программистам и просто любителям игр. А также тем, кто хочет просто блеснуть эрудицией или припасть к авторитетному источнику и разобраться, отстой он вчера купил на Горбушке или суперхит :). Мы хотели сделать такую книгу о компьютерных играх, не прочесть которую было бы просто неприлично, - посмотрим, удалось ли нам это.

Хотя можно сказать, что эта книга и не об играх... Нам, например, кажется, что она - о жизни. О том, чему надо учиться. О том, как заниматься любимым делом и получать за это деньги. О том, как делается проект. О том, как зарабатывать, не выходя из дома. О том, как поступить на работу в ведущую компанию и сделать там карьеру. О том, как принимаются большие решения и какие мероприятия надо посещать, чтобы решения были приняты в твою пользу. О целеустремленности, о мечте и об упорстве. Короче говоря, эта книга является практическим руководством тому, кто хочет поставить себе цель и добиться ее - на примере отрасли компьютерных игр. И если пять лет назад 95% написанного в этой книге не имело бы к нашей российской действительности никакого отношения, то теперь все эти советы вполне могут быть с успехом применены к себе молодыми дарованиями в России. Кстати, папы и мамы дарований: книга - лучший подарок! Если у вас сомнения в том, что ваше дитя с пользой проводит время за Quake, подарите ему эту книгу. Не бойтесь, шансы на то, что ваш сын станет игровым разработчиком, ничтожно малы. Ну, а если станет - считайте, что вам повезло, поскольку создание компьютерных игр - дело вовсе не шуточное, а очень даже серьезное.

В 1999 году в США было продано более 215 миллионов копий компьютерных игр, а общий оборот отрасли превысил 6 миллиардов долларов, что в два раза выше, чем в 1995 году. Чтобы получить мировую картину, эти цифры надо удвоить. При этом оборот отрасли растет как на дрожжах каждый год и останавливаться не собирается. Если такие темпы развития сохранятся, то индустрия компьютерных развлечений вскоре поглотит многие другие отрасли развлечений. Все это означает, что создание компьютерных игр - это не только Большое Искусство, но и Большой Бизнес. А в мировой индустрии компьютерных развлечений российские разработчики занимают свое достойное место. И мы имеем в виду не только дедушку Тетриса, а все те замечательные проекты, которые последовали вслед за ним. Процесс набирает обороты, и мы все заинтересованы в том, чтобы российских проектов и команд, успешно заявивших себя на этом глобальном рынке и сумевших занять там свое место, становилось все больше и больше. Мы очень надеемся, что одной из первых ступеней на этом пути станет предлагаемая вам книга. Именно она объединила нас с партнером по изданию - журналом GAME.EXE, который не только гордо выделяется среди прочих изданий аналогичной тематики реальным отсутствием ангажированности, но и является настоящим источником идей для думающего разработчика.

Эта полезная, многоплановая, всеохватная книга написана в весьма необычном и одном из самых трудных для перевода жанров, в виде сборника интервью от первого лица. Избрав этот подход, Марк Зальцман добился потрясающей достоверности изложения. Нам предоставляется возможность увидеть все своими глазами, а не через призму мнения автора. Эта волшебная книга открывает перед вами двери в святая святых отрасли, дает пощупать руками культовые предметы, из первых рук услышать рассказ о том, как создавались миры.

Мы задержали книгу по сравнению с первоначальным планом выпуска, но нисколько об этом не жалеем. Благодаря этому нам удалось дополнить книгу материалами из фотоархива GAME.EXE, в том числе фотографиями с последней выставки ЕЗ, проходившей в мае 2000 в Лос-Анджелесе. Ведь сотрудники GAME.EXE лично знакомы со многими соавторами этой книги, которые обязательно получат в подарок свой экземпляр. И хотя по-русски многие не понимают ни слова :), они все равно будут ужасно благодарны!

А если серьезно, то надо прямо сказать, что книга осталась бы недоступной русскоязычному читателю без понимания и неоценимой помощи Игоря Исупова и Михаила Новикова из журнала GAME.EXE. Они не только приняли организационное участие в проекте, не только возвестили миру со своей трибуны «камо грядеши», но неоднократно магическим прикосновением с высоты своего опыта указывали нам на неточности перевода. За что мы им искренне и глубоко благодарны - даже несмотря на то, что слова «скриншот», «аддон» или, скажем, «дефматч» несколько взрезали наше мелкомягко взращенное ухо. Надеемся, что мы будем еще не раз иметь возможность их поблагодарить и в других книгах серии. А вас, дорогие читатели, мы благодарить пока не будем. Вот прочтете, напишете отзыв, тогда и поблагодарим.
Что касается следующих книг, то один раз нам удалось еще протащить в серию «Библиотека GAME.EXE» книгу не совсем об играх. Но второй раз номер точно не пройдет. Так что следующие книги серии будут все-таки об играх. Мы будем стараться выпускать их быстро и качественно. Это - серьезное такое обязательство (в чем вы убедитесь, прочтя эту книгу). Надеемся, что дебютант убедит вас в том, что вам следует раздобыть и все остальные книги серии. Направляйте нам по обычной (117335, Москва, а/я 37) и электронной (books@logrus.net) почте все свои отзывы, предложения и замечания по переводу, оформлению, выходу книг и вообще все, что хотите. Предложения мы распечатаем и сложим в папочку, замечания учтем, что не понравится удалим, а вот ценные советы по поводу того, какую следующую книгу вы -бы хотели видеть, мы обязательно постараемся воплотить в жизнь.

Пишите!

ЛОГРУС

Июнь 2000


От автора

Посвящение автора

Эта книга посвящается Келли Шерман за ее бесконечную любовь и поддержку.

Благодарности автора

Настоящим выражается сердечная благодарность всем незаурядным лицам в индустрии электронных игр, потратившим время и силы на то, чтобы принять участие в создании этой книги.

Огромное спасибо Стиву Шаферу за его приветливость и профессионализм, а также за оправдавшуюся уверенность в том, что людям, которые любят игры, может быть интересно, как они создаются. Спасибо Робин Дрейк за ее профессиональную редактуру и ободряющие слова. Наконец, большое спасибо Брэду Смиту за огромную работу, которую он проделал над книгой. Без него бы у нас ничего не получилось!

Об авторах

Марк Зальцман, редактор-составитель

Марк Зальцман - независимый журналист, автор более чем 40 публикаций по играм и маркетингу в USA Today, Playboy magazine, PC Gamer, PC Accelerator, PC Games, Gamecenter, Yahoo! Internet Life, Next Generation, Happy Puppy, Family PC, Golf Digest и многих других изданиях. Он также является автором двух книг об Интернет-играх, изданных Macmillan Publishing, и двух руководств пользователя для игр Quake II и Sin.

Участники проекта

Материал этой книги составлен со слов перечисленных ниже замечательных дизайнеров, программистов, продюсеров, музыкантов, звукоинженеров и других специалистов (все профессии которых невозможно здесь перечислить), чей опыт открывает читателю захватывающий мир компьютерных игр. (Биографические сведения о лицах, принимавших участие в создании этой книги, приведены в приложении в конце этой книги.)

Peter Akemann
Kurt Arnlund
Marc Aubanel
Ted Backman
Kelly Bailey
Sinjin Bain
Andrew Barnabas
Bob Bates
Tom Bazzano
Liz Bell
Mark Bernal
Eric Biessman
Cliff Bleszinski
Dan Bray
George Broussard
Chip Bumgardner
Melanie Cambron
Carol Caracciolo
Louis Castle
Jim Charne
Jason Chu
Kevin W. Cloud
Steven Coallier
Bryce Cochrane
Vance Cook
Nick Corea
Brad Crow
Matthew D'Andria
Stuart Denman
Vince Desiderio
Barry Dorf
Scott Easley
Sacha Fernandes
Chad Freeman
Jamie Fristrom
Toby Gard
Alex Garden
Richard «Lord British» Garriott
Ron Gilbert
Rick Goodman
Charles Gough
Mark A.C. Green
Mario Grimani
Tom Hall
Torsten Hess
Evan Hirsch
Rodney Hodge
Bryan C. Horling

Sean House
Matt Householder
Marc Hudgins
Allen Jackson
PaulJaquays
Jane Jensen
Todd Johnson
Matthew Lee Johnston
Adam Kahn
Michael Kelly
Geoff Kirk
Joe Koberstein
Marc Laidlaw
Michael Land
Franz Lanzinger
Tim Larkin
The Levelord (Richard Bailey Gray)
Adam Levesque
Susan Lewis
Bill Linn
Mark Linn
Carin Lockrem
Doug Lombardi
Al Lowe
Tony Lupidi
Jean-Francois Malouin
Michael McCart
Mitzi McGilvray
Michael McGrath
Seumas McNally
Sid Meier
Ellen Meijers-Gabriel
Michael Meyers
Harry A. Miller
Shigeru Miyamoto
Richard Мое
Peter Molyneux
Steve Moraff
Peter Moreland
Ray Musyka
Gabe Newell
Mike Nichols
Mike Nicholson
Paul O'Connor
Scott Orr
Genevieve Ostergard
Alexey Pajitnov
Rob Pardo

Alan Patmore
David Perry
Kurt Pfeifer
Bobby Prince
Matt Pritchard
Josh Resnick
Brian Reynolds
Hugh Riley
Chris Rippy
Seth Robinson
John Romero
Stuart Roseman
Michael Rubinelli
Haiko Ruttmann
Michael Saladino
George (The Fat Man) Sanger
Ragnar Scheuermann
Kevin Schilder
Carl Schnurr
Joe Selinske
Lee Sheldon
Bruce C. Shelley
Toby Simpson
Chris Sivertsen
Brandon Smith
Joshua Staub
Phil Steinmeyer
Timothy J. Stellmach
Jay Stelly
Jonas Stewart
Greg Street
Gonzo Suarez
Tommy Tallarico
Chris Taylor (Gas Powered Games)
Chris Taylor (Interplay)
Chance Thomas
Joel Thomas
Matthew Toschlog
Rick Vandervoorn
Jeff Vogel
Wolfgang Walk
David Walls
Robin Ward
Roberta Williams
Tim Willits
Jay Wilson
Mike Wilson
Jon Zuk


Итак, вы решили посвятить себя созданию игр...

...или хотя бы узнать, КАК ЭТО ДЕЛАЕТСЯ. В любом случае правильное, а главное своевременное решение: программное обеспечение (ПО) стало значительно совершеннее, работать с ним куда легче, чем прежде, игровая индустрия бурно развивается, а Интернет предоставил игрокам и разработчикам небывалые возможности. Так что куйте железо, пока горячо!

Зарабатывать на жизнь созданием игр?.. Поначалу кажется, что это похоже на детскую мечту. Однако для тысяч людей сегодня это вполне реальный способ получить свой кусок хлеба с маслом, а нередко и с колбасой. Между прочим, для создания популярной (или, если угодно, хорошо продаваемой) игры совсем не обязательно иметь миллионы долларов. Возьмем, к примеру, небезызвестную игру Deer Hunter (издатель Wizard Works). По затратам на разработку «Охотник на оленей» был одним из самых дешевых проектов, но в то же время оказался одной из самых популярных игр 1998 года, только в США изданной тиражом более миллиона экземпляров (задумайтесь: по одному «Охотнику» на 272 американца!). В чем причины такого успеха? Оригинальная игровая идея удачно соединилась с умело организованным сбытом и относительно низкой ценой. Подобные достижения обычно открывают новые горизонты - торговлю лицензиями и создание продолжений. Так и случилось: продажи Deer Hunter II уже приближаются к миллиону экземпляров.

По данным за 1998 год только в США объем розничной торговли компьютерными и консольными (приставочными) играми (ПО и оборудование) превысил 6,3 миллиарда долларов. Вас это не впечатляет? Тогда знайте, что годовой прирост составил 27%. Налицо бурный расцвет молодой индустрии, так что же ждет нас с вами в 21-м веке!..

Как нам известно, книга, которую вы держите в руках, не похожа ни на одну из когда-либо издававшихся по данной тематике. От вас не требуется обширных знаний. Для понимания этой книги не нужно быть продвинутым программистом и разбираться в таких сложных вещах, как структуры данных, анализ алгоритмов и т.п. Книга написана доступным языком, а все специальные термины, аббревиатуры и профессиональные жаргонизмы снабжены пояснениями.

Хотя книга называется «Компьютерные игры: как это делается», речь в ней идет не только о разработке как таковой. Помимо объяснений, как правильно составлять проектную документацию или же выбирать жанр
будущей игры, вы найдете здесь массу сведений, которые будут небезынтересны любому участнику коллектива разработчиков - программисту, художнику, аниматору, звукоинженеру, композитору. Затронуты и многие коммерческие вопросы этой деятельности. Изложены советы по организации сбыта игр, работе с прессой, описаны лучшие способы тестирования продуктов, объясняется важность посвященного игре веб-сайта, обсуждаются всевозможные тонкости технической поддержки и обслуживания пользователей, а также многое-многое другое. Наконец, значительная часть второй половины книги посвящена тому, как сделать карьеру в игровой индустрии. Что вам больше по душе: создавать в одиночку условно-бесплатные игры (shareware), учредить собственную фирму и предложить свою идею издателям или поступить на работу в уже существующую компанию?

Разумеется, столь разностороннюю книгу вовсе не обязательно штудировать от корки до корки. Выбирайте наиболее интересные лично вам разделы в любой последовательности.

Не забывайте также, что тему любой главы, в свою очередь, можно развить на целую книгу, а то и несколько книг. Именно поэтому многие главы содержат ссылки на другие «бумажные» публикации, веб-сайты и иные Интернет-ресурсы, где можно почерпнуть дополнительную информацию, а двадцать четвертая глава целиком состоит из кратких описаний веб-сайтов и электронных журналов, посвященных созданию игр.

Какой бы жанр вас ни привлекал, будь то экшен-игры или стратегии, симуляторы или спорт, квесты, РПГ или логические игры, в каком бы жанре вы ни хотели работать, более сотни ведущих мировых разработчиков поделятся с вами своим многолетним опытом создания успешных игр.

Итак, в добрый путь по миру игр. Перед вами сотни страниц, в которых заключены секреты мастерства. Если вы прислушаетесь к мудрым советам, изложенным на этих страницах, то для создания хита всех времен и народов вам останется лишь призвать на помощь воображение...


Подготовка проекта

Часть I

Подготовка проекта

1 | Игровые жанры и типы перспективы
2 | Общие принципы создания игр: экшен-игры и стратегии
3 | Общие принципы создания игр: квесты, РПГ, спортивные игры, головоломки и симуляторы
4 | Создание персонажей, эскизов и проектной документации
5 | Создание головоломок
6 | Создание уровней
7 | Создание миссий


Игровые жанры и типы перспективы

Глава 1

Игровые жанры и типы перспективы

Прежде чем перейти к основному содержанию книги, оговорим несколько базовых понятий, с которыми нам потом придется часто сталкиваться. В первой части этой главы вы познакомитесь с нашим вариантом классификации игровых жанров. Это необходимо, чтобы говорить с вами на одном языке. Кроме того, прежде чем сесть за компьютер и начать писать собственную игру, имеет смысл определить, в каком жанре (или их комбинации) вы намереваетесь творить.

К тому же нам понадобятся термины, описывающие перспективу игры - точку, с которой игрок наблюдает за происходящим. В разделе «Типы игровой перспективы» мы объясним и снабдим примерами такие понятия, как «вид с высоты птичьего полета», «игра от первого (третьего) лица», «изометрическая проекция» и т.п.

Ну что ж, как говаривал Дюк Ньюкем, приступим...

Игровые жанры

Экшен-игры (Action) и аркады (Arcade)

Эти игры привлекают своих поклонников скорее возможностью пощекотать нервы и проверить скорость реакции, нежели захватывающим сюжетом или хитроумными игровыми стратегиями. Действие развивается очень быстро, и победить можно только слившись с клавиатурой (или мышью) в единое целое и доведя движения до полного автоматизма. Самые популярные среди экшен-игр - трехмерные (3D) шутеры («стрелялки») от первого лица, вроде Quake (id Software) или Unreal (Epic MegaGames/GT Interactive). Если вы предпочитаете прямой контакт с противником или, проще говоря, драки, к вашим услугам сериалы Mortal Kombat (Midway). К экшен-играм относятся и так называемые «платформеры» (или платформенные игры), например Oddworld: Abe's Exoddus (Oddworld Inhabitants/GT Interactive) или Heart of Darkness (Amazing Studio/Interplay), а также некоторые игры с видом от третьего лица, или, «из-за плеча», - Tomb Raider (Core Design/Eidos Interactive), MDK2 (BioWare/Interplay), Heretic II (Raven/Activision) и др.

Экшен-игры (как компьютерные, так и приставочные) являются сегодня одним из самых популярных жанров. Рамки этого жанра довольно широки и включают в себя игры с самыми разнообразными изюминками. Например, Half-Life, классический ЗD-шутер, основан на глубоком, захватывающем сюжете. (Использовано с разрешения Sierra Studios.)

Стратегии

Стратегические игры делают ставку на логическое мышление и трезвый расчет. Точное распределение времени и ресурсов здесь обычно важнее быстроты действий и вовлеченности в судьбу персонажа. Путь к победе лежит через разработку оптимальной тактики и четкое выполнение планов, причем создатели игры, как правило, оставляют управление (подвластным вам народом/армией/боевой единицей) полностью на усмотрение игрока.

Стратегические игры делятся на пошаговые (или походовые), вроде Civilization (MicroProse) и Heroes of Might and Magic (3DO), и стратегии в реальном времени (real-time strategy, RTS), которые усложняют игру тем, что пользователю приходится удерживать в голове множество одновременно происходящих событий. Примерами таких игр могут послужить StarCraft (Blizzard) и Age of Empires (Ensemble Studios/Microsoft).

Игры компании Blizzard WarCraft и WarCraft II (здесь приведена сцена из последней) наряду с Command & Conquer и родоначальником жанра Dune II (Westwood Studios) были одними из первых стратегий в реальном времени. (Использовано с разрешения Blizzard Entertainment, Inc.)

Квесты (Quests, Adventures)

Квест, игра-приключение, с первых секунд погружает игрока в мир, полный тайн и головоломок. В таких играх обычно присутствует линейный сюжет, согласно которому вы, главный герой, должны достичь некоей высшей цели, общаясь с другими персонажами и используя различные предметы. Иногда здесь могут встретиться и элементы экшен-игры. Прекрасные примеры этого жанра - Grim Fandango (LucasArts), а также Myst (Cyan/Broderbund) и The Last Express (Smoking Car/Broderbund).

Ролевые игры (RPG)

Ролевые игры, или РПГ (RPG или CRPG, Computer Role Playing Games), - это практически то же самое, что и квесты, но в них больше внимания уделяется развитию основных персонажей, росту их умений и возможностей (что отражается повышением числовых характеристик), а также диалогам и стратегии схваток, нежели решению головоломок. В играх этого жанра мы сталкиваемся с великими эпическими подвигами и огромными фантастическими мирами, полными вспомогательных персонажей, управляемых компьютером (non-player characters, NPC). К тому же, если в классических квестах сюжет задан раз и навсегда (или линеен), то в ролевых играх часто именно от игрока зависит, как повернутся события. Нередко присутствуют и дополнительные задания, не связанные напрямую с основным сюжетом.

В РПГ могут встречаться как экшен-элементы (вспомните хотя бы Diablo от Blizzard), так и черты стратегий. Старые ролевые игры, которые часто обозначают аббревиатурой MUD (от multi-user domains/dungeons, или дословно - «многопользовательские темницы»), являются текстовыми (см. об этом чуть ниже) и играть в них можно только через Интернет. Большинство из них использует в качестве интерфейса программу Telnet вместо обычных Интернет-браузеров. Впрочем, многие поклонники этого жанра давно переключились на куда как более живописные графические сетевые игры вроде Ultima Online (Origin/Electronic Arts) или Everquest (Verant/Sony Interactive).

Final Fantasy VII от Squaresoft (картинка вверху) и Baldur's Gate от Interplay. Две популярнейшие РПГ, разительно отличающиеся как по дизайну, так и по стилю игры. (© 1997/1998 Square Co., Ltd. FINAL FANTASY и SQUARESOFT - зарегистрированные торговые марки Square Co., Ltd. Все права защищены. Скриншот из Baldur's Gate приводится с разрешения компании Interplay Productions.)

Спортивные игры

В эту жанровую группу входят симуляторы различных спортивных игр - как одиночных, так и командных. Игра ведется от лица участника или тренера. При создании спортивных симуляторов одинаково важны реализм, скорость реакции и тактика.

В качестве примеров популярных спортивных игр можно назвать серию NHL (Electronic Arts), WWF: Warzone (Acclaim), PGA Championship Golf (Siena Sports).

Симуляторы

Название говорит само за себя: игра сводится к максимально реалистической имитации некоего объекта или процесса. Обычные симуляторы - это трехмерные игры от первого лица, имитирующие разные виды техники: самолеты, танки, вертолеты или подводные лодки. Примеры: симулятор боевой авиационной техники времен второй мировой войны World War If Fighters (Jane's Combat Simulations) и танковый симулятор Armored Fist (NovaLogic).

Есть также игры, имитирующие мир животных, - Wolf (Sanctuary Woods) или SimEarth (Maxis). Ну а для тех, кто страдает манией величия, созданы «симуляторы Бога» (журнал Game.EXE традиционно относит их к стратегиям. - Примеч. ред.), где игрок должен строить города, коммуникации и другие жизненно важные объекты и управлять ими. Неплохие примеры: SimCity 3000 (Maxis/Electronic Arts) и Populous 3: The Beginning (Bullfrog/Electronic Arts).

Знаменитая игра Falcon 4 (MicroProse) принадлежит к одному из наиболее популярных видов симуляторов: она моделирует воздушные сражения. При создании игр этого жанра самое главное - максимально соблюдать реализм. (Приводится с разрешения компании Hasbro Interactive.)

Головоломки (логические игры)

К головоломкам, или логическим (иногда их называют еще классическими) играм, относятся в первую очередь те, с помощью которых человечество коротало вечера до изобретения компьютера. Это карточные игры, игры со словами и настольные игры: шахматы, шашки, нарды, крестики-нолики, маджонг, разнообразные пасьянсы. В последнее время к «классике» стали также относить и простейшие компьютерные игры раннего периода, например тетрис, «Сапер» (Minesweeper) или Bust-A-Move.

Следует заметить, что некоторые из этих игр сочетают в себе элементы разных жанров (как показано на примере РПГ) или оперируют различными типами игровой перспективы.

(Кстати, недавно появился еще один игровой жанр, получивший название «музыкальный». Такие игры, как Bust a Groove (989 Studios) и Parappa the Rapper (Sony) сфокусированы на музыке, пении и танцах. Похоже, этот захватывающий вид развлечений ждет большое будущее...)

Типы игровой перспективы

Ниже приведены краткие характеристики основных типов игровой перспективы.

Игры от первого лица (first-person)

Как уже отмечалось, подобная перспектива особенно любима разработчиками экшен-игр. В большинстве ЗD-шутеров игрок видит окружающий мир глазами своего персонажа. Примеры: Duke Nukem 3D (3D Realms/GT Interactive), Turok: Dinosaur Hunter (Iguana/Acclaim).

Вид от первого лица используется и в других жанрах. Среди них симуляторы (Microsoft Combat Flight Simulator), квесты (John Saul's The Blackstone Chronicles от Legend Entertainment/Mindscape), стратегии (Battlezone от Activision и Uprising от Cyclone Studios/3DO) и ролевые игры (Lands of Lore III от Westwood Studios).

Перспективе от первого лица часто отдается предпочтение, так как она придает игре больший реализм. Вот так выглядит экран в вашей любимой игре Deer Hunter II. (Приводится с разрешения компании GT Interactive Software Corp. и Wizard Works, Inc.)

Игры от третьего лица (third-person)

Эта перспектива, известная также как «вид из-за плеча», позволяет играющему наблюдать на экране своего героя. Ее тоже довольно часто используют в современных играх, тем более что большинство из них - трехмерные. У игры «из-за плеча» есть свои достоинства. Она позволяет вам не только расширить угол зрения, но и планировать возможные ходы вашего героя, видеть, куда он в принципе может пойти, что невозможно, если вы играете «от первого лица».

Перспектива «от третьего лица» используется во многих играх - как компьютерных, так и консольных. Перечислим самые известные: сериал Tomb Raider, Mario 64, Legend of Zelda: Ocarina of Time, Crash Bandicoot: Warped, Metal Gear Solid и Resident Evil...

Игра Tomb Raider (Eidos Interactive) стала одним из первых блокбастеров, где использовалась перспектива от третьего лица и «умная» камера, следующая за героиней игры Ларой Крофт. На иллюстрации - кадр из 3-й части сериала Tomb Raider. (Приводится с разрешения компании Eidos Interactive, Inc.)

Впрочем, не думайте, что играть от первого лица можно только в экшен-игры или аркады. Эту перспективу предпочитают почти все спортивные игры; не обделяют ее вниманием и РПГ (серия Final Fantasy), а также квесты (взять хотя бы King's Quest: Mask of Eternity или Gabriel Knight III: Blood of the Sacred, Blood of the Damned).

Игры с высоты птичьего полета (top-down)

Комментарии здесь излишни. Вы видите игровое пространство сверху, как бы паря над ним. Обычно такая перспектива появляется в стратегических играх (как в походовых, так и в RTS) - она позволяет игроку свободно командовать своими войсками или мирными жителями, дает возможность быстро оценивать ситуацию. Примеры: StarCraft, Civilization, Steel Panthers и Panzer General (SSI).

К играм других жанров, построенным по этой модели, относятся, к примеру, Get Medieval - ролевая игра в стиле ретро, созданная компанией Monolith, гоночная аркада Death Rally (Remedy/Apogee/GT Interactive) старые игры серий Ultima и Zelda, а также многие классические двухмерные игры раннего периода, включая популярные аркады Centipede и Frogger.

Не забывайте и об играх, имитирующих пинбол. Большинство из них также использует вид сверху. Иллюстрация взята из пакета дополнений к Balls of Steel. (Приводится с разрешения компании 3D Realms/Apogee, Inc.)

Игры в изометрической проекции

Их часто путают с играми с высоты птичьего полета. Вы наблюдаете за; игрой не просто сверху, а как бы сверху и со стороны, что создает впечатление трехмерности происходящего. Эта перспектива используется в Diablo, Baldur's Gate (BioWare/Interplay), Little Big Adventure 2: Twinsen's Odyssey (Adeline/Activision).

В квесте Sanitarium (ASC Games) используется изометрическая проекция. Ее предпочитают многие разработчики игр, так как она позволяет видеть одновременно как игрока, так и окружающую обстановку. (Приводится с разрешения компании ASC Games, Inc.)

Игры с видом сбоку

Вид сбоку - типичная перспектива для двухмерных экшен-игр и аркад. Сейчас он становится все менее и менее популярным, хотя в конце 80-х - начале 90-х годов широко использовался в «платформерах». Примеры: серии игр Mario Brothers и Sonic the Hedgehog.

Эта перспектива применяется и в некоторых современных играх. Сейчас, на фоне изобилия проектов от первого и третьего лица, такое решение даже кажется свежим и оригинальным. Примеры: Jazz Jackrabbit 2 (Epic MegaGames), Worms 2 (Team 17/MicroProse), Claw (Takarajimasha/ Monolith), Oddworld: Abe's Exoddus и Oddworld: Abe's Oddysee (Oddworld Inhabitants/GT).

Игры Claw (Monolith, картинка вверху) и Creatures 2 (Mindscape) используют традиционную двухмерную перспективу. (Приведено с разрешения Monolith Productions, Inc. и Mindscape Entertainment, Inc. соответственно.)

Игры в текстовом режиме

Игр, которые не используют графику вообще или используют ее очень скудно, - совсем немного. Помимо классических текстовых ролевых игр начала восьмидесятых, вроде знаменитого сериала Zork от компании Infocom или «Hitchhiker's Guide to the Galaxy» Дугласа Адамса, неплохим примером текстовой игры является более современная игрушка под названием You Don't Know Jack.

Игра-викторина You Don't Know Jack (Berkeley Systems) очень популярна как в дисковом, так и в сетевом варианте. Игра выполнена в текстовом режиме с параллельным звуковым повествованием. (You Don't Know Jack - зарегистрированная торговая марка Jelly vision, Inc., скриншот использован с разрешения Jellyvision и Berkeley Systems, Inc.)

Заметим напоследок, что во многих играх вы можете менять перспективу в зависимости от того, что происходит на экране. Среди таких игр European Air War (MicroProse), Need For Speed III: Hot Pursuit (Electronic Arts), Jedi Knight (LucasArts) и Тот Clancy's Rainbow Six (Red Storm Entertainment).

Кроме того, в последнее время разработчики все чаще экспериментируют, смешивая разные жанры и используя разные перспективы.


Общие принципы создания игр: экшен-игры и стратегии

Глава 2

Общие принципы создания игр: экшен-игры и стратегии

Создание хороших игр - скорее искусство, чем наука, поэтому сложно просить кого-либо «обучить» вас этому. Представьте, что вы обращаетесь к Джону Леннону или Полу Маккартни с просьбой научить вас сочинять такие песни, как Yesterday, а к Сальвадору Дали - объяснить, как пишутся картины, подобные «Постоянству памяти». А ведь разработка компьютерных игр объединяет в себе сразу несколько традиционных форм искусства, что делает ее еще более сложной для анализа и обучения. Кроме того, игра часто является плодом коллективных усилий, а оценивает их не пассивный слушатель или зритель, а участник игры.

Поэтому нам очень повезло, что нашлись талантливые разработчики, способные познакомить нас с источниками своего вдохновения и доступно описать процесс создания игр. Конечно, у каждого из них свой подход к работе. В этой и следующей главах собран ряд советов от лучших умов этой молодой и бурно развивающейся отрасли, которые, как мы надеемся, помогут вам при создании ваших собственных игр.

Впрочем, погружаясь в эту пучину мудрости, не забывайте: ни дорогостоящее художественное оформление, ни великолепная анимация, ни настоящие актеры и лучшие музыканты не смогут спасти положение, если сама игра не будет увлекательной.

В этой главе вы познакомитесь с ведущими специалистами в области экшен-игр, аркад и стратегий.

Экшен-игры и аркады

Сигеру Миямото (Shigeru Miyamoto), Nintendo

Достопочтенный Сигеру Миямото является директором-распорядителем отдела анализа и разработки игр компании Nintendo Co. Ltd. (Киото, Япония). Он создал несколько серий популярнейших игр, включая Donkey Kong, Mario Brothers и Zelda. В списке легенд индустрии, составленном Академией интерактивных наук и искусств (Academy of Interactive Arts and Sciences) в 1998 году к выставке Electronic Entertainment Exposition (ЕЗ), имя господина Миямото занимало первую строчку.

На наш вопрос, о чем в первую очередь нужно помнить начинающим разработчикам, Сигеру Миямото ответил:

Прежде всего нужно понять, что создатель игр целиком посвящает себя своей работе. Только благодаря полной отдаче на свет появляются уникальные, действительно новаторские игры. В то же время, это часто мешает понять «простого смертного», который впервые сядет за созданную игру. Не следует забывать об этой особенности нашей профессии.

Важно также понимать, что разработчик - во многом художник. Однако ему приходится одновременно быть и инженером, поскольку этот вид творчества требует соответствующей квалификации.

Сигеру Миямото говорит, что компания Nintendo не жалеет сил и средств на то, чтобы ее игры были как можно более увлекательными. (Использовано с разрешения компании Nintendo of America, Inc.)

В главе 4 Сигеру Миямото расскажет, как он создает таких запоминающихся персонажей, как Марио и Линк.

Курт Арнлунд (Kurt Arnlund), Accolade

В качестве программиста Курт Арнлунд участвовал в создании игр Mechwarrior 2: NetMech, Heavy Gear, Interstate '76. В момент написания книги Курт работал над игрой Slave Zero в компании Accolade. Этот опыт позволил ему поделиться с нами двумя советами.

Погружение

Создайте настолько проработанную игровую среду, чтобы игрок мог полностью погрузиться в нее и забыть о том, что это всего лишь игра. Речь идет не о картах со множеством мелких деталей и тончайшей текстурой. Игровой мир должен казаться реальней и больше, чем он есть на самом деле. Щели в стенах, за которыми угадывается неведомый мир, живущий собственной жизнью. На улицах - автомобили и пешеходы, будничная суета. Если вам удастся создать иллюзию настоящей жизни, в которой игрок является лишь одним из многочисленных персонажей, погружение в игру будет еще более полным. Вот хорошие примеры подобных игр: Half-Life, Duke Nukem, Jedi Knight, Monkey Island.

Сделайте игру увлекательной

Далее Курт Арнлунд напоминает, что если игра не интересна, то ее попросту не будут замечать.

А если игра не будет привлекать внимание игроков, то последние не станут рекомендовать ее своим знакомым. Если же о ней не будут рассказывать, то и раскупаться она будет плохо. Стремитесь создать игру, которая будет у всех на устах. При малейших признаках скуки игрок просто поставит компакт-диск на полку и забудет о нем. Для меня нет большего удовольствия, чем звонить друзьям и рассказывать, что я обнаружил в очередной игре то-то и то-то: какой-нибудь необычный ход, остроумное решение. Мне особенно нравится, если кто-нибудь заводится при этом так же сильно, как и я.

Курт говорит, что хотел бы продолжить работу над творческими проектами, которые не просто используют последние достижения компьютерной технологии, но позволяют игрокам пережить нечто такое, чего в реальной жизни они никогда не испытывали.

Тоби Гард (Toby Card), Confounding Factor

Возможно, имя этого специалиста ни о чем вам не говорит, но вы наверняка наслышаны о его любимом детище - очаровательной Ларе Крофт. Именно так, раньше Тоби Гард работал в компании Core Design, где был ведущим художником и разработчиком проекта Tomb Raider, оставившего в истории компьютерных игр столь значимый след, а затем организовал собственную студию вместе со своим компаньоном Полом Дугласом (Paul Douglas), ведущим программистом той же компании.

Рассуждая об общих вопросах создания игр, Тоби отметил, что цели, которые ставит перед 'собой разработчик, должны соответствовать ресурсам, которыми он обладает.

Если вам приходится использовать ту или иную технологию, например уже имеющийся графический движок, или вы делаете игру для конкретного устройства, необходимо учитывать эти ограничения, планируя последующую работу. Вот наглядный пример: если вы делаете игру для карманного компьютера Game Boy, то все ваше мастерство упрется в двухмерное изображение, низкую скорость и небольшой объем памяти. Об играх вроде Quake здесь нечего и думать.

С другой стороны, если вы делаете игру для мощного персонального компьютера (ПК) или современной игровой консоли, поддерживающей трехмерную графику, ограничений становится значительно меньше. И Тоби предлагает свой путь разработки новой игры:

Я предпочитаю начинать именно с оценки ресурсов, потому что на самом деле абсолютно любую идею можно осуществить в какой-нибудь форме, как бы трудно вам при этом ни пришлось. Дело за малым - нужна идея. Я думаю, этого добра хватает у каждого из нас: кто-то мечтает поучаствовать в Звездных войнах, кому-то не терпится показать народу всю прелесть сноубординга, - да мало ли чем увлекаются люди! Тут надо просто пойти в бар и начать обсуждать эту идею с друзьями, а еще лучше с коллегами, с которыми вы собираетесь работать над проектом.

На этом этапе надо постоянно задаваться техническими вопросами: «Как же, черт возьми, нам это сделать?». Полезны даже такие пустяковые реплики: «А еще нужны тени. В Quake ведь они есть! Как они это делали? Может, и нам стоит попробовать?» Во время таких обсуждений надо хорошенько продумать, как пользователь будет управлять игрой. Я не сторонник громоздких интерфейсов управления, лучше свести все к минимуму кнопок, тогда систему можно будет назвать изящной. В конце концов, вы должны настолько четко представлять себе игру, чтобы быть способным проиграть ее в голове - от начала до конца. И если это вам удалось, если идея созрела настолько, что вы ее четко видите, то и все недостатки в игре вы найдете и исправите прежде, чем она будет создана!

Итак, я считаю наиболее важными три вещи: а) ясно представить себе систему управления, включая сам процесс игры; б) составить представление о том, как технологически реализовать задуманное; в) все это записать!

Секретами создания запоминающегося главного персонажа Тоби Гард поделится с нами в главе 4.

Карл Шнурр (Carl Schnurr), Red Storm Entertainment

Карл Шнурр, продюсер известнейшей игры Rainbow Six и аддона к ней Eagle Watch, охотно делится с нами соображениями по следующим вопросам.

Игровые элементы

Придумать кучу разных игровых элементов не так уж трудно. Гораздо труднее выбрать из этой кучи то, что действительно важно. К отбору элементов следует относиться очень внимательно. Как одни из них повлияют на другие? Сделают ли они игру более занимательной, оправдают ли затраты времени на разработку? Не перегрузят ли игру излишествами?

Уровни

Мне всегда нравились игры, которые не заставляют меня втискиваться в узкие рамки, а позволяют выбрать собственный путь к цели. Предусмотрите несколько способов прохождения уровня, не говорите игроку: «Ты должен действовать так и только так!» Мы руководствовались этим принципом при создании Rainbow Six, и такой подход оказался успешным.

Продюсер игры Rainbow Six Карл Шнурр получает по электронной почте письма от игроков, которые раз за разом осваивают один и тот же уровень - просто чтобы перепробовать все способы его прохождения. (© Red Storm Entertainment, Inc.)

Только профессионалы!

Никогда не экономьте на качестве. Настоящий талант окупит каждую вложенную копейку. Никто вам не мешает, конечно, пригласить для озвучивания игры своих приятелей, но такой подход обычно не приносит ожидаемых результатов: либо страдает качество, либо вы тратите слишком много времени, чтобы добиться желаемого. Не скупитесь, найдите хороших актеров и будьте готовы заплатить им по расценкам для профессионалов.

Временные и внештатные сотрудники

Набирая временных сотрудников, предъявляйте к ним те же требования, что и к штатным. Прежде чем подписать с работником договор, проведите с ним подробное собеседование, обязательно проверьте все рекомендации. Убедитесь, что вы оба ясно понимаете условия и ожидаемые результаты труда, лишь после этого подписывайте какие бы то ни было соглашения. Обязательно включите в договор пункты об условиях исправлений и переделок. Постоянно следите за работой своих сотрудников, не бойтесь увольнять нарушителей договоров.

Оценка игры

Если вам не удалось увлечь кого-либо своим замыслом в течение первых пяти минут разговора или кратким (не более страницы) описанием игры, то либо переработайте проект, либо откажитесь от него совсем. На этом этапе, пока ресурсы не привлечены и основная часть работы не выполнена, переделки обходятся дешево.

Содержание

Суть игры важнее ее обрамления. Если сама игра плоха, не помогут ни красивые видеоролики, ни умопомрачительная музыка. Люди могут купить незнакомую игру, соблазнившись эффектностью оформления, но в процессе игры внешний лоск отходит на второй план. Игру либо хвалят, если она увлекательна, либо ругают, предостерегая друзей от неудачной покупки. Прежде всего сделайте игру интересной, а уж потом придавайте ей блеск. К сожалению, многие поступают как раз наоборот.

Гейб Ньюэлл (Gabe Newell), Valve Software

Игра Half-Life, первый продукт компании Valve Software, получила всемирное признание, завоевав за короткий срок множество наград. Исполнительный директор этой компании Гейб Ньюэлл делится некоторыми секретами создания популярных игр.

Чем эта игра интересна? - вот первый вопрос, на который вы должны искать ответ. На какую игру покупателям не жалко денег и времени? Это серьезная проблема, именно здесь камень преткновения для многих игр.

Одна из причин неудач заключается в том, что одинаковые решения, например, переделка уже существующей игры с незначительными изменениями игрового процесса или оформления, хорошо сработают при одних обстоятельствах и провалятся при других. Создатели продолжения популярной игры иногда могут позволить себе ограничиться мелкой правкой уже существующего дизайна. (Стоит все же отметить, что в дальней перспективе такая «эксплуатация» известного имени ни к чему хорошему не ведет, хотя вторая часть может разойтись столь же большим тиражом, как и первая.) Некоторые разработчики пытаются заимствовать дизайн игр других компаний, как бы создавая их продолжения, но в этих случаях вероятность успеха невелика по целому ряду причин.

Создание Half-Life, по рассказам Гейба Ньюэлла, началось с определения ощущений, которые должна вызывать эта игра. «Мы знали, какие чувства будут возникать у игрока при прохождении Half-Life, и, основываясь на них, приняли ряд решений». Какой же они представляли себе эту игру и насколько точно им удалось реализовать замысел?

До начала работы над Half-Life я прочитал несколько книг Стивена Кинга, в том числе его новеллу «The Mist» («Туман»). Мне понравилась основная идея - привычный мир внезапно становится неуправляемым и необычным. Например, в бакалейной лавке вдруг появляется чудовище с щупальцами. Научная фантастика в этой книге перемешана с ужасами, а я это обожаю. Главный персонаж осознает, что помощи ждать неоткуда, что люди, которых он считал друзьями, обернулись против него, и придется выкарабкиваться самому, а истинный масштаб катастрофы долгое время неизвестен.

Вспомнив свои ощущения от игры Doom, я задумался о проекте с напряженной, динамической и пугающей атмосферой и сразу решил, что игра не должна напоминать те «стрелялки», в которых самым опасным монстром оказывается игрок, который просто прогуливается, походя расстреливая все, что движется.

Персонаж Гордон Фримен прозрачен для игрока, насколько это возможно. Никакого голоса за кадром, никаких зеркал или видов со стороны. Мы старались сделать так, чтобы игрок воспринимал происходящее только от первого лица, как в реальной жизни, в которой нет видеовставок, закадрового текста и прочих искусственных приемов. Мы также ввели в игру симпатичных и доброжелательных персонажей, с которыми потом происходили ужасные вещи. Мы хотели столкнуть игрока с неподдельной горечью утраты и заставить его почувствовать реальную опасность. В сюжете игры много неоднозначных моментов, и игрок может достраивать историю самостоятельно - так, как ему больше нравится.

Можно ли сказать о создателях игры Half-Life: Team Fortress 2, недавно выпущенной компанией Valve, что они, по выражению Гейба Ньюэлла, «эксплуатируют» известное имя? Нет, вовсе нет! Это новая чисто сетевая командная игра. При этом чертовски увлекательная.

В игре Half-Life: Team Fortress 2 компании Valve Software можно играть за любого из девяти персонажей, каждый из которых является специалистом в своем деле: командир, разведчик, врач, штурмовик, гранатометчик, снайпер, десантник, шпион или инженер. (Использовано с разрешения Sierra Studios.)

Клифф Блежински (Cliff Bleszinski), Epic Games

Клифф Блежински разрабатывает игры для компании Epic Games с 17 лет. В 1993 году Клифф создал популярную игру Jazz Jackrabbit, затем приступил к работе над проектом Unreal и продолжением Jazz Jackrabbit, которые были выпущены в 1998 году. Во время нашего с ним разговора он «шлифовал» близящуюся к завершению игру Unreal Tournament.

В искусстве создания игр Клифф Блежински считает ключевыми три следующих момента.

Один в поле не воин

Победы в футболе достигаются трудом всей команды, а отнюдь не стараниями одного нападающего, каким бы талантливым он ни был. Так и у нас: компьютерную игру не может создать один программист или разработчик. Над игрой трудится коллектив талантливых, увлеченных людей. В хорошей команде все работают слаженно, время от времени вместе отдыхая, а в целом команда напоминает хорошо отрегулированную машину.

В качестве примера Клифф привел игру Unreal, над созданием которой постоянно работала команда из 20 человек. «Современные игры значительно сложнее и требуют намного больше усилий, чем раньше».

Краеугольный камень - дизайн-проект и эскизы

Они составляют основу плана игры и служат руководством к действию для всей команды. Если на стадии разработки кто-нибудь погрузится в себя и начнет грызть ногти, укажите ему на проектные документы или эскизы. В них он должен найти ответы на многие вопросы. Даже самой хорошей команде для разработки необходимы основополагающие материалы, направляющие ее деятельность. Именно для этого и нужны дизайн-проект и эскизы.

Эскиз уровня еще необъявленной игры, готовящейся к выпуску в компании Epic Games. Клифф Блежински говорит, что разработчики часто отталкиваются именно от набросков, выполненных профессиональным художником, что гарантирует неповторимость внешнего образа игры. (Использовано с разрешения компании Epic Games, Inc.)

Способность отсеивать плохие идеи от хороших слишком часто недооценивается

Мечтать о создании «величайшей игры всех времен и народов» очень просто, но такие мечты редко удается осуществить в заданный срок. Вы уверены, что успеете придумать 40 видов оружия, на основе которых сможете составлять бесконечное множество комбинаций разнообразного вооружения? Будьте реалистом, не бойтесь отказаться от идей, которые вам не нравятся или которые не позволят уложиться в отведенные сроки. Помните: каждый месяц задержки - это месячное жалование, которое вы платите команде разработчиков вместо того, чтобы получать деньги от продажи игры.

Дэвид Перри (David Perry), Shiny Entertainment

Дэвид Перри, президент компании Shiny Entertainment, руководил созданием множества популярных игр, из которых выделим Aladdin (по известному мультфильму Диснея), серию Earthworm Jim, MDK, Messiah. Основная часть советов Дэвида изложена в главе 4, а здесь он делится с нами краткими замечаниями общего характера.

Очень важно подобрать игре девиз. Хороший девиз - это меткое описание игры несколькими словами. Например, для девиза MDK как нельзя лучше подходит характеристика снайперского режима: «Попадание противнику в глаз с расстояния в милю».

Хорошо продумайте окружающую среду (атмосферу игры). Поместите игрока в такой мир, который он будет с удовольствием исследовать. Даже если этот мир похож на реальный, позвольте игроку делать такие вещи, на которые он в действительности не способен. А если это фантастический мир, сделайте его осмысленным и логичным.

Игра должна быть достаточно сложной, чтобы ее прохождение приносило удовольствие, но не давайте игрокам заблудиться и обвинять вас в своих неудачах. Хороший разработчик всегда знает, что • чувствует пользователь, когда играет в его игру.

Личный веб-сайт Дэвида Перри находится по адресу www.dperry.com, а официальный веб-сайт компании Shiny вы найдете здесь: www.shiny.com.

Мэтью Тошлог (Matthew Toschlog), Outrage Entertainment

Мэтью Тошлог - президент компании Outrage Entertainment. Эта сильная группа разработчиков создала головокружительные игры Descent и Descent II для компании Parallax Software, а после ее разделения оформилась в собственную компанию и выпустила игру Descent III. (Оставшаяся часть Parallax Software образовала компанию Volition и приступила к работе над Descent: FreeSpace.)

По поводу общих принципов создания игр Мэтью Тошлог заметил, что главной стадией разработки является завершение игры.

Собственно, к самим играм это имеет мало отношения, но многие маленькие команды (а иногда и большие) не справляются с задачами вовремя. Если создание игры затягивается, то используемая вами технология устаревает и рынок занимают другие игры. Это может привести команду в уныние и загубить дело.

Чтобы избежать такой ситуации, Мэтью Тошлог советует придерживаться трех правил: а) с самого начала знать, что вы хотите сделать; б) отбрасывать все несущественное; в) не пытаться довести каждую мелочь до совершенства любой ценой. «Если вы не можете продать свою игру, то ее достоинства не имеют никакого значения».

Многим разработчикам будет любопытно узнать, как возникла идея игры Descent. Может быть, под воздействием Doom и других шутеров от первого лица? Мэтт Тошлог приоткрывает завесу:

Свою деятельность в области создания игр я начал с авиасимуляторов. Идея Descent родилась из желания совместить воздушные бои с движком, отвечающим за обработку замкнутого пространства. Мы познакомились с игрой Doom, и она действительно впечатлила нас, но мы никогда не рассматривали Descent лишь в качестве ее усовершенствования. Обе эти игры, Descent и Doom, объединяет использование движка для боя в замкнутом пространстве, но я не отношу их к одному жанру: в Doom надо ходить, а в Descent - летать.

Разумеется, другие игры - важный источник вдохновения. Играя, ты всегда подмечаешь достоинства и недостатки проекта, думаешь о том, как его можно улучшить... Поэтому обязательно играйте в чужие игры. Впрочем, любой вид искусства может стать источником вдохновения, будь то фильмы, книги, живопись, скульптура или комиксы.

«Задача заключается в том, чтобы соединить ваши идеи с подходящими элементами искусства и культуры таким образом, чтобы получился уникальный продукт», - говорит Мэтью Тошлог, а в качестве доказательства приводит кадр из игры Descent III. (Использовано с разрешения компании Interplay Productions.)

Далее Мэтью приводит примеры из своей практики, которые помогли ему приобрести ценный опыт, научили концентрировать силы на главном и отметать «мусор».

Мы сделали массу промахов в игре Car & Driver, но зато этот печальный опыт очень помог нам добиться успеха в работе над проектом Descent. Наверное, самой большой ошибкой Car & Driver была неверная организация работы - программисты и художники были разбросаны по всей стране. Приступая к работе над Descent, мы поняли, что все его участники обязательно должны быть рядом, и это оказалось верным решением.

Необходимо составить ясное представление о том, какую игру вы собираетесь сделать. Из-за нечеткой проработки проекта можно впустую потратить массу времени. Например, вы можете начать добавлять в игру ненужные детали или сесть за написание лишних кусков программы, которые впоследствии выбросите. Чем лучше вы спланируете свои действия, тем меньше времени уйдет на осуществление проекта. Неправильное планирование было еще одной нашей ошибкой при создании Саг & Driver - мы работали без четкого плана, многое придумывая на ходу.

И еще: не возлагайте слишком большие надежды на технологию. Это всего лишь инструмент, а не сама игра. Игра должна быть захватывающей, вот что главное, а для этого вовсе не обязательно иметь самую лучшую технологию.

Заключительный совет Мэтга: «Не бойтесь выбрасывать ненужное. Чем проще - тем лучше. Это справедливо для большинства игр. Постарайтесь убрать из игры все лишнее еще до начала ее реализации, а затем не поддавайтесь искушению добавлять в нее новые заманчивые идеи».

Алан Пэтмор (Alan Patmore), Surreal Software

Алан Пэтмор - президент компании Surreal Software и главный разработчик изданного компанией Psygnosis проекта Drakan, представляющего собой сплав экшен-игры и квеста.

В приведенном ниже интервью Алан затрагивает вопросы создания игр, поиска вдохновения, сравнивает двухмерные и трехмерные игры.

Последние четыре года процесс создания игр постоянно изменялся. Раньше разработчики сначала составляли проектную документацию и эскизы уровней, а затем на этой основе программисты и художники строили игру. После Doom подход к разработке стал иным, поскольку появились удобные средства, позволяющие оде повременно рисовать и программировать уровень. Произошел качественный скачок. Если раньше для очередной итерации сборки игры требовалось несколько дней, то теперь на это уходит всего несколько минут. Компания Surreal взяла эту модель на вооружение и создала программные средства для максимально тщательной шлифовки игр. Наши разработчики одновременно являются архитекторами игровой среды и специалистами по игровому процессу.

Приступая к созданию игры, первым делом надо записать все свои идеи. Каким бы совершенным ни был ваш инструментарий, толку от него не будет, если игра не продумана. Изложите свой замысел на бумаге во всех подробностях и лишь после этого начинайте собственно разработку. Предварительные эскизы уровней на бумаге избавят вас от множества трудностей на следующих этапах проекта.

Следующим этапом, считает Алан Пэтмор, должно быть создание демонстрационной версии - первого реального воплощения вашего замысла.

Важно отразить в демо-версии все основные особенности игры. Например, в экшн-квесте от третьего лица продумайте расположение и перемещение снимающей игру камеры, масштаб, в котором изображается мир. Разработайте систему управления и систему боя. Когда все будет готово, вы по-настоящему почувствуете, какой будет эта игра на деле, как она будет восприниматься игроком.

В процессе разработки самое главное - понять, что у вас получается хорошо, и отталкиваться от этого. Качественные игры обычно используют пять-шесть игровых механизмов, из комбинаций которых создается большая часть игры. Обязательно придерживайтесь поставленных задач и не перегружайте проект лишними вещами.

Алан советует: если вы действительно хотите стать разработчиком компьютерных игр, постарайтесь сформулировать для себя ответы на следующие вопросы.

Первый вопрос: ЛЮБИТЕ ли вы игры? Чтобы держаться на плаву в этой области деятельности, люди посвящают себя играм до такой степени, что все в их жизни превращается в игру. Свободного времени хватает лишь на еду и сон. Ничего другого они не видят. Вас устроит постоянная сверхурочная работа? Создание игр - это не та профессия, где позволительно просиживать штаны «с девяти до пяти». Когда поджимают сроки, приходится работать и по 100 часов в неделю. А как насчет критики? Вы способны воспринимать ее адекватно? Если на все эти вопросы вы ответили «да», то у вас есть шанс удержаться в игровой индустрии.

Следующий шаг: решите, что именно вы хотите и можете делать в области создания игр. Я часто получаю письма от людей, которые хотели бы у нас поработать, но не имеют ни малейшего представления об индустрии. «Немного умею программировать, хочу заниматься разработкой игр и анимацией». Не разбрасывайтесь! Самые лучшие разработчики из тех, кого я знаю, занимаются почти исключительно проектированием игр. Это их единственная задача. Самые лучшие программисты только программируют. Каждый член команды вносит свой вклад в игру. Решите, что именно для игры вы хотите делать, затем сосредоточьтесь на этом. Лучше всего начать с построения собственных уровней с помощью редактора последней версии любой из следующих игр: Quake II, Unreal, Half-Life, Drakan. Сделав готовый этап, вы покажете свою способность создавать трехмерную графику и схемы уровней, правильно размещать персонажей, конструировать гармоничную игру.

А как же вдохновение? Его-то где брать?

Нужные идеи витают в воздухе. Когда я играю в другие игры, в голову постоянно приходят мысли: «Было бы круто сделать вот эту штуковину не так, а этак. Почему они этого не сделали?» Или что-то в этом роде. Фильмы, книги, просто воображение - вот главные источники вдохновения. Я постоянно воображаю себе разные виртуальные миры, Так родилась и игра Drakan.

Каков был следующий шаг на пути разработки Drakan после создания исходного плана? Как за последние два года изменилось ваше видение этой игры?

У игры Drakan было два различных варианта. Первый - это динамичный экшен со стрельбой и полетами на драконах. В той игре совсем не было Ринн. Мы пошли в этом направлении не по собственной воле, а скорее под давлением издателя. В начале проекта, создавая демонстрационную версию, мы поняли, что такая игра не обладает необходимой глубиной. Наши издатели (компания Virgin) испытывали денежные затруднения, и отношения между нами оставляли желать лучшего. В конце концов, нам посоветовали искать нового издателя. Мы воспользовались этой возможностью, чтобы построить игру совсем иначе. Все было сделано заново - так был создан мир Drakan. Мы сразу выпустили демо-версию, показывающую новые механизмы игры, новый мир, систему боя. С этого момента мы взяли за основу разработанные нами механизмы игры. Drakan всегда был экшен-игрой, поэтому вначале мы сосредоточились на воздушных сражениях.

Когда механизм полетов был отточен достаточно хорошо, мы перешли к наземной части игры, то есть к системе боя Ринн. Это оказалось самым трудным этапом проекта. Мы решили разработать систему, ранее не применявшуюся в других играх, поэтому у нас не было модели, которую можно было взять за основу.

«Показать издателям работающую демо-версию игры Drakan было проще простого, - говорит Алан Пэтмор. - Вопросов не было. Все основные особенности игры были наглядно представлены». (Использовано с разрешения компании Psygnosis, Inc.)

Обязательно ли современные игры должны быть трехмерными? Может ли 2D-игра стать популярной? Алан считает, что игра не обязательно должна быть трехмерной, и в качестве примера приводит StarCraft и Diablo, пользовавшиеся невероятным успехом. Далее Алан Пэтмор рассуждает на эту тему подробнее:

Тем не менее теперь, когда ЗD-ускорители стали стандартным компонентом большинства компьютеров, а разработчики могут обращаться с трехмерными изображениями гораздо свободнее, нет особого смысла создавать двухмерные игры. 3D позволяет намного глубже погрузиться в игру. В конце концов, живем-то мы в трехмерном мире. Существуют проверенные и оправдавшие себя механизмы двухмерных игр, которые легко переделываются под 3D. Игра Mario 64 является прекрасным примером того, как двухмерные элементы могут великолепно работать с трехмерными изображениями.

Алан говорит, что увлекся компьютерными играми, когда ему было восемь лет. (Не здесь ли следует искать истоки игры, в которой можно оседлать дракона?..)

Дэвид Уоллс (David Walls), Hasbro Interactive

Дэвид Уоллс более двух лет является художественным руководителем компании Hasbro Interactive. Ему представилась возможность быть разработчиком и руководить созданием множества игр: Frogger, Centipede, Game of Life, Jeopardy, Wheel of Fortune, Clue, серии Tonka и других.

Касаясь общих вопросов создания игр, Дэвид советует придерживаться следующих правил.

Изучайте игры

Не просто играйте, а изучайте игры. Увлекаются играми многие, но немногие их понимают, а ведь это - ключ к созданию игр. Почему от некоторых игр невозможно оторваться, а другие вызывают лишь скуку и желание вернуть их обратно в магазин? Почему одни игры сразу вызывают восторг, а другие - раздражение? Сложность заключается в том, что общепризнанных правил создания игр не существует, поэтому многие проекты разрабатываются на чистой интуиции. Изучение игр, попытки понять причины их популярности или непривлекательности позволяют накопить опыт, столь необходимый для создания хороших игр. Но помните - опыт просто так не дается: одного лишь времяпрепровождения за экраном монитора недостаточно. Нужно постоянно анализировать все попадающие в поле вашего зрения игры, спрашивая себя, почему они сделаны именно так, а не иначе...

Важно также играть во все виды игр, не останавливаясь на одном жанре. От многих игроков мне доводилось слышать примерно такие признания: «Знаешь, я тащусь только от экшен-игр» или «Мне нравятся только крутые стратегии». Думаю, эти люди ограничивают свой кругозор, останавливаясь на чем-то одном. Осмысленное познание других жанров - чрезвычайно правильное занятие. К слову, мы в Hasbro Interactive занимаемся всеми жанрами, от игр вроде Candyland до Frogger, от Axis and Allies до Civilization. Такое обилие замечательных игр различных жанров дает нам очень многое. Даже продукты вроде Sorry! могут научить кое-чему полезному для создания больших сетевых игр.

Итак, играйте во все игры, и приставочные, и для ПК, изучайте экшен-игры и стратегии, настольные и семейные игры. После боевой GoldenEye перейдите к стратегии Civilization. Найдите в этих игрax удачные решения, подумайте, чем они друг на друга похожи. Определите приемы, которые работают в одном жанре и неприемлемы в другом, разберитесь, почему. Изучите как можно больше игр, и у вас появится необходимое чутье.

Учитесь составлять хорошие описания

Нередко начальная стадия создания игры завершается составлением дизайн-проекта. Этот документ содержит полное описание игры, включая правила, жанр, интерфейс, персонажей, сюжет и т.д. Прежде чем приступить к выполнению технической части проекта, внесите в проектную документацию как можно больше подробностей.

Подобная работа требует способности ясно излагать мысли и представить накопленные сведения в виде единого документа.

Учитесь рисовать

Многие описывают в проектной документации графическую часть игры, но лучше один раз увидеть, чем сто раз услышать. Я не призываю все бросить и срочно учиться живописи, однако разработчику необходимо уметь рисовать или хотя бы пользоваться такими программами компьютерной графики, как Visio, чтобы набросать, эскизы интерфейса, уровней, карт, персонажей, структуру игры и т.д. Хорошее описание - это великолепно, а если к нему прилагаются рисунки - еще лучше. Способность мыслить зрительными образами чрезвычайно важна.

Легче или труднее работать над играми по хорошо раскрученным темами вроде популярных настольных игр, аркад или телевизионных шоу? Каковы здесь преимущества и недостатки? Дэвид Уоллс ответил на это тан «Работать над игрой на основе широко известной идеи интересно, но сделать из этого достойную игру - задача не из легких». Далее он поясняет свою мысль:

Вначале может показаться, будто работать на основе известной идеи будет легко, но затем часто выясняется, что это так же трудно, как создавать игру с нуля. Мы в Hasbro Interactive имеем дело со многими известными играми. За основу берутся самые разные формы и жанры: игровые автоматы (Centipede и Frogger), настольные игры (Monopoly, Scrabble и Clue), телевизионные шоу (Jeopardy и Wheel of Fortune), даже обычные игрушки (Tonka). У каждого из этих проектов есть свои трудности, но главное - придерживаться общего стиля игры, устоявшихся законов, оформления и в то же время приспосабливаться к требованиям рынка компьютерных игр. Вот несколько полезных примеров.

Игра Frogger

Часто возникает соблазн ввести в игру побольше занимательных дополнений, и в результате совершается величайшая ошибка - игра оказывается слишком «раздутой». Наверное, многие помнят, что Frogger - это довольно простая, но увлекательная игра, в которой лягушонок Frogger прыгает через дорогу. Нам дали задание привести эту игру в соответствие с требованиями 90-х годов. Интересно? Да. Просто? Нет. Вначале Frogger хотели сделать похожей на игру Mario - лягушонок, которого можно заставить прыгать в любом направлении. Кто захочет покупать старую игру, в которой не произошло никаких изменений? Идею нужно было как-то обновить...

Эти рассуждения выглядят очень разумными, но на практике они оказались неверными. У нас никак не возникало ощущения отчаянной спешки лягушонка. Ладно, решили мы, разрешим ему прыгать по диагонали. Звучало неплохо - отдел сбыта даже мог взять на вооружение лозунг: «Frogger! Теперь он прыгает по диагонали!». Это можно было выдать за обновление. Но сама игра от прыжков по диагонали не выигрывала. Тогда мы приняли иное решение: оставить все как есть, не менять суть: только вперед, назад, влево и вправо, а также сохранить сетку в оформлении уровней. И это было правильно - Frogger остался самим собой!

Конечно, нас мучил важный вопрос: «Захотят ли люди играть в игру с таким простым управлением?» После продажи миллионного экземпляра ответ стал очевиден: «ДА!» Простые и увлекательные игры все еще нужны людям!

Создавая игру Frogger, мы многому научились. Первый урок, который мы извлекли: иногда лучше преодолеть соблазн усложнить игру, пытаясь подогнать ее под новые стандарты, и придерживаться добрых старых традиций. Второй урок: по мере того как у людей становится все больше компьютеров, идет постоянный приток новых игроков, которым нужны простые, легко осваиваемые, но интересные игры.

Дэвид Уоллс и его коллеги из компании Hasbro Interactive решили не менять формулу успеха самой первой версии аркады Frogger, увидевшей свет 15 лет назад. (Использовано с разрешения компании Hasbro Interactive.)

Игры Jeopardy и Wheel of Fortune

Телевизионные игры и шоу имеют свои особенности. Часто первое побуждение - просто воссоздать шоу на компьютере: ввести образы соперников, управляемые компьютером, вставить в игру множество видеороликов и т.п., одним словом - сделать настоящее интерактивное телешоу. Когда мы приступали к созданию игр Jeopardy и Wheel of Fortune, я уверен, мы бы пошли именно таким путем, если бы не изучили две уже имевшихся игры: прежнюю компьютерную версию Jeopardy и You Don't Know Jack.

Мы принялись внимательно играть. Старая Jeopardy оказалась попыткой скопировать характерные для телевизионного шоу черты. Однако игра от третьего лица за какого-то нарисованного персонажа не дает ощутить причастность к происходящему. Это просто не интересно. И наоборот, игра You Don't Know Jack ориентирована на игрока. Играя от первого лица, вы участвуете в ней, а не наблюдаете ее со стороны. Вы сами играете. Здесь все обращено к вам, игроку. Мы быстро пришли к выводу, что именно так следует подходить к созданию новой версии Jeopardy и Wheel of Fortune.

Но разве людям не нужно дать ощущение участия в телевизионном шоу? Неужели можно убрать из игры реакцию зрительного зала и девушку, переворачивающую буквы? Оказывается, не только можно, но и нужно. Люди за компьютером хотят играть, а не смотреть телевизор. Игры Jeopardy и Wheel of Fortune хороши сами по себе, от них можно получить массу удовольствия без всякого шоу. Поэтому мы решили действовать в таком направлении: это будут не телевизионные шоу, а компьютерные игры. Подход тут должен быть таким же, как в любом другом компьютерном проекте: игроки сидят не в студии, а вокруг компьютера. Избегайте всего, что может испортить игру.

Такой подход освободил нас от множества ограничений. Благодаря широким возможностям самих игр, мы смогли отказаться от бесконечных видеоматериалов, изображения зрительного зала и зрителей, от свистков и звонков, даже от девушки, переворачивающей буквы (она хорошо смотрится на телеэкране, но для компьютерной игры ее неспешные движения просто убийственны). Все это позволило нам создать весьма неплохие игры.

Вывод: создавая игру, обязательно взгляните на нее с точки зрения игрока. Откажитесь от всего, что может снизить игровой азарт. Игра должна быть ориентирована на игрока.

В заключение Дэвид заметил, что работа над старыми играми очень трудна, поскольку нелегко добиться нужного баланса традиций, игрового момента и оформления, но вместе с тем она очень интересна и поучительна. «Я ничуть не удивляюсь, - сказал он, - что все эти старые игры пользуются успехом. Ведь они великолепны!»

Затем мы задали Дэвиду Уоллсу вопрос о том, как он и его коллеги в компании Hasbro Interactive придумывают новые игры. Результат ли это обсуждения на собрании команды или плод вдохновения отдельного сотрудника? «И то и другое, - был ответ, - вдохновение нужно черпать из многих источников». Каковы же эти источники?

Другие игры. Займитесь играми того жанра, который вас интересует в данный момент, просто играйте и настраивайтесь на нужное состояние. Не надо сразу приступать к созданию игры, вначале разузнайте все об уже выпущенных играх. Постарайтесь пойти дальше, чем их создатели. Это непросто. Иногда помогает какая-нибудь сумасшедшая мысль. Например, вы говорите себе: «Хочу сделать «стрелялку» с видом от первого лица, но чтобы никакого оружия!» Слабо?

Советы коллег. Соберите вместе несколько человек и устройте мозговой штурм. Пусть участвуют все: продюсеры, программисты, коммерческий отдел, администраторы и все, у кого могут возникнуть идеи. В начале такого собрания не забудьте объявить, что это именно мозговой штурм. Любая идея хороша, но серьезные решения сразу приниматься не будут. Это всего лишь способ собрать как можно больше идей. Такие обсуждения очень полезны, но не стоит проектировать игру на подобной «демократической» основе.

Наконец, длительное размышление. Обычно хорошие идеи являются плодом упорных и длительных раздумий. Полезно запереться в комнате с блокнотом и карандашом и просто раскинуть мозгами. Представьте себе игру с самого начала - с названия и заставки. Продумайте персонажей, механизмы игры. Попробуйте представить себе игру как единое целое. А затем - бросьте себе вызов! Что-то получилось хорошо? Попытайтесь сделать еще лучше. Что-то получилось великолепно? Сделайте это потрясающим.

Что Дэвид думает о двухмерной и трехмерной графике? Вот его ответ: «Имеет смысл использовать трехмерную графику, если она действительно необходима данной игре. Может ли двухмерная игра стать популярной в конце 20 века? Да, если это будет хорошая игра».

Тогда почему люди предпочитают 3D-игры? Дэвид Уоллс считает, что все зависит от жанра, а также от материальных возможностей игроков. «Экшен-игры сейчас делаются трехмерными. Для стратегий трехмерность необязательна. Игроки, которые заявляют, что им трехмерность не нужна, утверждают так в основном по одной простой причине: они играют на устаревших компьютерах, которые просто не поддерживают 3D-игры».

Наконец, что можно сказать о сетевых играх? Обязана ли в наши дни хорошая игра быть сетевой? И вновь, как говорит Дэвид, все зависит от самой игры:

Аудитория у одиночных игр будет всегда. Если бы в игре Half-Life не было сетевых режимов, наверное, она все равно имела бы успех, поскольку ее сюжет - приключенческий боевик. Здесь возможность играть с другими игроками по сети - приятное, но необязательное дополнение. Но есть игры, которые существуют только в многопользовательском варианте, например Quake III: Arena. Тут все основано на состязании по сети.

Дэвид Уоллс собирается продолжить создание высококачественных игр для компании Hasbro Interactive и надеется пополнить ассортимент игр оригинальными новинками.

Джей Уилсон (Jay Wilson), Monolith

Отвечая на вопрос: «Как делать хорошие игры?», Джей Уилсон из компании Monolith охотно дает советы начинающим разработчикам. Вот они, разложенные по полочкам:

1. Играйте в разные игры, понимайте их и любите. «Это кажется очевидным, но сказать об этом все-таки надо, - начинает Джей. - У вас должно хватить энтузиазма преуспеть в этом немного больше других. Конкуренция в индустрии игр очень велика, поэтому без энтузиазма тут не обойтись».

2. Любую хорошую вещь можно улучшить. Джей Уилсон проводит аналогию с фильмами, которые делятся на такие крупные жанры как боевик, драма, комедия, но в пределах каждого из этих жанров возможны различные способы реализации своей задумки (например клоунада, черная комедия, иронический рассказ и т.д.). Эта индустрия еще молода, поэтому каждый стремится изобрести велосипед. Развитие идет эволюционно, а не революционно. Создавая игру Blood 2, мы привнесли в экшен элементы ролевой игры. А вот в игре Shogo: Mobile Armor Division добавили к этому жанру элемент «аниме» - анимации в японском стиле.

3. Еще более важный вопрос: что из задуманного можно осуществить? Как и другие разработчики, высказавшиеся в этой главе, Джей считает ключевым моментом оценку своих реальных возможностей. Если вы хотите создать сетевую ролевую игру, тщательно взвесьте - сможете ли вы сделать ее конкурентоспособной? Если воплотить идею невозможно, выбросите ее в корзину - или измените ее.

4. И последнее: «Главное - организация. Это очень и очень важно, - настаивает Джей Уилсон. - Я считаю верной поговорку «лучше меньше, да лучше». Если вы заранее точно знаете, что именно собираетесь сделать, то все пойдет хорошо».

Джон Зук (Jon Zuk), Raven Software

Будучи ведущим разработчиком Heretic II и других игр, Джон считает себя вправе давать советы начинающим бойцам индустрии. Вот три его кратких рекомендации:

Главное, о чем нужно помнить, создавая игру, - это то, что она должна быть увлекательной. Даже если идея игры очень хороша, если вы внесете в нее множество красивых мелочей, игра никогда не станет популярной, если будет неинтересной. На каждом шагу мы внимательно проверяли, все ли сделано для того, чтобы Heretic IIполучился увлекательным. Мы уделяли много времени проработке персонажей, пробовали различные сочетания клавиш управления, долго искали наилучшее расположение камеры и т.д. Как команда разработчиков, мы понимали, что в конечном итоге главной причиной успеха игры является ее увлекательность, а не «приманка». «Приманка» - это лишь рекламный трюк для тех, кто видит игру впервые. Скорее всего, люди не захотят тратить деньги и время на игру «Капуста-2000: Симулятор дачного участка», потому что сразу ясно: эта игра вряд ли будет захватывающей.

Как вы заметили, я употребил слово «приманка». Наверное, именно «приманка» является вторым после интересности фактором. Что заставит покупателя обратить внимание именно на вашу игру среди прочих 4000 коробок? Задумайтесь, - и вы увидите, что игровых идей на рынке не так уж много. Как выделиться на фоне 20 шутеров типа Quake, 50 гонок, 100 стратегий в реальном времени? Для этого-то и нужна «приманка». Игра обязательно должна иметь «приманку», а также стиль, который будущие игроки могли бы с чем-нибудь сравнить. Возьмем для примера наш Heretic II. Его «приманка» - шутер с видом «из-за плеча». Это не Tomb Raider и не Quake, хотя по стилю игра ближе к знакомому всем и каждому Quake.

Если решена задача, как сделать игру увлекательной (или вам кажется, что она решена), если «приманка» для продажи игры найдена, пора подумать о команде. Совместимость людей очень важна. В нашей компании все друг с другом ладят. Может быть, не у всех сложились приятельские отношения, но все без исключения - профессионалы. Я слышал и читал о других компаниях, в которых складывалась ужасная атмосфера. Постоянные склоки, руководители орут на подчиненных, никто не хочет работать. Из-за этого графики работ постоянно срываются, и в результате страдает сама игра. Если вы хотите набрать команду, способную сделать игру вашей мечты, подберите таких людей, с которыми вы сами сможете прожить в мире и согласии не менее года.

Стратегические игры

Сид Мейер (Sid Meier), Firaxis Games

Неудивительно, что Сид Мейер является одним из самых опытных и уважаемых разработчиков. В этой индустрии он был первопроходцем, создал ряд потрясающих игр, сразу же ставших классикой, - вспомните, хотя бы симулятор воздушного боя F-15 Strike Eagle, за которым последовали знаменитые Pirates! и Railroad Tycoon. И конечно же, нельзя не упомянуть Civilization, справедливо называемую лучшей игрой всех времен и народов. Мы будем цитировать Сида Мейера во многих главах этой книги, а здесь он дает несколько кратких советов на тему вдохновения.

«Найдите нечто такое, что вдохновит вас, - начинает Сид. - Отсутствие вдохновения отрицательно скажется на дальнейшей работе». Он также напоминает, что проект может отнять у вас около двух лет, поэтому нужно спросить себя, готовы ли вы выполнять эту работу изо дня в день на протяжении столь длительного времени. Если рассматривать вопрос с практической стороны, поясняет Сид Мейер, «вряд ли кто-нибудь из вас пожелает иметь дело с полностью исчерпавшим себя жанром».

Сид считает, что многое зависит от энтузиазма.

Что вызывает у вас энтузиазм, что вы умеете хорошо делать? Если вам по душе ролевые игры, делайте именно их - вовсе не обязательно заниматься 3D-шутерами, потому что они сейчас в моде. Постарайтесь найти что-нибудь новое, свежее, ведь издатели тоже не хотят отставать от времени, поэтому в большинстве случаев относятся к новым идеям хорошо. Но помните, из каждых двадцати человек, приходящих в издательство, лишь у двоих есть идеи, достойные серьезного рассмотрения.

Недавно Сид Мейер выпустил игры Gettysburg! и Alpha Centauri.

Не пропустите его ценные замечания об интерфейсе пользователя (глава 12), тестировании игр (глава 15) и о том, как влиться в игровую индустрию (глава 20)!

Питер Молиньё (Peter Molyneux), Lionhead Studios

Это имя знает каждый заядлый игрок благодаря цепочке успешных игр маэстро, выпущенных компанией Bullfrog Productions. В этой студии, расположенной в Великобритании, Питер работал ведущим дизайнером, программистом и продюсером следующих проектов: Populous (1989), Powermonger (1990), Populous 2 (1991), Syndicate (1993), Theme Park и Magic Carpet (1994), Dungeon Keeper (1997). В настоящее время он всецело поглощен идеей создания игры Black & White, своего первого проекта в компании Lionhead Studios и, как он утверждает, «лучшего из когда-либо существовавших».

В ответ на просьбу посоветовать что-нибудь начинающим разработчикам Питер Молиньё ответил следующее:

Это совсем не так трудно, как некоторые себе представляют. Вначале я бы посоветовал создателям игр черпать вдохновение из всех возможных источников - из фильмов, книг, музыки и просто из жизни. Например, мне захотелось создать игру Dungeon Keeper после просмотра кинокартин «Криминальное чтиво» и «Интервью с вампиром» с отрицательными главными героями. После появления вдохновения и рождения идеи замысел вызревает в моей голове не менее полугода. Лично я стараюсь подольше ничего не записывать, иначе сырая идея останавливается в развитии. Предпочитаю прокручивать ее в голове, пока она полностью не созреет. Когда это, наконец, происходит, я записываю замысел на двух страницах, не более, просто перечисляя интересные моменты будущей игры. (Если для записи идеи требуется более двух страниц, то она слишком громоздка.) Лишь после этого я могу рассказать о будущей игре друзьям и коллегам. И если ее идея кажется им интересной, значит, я иду верной дорогой. В заключение хочу сказать, что мои идеи всегда продолжают совершенствоваться в процессе разработки игры.

Советы Питера Молиньё о том, как влиться в индустрию игр, изложены в главе 20.

Рик Гудман (Rick Goodman), Stainless Steel Studios

В1995 году Рик Гудман основал вместе с братом Тони компанию Ensemble Studios, где был ведущим разработчиком чрезвычайно популярной игры Age of Empires, выпущенной корпорацией Microsoft. Затем он ушел оттуда и учредил другую компанию, Stainless Steel Studios, занимающуюся сейчас созданием эпической стратегии в реальном времени Empire Earth.

Рик предлагает нам свои «Десять заповедей создания стратегических игр в реальном времени». Внемлите же:

У здоровых растений сильные корни

Изучайте первоисточники, будь то комиксы, научная фантастика, настольные игры, головоломки, игрушечные солдатики, шахматы! «Dungeons & Dragons» или еще что-нибудь в этом роде.

Бумага все стерпит

Научитесь отделять хорошие идеи от плохих, ведь слишком многим авторы приходят со словами «Вот отличная идея, как сделать крутую стратегию!».

Рик говорит, что написать хороший проектный документ может каждый, но для успеха важны еще четыре момента. Прокрутите игру в голове, смоделируйте все в электронной таблице, нарисуйте эскизы интерфейсов и наберите «ударную команду» тестеров. Сам Рик с помощью Интернета набрал 12 поклонников Age of Empires и время от времени спрашивает их мнение по поводу его новой стратегии Empire Earth, отсеивая негодные игровые идеи. Рик Гудман призывает разработчиков прислушиваться к чужим советам, помня, что «со стороны всегда виднее».

Тот, кто движется по наезженной колее, не оставляет следов

Придумать что-то новое или копировать старое? Рик напоминает коллегам, что все любят критиковать клоны, но при этом с упорством религиозных фанатиков продолжают заниматься клонированием, выпуская все новые и новые копии игр. Он вспоминает выражение «непрерывность новаторства», которое придумал Сид Мейер, чтобы ему не мешали заниматься тем, чем он хотел. «Главное - соблюсти баланс. Внести кое-что новое и вместе с тем оставить доброе старое, чтобы игрок почувствовал уют, сразу понял правила, не лазил по описанию, прорубаясь сквозь дебри инструкций».

В заключение Рик советует «улучшать хорошее, устранять плохое и не трогать то, что не требует изменений».

Гонись я за реальностью, стал бы я включать компьютер?

Суть этой заповеди очень проста: увлекательность важнее реальности Рик ссылается на результаты опроса, проведенного журналом «Compute Gaming World», которые показали, что фантастические стратегически игры зачастую оказываются популярнее игр, основанных на реальных исторических событиях. Он напоминает разработчикам, что хотя в основе стратегической игры Age of Empires лежат исторические реалии, кое-что является чистой выдумкой: способность жрецов обращать вражеские юниты в «свою веру», самодвижущиеся катапульты, нападения морских отрядов на сухопутные и т.д.

Реализм игры и ее увлекательность - что важнее? Рик Гудман часто посмеивается над своей игрой Age of Empires, спрашивая: «А где женщины ? Почему никто ничего не ест? Всегда ли солдаты сражаются насмерть?» (Приводится с разрешения компании Ensemble Studios, Inc.)

Если бы я присутствовал при сотворении мира, дал бы пару дельных советов

Рик Гудман советует оценить свои возможности, взглянуть на свои пристрастия, сильные стороны, воспользоваться уже полученными навыками. Например, близкое знакомство с настольными играми очень помогло Рику в развитии замысла Age of Empires.

Близко видать, да далеко шагать

Игры обычно создаются последовательно сверху вниз: замысел игры - вершина пирамиды, игровые идеи и функции - ее середина, а у подножия - механизмы игры. Рик поясняет:

Метод заключается в следующем. На вершине пирамиды рождается замысел игры («А не сделать ли игру, действие которой будет происходить на необитаемом острове?»), в середине придумываются функции игры («А вот что мы будем делать на этом острове»), а у подножия выполняется самая существенная часть процесса - воплощение всех идей в игру.

Рик считает, что многие разработчики слишком задерживаются на двух верхних уровнях этой пирамиды и не уделяют должного внимания игровым механизмам. «Нижний уровень - самый трудный, разработка подробностей - это ключ ко всей игре», - говорит Рик Гудман. Он также полагает, что проектная документация зачастую тоже ограничивается двумя верхними уровнями, в то время как акцент следует делать не на самих идеях, а на их практической реализации.

Думайте о будущем, вы проведете в нем всю оставшуюся жизнь

Рик уверен, что для успешного развития стратегий в реальном времени необходимо постоянно обновлять механизмы игры. В жанре 3D-экшен в основном идет развитие графики, а сам процесс игры, за немногими исключениями, не эволюционирует. Что касается стратегий в реальное времени, тут попросту следует попробовать угадать перспективные направления и исходя из этого совершенствовать жанр.

Деревья, которые медленно растут, приносят самые вкусные плоды

«Время - ваш друг, - говорит Рик Гудман. - Относитесь к графику проекта внимательно». Работа над Age of Empires длилась почти три года, причем четверть этого времени ушло на то, чтобы 500 раз пройти игру при тестировании.

«Не забывайте - хорошую игру может погубить только выдающаяся». Будьте реалистами с самого начала проекта и помните, что многие замечательные стратегии в реальном времени, например StarCraft и Age of Empires, потребовали больше времени на разработку и завершение, чем обычно, но посмотрите, какой успех!..

Сообщите миру о том, каким вы его видите

При разработке игры очень важно наладить обмен информацией не только между разработчиком и его командой, но также с издателем, публикой, дистрибьюторами, журналистами и тестерами.

И не кладите жирные пончики на коврик для мыши

«...Много истин нажито нелегким опытом», - говорит Рик. Среди них правило «качество важнее сроков», а также тот факт, что принцип «мы им не скажем, может, они и не заметят» ни за что не сработает. Мир мало изменился с тех пор, когда вы таскали варенье из бабушкиного буфета!

Более подробные сведения об игре Empire Earth и команде ее создателей Stainless Steel Studios вы найдете на веб-сайте www.stainlesssteelstudios.com.

Брюс Шелли (Bruce С. Shelley), Ensemble Studios

Ведущий разработчик Ensemble Studios Брюс Шелли был одним из тех, кто помог компании добиться громкого успеха с серией игр Age of Empires. До перехода в Ensemble Studios он участвовал в создании многих игр компании MicroProse, в том числе Railroad Tycoon, Covert Action, а также единственной и неповторимой Civilization (совместно с Сидом Мейером).

Прежде чем выслушать его советы по созданию игр, мы попросили Брюса рассказать о том, как велись исследования для игр на исторической основе вроде Age of Empires I и II. (Доводилось ли вам когда-нибудь видеть в игре библиографические ссылки?) Наверное, это стоило немало денег? На что Брюс Шелли невозмутимо ответил:

При проектировании большинства игр не следует слишком углубляться в подробности. Не пытайтесь поразить игрока глубиной своих познаний. Ведь удовольствие от игры должен получить именно игрок, а не ее проектировщики или разработчики. Информационная насыщенность игры должна быть на уровне, доступном восприятию среднего человека. Я обычно начинаю свои исследования в детском отделе местной библиотеки. Это дает хорошие результаты, потому что детские книги содержат большое количество иллюстраций, а компьютерные игры очень интенсивно используют графику. Таким образом, одновременно с изучением темы можно подобрать для игры подходящие графические подсказки. Степень исторической подробности в детских книгах очень хорошо подходит для компьютерных игр, делая их наиболее раскупаемыми. А вот если ваша цель - очень точный симулятор для посвященных, тогда следует обратиться к более подробным источникам. В конце концов, чтобы лучше понять описываемые события и эпоху, я читаю далеко не только детские книжки.

Не стоит тратить большие деньги на исследования. В MicroProse бюджет на книги и другие источники информации был сильно ограничен, так что я выучился работать, используя только то, что можно было найти в библиотеке. Ensemble Studios гораздо охотнее покупала книги и видеокассеты, которые помогали в работе нашим дизайнерам и аниматорам. Так, для Age of Empires II собранные материалы едва поместились на двух книжных полках.

Брюс Шелли уверен, что избыток информации в игре опасен, поскольку у большинства людей уже сложилось свое мнение о различных исторических событиях на основе кино и видеофильмов. Такая публика быстро разочаруется в игре, если вы слишком далеко отойдете в ней от общепринятой точки зрения. Далее он привел пример, чтобы проиллюстрировать это утверждение.

Если сюжет игры сильно отличается от ожидаемого, пользователи приходят в замешательство. Всегда старайтесь сделать игру максимально занимательной, пусть даже жертвуя воссозданием реальных исторических событий. Этот прием постоянно используется в индустрии развлечений, особенно в кинофильмах и телепрограммах.

В качестве примера можно привести катапульты из Age of Empires: они способны передвигаться и имеют большую площадь поражения. Насколько я знаю, в те давние времена оружия с подобными возможностями еще не было, но в нашей игре оно прижилось и стало неотъемлемой ее частью. Кроме того, в Age of Empires мы настроили значения дальности стрельбы, силы атаки и скорости движения для различных боевых единиц таким образом, чтобы между ними возникали интересные взаимодействия. Для достижения баланса мы использовали не реальные характеристики этих юнитов, а данные, полученные от игроков, тестировавших бета-версию. В «облегченных» летных симуляторах время полета от базы до места воздушного боя и назад обычно сокращается, поскольку полное его воспроизведение было бы утомительно для играющего. Кроме того, игрокам обычно дается гораздо больше горючего и боеприпасов, чем это возможно в реальном мире. Все это делается для усиления развлекательной стороны игры, которой в данном случае является сам воздушный бой, а не многочасовые перелеты к месту его проведения.

Я обратил внимание Брюса на то, что, приступая к созданию новой игры, начинающий разработчик может испытывать страх перед уже существующими на рынке «монстрами». Есть ли у него какой-нибудь совет как добиться успеха? В ответ Брюс Шелли предложил следующий набор основных рекомендаций создателям игр.

Проектируйте игры так, чтобы в них хотелось играть самому, в надежде на то, что ваши вкусы совпадают со вкусами миллионов других людей.

Постарайтесь сделать игру привлекательной как для искушенных, так и для начинающих игроков. Первые создадут ей репутацию, но основной объем продаж приходится все же на долю казуалов, случайных покупателей. Учтите, что чрезмерный натурализм, обилие крови и сквернословия в игре могут значительно ослабить интерес к ней со стороны случайных покупателей, а значит, ограничат возможные объемы продаж.

Предложите играющему интересные нестандартные решения. Это основа любой игры.

Проанализируйте сильные стороны игр-конкурентов и спланируйте свою игру так, чтобы не уступать им в этих областях. Определите их слабые стороны и уделите в своем проекте особое внимание этим моментам, сделав их лучше, чем у конкурентов. Например, мы обнаружили, что до Age of Empires ни в одной из RTS не было ни честно играющего искусственного интеллекта, ни случайно создаваемых карт, ни настраиваемых условий победы. Включив эти возможности в нашу игру, мы сделали Age of Empires непохожей на другие стратегии в реальном времени, что помогло нам добиться той особой атмосферы, которая в итоге и принесла успех.

Не вводите в игру случайные события, неблагоприятно влияющие на игрока. Такие события едва ли вызовут дополнительный интерес пользователя, скорее он будет разочарован.

Создавая игру, следуйте двум основным целям: старайтесь доставить игроку максимум удовольствия от игры и минимум разочарований от непредсказуемых событий, плохого интерфейса и ошибок в работе программы.

И под конец Брюс Шелли произнес одну хорошо известную истину, которую особо подчеркнул.

Любая новая игра (возможно, в отношении продолжения известной серии это не так) должна увлечь игрока в первые 15 минут. В отличие от многих своих конкурентов, Age of Empires обладала этим качеством.

Что можно порекомендовать начинающему разработчику в связи с настройкой баланса боевых юнитов для стратегий в реальном времени?

На самом деле жестко оговоренных правил не существует. Вы просто должны положиться на свой инстинкт и на тысячи часов тестирования игры. Внесите исправления в те места, на которые будут поступать жалобы, и оставьте все как есть там, где их не будет. Если люди считают данную боевую единицу бесполезной, улучшите ее характеристики. Если все стремятся использовать только один вид юнитов, уменьшите его эффективность. Мы используем этот эволюционный процесс, так как он обеспечивает максимальные возможности для создания по-настоящему интересной игры. Существенным минусом этого метода является большая сложность прогноза. До тех пор пока мы не приблизимся к окончанию проекта, нельзя определить точное время его завершения. Для большинства издателей такие условия неприемлемы, поскольку нарушаются их маркетинговые, рекламные, бюджетные и прочие планы.

Для Age of Empires II была написана небольшая программа, позволяющая оперативно моделировать битвы между различными типами боевых единиц. Сражения велись с огромной скоростью, и за короткий промежуток времени мы получили практические сведения о том, как эти юниты воюют друг против друга. Рассчитать результаты схватки обычным способом весьма трудно: нередко десять единиц А, каждая из которых в одиночку всегда справляется с боевой единицей Б, всегда безнадежно проигрывают бой десяти Б.

Создателям стратегических игр, желающим узнать больше о настройке характеристик боевых единиц, будет полезно прочитать дополнительные советы в главе 7.

Брайан Рейнольде (Brian Reynolds), Firaxis Games

«У меня есть несколько общих соображений...» - начинает свой рассказ Брайан Рейнольде, на момент написания книги вице-президент по разработке программного обеспечения компании Firaxis Games.

Быть профессиональным «игроделом» (как и профессионалом в любой другой области) не так трудно, как кажется на первый взгляд.

Все зависит от масштаба и от того, сколько времени вы посвящаете этому занятию. Если вы в хороших отношениях с компьютером, то, возможно, вполне способны написать простую, но увлекательную игрушку за выходные или за неделю. Теперь представьте, что вы нанимаете еще 10 человек и тратите дополнительный год или два на шлифовку своего творения. Вот, собственно, в чем и состоит различие между работой только ради удовольствия и работой ради удовольствия и прибыли одновременно. Все используемые профессиональными разработчиками приемы годятся и для игр, написанных в домашних условиях. Работа дома даже имеет много преимуществ - неспроста среди профессиональных создателей игр наибольшего успеха обычно достигает тот, кто одновременно является и разработчиком, и программистом. Если вам в голову пришла хорошая идея, никто лучше вас не сможет воплотить ее в жизнь.

Второй совет Брайана Рейнольдса: не затягивайте обдумывание, сразу приступайте к работе и быстро создавайте действующий прототип игры.

Не пытайтесь формализовать все на бумаге или рисовать детальные макеты интерфейса игры в надежде, что потом у вас будет время вернуться назад и дописать к ним нужные программы. Постарайтесь быстро собрать прототип будущей игры на самых простых элементах, чтобы с первых шагов разработки иметь возможность играть в нее и проверять свои идеи на практике. Определите, что игре увлекает, выделите ее сильные и слабые стороны. После этого вернитесь к программированию: развивайте сильные стороны игры и уберите из нее то, что оказалось неудачным (иногда даже приходится начинать все заново, опираясь на принципиально новые идеи). Обычно в Firaxis мы создаем работающий прототип за первые несколько недель проекта, а затем до самого его окончания длится непрерывный цикл совершенствования: играем - исправляем - играем - исправляем - снова играем - снова исправляем. Мы называем это «опытным производством», а также «итеративным проектированием», и такой подход на самом деле дает хорошие результаты. Нет лучшего способа сделать игру действительно, увлекательной, чем поиграть в нее самому.

Свой третий и последний совет Брайан посвятил развлекательной стороне игр, задачам, которые они ставят перед игроком, а также влиянию игрока на игровой процесс.

Одно из определений, которое можно дать компьютерной игре, - это «множество интересных решений». Компьютерные игры увлекательны, потому что они позволяют нам влиять на развитие сюжета, а не просто выступать в роли пассивного зрителя. Поэтому, создавая игру, постарайтесь предусмотреть в ней как можно больше вариантов поведения игрока. Я видел немало игр, некоторые были даже довольно популярны, где была допущена одна и та же ошибка: слишком детальная «система игры» не оставляла на долю игрока ни одного важного решения. Если большая часть времени уходит на изощренные расчеты и имитацию сложных процессов, а у игрока нет возможности контролировать ход событий, то, как у нас говорят, «основное удовольствие от игры получает компьютер». Это портит игру: лишаясь возможности выбора решения, игроки теряют к ней интерес. Сходная ситуация складывается в играх с линейным сюжетом, когда успешное прохождение игры предусматривает строго определенную последовательность действий. В таких случаях «все удовольствие от игры уже получил разработчик». Эти игры также имеют мало шансов на успех, поскольку, если заранее известно, что ответ «А» всегда правильный, выбор становится механическим, а игра - скучной.

Вот почему мы утверждаем, что игра должна предоставлять множество интересных решений. Если игроку дается на выбор три возможных варианта развития событий, каждый из них должен быть «проходимым», причем нужно предусмотреть возможность выиграть игру (хотя бы иногда), используя каждый из этих вариантов. Например, если герой в некоторой ситуации может сражаться, откупиться или убежать, то ни один из вариантов не должен полностью исключать возможность победы. Как правило, лучшие из игр предоставляют игроку выбор. Сначала игрок выбирает стратегию, а затем решает, как ему получить необходимый результат. А если игру можно выиграть, используя не одну, а несколько стратегий, люди захотят сыграть несколько раз.

Крис Тэйлор (Chris Taylor), Gas Powered Games

К тому моменту, когда Крис Тэйлор основал свою компанию Gas Powered Games, он проработал в игровой индустрии более 11 лет, большую часть которых он создавал игры в компании Electronic Arts. Четыре года назад он объединился с Роном Гилбертом (Ron Gilbert), чтобы начать работу над игрой Total Annihilation в компании Cavedog Entertainment.

Несмотря на отпуск, который Крис проводит в своей родной провинции Британская Колумбия (Канада), он с большой охотой согласился поделиться своими знаниями о создании игр, вдохновении и о том, как научиться реагировать на требования рынка. Он начал свой рассказ следующими словами:

Во-первых, у вас должно быть общее видение создаваемой игры. Действительно, очень сложно что-либо сделать, если у вас нет ничего кроме задумки создать замечательную игру. Во-вторых, важным моментом является реализация идеи, и вам необходимо подобрать наилучшую команду, которая будет создавать игру. В-третьих, работая над проектом, необходимо следовать довольно длинному своду правил. Вот выдержки из него: не планируйте все заранее, работайте в команде, постоянно экспериментируйте, внимательно следите за рынком, не бойтесь нарушать стереотипы, смело копируйте .успешные приемы своих конкурентов, без тени сомнения отбрасывайте все, что портит вашу игру.

Говоря о вдохновении, Крис Тэйлор заметил, что оно часто исходит от игрока, сидящего внутри каждого разработчика.

Что вам нравится? Что может свести вас с ума? А как сделать это еще лучше? Когда я играю в игры, то всегда задаю себе эти простые вопросы. Я также пытаюсь почерпнуть что-то полезное из кинофильмов, книг, музыки. Люди, работающие в этих жанрах, всегда стараются создать что-то новое, рассказать свежие истории, вызвать у аудитории ранее не испытанные чувства.

В качестве примера Крис предложил историю возникновения Total Annihilation.

После Command & Conquer M.HQ тоже захотелось сделать стратегию в реальном времени, но только трехмерную. Я тогда не знал, какая часть игры будет использовать трехмерные эффекты, но был уверен, что если я смогу показывать свои боевые юниты с разных ракурсов, то появится такая увлекательная возможность, как ответная стрельба при отступлении. Я также знал о том, что в память можно будет загрузить гораздо больше трехмерных объектов, чем заранее заготовленных точечных рисунков.

Когда я рассказал об этой идее Рону Гилберту, она ему сразу понравилась и он поддержал проект, включив меня в состав Humongous Entertainment, дочерней компании Cavedog.

Ландшафт в Total Annihilation трехмерный, но он предварительно прорисовывается, так что камере приходится постоянно держать один и тот же ракурс.

Согласно убеждению Криса, внимательное наблюдение за рынком является одной из важнейших составляющих успеха игры. Далее он объяснил, как добиться этого, не вступая в противоречие с оригинальным видением игры разработчиками.

Для начала давайте определим значение термина «чувство рынка». Я понимаю под этим прежде всего внимание к тому, что покупают люди и чего они избегают, а также некое «шестое чувство», позволяющее предугадать, что бы они купили, будь у них возможности

Я думаю, если у вас уже есть четкое представление о том, что именно вы хотите создать, ничто не сможет вам помешать, даже рынок с его постоянно меняющимися ориентирами.

«Узнайте, что популярно сегодня на рынке, и добавьте это в проект. Отнимите то, от чего публика уже устала, а затем придумайте что-нибудь свеженькое и необычное, чего никто раньше не видел», - говорит Крис Тэйлор. (Приводится с разрешения компании Cavedog Entertainment, Inc.)

Полагаю, что не стоит бросаться в крайности и создавать нечто настолько новое, что игроку будет просто не за что ухватиться. Очень важно, чтобы игрок не испытывал дискомфорта при знакомстве с новой игрой и находил в ней что-нибудь привычное.

Я напомнил Крису, что помимо прочего эта книга обращена к разработчикам, стесненным в денежных средствах. Можно ли начать создание собственной команды, не имея серьезного бюджета? Крис ответил:

Если у вас нет денег, то каждый из членов команды должен иметь другую работу, чтобы оплачивать аренду, а также достаточно много свободного времени, которое он мог бы посвящать проекту. Если это так, у вас есть шанс.

Кто-то из команды должен иметь видение конечного продукта, кому-то необходимо быть экспертом в программировании, кто-нибудь еще должен быть неплохим художником. Звук тоже важен, но с ним можно разобраться позже, однако внимательно выбирайте людей, которые этим займутся, поскольку ничто не делает игру более завораживающей, чем правильно подобранные звук и музыка.

Если вы не придаете проект широкой огласке в ходе работы, нужно иметь в запасе что-то особенное, какую-то изюминку, которая позволит ему выделиться среди более дорогих конкурентов. Представьте себе художественный фильм, снятый не за 100 миллионов, а за 100 тысяч долларов, который тем не менее поражает воображение публики. Даже профессиональным создателям игр необходимо постоянно прибегать к разным хитростям, чтобы заставить тысячу долларов выглядеть на миллион. Черт возьми, я уверен, что это и есть источник волшебства. Ограниченный бюджет помогает сфокусироваться на впечатлении, производимом игрой, а не на дорогих «прибамбасах», которыми изобилуют многие современные проекты.

Питер Морленд (Peter Moreland), Hothouse Creations

Питер Морленд является директором британской компании Hothouse Creations, производящей компьютерные игры, кроме того, он частенько берет на себя роль продюсера игры, руководителя команды или разработчика. Его последнее детище, стратегия Gangsters: Organized Crime, получило очень противоречивые оценки со стороны публики. Питер начал беседу с признания: «Вообще-то, я не считаю себя разработчиком. На самом деле, я даже не знаю, что это, собственно, такое». Далее он пояснил это заявление.

Я проработал в области игрового ПО более 15 лет и, похоже, ни разу не встретил такого мифического гения, который в одиночку смог бы наработать все концепции, идеи по их реализации, подробные формулы, планы развития игры, сценарии, проекты уровней, звуки, картинки и все прочее, из чего складывается игра. Я знаю только пару человек, которые достаточно близко подошли к этому. Но для большинства смертных производство игр - это коллективный процесс. Причина в том, что один человек не может обладать тем широким спектром талантов, которые необходимы для создания хорошей игры. Наиболее удачливые разработчики прислушиваются к советам окружающих и используют их.

Работой, приносящей наибольшее удовольствие, Питер Морленд считает создание концепции игры.

Первым шагом является определение жанра, темы и основного содержания игры. Этот этап обычно стремятся поскорее проскочить, однако он является одним из наиболее важных моментов разработки. Это основа игры. Все просто: плохой фундамент - плохая игра. Вы будете тратить уйму времени, модернизируя различные части игры и пытаясь ее «подлатать». В большинстве случаев это все равно окончится крахом, так что лучше посвятите дополнительное время выбору правильной концепции.

У себя в Hothouse мы всегда стараемся сохранять игровые концепции как можно более простыми. Гангстер во времена сухого закона, безжалостный пират или головорез для спецопераций, - все эти темы не возникают из воздуха, а тщательным образом подбираются. Игрок наверняка читал книги и смотрел фильмы об этом и, может быть, даже воображал себя кем-то из этих персонажей.

Преимущество здесь, по словам Питера, состоит в том, что игрок уже знает что-то об этих героях, о том, как они выглядят, об их поступках и о том, как они себя ведут. Еще до того, как запустить игру Gangsters, вы ум знаете, что вы в ней будете делать. Далее Питер продолжил:

Не следует заставлять играющего изучать сложный мир, полный новых, чуждых ему ценностей и правил. Это не верх премудрости, а всего лишь здравый смысл. Постарайтесь облегчить освоение игрового мира настолько, насколько это возможно.

Уделите больше времени продумыванию исходной концепции, при необходимости ее можно будет изменить до завершения проектирования или начала разработки. В MicroProse мне посчастливилось работать с Ником и Джулианом Голлопами (Nick, Julian Gollop) из Mythos Games, вместе с которыми мы выпустили имевшую огромный успех серию игр Х-СОМ. Когда Голлопы предложили нам первую игру, она задумывалась исключительно как ряд тактических боевых действий на чужой планете. Хотя в целом идея нам понравилась, мы решили, что игра должна быть более масштабной, а сюжетная линия - более понятной игрокам. Поэтому как-то раз после обеда Роб Дэвис (Rob Davies), Голлопы и я собрались для совместного мозгового штурма. Мы с Робом предложили перенести действие игры на Землю, обозначив в качестве главных целей защиту планеты и проведение исследований, а также добавить в игру энциклопедию НЛО. Это превратило бы неплохую тактическую игру в великолепную стратегию, которая действительно понравилась бы игрокам. Ребята из Mythos с этим согласились и исчезли на некоторое время, взяв таймаут для самостоятельного развития предложенной идеи. В результате получилась одна из лучших стратегических игр в истории жанра.

Есть ли у вас мнение о том, как лучше вырабатывать такие концепции? Часто ли команде Hothouse приходится заниматься мозговым штурмом? Питер Морленд подтвердил, что часто, и предложил следующие простые ориентиры.

Во время сеансов мозгового штурма убедитесь, что сказанное фиксируется на пленке или на доске. Если попытка «штурма» окажется плодотворной, не тратьте творческий заряд на чрезмерное углубление в детали. Сделайте наброски общей схемы, чтобы впоследствии вернуться к подробностям.

Обязательно просмотрите результаты через несколько дней, чтобы убедиться, все ли выглядит так хорошо, как казалось во время обсуждения. Дайте свой план на рассмотрение группе коллег. Сохраните идеи, которые им понравятся, отбросьте или переделайте те, что получат негативную оценку. Вероятно, потребуется несколько сеансов, чтобы прийти к варианту, с которым можно будет двигаться дальше.

«Как только это будет сделано, изложите свою концепцию в обзорном документе, представляющем ваше видение игры, - сказал Питер, одновременно предупредив, - Не пишите больше двух страниц». Если группа посвященных в ваши планы коллег положительно воспримет документ, дело стоит того, чтобы быть продолженным, если нет - вероятно, вы что-то упустили. Тогда исправьте документ или откажитесь от него и начните все заново.

Следующий шаг - это проектный, или «ударный», как говорит Питер, документ.

Он должен сжато описывать всю игру и ориентироваться на потенциального издателя. Законченный проектный документ для игры Gangsters содержал всего лишь дюжину страниц, в которых, однако, были изложены все основные моменты игры: ее цель, действия игрока, линия развития сюжета, что должен видеть игрок, как он может воздействовать на виртуальный игровой мир.

Этот документ должен не только передавать ваше видение игры другим людям, в нем должно быть четко обозначено, чем уникальна игра. Выделите «пригоршню золотых самородков» - тех особенностей вашего проекта, которые делают его по-настоящему классным, и тогда ни у кого не будет сомнения, что игру ждет успех. Ну а если вы делаете игру по принципу «я тоже так могу», проектный документ должен продемонстрировать, насколько сильно она превосходит своих предшественников.

Специально для начинающих разработчиков Питер Морленд напомнил о необходимости иметь хорошо сбалансированную команду. «В случае с Gangsters концептуальная основа игры была передана Мартину Капелу (Martin Capel), которому удалось развить все идеи от кратких набросков до мельчайших подробностей (лично у меня это слово вызывает содрогание)». Но, по словам Питера, в этот момент к работе необходимо подключать дополнительных людей.

Не забывайте о художниках и программистах. Дайте им максиум возможностей для подбора и изучения материалов, пока вы работаете над оформлением концепции в проектный документ. В случае с Gangsters все художники и программисты на этой стадии экспериментировали с различными эффектами и способами их представления. Можно рассказать одному художнику и одному программисту о том, как вы представляете себе игру, но остальным дать возможность интерпретировать концепцию и проектный документ самостоятельно, по их собственному усмотрению. Не исключено, что их интерпретация окажется лучше вашей, конечно, если вы не сочетаете в себе таланты выдающегося художника и программиста со способностями разработчика.

В заключение Питер сказал: «Используйте свои навыки, но не злоупотребляйте ими». Действуйте разумно.

Если вы знаете, что кто-то в команде делает что-либо лучше вас, всегда обращайтесь к нему за помощью и работайте совместно. Всегда тщательно планируйте концептуальную основу проекта, правильно подбирайте темы игр (избегая излишних сложностей), глобально продумывайте все на концептуальной стадии, регулярно выполняйте обзоры сделанного, не теряйте из виду преимущества своей игры, и можно будет сказать, что вы уже владеете некоторыми секретами создания хороших игр.

Чип Бамгарднер (Chip Bumgardner), Interplay

Этот продюсер из компании Interplay Productions еще появится в главе 15, где расскажет о правильном тестировании игр, а в этом разделе он рассуждает об особенностях проектирования игр и о том, как нужно работать над лицензионными играми по хорошо известным темам. Добавлю, что в настоящий момент он работает над игрой Star Trek: New Worlds для ПК и приставки PlayStation.

Что касается создания игр, Чип Бамгарднер отметил: «Всегда начинайте с хорошей идеи о том, какой должна быть игра, но будьте готовы к изменениям». Далее он пояснил свою мысль.

Редко случается, чтобы конечный продукт в точности соответствовал начальным замыслам разработчика. В процессе работы команды всегда всплывают новые идеи, которые необходимо учитывать для улучшения игры, но старайтесь не увлекаться этим чересчур, иначе вам никогда не удастся закончить проект (поверьте, мне уже случалось такое видеть).

Затем Чип напомнил разработчикам о том, что они делают прежде всего игру, и сказал: «Не загоняйте себя в жесткие рамки - самыми запоминающимися играми всегда были те, в которых встречались неожиданные решения».

Мы спросили Чипа Бамгарднера, как он относится к работе по лицензии, не накладывает ли дополнительные ограничения то, что приходится соблюдать правила «лицензированного» виртуального мира. Вот что он ответил:

Мне нравится работать над Star Trek! У этой игры такая долгая и увлекательная история. На ваш вопрос нельзя ответить однозначно. С одной стороны, действительно, в таких условиях сложнее работать, поскольку все, что вы делаете, должно быть одобрено свыше, поэтому нельзя просто так взять и изменить сюжет по своему усмотрению. К счастью, руководство Paramount понимает, что мы собираемся делать, и с ними оказалось приятно работать. Они активно участвуют в создании игры, мы пользуемся их рекомендациями, чтобы сделать из игры полноценный аналог Star Trek. С другой стороны, иметь дело с лицензией проще, поскольку большая часть истории уже написана. Если нам нужно узнать, как что-либо работает, мы просто заглядываем в оригинальные архивы.

В заключение Чип признался, что он «без ума» от Star Trek: New Worlds, поскольку это первая наземная стратегическая игра в серии Star Trek. И им действительно удалось создать кое-что новенькое. Любопытно?

Крис Тэйлор (Chris Taylor), Interplay

Еще один Крис Тэйлор, ведущий разработчик, занятый в момент написания книги игрой Starfleet Command в лицензионной серии Star Trek, предложил следующие советы начинающим создателям игр.

Играйте в игры

Обязательно играйте в игры, всегда, постоянно! Нельзя создать игру, пользующуюся успехом на рынке, если вы не знаете, что там происходит. Играйте в компьютерные игры того жанра, в котором вы сами хотите работать, не забывая и о других. Играйте в игры-бестселлеры и в те, что оказались неудачными. Анализируйте игры, разберитесь, почему одни были успешны, а другие провалились. Записывайте свои замечания. Ведите журнал игр, в которые вы играли, с комментариями о них. Также играйте в настольные, карточные ролевые игры - во все, что угодно. Просто играйте.

Ставьте себе небольшие цели и достигайте их

Гораздо проще поставить и выполнить маленькую задачу, чем большую. Оцените работу и разделите ее на этапы меньшего размера. Вместо того чтобы ставить себе задачу спроектировать 20 миссий за месяц, запланируйте 5 за неделю или одну за день.

Не пытайтесь объять необъятное

Выберите какой-либо из аспектов своей игры и сделайте его лучшим среди всех игр этого жанра. Всегда старайтесь сделать что-нибудь лучше остальных, но никогда не пытайтесь превзойти конкурентов во всех областях сразу. В игре Fallout мы задались целью создать лучшие в ролевом компьютерном жанре систему персонажей и способ их генерации. Мы добились того, что характеристики и умения каждого персонажа стали заметно влиять на игровой процесс. При разном показателе интеллекта персонажей игроку предлагались различные варианты диалогов. Поэтому в Fallout можно было играть многократно за разных героев - и всякий раз игре оставалась интересной. Хотя Fallout имела далеко не лучшую игровую среду, поскольку здесь нельзя было подобрать любой предмет или, к примеру, разрушить стену, мы действительно добились успеха в ее ролевом аспекте, чего многие прежние компьютерные игры так и не смогли сделать.

Далее мы попросили Криса сказать несколько слов о том, каково ему работается над такой удачной и известной темой, как Star Trek. Проще или труднее создавать игры по лицензии?

Проще, поскольку за вами стоит много уже готовых материалов. Труднее, поскольку необходимо все эти материалы учитывать. Вам не надо подробно расписывать для игроков особенности виртуального мира игры, так как предполагается, что они уже понимают этот мир (вселенную, в случае со Star Trek). Например, люди знают, кто такие Вулканы, поэтому нет необходимости описывать эту расу в подробностях. Лучше обратиться к той важной части, в которой рассказывается о происходящих событиях. Это облегчает жизнь, но ограничивает вашу свободу, поскольку нельзя вступать в противоречия с уже накопленной информацией. Необходимо лишний раз проверять согласованность своих проектов с другими известными произведениями по данной теме.

Марк Грин (Mark Green), Psygnosis

В настоящий момент Марк Грин отвечает за связь между отделами выпуска и разработки в студии Psygnosis, Великобритания. До конца 1998 года он был ведущим разработчиком, но теперь перешел на более ответственную должность, где ему приходится заниматься маркетингом и влиять на выпускаемые студией в Лидсе игры.

Первый и самый важный совет по созданию игр, который дал Марк, состоит в том, что тому, кто не может быть программистом или художником, бесполезно заниматься разработкой.

Чтобы стать хорошим разработчиком, необходимо быть и программистом, и художником одновременно. Если вы не сможете разговаривать с людьми на их языке, они не будут принимать вас всерьез, а вы не сможете понять, почему нельзя сделать ту или иную вещь. Я не имею в виду, что нужно непременно быть и выдающимся программистом, и величайшим художником. Однако вам необходимо понимать, как программисты выполняют структурирование и пишут программы, как художники создают модели и покрывают их текстурами, а также знать, какие имеются ограничения в обоих случаях. Очевидно также, что из отличного программиста и художника не обязательно получится хороший разработчик, поскольку каждая профессия требует особых навыков.

Далее Марк отметил, как важно уметь понимать и классифицировать идеи.

Недостаточно просто знать, что эта игра хорошая, а та - плохая. Необходимо уметь анализировать игры, чтобы четко понимать, что именно делает конкретную игру плохой или хорошей. Люди из вашей команды будут приходить к вам с разными идеями по поводу игры, над которой вы будете работать. Ответ «Это не пойдет!» их, скорее всего, не устроит. Они захотят узнать, почему это не пойдет. Программисты, художники и даже продюсеры - все они используют собственную терминологию, говоря о предметах своей деятельности. То же относится и к разработчикам, правда, их словарный запас должен не только включать в себя термины, характерные для всех вышеуказанных профессий, но быть также расширен в части психологии, маркетинга и особенностей конкретной игры.

«Создание игры - это эволюционный процесс, - говорит Марк. - У вас возникает идея, как сделать новую великолепную игру - хит сезона, которая потрясет публику. Вы записываете свои мысли на паре листков бумаги, затем другие люди начинают проявлять интерес к вашей идее, и в конце концов проект набирает обороты». А что потом?

А потом вы вместе с только что набранной командой переходите от исходного проекта к стадии, когда все начинают работать над идеей. Поскольку каждый человек имеет свое собственное мнение - что-то ему нравится, что-то нет - на этой стадии ваша идея, вероятно, претерпит некоторые изменения. Далее, по ходу разработки вы, скорее всего, обнаружите, что различные детали игры еще больше изменились по сравнению с оригинальным замыслом. До теш пор пока сохраняется суть игры, считайте, что все в порядке.

В заключение Марк Грин отметил, что если вас не критикуют, значив «либо что-то не так, либо вы абсолютный гений - из тех, что встречаются один на миллион»!

Вольфганг Валк (Wolfgang Walk), Blue Byte

Вольфганг Валк работает руководителем проекта бурно встреченной игры Incubation, а также занимает много других должностей в немецкой студии Blue Byte. У него есть несколько простых советов для начинающих создателей игр.

Прежде всего хорошо продумайте, что именно вы хотите создать. Затем не менее хорошо продумайте, чего вы создавать не хотите. Сопоставьте полученные результаты и подумайте еще более тщательно, как максимально упростить механизм вашей игры. Старайтесь никогда не утомлять и не разочаровывать своих игроков.

«А затем, - продолжил Вольфганг, - существует обычный путь, который должны пройти новички».

Посмотрите, что делают другие. Не зазнавайтесь и никогда не останавливайтесь на достигнутом. Вокруг столько нового, что вам просто не удастся достичь состояния, когда бы вы перестали быть учеником. Всегда продолжайте учиться, даже когда сами станете примером для других.

Ищите талантливых людей.

Знакомьтесь с родственными видами искусств: кинематографом, литературой, комиксами и так далее.

И, наконец, самый важный совет: «Главное - будьте игроком!».

Торстен Хесс (Torsten Hess), Blue Byte

Руководитель проекта и художник Торстен Хесс, работавший над играми Settlers III и Incubation, а сегодня занятый выпуском аддона к Settlers III, поделился с нами своими мыслями. Торстен отметил, что первое и основное, что должен сделать разработчик, - это написать концепцию.

Она должна быть подробной до такой степени, насколько это возможно. Потом многое, без сомнения, будет исправлено. Однако куда проще управлять проектом, когда вы начинаете с готовой концепции, а не с чистого листа.

Читайте статьи и книги о создании игр, проектировании интерфейсов, знаках и пиктограммах. Знакомство с этими материалами позволяет избежать многих ошибок. По мере развития проекта у вас и так будет возможность наделать их достаточно. Надеюсь, материалы о создании игр вас заинтересуют. Для меня одной из первых таких книг была «Computers as Theatre» (1993, Addison Wesley), написанная Брендой Лоурелс (Brenda Laurels).

Затем подумайте о бюджете.

Мы получаем много идей от людей, которые хотят продать нам игру. Даже если они преодолели первый барьер и написали понятную концепцию, у большинства из них нет графика работы над проектом и бюджетного плана. Оглядите рынок и постарайтесь понять тенденции развития в области разработки игр. Впрочем, это не означает, что вы обязательно должны создавать шутеры от первого лица, поскольку это сейчас модно.


Общие принципы создания игр: квесты, РПГ, спортивные игры, головоломки и симуляторы

Глава 3

Общие принципы создания игр: квесты, РПГ, спортивные игры, головоломки и симуляторы

В этой главе мы продолжим обсуждение основных принципов создания компьютерных игр и рассмотрим оставшиеся игровые жанры: квесты, ролевые и спортивные игры, головоломки (логические игры) и симуляторы.

Квесты

Боб Бейтс (Bob Bates), Legend Entertainment

Боб Бейтс, глава студии Legend Entertainment, начал свою карьеру в 1986 году с создания игр для компании Infocom, навсегда вошедшей в историю индустрии со своими текстовыми квестами. С тех пор его графические игры, в том числе Eric The Unready и недавно вышедшая John Saul's Blackstone Chronicles, не раз удостаивались различных наград.

В своем очерке Боб Бейтс делится идеями и секретами создания игр-приключений.

Не давайте игроку скучать

Самое ужасное преступление, какое только может совершить создатель игры, - наскучить игроку. Поясним это положение.

а). Не заставляйте игрока дважды повторять одну и ту же последовательность действий. Если он уже выполнил все необходимые шаги и решил сложную головоломку, предоставьте ему возможность в дальнейшем в аналогичной ситуации миновать эту последовательность одной командой. Для ясности приведу два примера.

Если в вашей игре появляется сейф с кодовым замком, то, как только игроку удалось с ним справиться, добавьте в его арсенал команду «Открыть сейф». Не заставляйте его набирать код снова и снова всякий раз, когда ему понадобится воспользоваться сейфом.

Если в придуманном вами лабиринте игроку приходится делать 20 поворотов, прежде чем он доберется до центра и отыщет заветный артефакт, позвольте ему пройти обратный путь автоматически. Если же он вдруг решит снова пуститься в путешествие по лабиринту, переместите его прямо в центр, минуя все закоулки.

б). Не стоит заставлять игрока выполнять длинную последовательность сложных трюков без возможности сохраниться, а при малейшей ошибке - начинать все сначала.

в). Сделайте так, чтобы игрок мог свободно перемещаться в окружающем пространстве. Если созданный вами мир занимает большую площадь, позвольте игроку одной командой преодолевать расстояния из конца в конец. Не утомляйте его бесконечными путешествиями туда и обратно.

г). Если в игре есть видеовставки, дайте игроку возможность отказаться от их просмотра (нажав клавишу ESCAPE или правую кнопку мыши). Поверьте, нет ничего скучнее, чем снова и снова созерцать одну и ту же сцену. Всемогущий Создатель не случайно дал нам клавишу ESCAPE. Используйте ее! Еще одно слабое место - повторная загрузка. Не сомневаюсь, вы сочинили потрясающий ролик для заставки, но игрок уже посмотрел его. Позвольте ему на этот раз пропустить ваш шедевр.

Если вам удастся устранить эти и другие утомительные действия, которыми грешат многие творения нашего жанра, вы получите динамичную игру, которая будет держать игрока в напряжении от первой до последней минуты.

Не владеете словом - не беритесь за перо

Не такое это простое дело - сочинительство, а уж тем более сочинительство профессиональное. На овладение этим искусством уходят годы. Если вы никогда раньше не писали, не стоит мучиться и теперь. Разумеется, это вовсе не значит, что из вас не выйдет хорошего разработчика компьютерных игр или что вы не в состоянии озадачить игрока парой интересных головоломок - нет, просто для создания сюжета и сочинения диалогов вам придется найти того, у кого это получается лучше. Плюс к тому, разрабатывая сюжет игры, надо непременно подумать о максимальном эффекте при минимальных затратах...

Как оценить собственную литературную профпригодность? Я придерживаюсь следующего правила. Если вы никогда не слышали о книге «Elements of Style» Странка и Уайта (издательство Allyn & Bacon), если вам не приходилось изучать литературные приемы и задумываться о различиях между хорошим и плохим текстом, предоставьте сочинительство кому-нибудь другому.

Почувствуйте игрока

Когда меня спрашивают, что значит быть разработчиком игр, я отвечаю, что самое главное качество нашей профессии - это способность «чувствовать» игрока. Постарайтесь поставить себя на его место. Поймите, о чем он думает и что чувствует. Выясните, чего бы ему хотелось, и дайте ему попробовать все, что ему интересно. Угадайте, от чего он придет в восторг, а что покажется ему скучным. Откажитесь от заведомо неинтересных моментов игры.

Если же у вас отсутствует эта способность, боюсь, вы не сможете стать хорошим разработчиком ни в одном из существующих жанров.

«Я советую разработчикам сначала прокрутить все в голове. Закрыть глаза и представить всю игру - еще до написания программы», - говорит Боб Бейтс. Игровой экран из квеста John Saul's Blackstone Chronicles. (Приводится с разрешения компании Mindscape, Inc. Все права защищены.)

Рон Гилберт (Ron Gilbert), Humongous Entertainment

«На совести» этого господина - множество популярнейших игр производства компании Humongous Entertainment (вспомните хотя бы игре Maniac Mansion), легендарный сериал Monkey Island и несколько детских квестов. Ниже приводятся соображения Рона касательно самого главного аспекта творческого процесса - вдохновения. А именно:

Иногда вдохновение приходит, когда вы играете в чужую игру, смотрите фильм или читаете книгу, - искра озарения может вспыхнуть от чего угодно. Квесты построены на сюжете, и надо подходить к их созданию так, как если бы вы писали сценарий или книгу.

При этом не следует забывать об аудитории. Если вы создаете игру только для собственного удовольствия и ваши предпочтения вдув вразрез с требованиями рынка, она не будет иметь успеха. В то же время замысел должен зародиться не в голове, а в сердце. Если вы полагаетесь только на исследования рынка, у игры не будет «души».

Какие примеры может привести Рон Гилберт, основываясь на своих работах? Как ему пришла в голову идея Monkey Island. По его словам, изучение спроса на игровом рынке, конечно, проводилось (как выяснилось, «Обезьяний остров» была первой игрой на «пиратскую» тематик» но главную роль сыграли его собственные пристрастия.

После Maniac Mansion, действие которой происходило в современном мире, мне захотелось придумать игру-сказку, и тут я вспомнил о своих любимых пиратских историях... На создание Monkey Island ушло около двух лет. Я написал пять сценариев, прежде чем остановился на одном, самом удачном. Зато Monkey Island II отняла меньше года.

Мы еще встретимся с Роном Гилбертом в следующей главе, где говорится о создании яркого игрового персонажа, а также в главах 12 и 15, посвященных оформлению пользовательского интерфейса и тестированию игр.

Чэд Фримен (Chad Freeman), Dreamforge Intertainment

Чэд Фримен работал в качестве программиста над такими широко известными играми, как Anvil of Dawn и Warwind, а в последнее время являлся ведущим программистом игры Sanitarium (в русской версии «Шизариум». - Примеч. ред.), изданной компанией ASC Games. В главе 8 вы встретитесь с его советами по программированию, но у Чэда есть что рассказать и об общих принципах создания компьютерных игр.

Важность сюжета

Для начала замечу, что для хорошей игры самое главное - это сюжет. Конечно, существует множество неплохих игр и даже целые жанры, в которых нет и намека на сюжетную линию, и все же самые лучшие игры - те, где присутствует интересная фабула. Quake, бесспорно, является классическим шутером от первого лица, но игру Half-Life, относящуюся по сути к тому же жанру, увлекательная сюжетная линия ставит на порядок выше.

Поддерживайте «обратную связь»

Работая над игрой, обязательно учитывайте пожелания других игроков. Создавая Sanitarium, мы попросили каждого сотрудника нашей компании пройти игру от начала до конца. Заметив, что коллег не особенно впечатлила одна из частей игры, мы убрали ее и приступили к доработке проекта. Однако не спешите менять и удалять отдельные фрагменты игры только потому, что кому-то (или даже всем) так хочется. Если вы уверены, что ваша идея сработает, оставляйте ее без изменений. И не важно, окажетесь вы правы или нет, - кто не рискует, тот не пьет шампанского!

Изучите свои возможности

Верьте в свои силы, но в то же время будьте предельно требовательны к себе. Делая Sanitarium, мы старались трезво оценить свои сильные и слабые стороны и постоянно держали это в голове. Характерная особенность каждого игрового проекта - необходимость отказываться в конечном итоге от многочисленных подробностей, чтобы завершить игру. Для Sanitarium были написаны целые куски уровней, которые можно было вырезать без ущерба для самой игры. Когда такая необходимость и в самом деле возникла, мы уже были готовы к этому, и игра в целом не пострадала.

В будущем Чэд Фримен мечтает создать игру, которая превзошла бы Sanitarium по динамичности и остроте сюжета.

Ли Шелдон (Lee Sheldon), SouthPeak Interactive

Писатель и разработчик компьютерных игр Ли Шелдон участвовал в создании ряда широко известных квестов, включая Dark Side of the Moon, Temujin и «орденоносный» The Riddle of Master Lu. Мы попросили господина Шелдона рассказать, что в первую очередь следует помнить создателю игры, и по возможности подкрепить свои слова примерами.

Зачем вы это делаете?

Прежде всего спросите себя, ради чего вы хотите создать игру. Это самый главный вопрос, на который необходимо знать ответ. Вам нужны деньги? Или вы решили заняться этим от скуки? А может, все дело в том, что творчество - ваша стихия? Чтобы ответить на этот вопрос, надо заглянуть в свое сердце и познать себя. Это первый шаг, и без него не обойтись, если вы хотите создать что-либо действительно стоящее. Сделать этот шаг не так просто, как кажется. Часто бывает, что этому не придают особенного значение.

Выступая в защиту этого незаслуженно обойденного вопроса, Ли Шелдон приводит следующий пример.

Игру Dark Side of the Moon я получил «в наследство» от другого разработчика. Должен признаться, что работать над игрой, задуманной не тобой, гораздо сложнее. Сюжет Dark Side основывался на научной фантастике, действие происходило в открытом космосе. Таких игр к тому времени было более чем достаточно. Итак, я спросил себя: «Зачем тебе эта игра? Что тебя привлекает в ее сюжете?» И в голову мне пришла одна идея. Задумка была простая и не особенно оригинальная, но что-то в ней было... Вот эта мысль: человеку необходима семья. Семья воспитывает нас и дает нам силы противостоять жизненным невзгодам. Но традиционные представления о семье помогают нам далеко не всегда. Я создал персонаж, который по ходу игры теряет своих кровных родственников (в результате смерти или предательства), но находит новую семью в совершенно неожиданном месте. Увы, ни один рецензент так им отметил это обстоятельство. Я их не виню. Сюжеты в компьютерных играх редко претендуют на звание литературного шедевра. Но именно тема семьи вдохновила меня на создание этой космической игры.

Для кого эта игра?

Делая СВОЮ игру, не забывайте об игроках, для которых вы работаете. Даже если вы заняты, скажем, «стрелялкой», которую терпеть не можете. Соблюдайте требования жанра и учитывайте вкусы вашей аудитории. Не пытайтесь навязать правила стратеги ролевым играм. Прививайте игрокам любовь к прекрасному, если вам это по силам, но не игнорируйте их пристрастия. Покупателю нет никакого дела до того, что вы вложили в игру сердце и душу. Ему важно только одно: насколько интересна эта игра. Ему лично.

Свою карьеру в индустрии я начинал с детских игр. Квест Once Upon a Forest предназначался для совсем маленьких игроков. Я видел, что головоломки игры и ее прохождение не отличаются особой сложностью и не требуют дополнительных подсказок. Но я на собственном опыте знал, как обидно бывает застрять на какой-нибудь заумной задачке. Так в игре появилась система помощи. Если малыш не знает, что делать, или ему лень ломать голову над загадкой, он может нажать на свечку («доэлектрический» аналог лампочки) в поле интерфейса, и загадка решится сама собой. Итак, мне пришлось представить себя на месте маленького игрока, как бы почувствовать себя в его крохотной «шкурке»!

Испытайте себя

Ни в коем случае не беритесь за создание игры с намерением сделать ее «как игру N, только лучше». Конечно, большинство элементов, присущих выбранному игровому жанру, будут использоваться и здесь, и пренебрегать ими не стоит, но постарайтесь найти к ним новые подходы. Поднимайте планку везде, где только можно: в техническом воплощении, сюжете, персонажах и т.д. Вам потребуется вся ваша фантазия, чтобы выделиться на общем фоне.

Вот как я бросил вызов самому себе в игре Dark Side of the Moon: в порядке эксперимента я создал систему модульной сюжетной линии, чтобы проверить, можно ли ввести в игру сложную и запутанную историю. С одной стороны, повествование должно было разворачиваться по многим направлениям, а с другой - находиться под моим постоянным контролем. Среди многочисленных достоинств квестов нелинейность обычно не значится. Если игроку и дают возможность управлять сюжетом, то очень ненадолго. Даже если история, положенная в основу игры, имеет развернутую структуру, события в ней следуют друг за другом в строго определенном порядке.

Итак, я решил сочинить для игры длинную, подробную и при этом нелинейную фабулу. Никто не просил меня об этом. Было невероятно трудно отслеживать все возможные изменения: я должен был убедиться, что игрок никогда не попадает в заведомо ошибочное положение, выпадающее из общей последовательности. Поскольку точно предсказать, как будет развиваться игра для каждого конкретного пользователя, оказалось практически неразрешимой задачей, игроку приходится постоянно менять диски. Это было новое слово в создании квестов, хоть и не революционное: мне просто хотелось узнать, возможно ли это сделать в принципе. Теперь, когда я убедился, что это возможно, а рецензенты и игроки заметили и оценили это нововведение, я решил, что в следующей игре смогу еще больше расширить набор вариантов сюжетного развития.

Наконец, заключительные слова Ли Шелдона посвящены стремлению к совершенству.

Я начинал на телевидении. Когда мне приходилось беседовать с коллегами о создании телепрограмм, я часто слышал в ответ, что поскольку телевидение само по себе «сущая чепуха», то работа для него не требует больших усилий. Проще говоря, они смотрели на СМИ свысока. И зря. Никогда не следует опускаться до халтуры, даже если вы видите, как «по ящику» бесконечно раскручивают чужие поделки не самого лучшего качества. Старайтесь выкладываться в любом деле полностью. Используйте все свое умение и талант и не занижайте планку заранее. Всегда найдутся «доброжелатели», которые с радостью сделают это за вас. Необходимость согласовывать свои идеи с другими людьми и материальная сторона дела в конечном итоге спустят вас с небес на землю. Поэтому старайтесь начинать с высочайшей горной вершины, иначе в итоге от вашей задумки не останется даже мало-мальски заметного холмика.

Что Ли Шелдон планирует на будущее? Он обещает нам игру в жанре экшен/приключение на основе известной сюжетной линии (все подробности пока держатся в глубокой тайне), а также квест 20000 Leagues: The Adventure Continues, выпуск которого намечен на весну 2000 года.

Роберта Вильяме (Roberta Williams), Sierra

Это имя еще не раз встретится вам на протяжении всей книги, здесь же Роберта Вильяме, создатель множества великолепных компьютерных игр, поделится своими соображениями по поводу начальной идеи новой игры и приведет в качестве примера свои последние проекты. Как ей кажется, преуспевающий разработчик компьютерных игр обязан хорошо чувствовать рынок. Роберта объясняет это так: «Да, очень важно, чтобы вам самому захотелось создать игру, чтобы вам нравилось над ней работать, но нужно также знать свою аудиторию и четко представлять, какую нишу на компьютерном рынке вы можете занять».

На примере своей последней игры King's Quest: Mask of Eternity госпожа Вильяме рассказывает, что заставило ее внести изменения в традиционную структуру игры.

У меня создалось впечатление, что пользователям надоело продираться сквозь бесконечные головоломки, не получая быстрого вознаграждения за свои труды. Я поняла, что если Mask of Eternity будет сделана в том же ключе, что и предыдущие части King's Quest, она вряд ли будет отвечать нынешним потребностям. Поэтому сделала игру трехмерной и добавила в нее в качестве изюминки экшен-элементы. И снова рынок и его законы! Mask of Eternity сохранила хорошее отношение давних поклонников этой серии, а вот что касается новой аудитории... привлечь ее оказалось сложнее, но мне так хотелось внести свежую струю в традиционный квестовый жанр...

Приступив к работе над игрой Mask of Eternity, Роберта Вильяме почувствовала, что пришло время перемен. Она добавила в игру экшен-элементы и сделала ее трехмерной, а сюжет и диалоги оставила прежними, чтобы доставить удовольствие давним поклонникам серии King's Quest. (Приводится с разрешения компании Sierra Online, Inc.)

Говоря о «нишах» в индустрии, Роберта проливает свет на подробности создания своего давнего хита Phantasmagoria.

Я обнаружила, что в литературе и кино есть популярнейший жанр - ужасы, у нас же до недавнего времени эта тема вообще не затрагивалась. Таким образом, Phantasmagoria стала полноценным интерактивным фильмом ужасов, в котором задействованы настоящие актеры.

Ролевые игры (RPG)

Мэтт Хаусхолдер (Matt Householder), Blizzard Entertainment

Компания Blizzard North пригласила Мэтта Хаусходцера в качестве ведущего разработчика Diablo II (вам знакомо это название, не так ли?), кроме того, на его плечи лег подбор команды программистов, художников и специалистов по звуковому и музыкальному оформлению. Не беда - Мэтт уже много лет работает в игровой индустрии над проектами для различных игровых платформ. Специально для этой главы он составил свод рекомендаций, предназначенных создателям игр. Эти правила относятся не только к ролевым играм, но и к другим игровым жанрам.

Принципы создания интерактивных игр по Хаусхолдеру

Работайте исключительно для конечного потребителя - для игрока. Это правило кажется очевидным, но о нем нередко забывают во время захватывающего творческого процесса. Конечно, оно справедливо не только для компьютерных игр.

Создание игры - работа трудоемкая: приходится постоянно менять программный код, художественное оформление, звук. После каждого изменения необходимо проверять, улучшилась ли игра. Чтобы не терять время на действия, которые ничего или почти ничего не улучшают в проекте, попытайтесь предугадать, какие именно переделки приведут к положительному и наиболее эффективному результату. Таким образом ваша игра шаг за шагом будет приближаться к совершенству.

Все элементы игры должны соответствовать стандартам, принятым на компьютерном рынке. В конце концов, потенциальные потребители вашего творения хотят тратить время и деньги на то, что им нравится и приносит удовольствие. Самый лучший способ убедиться, что ваши дизайнерские новшества делают игру занимательнее, - это проверить каждое из них непосредственно на потребителе. С другой стороны, это самый непрактичный способ: во-первых, компьютерный рынок огромен, а во-вторых, обратной связи придется ждать слишком долго. На практике приходится ограничиваться опросом небольшого числа будущих покупателей. В этом случае проблема сводится лишь к подбору наиболее представительной группы респондентов. Удобнее и быстрее всего опросить собственно разработчиков. Поэтому необходимо, чтобы ваша команда как можно полнее представляли потребительский рынок: разбиралась в игровой продукции и отличала хорошую работу от халтуры.

Мэтт Хаусхолдер рекомендует: «Работая над игрой, сделайте игровой макет и раскритикуйте его в пух и прах. Затем остановитесь, проанализируйте ошибки и внесите изменения. При необходимости повторите процедуру». (Приводится с разрешения компании Blizzard Entertainment, Inc.)

Получив бета-версию и приступив к окончательной доработке игры, включите в вашу модель потребительского рынка группу тестирования. Интернет в этом случае незаменим: с его помощью вы найдете таких людей и сможете поддерживать с ними контакт.

Ознакомьтесь с игровой классикой. Для игральных автоматов это РасМап, Centipede, Asteroids, Defender, Robotron 2084, Joust, Street Fighter, NBA Jam. Среди компьютерных игр - Pinball Construction Set, Jumpman, John Madden Football, Doom, Quake. Среди карманных игр и игр для приставок - Mario, Zelda, Bomberman, mempuc.

Возьмите за основу что-нибудь общеизвестное и дополните свежими идеями. Однако будьте осторожны с новинками, которые до сих пор не встречались ни в одной игре. Вполне возможно, что новшество настолько неудачно, что испортит любую игру - что-то вроде смертельной генетической мутации.

Игроку нравится, когда компьютерный мир повинуется ему целиком и полностью, не разрушайте его иллюзии. Если он хотя бы на мгновение почувствует, что ситуация выходит из-под контроля, это будет означать ваш провал как разработчика игры.

Пользовательский интерфейс должен быть интуитивно понятен и последователен. Тогда новичкам будет проще обучаться, а опытные игроки почувствуют себя настоящими профессионалами.

Важность соответствия действительности часто переоценивают. Не стремитесь воссоздать реальность во всех деталях. В конце концов, если бы реальный мир был так захватывающе интересен, разве люди играли бы в игры?

Не пытайтесь заставить игрока полностью вам поверить. Пусть придуманный мир (и взаимодействие с ним) будет самодостаточным и непротиворечивым. Возможно, современный человек только притворяется, что не верит в сказку.

Персонаж, который отождествляется с игроком, обязательно должен быть симпатичным. Представьте, что игрок смотрит на экран и думает: «Господи, да неужели это я? Ну и урод!..» Вряд ли в этом случае ваша игра будет хорошо раскупаться. Потребители компьютерных игр - очень разборчивая публика, они не потерпят плохого художественного оформления, и им вряд ли придется по вкусу ваш юмор, если они его не поймут.

Проследите, чтобы скорость вывода изображения на экран (частота кадров) была достаточно высокой и устойчивой. Это особенно важно (и особенно сложно для выполнения) в экшен-играх.

Если вам не удается организовать вычисление чего-либо непосредственно в процессе игры, сделайте это заранее. Не усложняйте программирование ненужными вычислениями в реальном времени. Везде, где только возможно, старайтесь предварительно просчитывать алгоритмы в таблицах, а во время работы программы только подставляйте готовые результаты.

Все мало-мальски важные параметры в игре должны быть настраиваемыми.

Важным моментом в создании и разработке игры является моделирование игрового мира, то есть определение игровых переменных и их взаимодействия. Занесите переменные в таблицы. Сюда войдут характерные свойства игроков, их врагов и окружающей обстановки.

При окончательной настройке игры постарайтесь довести ее до полного совершенства. Впрочем, это легче сказать, чем сделать. Экономические соображения рано или поздно заставят вас остановиться.

Получайте удовольствие от всего, что вы делаете.

Если все пойдет хорошо, вы еще не раз захотите вернуться к созданию игр.

Рэй Музика (Ray Muzyka), BioWare

Ролевая игра Baldur's Gate, выпущенная в самом конце 1998 года, сразу же стала признанной классикой как своего жанра, так и компьютерных игр в целом. Коммерческий успех также не заставил себя ждать: более 200 тысяч копий было распродано только за первые две недели. Рэй Музика, один из трех основателей BioWare, беседует с нами о том, что значит работать с лицензированной собственностью (речь идет об игровой вселенной Forgotten Realms и своде правил «комнатных/настольных» ролевых игр Advanced Dungeons & Dragons), помогает это или мешает создавать игру и бороться за успех у потребителя. Ниже следует подробный ответ Рэя Музики.

Интересный вопрос. Как правило - и то и другое. Думаю, это зависит главным образом от того, кто именно обладает правами на вашу продукцию, а также от самой продукции. Нам очень понравилось работать с компаниями Wizards of the Coast и TSR, которую WOTC приобрела в 1998 году (наше издательство Interplay/Black Isle владеет вместе с ними авторскими правами на Forgotten Realms, a BioWare разрабатывала Baldur's Gate по этой вселенной). Представители WOTC/TSR всегда были внимательны к нашим предложениям. Если бы нам не удалось прийти к взаимопониманию, наша работа значительно усложнилась бы, но, к счастью, эти трудности нас не коснулись: иметь дело с этой компанией было одно удовольствие.

С самого начала работ над Baldur's Gate мы вовлекли WOTC/TSR в процесс создания игры: несколько сотрудников TSR посетили BioWare, чтобы ознакомиться с нашим заделом по художественному оформлению, дизайну и текстам. Более того, они стали активными участниками коллективного творческого процесса: так, их предложения помогали нам в создании сюжетной линии игры. Мы убедились, что они поняли наш замысел, а кроме того, теперь нам была известна их точка зрения касательно различных дизайнерских направлений, и мы старались создавать проект в соответствии с их собственными разработками. Мы часто советовались с владельцами лицензии, не только вначале, но и потом, спустя несколько месяцев после запуска проекта, и еще через несколько месяцев. Словом, WOTC/TSR постыоянно были в курсе того, как мы ведем разработку их детища.

Конечно, развивать лицензированный продукт не так-то просто. Одним из первых препятствий, с которым мы столкнулись в процессе создания виртуального мира AD&D, была необходимость соблюдать жесткий моральный кодекс, что в свою очередь несколько ограничило полет нашей фантазии. Однако это не помешало нам изобрести новую концепцию сюжетной линии и ничуть не ухудшило игру в целом. Просто мы всегда помнили о тех правилах, которых следовало придерживаться в работе.

Нам очень помогли области и персонажи, уже созданные в мире Forgotten Realms, - это значительно упростило выбор мест действия. Мы постоянно изучали первоисточники, в соответствии с которыми располагали поселения, города, здания, персонажей и даже пейзажи и декорации Baldur's Gate. Сковывало ли нас это? Не особенно - так как мы имели право добавлять в игру множество новых персонажей и областей.

Труднее всего оказалось придумать, как перенести свод правил AD&D на компьютер. Мы сознательно усложнили себе задачу и решили сделать игру в режиме реального времени. Кроме того, мы довольно рано поставили себе целью не менять правила без необходимости. А поскольку AD&D представляет собой скорее набор исключений из правил, чем сами правила, нам пришлось изрядно поломать голову над этой проблемой. В конце концов, при тестировании игры стало очевидно, что сохранение существующих правил было мудрым решением: игра и так уже «распухла» от огромного количества статистических данных по каждому персонажу и предмету, взятому из первоисточников. А изменение правил и вовсе привело бы Baldur's Gate к трудноразрешимым проблемам балансировки игрового процесса.

Наконец, финансы. Я не имею права разглашать, сколько Interplay/BioWare пришлось заплатить за использование лицензии на Forgotten Realms/AD&D, но это довольно дорогое удовольствие.

В общем, процесс разработки лицензированного проекта имеет как положительные, так и отрицательные аспекты. Мы со своей стороны планируем продолжать совместную работу с WOTC/TSR (через издательство Interplay), поскольку в нашем случае это сотрудничество было приятным и плодотворным.

Что касается способности привлечь потребителя, то разработка игры на основе широко известной и всеми любимой темы может оказать вам как хорошую, так и плохую услугу. С одной стороны, покупатель встретится с уже знакомыми персонажами (как, к примеру, в игре X-Files компании Fox Interactive), местом действия (как в Star Wars или Star Trek) или правилами (как в D&D). Следовательно, можно ожидать, что игру тут же сметут с прилавков, признав в ней старого знакомого, и игрокам будет гораздо проще в ней разобраться. С другой стороны, если надежды потребителя не оправдаются, его постигнет гораздо большее разочарование, чем в случае с абсолютно незнакомыми ему персонажами, сюжетом и правилами.

Том Холл (Tom Hall), ION Storm

Перед тем как приступить к созданию ролевой игры Anachronox, Том Холл, опытный и талантливейший разработчик, представляющий ныне знамена ION Storm, стал соучредителем компании id Software - колыбели 3D-шутеров от первого лица.

Что касается основных принципов создания игр, Том Холл считает, что здесь много важных аспектов, но самых главных три.

Игра создается для игрока

Конечно, здорово, если вам пришла в голову идея рассказать захватывающую историю средствами игры или направить ход событии по определенному пути, но помните, что игра должна понравиться игроку и быть у него под контролем, насколько это возможно. Устанавливайте себе на здоровье любые правила (вроде того, что персонаж может одновременно нести не больше четырех предметов), но никогда не давайте ему почувствовать себя одураченным. Не позволяйте игроку видеть за игрой ее создателей. Пусть он ощущает себя участником представления. Если он хотя бы на миг почувствует собственную беспомощность, вы потеряете его доверие. И еще: все, что вы делаете, должно быть забавным и увлекательным. Некоторые дизайнеры слишком много внимания уделяют новым веяниям, добавляют в игру всяческие причудливые особенности, без конца шлифуют художественные детали и забывают, что игроку хочется только одного - развлечься.

Старайтесь сразу же увлечь игрока

В первые же полминуты игры дайте игроку понять, что он нашел нечто потрясающее. Если он застрянет на нудном введении или заскучает, прежде чем доберется до лакомого кусочка, можете поставить крест на своем проекте. В идеале, нажимая на клавиши, игрок должен то и дело восклицать: «Вот это класс! Здорово!» В этом смысле берите пример с Half-Life.

Первые десять блинов - комом

Ну и пусть! Для начала имеет смысл сделать несколько маленьких игр на различную тематику – просто чтобы набраться опыта. Я и сам «состряпал» порядка полусотни небольших игрушек, прежде чем перешел в Softdisk. Создать игру самому от начала до конца - великий подвиг. Совершая его, вы обучитесь всем премудростям и приобретете уверенность в себе.

Если вы хотите побольше узнать об Anachronox, посетите страничку игры по адресу www.anachronox.com.

Спортивные игры

Шон Хауз (Sean House), Electronic Arts

Шон Хауз, помощник продюсера, отвечает за серию игр для ПК Madden NFL Football, отмеченных многочисленными наградами. Его советы применимы как к спортивным играм, так и к другим игровым жанрам. На что же в первую очередь должен обращать внимание начинающий разработчик? Шон Хауз отвечает, что это «внимание к деталям, выразительность и новаторство», причем первое - самое важное.

Очень важно уделять внимание каждой мелочи. Когда программисты и художники сталкиваются с неясностями в проекте, они обычно интерпретируют их по-своему, и их понимание может не совпасть с вашим. В невыразительном, плохо проработанном дизайнерском наброске трудно разобраться, и такой проект вряд ли станет успешным. Большинство важных моментов будет наверняка упущено из виду. В то же время новаторский замысел привлекает внимание тех, кто воплощает его в жизнь, и имеет все шансы на успех.

Шон Хауз, сотрудник компании ЕА, считает, что внимание к деталям и их талантливое исполнение только улучшат качество игры. Игровой момент из Madden NFL Football '99. (Приводится с разрешения компании ЕА Sports.)

В качестве примера Шон приводит свой опыт работы над Madden NFL Football '97:

Мы в общих чертах обрисовали разработчикам, каким, по нашим представлениям, должен быть основной экран игры. Нам хотелось, чтобы он напоминал диалоговое окно Windows 95 с вкладками (подобно окну свойств экрана) и выглядел так, будто сделан из металла, а кнопки при нажатии должны издавать разные «металлические» звуки. Спустя почти месяц мы получили экран со стандартной металлической текстурой, взятой из 3D Studio, - тусклой, без отблесков, без структуры и совершенно неинтересной, а звучки напоминали позвякивания треугольника (нечто дребезжаще-высокое). Но мы-то стремились к тому, чтобы экран выглядел стальным и мощным, а сопровождающие звуки были низкими, как на металлургическом заводе, - все это по замыслу призвано было символизировать грубую силу и мощь игроков NFL и самой игры. Вместо этого нам предложили приятный чистенький экранчик с забавным звучанием, который скорее подошел бы для какой-нибудь инженерной программы. Мораль сей истории такова: если у вас возникла идея, то пока вы не сделаете подробный, выразительный и новаторский дизайнерский набросок, есть опасность получить в итоге совсем не то, что рисовалось вашему воображению.

На вопрос, что он думает по поводу секретных кодов и прочих сюрпризов в играх, Шон Хауз ответил: «Я смотрю на ситуацию как бы из-за кулис. На мой взгляд, они не так уж важны»,- но тем не менее заметил, что это его личное мнение. В то же время он признает целесообразность подобных решений:

Коды делают повторное переигрывание более занимательным. После того как пользователю наскучит сражаться по стандартным правилам, он может воспользоваться секретным кодом, чтобы еще немного позабавиться и вдобавок почувствовать себя более уверенно, навязывая компьютеру свою волю. По крайней мере так говорят многие наши покупатели.

В заключение Шон Хауз сказал, что мечтает «взбираться все выше и выше по лестнице мастерства, ставить перед собой все более серьезные задачи и создавать новые и при этом обязательно новаторские развлекательные программы».

Стив Коалльер (Steve Coallier), Electronic Arts

Стив является менеджером по программному обеспечению и входит во внутреннюю группу разработчиков (Scoreboard Productions) в рамках компании Electronic Arts. Он участвовал в создании ряда игровых проектов, выходивших под маркой ЕА, - от шутеров до космических симуляторов и спортивных игр. Мы попросили его высказать свои соображения по поводу текущего положения в области спортивных игр и дать несколько советов создателям игр этого жанра. Вот что он ответил:

Я видел не так уж много приличных спортивных игр для ПК. Здесь есть какой-то замкнутый круг: спортивные игры, разработанные для персонального компьютера, не очень хорошо раскупаются, поэтому считается нецелесообразным затрачивать много усилий на их создание. Это не может не отражаться на их качестве, что, в свою очередь, приводит к тому, что они плохо раскупаются, и так без конца. Полагаю, что для создания удачной ПК-игры необходимо использовать преимущества ПК. Следует тщательно разработать многопользовательскую сетевую версию и наборы характеристик, которые пользователь может загрузить через Интернет. Необходимо предоставить игроку возможность загружать свои рисунки - чтобы придать индивидуальность каждому персонажу. Графика должна использовать аппаратные возможности компьютера на полную катушку. Увы, почти все современные спортивные игры, написанные для ПК, мало чем отличаются от тех, что есть на игровых приставках. То же, к сожалению, можно сказать и о некоторых играх ЕА (например FIFA и Madden), и это одна из главных проблем, над которой мы работаем, стараясь увеличить продажи наших продуктов.

Что касается игровых приставок, то создается впечатление, будто цель большинства подобных игр - задействовать максимум подробностей, что неприемлемо, поскольку здесь все упирается в ограниченные аппаратные возможности. Мы и сами грешны: когда создавалась наша последняя игра (NCAA March Madness '99), всем казалось, что версия 98 года, взятая ЕА за основу для сериала по лицензии, получилась несколько слабоватой, поэтому мы решили дополнить ее всеми мыслимыми элементами, характерными для школьного баскетбольного матча. В результате нам банально не хватило времени довести замысел до ума и придать продукту блеск и завершенность.

Итак, какой же из этого следует вывод?

В игре должен присутствовать ограниченный набор тщательно проработанных возможностей, причем основные усилия надо направлять на саму игру, то есть собственно спортивное состязание. Игру нужно сделать динамичной, а управление - интуитивно понятным, чтобы пользователь ощущал себя активным участником соревнования, происходящего на экране компьютера. Хорошим примером является созданная нами по лицензии игра NBA Live. Ее авторы понимали, что этот продукт будет выпускаться ежегодно, и поэтому решили каждый год вносить строго ограниченный набор улучшений. К примеру, сперва можно добавить новые сценарии игры в систему искусственного интеллекта и усовершенствовать режим создания игрока; на следующий год - ввести мимику игроков и пару-тройку новых способов покрасивее забросить мяч в корзину. Каждый раз у вас оказывается достаточно времени, чтобы внедрить очередное новшество, из-за которого игру будут покупать даже со старыми характеристиками игроков, а потом можно будет обновить и их. Если работать по заранее составленному плану, в конечном итоге результат будет гораздо лучше.

Напоследок Стив Коалльер делает замечание, верное для игр любой платформы, будь то компьютер или игровая приставка.

Время, потраченное на то, чтобы придать игре бесподобное оформление, потрясающее звучание или наполнить ее всеми мыслимыми подробностями, можно считать потраченным впустую, если игра получилась скучной и неинтересной. Возьмем для примера Doom: при строго ограниченном числе новых возможностей разработчики всецело сосредоточились на создании захватывающего продукта и в результате добились потрясающего успеха.

Игры-головоломки

Алексей Пажитнов, Microsoft

Знаменитый разработчик, в настоящее время сотрудник Microsoft, отвечающий в компании за создание логических игр, Алексей больше всего известен как автор тетриса, одной из самых популярных (и породившей великое множество подражаний) игр нашего времени. В своем телефонном интервью Алексей Пажитнов раскрыл нам три своих основных принципа создания игр и признался, что всегда следует им в своей работе.

Все не так просто, как кажется...

«Когда вы с головой погружаетесь в проект и долго над ним работаете, - говорит Алексей, - все в нем кажется вам простым и понятным». Но так ли это для игрока? Можно ли, создавая головоломку, не брать в расчет его мнение?.. В играх, над созданием которых трудился Алексей Пажитнов, с течением времени все начинало представляться ему тривиальным, но он понимал, что для того, кто видит игру впервые, она окажется довольно трудной задачкой.

Сложностью тоже не следует пренебрегать

«Какой бы сложной ни была головоломка, всегда найдется игрок, который ее решит», - утверждает Алексей. Он признает, что это положение противоречит предыдущему, и все же оба верны: «Не пренебрегайте сложностью головоломок лишь потому, что вам кажется, будто никто не в состоянии их решить; всегда найдется игрок, который не глупее вас».

Интересно ли вам играть в свою игру?

И наконец, если вам не нравится ваша собственная игра, она вряд ли придется по душе другим. «Эти три правила я неустанно повторяю своей команде», - говорит Алексей Пажитнов.

А как же вдохновение? Есть ли способ его вызвать? Пажитнов отвечает: «Вдохновение нельзя запрограммировать; обычно оно приходит во время работы - я не жду, когда оно меня посетит».

Надо ли создавать трехмерные логические игры? Как насчет сетевых игр? Есть ли шансы на успех в 21-м веке у игры, рассчитанной на одного игрока? Алексей отвечает:

Двухмерные игры все еще пользуются огромной популярностью. За последние десять лет технология сделала огромный шаг вперед, но человеческий мозг остался прежним. До сих пор многим нравится раскладывать пасьянсы. В то же время сетевой режим предоставляет столько преимуществ, что грех ими не воспользоваться.

Франц Ланзингер (Franz Lanzinger), Actual Entertainment

Франц Ланзингер - независимый разработчик компьютерных игр с десятилетним стажем, автор известных головоломок Gubble 1 и 2. Теперь он работает с компанией Actual Entertainment и в беседе с нами дал ряд комментариев, которые, на первый взгляд, могут показаться излишне суровыми, но такова, по мнению Франца, правда жизни.

Итак, вот три правила, которые должен соблюдать начинающий разработчик, приступая к созданию логической игры.

Во-первых, ваши головоломки должны быть простыми. Это полезно для начинающих и помогает игрокам быстрее постичь суть игры. Многие разработчики ошибаются, полагая, что их первые головоломки чрезвычайно легки, - это далеко не так.

Франц Ланзингер советует: «Даже если вы абсолютно уверены в том, что игра получилась понятная и доступная, не забудьте испытать ее на детях и тех взрослых, которые редко играют в компьютерные игры». Кадр из игры Gubble. (Приводится с разрешения компании Actual Entertainment, Inc.)

Во-вторых, если уж вам хочется создавать до нелепого сложные задачки, сделайте их выполнение необязательным. К вам все равно будут поступать мольбы о подсказках, но уже не так часто. А еще лучше, включите в игру секретные коды и советы. В конце концов, никто ведь не продает кроссворды без ответов!

В-третьих, где только возможно, используйте саму игру для обучения игроков! Работая над головоломкой Gubble, мы столкнулись с одной проблемой: если наш игрок не научится «летать», он неминуемо застрянет на том уровне, где это умение необходимо. Разработчики часто решают эту проблему так: помещают пояснение в руководство по игре либо вносят в саму игру текст или звуковое сопровождение для обучения игроков. Это приемлемо, но мы нашли вариант получше: для Gubble был создан уровень, целью которого было научить игроков пользоваться клавишей полета и доказать им, что пренебрежение ею грозит им невозможностью добраться до конца игры.

Стюарт Роузмен (Stuart Roseman), nineCo

Компания nineCo, Inc. является создателем популярного сетевого продукта Gainesville, включающего в себя игры The Bingo Zone, Picturama, AceyDeucey, Crystal Ball и многие другие. Стюарт Роузмен, технический директор компании, принял участие в нашей дискуссии о многопользовательских проектах и создании игр в целом.

Мы спросили Стюарта, обязательно ли любая современная игра должна иметь многопользовательский режим? Что он думает о чисто сетевых играх? Сложнее ли их программировать, нежели одиночные игры? Стюарт Роузмен отвечает:

Наши игры - шаг вперед по сравнению с обычными многопользовательскими проектами. Под играми для нескольких игроков часто понимают нечто вроде партии в бридж для двух-четырех человек. Чтобы как-то выделить нашу продукцию, мы назвали свои игры «массовыми сетевыми» и не успокоимся, пока не добьемся того, что в нашу игру смогут играть тысячи игроков одновременно.

Такую толпу гораздо сложнее организовать - для этого требуются другие условия состязания, переключение контекста и оптимизация вычислений, однако и удовольствие при этом намного больше. Почувствовать, что такое «массовая сетевая игра», можно, сразившись в Gainesville через Интернет. Ощущение просто потрясающее. Вы становитесь частичкой человечества, соревнуясь с игроками со всего мира - от русских до филиппинцев, - и благой даря «месту» встречи не можете не чувствовать связь между собой.

По поводу общих принципов создания игр Стюарт замечает, что для успеха игры необходимы два условия: четко представлять себе потенциального покупателя и уделять особое внимание программированию.

Мы с самого начала решили, что наши продукты будут общедоступны. Если вы создаете продукцию для широкой аудитории, старайтесь, чтобы ваши игры были максимально просты и понятны.

Наш девиз: «Чем проще, тем лучше». Мы потратили уйму времени на то, чтобы очистить интерфейс игры от ненужных деталей.

Что касается второго условия, то многие весьма известные компании, разрабатывающие ПО, считают своим долгом выпускать игры, которые используют компьютер на всю мощность, требуя все больше памяти и все более быстрые процессоры, тогда как лучше сосредоточиться на написании более компактных, быстрых и эффективных программ. Это, конечно, непросто, но представьте себе, что вы пытаетесь объяснить последний из своих вопиющих перерасходов памяти парню с мечом, который встретит вас у райских врат!

Стюарт рассуждает о простоте программы E-mercial в продукте Gamesville.

Это как на телевидении - рекламная пауза между играми. В диалоговом окне есть панель управления. На ней расположены две кнопки: «стоп» и «пуск». Вы скажете, что это очень простой интерфейс, но мы решили пойти еще дальше. Мы переделали программное обеспечение, чтобы избавиться от кнопки «стоп». Если вы задумаетесь, то согласитесь, что она совершенно не нужна. В окончательном варианте каждое действие игрока вызывалось кнопкой «пуск». Игроку незачем останавливать программу, поскольку он запускает ее только тогда, когда считает нужным.

Вот общая характеристика игр Gamesville:

Для этих игр не требуется ни загрузки данных, ни мощных и дорогих компьютеров. Все, что вам нужно, - это подключенный к Интернету ПК и мышь. Мы постоянно получаем по электронной почте письма от наших пользователей, в которых они благодарят нас за то, что мы избавили их от необходимости постоянно загружать из Интернета разные программные модули (plug-ins) и прочий «мусор».

И в заключение об игре AceyDeucey:

Это карточная игра, рассчитанная на огромное число игроков. Вам сдают две карты, и вы делаете ставку, пытаясь угадать, какой же будет третья карта. В конце концов, наступает момент, когда надо вычислить, у кого из игроков больше всего очков. Сперва нам казалось, что вычисление должно происходить мгновенно, для чего потребовалось бы задействовать дополнительные сетевые шлюзы и выстроить очередь обработки ходов. Вместо этого мы создали дополнительную вставку «Пожалуйста, подождите, пока мы выберем победителя» - такой забавный ролик с музыкой и графикой, игроки от него в восторге. А всем известно: то, что трудно или почти невозможно сделать мгновенно, становится гораздо легче, когда в запасе есть, скажем, лишние секунд пять.

Симуляторы

Адам Левески (Adam Levesque), Blue Fang Games

Прежде чем оставить знаменитую Papyrus и стать президентом недавно основанной компании Blue Fang Games, Адам Левески работал художником 3D-графики для IndyCar Racing, был продюсером и разработчи-1 ком проектов NASCAR Racing 1 и 2, а также исполнительным продюсером всей продукции Papyrus. Мы спросили Адама, какие три совета он может дать начинающему создателю компьютерных игр в жанре гоночных симуляторов? Вот его ответ.

Определите, для кого вы работаете

Если вы хотите завоевать сердца профессиональных игроков, вам необходимо понимать, чего они хотят. Игра должна быть очень реалистичной. Законы физики, правила гонок (особенно при моделировании реальных состязаний) - все это надо тщательно изучить. Если же вы хотите привлечь на свою сторону случайного игрока, сделайте так, чтобы в игре было просто разобраться, а сама она была не очень сложной. Исходите из того, чтобы дать пользователю легко выиграть. Физические законы здесь будут, по всей вероятности, похожи на те, которые используются в аркадах. Самое важное - максимально снизить риск разочарования.

Тщательно исследуйте вопрос

Изучите гонки, которые вы собираетесь моделировать. Это относится в большей степени к реальным гоночным состязаниям, вроде NASCAR или «Формулы-1». Если же вы изобретаете собственные серии, это не так важно. Но в любом случае вам не помешав знать гоночные правила вдоль и поперек и быть в курсе всех нюансов состязаний: кто считается лучшим гонщиком, какие трасы самые трудные и т.д.

Твердо следуйте поставленным целям

Это справедливо для всех жанров. В начале проекта определите для себя цели и задачи (как правило, не больше пяти), которым должна удовлетворять задуманная вами игра. Убедитесь, что каждый член команды понимает и принимает эти задачи. В дальнейшем при обсуждении кардинальных вопросов, касающихся игры, снова и снова обращайтесь к сформулированным ранее целям и задачам и уже на этой основе принимайте решения.

В качестве примера Адам Левески приводит список задач для проекта NASCAR 2:

Мы поставили следующие цели: а) упростить интерфейс пользователя; б) добавить судью на линии; в) добавить капитана команды; г) сделать оба гоночных дня более реалистичными; д) усовершенствовать графику и довести ее до современных стандартов. Мне кажется, мы ни разу от них не отступили. С каждой из поставленных задач в отдельности мы справились по-разному (особенно это касается гоночных дней), но в общем цели своей достигли.

Смотрел ли Адам другие гоночные симуляторы в процессе создания NASCAR Racing? He говорил ли он себе: «Хм... Я мог бы сделать и получше?» Другими словами, надо ли создателю игры изобретать велосипед или имеет смысл просто улучшать уже имеющиеся наработки? Адам Левески отвечает:

Какую бы игру вы ни делали, вы всегда черпаете вдохновение в уже существующих образцах. Задача состоит в том, чтобы взять их конструктивную основу и интерпретировать ее по-своему. Мне кажется, что любая игра должна иметь свою изюминку. Что с того, если кто-то создал игру, фактически являющуюся копией Need For Speed (ЕА)? Не лучше ли было взять ее за основу, но добавить что-либо необычное? К примеру, заставить все эти спортивные гоночные машины носиться по проселочным дорогам, уворачиваясь от других автомобилей и полиции. Или устроить гонки по улицам крупнейших городов мира. В отношении NASCAR могу с уверенностью сказать, что идея с IndyCar Racing была очень удачной. Мы понимали, что серия NASCAR - не одноразовая игра. Черт возьми, даже такое старье, как Bill Elliott's NASCAR Challenge (не говоря уже о том, что и сама по себе эта игра далеко не блестящая) очень неплохо раскупалось только потому, что это NASCAR. Самое главное для нас в NASCAR было развить успех IndyCar и постараться быть максимально правдоподобными в изображении спортивных состязаний.

NASCAR 2 была сделана в том же ключе. Мы понимали, что в основе игры лежала хорошая тема, и хотели привнести в нее что-нибудь свежее. Я рад, что мы решили добавить в игру судью и капитана команды. Это не просто помощь игроку, у этих фигур есть реальные прототипы, которые играют важную роль в настоящих гонках.

В заключение Адам Левески повторяет, что самое главное - четко обозначить цели игры и неуклонно им следовать. «Ну а кроме того, добавляйте что-то новое в уже существующий жанр. Не переливайте из пустого в порожнее, двигайтесь вперед».

Адам оставил работу в Papyrus и основал собственную компанию, где экспериментирует с различными игровыми жанрами: к примеру, сейчас он трудится над проектом Dragon Hoard, одновременно стратегией и РПГ, где игра ведется «от лица» дракона.

Аллен Джексон (Allen Jackson), Origin Systems

Аллен Джексон, сотрудник Origin Systems с многолетним стажем, работал инженером по программному обеспечению в ряде интересных и неплохо продаваемых игровых проектов, включая серии Crusader и Wing Commander. Он внес свой вклад в главу по программированию (глава 8), а здесь приводится его обширный очерк о создании игр и всех тех трудностях, которые сопутствуют этому нелегкому процессу. Итак, усядьтесь поудобнее и приступайте к чтению.

Инструменты и редакторы

Создание игры включает три основных задачи: проектирование, программирование и художественное оформление. Частенько каждому из участников проекта приходится заниматься понемногу всеми этими вопросами, причем это особенно верно для малочисленной либо ведущей группы разработчиков.

Во всех трех задачах огромную роль играет набор инструментальных средств, применяемых для разработки игры. Программистам необходимо решить, какой компилятор и системный инструментарий они будут использовать (под системным инструментарием понимаются диспетчеры памяти, средства экспорта и библиотеки программ для разработки игры). К примеру, если игра разрабатывается под Windows 95, программист должен быть хорошо знаком с интерфейсом Microsoft DirectX.

В идеале 70% игры должны создавать разработчики. Они формируют данные, которые обрабатываются игровым движком и выводятся игрокам в процессе игры. Все крупные игры должны быть основаны на наборе данных, причем большая часть работы над игрой должна сводиться к использованию стандартного набора редакторов, инструментария и программ экспорта, настроенных на конкретный игровой движок. Самой программе совершенно не обязательно знать что-либо о конкретной игре, она обрабатывает информацию в общем виде, что позволяет игре стать расширяемой и «долгоиграющей».

Следует помнить, что разработчику потребуется определенней алгоритмический язык для создания базовой системы искусственного интеллекта, различных сценариев и меню. Существует множество таких языков, включая Python и JavaScript. Когда разработчики описывают сцену, они используют игровые объекты в последовательности диалогов, которые поясняют какой-нибудь из элементов сюжета на одном из алгоритмических языков. Затем программист претворяет сценарий в жизнь с помощью языка программирования, и игра начинает функционировать. Таким образом программный код может быть изолирован от создания собственно игры.

Программист, участвующий в игровом проекте, должен заниматься многими вопросами. Для связи с операционной системой игре требуется интерфейс нижнего уровня, отвечающий за работу с файлами, видео, звуком и сетью. Такой интерфейс встраивается в программное ядро игры, осуществляющее представление игровых данных пользователю.

Аллен Джексон утверждает, что разработчик не может начинать проект, пока не выяснит, каким инструментарием пользуются программисты. Скриншот из игры Wing Commander: Prophecy. (Приводится с разрешения компании Origin Systems, Inc.)

В настоящее время существует не так уж много приличных приложений для создания игр, поскольку игры очень разнообразны и никому не хочется выпускать похожие продукты. Так как идея игры должна быть как можно более оригинальной, приходится каждый раз заново разрабатывать технологию ее создания. К примеру, если вы вдруг захотите клонировать Quake, то сможете воспользоваться рядом 3D-движков, которые предоставят набор инструментов, предназначенных для создания динамичных шутеров вроде самого Quake. С другой стороны, если вы решите сделать компьютерный футбол, используя тот же движок, программистам придется заново написать инструментарий для этого проекта. Далее, основное программное ядро игры тоже придется несколько переделать, чтобы оно подходило для того жанра, в рамках которого создается новая игра.

Никогда не следует недооценивать художественное оформление игры. Даже для простейшей 2D-игрушки необходим приличный генератор двухмерных спрайтов. Словом, и здесь первостепенную роль играет художественный инструментарий. Было бы весьма удобно, если б такие инструменты предоставляли возможность использовать метки, указывающие на различные оформительские элементы - анимационные кадры, активные точки и команды сценария. К примеру, если художник работает над анимацией ходьбы и хочет поместить в кадр команду «проиграть звук шагов», то возможность сохранить эту команду внутри графического файла значительно ускорила бы разработку и программирование игры. Графический инструментарий должен также обеспечивать возможность создания временных эскизов. Конечно, на фоне общего комплекса задач эта проблема не столь серьезна, но программисту было бы весьма удобно ускорить работу над программой за счет импорта различных графических объектов непосредственно в игру.

При разработке инструментария для игры важно создать промежуточный формат файлов, который позволит в будущем выполнять модернизацию игры и вносить в нее новые элементы. В дальнейшем игровой инструментарий может использовать временные файлы для формирования специальных оптимизированных игровых файлов. К примеру, текущий трехмерный игровой движок, которым пользуются разработчики, позволяет наносить только одну текстуру на многоугольник, но в будущем возможности движка расширятся до нескольких текстур на многоугольник. Труд художников и программистов серьезно облегчится, если графику можно будет экспортировать в промежуточный файл, включающий в себя все текстуры для каждой ячейки. Тогда по мере совершенствования 3D-движка не потребуется переделывать трехмерную графику для реализации дополнительных возможностей.

Суть игры и ваша аудитория

В основе любого развлекательного продукта, будь то фильмы, телесериалы, книги, игры или аттракционы, лежит некая основная идея, его суть, делающая продукт интересным. Правильный выбор этой идеи очень важен для игры. Игрок будет проводить за экраном не один час, поэтому он должен сразу понять и полюбить главную идею игры, ее правила и основной сюжет.

Прежде всего создателю игры следует задуматься, для какой аудитории она предназначена. Развитие структуры игры ведется таким образом, чтобы привлечь максимально возможное число потребителей и в то же время сохранить стержень проекта.

Чтобы изучить влияние аудитории, сравним две игры с одинаковыми предпосылками, но различной реализацией. В Diablo и Fallout есть главный персонаж, с помощью которого игрок взаимодействует с вымышленным миром. Поклонников Diablo привлекает динамичность игры. Им нравятся простые в освоении игры с непрерывным действием и возможностью играть через Интернет. Diablo - экшен-игра с динамичной анимацией и сюжетом, основанная на интуитивном интерфейсе; ее действие происходит в подземельях, создаваемых случайным образом. Когда тролли, гоблины и горгульи врываются в пещеру, которую исследует игрок, ему достаточно щелкнуть монстра мышью, чтобы атаковать его. Система снаряжения упрощена за счет снятия ограничений на максимально допустимый вес и отказа от всяких сложностей вроде вложенных друг в друга рюкзаков. Игрок размещает предметы на простой сетке. Если какой-либо предмет не помещается на сетку, это значит, что персонаж не может держать его у себя.

А вот почитатели Fallout уделяют больше внимания персонажам и развитию сюжета; игра протекает неторопливо, спокойно, и через Интернет в нее играть невозможно. Разработка такой игры основывается на характеристиках и свойствах персонажей, а также на общем сюжете игры и элементах виртуального мира, который исследует игрок. Хотя интерфейс у этой игры тоже не отличается сложностью, число способов взаимодействия игрока с виртуальной реальностью гораздо больше и они куда разнообразнее.

Обе игры очень хороши, и вполне возможно, что один и тот же пользователь будет с удовольствием в них играть, находя в каждой что-то привлекательное для себя. Но несмотря на то что они весьма похожи, а интерфейс использует одни и те же действия мышью, каждый проект преследует свою цель. Следует помнить, что многочисленные элементы игры ни в коем случае не должны портить изначальный замысел.

Игра с самого начала должна быть захватывающей. Нельзя допустить, чтобы игрок страдал в ожидании момента, когда ему наконец будет дозволено получить порцию развлечения. К примеру, если вы создаете военную игру, посвященную танковым боям, не нужно заставлять игрока проходить службу в лагере для новобранцев или отправлять его на учения только ради реализма. В игру необходимо вносить обучающие уровни и инструкции, с помощью которых игрок совершенствует свое мастерство, но абсолютно незачем обязывать его проделывать скучную последовательность рутинных действий.

Некоторые элементы игры надо проработать сразу, чтобы избежать серьезных проблем на следующих этапах проекта. Если в игру планируется включить сетевые возможности, основной механизм игры должен это позволять. Если игра предполагает использование джойстика как основного устройства управления, надо продумать интерфейс, который позволяет обойтись без этого приспособления, а вместо него подключать клавиатуру или мышь. При подобном подходе после окончания проектирования игры программирование и разработка данных потребуют гораздо меньше усилий.

Внешний вид игры

При создании игры важно хорошо продумать, какими будут игровые меню, звуковое оформление и графика. Первоначальное представление должно быть динамичным и простым; не стоит перегружать его специальными эффектами, замедляющими разворачивание действия. Например, если нажатие кнопки меню вызывает другое меню с потрясающей анимацией, но на это уходит около двух минут, то от потрясающей анимации придется отказаться.

Очень важно выбрать подходящий графический движок. Осмелюсь утверждать, что двухмерная графика еще не умерла. Если в процессе игры по экрану бегают двухмерные спрайты, это не так уж и плохо. Раскрою «секрет»: многие игры основаны на 2D-спрайтах, в том числе такие хиты, как Crusader, Ultima Online, Fallout, Diablo, Civilization 2 и StarCraft. Двухмерные спрайты выглядят, как трехмерные, но они представляют всего лишь двухмерное спрайтовое воспроизведение трехмерного объекта.

Видеоплаты с аппаратными 3D-ускорителями в персональных компьютерах появились не так давно. И некоторые игровые жанры в буквальном смысле слова расцвели с введением этой технологии - Thief: Dark Project, Tomb Raider, Wing Commander: Prophecy, Quake... Следует добавить, что уже написано немало хороших трехмерных движков, которые используют все преимущества драйверов OpenGL, Glide и DirectX.

Внешний вид игры - это еще и ее звуковое оформление. Яркие аудиоэффекты, правильно подобранная музыка - все это играет немаловажную роль в представлении игры. Выбор графического движка - ответственный шаг, а вот для работы со звуком, если, к примеру, вы трудитесь в Windows 95, единственным выбором является DirectSound. Это не означает, что звуковая технология менее важна, чем графическая. Грядет следующее поколение трехмерных звуковых плат, и спустя некоторое время аудиоплаты ISA совсем исчезнут из употребления.

Работая над внешним видом игры, уделите особое внимание сильным сторонам вашей команды. Если ваши художники способны рисовать только 2D-спрайты, постройте игру на их основе. А если в группе есть специалист по звуку, который к тому же сочиняет музыку, не бойтесь потратить дополнительное время и усилия на создание выразительного музыкального оформления, которое значительно оживит игру. Не забывайте и о «пристрастиях» своих программистов: если у них есть опыт работы с сетями, включите в проект игры многопользовательские возможности.

И последнее замечание, касающееся представления игры. Не делайте интерактивных видеороликов. Если игра в них не нуждается, любительские видеовставки скорее наскучат пользователю, чем развлекут его.

Аллену Джексону были заданы еще два вопроса: нужно ли начинающим разработчикам покупать лицензию на уже существующий игровой движок или стоит создавать собственный? Возможно ли в принципе сделать игру при полном отсутствии денег? Аллен отвечает на эти вопросы по порядку.

Лицензионные игровые движки

Мой совет тем, кто просто хочет сделать игру: используйте существующие трехмерные разработки. Может быть, вашему программисту интереснее построить собственный ЗВ-движок, но следует помнить, что задача эта не из легких. Сказать по правде, без достаточно серьезного опыта работы с трехмерной математикой и сложной архитектурой программирования создание трехмерной структуры превращается в независимый проект - такого огромного зверя не одолеть в одиночку.

Для начала посетите веб-страницу www.cg.cs.tu-berlin.de/~ki/engines.html. Большинство представленных там 3D-движков бесплатные, а некоторые даже приводятся вместе с исходным текстом программы. На сегодня почти все 3D-движки «заточены» под эффективную передачу последовательностей многоугольников и текстур в 3D-видеоплату. Можно также подыскать программы для звука и графики, которые упростят и ускорят процесс создания игры. На том же веб-сайте, кстати, вы найдете множество советов по работе с трехмерными приложениями.

Что делать, если нет денег

Если у вас уже есть компьютер, компилятор и доступ к Интернету, вам вовсе не обязательно тратить деньги на что-либо еще. Хотя вполне возможно, что вам захочется приобрести уже существующий «конструктор игр». Многие игровые компании покупают трехмерные разработки у внешних производителей. Почему? Все просто: фирмы-разработчики вложили в свои технологии уйму времени и средств, гарантируя определенное качество, и если оно вас устраивает...

«И наконец, - говорит Аллен Джексон, - если фирма-разработчик выпустила ряд неплохих редакторов и вспомогательных приложении, приступить к созданию самой игры вам будет значительно легче».


Создание персонажей, эскизов и проектной документации

Глава 4

Создание персонажей, эскизов и проектной документации

Лара Крофт. Марио. Соник. Пэкман. Червяк Джим. Крэш Бандикут. Неудачник Ларри. Дюк Ньюкем.

Что общего между этими словами? Ответ прост: это имена, известные всем и каждому, хотя принадлежат они вовсе не голливудским киноактерам или телезвездам. Нет, это не персонажи субботних мультсериалов (хотя некоторых из них уже можно встретить и там) и не новинки из царства Барби и Кена. Все они - герои компьютерных и консольных игр, звезды интерактивных экранов, чей маркетинговый потенциал долгие годы помогал им оставаться на устах у публики и наполнять деньгами карманы своих создателей.

Многие разработчики и издатели пытались создать очередного игрового кумира, который принесет им миллионы долларов, но одного лишь броского имени и симпатичной мордашки героя недостаточно. Так в чем же секрет? Эта глава, словно губка, впитала в себя мудрые мысли авторов многих из упомянутых выше персонажей. Однако это далеко не все, о чем мы собираемся здесь рассказать.

Если бы мы попытались сформулировать общую тему этой главы, она прозвучала бы так: как записывать свои идеи. Некоторые разработчики предпочитают выполнять на бумаге эскизы персонажей или игровых экранов (или нанимают для этого художников). Другие создают серии последовательных набросков, помогающие им выработать концепцию и сюжетные линии игры. Наконец, третьи пишут целые литературные произведения или постановочные сценарии (обычное дело для квестов или ролевых игр, изобилующих диалогами). Проектная документация - это, как правило, длинные бумажные отчеты, создаваемые для того, чтобы полностью представить план игры, описать все ее возможности, элементы сюжета, персонажей, место действия, диалоги, загадки, графические элементы, звуковые эффекты, музыку и многое другое. Обычно эти документы создаются в виде модулей, чтобы потом их легко было изменять, если проект игры трансформируется.

В этой главе рассказывается о том, как проходило рождение некоторых из самых известных персонажей мира игр. Кроме того, разработчики и художники поделятся с нами секретами создания сюжетов, эскизных набросков, сценариев и проектной документации, позволяющих вдохнуть жизнь в игру, программная реализация которой еще даже не начата.

Эл Лоуи (Al Lowe), Al Lowe Associates

В 1982 году Эл Лоуи начал разрабатывать игры для компании Sierra On-Line, а пять лет спустя предложил миру персонаж милого неудачника Ларри (Leisure Suit Larry). На основе этого сверхуспешного образа было создано восемь игр, последняя из которых, Leisure Suit Larry's Casino, выпущена в 1998 году.

Мы спросили Эла Лоуи, что он может посоветовать тем, кто хочет создать такой же удачный персонаж, как Ларри. Он ответил:

Нужно четко представлять себе своего героя. Подробно опишите его, конкретизируя черты его характера, его надежды и мечты, раскрывая сильные и слабые стороны его личности и так далее. (Разумеется, ничем подобным я не занимался, когда работал над Ларри. Наоборот, я придумывал его образ по мере создания игры. Но посмотрите, каким он получился!)

Откуда же Эл Лоуи черпал вдохновение для создания этого героя?

Какое там вдохновение! Я должен был сделать игру за шесть месяцев, не имея ничего, кроме предполагаемого места действия и нескольких примитивных головоломок. Это было не вдохновение, а неподдельный страх!

Могу рассказать об этом подробнее. В конце 1986 года я почувствовал, что настало время для создания совершенно новой игры. Мне казалось, что она должна быть связана с какой-нибудь темой, интересной взрослым, но в то же время не должна утратить забавности. В то время любая компьютерная игра была чрезвычайно серьезна: нужно было спасти либо принцессу, либо целую галактику. И все это происходило в фантастической обстановке: в средние века, на других планетах... Я подумал, что мир уже готов к появлению СМЕШНОЙ игры, действие которой происходит в наши дни с современными людьми. По мере того как я разрабатывал игру, складывался образ неудачника Ларри. Был ли у него прототип в реальной жизни? Нет, за основу был взят этакий тип простака, хорошо известный всем и каждому. (Ну... если честно, был один парень - работал у нас коммивояжером по продаже программ...)

Когда Эл Лоуи создавал Ларри, он хотел получить персонаж, над которым люди могли бы посмеяться. Но самой сложной задачей было сделать героя, знакомого каждому игроку. Именно это равновесие и принесло успех вечному неудачнику Ларри. (Приводится с разрешения компании Sierra On-Line.)

Эл Лоуи отметил, что очень важно делать эскизные наброски главного героя, прежде чем садиться за написание игры.

Не получается? Значит, вы не до конца все продумали. Если вы не в состоянии отобразить персонаж на бумаге, как кто-либо другой сможет догадаться о том, что вы предлагаете? Каждая игра, созданная мною (по крайней мере, начиная с тех, которые я уже не «делал полностью сам, включая рисунки»), имела свою собственную «библию», содержащую информацию обо всем, что есть в этой игре. Единственным исключением были диалоги: я писал их по мере продвижения вперед программистов и художников.

Делались ли сюжетные эскизы для первой игры про Ларри?

В некотором роде. Первая игра про Ларри была основана на текстовой игре Softporn, которую компания Sierra опубликовала еще в доисторическую для домашних компьютеров эпоху (1980). Sierra хотела получить обновленную, чисто графическую версию этого сюжета. После внимательного изучения я понял, что просто не смогу сделать этого. Представьте себе: игра без главного героя, да к тому же с отвратительным текстом! Там вообще очень прямолинейно подходили к заданию: целью игравшего было «соблазнить трех цыпочек». Это была настолько топорная работа, что мне оставалось только одно: сделать пародию. Поиздеваться. Позубоскалить. Так что героя я подобрал - нелепее некуда. Он абсолютно не подходил на роль донжуана, Ларри ведь до сих пор носит костюмы, вышедшие из моды несколько десятков лет назад...

Ну так возились ли мы с эскизами? Нет. Вдвоем с Марком Кроуи (Mark Crowe) мы определяли все необходимые сюжетные элементы для конкретной сцены. Он рисовал их, а я программировал. Затем я писал диалоги, соответствующие каждой сцене.

Все остальное, как говорится, уже история.

Не пропустите следующую приключенческую игру из серии Leisure Suit Larry, названную Lust in Space, которая выйдет в 2000 году. А пока поклонники серии могут посетить огромное число посвященных Ларри веб-страниц, начиная с www.sierrastudios.com/games/larry/links.html.

Тоби Гард (Toby Gard)f Confounding Factor

Тоби Гард является художественным руководителем недавно созданной компании Confounding Factor, но большинство игроков знают его по работе в студии Core Design, где он прославился как разработчик игре Tomb Raider и создатель неповторимой Лары Крофт.

Тоби говорит, что работая над образом главного героя, необходимо добиться того, чтобы он прежде всего нравился самому создателю. Тогда и у других людей будет шанс полюбить этот персонаж. Далее он поясняем:

Если вы не уверены, нравится ли вам созданный образ, откажитесь от него. Если постоянно экспериментировать, рисовать без какой-либо конкретной цели и при этом в довольно свободной форме развивать понравившиеся идеи, то в определенный момент у вас может получиться что-нибудь удачное, причем вы сразу же это почувствуете. Тогда вы обнаружите, что сами полюбили свой персонаж, и это будет путеводной звездой в последующей работе над ним, когда на основе ваших рисунков герой приобретет собственную индивидуальность. Я думаю, что это действительно так - необходимо создавать и пересоздавать образ снова и снова, пока это возможно. Затем просто нарисуйте его еще сотню раз (для удовольствия) - и вы достигнете желаемого. Такой метод я и использую.

Тоби Гард утверждает, что выигрышный персонаж начинает обретать форму и индивидуальность только после многочисленных экспериментов. (Использовано с разрешения компании Eidos Interactive.)

Мы спросили Тоби Гарда, есть ли у него какие-нибудь конкретные рекомендации, которые можно использовать при создании популярного героя, подобного Ларе Крофт?

Сделайте персонаж простым и понятным, загляните в комиксы, если хотите увидеть, как это работает. Ваши рисунки должны быть своего рода произведениями изобразительного искусства: четкий, запоминающийся силуэт и хорошо подобранная цветовая гамма. Приведу пример: серый, черный и желтый цвета - это Бэтмен. Яркий контраст и незамысловатые очертания. Как бы вы его ни рисовали, он всегда будет Бэтменом, поскольку герой так стилизован, что является эмблемой самого себя.

Сотворите что-нибудь из ряда вон выходящее. Почти все можно перевернуть с ног на голову без ущерба для работы. Помните, большинство людей тошнит от вида одних и тех же персонажей, так что смело нарушайте правила.

Если хотите, чтобы игроки заинтересовались вашим персонажем, вы сами должны относиться к нему с уважением. Он должен иметь качества, достойные восхищения, и быть тем, кем вы сами были бы не прочь стать на пару часов.

В этом-то и состоит вся суть, верно?

Сигеру Миямото (Shigeru Miyamoto), Nintendo

Сигеру Миямото - живая легенда индустрии интерактивных развлечений. Он является «отцом» известных всему миру Марио и Линка. Как же ему удалось создать столь знаменитых и горячо любимых электронных героев? Господин Миямото считает, что в конечном счете все мастерство разработчика игр сводится к одному: постоянно помнить, что игра должна быть увлекательной.

Наша единственная цель - увлечь игрока, и мы делаем все от нас зависящее, чтобы ее достичь. Работа над персонажами - просто один из шагов в этом направлении. Если бы игры с Марио не были увлекательными, этот персонаж не стал бы популярным.

Сигеру Миямото также предупредил, что разработчикам может быть трудно объективно предсказать, каким окажется первое впечатление пользователя при знакомстве с новой игрой, потому что они сами слишком тесно связаны с проектом.

Самое главное, говорит Сигеру Миямото, - это чтобы с такими персонажами, как Линк было интересно играть. Это кажется очевидным, но почему же тогда компьютерные и консольные игры переполнены тусклыми персонажами! (© Nintendo, 1998. Опубликовано с разрешения Nintendo of America, Inc.)

Дэвид Перри (David Perry), Shiny Entertainment

Дэвид Перри, знаменитый разработчик и президент компании Shiny Entertainment, дал жизнь целому ряду популярнейших персонажей. К ним относятся главные герои игр Earthworm Jim, MDK, Wild 9, Messiah и др.

Мы обратились к Дэвиду с просьбой поделиться с нашими читателями самыми ценными (или, лучше сказать, бесценными) советами относительно того, как создать хороший игровой персонаж. Над его ответами стоит поразмыслить...

1. Чувство юмора. Без него никуда. Самый легкий способ сделать героя привлекательным - сделать его смешным. Неплохо также добавить к его портрету какие-нибудь уникальные способности. Костюм Червяка Джима, к примеру, использует хозяина в собственных целях. Подобные забавные штучки наделяют созданных вами персонажей особым шармом.

2. Кто-то однажды сказал, что по-настоящему хороший персонаж узнается по одному силуэту. Если вашего героя можно узнать по тени, которую он отбрасывает, то вы проделали действительно стоящую работу.

3. Не забудьте также включить в арсенал героя побольше новых и интересных видов оружия. Нет ничего хуже, чем выходить на серьезное задание, имея в запасе лишь водяной пистолетик. Огневая мощь - это хороший способ доставить радость игроку.

И последний вопрос: насколько важны сюжетные эскизы игры? Дэвид считает, что это зависит от конкретных обстоятельств. «Эскизы задают направление и скорость развития игры, но в конечном счете все сводится к тому, как вам в нее играется. Это неплохая отправная точка, но полностью полагаться на них не стоит. То, что годится для кино, не всегда подходит для компьютерных игр».

Множество ликов Дэвида Перри. Запоминающиеся персонажи из Earthworm Jim, MDK и Messiah появились на свет благодаря тому, что Дэвид всегда твердо придерживался трех своих правил. (Приводится с разрешения компании Shiny Entertainment, Inc.)

Джордж Бруссард (George Broussard), 3D Realms

Джордж Бруссард - президент и совладелец компании 3D Realms. Эта студия, занимающаяся разработкой компьютерных игр, пользуется огромной популярностью. Именно здесь возник сериал Duke Nukem. Сейчас 3D Realms работает над четвертой игрой в этой серии под названием Duke Nukem Forever (или шестой, если считать лицензированные версии для игровых приставок PlayStation и Nintendo).

Что может посоветовать Джордж Бруссард тем, кто мечтает о создании удачного компьютерного персонажа?

Собственно, все зависит от типа персонажа, над которым вы работаете. Наши герои обычно несколько гротескны - с такими скорее можно встретиться в комиксах или фильмах-боевиках, нежели в реальной жизни. Для их создания всегда найдется какая-нибудь зацепка.

По Бруссарду, любой персонаж можно разложить на следующие составляющие:

• Личностная характеристика. Этот параметр определяет личность героя и то, как он реагирует на обстоятельства.

• Внешность. Ваш персонаж должен выделяться среди других, чтобы люди узнавали его уже по изображению. Примеры: Лара Крофт, Супермен (вообще любой супергерой из аналогичных сериалов), Дарт Вейдер.

• Мотивы. Почему ваши герои поступают именно так, а не иначе? Что ими движет? Когда мотивы героя определены, его поступки соответствуют ожиданиям игрока. Это делает созданный вами образ более жизненным.

• Ключевая фраза. Лучшие персонажи приобрели известность благодаря простой ключевой фразе. Она застревает в голове и фактически становится частью языковой культуры породившего ее общества. Вспомните рекламу ресторанчиков Andy's со знаменитым «Где же мясо?» (в качестве русского аналога этой крылатой фразы можно привести наше «Я не халявщик, я партнер!» - Примеч. перев.). Примеры: «В чем дело, док?» (Багз Банни), «Вверх, вверх и в сторону!» (Супермен), «Замечательные гранаты, Бэтмен!» (Робин), «Я вернусь!» (Терминатор), «Вперед, доставьте мне радость» (Грязный Гарри).

• Имя. Имя персонажа должно быть оригинальным и хорошо запоминающимся, таким, чтобы с ним сразу ассоциировался образ его носителя. Помочь вам в этом может рифма и звукопись. Примеры: Дюк Ньюкем, ежик Соник, Червяк Джим.

Чтобы проиллюстрировать свою систему, Джордж Бруссард приводит три замечательных примера.

Попробуйте угадать, о ком идет речь до того, как будет названо имя, просто по основным характеристикам.

Личностная характеристика: эгоист.

Внешность: темные очки, красная майка, нагрудный патронташ, светлые, коротко остриженные волосы.

Мотивы: бить морды инопланетянам и развлекаться с девочками.

Ключевая фраза: «Ну что ж, приступим...»

Имя: Дюк Ньюкем.

Дюк Ньюкем - один из немногих игровых персонажей, которому удалось стать кинозвездой и детской игрушкой. (Использовано с разрешения 3D Realms, Inc.)

Личностная характеристика: решительный, любознательный одиночка.

Внешность: черный костюм, белая рубашка, галстук, мобильный телефон.

Мотивы: агент ФБР, раскрытие заговоров.

Ключевая фраза: «Истина где-то там».

Имя: Фокс Малдер («Секретные материалы»).

Личностная характеристика: ленив, хитер, самовлюблен, мягок в обращении.

Внешность: средних лет, седоволос.

Мотивы: космический исследователь, уклоняющийся от выполнения своего долга и наносящий вред.

Ключевая фраза: «Ой, больно!».

Имя: доктор Смит («Затерянные в космосе»).

Джордж Бруссард говорит: «Такие досье на персонажей - не более чем отправная точка. Личность героя можно сделать более или менее сложной, в зависимости от того, к чему вы стремитесь. Однако все перечисленные параметры должны быть определены, если вы хотите, чтобы ваш персонаж стал действительно запоминающимся».

Вернемся к художественному оформлению игры. Как соотносятся первоначальные эскизы с реальными персонажами? Считает ли Джордж, что они необходимы для такой игры, как тот же Duke Nukem?

Поскольку оформление игр становится все более и более сложным, мы стараемся при разработке пользоваться теми же методами, что применяются в кино. Большинство современных игр, подобно фильмам, основаны на сценарии, где подробно описаны все события, видеовставки и диалоги. Другим заимствованием является идея концептуальных набросков. Эти эскизные зарисовки служат для того, чтобы определить внешний вид и обозначить ощущения, вызываемые элементами игры, такими, как персонажи, место и последовательность действий.

Старая поговорка «Лучше один раз увидеть, чем сто раз услышать» актуальна и сейчас.

Концептуальный набросок для персонажа по имени Гас из игры Duke Nukem Forever. Рядом - игровая реализация. Наброски дают художникам, создающим трехмерные модели, четкое представление того, что нужно сделать. (Использовано с разрешения 3D Realms, Inc.)

Помните эту нашумевшую видеовставку из игры Duke Nukem 3D? Джордж Бруссард предоставил нам оригинальную серию эскизных набросков к ней. (Использовано с разрешения 3D Realms, Inc.)

Здесь приведены предварительные эскизы двух локейшенов из игры Duke Nukem Forever, с нетерпением ожидаемой армией поклонников. (Использовано с разрешения 3D Realms, Inc.)

А как насчет проектной документации? Считает ли Джордж Бруссард, что она необходима для игр всех жанров?

Что ж, поговорим о проектной документации. В игре Duke Nukem 3D не было ничего подобного. Мы придумывали новое по мере того, как продвигалась работа над проектом - добавляли удачные детали, отказывались от пустых идей. Посмотрите, что получилось. Начинали же мы с довольно расплывчатой идеи, что действие игры будет происходить в будущем, в полуразрушенном Лос-Анджелесе. Все остальное пришло в процессе создания.

В случае с Duke Nukem Forever бумажной работы было значительно больше: эта игра имеет весьма серьезный объем, а ее части более тесно связаны друг с другом. Однако разработчики, исписывающие сотни страниц, прежде чем приступить к проекту, тратят время попусту. Работа над игрой - это, как правило, эволюционный процесс. Вы постоянно что-то улучшаете и переделываете, учитесь на своих ошибках, постепенно продвигаясь к совершенству. Глупо сначала писать длиннющий план, а затем неукоснительно ему следовать. Масса интересных идей приходит в голову только тогда, когда вы уже стартовали. Необходимо обладать достаточной гибкостью, чтобы начинать проект без длительной подготовки, добавляя и развивая идеи в ходе работы по намеченному графику.

Исходя из нашего опыта, проектная документация - это просто общее руководство, которое модифицируется по мере того, как мы продвигаемся вперед. Это просто попытка распланировать действия на ближайшие три-четыре месяца. Окончательно документ бывает завершен только вместе с самой игрой.

Не забывайте также, что трехмерные шутеры не так уж и сложны. Все, что там есть, - это «плохие парни», оружие и другие полезные вещи, а также планы уровней. Это совсем не космические технологии, требующие сотен страниц описания.

Обязательно прочтите все материалы, относящиеся к игре Duke Nukem, на веб-сайте компании 3D Realms (www.3drealms.com).

Джейн Дженсен (Jane Jensen), Sierra On-Line

Работая в Sierra On-Line, Джейн создала одного из самых известных игровых персонажей, чье имя неразрывно связано с этой уважаемой компанией, - Габриэля Найта. У нее уникальный опыт в написании сценариев для квестов (многие из которых удостоены различных наград). В этой главе вы познакомитесь с ее мнением о создании персонажей и квестовых сюжетов.

В какой бы области вы ни трудились, будь то компьютерные игры, кино или театр, работа над собственно сценарием меняется мало. Конечно, я всякий раз стараюсь определить происхождение каждого персонажа и движущие им мотивы, а потом вношу в первоначальный образ изменения, продиктованные самим сюжетом.

Обычно я довольно жестко контролирую образы своих героев в процессе разработки. Просматриваю эскизы, сама пишу диалоги и участвую в подборе актеров для озвучивания. Это очень важно, если вы хотите, чтобы персонаж получился удачным. Кроме того, существуют трудности и преимущества, связанные со взаимодействием персонажа и игрока. С одной стороны, если ваш персонаж интерактивен, вам приходится проделывать массу дополнительной работы, придумывая и осуществляя реакцию персонажа на совершенно не относящиеся к делу предметы, вроде двери или лупы, валяющейся поблизости. Кроме того, вашему герою придется вести множество ни к чему не обязывающих диалогов. С другой стороны, эти дополнительные детали, не относящиеся непосредственно к сюжету, помогают получить более естественный, живой образ. В книгах и фильмах, где вы постоянно следите за событиями, часто гораздо труднее добиться подобного эффекта.

Игры серии Gabriel Knight, должно быть, требовали немалой предварительной работы, массы эскизов? «Мы делали эскизы для больших сцен - из художественных соображений, - отвечает Джейн, - когда это было необходимо, чтобы правильно выполнить анимацию и определить место воображаемых камер. Но в большинстве случаев эскизов не было». Как же в таком случае удалось скоординировать все сцены?

Процесс разработки происходил примерно так: прежде всего я писала так называемую «библию» игры. Обычно она занимает около сотни страниц, и у меня уходит на эту работу месяцев пять. В ней расписаны все сцены и то, что в них происходит. Здесь же и основные головоломки, вроде карты сокровищ в Gabriel Knight III, однако множество мелких задачек придумывается позже.

Затем команда изучает этот документ и вносит необходимые изменения. В это время я занимаюсь «инвентаризацией местности» - расписываю все декорации, мизансцены, определяю, какого рода анимация понадобится в данном конкретном месте. Это нужно для художников, занимающихся фоновыми декорациями игры. После этого я приступаю к сценарию. Мы пользуемся на этом этапе собственной программой, которая напоминает базу данных Microsoft Access. Для каждого эпизода игры, независимо от размера и значимости, заводится отдельная запись. Записи проиндексированы следующим образом: предмет - связанное с ним действие - дополнительные обстоятельства - порядковый номер. К примеру, для места действия КУХНЯ вы можете найти запись ПЛИТА СМОТРЕТЬ ВСЕ 1 - «Это плита». Еще примеры:

ТРУБА ЗАЛЕЗТЬ НЕТ_ВЕРЕВКИ 1 «Как же это сделать?»

ТРУБА ЗАЛЕЗТЬ ЕСТЬ_ВЕРЕВКА 1 «Можно попробовать...»

ТРУБА ВЕРЕВКА ПЕРВЫЙ_РАЗ 1 «Можно попробовать...»

ТРУБА ВЕРЕВКА ПЕРВЫЙ_РАЗ 2 <Габриэль берет веревку и забрасывает ее на трубу.>

ТРУБА ВЕРЕВКА ПЕРВЫЙ_РАЗ 3 <Габриэль взбирается по веревке. ПЕРЕЙТИ К: Крыша>

ТРУБА ВЕРЕВКА ДРУГОЙ_РАЗ 1 «Мне незачем возвращаться туда.»

Таким образом, любой интерактивный элемент раскладывается на условия осуществления (что и при каких обстоятельствах вызывает данную реакцию героя), словесную реакцию (отдельную реплику или диалог) и описание действий героя (для художников-аниматоров и программистов).

Когда фоновые декорации готовы, я добавляю к сценарию «комментарии по случаю» - они используются по команде СМОТРЕТЬ, это просто краткие описания тех предметов, которые художники включили в декорации без моего ведома (некоторые предметы, впрочем, приходится убирать: они слишком прямо намекают на решение задачи или, наоборот, запутывают дело).

При озвучивании игр база данных Джейн Дженсен выводит текст для актеров, озвучивающих персонажи (на этом снимке запечатлен актер Дин Эриксон (Dean Erickson)), или для записи голоса за кадром. (Приводится с разрешения компании Sierra On-Line, Inc.)

Джейн рассказывает, что многие просто не понимают, как заставить игру общаться с игроком. Ей случалось бывать на конференциях, где профессионалы из Голливуда прямо утверждали, что это невозможно. Она объясняет, почему возникают подобные сомнения.

Причина в том, что обычный сюжет по природе своей линеен. Меня часто спрашивают, где же в Gabriel Knight (GK) хваленые «множественные концовки»? Ответ прост. Реальный сюжет имеет естественное развитие и вполне естественный финал. Если бы в GK I я, к примеру, решила умертвить главного героя или оставить в живых злодея, игрокам вряд ли бы это понравилось. Более того, в GK I была неправильная концовка, где герой погибает. Игроки инстинктивно понимали, что «здесь что-то не так», а значит, где-то была допущена ошибка. Мне даже приходили письма, где говорилось: «Я дошел до неправильной концовки, но потом начал заново и дошел до настоящей». Возьмем, к примеру, сцену с ключом. У нее несколько возможных финалов, но большинство выглядит довольно подозрительно. «Настоящий» конец - только один. Из-за всех этих ухищрений, обеспечивающих нелинейность сюжета, игра становится похожей не столько на кинофильм, сколько на нагромождение отвлекающих маневров.

Другая проблема - это естественная линейность повествования. Габриэль не может выступить против своей госпожи до тех пор, пока не узнает о ее злодеяниях. А у той нет повода угрожать жизни Габриэля, пока он не стал ее противником. Соответственно, у нашего героя нет причин для ответных угроз. И так далее... Сюжет - это цепь стимулов и реакций, причем чем дальше, тем сильнее действие зависит от того, что ему предшествовало. Как же сделать его интерактивным?

Выход - в старом принципе «жемчужного ожерелья», им как-то поделилась со мной Роберта Вильяме, когда мы вместе работали над игрой King's Quest VI. Идея состоит в том, чтобы представлять себе каждый ключевой момент в игре как перемычку между жемчужинами. Она фиксирована. Это может быть начало игры или любого самостоятельного отрезка - назовем его главой. В этот момент вы знаете, где находится ваш герой и что ему известно, и разворачиваете очередной фрагмент сюжета. Далее начинается «широкая часть» жемчужины. Игрок может пройти через несколько маленьких сценок или совершить ряд действий - неважно, будет ли их три, восемь или пятнадцать - причем в любом порядке. Когда он прошел все (или по крайней мере те, что являются необходимыми для перехода к новому фрагменту, так как некоторые моги оказаться необязательными), игра фиксирует этот факт и возвращается к основной линии сюжета: завершает фрагмент и выдав новую порцию информации, переходя к следующей «жемчужине».

Рассмотрим теперь пример, предложенный Джейн:

Первая часть GK II начинается с того, что жители деревни Риттерсберг приходят к Габриэлю с просьбой помочь в охоте на оборотня, якобы убившего молодую девушку. В этот момент я знаю, где находится игрок: игра только начата, и ему еще ничего не известно. Сцена поэтому очень проста - как любое вступление к фильму или книге. Наконец, она завершилась: Габриэль в доме, где живут родители убитой девушки. Теперь начинается «интерактивный» период. Игрок передвигает героя, изучая обстановку. За это время Габриэлю (вернее, вам - его руками) предстоит сделать следующее:

• Прочитать заметку в газете, где говорится, что в убийстве подозревают волков, сбежавших недавно из местного зоопарка, а также указано имя детектива, расследующего это дело.

• Написать и отправить письмо помощнику.

• Изучить место преступления на ферме, сделать слепок с отпечатка лапы, похожей на волчью, подобрать клок звериной шерсти.

• Отправиться в зоопарк и рассмотреть волков в вольере. Расспросить парня, который кормит животных, и смотрителя зоопарка. Пробраться внутрь, рассмотреть волка вблизи и подобрать клок его шерсти, чтобы сравнить с первым.

• Пойти в полицейский участок и попросить о встрече с детективом.

• Отдать на анализ в лабораторию образец волчьей шерсти, а также шерсть и отпечаток лапы, найденные на месте преступления.

• Встретиться с семейным адвокатом и попросить его перевести найденный текст на немецком языке.

• Проследить за посетителем зоопарка до мужского клуба и найти способ пробраться внутрь.

«Это, конечно, сильно упрошенный вариант, - говорит Джейн, - но на этом примере можно увидеть, какие эпизоды обязаны следовать друг за другом, а какие нет». Подробнее рассматривая приведенный фрагмент игры, Джейн Дженсен развивает аналогию с жемчужным ожерельем:

Габриэль не может побывать в зоопарке, пока не прочитает о нем в газете. Однако все его действия, связанные с зоопарком, никак не зависят от похода в полицейский участок или отправки письма помощнику. Разумеется, лабораторный анализ улик с места преступления мало чем может помочь герою, пока он не достал «контрольный» клок волчьей шерсти, однако ничто не мешает Габриэлю провести его. К адвокату можно зайти в любое время; но если вы хотите, чтобы он перевел вам записку, ее нужно сначала найти. Можно также побывать в зоопарке и сделать там все, что от вас требуется, но так и не обнаружить шерсть и отпечаток лапы на месте преступления. И так далее... В конечном счете все эти дорожки приведут вас в мужской клуб, но вас туда не пустят, пока вы не сделаете всего, что от вас требуется в рамках текущей «жемчужины». Это просто: подойти к клубу можно в любое время, после того как вы проследили за человеком из зоопарка, а адвокат перевел вам записку, где указано его название. Однако швейцар не пропустит вас внутрь, пока не получит бумаги, подтверждающие ваше происхождение. Документы можно взять у адвоката, но он говорит вам, что секретарь должен сначала найти их и сделать ксерокопии. Вы можете заходить к адвокату сколько угодно раз, но пока не напишете помощнику, не зайдете в участок и прочее, бумаг не будет. Когда, наконец, вы будете готовы к новым приключениям, адвокат выдаст вам документы, и вы сможете пройти в клуб. И в этот момент (когда Габриэль протягивает бумаги швейцару) я снова знаю, где находится игрок: он выполнил все задачи первой части, а значит, мы можем переходить к следующей «жемчужине» и вводим в повествование очередную видеовставку, где Габриэль знакомится с членами клуба. Первая часть завершена, и одновременно завязана новая интрига: появляются новые персонажи, с которыми еще не все ясно. Таким образом, сюжет нельзя назвать абсолютно произвольным, но в процессе игры вам предоставляется достаточная свобода действий и возможность исследовать обстановку в той последовательности, в какой вам заблагорассудится. И, что более важно, этот метод дает возможность членить сюжет на большие и малые эпизоды, и в конечном счете - рассказать всю историю.

Джейн Дженсен опубликовала ряд повестей по мотивам сериала Gabriel Knight, а нам любезно предложила познакомиться с выдержками из проектной документации к последней игре серии - Gabriel Knight III: Blood of the Sacred, Blood of the Damned.

Отрывки из проектной документации к игре Gabriel Knight III

Примеры характеристик персонажей:

Детектив Мозли

Мозли работает в полицейском департаменте Нового Орлеана. Это старый приятель Габриэля. Он случайно оказывается в Ренн-ле-Шато, чтобы провести отпуск в поисках сокровищ. «Милое времяпрепровождение», - говорит он, однако его поведение внушает подозрения. Он постоянно куда-то исчезает, проявляет до странного глубокий интерес к делам Габриэля, а затем еще более озадачивает нашего героя, когда просит его никому не говорить, что он, Мозли, полицейский. Почему же у Габриэля такое чувство, что Мозли вовсе не в отпуске, как уверяет?..

Мадлен Бютэн

Очаровательная, своевольная и сексуальная француженка - воплощение женственности, перед которым нелегко устоять простому смертному. Для нее проще простого обвести всю туристическую группу (состоящую исключительно из мужчин) вокруг своего изящного пальчика. И все же, ее необычная увлеченность (чтобы не сказать «одержимость») сокровищами замка Ренн заставляет задуматься. Организация экскурсии в замок - не уловка ли это? Бесплатная рабочая сила, которую можно использовать в собственных целях? А может, повод для частых визитов в замок? А интерес Мадлен к идеям каждого, с кем она разговаривает, - просто ли это кокетство или девушка пытается выяснить что-то конкретное?

Джон Уилкис

Уилкис - австралиец, относящийся к типу «мачо», «настоящих мужчин» (как будто там бывают другие типы). Ему уже далеко за сорок и он успел объездить весь свет или, по крайней мере, все его необитаемые уголки. Он настоящий искатель сокровищ - это видно издалека. Хотя сам он ни за что в этом не признается (если только хорошенько не напьется или не окажется под чарами прекрасной Мадлен), Уилкис уверен, что знает секрет сокровищ замка Ренн. Он надеется сказочно разбогатеть... Как же он ошибается!

Пример сцены с головоломкой:

Задача: поймать с поличным Эмилио, подслушивающего у двери (трехмерная головоломка).

Если, разговаривая с Мозли, вы приглядитесь к замочной скважине, то можно увидеть чье-то ухо.

Выйдя из номера, вы увидите Эмилио, который только что отошел от двери. В руках у него стакан, и он делает вид, будто допивает оставшуюся жидкость (на самом деле стакан пуст). Затем он ставит стакан на поднос в холле и поспешно уходит.

Даже если Габриэль пропустит эту сцену, у него есть возможность взять с подноса стакан - он увидит его, выходя из номера.

Возьмите с подноса стакан.

Стакан появляется среди других предметов, которые Габриэль таскает с собой.

Теперь, приложив его к двери любой комнаты, можно узнать, есть ли кто-нибудь в том или ином гостиничном номере (для этого нами было придумано множество специальных звуковых эффектов).

И, наконец, пример интерактивного диалога:

Жан, портье. Поговорите с Жаном. Тема: Замок Ренн.

Жан рекомендует Габриэлю посетить музей. Тема: Двое неизвестных с чемоданом.

Жан не дежурил прошлой ночью, поэтому не знает, как вселялись постояльцы и какой у них был багаж. Единственное, что ему известно, - это то, что в отеле только семь номеров и шесть из них (в седьмом живет Габриэль) заняты членами туристической группы.

Тема: Прибытие группы.

Жан может лишь сказать, что номера были заказаны заранее и что все они уже заняты. Времени прибытия постояльцев он не знает.

Официальная веб-страница игры Gabriel Knight III: Blood of the Sacred, Blood of the Damned находится по адресу www.sierrastudios.com/games/gk3.

Хорошо написанное и очень информативное руководство о том, как составлять проектную документацию, можно найти на веб-сайте Gamasutra. Оно создано Цви Фри-маном (Tzvi Freeman) из компании DigiPen и в середине 1 997 года было опубликовано в журнале Game Developer. Можно шаг за шагом ознакомиться с этим руководством по адресу www.gamasutra.com/features/game_design/9297/design_doc.htm. Большое спасибо редактору журнала Алексу Данну (Alex Dunne) за эту ссылку!

Роберта Вильяме (Roberta Williams), Sierra On-Line

Во время телефонного интервью Роберта Вильяме поделилась с нами своими взглядами на создание персонажей и эскизных набросков.

Эскизы помогают при создании отдельной сцены или вводного видеоролика, где мало предметов. Но они не всегда позволяют понять, каким будет процесс игры, так как на них нельзя отобразить все ее возможности.

Роберта говорит, что для своих игр она предпочитает делать не эскизные наброски, а писать настоящие постановочные сценарии, как она поступала, создавая сериал King's Quest и игру Phantasmagoria. Проектная документация пишется, а не рисуется и передает словами, как должен выглядеть каждый персонаж или комната. Художники, создающие концептуальные образы, могут извлечь оттуда информацию для эскизных набросков. Роберта также пишет комментарии для программистов, объясняя им, что она хочет увидеть в каждом конкретном месте игры.

Роберта, как правило, уделяет гораздо меньше внимания характеристике основного действующего лица, роль которого берет на себя игрок, нежели персонажей, управляемых компьютером. Почему, спросите вы?

Это делается для того, чтобы играющему было проще представить себя на месте героя. Главные персонажи меньше раскрываются в игре, поэтому вы не знаете наверняка, кто они и откуда. Я специально оставляю их более открытыми для самостоятельного истолкования игроками.

Дополнительные сведения о том, как создавать проектную документацию, можно найти в главе 20 «Как найти свое место в игровой индустрии».

Марк Хаджинс (Marc Hudgins), Yosemite Entertainment

В компании Sierra работает и Марк Хаджинс, являющийся сотрудником студии Yosemite Entertainment (Окхерст, Калифорния). Марк, художественный директор и разработчик, участвовал в создании многих игр, среди которых наиболее известны Quest for Glory I, III и IV, The Realm, King's Quest VII.

Марк считает, что очень важно определить, эскизы какого типа нужны в каждом случае и для кого они предназначены.

Когда речь идет о разработке компьютерных игр, эскизы бывают двух видов: одни моделируют интерактивные процессы, другие, соответственно, остальные части геймплея. Кроме того, у эскизных документов могут быть разные адресаты: члены команды, администраторы или внешние сотрудники, работающие по контракту. Каждый из этих факторов определяет степень детализации эскиза и то, какие детали он должен отражать. Идея состоит в том, чтобы потратить на эскизы ровно столько времени, сколько нужно, чтобы они верно передавали необходимую информацию. Эскизы - это средство, а никак не цель. Главное для них - адекватно отображать визуальную информацию.

Фрагменты игры, не являющиеся интерактивными, обычно отражаются в документации с одной - фиксированной - точки зрения. Действие в них разворачивается последовательно, шаг за шагом. Эскизы в этом случае делаются более техничными и детальными. Отображение неинтерактивных элементов игры очень похоже на обычные комиксы. Здесь часто используется смена положений камеры, монтаж и другие кинематографические ухищрения. Очень важна и синхронизация. Неинтерактивные фрагменты по большей части несут в себе эмоциональное и драматическое содержание, поэтому художник должен хорошо владеть визуальным киноязыком и уметь использовать все его преимущества.

Степень детализации эскиза зависит от адресата. Если это такой же художник, как и я, то я просто схематично набросаю от руки последовательность событий. Если же моя работа адресована программисту, я постараюсь сделать все образы максимально ясными и верно отразить все пропорции и отношения между объектами. Программисты всегда понимают нарисованное буквально, поэтому эскиз надо делать подробным и проработанным. Но если эскиз предназначен для группы непосредственных разработчиков проекта, наводить на рисунках излишний лоск не стоит.

А вот в том случае, когда мне приходится представлять проект администрации или разработчикам, приглашенным со стороны, я выполняю эскизы с максимальной тщательностью. В них содержится все та же информация, однако выглядят наброски более четкими и «законченными». Любой человек сможет прочитать их без моих пояснений. Рисунки должны быть понятными и отображать правильную перспективу, положение, действия, синхронность и связь между отдельными элементами кадра. Создавая эскизы для этой аудитории, разработчик либо пытается представить свой проект в самом выгодном свете и «продать» свою идею, либо, если речь идет о приглашенных разработчиках, старается объяснить все досконально, чтобы получить в конечном итоге именно то, что он задумал. Так или иначе, но все подробности, и визуальные, и умозрительные, должны присутствовать на вашем эскизе.

Эти эскизные наброски взяты из игры King's Quest VII: The Princeless Bride. Первый из них представляет видеоролик, а второй служит для разработки диалогов и фоновых декораций. (Приводится с разрешения компании Sierra On-Line, Inc.)

Марк Хаджинс признается: «Когда я работаю над эскизом, идеи постоянно роятся у меня в голове, и я начинаю машинально делать наброски, пока замысел не приобретает конкретную зримую форму. Далее - два варианта: либо я делаю очень подробный рисунок на бумаге, а затем сканирую и превращаю его в шаблон, либо сразу же начинаю работать с графической программой на компьютере».

Чтобы познакомиться с работами Марка Хаджинса, посетите его веб-сайт www.marchdesign.com.

Рон Гилберт (Ron Gilbert), Humongous Entertainment

Гений индустрии, создатель всеми любимых персонажей, таких как Гайбраш Трипвуд из Monkey Island, Бернар из Maniac Mansion и Pajama Sam, Рон Гилберт считает, что «главный герой должен быть узнаваемым и понятным игроку».

Мы еще не достигли масштабов, которые используются в кино для создания сложных, неоднозначных характеров. Поэтому часто приходится использовать в работе стереотипы, которые затем развиваются в процессе развертывания сюжета. В экшен-играх и стратегиях стереотипный персонаж даже полезен: игрок сразу понимает, с кем имеет дело, сюжет же здесь не столь важен. Для квестов это, разумеется, не так.

На веб-сайте www.humongous.com вы сможете найти и скачать изображения множества персонажей, созданных Роном Гилбертом за последнее время.

Том Холл (Tom Hall), ION Storm

Том Холл, сотрудник компании ION Storm, любезно согласился ненадолго отвлечься от работы над проектом Anachronox и рассказать нам, как, по его мнению, следует создавать персонажей для компьютерных или консольных игр.

Главный герой обязан иметь характерные черты и личные качества, которые импонируют игроку и воплощают его мечты и фантазии. Кроме того, у героя должна быть какая-нибудь забавная причуда, Ахиллесова пята или любимая вещь, подчеркивающая его индивидуальность. Юмор пусть присутствует в самой его природе. Персонаж, пересыпающий речь шутками, - это, конечно, здорово, но когда вы постоянно слышите одни и те же остроты, они быстро надоедают. А вот если вам смешно уже потому, что «персонаж такой, какой он есть», то вы будете улыбаться на протяжении всей игры. Бен из игры Full Throttle! - последовательный пример «крутого парня». Шутки и комментарии, которые он время от времени отпускает, приобретают смысл только в контексте сурового мира байкеров. Свободная жизнь на колесах - чистая мечта: многие игроки хотели бы оказаться на месте Бена. Любимая вещь этого персонажа - его верный друг-мотоцикл.

Мэнни Калавера и другие основные персонажи Тима Шефера (Tim Schafer) славятся способностью цитировать разных авторов и восхитительно непредсказуемым поведением, что придает игре особый интерес. К тому же у них выразительная мимика, что не часто встречается в играх. Это очень помогает, поскольку создателю игры не обязательно объяснять игроку, что чувствует его персонаж, или использовать преувеличенные голосовые эффекты и жесты, - достаточно одного взгляда на удрученную физиономию героя, чтобы все стало понятно. Тим создает персонажей, которые обладают яркими индивидуальными чертами и в то же время легко узнаваемы.

«Мэнни Калавера и другие персонажи из незабываемой Grim Fandango - великолепные примеры ярких, выразительных образов», - говорит Том Холл из ION Storm. (Напечатано с любезного разрешения компании LucasArts Entertainment Company LLC. © LucasArts, 1998. Все права защищены. Использовано с разрешения владельца.)

Если говорить об экшен-играх, то Дюк Ньюкем, этот брутальный мачо, является чем-то вроде глотка свежего воздуха для тех, кто живет в обществе политической корректности. Персонаж одновременно напоминает Арнольда Шварценеггера и Эша из игры Evil Dead 2.

Прекрасно расставлены акценты в образе Лары Крофт: упорная бесстрашная искательница приключений (похожая на англичане Рипли, героиню сериала «Чужой»/«Чужие») с гиперболизировано женственной фигурой - это настоящая мечта любого подростка. Если вы мужчина, то непременно захотите отправиться с ней рискованное путешествие. А для женщин она является примером сильного женского характера - в играх такие героини встречаются не часто.

«Еще один важный момент - таинственность, - продолжает Том. - Если история персонажей не ограничивается рамками игры, то это просто замечательно». Что это значит? Том поясняет:

Если вы придумаете «биографию» своего персонажа, то его образ только выиграет от этого, хотя вполне возможно, что в игре вы не станете рассказывать его предысторию. А если в игре есть что-то таинственное, как, скажем, временные заскоки у Клауда из Final Fantasy VII, это непременно озадачит и заинтригует игрока. Он захочет узнать, в чем тут дело и что это сулит.

Чего следует избегать разработчику при создании главного персонажа?

Я бы посоветовал не полагаться на известные шутки и не использовать стереотипы. Постарайтесь придумать что-нибудь новенькое. Если уж вы решили воспользоваться готовым шаблоном, попробуйте развить характер персонажа и придать ему новые, неожиданные черты. К примеру, если вы хотите сделать своим героем старого золотоискателя вроде Габби Хейза, пусть он будет, скажем, специалистом по квантовой механике. Еще лучше, если герой шутера обожает домашних животных. И уж совсем замечательно, если какая-нибудь старушка признается вашему герою, что была страстно влюблена в его батюшку. Делайте то, чего от вас не ждут, и вы завоюете интерес аудитории.

Джо Селински (Joe Selinske), Ritual Entertainment

В заключение данной главы, посвященной разработке идей «с карандашом в руках», Джо Селински из Ritual Entertainment предлагает пример досье на персонажа. Героиня - «роковая женщина» из игры Sin (Ritual/Activision), прекрасная и беспощадная Элексис Синклер.

Ниже приводится выдержка из ее досье.

Имя: Элексис Синклер.

Пол: женский. Возраст: 31.

Цвет глаз: зеленый.

Цвет волос: черный.

Семейное положение: не замужем.

Род занятий: биогенетик и химик, глава компании SinTEK Industries.

Особые приметы: татуировки на правой ягодице и вокруг лодыжки, пирсинг на пупке.

Родители: отец, Тролл (местонахождение на данный момент неизвестно); мать, Диана (живет в Европе).

Джо Селински из Ritual Entertainment привел досье Элексис Синклер в качестве примера того, как талантливый разработчик может вдохнуть жизнь в игровой персонаж. (Использовано с разрешения компании Activision, Inc.)

Краткая предыстория:

Родилась 12 апреля 1996 года в роскошном предместье Фрипорт в семье доктора Тролла Синклера и Дианы Кеттл Синклер. Мать Элексис бросила семью, когда дочери исполнилось два года, и отправилась «на поиски себя». Воспитывал Элексис ее отец, профессор университета и научный сотрудник огромной фармацевтической компании. До шести лет девочка посещала различные пансионы, а потом вернулась ее мать и заявила о своих правах на состояние Тролла. Тролл собрал все сбережения, принадлежавшие ему и дочери, продал всю недвижимость, спрятал деньги и исчез в диких джунглях, спасаясь от бывшей жены.

Об этом периоде жизни Элексис известно немногое. Отец и дочь объездили весь мир; Тролл изучал мистические и оккультные науки туземных племен. Четыре года они путешествовали, Тролл занимался исследованиями и научными изысканиями. Но несчастный случай резко изменил их жизнь: Элексис заразилась редкой болезнью, которая свирепствовала в городе, где они в то время остановились. Тролл, опасаясь за жизнь дочери, срочно вернулся вместе с малышкой в Фрипорт в надежде на самую квалифицированную врачебную помощь, какую только можно получить за деньги. Элексис прошла интенсивный курс лечения и чуть не умерла от осложнений.

Тролл плакал у ее постели, пока она боролась со смертью. Нет, такое больше ни с кем не должно повториться, решил он. Смерть – самый жестокий враг человеческого рода, и Тролл поклялся, что найдет способ обмануть и даже победить ее. Он вернулся к научной работе с удвоенным рвением: его цель - победить смерть.

На формирование характера «железной леди» повлияли многие события. Очередное возвращение ее матери, боль и зло, которые Диана причинила Элексис и ее отцу. Споры и ссоры вокруг денег, борьба за право воспитывать Элексис - от всего этого ранимая душа девочки разрывалась на части. Элексис с головой погрузилась в учебу, чтобы как-то уйти от семейных проблем. Ее охватила настоящая страсть к познанию. Она быстро взрослела и никогда не оглядывалась назад.

У Элексис обнаружились недюжинные способности к наукам: она много трудилась, приобретая знания. Ей удалось окончить университет за три года и получить диплом по химии и биологии. Летом того же года она продолжила обучение, сдав экзамены в аспирантуру. Всего через полтора года, чего еще никогда не случалось в этом и других университетах, она получила степень магистра по химии и биологии. Элексис добилась того, чтобы ей позволили участвовать в очень престижном научном проекте, что дало ей возможность получить ученую степень в области биохимии и генной инженерии. Теперь она не уступала своему отцу ни в умении вести дела, ни в знаниях.

Объединенными усилиями отец и дочь создали небольшую, но очень перспективную компанию SinTEK Industries, чьи исследования находились на передовых рубежах медицины и смежных наук. Они расширили область применения исследований и вышли со своей продукцией на мировой рынок. Их открытие потрясло мир: созданный ими препарат Vanity замедлял и почти останавливал процесс старения человеческого организма. Их жизнь текла спокойно и неторопливо; Тролл постепенно отошел от дел, и Элексис стала самостоятельно руководить компанией SinTEK Industries.

О ее недавних исследованиях в области генетики почти ничего неизвестно. Ходят слухи, что она проводит эксперименты в тех областях науки, к которым другие ученые относятся с опаской. Компания SinTEK Industries - неприступная крепость, и даже полицейским еще не удавалось проникнуть туда и побеседовать с Элексис о ее последних открытиях. Можно быть уверенным в одном: чем бы ни занималась Элексис, об этике и морали здесь речь не идет.

У нее соблазнительная и загадочная внешность. Эта женщина - гений, использующий все свои способности для достижения поставленных задач. Она всегда добивается своего. Настоящий вечный двигатель, Элексис ко всему успевает приложить руку - ей позавидовал бы даже осьминог...

Часто ли внешность персонажа используется для того, чтобы добиться коммерческого успеха? Сложно спорить с тем фактом, что сексуальная привлекательность имела немаловажное значение для популярности таких персонажей, как Элексис Синклер из игры Sin, Лара Крофт из Tomb Raider или изображенная здесь Ринн из Drakan. Действительно, почему игры должны отличаться в этом вопросе от фильмов, телепередач или комиксов?


Создание головоломок

Глава 5

Создание головоломок

...Вожделенная магическая книга, ради которой вам пришлось преодолеть столько преград, находится в этой комнате. Завладев этим кладезем волшебных снадобий и заклинаний, вы безо всякого труда проскользнете мимо пары громил, охраняющих вход в замок. Но как попасть в заветную комнату?.. Дверь, увы, заперта. Заглянув в замочную скважину, вы обнаруживаете, что в ней находится ключ! Торопливо осмотревшись вокруг, вы видите на столе листок бумаги. И тут вас осеняет блестящая идея: надо просунуть листок под дверь и молотить по ней кулаками до тех пор, пока ключ не выскочит из скважины и не упадет прямо на бумагу. Теперь остается лишь осторожно вытянуть листок, взять ключ, отпереть дверь - и магическая книга у вас в руках!

Приведенный выше пример суть одна из возможных игровых головоломок. Вот так разработчики заставляют игрока преодолевать препятствия, используя ум, а не силу. Подобные задачи часто встречаются в квестах, РПГ и некоторых типах экшен-игр. Классифицировать игровые головоломки можно следующим образом.

• Головоломки-исследования. Обычно решаются путем тщательного изучения и изменения окружающего игрового пространства. В игре Legend of Zelda: Ocarina of Time (Nintendo) вы должны зажечь факелы по обеим сторонам двери, чтобы проникнуть в следующую область пещеры.

• Предметные головоломки. Задача решается с помощью предметов, переносимых героем (игроком). Справедливости ради следует отметить, что во многих задачах сочетаются элементы исследовательских и предметных головоломок, как в приведенном выше примере (или в игре Day of the Tentacle компании LucasArts, где требуется поместить бутылку вина в машину времени, чтобы, оказавшись в будущем, вынуть ее и получить уксус).

• Головоломки на основе диалогов. Их можно решить, поговорив с нужным персонажем или вспомнив разговор между другими персонажами. В качестве примера приведем квест The Blackstone Chronicles (Mindscape/Legend Entertainment), где герою требуется переговорить с душами замученных пациентов психиатрической клиники, чтобы отыскать своего похищенного сына.

• Головоломки-вставки. Многие квесты, в особенности выпущенные в середине 90-х годов, используют головоломки, не имеющие никакого отношения к событиям, происходящим в игре, этакие дополнительные мини-игры. К примеру, в квесте The Neverhood Chronicles (DreamWorks Interactive) вы должны в одном случае сыграть в «пятнашки», а в другом - испытать себя в игре на внимание и зрительную память, при этом обе головоломки никак не связаны с сюжетом игры.

Боб Бейтс (Bob Bates), Legend Entertainment

Боб Бейтс, глава компании Legend Entertainment, руководит ею вместе с Майком Вердю (Mike Verdu), который является его компаньоном с момента основания Legend в 1989 году. В качестве разработчика, соавтора или продюсера Боб участвовал в создании более двадцати игр, завоевавших в общей сложности свыше тридцати наград.

Ниже Боб Бейтс рассказывает, как лучше всего вплетать загадки и головоломки в сюжетную ткань игры.

Приступая к созданию игры, прежде всего следует определить ее основные структурные элементы: сюжет, художественное оформление, персонажей, главную опасность, грозящую миру героя, и конечную цель, к которой должен стремиться играющий. После чего можно приступать к размещению в игре препятствий, которые необходимо преодолеть на пути к заветной цели. Это и есть головоломки, и они должны естественно вытекать из сюжета игры.

Существует мнение, что перечисленные требования справедливы только в отношении квестов, но это не так. Как правило, ни один мало-мальски приличный сюжет не обходится без препятствий на пути главного героя. Вспомним хитроумного Одиссея - разве его возвращение домой от стен Трои заняло один день?

Важно, чтобы любая головоломка соответствовала текущим обстоятельствам, чтобы ее присутствие было оправдано, а когда игрок ее благополучно решит, ему должно стать понятно, почему его действия привели к успеху.

Боб Бейтс считает, что за каждой головоломкой должен стоять «злодей». Он поясняет свою мысль:

Единственное, что можно посоветовать создателю головоломок, это не забывать о злодее. Кто-то или что-то стремится помешать вашему герою. Будь то человек или боги, правительство или самый главный «плохой парень» - для вашего героя это злодей, главное предназначение которого - строить козни. Именно он придумывает и реализует все игровые препятствия, материалом для которых может быть все, что угодно. Его рассуждения: «Я не хочу, чтобы герой победил, и я сделаю то-то и то-то, чтобы помешать ему». Напротив, дело героя - преодолеть все преграды на пути к цели. Итак, прежде чем изобретать очередную головоломку, спросите себя, почему она должна быть именно здесь. Кто ее сюда поместил? Зачем? Кто этот недоброжелатель, почему он угрожает (мешает) вашему герою?

В игре John Saul's Blackstone Chronicles в роли злодея выступает Малькольм Меткалф, дух покойного отца главного героя. Если игрок разгадает мотивы поступков Малькольма, ему будет легче справиться с многочисленными головоломками, встречающимися в клинике. (Приводится с разрешения компании Mindscape, Inc. Все права защищены.)

«И помните: головоломка обязательно должна иметь смысл, - замечает Боб Бейтс. - Позаботьтесь о том, чтобы в распоряжении игрока было достаточно подсказок. Не делайте загадки слишком сложными и следите за тем, чтобы каждая решенная головоломка приближала героя к заветной цели».

Боб приводит пример загадки, основанной на диалоге с персонажем, решив которую, игрок переходит на следующий уровень игры.

Представьте себе запертую дверь. Конечно, можно просто пометить на нее очередной кодовый замок и этим ограничиться. Но что если на полу перед дверью посадить плачущую женщину? Очевидно, что нужно поговорить с ней и узнать, кто ее обидел. А потом вам придется ей помочь и только после этого открыть дверь.

Это и есть головоломка на основе беседы с персонажем. Вполне возможно, что женщину обидел тот же самый злодей, который портит жизнь герою. По ходу разговора вы узнаете о жертве, об обстоятельствах происшествия и о вашем общем противнике, - и все это благодаря тому, что вы сочинили неплохую головоломку.

В заключение Боб Бейтс говорит, что головоломки, основанные на сюжете или диалогах, - лучший выбор при создании квеста. «Если каждая придуманная вами головоломка будет органично вплетена в сюжетную линию, то игроки будут воспринимать ее как часть сюжета игры, а не просто как произвольное препятствие, поставленное у них на пути только для того, чтобы замедлить их продвижение к цели».

Джейн Дженсен (Jane Jensen), Sierra

Мы уже не раз беседовали с Джейн Дженсен на страницах этой книги. Она делилась с нами своим многолетним опытом в области разработки игр и создания главного персонажа игры (глава 4), а теперь предстает перед нами в качестве автора замечательных головоломок в играх серии Gabriel Knight (Sierra Studios).

Джейн считает, что для начала полезно выбрать сюжет, в который головоломки вписывались бы самым естественным образом. Она поясняет свою мысль:

Хорошо подходят детективные истории. В чем заключается работа детектива? Он исследует место преступления, ищет улики и допрашивает подозреваемых, устанавливает слежку, получает данные экспертизы из лаборатории, просматривает досье на подозреваемых и т.д. Все это вполне может стать основой для головоломок. Приключенческий жанр, приобретший всемирную популярность благодаря «Одиссее» и «Приключениям Синдбада», тоже прекрасно подходит для головоломок, ведь он предполагает путешествие в неизведанные страны, схватки со злодеями или чудовищами, поиск сокровищ и т.д. А вот на основе любовного романа головоломки делать практически невозможно. Я не говорю, что любая игра должна быть детективом или приключением. Просто прежде чем разрабатывать сюжет, нужно тщательно продумать, как вы будете вставлять в него головоломки.

По мнению Джейн Дженсен, лучше всего, если головоломки плавно вытекают из сюжета. Почему, спросите вы? Кроме того, почему многие разработчики добавляют в игры головоломки, никак не связанные с происходящими событиями? Может быть, справедливы оба подхода?

Игры, являющиеся этаким набором логических загадок (например 7th Guest), имеют право на существование, но в такой игре сюжет не будет играть основную роль. Согласитесь, если ваш детектив постоянно натыкается на китайские головоломки и замки с секретом, это выглядит не очень правдоподобно. Конечно, одна - две такие задачки не помешают. Скажу больше, вы обязательно должны включить в сюжетную канву несколько более интересных головоломок, чем те, что основаны на бесконечных расспросах, найденных ключах или прочитанных письмах. Постарайтесь лишь, чтобы задачи были связаны с игровыми событиями.

В игре Gabriel Knight I на чердаке у бабушки Габриэля имеются старинные стенные немецкие часы, собственность покойного деда главного героя. И с ними явно надо что-то сделать. На наружном циферблате изображены фигурки: дракон, лев, луна и т.д. Чтобы открыть секретный ящичек в корпусе часов, игроку требуется установить изображение дракона в верхнюю позицию (12:00), а стрелки перевести на 3:00. Загадка? Загадка. Но она органически вплетена в ход событий. «Три змейки» - периодически возникающая тема в снах Габриэля; те же самые сны видят его отец и дед. Этот образ является своего рода священным символом их врагов. Подобная маленькая загадка не только усиливает значение образа из снов семьи Габриэля, но также является намеком на последующую более важную головоломку: вам нужно будет установить «змеек» в храме противника, чтобы вернуть семейный талисман. Итак, идея «трех змеек» повлекла за собой создание двух логических головоломок, являющихся в то же время важными элементами игры, а не просто загадками, притянутыми за уши к сюжетной линии.

В той же игре Габриэль посещает могилу Мари Лаво в Нью-Орлеане, где обнаруживает на могильной плите странные символы, которые можно скопировать. Сняв с них копию, герой может впоследствии найти знатока магии вуду, который сообщит ему, что эти символы суть зашифрованное послание, и раскроет смысл загадочного письма. В письме каждый символ соответствует букве; расшифрованное послание указывает на подозреваемого, но намек этот очень расплывчатый и неопределенный. Дело в том, что первое письмо - далеко не главная часть головоломки. В дальнейшем Габриэль находит на могиле второе послание, срисовывает его, но расшифровать письмена уже нельзя - знаток магии теперь недоступен. Потом Габриэлю потребуется, чтобы встреченные им шаманы пронесли нечто на одно из своих сборищ. Как это сделать? А вот как: он может оставить на могильной плите собственное послание, и те, кому оно адресовано, решат, что его написал автор двух предыдущих сообщений. В чем же загвоздка? Чтобы составить послание, Габриэлю требуются буквы, которые не использовались в самом первом, переведенном, письме. Перенося известные буквы из первого письма во второе, он получает фразу наподобие «Мне бы хо_е_ось». С помощью дедуктивного метода он угадывает символы, соответствующие буквам «т» и «л». Теперь герой в состоянии самостоятельно закончить свое сообщение. Это весьма сложная задачка в три шага, но она связана с событиями, происходящими в игре.

Для Gabriel Knight III я использовала сюжет, битком набитый всевозможными головоломками. Действие игры разворачивается в уединенном местечке Ренн-ле-Шато, что во Франции. Таинственная история включает в себя ряд загадок, указывающих путь к зарытому кладу. Идея уже сама по себе захватывающая, и кроме того, она позволяет дополнить игру рядом головоломок (решение которых помогает найти сокровища), связанных с сюжетной линией.

Последняя игра Джейн Дженсен Gabriel Knight III: Blood of the Sacred, Blood of the Damned поступила в продажу в конце 1999 г.

Луис Касл (Louis Castle), Westwood Studios

Теперь мы предлагаем вам послушать Луиса Касла, вице-президента компании Westwood Studios. Луис, опытный продюсер, программист, художник и художественный директор, рассказывает нам, как были придуманы и разработаны головоломки для игры Lands of Lore 3.

Сюжетная линия и геймплей должны развиваться параллельно. Мы стараемся спланировать эмоции и реакцию игрока по ходу действия. Головоломки занимают в этом далеко не последнее место, поскольку они замедляют ход игры и вызывают у игрока совершенно иные эмоции по сравнению с «активной» частью сюжета. Создание сюжетной головоломки начинается так: «А давайте-ка поместим здесь загадку, которая научит игрока выполнять действие X». После чего каждый разработчик начинает рыться в собственных запасах идей, чтобы мы могли осуществить задуманное как можно эффективнее.

Часто бывает так, что у разработчика возникает превосходная идея головоломки, но он никак не может найти ей место в сюжете игры. Я всегда призываю членов команды прорабатывать свои задумки - и откладывать их на некоторое время. Через несколько недель обычно оказывается, что как раз такой задачки в игре и не хватало.

Луис говорит, что создание головоломки - плод коллективных усилий.

К работе над сюжетом мы привлекаем как собственных авторов, так и тех, кто сотрудничает с Westwood Studios по договору. И пока нам понятен основной сюжет игры и те эмоции, которые он должен вызвать у игрока, литераторы могут работать над конкретными персонажами и ситуациями. Часто бывает, что идея головоломки возникает после прочтения сценария игры.

В Lands of Lore 3 игрок совершает путешествие в подземное царство - узилище душ умерших. Вы встречаете там девушку, которая оплакивает свою судьбу и горькую участь своих сестер. Она умоляет вас положить конец ее страданиям. Вы начинаете осматривать дом, и в нем внезапно вспыхивает пожар - вас со всех сторон обступает пламя, которое охватывает залы и спальни. В чем здесь секрет? Все просто: заранее найдите светильники и вылейте из них масло, чтобы предотвратить возгорание. Как и в других ситуациях, возникающих в Lands of Lore 3, если вы допустили оплошность и пожар уже начался, разработчики дают вам еще один шанс. Языки пламени оказываются призрачными, «ненастоящими». Из любой, даже самой безнадежной ситуации предусмотрен выход - игрок никогда не окажется в тупике, ему никогда не придется начинать все с начала. Всегда есть возможность успешно завершить игру, хотя это порой и нелегко.

Вместо того чтобы наказывать игрока за то, что он не решил головоломку в режиме реального времени (речь идет об игре Lands of Lore 3), разработчики из Westwood Studios предоставили ему шанс справиться с задачей другим способом. (Приводится с разрешения компании Westwood Studios, Inc.)

Роберта Вильяме (Roberta Williams), Sierra On-Line

«Создание головоломок - настоящее искусство. Необходимо заинтересовать игрока, заставить его думать, и в то же время не перегружать его слишком сложными задачами, - сохранять это хрупкое равновесие далеко не просто». Роберта Вильяме знает об этом не понаслышке - ее часто называют «крестной матерью» графических квестов (один из первых графических квестов - Mystery House - появился на компьютере Apple IIe в 1980 году).

Роберта считает, что при введении в игру подсказок, диалогов и предметов, а также планировании обстановки разработчику не грех показаться несколько навязчивым. Она полагает, что «надо как можно чаще повторять подсказки на случай, если игрок пропустил первую, и так должно продолжаться, пока задача не будет решена - только после этого подсказку можно убрать».

Вам когда-нибудь случалось сталкиваться с неразрешимой головоломкой в квесте, после чего вы «жульничали» - искали прохождение в Интернете или звонили в службу поддержки игры? Как же бывает досадно, когда вы обнаруживаете, что просто не заметили чего-то на экране! Именно поэтому при создании головоломок-исследований Роберта Вильяме вводит в игру примерно в два раза больше предметов-подсказок, нежели другие разработчики, стараясь располагать их в центре экрана. Не меньшее значение она уделяет специальным указующим сообщениям, будь то намеки в диалогах или предметы, которые выдают подсказку, когда вы выбираете их мышью.

Вторя своим коллегам, собравшимся за «круглым столом» этой главы, Роберта признается, что абстрактным задачкам предпочитает правдоподобные и недобрым словом вспоминает игру 7th Guest компании Trilobyte, в которой головоломки никак не связаны с сюжетом.

Пример красивой головоломки-исследования, тематически связанной с сюжетной линией, можно найти в последней игре Роберты Вильяме King's Quest: Mask of Eternity.

На определенном этапе игры вам необходимо отыскать похищенный в свое время Камень порядка (Stone of Order), который олицетворяет собой закон и порядок сказочного государства.

Разумеется, вы находите камень, но он располагается высоко на алтаре, под которым шипит раскаленная лава. Игрок стоит на небольшой доске, нависающей над пропастью. Между вашим героем и заветным камнем подвешены семь предметов, напоминающих по виду гонги. В распоряжении игрока имеются подсказки-сообщения, которые появляются при выборе объектов на экране (камень вдалеке, предметы в снаряжении героя или гонги), что помогает решить задачу. Игрок понимает, что может использовать свой лук и стрелы, чтобы стрелять по гонгам. Как только его стрела попадает в гонг, тот издает музыкальный звон и вспыхивает определенным цветом. Если игрок попадает в нужный гонг, к возвышению с камнем выдвигается площадка. Но если следующий выстрел ошибочен, все приходится начинать сначала.

Роберта Вильяме утверждает, что некоторые головоломки из игры King's Quest: Mask of Eternity можно решить различными способами, если правильно и своевременно использовать многочисленные сообщения-подсказки. (Приводится с разрешения компании Sierra Studios.)

Вы можете воспользоваться методом проб и ошибок, к примеру, записывая гонги по номерам - какой был первым, вторым и т.д., либо догадаться, что звуки, издаваемые гонгами, представляют собой музыкальную гамму, начинающуюся с ноты «до», и располагаются по возрастанию тона, а вспышки цвета символизируют семь цветов радуги. Ведь не случайно Камень порядка носит такое название.

Чтобы побольше узнать о Роберте Вильяме и ее пути в индустрии игр, обязательно найдите сборник «The Roberta Williams Anthology», выпущенный компанией Sierra в 1996 году (журнал Game.EXE писал о нем в апреле 1997 года. - Примеч. ред.).


Создание уровней

Глава 6

Создание уровней

С тех пор как весной 1992 года компания id Software выпустила игру Wolfenstein 3D, мир компьютерных игр претерпел значительные изменения. Более четверти миллиона человек сломя голову ринулись доставать эту захватывающую новинку с локальных досок объявлений (BBS), перекачивая 700 килобайт условно-бесплатного (shareware) кода на свои персональные компьютеры. Так родился новый жанр компьютерных игр - трехмерные шутеры («стрелялки») с видом от первого лица.

Следующие семь лет ознаменовались появлением множества знаменитых экшен-игр - Doom, Dark Forces, Duke Nukem 3D, Quake, Jedi Knight, GoldenEye 007, Unreal, Sin и Half-Life... Благодаря этим играм возник новый вид творчества - художественное проектирование уровней. Коротко говоря, создание уровней заключается в разработке их архитектуры и расположении на них объектов, а также постановке общих и мини-задач в пределах уровня.

Итак, что нужно сделать, чтобы уровень, разработкой которого вы заняты, получился интересным и правильно спланированным? Какие основные ошибки встречаются у разработчиков-любителей? Существуют ли общие правила создания уровней игры?.. В этой главе собраны рекомендации лучших разработчиков и их соображения о методах создания архитектуры уровней в трехмерных экшен-играх. К слову, почти все нижеследующие советы применимы к любым 3D-играм, например, экшн-квестам с видом от третьего лица (вроде Tomb Raider).

Игра Wolfenstein 3D, классика жанра 3D-шутеров, резко выделялась в свое время на фоне многочисленных плоских игр с горизонтальным скроллингом. С появлением новой перспективы возникли и новые проблемы... (Использовано с разрешения компании id Software.)

Тим Уиллитс (Tim Willits), id Software

Тим Уиллитс занимался разработкой уровней для игр Ultimate Doom и Quake, а затем был ведущим дизайнером уровней легендарных Quake II и Quake III: Arena. Он охотно раскрывает перед нами секреты своего мастерства в этом важном аспекте разработки трехмерных игр. Прежде чем приступить к работе, Тим всегда спрашивает себя, с какой картой он имеет дело: будет ли это уровень для одиночной игры или же речь идет о многопользовательской карте для дефматч-баталий (deathmatch)?

Итак, прежде всего определитесь с типом уровня. Как только вы сделаете выбор между дефматч-картой и одиночной игрой, все станет намного проще. Создание карты, одинаково годной для обоих режимов игры, возможно, но это очень трудная задача. Обычно на дефматч-картах неинтересно играть в одиночку и наоборот.

Дефматч-карты применяются для многопользовательской игры через Интернет или по локальной сети. Уровни такого рода строятся по принципу «убей или умри» и ставят единственную цель - остаться в живых, собрав при этом как можно больше фрагов (очков, выдаваемых за каждую жертву) Столь же просты и правила дефматч-игры: «убей соперника - получишь фраг». Отсюда и название этого типа уровней.

Многие правила разработки в равной степени применимы как к одиночным играм, так и к дефматч-картам. Тим Уиллитс, впрочем, разделил свои советы на две группы.

Одиночные уровни

Ниже перечислены наиболее важные правила, которые стоит соблюдать при разработке уровней для одиночной игры.

Основной замысел и целостность

Тим Уиллитс утверждает, что важнейшим моментом при разработке уровней, который довольно легко потерять из виду в процессе создания игры, является основной замысел и целостность выполняемой задачи.

В каждой игре есть некая главная цель - условие победы. Сама же игра состоит из отдельных уровней, или этапов. Каждый этап, в свою очередь, имеет собственную цель. Следовательно, существование любого фрагмента карты должно быть оправдано этой целью. И очень важно не забывать об этом при разработке (что, к сожалению, случается сплошь и рядом).

Представьте, что вы делаете уровень, держа в голове конечную цель. А затем происходит что-нибудь неожиданное: в игру привносится новая технология или появляются технические проблемы - и центральная идея потеряна. Порой дизайнеры карт, увы, даже не понимают, что их работа изменила направление и отошла от первоначального замысла. В такой ситуации следует сделать шаг назад, посмотреть на происходящее со стороны и сфокусировать все внимание на общем плане создаваемого уровня и его целях. Иногда требуется переработать какие-либо области карты и даже изменить задание, чтобы уже выполненную работу привести в соответствие с общим замыслом. Главное же - создавая уровень, не терять нить основной идеи.

В дополнение Тим Уиллитс отмечает, что в каждой команде обязательно должен быть человек, который контролирует общий ход разработки, иначе вероятность отклонения уровней от первоначального замысла оказывается довольно велика. Свежий взгляд человека, не слишком погруженного в «уровнестроение», - непременное условие при создании игр.

Архитектура уровня и игровой процесс

По словам Тима, игра на одиночных картах протекает достаточно линейно, и здесь одинаково важны как архитектура уровня, так и геймплей, собственно игровой процесс. Поясним: в данном случае под «архитектурой» понимается то, как уровень устроен, а именно разбит на зоны, соответствующие основным мини-задачам карты, позволяющим переходить от одной зоны к другой (о мини-задачах - чуть позже). С другой стороны, игровой процесс включает в себя все события, связанные с основным сюжетом игры. Рассмотрим следующий пример:

Если задача игрока - разрушить ядерный реактор на электростанции, то уровень следует разделить на отдельные области - центр управления, насосную станцию для откачки отходов, активную зону реактора и систему охлаждения. Каждая из этих областей должна быть похожа на свой реальный прототип и быть необходимой для решения главной задачи уровня. Возможно, игроку потребуется ввести секретные коды на пульте центра управления, чтобы получить допуск к системе охлаждения реактора. Попав в зону системы охлаждения, он может выпустить теплоноситель из первого контура реактора, вызвав неуправляемый разогрев активной зоны. Затем игрок может изменить направление откачки отходов на насосной станции, запустив цепную реакцию, которая в конечном итоге приведет к взрыву ядерного реактора.

Риск и вознаграждение

Уровень должен иметь дополнительные задания и, разумеется, бонусы за их выполнение. Это усилит мотивацию игрока. Тим считает, что особые задачи должны содержаться в каждом фрагменте одиночной карты. Он приводит пример:

Игрок попадает в новую область карты и останавливается перед бассейном с нечистотами - слишком широким, чтобы его перепрыгнуть. С другой стороны бассейна находится кнопка, опускающая мост. Ее охраняет очередной монстр. Задача игрока - перебраться на другую сторону. Препятствием является монстр, а также удаленность кнопки, расположенной к тому же на довольно большой высоте. Чтобы выполнить эту мини-задачу, необходимо всего лишь выстрелить в кнопку и увернуться от монстра, пробегая по мосту. Просто, не так ли? Возможно, кому-то покажется, что эта ситуация «не тянет» на задачу, но именно ею она и является. Игрок вынужден преодолеть это препятствие, чтобы двигаться дальше. Уровни в одиночных играх состоят из последовательности таких задач, логически привязанных к отдельным областям карты.

Помимо собственно врагов каждый уровень должен содержать мини-задачи, то есть препятствия и цели. В этой сцене из Quake II игрок должен пробежать через сломанный мост, не свалившись в раскаленную лаву. (Использовано с разрешения компании id Software, Inc.)

Тим также приводит пример недостаточного вознаграждения игрока:

В одной игре мне встретилась башня, стоящая во внутреннем дворе замка. Ее охраняли несколько монстров, и выглядела он довольно важным объектом. Я расправился с двумя охранниками и поднялся наверх. Можете представить себе мое разочарование, когда я никого и ничего там не обнаружил! Каждый раз, когда в вашей игре появляется участок, который охраняется и выглядит, как нечто важное, не забывайте наградить игрока, которому удастся туда пробраться.

Атмосфера игры, оформление и игровая динамика

Для одиночных карт, по словам Тима, очень важна общая атмосфера игры. Что стоит за этими словами помимо удачного дизайна и увлекательности самого процесса?

Уровень должен выглядеть так, как этого ожидает игрок. Если место действия - склад, пусть повсюду лежат коробки и ящики: это первое, что будут подсознательно искать игроки. Кроме того, каждый уровень должен вписываться в общую картину игры. Не смешивайте исторические периоды, если только вы не путешествуете во времени, сохраняйте верность единому архитектурному стилю в пределах одного исторического периода. Так, если на первом уровне стены обиты металлическими листами, не стройте второй из кирпичей и штукатурки. Люди ценят в игре логику и последовательность, ведь это окружает их в реальной жизни.

Еще один неплохой способ создания нужной атмосферы - оформить пространство так, будто за его пределами есть что-то еще. «Нарисуйте фальшивые стены зданий - видимые из окон, но недостижимые в игре. Пусть ящики выезжают на конвейере из отверстия в стене и пропадают в отверстии напротив. Пусть здания продолжаются за пределы игрового пространства», - говорит Тим Уиллитс. Если в вашей игре будет что-нибудь подобное, игроки почувствуют, что находятся в большом мире.

Наконец, заключает Тим, никогда не помешает парочка красивых сцен и тщательно оформленные пейзажи.

Не жалейте времени на художественное оформление. Добейтесь от парадного входа великолепия, самым детальнейшим образом проработайте фасад, создайте потрясающий воображение футуристический центр управления. Пусть игрок придет в восторг, свернув за первый же угол. Если оформление понравится игрокам, они надолго запомнят ваш уровень. Кстати, это не так важно в дефматч-картах, потому что там на любование красотами просто нет времени. Так что, создавая многопользовательский уровень, прежде всего сконцентрируйте внимание на динамике игры.

Выполненный со всеми подробностями фасад дома, фантастические виды природы и другие завораживающие глаз картины играют важную роль в. компьютерных играх. Дизайнеры уровней совместно с художниками создают запоминающиеся сцены, среди которых можно назвать и этот центр управления в игре Quake II. (Использовано с разрешения компании id Software, Inc.)

Что касается динамики, то общее правило здесь таково: легкие в начале игры, уровни должны усложняться по мере приближения к ее концу. Тим Уиллитс обычно делает первый уровень игры тренировочным.

Если вы хотите вставить в игру какие-либо «декоративные» движущиеся объекты или же украсить ее иным образом, постарайтесь, чтобы творения вашей фантазии не мешали передвигаться персонажам. К примеру, вращающиеся вентиляторы выглядят ничуть не хуже, если их поместить за защитные решетки. Действующие насосы, расставленные вдоль стен, - также неплохой пример «безопасного» использования анимации. Я ценю ваше стремление увлечь игрока с первых же уровней, но постарайтесь, чтобы декорации не мешали самой игре.

Впрочем, быть может, вы заинтересованы исключительно в разработке карт для нескольких пользователей? Если так, послушайте советы Тима Уиллитса по созданию дефматч-уровней, а также его рассказ о картах для командной игры «Захват флага».

Уровни для многопользовательской игры (deathmatch-уровни)

Существует пять наиболее распространенных видов дефматч-карт: арена, круговая, линейная, зональная и тематическая. Большинство из них, согласно Уиллитсу, можно использовать в пределах одного уровня, но некоторые несовместимы друг с другом.

Арена

Если не вдаваться в подробности, уровни этого типа содержат, как правило, некую центральную область, где разворачивается основное действие, а большинство дверей и коридоров ведут либо к ней, либо от нее.

На такой карте обычно довольно мало других (кроме центрального) больших помещений, да и вообще областей, представляющих какой-нибудь интерес. Карта весьма прямолинейна, крайне упрощена, ее легко запомнить и несложно пройти. Игроки всегда знают, где они находятся, и никогда не потеряются в коридорах, расположенных вокруг центрального помещения. Игра на такой карте протекает очень динамично и с большим количеством фрагов. Примером такого уровня служит map07 в Doom II.

И еще одно предостережение для разработчиков:

Не стоит усложнять архитектуру центральной области «арены». Здесь происходят наиболее горячие схватки, поэтому у игроков не будет времени, чтобы любоваться окрестностями. Сложная архитектура может прекрасно выглядеть, но она замедляет игру. Постарайтесь сделать эту часть карты наиболее простой.

Круговой уровень

Как следует из названия, карты этого типа спроектированы в виде замкнутого круга, или, как характеризует их Тим, «построены таким образом, чтобы игроку не приходилось останавливаться и поворачивать назад».

Количество тупиков здесь нужно свести до минимума. А лучше, чтобы их не было вовсе. Используйте множество входов и выходов вокруг основного помещения, это обеспечит игроку свободное движение по карте. Также необходимо позаботиться о балансе оружия, дабы ни у одной стороны не было сильного перевеса. Сократите количество укрытий (под «укрытием» в данном случае понимается место, где игрок может «залечить раны» и пополнить боекомплект). Типичный пример кругового уровня - карта dm6 в Quake.

Линейная карта

Линейные карты отличаются минимумом альтернативных путей.

Архитектура такого уровня выполняет функцию дорожной карты. С ее помощью игроки могут сразу определить, где они находятся. Открытые пространства и широкие коридоры позволяют игрокам испытывать удовольствие от поединков, а схема распределения оружия заставляет их двигаться по всему пространству карты. Пусть боеприпасы к найденному оружию находятся на противоположном конце уровня, - это вынудит игроков предпринимать дальние переходы. В качестве примера линейного уровня можно назвать карту e1m1 в Doom.

Зональная карта

Хотя на таких картах довольно сложно выбрать короткую дорогу, они позволяют в любой момент определить, где ты находишься. Эти карты не обеспечивают той свободы и динамики, что есть на уровнях кругового или линейного типа. Они поделены на четкие, легко узнаваемые зоны, каждая из которых, в свою очередь, представляет собой несколько отдельных площадок для сражений. Так, на уровне dm3 в Quake есть водоем, узкая лестница для схватки по вертикали, а также компьютерный зал для ближнего боя. Все области в соответствии со своей тематикой предлагают игрокам специальное вооружение или дополнительное снаряжение. Зональные карты превосходно зарекомендовали себя в командных играх (см. ниже параграф «захват флага).

Тематическая карта

Последними в списке дефматч-карт стоят тематические. По словам Тима Уиллитса, они строятся с использованием уникальных условий, в которых происходят сражения и которые дают о себе знать по всей карте. Чтобы пояснить свою мысль, Тим приводит следующий пример.

Тематической картой можно назвать уровень e1m4 в Quake, известный как «Канализация». Эта карта почти полностью покрыта водой, в которой (или рядом с которой) происходит большинство схваток. Куда бы ни пошли игроки, они всюду видят воду или что-то связанное с ней. Почти во всех областях карты игрок может войти в воду или выйти из нее. Таким образом вода является «темой» этого уровня. Тематические этапы по душе тем игрокам, которые любят оригинальные решения. Эти карты трудно пройти, поэтому применяйте их лишь при игре на среднем и высоком уровнях сложности. Не забывайте, что «тема» должна усиливать впечатление от игры, а не отвлекать от нее.

Тематика карт, созданных компанией id Software, достаточно широка. Это аэродинамические трубы (Quake, e3m5), невесомость (Quake, e1m8), слабоосвещенные помещения (рудники в Quake II), опасные зоны (лава, канализация, ямы-ловушки в Quake, dm4), поражающие устройства (заградительные лазеры и разнообразные механизмы с шипами в Quake II), широкие открытые пространства (Quake II), лабиринты с телепортами (Quake, dm1).

«Захват флага»

«Захват флага», или CTF (от «Capture the Flag»), - это популярная разновидность командных сетевых игр, имеющих целью захват знамени противника и перенос его на собственную базу. В последнее время появилось много новых видов этой игры. Далее Тим Уиллитс дает советы разработчикам, создающим CTF-карты.

Симметричные уровни

Для CTF очень важно, чтобы разные стороны карты были практически зеркальными отображениями друг друга. «Теоретически, конечно, можно сделать базы неодинаковыми, - говорит Тим, - но на практике это не работает». В качестве отрицательного примера он приводит одну из неудачных карт в Quake II.

Большой ошибкой в этом плане оказался уровень Strike: из-за неправильного размещения на уровне BFG и телепортов красная команда оказалась в крайне невыгодном положении. Кроме того, эта карта обеспечивает больше подступов к базе красной команды, следовательно, синюю базу оказалось легче защищать. Наконец, боеприпасы и оружие также расположены неравномерно - на синей базе гораздо больше ресурсов. Все эти проблемы легко решить, сделав стороны одинаковыми.

Асимметричные уровни

Создавая асимметричный уровень, продумайте сбалансированные стратегии для каждой из команд. К примеру, если одна сторона карты покрыта водой, снабдите соответствующую команду аквалангами. Аналогично, в области с ядовитой слизью нужно предусмотреть защитные комбинезоны.

Другие рекомендации разработчикам CTF-уровней

Расположите рядом с базой достаточное количество вооружения и боеприпасов, но постарайтесь не переборщить. Иначе базу будет слишком легко защищать и сложно атаковать. Если на уровне предусмотрено снаряжение для улучшения характеристик, не размещайте его рядом с базой.

Сделайте так, чтобы базу можно было оборонять, но при этом предусмотрите несколько входов и выходов.

Вы не ошибетесь, если разместите основные предметы, повышающие возможности игрока, в центре карты. В любом случае их следует располагать подальше друг о друга, иначе самый расторопный игрок сможет собрать их все и быстро разобраться с противниками.

Пусть на вашей карте будут хорошие укрытия для снайперов, но и они (снайперы) должны быть уязвимы.

Установите четкие цветовые различия между игроками и принадлежащими им областями карты. Не полагайтесь на цветное освещение уровня, так как оно способно «перекрыть» цвета формы персонажей, и вы не сумеете определить, к какой команде они принадлежат. Надежнее всего использовать для этой цели разноцветные текстуры.

Обратите особое внимание на размещение на карте оружия. Для CTF-уровней оно еще более важно, чем для дефматч-поединков. Ошибка здесь может серьезно нарушить баланс сил играющих сторон.

Позднее мы еще вернемся к кудесникам из id Software, а сейчас приготовьтесь к восприятию пророческих речений. Снимите шляпы, перед вами сам Левелорд (буквально: Властелин уровней. - Примеч. перев.)!

Ричард «Левелорд» Грей (Richard «The Levelord» Gray), Ritual Entertainment

Большая часть эмоций, испытанных вами при игре в Duke Nukem 3D Quake: Scourge of Armagon или Sin, обязана своим происхождением великому чародею, называющему себя Левелордом. В чем же секрет волшебства, заставлявшего вас сидеть за экраном до поздней ночи?

Три заповеди Левелорда могут показаться очевидными, но, если верить их автору, о них часто забывают. Это интересность игры, ее интерактивность и достоверность.

Кстати, Левелорд потребовал, чтобы мы в точности сохранили текст его учения. Внемлите же!

Интересность

Первый и самый существенный вопрос для любой игры, будь то шутер или квест, - интересна ли она? Этот вопрос относится к самой игре, но он имеет важное значение для всех ее компонентов, включая разработку уровней. При создании игры его следует задавать как можно чаще.

Интересность нередко игнорируется ради авангардных решений, и основные усилия при разработке направляются не на то, чтобы сделать игру увлекательной, а на внешние эффекты. Парадокс, но многие игры выглядят превосходно, а играть в них не хочется. Да, это здорово, когда разработчик использует возможности современных технологий, чтобы привнести в игру еще один специальный эффект или повысить динамику действа, однако как же грустно наблюдать за тем, как люди тратят уйму времени на исследования и отработку деталей, напрочь забывая об основном - о занимательности игры!

Увлекательность также часто приносится в жертву реализму. Нет ничего плохого в том, что игры становятся все более реалистичными и достоверными, но очевиден и побочный эффект «реальности», вносимый в виртуальный мир игры. Слишком часто увлекательные замыслы и идеи отбрасываются только из-за того, что разработчики заявляют: «Ты что, хочешь мгновенно остановиться на огромной скорости?!» или «Настоящие пули за угол не заворачивают!» И это несмотря на обращенный к ним пьянящий призыв: «Но ведь так же интереснее!»

Не существует четких правил создания увлекательной игры, и единственный способ проверить, интересно ли играть в ваше творение, - это просто играть в него. К счастью, мир устроен так, что большинство из нас одинаково понимают, что такое увлекательная игра, и если разработчик считает что-либо интересным, его игровая аудитория, скорее всего, согласится с ним. Игровой элемент, придающий игре искрометность и живость, не должен быть мимолетным или эфемерным. Он должен выдерживать бесчисленные испытания и тесты, оставаясь до конца таким же захватывающим, каким был с самого начала. Есть только один способ гарантировать увлекательность игры - безостановочно тестировать ее, и чем больше, тем лучше.

Интерактивность игры

Шутеры с видом от первого лица - это уже не просто «расстреляй все, что движется, отыщи ключ и постреляй еще немного», как несколько лет назад. Сегодня действие происходит в полностью интерактивной среде, и элементы, которые раньше считались редкими, стали нормой. Так, если на вашем уровне есть телефон или компьютер, то пусть уж они работают, как полагается, а игрок, в свою очередь, должен иметь возможность разнести их вдребезги.

Разрешите игроку крушить все на своем пути. Лично я трачу массу времени на то, чтобы сделать объекты уничтожаемыми, но это оправдывает себя. Станьте экспертом по всякого рода разрушениям, ведь ломать вещи в игре не только полезно, но и исключительно приятно.

Еще один важный аспект игрового процесса в шутерах от первого лица - головоломки. Грамотно спроектированный уровень должен состоять из множества задач и бонусов за их выполнение. Задача может предшествовать награде или следовать за ней, самое главное - соблюдать некую закономерность, распределяя по карте монстров и гостинцы. Игрок должен чувствовать, что участвует в турнире, состоящем из серии поединков и награждений.

«Решение головоломок является неотъемлемой частью трехмерных уровней», - замечает Левелорд. Эта «горячая» сцена взята из Scourge of Armagon, первого официального аддона игрее Quake. (Использовано с Разрешения компании Ritual Entertainment.)

Добавьте в игру как можно больше анимации: она помогает почувствовать вовлеченность в действие. Пусть игрок хорошенько поработает, добиваясь награды. Сделайте все, чтобы люди, играя в вашу игру, почаще бормотали себе под нос: «Ах, вот вы как!» И пусть в игре будет побольше тайников: для игрока нет ничего приятнее чем отыскивать их.

Достоверность

Ответ на третий вопрос: «Захвачены ли вы игрой?» напрямую связан с разработкой уровней. Это особенно верно для шутеров от первого лица, где иллюзии погружения придается первостепенное значение. Вообще говоря, основная цель дизайнера уровней - любыми способами вовлечь игрока в действие на экране. А потому все другие задачи начинают работать только тогда, когда выполнена эта.

Чем больше на вашем уровне «жизненных элементов», объектов, знакомых игроку, тем естественнее он себя чувствует. Использование реалистичной обстановки и привычных ситуаций помогает игроку быстрее освоиться в игре, что также немаловажно.

Иными словами, чем ближе игроку реалии вашего уровня, тем глубже он погрузится в него.

Всепоглощающее чувство достоверности - основа успеха для любого уровня. Как, например, не вспомнить кинотеатр или футбольный стадион в игре Duke Nukem 3D или начальную сцену в банке в Sin. (Перед вами один из эпизодов игры Sin. (Использовано с разрешения компании Ritual Entertainment.)

Целостность уровня также является важным фактором, помогающим игроку полностью отдаться игре. Отличительная черта целостного уровня - обыгрывание основной темы на всем его протяжении. Слишком часто мне приходилось видеть уровни, сшитые из разных, не связанных между собой тем. Настоящая карта должна выглядеть как единое целое.

Итак, Левелорд сказал свое веское слово, подтвердив, что три его правила суть три кита, на которых зиждется любой хороший уровень. «Они могут показаться очевидными, но в них главная трудность, с которой сталкивается разработчик, особенно если он занимается дизайном уровней... Если их не учитывать, любые другие аспекты уровня будут пропущены или забыты, что отрицательно отразится на игре в целом».

Левелорд полагает, что при создании карты важное значение имеет использование тайников и секретов, которых должно быть как можно больше. Кто-нибудь из вас нашел эту надпись в Duke Nukem 3D? (Использовано с разрешения компании 3D Realms, Inc.)

Пол Джейкуэйз (Paul Jaquays), id Software

Пола можно назвать «мастером на все руки» (сомневающиеся могут свериться с его биографической справкой, приведенной в приложении), но в компании id Software он занимался разработкой уровней для Quake II, а при создании Quake III: Arena работал как над уровнями, так и над игрой в целом. О, сколько людей хотели бы оказаться на его месте! Узнав об этой книге, Пол с удовольствием поделился с нами советами по разработке уровней, а также дал ряд более общих рекомендаций, касающихся проектирования карт. Так давайте же обратимся к его рецептам.

26 советов по проектированию уровней

1. Перед началом работы определите, что вы хотите от уровня. Если это одиночная игра, не пытайтесь затем подогнать ее под нескольких игроков, а хорошие многопользовательские карты вряд ли будут интересны для сольной игры.

2. Набросайте общую схему карты, она послужит вам ориентиром в работе.

3. Не замахивайтесь сразу на нечто грандиозное. Начните с небольшого, но увлекательного уровня из нескольких комнат.

4. Попробуйте включить в уровень изюминку, которая сделает его запоминающимся. Среди наиболее популярных трюков можно назвать аэродинамические трубы, многочисленные порталы, лаву, ловушки, воду, невесомость и медленно надвигающиеся опасности.

5. Приступая к очередному проекту, постарайтесь придумать что-нибудь новенькое, чего до вас никто не делал.

6. Как следует протестируйте все трюки и ловушки, прежде чем включать их в игру.

7. Заранее продумайте архитектурный стиль уровня и подберите под него соответствующие текстуры, а в дальнейшем не отступайте от задуманного.

Верхний рисунок - это набросок Пола Джейкуэйза для Quake II, изображающий часть лаборатории с замороченной головоломкой и ловушкой, собранными из модулей передвижных тюремных камер. Эта идея не получила своего воплощения в игре. На нижнем рисунке показаны эскизы одной из первых карт типа «арена» для Quake III, где схематично изображены основные детали карты и их взаимодействие. Некоторые идеи вошли в окончательный вариант уровня, но его структура претерпела значительные изменения. (Оба рисунка использованы с разрешения компании id Software, Inc., © 1998.)

8. Создайте карту «вчерне», используя крупные блоки правильной геометрической формы. Внешний вид на этом этапе, конечно, важен, но главное - сама игра. Для начала полезно разбить карту на крупные ячейки (в Quake II и Quake III я использовал сетку с 64 ячейками). Отставьте в сторону мелкие подробности и работайте только с крупными формами. На этой стадии следует установить такую скорость обновления экрана, которая была бы заметно ниже значений, разрешенных игрой (для Quake II мы ограничили число треугольников пятьюстами на экран). Кроме того, следует ограничить количество полигонов в наиболее сложных «картинках» (например в больших помещениях или вокруг них) тридцатью процентами от возможного максимума.

Эта карта для 64-х игроков взята из аддона DM Pack 1: Extremities к игре Quake II. Пол Джейкуэйз советует дизайнерам уровней создавать на больших картах яркие, запоминающиеся игровые области. (Использовано с разрешения компании Activision.)

9. Разобравшись с динамикой игры, можно приступать к детализации игрового окружения, и уточнению внешнего вида коридоров и закрытых помещений.

10. Заготовьте побольше шаблонов и активно используйте их при создании уровня. Нарисуйте единожды красивую деталь (дверную раму, лепной карниз, старинный стул), чтобы затем при необходимости тиражировать ее на карте в необходимых местах.

11. Занимаясь оформлением уровня, думайте над тем, как это могло бы выглядеть в реальности. Пусть объекты, которые впечатляют вас в жизни, попадут в игру, даже ценой некоего упрощения.

12. Установите баланс между использованием реальной геометрии и текстур, имитирующих трехмерность. Не стоит злоупотреблять последними. Издалека квазитрехмерные текстуры действительно могут обмануть глаз, но при ближайшем рассмотрении вся иллюзия глубины пропадает.

13. Почаще компилируйте карту. Не ждите завершения работы над картой, чтобы узнать, как она выглядит (или приступить к поиску ошибок).

14. Лишь завершив работу над картой, начинайте размещать на ней монстров и предметы.

15. Работая с одиночными картами, не пытайтесь втиснуть в один уровень все, что только есть в игре, - это типичная любительщина. Единственное место в игре, где можно встретить сразу всех монстров, - это специальный уровень, созданный для тестирования системы искусственного интеллекта.

16. То же самое справедливо и в отношении игровых хитростей, ловушек, находок, оружия и специальных объектов. Если только вы не работаете над картой, подобной тем огромным дефматч-уровням для 64 игроков, что были в Quake II, ограничьте свое творение по этой части. Лучше с умом использовать несколько объектов, чем бестолково распорядиться многими.

17. Небольшие карты могут быть сравнительно однородны на всем протяжении. Большие же стоит разделить на четкие, запоминающиеся зоны, которые игрок сможет использовать для ориентирования. Вспомните, City64, огромная дефматч-карта в Quake II, состоит из глубокого ущелья, впечатляющего храма пришельцев, подводных пещер, обширного и глубокого резервуара с водой, а также бесчисленных извилистых коридоров. Коридоры однотипны, но ведут в различные игровые зоны.

18. Дефматч-карты должны предоставлять игрокам возможность избавляться от преследователей и прятаться в укрытиях. Не стоит использовать длинные коридоры с тупиками. Не заставляйте игроков совершать долгие прогулки по глухим лабиринтам, даже если их там ждет солидная находка.

19. Для пущего накала страстей используйте возможности освещения. Если у вас есть выбор, «недоосветить» или «переосветить» сцену, выбирайте темноту. Только не переборщите. Затемненные уровни могут выглядеть вполне изящно, но пробираться в потемках - развлечение на любителя.

20. Освещайте территорию по мере продвижения героя - даже если это временное освещение.

21. Не забывайте о звуке, который можно использовать для важных игровых подсказок.

22. Постарайтесь снабдить каждую игровую задачу несколькими вариантами решения. Игроки, которые решат ее наилучшим способом, просто обязаны получить специальное вознаграждение.

23. Сделайте уровень разнообразным. Карта, состоящая из одних головоломок, или, наоборот, исключительно из стрельбы, быстро надоедает.

24. Будьте милостивы к игроку, не нагружайте его без надобности. Опасность, подстерегающая в нужном месте, поддерживает напряжение в игре, но если игрок проваливается в лаву или трясину каждые пять секунд или ему на голову падает кирпич всякий раз, как он вздумает оглянуться, игра начинает вызывать совсем не те эмоции, на которые рассчитывает ее автор.

25. Изучайте чужие игры, не стесняйтесь перенимать оттуда понравившиеся элементы. А еще лучше - доводите их до ума.

26. Не забудьте закончить начатое! (Как показывает опыт множества программистов, художников, аниматоров, музыкантов и дизайнеров уровней, выполнение последнего пункта обязательно и представляет довольно серьезные трудности для начинающих.)

Общие рекомендации по разработке игр

За двадцать четыре года работы в игровой индустрии Пол Джейкуэйз накопил гигантский опыт в искусстве создания игр. Выше он поделился с нами своими умозаключениями по поводу проектирования уровней, а теперь речь пойдет о более общих вопросах «игростроения»...

Не занимайтесь автоцитированием

Я начинал в индустрии с работы над настольными ролевыми играми новой по тем временам серии Dungeons & Dragons, а затем и Runequest. И, между прочим, считался там одним из лучших. Но спустя некоторое время я бросил это занятие, осознав, что начал подражать самому себе, повторяя на все лады одни и те же сюжеты. Из моего творчества исчезла новизна. К счастью, у меня были другие возможности продолжать карьеру в игровом бизнесе. Но вопрос остается: как поддерживать жизнеспособность и новизну идей?

Выбирайте нестандартные решения

Очень часто, сталкиваясь с альтернативой, разработчик выбирает решения, проверенные временем. На закате Золотого века видеоигр (8-битная классика) почти все игры, основанные на лицензии на использование известного персонажа или фильма, применяли горизонтальный скроллинг (прокрутку игрового экрана). Когда я работал в Coleco (в те времена, а речь идет о 80-х годах, основной конкурент такого аркадно-приставочного монстра, как Atari. - Примеч. ред.), мы в основном были заняты анализом чужих проектов и переделкой разнообразных аркад, не имея возможности создавать собственные игры.

Все изменилось с получением лицензии на использование фильма «Военные игры». Стандартным решением явилась бы очередная плоская игра по принципу «реши головоломки, разыщи бонусы и увернись от плохих парней» с решающим поединком в конце. После этого вы вернулись бы к началу игры с чуть более высоким уровнем сложности. Однако после просмотра специальной компьютерной версии фильма я задумался над одним из его завершающих эпизодов, где компьютер моделирует сценарий за сценарием, но исход оказывается всегда одним и тем же: ядерная война и опустошение планеты. Мне понравилось изобразительное решение - траектории приближающихся к целям ракет. Я понял, что если только удастся убедить начальство, то из одного этого короткого фрагмента можно сделать целую игру.

Игровой процесс, геймплей, стал суммой нескольких, не связанных друг с другом понятий. Цель игрока - помешать бомбардировщикам, подводным лодкам и ракетам (рассчитывать и отображать на экране их траектории - не такая уж простая задача для тех «древних» 8-разрядных систем), уничтожающим объекты на территории США. Нечто подобное было осуществлено в популярной аркаде Missile Command, где игрок должен сбивать ракетами класса «земля-воздух» баллистические ракеты, падающие с верхней части экрана. В отличие от Missile Command, в нашей игре нужно было следить за шестью различными картами одновременно. Подобно жонглеру, вращающему тарелки на концах нескольких шестов, игрок должен мгновенно переключать внимание с радарной карты, показывающей всю территорию США, на шесть небольших карт с более подробными видами городов и военных объектов. Столь же быстро распоряжаясь ресурсами (ракетами, самолетами-перехватчиками, подводными лодками), вы отбивали атаки врага, после чего переходили на следующую карту, где проделывали то же самое.

Смешивайте противоположности

Рецепты многих популярных блюд содержат непохожие или даже противоположные по вкусу ингредиенты. Вот всего два примера: кисло-сладкие китайские кушанья и чикагские хот-доги. Какое отношение это имеет к играм? Одним из проектов, которым я могу гордиться, является серия книг под названием «Central Casting». Цель этой работы - сочинение занимательных историй о похождениях персонажей ролевых игр. Я написал несколько книг, касающихся трех РПГ-жанров: фэнтези, научной фантастики и «современности». Игроки бросали кости и определяли результаты по таблицам и спискам. За несколько ходов они выбирали события биографии и личные качества персонажей игры. Довольно часто эти результаты казались несовместимыми, но творческий подход позволял объединить разнородные события подобно тому, как множество ароматов чикагского хот-дога сливается в одну уникальную комбинацию.

Не забывайте о реализме

Даже в том случае, если вы собираетесь создать нечто совершенно фантастическое, не имеющего никакого отношения к реальному миру, постарайтесь сохранить ощущение реальности. К этому выводу я пришел, иллюстрируя обложки фэнтези-книг и оформляя коробки игр того же жанра. Чтобы фантастические элементы на рисунке выглядели достоверно, нужно всего лишь реалистично изобразить те детали, которые являются вполне земными. И тогда у зрителя создается впечатление, будто все срисовано с натуры. При этом фантастические объекты следует прорисовывать с тем же тщанием, что и реальные. Этот же механизм восприятия работает и при создании уровней 3D-игры. Игрок должен видеть хотя бы один знакомый ему элемент. Нереальные предметы должны казаться более реалистичными, нежели реальные, вернее, более правдоподобными. И тогда, благодаря контрасту с привычными вещами, они покажутся еще более фантастическими, еще более манящими.

Джон Ромеро (John Romero), ION Storm

«Работа дизайнера уровней чрезвычайно важна, потому что карты - это то место, где проходит вся игра», - говорит Джон Ромеро, разработчик, глава и соучредитель компании ION Storm. Легендарный Ромеро, один из авторов классических 3D-шутеров Wolfenstein 3D, Doom, Doom II, Heretic, Hexen и Quake, знает цену этим словам...

Джон утверждает, что разделение обязанностей в процессе разработки может пагубно сказаться на общей увлекательности и целостности игры. «Во многих компаниях, - говорит он, - уровни разрабатываются по частям, конвейерно, одни люди отвечают за архитектуру карт, другие за художественное оформление, третьи за размещение объектов и т.д... Ничего хорошего из этого, как правило, не выходит».

Хотя большинство советов по созданию уровней универсальны (разместите на карте ориентиры, чтобы придать ей неповторимые черты; помогите игроку погрузиться в вымышленный мир и т.д.), Джон Ромеро предлагает интересное правило, которое, как он считает, чаще нарушается, чем выполняется. «Игрок постоянно должен находиться в напряжении, - говорит Джон. - В нашем жанре очень важно заставить игрока выкладываться на полную катушку, расставить ему побольше ловушек, чтобы он постоянно трясся за свою жизнь».

Ориентиры в игре выполняют двойную функцию: они не только глубже погружают игрока в мир игры, но и помогают ему понять свое положение и направление движения.

Джон приводит конкретные примеры, такие как уровень Е2М5 (Wizard's Manse) в игре Quake, когда игрок оказывается запертым в клетке, медленно погружающейся в воду. Столь же неторопливое вертикальное погружение есть и на другой карте Quake - E2M6 («Dismal Oubliette»), оно навеяно катанием на лифте в «доме с привидениями» парка развлечений Disney World. «Игрок в панике, ему некуда деваться, он не видит выхода, и вдруг в помещение телепортируется Шэмблер, откуда-то выскакивают шипы, приходится сражаться со злым демоном, а затем появляются зомби. Одна опасность следует задругой, - улыбается Джон. - Вот ключ к созданию хорошего уровня».

Что ж, у Джона есть возможность доказать нам на практике эффективность этих советов, когда он завершит, наконец, игру Daikatana (выпуск намечен на 2-й квартал 2000 года).

Клифф Блежински (Cliff Bleszinski), Epic Games

В свои двадцать пять лет Клифф пользуется заслуженной славой как разработчик и дизайнер уровней таких знаменитых игр, как Jazz Jackrabbit и Unreal. Соглашаясь с Джоном Ромеро в том, что игрок постоянно должен находиться в напряжении, он все же считает, что это лишь один из факторов, влияющих на увлекательность уровня. «Гораздо важнее общая динамика игры. Если игрок боится гибели на каждом шагу - он впадает в оцепенение. Если его постоянно подстерегают неожиданности, он устает и теряет интерес», - поясняет Клифф.

Необходимо тщательно продумать, где, когда и как устраивать ДЛЯ игрока опасности. Представьте: на протяжении пяти минут вы совершенно спокойно исследуете местность и беседуете с мирными существами, а затем внезапно распахивается дверь, и из нее вываливается злобно рычащее огненное чудовище. Ваша реакция - инстинктивный страх, и это правильно. Заметьте, что в хороших фильмах ужасов страшные события происходят не так уж часто. Соблюдение баланса необходимо при создании каждого элемента уровня. Нужно правильно выбрать вид и количество монстров, предусмотреть области, в которых игроку приходится уничтожать множество глупых и слабых тварей, а также области, где монстры малочисленны, но очень сильны и коварны. Награды в виде дополнительного здоровья и полезных вещей должны встречаться не слишком часто, но и не слишком редко. Не стоит злоупотреблять подобными приемами; куда правильней награждать игрока за конкретные дела: уничтожение монстра, открытие двери, взятие высоты.

За игроком гонится Скаарж - и это придает уровню особый интерес. Однако Клифф Блежински не советует злоупотреблять опасностями - они не должны подстерегать игрока на каждом шагу. (Использовано с разрешения компании Epic MegaGames.)

Клифф признает, что для создания хорошего уровня одного умения держать игрока в напряжении и верно расставлять ловушки мало. Он предлагает собственный интенсивный курс «повышения квалификации» из пяти шагов. Взяли карандаш в руки? Тогда приступим...

Геометрия и текстуры

Разумеется, вначале нужно создать игровую среду. В идеале художники готовят текстуры, которыми дизайнеры уровней оформляют создаваемые области. Дизайнер может сказать художнику: «Мне нужна балка размером 32x128, с тремя болтами и без ржавчины. И не забудь, пожалуйста, включить ее в типовой набор текстур для карты фабрики!»

Освещение

Освещение может само по себе создать или испортить всю сцену. В полутьме монстры выглядят куда внушительней, а хорошо освещенные участки позволяют отдохнуть от блуждания в потемках. Используйте подсветку творчески. Например, если ваш герой погружается в жерло вулкана, пусть в спектре освещения преобладают красный и оранжевый тона, а поход через болота будет выдержан в тусклой, серо-зеленой гамме.

Панно Икельс (Pancho Eekels), один из дизайнеров у ровней, коллега Клиффа Блежински, сумел создать хорошо освещенное, красочное и в то же время мрачное помещение. Скриншот из игры Unreal Tournament. (Использовано с разрешения Клиффа Блежински.)

Программное ядро Unreal или Quake предоставляет дизайнеру уровней великолепные возможности для создания реалистичных оттенков. Обязательно продумайте, как, работая над уровнем, вы будете использовать тени. Поместите несущие балки на фоне окон, чтобы получить резкие и мрачные тени на полу, или заставьте пламя за решеткой камина отбрасывать нечеткие и выразительные тени на противоположную стену.

Трюки, ловушки, головоломки

Не заставляете игрока добывать опыт большой кровью. Дайте ему возможность отгадать загадку без особых потерь. Помните, люди приобретают игру, чтобы развлекаться, а не работать. Например, если вы поставили ловушку, в которой из пола выскакивают острые клинки, «разместите» вокруг нее лужи крови и куски растерзанных тел, чтобы внимательный игрок мог заметить опасность. И тогда, даже погибнув, он воскликнет: «Как же я не заметил этого предупреждения!», восприняв вашу ловушку как должное.

Если основная цель игры - убивать и как можно быстрее, не задерживайте игрока утомительными головоломками. Одно дело - предложить игроку подобрать комбинацию из трех переключателей, чтобы войти в дверь, и совсем другое - заставить его возиться со сложнейшей кодовой комбинацией из двенадцати цифр, ключ к которой находится где-то совсем на другом уровне, а потом бежать за карандашом и бумагой, поскольку запомнить все это невозможно.

Монстры, боеприпасы, аптечки (динамика игры)

Во время работы над Unreal я требовал от дизайнеров уровней, чтобы чудовища либо патрулировали небольшую область, либо внезапно набрасывались на игрока из темноты (или, как вариант, через стекло, разбивая его своим телом). Если игрок входит в помещение, а монстры просто стоят и ждут его, то вряд ли такой мир покажется правдоподобным. Если же чудовище проходит мимо, не замечая вас, и направляется к компьютерному терминалу, то, согласитесь, вы готовы оценить реализм ситуации достаточно высоко.

Довольно много внимания приходится уделять размещению боеприпасов. Дайте игроку слишком много боеприпасов, и он пройдет уровень без каких бы то ни было усилий; резко урежьте их количество, и игрок будет все время бегать с оружием начального уровня, попутно подумывая о поиске секретных кодов в Интернете. Оптимальный вариант - когда ящик патронов обнаруживается как раз в тот момент, когда игрок начинает думать: «Скоро у меня кончатся патроны. Где бы их найти?» Это же правило справедливо и для аптечек.

Сценические эффекты

Работая над Unreal, мы стремились передать атмосферу враждебного мира чужой планеты. Этому сильно помогло то, что я называю «сценическими эффектами». Вы слышите звуки ссоры из-за закрытой двери; видите, как наказывают дружественного инопланетянина за то, что он помог вам; у вас на глазах убивают вашего товарища... Множество подобных событий, происходящих в реальном времени, в которые игрок может вмешаться. Правильно подобранные сцены могут увлечь игрока настолько, что он будет играть в вашу игру по меньшей мере несколько лет.

Итак, дизайн уровня очень важен. Почему? «Уровень - это место соприкосновения колес машины с дорогой», - так однажды сказал Клиффу Джей Уилбур (Jay Wilbur), бывший исполнительный директор компании id Software. Это сравнение запомнилось Клиффу как «абсолютная истина». Далее он развивает эту аналогию:

Разработку игры можно сравнить со сборкой автомобиля. У вас на руках отдельные части, созданные талантливыми специалистами: программы, модели, художественное и звуковое оформление, - осталось все это соединить, и колеса коснутся мостовой. Уровни - вот место, где подводится итог работе всех специалистов. Неудачная сборка сведет на нет усилия всего коллектива.

Марк Лейдлоу (Marc Laidlaw), Valve Software

Первая игра компании Valve, Half-Life, появившаяся всего лишь полтора года назад, уже вошла в историю шутеров с видом от первого лица. Игра оказалась выдающейся по всем параметрам: сюжету, оформлению, анимации, звуковым эффектам, музыке, динамике и структуре уровней. Все это вместе заставляет игрока почувствовать себя частью реального мира, живущего по своим законам. Во многом подобный эффект присутствия - заслуга дизайнеров уровней, не опустивших планку даже в последней трети игры, где действие происходит на другой планете, а значит, узнавание затруднено по определению.

В компании Valve Марк Лейдлоу координировал работу группы создания уровней и руководил шестью дизайнерами, трудившимися над Half-Life едва ли не круглосуточно. Кстати, для этой игры было создано 96 непревзойденных BSP. Несмотря на свою колоссальную занятость, Марк выкроил время для рассказа о своем подходе к дизайну уровней.

BSP - это средство для преобразования файлов карт в файлы уровней, совместимые с Quake. Half-Life использует движок Quake/Quake II, поэтому мини-уровень иногда называется BSP.

Цель

Самое главное в уровне - его цель. От этого зависит вся схема игры. «На уровне все должно быть подчинено его цели, в том числе второстепенные красоты и всевозможные мелочи», - говорит Марк Лейдлоу.

Игровой процесс

Не менее важен процесс игры, геймплей. Какие действия должен выполнять игрок, чтобы пройти уровень? Смогут ли эти действия заинтересовать игрока, увлечь и погрузить в игру настолько, чтобы он не смог оторваться, пока не выиграет?

Атмосфера

Марк спрашивает: «Какое настроение вы хотите создать у игрока? Вы погружаете его в атмосферу «ужастика» или боевика? Будет ли оно контрастировать с атмосферой предыдущего и последующего уровней?» Задача состоит в том, чтобы подобрать детали, создающие нужное настроение.

А теперь рассмотрим три упомянутые Марком фактора - цель, геймплей и атмосферу - более конкретно на примере ключевых уровней игры Half-Life.

Уровень Office Complex («Офисный комплекс»)

Этот уровень состоит из разнообразных помещений: офисов, лабораторий, коридоров и лестничных пролетов, намеренно оформленных в тусклых, невзрачных тонах. Иными словами, это самый обычный интерьер, абсолютно непохожий на привычные декорации научно-фантастических игр. Марк Лейдлоу анализирует этот уровень с точки зрения каждого из рассмотренных выше факторов.

Цель. Цель игрока на этом уровне тривиальна: выйти из здания. Выход обнаружить чрезвычайно просто. Структура карт тоже проста, по сути линейна. Однако на пути к цели мы разместили препятствия, чертовски затрудняющие продвижение вперед. Например, через стеклянное окошко двери можно увидеть, что выход находится в конце коридора, но открыть эту дверь невозможно, поэтому игроку приходится искать другие варианты. Разумно расставленные препятствия превращают очевидное с первого взгляда решение в сложную и далеко не бесспорную задачу. Такой способ применен в Half-Life множество раз. Игроку важно сразу же знать цель, чтобы он получил возможность немедленно приступить к поиску решения. Если же он по пути забудет о цели, тем сильнее будет его потрясение, когда внезапно ее обнаружит.

Марк Лейдлоу подчеркивает, что создание карт в жанре 3D-шутеров требует понимания цели, геймплея и атмосферы уровня. Здесь приведены скриншоты уровней Office Complex и Questionable Ethics из игры Half-Life. (Приводится с разрешения компании Sierra Studios.)

Геймплей. Этот уровень стоит в игре одним из первых, поэтому геймплей приспособлен для того, чтобы игрок овладевал основными навыками, которые еще понадобятся ему при встрече с более серьезными опасностями. Ему приходится ползти, укрываться от атак, сражаться с монстрами на крохотных пятачках. Медленно передвигающиеся монстры вызывают у игрока чувство постоянной угрозы и предоставляют ему массу возможностей действовать вместе с союзниками. Игрок разговаривает с другими компьютерными персонажами и решает небольшие головоломки (как вывести из строя вон те пулеметы и отключить высокое напряжение, подаваемое на ограждение). Поскольку на следующем уровне игроку придется сражаться с настоящими коммандос, здесь ему предоставляется возможность потренироваться на отрядах довольно слабых и даже забавных существ.

Атмосфера. Унылая атмосфера обыкновенного офиса - отличный фон для сцен резни и ужасов: контраст с обыденной обстановкой производит потрясающий эффект. Научные сотрудники гибнут в вентиляционных шахтах, монстры пожирают трупы в столовой. В создании подходящей атмосферы очень важным элементом является звук - его вклад не заменят никакие картинки. Как только игрок входит в морозильную камеру, включается соответствующая музыка. Мрачные аккорды, многократно повторяемые эхом, вызывают ощущение угрожающей пустоты. Эхо усиливает не только реализм сцены, но и ощущение страха. Неудивительно, что по коже начинают ползать мурашки.

Далее Марк обсуждает другой уровень Half-Life. Его действие происходит в научно-исследовательской лаборатории Black Mesa. Игрок получает возможность взглянуть на некоторые эксперименты, которые велись здесь, когда произошла катастрофа.

Уровень Questionable Ethics («Сомнительная этика»)

Лаборатории в игре выполняют самые разные функции. Они создают атмосферу таинственности и заставляют игрока задуматься, что же, собственно, произошло в Black Mesa. Они обеспечивают игроку доступ к мощному оружию, которое поможет ему в схватках с сильными противниками на следующих уровнях. Наконец, они помогают ему освоить новый стиль решения головоломок, где главная цель - не просто подобрать нужную комбинацию переключателей, но при этом защитить научных работников.

Цель. Структура этой части лаборатории нелинейна, хотя поначалу наличие запертых дверей позволяет вам продвигаться самым обычным образом. Нелинейные области снижают обычный динамизм и напряжение, позволяют не торопиться, запутывают ситуацию и создают массу возможностей для скуки. Игрок запросто может забыть о цели или пройти мимо нее. Проектируя лабораторию на бумаге, мы решили, что игрок должен увидеть свою цель (выход) сразу после входа в вестибюль. Рядом с запертой дверью находится сканер, но опыт прохождения предыдущих уровней подсказывает игроку, что работать со сканером могут только ученые и прочие вспомогательные персонажи. Игрок должен помнить об этом, пробиваясь с боями к другим областям карты, все дальше от выхода, и когда он обнаружит группу спрятавшихся ученых, то поймет, что должен сопровождать одного из них через лабиринт лабораторных помещений обратно к сканеру. (Чтобы облегчить игроку понимание его цели, мы добавили охранника, который дает краткие пояснения по пути к этой области.)

Геймплей. Головоломки на этом уровне перемежаются со схватками, ловушками и хитроумными приспособлениями, логически связанными с игровой средой: стерилизаторами, лазерным оборудованием, монстрами в клетках. Добыть оружие непросто: игроку приходится подставиться под удар, а затем быстро нейтрализовать угрозу. К примеру, в одной из головоломок нужно открыть клетку с акулами, а затем быстро отступить в комнату управления стерилизатором и уничтожить монстров прежде, чем они до вас доберутся. Кроме того, наряду с инопланетными чудищами игроку постоянно угрожают вражеские солдаты-люди. В некоторых случаях игроку бывает выгодно подождать схватки между людьми и инопланетянами, а затем сразиться с ослабленным победителем. Лучшая тактика здесь - терпение. Это совсем непохоже на обычные экшен-игры, где для успеха лучше всего атаковать врага «в лоб».

Атмосфера. Мы отобрали детали, соответствующие нашим представлениям об исследовательском центре и общем сюжете игры. Некоторые зоны здания были специально отведены для изучения инопланетных существ, что заставляет задуматься, как давно ученые знали о существовании инопланетян и какие именно опыты проводились в лабораториях. Кроме того, такие детали хорошо использовать в самой игре. Так, стерилизаторы, с помощью которых ученые очищали помещения от инопланетной инфекции, оказались очень удобны для уничтожения преследующих вас солдат. Добиваясь того, чтобы господствующим настроением в Half-Life был постоянный страх перед неизвестной опасностью, мы отказались от множества возможностей превратить игру в эксцентричную комедию и постарались вместо этого создать ситуации, где действие разыгрывается с мрачной иронией. К примеру, «Тау-распылитель» достается игроку после крайне мрачной последовательности действий. И вместе с оружием он получает «в награду» мелодию, которая оттеняет действие, слегка скрашивая в остальном неумолимое чувство постоянного ужаса.

Ограничение в инструментах

Не забывайте, что все вышеупомянутые факторы придется воплощать в жизнь, используя имеющийся в вашем распоряжении инструментарий и с учетом ограниченных возможностей движка.

Поначалу эти ограничения могут показаться неудобными, зато они помогают планировать и сосредоточиться на творчестве. Если вы располагаете программистами, способными внести в игру любые новые функции, казалось бы, работа должна идти более свободно, но иногда такая свобода отягощает соблазнами, мешая пользоваться тем, что уже есть. Предвидеть же последствия новшеств очень трудно. Дизайнеры уровней, создавшие множество карт для Quake, привыкли взаимодействовать с определенным количеством материала, знают все ограничения движка, все объекты, с которыми они уже работали, знают, как создавать спецэффекты с учетом всех этих факторов. Если же правила внезапно меняются, появляется множество новых объектов и функций, изменяется сам движок, то наступает нечто вроде паралича. Подобное происходит с любителями, которые вдруг начинают работать на профессиональной основе... Поэтому следует трезво рассчитывать свои силы и переходить к новшествам постепенно.

Спланируйте все заранее

Марк считает, что если вы способны удержать все детали в голове - прекрасно, но лучше все-таки спланировать все на бумаге.

Это полезно. Расписав проект на бумаге, легче оценить идею. Если вы не можете выразить задуманное в нескольких словах или нарисовать понятную схему, ждите серьезных затруднений по ходу разработки, когда вы уже потратили уйму времени на создание уровней.

Не работайте в одиночку

Марк Лейдло советует начинающим дизайнерам почаще обсуждать идеи с единомышленниками.

Несколько голов всегда лучше одной. Работая в коллективе, можно прийти к более оригинальным и интересным идеям, чем в одиночку. У каждого свои вкусы, пристрастия к определенному стилю игры, свой подход к дизайну, поэтому участие в работе нескольких людей позволяет избежать творческого застоя.

Творите

Марк признает, что учиться на чужих примерах полезно, но советует использовать их лишь в качестве трамплина для собственных идей.

Каждый начинает с попытки повторить или переделать любимые игры или фрагменты, это полезно для приобретения основных навыков. Однако переработка старых идей не может привести к выдающемуся результату. Попробуйте вообразить себе игру, в которую вы с удовольствием сыграли бы, существуй она в действительности. А затем... сделайте ее сами!

Эрик Биссман (Eric Biessman), Raven Software

На электронный адрес Эрика Биссмана, работающего в компании Raven Software в качестве руководителя проектов, ведущего разработчика и дизайнера уровней, постоянно приходят письма от желающих научиться создавать такие же захватывающие уровни, как в игре Heretic П. Здесь приведен составленный Эриком список рекомендаций начинающим разработчикам.

• Уровень должен быть интересным. Это ведь игра, в конце концов.

• Спланируйте уровень, прежде чем приступать к работе. Заниматься разработкой с чистого листа - пустая трата времени.

• Черпайте идеи из реального мира, чем бы вы ни занимались. При этом избегайте плагиата. Детали очень важны, но следует убедиться, что они взяты из головы, а не из чужой игры.

• Сначала я набрасываю идеи, которые могут лечь в основу уровня. Затем обычно прорабатываю небольшие, но очень важные для игры области и начинаю «плясать» от них. Словом, прежде чем загружать редактор уровней, попробуйте изобразить будущую карту на бумаге.

Эрик Биссман считает, что ключевые области, такие как Silverspring Docks в игре Heretic II, вначале следует набросать на бумаге. (Использовано с разрешения компании Activision, Inc.)

• Будьте настойчивы. Чем больше вы практикуетесь, творите и строите, тем лучше у вас будет получаться. Познакомьтесь с другими разработчиками и регулярно обсуждайте с ними основные вопросы. Почаще играйте в самые различные игры, подмечайте в них все хорошее. Пусть ваше увлечение превратится в страсть. Если у вас этого не получается, стоит подумать о смене профессии. Конечно, 90% времени игрового проекта занимает рутинная кропотливая работа, но одного усердия все же мало - необходим талант. В противном случае создать что-либо достойное невозможно.

Пол О'Коннор (Paul O'Connor), Oddworld Inhabitants

Пол О'Коннор, ведущий разработчик Oddworld: Abe's Oddysee и Oddworld: Abe's Exoddus, знает о создании игр не понаслышке (в том или ином качестве он работает над играми с 1981 года). В этой главе Пол представляет несколько иной взгляд на вещи, поскольку первые две игры серии Oddworld относятся к двухмерным платформенным играм.

Пол предлагает ответить на следующие вопросы. «Правильно ли поймет игрок созданные вами уровни и головоломки? Ясно ли указано, что следует делать в каждом случае? Интересно ли будет игрокам решать предложенную задачу?»

Поскольку в компании Oddworld каждый дизайнер работает над своим набором уровней, а порядок следования уровней в игре иногда выясняется лишь на последних стадиях проекта, возникает вопрос: как конкретная карта вписывается в общую схему игры в плане сложности и содержания задач? Если уровень требует от игрока особых навыков, смогли игрок приобрести их на предыдущих этапах? Иными словами, всегда ли дизайн уровня и его сложность соответствуют его месту в игре?

Необходим ли этот уровень для развития сюжета? Какие жизненно важные навыки приобретет игрок в процессе прохождения этого уровня? Как он связан с предыдущим и последующим уровнями?

Относительно предварительного планирования уровня на бумаге Пол сказал следующее:

Я действительно делаю наброски, но только если ситуация мне не знакома. Редактор уровней, который мы использовали для работы над играми серии Oddworld, был достаточно гибким инструментом и обычно я садился за компьютер с приблизительной оценкой того сколько ресурсов отпущено бюджетом на эту часть игры, и общими представлениями о типе игры, а затем просто начинал работать.


Создание миссий

Глава 7

Создание миссий

Миссии, или сценарии, являются составной частью стратегий, симуляторов и ролевых игр. Впрочем, в последнее время подобная схема построения игр все чаще используется в шутерах и квестах.

Только что, в главе 6, вы познакомились с некоторыми правилами создания уровней - игрового элемента, являющегося принадлежностью экшен-жанра: планировкой игрового пространства (построением карты) и расположением в нем предметов. Здесь же речь пойдет о миссиях, ставящих перед игроком те или иные цели, которые он должен выполнить. Эти цели, или задания, могут соответствовать реальным историческим событиям, как, скажем, в симуляторах воздушных сражений Второй мировой войны или пошаговых военных стратегиях, или не иметь к реальности совершенно никакого отношения, как в фантастических ролевых играх. Нередко миссии разбиваются на несколько небольших заданий. В свою очередь, сами миссии являются лишь частью чего-то большего, например кампании, из последовательности которых и складывается основной сюжет игры.

Кампаниями в игре называются цепочки отдельных миссий, которые необходимо последовательно выполнить для достижения главной цели. Так, сверхпопулярная стратегия StarCraft (Blizzard) содержит три кампании для различных рас - зергов, протоссов и землян, а каждая кампания состоит из 10 отдельных сценариев.

В динамических кампаниях успехи и неудачи отдельных миссий влияют на ход игры в целом. К примеру, если в какой-либо миссии вы разрушили радиолокационные станции Саддама Хуссейна в северном Ираке, то дальше иракцам будет сложнее заметить американские и английские самолеты, приближающиеся со стороны восточной Турции. Такие моменты, естественно, вносят в игру правдоподобие и дополнительное удовольствие: игрок чувствует себя полноправным участником событий, а не пассивным исполнителем воли разработчика. Об этом часто забывают, из-за чего сотни игр каждый год терпят неудачу: игроку просто надоедают однообразные миссии и кампании, излишне запутанные ситуации, а также слишком легкие или чересчур сложные задания.

В играх, подобных European Air War компании MicroProse, используются динамические кампании, где миссии (и ситуации внутри миссий) изменяются в зависимости от течения игры. (Использовано с разрешения Hasbro Interactive, Inc.)

Эта глава содержит советы избранных специалистов о том, как превратить заурядную игру в настоящий шедевр.

Роб Пардо (Rob Pardo), Blizzard Entertainment

Роб Пардо является продюсером и дизайнером компании Blizzard Entertainment. При создании игры StarCraft он отвечал за баланс юнитов (боевых единиц), а во время работы над Brood War, весьма памятным набором дополнительных миссий к StarCraft, был ведущим дизайнером. Роб советует создателям миссий твердо придерживаться следующих правил.

Не усложняйте

Используйте не более одного условия выполнения каждой миссии (будьте ограниченное время, спасение отряда и т.п.), при этом оно должно быть предельно понятным. Слишком большое количеств условий и целей сбивает игрока с толку и он может упустить из виду основную задачу миссии.

Сначала спланируйте миссию на бумаге

Не поленитесь набросать на бумаге эскиз карты и расписать события миссии. В конечном счете это избавит вас от лишней работы: изменить что-либо на бумаге намного проще, чем в редакторе миссий.

Пусть карта радует глаз

Разумеется, самое главное - это игровой процесс, однако не стоит пренебрегать и художественным оформлением. Вот несколько правил, которым мы следовали в процессе работы над StarCraft.

• Пространство должно быть оформлено в изометрической проекции, это позволяет избежать неестественных длинных горизонтальных и вертикальных линий в пейзаже.

• Используйте разнообразные типы поверхности. Общее правило таково: в пределах экрана должно быть видно более одного типа поверхности (вода, земля, болото, песок и т.п.).

• Разумно используйте дополнительные элементы оформления. «Декор» очень полезен, он делает карту интересной и своеобразной, но расположение этих элементов не должно создавать помех игроку. Лучше всего размещать их вдоль границ карты (края обрывов, береговые линии и т.п.), редко пересекаемых игроком.

Четкие инструкции и цели

После того как игроки прошли инструктаж и ознакомились с задачей миссии, у них не должно быть проблем с началом игры. По моим меркам, если миссия содержит более трех целей, она уже относится к категории «не совсем понятных». Игроки не обязаны страдать из-за того, что они не знают, что делать дальше. Это существенный недостаток как многих миссий, так и некоторых игр в целом.

На скриншоте приведен эпизод из игры StarCraft: Brood War компании Blizzard Entertainment. Роб Пардо утверждает, что наличие более трех задач в миссии может сбить игрока с толку. (Использовано с разрешения компании Blizzard Entertainment, Inc.)

Избегайте пауз

Каждая пауза, вставленная вами в игровой процесс, мешает ощущению погружения в игру. Это допустимо, если вы хотите заострить внимание игрока на основных моментах сюжета или изменить цель миссии, но такие вставки должны быть скорее исключением, чем правилом. С другой стороны, сюжетный видеоролик отлично смотрится в конце миссии. Это награда, и игрокам обычно нравится, что можно расслабиться и посмотреть, как развивается сюжет на данном этапе.

Разумно наращивайте сложность

Какой бы ни была относительная сложность миссии, она должна постепенно нарастать с течением времени. Постарайтесь отказаться от налетов «карательных отрядов», стирающих игрока с лица земли в первые полчаса игры.

Правильно распределяйте ресурсы (на опыте StarCraft)

Согласно алгоритму выбора пути, который использовался в StarCraft, рабочие, добывающие минералы («кристаллы»), один из ресурсов в игре, могут легко «застрять» на месте, если месторождение истощится. Чтобы этого избежать, располагайте залежи ресурсов в строго определенном порядке и, прежде чем объявлять карту готовой, непременно протестируйте каждое месторождение.

Тестирование, тестирование и еще раз тестирование

Безостановочно тестируйте создаваемые карты, чтобы убедиться, что они работают без сбоев, а сложность игры соответствует задуманной. В Blizzard ближе к концу проекта в тестировании принимают участие все сотрудники. Только в этом случае мы можем быть уверены, что игра соответствует нашим стандартам качества.

Нельзя забывать и о том, что у разработчика, знающего игру от и до, попросту «замылен глаз», и с какого-то момента он не в состоянии видеть в игре недостатки. Поэтому предложите отдельную миссию кому-нибудь из приятелей, не знакомых с проектом. Может статься, что ваш друг не сможет разобраться с заданием, которое вы считали простым, и не справится с игрой.

Этапы работы над кампанией Brood War

Роб Пардо предлагает вашему вниманию хронологический обзор этапов создания одной из кампаний к игре StarCraft: Brood War.

1. Сюжетная основа. Первая задача - создание сюжета кампании. При этом очень важно, чтобы сюжет можно было изменить со временем. Сюжет - та самая печка, от которой мы потом все время плясали, разрабатывая кампанию в целом.

2. Структура кампании. Кампания Brood War носит линейный характер, где общий сюжет складывается из историй каждой из трех рас. Нам нужно было выбрать порядок ее прохождения игроком. В данном случае мы решили, что игрок начнет кампанию за протоссов, затем перейдет к землянам и закончит зергами.

3. Основные моменты сюжета. Затем нужно было определить основные события сюжета: какие персонажи должны погибнуть, кто и как станет предателем и т.д.

4. Первоначальный план кампании. Дизайнеры собираются в одной комнате и устраивают обсуждение основных черт каждой миссии, из которых складывается кампания. При мозговом штурме ни одна идея не считается плохой. Важно, чтобы в разговоре приняли участие все члены авторского коллектива, а любое из предложений должно быть зафиксировано. Мы тратили около 15 минут на каждую миссию, просто обсуждая ее сюжет, объем, дополнительные условия, доступные юниты и т.п.

5. Повторная проработка сюжета. После первого обсуждения кампании обнаружилось, что необходимо изменить некоторые части сюжета, чтобы состыковать их с целями ряда миссий. (Так, для лучшей передачи сюжета нам пришлось добавить в последнюю кампанию две дополнительные миссии.)

6. Повторное обсуждение миссий. Настало время конкретизировать наброски. Мы вернулись к каждой из миссий, чтобы еще раз обсудить, как она должна выглядеть, где будет начата игра, каким должен быть размер вражеских сил, что должен представлять из себя искусственный интеллект, как и где должны размещаться триггеры. Заметьте, что до сих пор ни одна из миссий не дошла даже до редактора. Вся работа велась на бумаге в конференц-зале.

7. Наконец-то переходим к осуществлению задуманного! Настало время распределить задачи между участниками проекта и начать работу. Дизайнеры несут ответственность за создание ландшафта, расстановку на местности вражеских юнитов и планирование их действий.

8. Программирование искусственного интеллекта. Далее за дело берутся программисты соответствующего профиля, чья задача - разработать разнообразные модели поведения компьютера (искусственного интеллекта), отвечающие предварительно намеченному плану миссий и их сложности.

9. Тестирование игры. Для полной готовности миссии понадобятся еще две-три недели тестирования и доработок. При этом очень важно не трогать уже готовые миссии! Даже самое незначительное изменение способно привести к необратимым последствиям в геймплее и тем самым пустить прахом всю работу.

Баланс юнитов

Одно из самых слабых мест и, по иронии судьбы, одна из самых важных составляющих стратегий в реальном времени - это правильный баланс юнитов, боевых единиц. Роб Пардо объясняет нам значение этого фактора для игры и предлагает несколько рекомендаций, позволяющих обеспечить выполнение принципа «камень - ножницы - бумага» для созданных вами видов войск (речь идет о необходимости адекватного ответа на действия противника, исходя из тех ресурсов, которыми вы располагаете. - Примеч. ред.).

Для многопользовательских игр вроде StarCraft правильный баланс сил - первейшее условие. Если силы разных рас заведомо не равны, вообще не имеет смысла заводить в игре эти самые расы: игроки будут выбирать только одну, заведомо доминирующую. Эта тема стоит целой книги (по крайней мере - главы), поэтому я прошу не относиться к моим советам, как к исчерпывающей инструкции. Это скорее необходимый минимум.

Равные условия по производству начальных юнитов

Каждая раса должна иметь равные возможности обзавестись на начальном этапе войсками или оборонительными сооружениями. Если одна раса производит воинов существенно быстрее, чем остальные, дело закончится тем, что она будет слишком часто побеждать в первые минуты игры.

Строгая специализация

У каждого рода войск должно быть свое назначение. К примеру, в StarCraft есть зилоты, чья единственная задача - наземные нападения, и королева, блестяще владеющая магией, но не имеющая способностей к прямой атаке. Труднее всего сбалансировать юниты, не имеющие «чистой» специализации. Таковы, к примеру, гидралиски, пехотинцы («маринеры» на жаргоне игроков. - Прим. ред.) и прочие.

Избегайте непобедимых комбинаций

Чрезвычайно важно вовремя отловить в игре комбинации юнитов, в принципе неодолимые другими сторонами. Эффективные сочетания сил допустимы, но необходимо также, чтобы умелый игрок при должной подготовке мог победить любое войско.

Не создавайте лишнего

Работая над StarCraft, мы старались исключать из игры юниты с одинаковыми свойствами в пределах одной расы. Например, пехотинцы - это первая боевая единица, доступная при развитии земной цивилизации, но этот род войск прослужит вам до конца игры, так как его не смогут заменить другие.

Определите, когда игрок получит возможность производить юниты. В момент возникновения в технологическом дереве какой-либо расы нового мощного вида войск у остальных рас должен появиться противовес. Вот пример из StarCraft: мы обнаружили, что муталиски появлялись в игре слишком рано и другие расы не успевали создать против них соответствующую защиту. Тогда, в качестве компенсации, мы увеличили время постройки Spire, здания для выращивания муталисков.

Изменения должны быть небольшими

Очень важно не переусердствовать с изменениями. Порой одно лишнее очко атаки играет огромную роль в боевых условиях. Даже если вам кажется, что требуется большее изменение, лучше ошибиться в сторону меньшего. Иначе возникает дисбаланс в какой-нибудь другой области, и это быстро вызовет цепную реакцию изменений, полностью нарушающих настройку всей игры.

Оцените результаты планируемого изменения

Очевидный шаг не всегда самый лучший. Если вы задумали внести в характеристику юнита какие-либо изменения, определите, как они повлияют на ход игры. Приведем еще один пример из StarCraft. В какой-то момент мы увеличили размер протоссовских драгунов (Dragoon) до среднего, изменив таким образом их уязвимость при атаках больших и малых противников. Так снизилась сопротивляемость драгунов мало использовавшимся прежде огнеметчикам (Firebats) и «саперам» (Vultures) землян; в то же время драгуны стали получать меньше повреждений от танков. Это, в свою очередь, привело к появлению стратегии «набега ордой» драгунов, сметающих все на своем пути, и внесенное изменение пришлось аннулировать.

Тимоти Дж. Стельмах (Timothy J. Stellmach), Looking Glass Studios

Последняя и, несомненно, наиболее впечатляющая работа ведущего разработчика компании Looking Glass Studios Тима Стельмаха - игра Thief: The Dark Project. В этом проекте помимо курирования разработчиков-новичков Тим отвечал за общее руководство работами над геймплеем и миссиями. Может ли кто-нибудь лучше него рассказать о создании миссий? Наконец, игра Thief: The Dark Project получила награду «Лучший сюжет» за 1998 год в популярном электронном журнале «Gamecenter». Вас это удивляет? Да, Thief отнюдь не стратегия, но в сюжет «Вора» вплетено множество индивидуальных заданий для игрока. Отсюда и результат. Итак, приступим.

Тим Стельмах начинает с рассказа о своем подходе к написанию сценария. В этом фрагменте Тим также объяснит нам разницу между разработкой сценария и созданием головоломок (см. главу 5).

В любой игре, основанной на отдельных миссиях, проект сценария включает в себя цели миссий, планы местности, где развертывается действие, препятствия, возникающие перед игроком, и средства для их преодоления. Заметьте, что реальные решения задач игрока в этот список не входят. В этом и состоит разница между сценарием и головоломкой. Головоломка предполагает заранее оговоренное решение, причем, как правило, единственное. Очень часто можно встретить игры, где миссия выполнена в виде цепочки головоломок, которые нужно «решить», чтобы достичь цели. В некоторых случаях, конечно, это оправдано, но каждый раз следует спрашивать себя, чего вы, собственно, хотите? Можно ли предусмотреть больше одного решения? Можно ли создать такую игровую среду, в которой игроку была бы предоставлена свобода эксперимента и импровизации?

«Кампания» в игре Thief основана на некоем художественном сюжете, объединяющем миссии и определяющем задания. Как и в большинстве экшен-игр, порядок следования миссий в игре фиксирован и не зависит от действий игрока, поэтому наличие сюжета играет лишь вспомогательную, хотя и важную роль. Общая фабула усиливает смысл целей отдельных миссий, делая их частью повествования. Успех в игре, конечно, сам по себе является наградой, но при захватывающем сюжете он приобретает дополнительную значимость.

Тим рассказал нам, как справиться с проектированием миссий, а также затронул общие проблемы, которые неизбежно придется решить для создании успешной игры.

В первую очередь разработка игры предполагает постановку задач, планирование решений и осуществление этих решений. Люди склонны забывать, что значит работать «по проекту». Стоит особо подчеркнуть роль планирования, поскольку в процессе творчества слишком легко увлечься идеями и начать импровизировать на ходу. Обычно это приводит к более небрежной работе, чем та, на которую вы действительно способны. Прежде чем заниматься отдельными частями, подумайте о конечной цели. Не начинайте работу без подготовки.

Непосредственный вывод, который можно сделать из этого правила: любую работу следует выполнять итеративно. Любая, слишком объемная для восприятия целиком работа должна быть разбита на стадии, каждая из которых совершенствует предыдущую. Действительно, изначально невозможно точно определить конечную цель, поэтому нужно иметь возможность понять суть задачи в процессе работы и адаптировать к ней свой план. Применительно к созданию миссий это означает, что сначала нужно написать план, затем начертить общую схему уровня, но не прорабатывать отдельные детали до тех пор, пока они не понадобятся. Чем сильнее детализирован объект, тем труднее его переделать, а все, над чем вы трудитесь, придется в свое время подвергнуть переработке. Спланируйте заранее прототипы и демонстрационные версии. Нет ничего полезнее для понимания вашего творения, чем действующая модель.

Это все к тому, что на первом месте должно стоять получение готового результата, причем желательно без бесполезной траты времени и побочных блужданий. Должен добавить, что для получения хорошего результата самое важное - это просто-напросто длительное тестирование и готовность вносить исправления в свою работу. Это, в частности, относится и к вашему общению с тестерами. Нельзя сохранить объективность, работая над игрой изо дня в день, в течение нескольких месяцев. Когда возникает сомнение, правым, вероятнее, будет посторонний человек, поскольку вы слишком близки к предмету спора, чтобы видеть его объективно. Установите хороший контакт с теми тестерами, которые способны на конструктивную критику.

Игра Thief: The Dark Project - это достаточно уникальный шутер, основной акцент которого был сделан не на уничтожении всего, что попадается на глаза, а скорее на применении хитроумных уловок и отточенности действий. Тим прокомментировал возникавшие проблемы в области разработки игровых миссий.

Самым сложным было то, что очень многое в игре нам пришлось придумывать с нуля. Никому до нас не приходила в голову идея экшен-приключения от первого лица, где такую важную роль играло бы умение прятаться в тени и незаметно подкрадываться к цели. Ни в одной игре прежде не придавалось такого огромного значения звуковому оформлению: у нас это не просто красивое дополнение к зрительному ряду, но действительно необходимый элемент для восприятия окружающей обстановки.

«Должен сказать, что самое главное при работе над игрой - это достаточно долгое тестирование и готовность к постоянным исправлениям», утверждает Тимоти Стельмах. Он также предупреждает о том, что, находясь «слишком близко» от своего проекта, бывает сложно оценить его объективно. (Использовано с разрешения Looking Glass Studios, Inc.)

Довольно сложно заниматься созданием миссий, если до конца не понятен сам механизм игры. Мы не знали, какие элементы получат отклик у игроков, поэтому предоставили главному герою целый ряд разнообразных вариантов поведения: просто красться по коридорам, шарить по карманам, устраивать засады на охранников, обезвреживать ловушки, подслушивать и т.д. Это, конечно, внесло в игру разнообразие, но порой бывает трудно разобраться в этих бесконечных возможностях.

Ключевым фактором для преодоления трудностей стал долгий период тестирования и критики, который помог нам лучше понять, какая же игра нам нужна. Даже наиболее оригинальные идеи несут в себе элементы предыдущих работ. Не бывает работы в творческом вакууме. Поэтому здесь присутствуют элементы System Shock, Prince of Persia, GoldenEye 007 и многих других игр. Мы раздумывали над похожими играми, которые нам не хотелось повторять, и задавали себе вопрос: что мы хотим сделать иначе и почему? Перед нами встали ключевые вопросы, например, «Каковы могут быть тактические ситуации, требующие действий украдкой?» и «Какие эмоции возникают в таких ситуациях и как нам это использовать?»

В заключение Тим Стельмах еще раз повторяет основные моменты работы над миссией: предварительно все спланировать, как можно скорее собрать прототип игры и получить максимально возможное количество отзывов игроков.

Грег Стрит (Greg Street), Ensemble Studios

Доктор Грег Стрит, разработчик из компании Ensemble Studios, принимал участие в создании игры Age of Empires II: The Age of Kings и дополнительных миссий Rise of Rome к игре Age of Empires. В обоих проектах он отвечал за создание кампаний и типов случайных карт, помогал настроить баланс юнитов и цивилизаций и, по необходимости, играл роль исторического консультанта. Грег обсуждает различия между сценариями, кампаниями, динамическими кампаниями и ветвящимися кампаниями в стратегических играх в реальном времени, а также приводит примеры из своей практики.

Задача сценария для стратегии в реальном времени - предложить игроку интересные ситуации, в которых ему нужно выполнить определенные задания. Игра не сводится к принципу «побыстрее отстроиться и разгромить противника» (хотя и такое часто бывает). Сценарии, или миссии, должны быть основаны на интересных картах, необычных условиях выигрыша, незаурядном художественном и звуковом оформлении и причастности к более масштабному сюжету.

Кампания состоит из цепочки миссий подобно тому, как книга состоит из глав, а пьеса - из действий. В Age of Kings одна из кампаний посвящена сражениям Жанны д'Арк. В одном из сценариев вы должны освободить Орлеан, осаждаемый англичанами, в других - атакуете Шалон и Париж.

В динамической кампании события одной миссии непосредственно влияют на условия следующих, причем от ваших результатов часто зависит состав и состояние ваших войск в следующем задании. (Неплохой пример динамической кампании можно найти в игре Warhammer: Dark Omen.) В ветвящейся кампании вы можете лично предпочесть тот или иной сценарий: либо с помощью простого выбора через интерфейс игры, либо в зависимости от ваших действий и результатов, с которыми вы закончили предыдущую миссию.

Лично мне динамические кампании не очень нравятся. Игрока постоянно преследует мысль, что он должен не просто победить в игре, но одержать победу с огромным перевесом, иначе не сможет пройти следующие миссии. Как правило, такие кампании труднее всего поддаются балансировке. С ветвящимися кампаниями дела обстоят проще, но часто приходится удваивать количество сценариев в игре, хотя многие из них игрок так никогда и не увидит. Одна из проблем с ветвящимися сценариями состоит в том, что игроки часто по очереди выбирают каждый из предложенных вариантов - чтобы убедиться, что они ничего не упустили.

Разработчикам, которые хотят научиться создавать удачные миссии и кампании, нужно прислушаться к следующим советам:

Сделайте миссию интересной. Иначе зачем игроку тратить на нее время, если он может сыграть с другими людьми или на случайной карте?

Не забывайте о сюжете. Игроки куда выше оценят миссию, если будут знать, что штурм горной крепости «главного негодяя» объединит всех сарацин против крестоносцев, чем если бы их просто натравливали на очередного злодея. Каковы воюющие стороны? Каково историческое значение битвы? Изменит ли что-нибудь ее исход? Я уже говорил об этом раньше (и вы могли меня слышать), но здесь повторюсь: «Красный игрок обозвал тебя обезьяной, иди и разрушь его город!» - это не лучший образчик эпической литературы.

Для игр вроде Age of Empires: The Rise of Rome важным моментом является историческая точность, поэтому Грег Стрит досконально изучил реалии исторического периода, отраженного в игре. (Использовано с разрешения Microsoft, Inc.)

Постоянно тестируйте игру! Снова и снова переигрывайте одну и ту же миссию, а затем зовите всех своих друзей, врагов и случайных людей, найденных по Интернету, не забудьте также родителей и домашних животных, - пусть каждый из них сыграет в вашу игру и выскажет свое мнение. Вы удивитесь, когда узнаете, что все ваши блестящие планы рушатся из-за сущего пустяка, который вы проморгали...

Может ли наш собеседник дать четкие советы, что стоит и чего не стоит делать разработчику миссий? Почему выходит так много стратегических игр и симуляторов с никуда не годной структурой миссий и кампаний? Грег Стрит приводит примеры и предлагает подробные рекомендации.

Вам нужен план

Я всегда говорю, что, разрабатывая миссию, нужно четко знать, что и когда должно в ней происходить. Нет смысла просто вываливать вражеские силы на игровое поле как попало, надеясь, что подобная халтура заинтересует игрока. Нужно всегда знать, что, скажем, через пять минут после начала игры произойдет небольшая стычка, еще через двадцать минут - серьезная битва, а прохождение всего сценария займет у опытного игрока около полутора часов.

Тонкая грань между юмором и серьезностью

Постарайтесь найти золотую середину между мелодрамой и балаганным юмором. Если происходящее слишком грандиозно, слишком ужасно или слишком штампованно, вы можете быстро потерять настрой игры и желание игрока продолжать кампанию. (В качестве примечания: видеовставки и озвучивание актерами слегка сдвигают игру в сторону мелодрамы.) С другой стороны, слишком далекий уход от эпического сюжета, когда все происходящее представляется одной большой шуткой, тоже не вдохновляет людей на продолжение игры. Иногда полезно разрядить напряжение, но не стоит делать игрока слушателем потока дурацких шуток. WarCraft 2 содержал в себе достаточно юмора, но никогда не уклонялся от суровости сюжета. Если вам так уж хочется вставить в игру «потешные» отряды, пусть игрок вызовет их с помощью чит-кодов или пусть они появятся в качестве бонуса.

Бесплатный инструментарий

Каким бы инструментарием вы ни пользовались для создания миссий, сделайте его доступным для поклонников вашего творения, желательно в качестве бесплатного приложения к самой игре. Как показывает практика, редактор с подробным описанием - неплохой способ продажи лицензии на игру. Мощные редакторы обеспечивают игре широкую поддержку ее поклонников.

Лучше меньше, да лучше

При прохождении миссий игроки сразу замечают повторы. Если один сценарий похож на другой, возможно, стоит от чего-то отказаться или объединить некоторые из миссий. Другой вариант: можно попробовать изменить ход миссии. Вместо обычного наращивания сил и атаки устройте сражение с ограниченным числом сил (т.е. ситуацию, в которой невозможно строительство дополнительных юнитов и приходится обходиться только начальными ресурсами), попытайтесь тайком провести отряд по запутанной карте или введите какие-нибудь необычные условия победы (к примеру, защита слабого юнита, миссия сопровождения и т.п.).

Используйте как можно больше разнообразных условий победы. Если игрок просто хочет нарастить силы и разгромить противостоящий ему компьютер, он выбирает случайную карту. В Ensemble Studios всегда стараются добавить в каждый сценарий свою изюминку - уникальную черту, которая придает игре особый интерес. Так, в Rise of Rome одной из самых популярных миссий, над которой мне довелось работать, была осада Сиракуз. Задача заключалась в том, чтобы захватить греческого математика Архимеда, находящегося в центре города, одновременно стараясь избежать страшных защитных зеркальных башен, построенных ученым. (Согласно легенде, эти зеркала направляли сфокусированный солнечный свет на римские триремы и поджигали их. До сих пор обсуждается достоверность этих фактов, хотя большинство исследователей согласны, что физически это было возможно.) Изюминкой в этом сценарии служили дополнительные трудности: нужно было постараться не убить слабого старика во время массового обстрела города из катапульт и не подставлять свой флот под практически непобедимые зеркальные башни, защищающие гавань.

И еще одно предупреждение. Исходя из нашего опыта, длительная осада врага, засевшего в крепости, выглядит очень занимательной на бумаге, но игра, заключающаяся в постепенном изматывании противника, быстро наскучивает. Враг должен постоянно переходить в контрнаступление. Не давайте игроку больше десяти секунд передышки, если в ваши цели не входит продлить напряжение в игре.

Больше удовольствия за те же деньги

Облегчите поклонникам игры доступ к дополнительным сценариям, не включенным в основной продукт. Всегда найдутся розничные торговцы или периодические издания, желающие заполучить какой-нибудь «призовой уровень». Разместите дополнительные миссии на веб-сайте своей компании или способствуйте обмену сценариями, созданными игроками, на веб-страничках поклонников игры (к слову, некоторые фанатские веб-страницы Age of Empires содержат сотни и тысячи дополнительных карт).

До полного блеска

В игре все должно быть прекрасно: и пейзажи, и герои, и музыка со звуком. Только так вы сможете поддерживать желание игрока пройти миссию вдоль и поперек лишь для того, чтобы увидеть следующую карту. Замечу, что поклонникам Age of Empires, занятым разработкой как кампаний, так и отдельных миссий, больше всего нравилось использовать легендарных героев, вроде Александра Македонского или Гектора Троянского.

Не злоупотребляйте триггерами

Используйте в миссии триггеры, заранее прописанные и строго предопределенные вещи, но не делайте из них культа. Да, скажем, в одиночном сценарии жесткая причинно-следственная связь между действиями игрока и другими событиями миссии может быть эффективна. Представьте, что вы получаете подкрепление при входе в конкретную область или при уничтожении определенного противника, возможно с текстовым или голосовым сопровождением. Однако если игрок почувствует, что компьютер стандартно отвечает на те или иные действия (например, атакует каждые пять минут или всегда атакует после постройки игроком зданий определенного типа), поведение компьютерного оппонента становится предсказуемым, и интерес к игре теряется. Примером «золотой середины в использовании триггеров можно назвать StarCraft (Blizzard).

Старайтесь разбудить эмоции

Попытайтесь вызвать эмоции в игроках, проходящих ваши миссии или кампании. Я как-то читал, что хороший документальный текст передает информацию, а хороший вымысел будит эмоции. Игроки должны почувствовать страх, если они знают, что им противостоит могущественный враг, который может ударить в любой момент. У них должно появиться желание спасти слабого или чувство праведного гнева при освобождении жертвы из рук палача. Даже ландшафт может нести в себе эмоциональную окраску. Пустынные бесплодные пространства будят чувство заброшенности, отчаяния, а смятый, беспорядочно изрезанный ландшафт наводит мысли о паранойе.

Age of Empires II охватывает период в тысячи лет, от раннего до позднего средневековья. Одна из задач Грега Стрита - вызвать в игроках эмоции. (Использовано с разрешения Microsoft, Inc.)

Сложность, подсказки и баланс игры

Не полагайтесь на стратегию «сохранился, проиграл, попробовал снова», она быстро надоедает. Не заставляйте игрока вслепую бросаться в заведомо проигрышную для него битву, если только это не наказание за неправильно принятое решение. Всегда должна существовать возможность (хоть и сопряженная с трудностями) пройти весь сценарий с первого раза. Если вы запланировали засаду, используйте какие-нибудь приметы (опрокинутые повозки, горящие дома, беженцев и т.п.), по которым игрок сможет ее обнаружить. На развилке два пути - правильный и ложный, значит, что-то непременно должно указать игроку верную дорогу (желательно, чтобы это указание фигурировало в сюжете). А лучше вообще не ставить игрока перед подобным выбором. Если одна из дорог более опасна, то в ее конце вас должна ждать соответствующая награда. Классический вариант - это длинный, нелегкий путь в противовес короткому, но полному опасностей.

Не забывайте об игроках-одиночках

Игра по сети имеет огромное значение для большинства стратегий в реальном времени, но, на мой взгляд, разработчики иногда забывают о потребителях, не имеющих пока надежного доступа к сети. При работе над дополнительными миссиями к Age of Empires сценарии создавались с акцентом на сетевую игру, генератор случайных карт и относительно неплохой искусственный интеллект, поэтому было слишком легко вовсе забыть об одиночных кампаниях. В мои обязанности входило следить за тем, чтобы этого не произошло.

Другой причиной вымывания из игр однопользовательских миссий является недостаточная серьезность программирования искусственного интеллекта, что серьезно упрощает задачу игрока. Так, до недавнего времени в стратегиях в реальном времени вроде WarCraft II и Age of Empires искусственный интеллект принципиально не строил укреплений! Разумеется, «живому» игроку весьма быстро надоедало выигрывать.

Джон Зук (Jon Zuk), Raven Software

Джон Зук из Raven Software, ведущий разработчик популярного шутера с элементами ролевой игры Heretic II (выпущенного компанией Activision в конце 1998 года), утверждает, что существует несколько способов создания миссии и приводит в качестве примера свой последний проект.

В Heretic II есть одна большая «миссия», а точнее, цель, которой надо достичь. Многие игры придерживаются того же принципа: победа в общей, достаточно большой и сложной миссии означает победу в игре. Другие же проекты состоят из нескольких миссий небольшого объема. Возьмем, к примеру, гонки. Цель игрока - победить в одном конкретном заезде, а остальные заезды на эту цель не влияют. Однако в большинстве игр основная миссия разбивается на более мелкие, более управляемые и легкие для запоминания задачи. В Heretic II основной задачей было излечить народ Парториса от эпидемии чумы. При прохождении первого уровня игрок встречает человека, дающего ему некоторую информацию и ставящего более непосредственную задачу - встретиться во дворце со звездочетом. Несмотря на присутствие основной цели, вводится дополнительная задача, определяющая направление поисков.

«Тем не менее я заметил, - продолжает Джон, - что в некоторых играх существует слишком много дополнительных задач».

Я могу назвать массу РПГ, грешащих этим. В итоге игрок теряет из виду основную цель и перестает понимать смысл игры, что неминуемо приводит к забвению последней. Если ваша игра будет содержать несколько миссий, ведущих к главной цели, убедитесь в их связи между собой. Или хотя бы поддерживайте внимание игрока на главной задаче.

В заключение Джон предупреждает: «Если игрок забудет об основной цели, игра потеряет для него всякий интерес, а что может быть хуже этого?»


Работа над проектом

Часть II

Работа над проектом

8 | Программирование
9 | Искусственный интеллект
10 | Игровая графика
11 | Анимация
12 | Интерфейс пользователя и управление игрой
13 | Звуковое оформление
14 | Музыка в играх


Программирование

Глава 8

Программирование

В этой главе мы поговорим о самом важном в разработке игр - программировании.

Программирование, естественно, подразумевает и разработку как таковую, и собственно написание компьютерной программы, в нашем случае - самой игры или игрового движка. Задачи программиста: а) решить, что игра должна делать; б) понять, как она будет это делать; в) написать инструкции для ПК на языке, который ПК способен перевести в собственный язык и выполнить (например на Microsoft Visual C++).

А вот другое определение программирования: «Это самое интересное из того, чем можно заниматься, не раздеваясь... хотя одежда тоже не обязательна». (Ну да, с этим можно спорить, но именно такая формулировка приведена в словаре FOLDOC на веб-сайте www.instantweb.com/~foldoc/contents.html!)

Называйте их, как хотите: программерами, кодерами, перемалывателями чисел или алгоритмическими анализаторами, - факт остается фактом: программисты - это те самые ребята, которые создают основу любой игры. Представьте себе, что игра - это строящийся дом. Тогда программирование - это каркас, определяющий форму здания. Никакая роспись на стенах, никакая, даже самая удивительная музыка, не смогут заменить несущие конструкции. Игра, как и здание, должна возводиться на надежном фундаменте.

Чтобы писать игры, требуется нечто большее, чем диплом специалиста в области прикладной математики и пара собственных программок. Программирование игр невозможно без изворотливости ума, адского терпения и той непостижимой субстанции, что по-французски зовется savoir faire, то есть сноровкой, или, если угодно, хваткой, и вырабатывается многолетней практикой, дисциплиной и одержимым трудом.

Итак, приготовьтесь. Следующие три с лишним десятка страниц отданы асам программирования, которые согласились поделиться с нами своим многолетним опытом работы в индустрии и рассказать, как обойти подводные рифы этой, становящейся все более популярной, профессии.

Курт Арнлунд (Kurt Arnlund), Accolade

Перед тем как оставить Activision и стать ведущим программистом игры Slave Zero в компании Accolade, Курт Арнлунд работал над созданием таких бестселлеров, как Mechwarrior 2: NetMech, серия Interstate '76 и Heavy Gear. Курт говорит, что, приступая к написанию компьютерной игры, программист должен держать в голове три условия успешного завершения проекта: соблюдение баланса между сроками и желаниями, точность в постановке задач, выбор между кратчайшим и оптимальным путями решения проблем.

Компромисс между сроками и желаниями

Разработчик должен постоянно балансировать на тонкой грани между мечтами о «потрясающей игре, которая намного опередит современные технологии» и временем, отпущенным на создание этого шедевра. Громадье планов - типичная причина срыва проектных сроков, обычно укладывающихся в один год. А любая - даже полугодовая - задержка с выходом на рынок влечет за собой риск опоздать: конкуренты гарантированно уже выпустят что-нибудь подобное. Впрочем, проблема обоюдоостра: слишком занизив планку проекта, вы имеете все шансы выпустить игру, которая будет превзойдена конкурентами задолго до релиза вашего нетленного произведения.

Будьте конкретны, предельно конкретны

Одна из главных задач разработчика состоит в том, чтобы придумать великолепную игру, а затем предельно четко и точно изложить свои мысли на бумаге. После этого не остается ничего иного, как передать программисту проектную документацию - и вожделенно потирать руки: еще немного - и мечта станет реальностью. Увы. Программист, приступив к реализации проекта, обычно наталкивается на детали, которые вы не обговорили заранее. И здесь, надо заметить, мало что может вызвать такую же досаду, как небрежность разработчика при составлении проекта. В результате - потеря времени и производительности, ведь программист, обнаруживший недочет в документации, возможно, уже начал писать программу... Чем больше времени вы потратите на раскрытие мельчайших деталей своей идеи, тем меньше создадите проблем для всех остальных. А заодно, получите умопомрачительную игру.

Какой путь выбрать, кратчайший или оптимальный?

Программисты - люди в большинстве своем ленивые. Это так, и ничего с этим не поделаешь. Не верьте, если кто-то попытается убедить вас в обратном. Не замечали, мы почти инстинктивно пытаемся воспользоваться самой короткой дорогой из пункта «А» в пункт «Б»? Порой кратчайший путь - это единственное, что мы видим, приступая к выполнению задачи. Зачем я все это говорю? Так и быть, раскрою вам один маленький секрет. Кратчайший путь далеко не всегда лучший. Как ни жаль, но это правда. Чем больше вы, разработчик, руководитель проекта, понимаете в программировании, тем чаще сможете подходить к своему программисту и говорить: «Слушай, то, что ты тут сотворил, - это, конечно, здорово, но какого черта ты не сделал так-то и так-то? Я ведь именно этого хотел!» Еще лучше, если вы, уважаемый разработчик, действительно знаете, что хотите получить, и зададите конкретный способ реализации с самого начала.

Возможно, у вас появится искушение спросить нас, программистов: если вы знаете, что короткий путь не всегда лучший, то почему не обращаете внимание на действительно лучший путь? Отвечаю: только потому, что лучший путь не всегда является кратчайшим. Вообще-то, это не так уж и плохо, что большинство программистов рассуждают именно так, поскольку это означает, что работа будет сделана вовремя. Если бы при создании программного кода мы стремились к полному совершенству, то проект отнимал бы в три раза больше времени, и при этом он содержал бы только треть планировавшихся деталей. А ведь может быть и того хуже, как с игрой Trespasser, мы закончили ее с перерасходом бюджета и серьезным опозданием, игра просто блистала с технологической точки зрения, но была совсем неинтересной.

Справа показан пререндеренный (предварительно прорисованный) кадр из популярной игры Interstate '76 компании Activision. (Использовано с разрешения компании Activision, Inc.) Снизу - последняя работа Курта Арнлунда, игра Slave Zero компании Accolade. (Использовано с разрешения компании Accolade, Inc.)

А как насчет покупки готового программного ядра, уровня, например Quake II или Unreal? Или собственные разработки - более надежный способ вкладывания капитала?

Трудный вопрос. Я знаю нескольких программистов, которые даже мысли не допускают о лицензионных движках, справедливо полагая, что в этом случае лишатся возможности копаться во всевозможных захватывающих деталях ядра игры, которая им нравится. На мой же взгляд, это не так уж и важно. Если создавать программное ядро с нуля, придется прорабатывать массу технических деталей, от не всегда приятного общения с которыми вы освобождены в случае с лицензией. Лицензионный движок - это, как правило, быстрое создание работающих прототипов, однако со временем вы все равно столкнетесь с необходимостью изучения и, возможно, отладки всех деталей лицензионной технологии. Если, конечно, захотите выжать из нее все, на что она способна. А поскольку у каждого собственный стиль программирования, то лицензионный движок может показаться вам как абсолютно нечитаемым кодом, так и шедевром программирования. Но, скорее всего, это будет нечто среднее.

Далее Курт Арнлунд дает советы начинающим программистам, желающим влиться в игровую индустрию.

Прежде всего необходим соответствующий диплом. Нет-нет, модный и дорогой вуз вовсе не обязателен; просто постарайтесь найти место, где можно получить крепкие знания по математике и (немного) физике, и все будет в порядке.

Вот лучший совет, который я могу дать начинающему программисту: дружище, если ты действительно молишься на игры, ни в коем случае не оставляй своей цели! Посвяти в свои планы всех, кого только можно. Вдруг завтра тебе удастся переговорить с агентом из рекрутирующей фирмы, курирующим нашу индустрию, или, скажем, с программистом, непосредственно работающим в одной из игровых компаний. А еще поднакопи денег и обязательно посети Конференцию разработчиков игр (Game Developers Conference), либо устройся ее обслуживать в качестве волонтера, чтобы получить бесплатный доступ. Старайся общаться с как можно большим числом людей, занятых в этой области, и удача тебе улыбнется. Мне повезло, поскольку мой друг, пытавшийся найти такую же работу, рассказал обо мне агенту по найму...

«Многие начинали с тестирования игр, а со временем становились разработчиками или продюсерами. Главное - упорно идти к намеченной цели, и все получится», - заключает Курт Арнлунд.

Джей Стелли (Jay Stelly), Valve Software

Джей Стелли - старший инженер-программист Valve Software, талантливейшей команды дизайнеров, программистов, художников, аниматоров и звукорежиссеров, создавших Half-Life, одну из самых нашумевших игр 1998 года. Последняя на сегодня работа Джея - сетевая игра Team Fortress 2, выпущенная Valve и Sierra Studios.

Когда Джея попросили осветить те аспекты программирования игр, которые прежде всего будут полезны и важны для инженеров-программистов, он обрисовал общую ситуацию, уделив особое внимание вопросам скорости вывода изображения на экран и ограничения памяти, возникающих при включении в игру поддержки 3D-ускорителей. Все его примеры касаются движка Half-Life, построенного на технологии Quake/Quake II, которая первоначально была приобретена Valve у id Software, а затем в значительной мере переработана.

Программному ядру любой игры всегда присущи определенные технические ограничения. Некоторые из них, вроде предполагаемой платформы (процессор, объем ОЗУ, место на жестком диске и т.д.) и требуемых ею технических характеристик (скорость вывода графики, время загрузки и т.д.), вы можете определить сами, другие же обусловливаются оборудованием, которым располагает ваша аудитория. Конечно же, сделанный выбор будет иметь определенные последствия. Рассмотрим конкретный пример.

Half-Life поддерживает 3D-ускорители. Благодаря этому пользователи, располагающие соответствующей техникой, получили лучшее качество изображения и более высокую частоту кадров. Казалось бы, все просто, верно? Однако нам пришлось слегка попотеть...

Самая большая проблема состояла в том, что многие из представленных на рынке 3D-ускорителей располагали лишь 2 мегабайтами памяти для хранения текстур. Дело усугубляло то, что для большинства ускорителей затраты на подкачку новых текстур взамен старых были достаточно высоки, поэтому применение более 2 Мбайт памяти значительно снижало частоту кадров. Для Half-Life это означало, что каждая отдельная сцена в игре должна была использовать не более 2 Мбайт отображаемых текстур.

Программирование дает возможность снять некоторые из вышеперечисленных вопросов. Однако время, отведенное для написания программ, строго ограничено. Хороший инженер в состоянии оценить сложность проблемы и выбрать правильный подход к ее решению. Многие из принимаемых при создании игры решений диктуются необходимостью найти компромисс между различными техническими ограничениями. Именно так было и с Half-Life.

Уже на ранних этапах разработки в Valve осознали, что управление памятью текстур в случае 3D-плат выливается в серьезную проблему, главной причиной которой является 2-мегабайтное ограничение текстур на каждую сцену. Собственную текстуру имела не только окружающая обстановка, но и каждый персонаж, а также любой вид оружия, которым персонаж обладал. Задние планы вне помещений были полностью составлены из больших текстур. Кроме того, движок был разработан таким образом, что львиная часть данных по эффектам освещения в игре также хранилась в виде текстур. Воленс-ноленс, но нам пришлось тратить время, отведенное под программирование, на решение данного вопроса. Иначе б нам просто не хватило текстур для получения того качества изображения, к которому мы стремились! Фактически проблема оказалась значительно более серьезной, нежели простое ограничение в 2 Мбайт для некоторых плат. Выяснилось, что почти все 3D-платы, существовавшие на рынке на момент выпуска Half-Life, показывали разительное отличие в производительности в зависимости от объема памяти, используемой под текстуры, и того факта, складывается ли ваше изображение из текстур, чьи размеры являются степенью двойки.

Джей Стелли: «Инженер-ас, в отличие от заурядного инженера, видит вопрос в комплексе, целиком, что позволяет быстро локализовать важные проблемы и потратить время, отведенное под программирование, на их решение». (Приводится с разрешения компании Sierra Studios.)

В конце концов, мы создали набор приемов, которые позволили Half-Life использовать больший объем текстур и при этом эффективно работать с 2-мегабайтными 3D-платами. Художники переработали текстуру персонажей и элементов интерфейса, комбинируя несколько текстур в одну карту с размером, кратным степени двойки. Программисты добавили в ядро игры подсистему для управления палитрой текстур, которая позволила хранить большее количество текстур в том же объеме памяти, а также изменили части прорисовки, дабы по возможности рисовать все полигоны с одинаковой текстурой за один раз (с целью минимизации подкачки текстур). Ну а платы с недостатком памяти получили возможность автоматически упрощать текстуру (что, конечно, ухудшает качество изображения, но улучшает динамику).

Другое качество, отличающее хорошего инженера от посредственного, - способность правильно определить время на решение конкретной задачи. На нашу проблему можно было затратить как значительно больше, так и значительно меньше времени. Очень важно выбрать верные критерии оценки вариантов решения. За балансом времени, выделенного на программирование, необходимо следить в течение всего процесса создания игры. Не забывайте о приоритетах, ведь хорошие инженеры могут улучшить абсолютно любой фрагмент технологии, поработав над ним.

Я считаю, что правильная постановка задачи и верная оценка решений - два очень важных момента, которые выделяют Half-Life на фоне других игр.

Теперь о преимуществах и недостатках использования лицензионного движка. Стоит ли начинающему программисту пытаться создать движок самостоятельно? Джей Стелли считает, что принять в данном случае верное решение очень сложно, и важно знать, как ведется разработка.

Над созданием лучших 3D-движков трудятся коллективы опытных программистов, многие из которых заняты этим не первый год. Следовательно, результат представляет собой плод многолетних нелегких изысканий в данной области. Впрочем, даже те игры, которые не могут похвастаться движками уровня Quake III или Unreal Tournament, способны предъявить вам свидетельства того, что над их программным ядром трудились настоящие профессионалы. Иначе говоря, создание собственного движка, как правило, требует привлечения целой команды высококвалифицированных программистов, но нередко это выходит дешевле, чем покупка лицензии на готовый движок. Однако существуют определенные моменты, из-за которых использование лицензионных продуктов может оказаться предпочтительным, несмотря на увеличение затрат.

Во-первых, эти движки уже были в деле, а значит, они более надежны. Вы покупаете не только технологию, но и время, которое было затрачено на ее разработку и тестирование. Во-вторых, у ваших инженеров отныне есть время на построение собственно игры или поиск решений для преодоления технических ограничений купленного движка. В-третьих, использование лицензионным движков предоставляет преимущества в области маркетинга и найма. Покупатели, имевшие дело с играми на данном движке, априорно благосклонны к вашему проекту. Наконец, велика вероятность привлечения в команду специалистов, уже знакомых тонкостями заложенной в движке технологии. Не упускайте из виду и вполне очевидную возможность быстро создать работающий прототип игры.

В Интернете можно найти целый ряд ресурсов, полезных для программистов игр. Ниже приведен краткий список сайтов, заслуживающих наибольшего внимания. (Веб-сайты, посвященные разработке игр, перечислены в главе 24.)

• Game Programming MegaSite www.perplexed.com/GPMega

• Visual Basic Explorer www.vbexplorer.com

• Game Programming Galaxy www.geocities.com/SiliconValley/Vista/6774/

• Game Programming '99 www.gameprog.com

• New Game Programmer's Guild http://pages.vossnet.de/mgricken/newgpg/

• Amit's Game Programming Information http://www-cs-students.stanford.edu/-amitp/gameprog.html

• GameProgrammer.com www.gameprogrammer.com

• Viper's C/C++ Page www.europa.com/-viper

• rec.games.programmer (группа новостей)

Чарльз Гоу (Charles Gough), Bungle Software

Чарльз «Чаки» Гоу начал программировать в девять лет, когда отец показал ему основные команды Applesoft Basic на стареньком Apple IIe. Чаки не имел никакого отношения к прославленной стратегии Myth II: Soulblighter, выпущенной Bungle Software, зато в очень скором временя игроки получат возможность увидеть его работу в игре, которая «весной 2000 года ураганом распространится по планете и продвинет Bungie еще дальше по дороге мирового господства».

Чаки делится своими мыслями с начинающими программистами.

1. Как можно скорее создайте работающую версию игры. Чем раньше будут готовы движок и основные элементы, тем больше останется времени на проверку и шлифовку самой игры. Кроме того, и вашей команде, и издателям будет легче проникнуться, вашим видением игры, если они смогут ознакомиться с работающим прототипом.

2. Чтобы достичь цели, вы должны быть готовы на компромиссы в отношении собственного программного кода. Предположим, у вас появилась идея великолепного, совершенно уникального алгоритма прорисовки. Одна беда - он медленно работает, а значит - отвлекает от игры, отнимая время на свою доводку. Результат: вы теряете издателя. Комментарии излишни...

«Памятка разработчика» от Чаки:

Игра должна быть интересной. Например, если вы создаете РПГ, можно, конечно, отразить в ней всю правду жизни и заставить виртуальных персонажей есть, спать и ходить по нужде. Но кому это нужно? Если ваш герой умрет от запора, потому что вы не следили за счетчиком дерьма, это может показаться забавным, но только поначалу, потом все эти штучки наскучат. Вывод: стремление сделать игру интересной должно стать основным приоритетом. Новейшие и самые лучшие технологии не спасут, если игра окажется скучной.

Есть ли у Bungie примеры, подтверждающие данный совет?

Серия Myth! Блестящий пример применения этих правил к жанру, который за все предыдущее время претерпел лишь минимальные изменения. До Myth все стратегии в реальном времени обязательно содержали достаточно длинный период возведения построек, и только после этого начиналось сражение, на которое вы не могли оказать никакого влияния, кроме как изменяя число и рода войск, вовлеченных в драку. Так вот, команда, работавшая над Myth, увидела огромный потенциал в собственно битвах, сделав основной упор на тактику сражения. Лучше всех имевший представление о том, как это должно выглядеть, Джейсон Джонс (Jason Jones) написал простую демонстрационную программу, состоящую из крошечной 3D-карты, гнома-гренадера, отряда нежити, вооруженного топорами, и базового движка, отражающего законы физики. Поначалу он планировал использовать полигональные 3D-модели персонажей и объектов, но вскоре понял, что, во-первых, это резко снизит частоту кадров, а во-вторых, на разработку движка уйдет слишком много времени. Тогда Джейсон изменил спрайтовый код из игры Marathon и использовал его для быстрого создания демо-версии. И что вы думаете? Такого простого начала хватило, чтобы попасть на обложку журнала Computer Game Strategy Plus...

Необходимость компромисса (между сроками, бюджетом, самой игрой и используемыми технологиями) - лейтмотив данной главы. Пришлось ли при создании Myth II: Soulblighter столкнуться с обычными трудностями, возникающими при написании любой игры?

Главная проблема состояла в том, что игру нужно было выпустить меньше, чем через год после выхода первой части. Естественно, ребятам хотелось «изменить, улучшить, добавить», но очень скоро стало ясно, что на все это нет времени. Зато они сосредоточились на самых ударных идеях - на поиске путей, интерфейсе и стрельбе. А вот от реализации таких вещей, как создание персонажей, полностью составленных из полигонов, «недвуногих» юнитов (кавалерия и катапульты), а также горящих деревьев и прочих «красивостей» пришлось отказаться.

Когда Чаки спросили, какие справочные материалы он считает полезными для начинающих игровых программистов, он ответил, что превыше всего ценит общение с опытными кодерами и изучение их программ. «Нет ничего лучше, чем поговорить с тем, кто уже написал несколько игр, или посмотреть настоящие исходные коды...» Программистам, не располагающим такой возможностью, Чаки советует читать книги, второй по значимости полезный источник, особенно университетские учебники, хотя и добавляет, что «найти среди них хорошие довольно трудно».

Майкл Д. Макграт (Michael D. McGrath), Dynamix/Sierra

Майкл Макграт - инженер-программист компании Dynamix. Он работал над созданием популярного симулятора воздушных сражений времен Первой мировой войны Red Baron 3D, а в прошлом участвовал в ряде других проектов, включая Netrek (свободно распространяемая программа) и Extreme Warfare (Trilobyte). Майкл предлагает вашему вниманию несколько советов, касающихся программирования и разработки игр, и перечисляет наиболее распространенные грубые ошибки, встречающиеся в игровой индустрии.

Сначала разработка, затем программирование

Лучший способ никогда не закончить игру - это сесть и попытаться сходу написать ее программу. Само собой, большинство дипломированных программистов способны на такой подвиг, но если вам не удалось завершить работу за относительно короткий промежуток времени, вас ожидает кошмарная перспектива использовать уже написанный код в качестве «руководства для разработки». Хороший дизайнер детально продумывает каждый аспект своего продукта задолго до того, как кто-то приступит к написанию кода, поскольку технические (и не только технические) решения, которые приходится принимать в процессе разработки, в значительной мере определяются конкретной задачей. Мне приходилось слышать о проектах (а иногда и принимать в них участие), которые никогда не были завершены или выбивались из графика не потому, что программисты не знали, что они делают, а потому, что ведущие инженеры и дизайнеры, очевидно, не имели представления, что именно они создавали, практически до момента выпуска игры. Проекты следует продумывать заблаговременно, в противном случае - готовьтесь платить за свое небрежение в будущем.

Но люди есть люди, и всегда, даже среди ваших коллег, найдутся такие, которые не понимают важности этого аспекта. Поэтому, прежде чем начинать проект, хорошенько присмотритесь к тем, с кем собираетесь работать, и убедитесь, что они разделяют ваши взгляды. К сожалению, многие из начинающих программистов, стремящихся в игровую индустрию, особенно те, кто бросил вуз ради того, чтобы поскорее начать писать игры, обладают совершенно недостаточными навыками программирования, необходимыми для эффективной работы над крупными игровыми проектами. Эти люди рано или поздно понимают, что программирование - всего лишь инструмент, используемый инженерами для реализации проектов. Инженерные навыки действительно необходимы. Практически каждый в этой индустрии является по крайней мере компетентным программистом. Что возвращает нас к подпункту 1 совета «А»: закончите учебу, если вы еще не сделали этого.

Научитесь сначала думать, а потом действовать.

Изучите свою аудиторию и конкурентов

Тем, кто не играет в игры, не следует пытаться их писать. Вообще, если вы не играете в игры, не стоит заниматься чем-либо, связанным с индустрией игр, за исключением, быть может, косвенной поддержки. Знание законов, по которым живет индустрия, образа мышления аудитории и возможностей, которыми обладают конкуренты, критически важно для создания высококачественных, успешных игр. Кроме того, необходимо понимать, в каком именно жанре вы можете проявить себя как разработчик. Определите, за какими играми вы готовы просиживать сутки напролет, - это как раз тот жанр, работая над которым вы принесете максимум пользы.

Не настаивайте на том, что сможете создать успешный шутер от первого лица, если всю жизнь играли в летные симуляторы и лишь недавно впервые попробовали пострелять, и вам это понравилось. Для работы над любой игрой необходимо знать все последние достижения в этом жанре и быть в состоянии оценить любую предлагаемую идею. Только в том случае, если вы можете предаваться воспоминаниям о «старом добром времени» с людьми, которые с первого дня поклоняются данному конкретному жанру, вы готовы нести свой шедевр в массы. Иначе вас хватит лишь на очередной клон, и вы затеряетесь в переполненном рыбешками море, чтобы в итоге быть съеденным какой-нибудь акулой, которая в отличие от вас всегда готовила уроки.

Это относится ко всем, но особенно к программистам. Программисты вдыхают в игру жизнь, и ни замечательная текстура, ни трехмерная графика, ни эпический сюжет не помогут, если программа не представит все это игроку должным образом. Чтобы понять, как подать эту замечательную историю, вы должны хорошо знать все прошлые работы, причем как победы, так и поражения. Другого пути нет и никогда не будет. Точка.

Когда программисты и другие члены команды трудятся над игрой, которая интересна лично им, дело идет быстрее и лучше. Для команды, работающей над проектом, я бы приравнял наличие подобного энтузиазма таланту и мастерству, вместе взятым. Запомните, это (в значительной степени) позволит создать высококачественный продукт.

Техника - это еще не все

Не следует думать, что вы сделаете все самостоятельно только потому, что можете писать программы с бешеной скоростью, по 1000 строк в день, и любите игры. Написать компьютерную игру - это все равно, что рассказать историю, - и хотя самого «рассказчика» создают программисты, без хорошего сюжета для рассказа не обойтись. Яркое художественное оформление, захватывающий сюжет, надежный движок, качественные режимы многопользовательской игры, не говоря уже о вдохновляющей музыке, - для хорошей игры требуется многое. И чтобы, взявшись за проект, довести его до конца, вам необходимо вникнуть во все эти детали, или хотя бы уверенно в них ориентироваться.

А чтобы постичь все тонкости представления различных элементов игры, вам необходимо понять их реализацию в среде, которую вы используете для того, чтобы рассказать историю. Однобитный графический поток позволяет получить замечательную частоту кадров, однако я сомневаюсь, что кто-нибудь по достоинству оценит визуальные эффекты вашей игры, решись вы использовать подобное программное ядро. Отчасти понимание того, что значит правильно рассказать хорошую историю, приходит с опытом - обычно возрастающим, если вы не ленитесь играть в чужие игры.

Наконец, необходимо уметь работать с людьми, которые помогают вам (как любой член команды, создающей игру) рассказывать эти истории. Вам необходимо иметь хорошие инструменты, необходимо научить остальных всему, что они должны знать, чтобы работать с вашей технологией, а прежде всего вам необходимо иметь терпение и решительность для того, чтобы выполнить все вышеперечисленное. И сохранять их до конца.

В нашей индустрии нет места для начальников-наполеонов, а также людей с высокомерным или замкнутым характером. Само собой, подобные типы появляются время от времени, но их игра находит свое последнее пристанище на полке для уцененных товаров (там же, к сожалению, заканчивается их карьера, а также карьера тех, кто с ними работал)... или, еще хуже, игра вообще не выходит на рынок. Если вы вдруг почувствуете, что работаете на кого-то, а не с кем-то, немедленно уходите, потому что в «смертельной схватке» на поле боя, именуемом «рынок игр», вы - на проигрывающей стороне.

Майкл Макграт поясняет свои советы на примере игры Red Baron II компании Dynamix и проблем, так замучивших ее программистов.

Скриншоты из игры Red Baron 3D. Первый - подвижные контрольные плоскости указывают на маневр противника. Второй - новые варианты облачности и эффекты наложения слоев, создающие ощущение неба, полного опасностей. (Использовано с разрешения компании Dynamix.)

Red Baron II - типичный пример избытка технических переделок и недостатка предвидения в процессе разработки. В Red Baron 3D большая часть программистской работы состояла в вылавливании ошибок и попытках разобраться в коде, чтобы мы могли добавить в игру новые возможности и технологии. Когда началась переработка Red Baron 3D, создававшие игру инженеры или уже покинули Dynamix, или перешли в другие проекты. Код был плохо документирован, из-за чего мы столкнулись с нескончаемыми трудностями, связанными с его переработкой, и не было никого, кто мог бы помочь в нем разобраться. Переделать игру было бы гораздо проще (я уверен, что первоначальной команде это было по силам), если бы программа была хорошо структурирована. Но код, будучи плодом труда многих и многих людей, которые совсем не заботились о том, чтобы снабдить его хоть сколько-нибудь приличным описанием, был ужасающе загадочен. В дополнение к этому, в тех местах, где проект все-таки был хорошо продуман, код был сверхабстрактен и сверхтехничен.

Игре Red Baron II очень не повезло. Изначально разработанная под DOS, позже она переделывалась сначала под Windows 95, потом под DirectX и, наконец, под 3D-платы. В итоге код игры перекраивался столько раз, что под конец стал невообразимо громоздким. Основная проблема заключалась не в самой реконструкции, а скорее в том, что технология привела, как оказалось, к «переоценке» возможностей повторного использования кода и нарушению модульности. Вырезая некоторые части, приходилось сохранять остальные, склеивая их кое-как. В результате программу стало очень трудно читать и понимать. Если бы код с самого начала был хорошо продуман и выстроен по модульному принципу, то игра могла быть завершена гораздо быстрее, независимо от преимуществ технологии, которые вдохновляли на внесение изменений. Не следует понимать это утверждение в том смысле, что «нужно было использовать Си++». Мы пользовались этим языком. Однако объектно-ориентированное программирование со всеми его достоинствами может стать настоящим кошмаром при злоупотреблении плохо продуманным проектом и применением техники «заплаток». Никогда не позволяйте «завораживающим» возможностям языков программирования убедить вас, что соблюдение принципа «бритвы Оккама» и удобочитаемость программы уже не существенны. Никогда.

Уильям Оккам, философ, живший в 13-14 веках, вывел закон экономии, известный сегодня как «бритва Оккама». Вот его формулировка: следует отказываться от понятий, не являющихся необходимыми.

В дополнение к общению с другими специалистами через Usenet и посещению различных конференций Майкл Макграт предлагает несколько полезных книг, на которые стоит обратить внимание желающим заняться программированием игр:

• Computer Graphics: Principles and Practice, Second Edition in С. Авторы Foley, van Dam, Feinern Hughes (Addison-Wesley, 1996)

• Руководство по программированию («красная книга») и справочник OpenGL («синяя книга»)

• Серия The Graphics Gems, под редакцией Andrew S. Glassner, James Arvo, David Kirk, Alan W. Paeth и Paul S. Heckbert (Academic Press и АР Professional, 1993-1995)

• Artificial Intelligence. Автор Patrick Henry Winston (Addison-Wesley, 1992)

В настоящее время Майкл Макграт занят написанием программного кода для игр Desert Fighters и Aces of the Pacific II, а в его планах на будущее - переписать Netrek и возобновить участие в создании научно-фантастических боевых летных симуляторов и стратегических игр.

Аллен Джексон (Allen Jackson), Origin Systems

Аллен Джексон работал в компании Origin в течение ряда лет, и ему посчастливилось принимать участие в создании многих экшен-игр и космических симуляторов, отмеченных разнообразными наградами. В их числе: Crusader: No Remorse, Crusader: No Regret, Wing Commander Prophecy и Wing Commander Prophecy: Secret Ops. В первую очередь Аллен имеет дело с игровым кодом высокого уровня, а именно с разработкой интерфейса, приложениями Win32 GUI, объектами, определяемыми в игре, и сетевыми вопросами.

В данном разделе Аллен Джексон делится тремя советами по написанию кода для игр, ссылаясь при этом на свои последние работы, на практике подтверждающие предлагаемые рекомендации.

Используйте движок, управляемый данными

Ядро игры должно, насколько это возможно, работать на основе данных. Вместо того чтобы корпеть над каждым отдельным эпизодом игры, предоставьте программе самой подобрать нужную комбинацию элементов. Например, космические корабли в Wing Commander: Prophecy в основном создавались как элементы данных. Программисты определяют общие свойства кораблей: двигатель, пушки, ракеты, щиты и максимальное ускорение. Затем дизайнеры собирают файл данных корабля, который описывает его внешний вид, свойства и статистику. Этот файл будет позже прочитан с жесткого диска и проинтерпретирован программой. Лишь иногда программа ищет конкретный корабль для применения специальных эффектов, но в идеале и эти случаи следует убрать из кода, чтобы все корабли могли обладать теми или иными свойствами.

Еще один способ представить движок на основе данных - это система триггеров, привязанных к карте. Главный герой Crusader: No Remorse - десантник далекого будущего, бегающий по изометрической карте и расстреливающий врагов. Карта заполнена объектами, с которыми наш морпех может взаимодействовать, - телепортерами, дверями, выключателями и мониторами. Система позволяет дизайнеру выбрать определенный триггер (например переключатель) и присоединить к нему команду, например «открыть дверь №21». Эта связь сохраняется в файле карты и интерпретируется программой во время выполнения. Если система триггеров создана правильно, она позволит активизировать множество действий, в том числе и те, которые не были изначально запланированы.

Миссии тоже, по возможности, должны управляться данными. Программа не должна знать, какие конкретно миссии используются в сюжете, ей достаточно иметь каркас, позволяющий дизайнеру создавать сценарии кампаний и отдельных миссий, - то, с чем имеет дело конечный пользователь, игрок. Проектировщик миссий и сюжета Wing Commander: Prophecy позволяет дизайнерам создавать файлы «сериалов», которые содержат указатели общего сюжета, наборы миссий и древовидную структуру, связывающую все миссии воедино. Такая система чрезвычайно гибка и надежна, она позволяет создавать разные типы ветвей дерева и условий, что приводит к многообразию сюжетов.

Экспериментируйте с существующими движками

Один из самых важных аспектов в работе игрового программиста над любым приложением - это структуры и иерархии классов. Если интерфейс программ низкого уровня написан правильно, последующие стадии программирования будут проходить более гладко. Например, если в середине разработки вы решите что-то изменить в сетевой версии игры, вам потребуется лишь переписать модули низкого уровня, непосредственно отвечающие за поддержку сети. Остальным программам высокого уровня должно быть все равно, какие именно низкоуровневые программы обеспечивают их работу.

В Интернете существует множество прекрасных графических движков, готовых к употреблению. Загрузите любой и попытайтесь создать с его помощью простое приложение. Затем постарайтесь разобраться, какая архитектура заложена в движок. К примеру, существует множество вариантов прорисовки сцен. Некоторые движки позволяют создавать игровые объекты, а затем добавляют или удаляют их при прорисовке. Другие предпочитают, чтобы объекты сами себя рисовали с помощью класса screen. Третьи движки одновременно прорисовывают несколько сцен, используя систему окон. Наконец, некоторые программы накладывают объекты на сцену слоями в особом порядке, оставляя основной экран интерфейса самым последним, чтобы он всегда был виден.

Ряд игровых компаний открыли доступ к исходным кодам своих старых игр. Хотя вас, скорее всего, не заинтересует прямое использование их архаичных и потерявших блеск движков, вы можете захотеть исследовать основной цикл игры, механизмы ввода данных, передачу сообщений внутри игры, обработчик объектов, инструменты отладки и систему прорисовки игрового мира.

Один из примеров предложения исходного кода игры через Интернет - продукция компаний Raven Software и Activision, опубликовавших исходные тексты Heretic и Hexen для бесплатного использования. Загрузить их можно с узла www2.ravensoft.com/source. Не стала прятать свои исходные коды и id Software, выложившая в Интернет код Quake.

Избегайте статических классов и переменных

Аллен Джексон предостерегает от опасности попадания в «ловушку памяти» при использовании статических классов и приводит пример программы, демонстрирующей альтернативный способ обойти это часто встречающееся программистам препятствие.

Статические переменные подобны глобальным, так как они доступны из большинства классов, но одновременно может существовать только один экземпляр такой переменной. Существует несколько классов, таких как ClassOperatingSystem, ClassGameSound и ClassFileSystem, которые действительно подразумевают наличие единственного экземпляра класса. Некоторые другие классы выглядят так, будто для них тоже должен существовать только один экземпляр, хотя иногда допускается наличие и нескольких экземпляров. Классический пример подобного статического класса - ClassGameWorld:

class ClassGameWorld
{
public:

// статические данные игрового мира
static void* m_GameWorldData;

// статические компоненты-функции
static bool Install(void);
static bool Remove(void);
static bool AddObject(GameObject& _obj);

};

После определения класса программист мог использовать функцию World::AddObject() в любом месте в своих модулях, что удобно, но позволяет работать только с одним игровым миром. Если в дальнейшем замысел игры изменится и потребуется наличие многих игровых миров (например в случае большой сетевой игры), придется кардинально переписывать весь код игры.

Более правильным решением будет создать нестатическую версию класса ClassGameWorld, а затем завести статический шаблон списка игровых миров где-нибудь еще, например в классе ClassGame:

class ClassGame
{
private:

static TemplateList<ClassGameWorld*> m_GameWorldList;

…

public:

static ClassGameWorld& GetWorld(int _nWorld);

};

Это позволит программе иметь доступ ко многим экземплярам данного класса и в то же время сохранить только одно место для доступа ко всем данным игровых миров.

В главе 3 приведены общие советы Аллена Джексона по разработке игр.

Рагнар Шейерман (Ragnar Scheuermann), Wombat Games

Рагнар Шейерман работал в Origin Systems в качестве инженера-программиста над Ultima: Ascension и Ultima Online. Позднее он оставил Origin, чтобы стать ведущим инженером-программистом, дизайнером и вице-президентом компании Wombat Games.

Рагнар подчеркивает, что его советы в равной степени будут полезны как начинающим игровым программистам, так и новичкам-разработчикам, и сопровождает их примерами из собственного опыта.

Во-первых, убедитесь, что вы знаете игру, над которой собираетесь работать. Так, вы должны четко представлять, каким образом будете в нее играть. При этом ваше знание не должно быть секретом для вашей команды, и, как только вы придете к единому пониманию игры, скажите «стоп!» всем дальнейшим переделкам игровой концепции.

Во-вторых, максимальная отдача и инициатива возможны только в коллективах, влюбленных в свою работу. Если вы только начинаете проект, вам придется использовать все доступные стимулы, чтобы суметь его завершить. Я также обнаружил, что порой самое лучшее в играх - это «дополнения», введенные программистами или дизайнерами не потому, что их обязывает долг, а потому, что им хочется это сделать.

Наконец, если вы новичок, не пытайтесь сразу же прыгнуть выше головы. Не бойтесь пометить некоторые части проекта как необязательные, в первую очередь сосредоточьтесь на основных элементах. Выберите технологию, которая соответствует жанру создаваемой игры. Например, если ваша игра может обойтись без трехмерности (да и вам самому это 3D не нравится), не обращайте внимание на моду, другие вам не указ.

Рагнар Шейерман приводит примеры, помогающие лучше понять предыдущие замечания.

Работа над Ultima Ascension велась почти шесть лет. Основная причина столь рекордной продолжительности состоит в том, что каждый год авторы меняли концепцию игры, в силу чего всякий раз приходилось выбрасывать значительную часть кода. Изначально игра базировалась на движке Ultima 8, но с графикой высокого разрешения (позже этот движок был использован для игры Crusader). Но затем, как раз перед моим приходом в компанию, было решено, что вся графика станет полигонной, что означало использование абсолютно нового движка, новых инструментов и обучение команды программистов, у которой до этого практически не было опыта работы с трехмерной графикой.

Через полтора года большая часть команды была переброшена на Ultima Online, чтобы помочь в завершении этого проекта. Аккурат в это время один из программистов добавил в игру поддержку 3D-ускорителей. В качестве побочного эффекта этого шага было принято решение изменить перспективу камеры с изометрической на вид «из-за плеча» (как в Tomb Raider). Само собой, это разрушило часть модулей движка, потребовало переработки многих областей, не соответствующих новому положению камеры, и подготовило почву для следующего ключевого изменения. Сразу после выхода Ultima Online команда Ultima: Ascension была собрана вновь, но с новыми продюсером и ведущим дизайнером. Это привело к еще большему отходу от традиций Ultima 7, к более динамичной и активной игре. Работа над проектом пошла под девизом: «Больше удовольствия в каждые 30 секунд». Через год продюсер был уволен.

К этому моменту игра и управление проектом изменились до неузнаваемости, а от первоначальной команды (которая работала во время моего прихода) остались только шестеро бойцов: продюсер Ричард Гэрриот (Richard Garriott), программисты Герман Миллер (Herman Miller), Гэри Скотт Смит (Gary Scott Smith) и Чак Зок (Chuck Zoch), художники Скотт Джонс (Scott Jones) и Майкл Морлан (Michael Morlan). Движок... опять был переписан, и игра снова изменила направление, восстановив изначальные РПГ-черты. Вывод: проблемы с Ultima IX: Ascension возникли не потому, что проект не был хорош, а потому, что замыслы постоянно менялись.

А вот Ultima Online пострадала от недостаточно ясного видения игры, хотя и не так сильно. Концепция этого проекта никогда подробно не обсуждалась, поэтому игра выглядела по-разному в головах разных членов команды. Одни работали над имитацией виртуального мира, другие - над квестом, третьи находились под влиянием Diablo. Куда больше игра претерпела от того, что вдруг изменились требования к тестированию, и вместо 100 тестеров на каждую миссию понадобилось 2500. К сожалению, срок завершения игры при этом остался прежним, и сокращать время пришлось за счет программистов, а не дизайнеров. В результате мы имеем то, что имеем: вышедшую с опозданием, полную ошибок игру, не имеющую явно выраженного жанрового направления. Код получился чрезвычайно сложным для использования, а все программисты, начинавшие его писать, покинули команду.

Сейчас мы работаем над новой игрой и прилагаем огромные усилия, чтобы дать ей хороший старт и все же реализовать возможности масштабной сетевой игры ролевого типа. Мы создаем виртуальный мир, где ничто не предписано заранее, а его главные обитатели - сами игроки. К слову, при проведении собеседования с кандидатами на участие в проекте наиболее важным был вопрос: «Согласны ли вы с подобной концепцией игры?»

Завершая разговор, Рагнар Шейерман вновь вернулся к проблеме концепции игры, сказав, что «тратит уйму усилий на построение желаемой технологической базы до начала работ над собственно игрой». Причины этого изложены выше. «Чтобы не пришлось ничего переделывать по мере появления текущих проблем».

Мэтт Притчард (Matt Pritchard), Ensemble Studios

Должность Мэтта Притчарда в Ensemble Studios - специалист по графическому движку и оптимизации. Мэтт участвовал в программировании Age of Empires, а в момент написания этой книги был всецело поглощен работой над Age of Empires II: The Age of Kings. Несмотря на плотный рабочий график, Мэтт нашел время, чтобы сказать несколько слов тем, кто мечтает программировать игры. Итак, о каких трех самых важных вещах должен помнить программист?

1. Невозможно написать эпическую сагу за ночь; упорство и настойчивость - вот лучшие инструменты.

2. Большинство задач уже было решено до вас; посмотрите, чему можно научиться у других.

3. Большинство проектов так и не завершается. Излишние амбиции и отсутствие реалистичной оценки возникающих задач обрекают их на скорое забвение. Правильно оценивайте себя и соизмеряйте свои желания с реальными возможностями.

С какой самой сложной проблемой может столкнуться игровой программист? Мэтт Притчард делит программистские «тяготы» на две части.

• Идти в ногу с современными технологиями. Единственный способ добиться этого - сосредоточиться на самом важном, не жалея сил и времени на постоянное совершенствование.

• Строго контролировать ход работ. Программы должны создаваться вовремя и в соответствии с планом. Это приходит с опытом. Не вычеркивайте из помощников и соответствующую литературу по написанию надежного и «окончательного» кода. А вообще, это постоянная борьба, избежать которой, похоже, не удается никому.

В заключение Мэтт советует программистам, работающим над играми, выделить какую-то часть времени на регулярное и внимательное чтение группы новостей rec.games.programmer в Usenet, отражающей всю необходимую информацию о создании и совершенствовании игровых программ.

Чэд Фримен (Chad Freeman), Dreamforge Intertainment

Чэд Фримен - ведущий программист студии Dreamforge Intertainment, выпустившей в 1998 году великолепный квест Sanitarium. До этого проекта Чэд работал над играми Anvil of Dawn и Warwind.

В данном разделе Чэд предлагает игровым программистам несколько бесплатных советов и даже образец программы.

Вам, возможно, приходилось слышать, что при написании игровых программ одним из основных критериев является эффективность кода. Не верьте этому ни на минуту! Лишь для 10-20% вашей программы эффективность может оказаться критичной. Остальной код должен быть гибким, поскольку вам придется много раз его изменять. В противном случае, если код окажется слишком хрупок, чтобы допускать изменения, игра получится «второсортной».

Не стесняйтесь использовать что-либо по той только причине, что это придумано не вами. Многие замечательные решения, примененные в 3D-играх, основаны на технологиях, созданных для программ трехмерной визуализации несколькими годами ранее. Потратьте немного времени на исследование технических приемов, которые вы хотели бы использовать в своей игре. Впоследствии это освободит вас для размышлений над по-настоящему уникальными аспектами игры.

Самое важное на первых порах - довести хоть что-нибудь до конца. Способность завершить игру - вот то, что будет отличать вас от тех героев, что начали, но не смогли... Один из моих приятелей, программист, любит повторять: «Завершить игру невозможно, можно лишь прекратить над ней работать». Всегда найдется что-то, что улучшит код, но однажды надо набраться смелости и сказать: «Хватит, он уже достаточно хорош», - и оставить игру в покое.

Я обнаружил один полезный технический прием при работе с Си++, который заключается в использовании массивов вместо динамического выделения памяти всюду, где только можно. Вы можете реализовать любую общую структуру данных (списки, очереди, стеки, кучи, деревья), используя массивы, - для этого достаточно применить индекс массива в качестве указателя. Это сразу же устранит связанные со структурой данных проблемы утечки памяти и, что существенно, среди прочих выгод заставит вас продумать худшие варианты условий выполнения вашей программы.

Ниже представлен пример реализации связанного списка через массив с указателем в сравнении с вариантом использования динамической памяти, а также небольшой пример, где противопоставлены эффективность и гибкость.

Пример массива:

При использовании указателей и динамического выделения памяти связанный список может выглядеть примерно так:

Содержимое адресов памяти
001 [Указатель на первый элемент (010)]
002 [Указатель на последний элемент (062)]

...

010 [Указатель на графическое представление объекта]
011 [Здоровье]
012 [Указатель на следующий элемент (053)]

...

053 [Указатель на графическое представление объекта]
054 [Здоровье]
055 [Указатель на следующий элемент (098)]

...

062 [Указатель на графическое представление объекта]
063 [Здоровье]
064 [Указатель на NULL (конец списка)]

...

098 [Указатель на графическое представление объекта]
099 [Здоровье]
100 [Указатель на следующий элемент (062)]

Если вы забудете освободить одну из этих структур, занимаемая ею память будет потеряна до момента выхода из игры. Кроме того, эти структуры разбросаны по всей памяти, так что независимо от порядка просмотра списка без подкачки обойтись не удастся.

При использовании массива реализация может выглядеть следующим образом:

Заголовок списка:

Первый [индекс первого объекта - 001]
Последний [индекс последнего объекта - 003]

Список:

Индекс массива - данные - индекс следующего элемента

001 Данные объекта 1 002
002 Данные объекта 4 004
003 Данные объекта 2 -1
004 Данные объекта 3 003

Применяя массив, невозможно потерять ни бита памяти, поскольку у вас всегда будет целиком заполненный массив - не более и не менее. Кроме того, если ваша функция добавляет объект в список, находя первое пустое место в массиве, можно просмотреть весь список по порядку с первого элемента по последний, сохраняя связность буфера.

При использовании этого метода в игре Warwind было задействовано множество списков, и все они имели дело с одним массивом. Общий модуль выполнял просмотр массива сверху донизу. Когда нам было необходимо выполнить обработку для конкретного игрока, мы просматривали список объектов данного игрока. Когда должна была выполняться обработка для некоторых типов элементов, мы просматривали соответствующий список и так далее.

И еще несколько слов о гибкости:

Это то, с чем вы сталкиваетесь всякий раз, когда создаете игру. По сути, программируя, вы пытаетесь предсказать будущее и неизбежно делаете предположения, которые в дальнейшем окажутся неверными. Однако предположения могут быть как хорошими, так и плохими. В Warwind мы решили, что каждая машина должна иметь точное представление о состоянии игры в каждом кадре. Это было неудачное предположение, поскольку в Интернете, где время ожидания велико, а потеря пакетов - обычное дело, синхронизация каждого кадра замедляет игру до скорости улитки.

Чтобы знать все о компании Dreamforge Intertainment, ее служащих и играх, обратитесь на веб-сайт www.dreamforge.com.

Стюарт Денман (Stuart Denman), Surreal Software

Стюарт Денман - вице-президент и технический директор Surreal Software, многообещающей компании, ответственной за игру Drakan (издатель Psygnosis).

Не чужой в программировании, Стюарт утверждает, что одним из наиболее важных критериев при создании экшен-игр является скорость вывода графики на экран. Ниже перечислены три основных потребителя памяти, чье влияние на частоту кадров вас вряд ли устроит, если только вы скрупулезно над ними не поработаете.

Количество полигонов и минимальные системные требования

Для тестирования лучше всего использовать компьютер, оснащенный по самому минимуму. Только в этом случае вы будете уверены, что игра покажет себя паинькой даже на слабых машинах. (Для примера: уровень, демонстрирующий 30 кадров в секунду на Pentium II 400 МГц, на Р166 при том же числе полигонов будет выводиться со скоростью 8 кадров/с.) Необходимо найти баланс между внешним видом игры (больше полигонов) и ощущениями от нее (частота кадров). Выбросите из головы мысли о том, что сможете провести оптимизацию частоты кадров по ходу проекта.

Искусственный интеллект

Искусственный интеллект загружает процессор не слабее полигонов. Сцена с 30 врагами в пределах одного экрана не только увеличивает количество обрабатываемой видеоинформации, но и резко повышает объем вычислений искусственного интеллекта, отвечающего за всю эту прорву компьютерных существ. Вывод: программисты, занятые искусственным интеллектом, просто обязаны установить ограничение на количество персонажей в игре.

Освещение

В Drakan точечное освещение изменяющихся объектов и ландшафта вычислялось динамическим образом. Иначе говоря, любое перемещение источника света или объекта должно было пересчитываться. При этом чем больше источников света и чем большие площади они охватывают, тем, разумеется, медленнее идет игра. Обратное справедливо.

«Частота кадров - один из наиболее критических факторов, за которым необходимо следить при программировании игры», - говорит Стюарт Денман. В игре Drakan сложное освещение - одна из причин дополнительного расхода памяти. (Использовано с разрешения компании Psygnosis, Inc.)

Кроме того, объясняет Стюарт, чтобы выиграть в скорости игры, там, где это возможно, необходимо снизить уровень детализации моделей (к примеру, меньше полигонов на удаленных объектах), а также убедиться, что базы данных и параметры организованы эффективно (как, конечно же, это было в игре Drakan).

В базах данных хранятся звуки, описания поведения, модели, текстуры и ресурсы сценария. Четкая организация этих элементов крайне важна для того, чтобы команда могла эффективно работать над уровнями. В игре Drakan поведение любого объекта определяется конкретными параметрами. Кроме того, существует отображение между ресурсами в базе данных и программным кодом, поэтому важно, чтобы все параметры задавались надлежащим образом.

Далее Стюарт Денман обсуждает аргументы «за» и «против» работы с лицензированным или собственным движком.

Приобретать лицензию или нет, зависит от той цели, которую вы себе поставили. Если вы решили сказать новое слово в технологии, то заемный движок не самое лучшее решение. Если же ваши планы не простираются дальше создания игры на основе оригинального сценария, лицензионный движок тут как тут. Лицензирование сэкономит годы работы и позволит уделить внимание самой игре.

Surreal повезло, поскольку мы добились начального финансирования проекта, имея на руках лишь небольшую демонстрационную программку. Большинству разработчиков это не удается. Я осознал (хотя и не сразу), что попасть в эту индустрию, если вы никогда в ней не работали, весьма трудно. Вам необходимо доказать собственную состоятельность либо с помощью репутации, либо поразив всех гениальной демо-программой. Жаждущие получить заказ на создание игры всегда могут появиться из ниоткуда и с ходу выдать демо-версию, соперничающую с профессиональными работами. Пока такое возможно, а значит, шансы есть у всех

В программировании информация часто хранится в виде массивов, то есть строк данных. Нередко попытка обращения к областям памяти находящимся за пределами массивов, вызывает общий сбой Windows - General Protection Fault (GPF). Например, если массив содержит только пять элементов, а программа попытается получить доступ к восьмому, вы увидите на экране сообщение о GPF. Чтобы застраховать себя от подобных ошибок, обратите внимание на следующую программу.

Это должен сделать каждый программист - создать шаблон для массивов. Не используйте массивы в стиле Си, если это не является абсолютно необходимым. Определение шаблона должно выглядеть примерно так:

template <class Entry> class Array
{
private:

Entry *pEntry;
int iSize;

Далее шаблон содержит внутренние компоненты для добавления (размещения) и удаления записей массива, а также компоненты для доступа к массиву, подобные приведенному ниже:

public:

// Обеспечивает доступ к записям массива...
Entry &operator [](const int ilndex) const
{

Assert(ilndex >= 0 && ilndex < iSize);
return pEntry[ilndex];

}

Функция Assert очень важна, так как она вызывает ошибку отладки, если значение выражения-аргумента Assert равно FALSE. Этот небольшой фрагмент программы спас нас от такого количества ошибок, что я просто не представляю, что бы мы без него делали. Наш макрос Assert выглядит примерно так:

// Режим отладки:
#if defined(_DEBUG)

extern BOOL MyAssertFunc(BOOL, int, char *};

#define NatBreakf) { _asm { int 3 } }

// Утверждает, что значение ехр - истина.
#define Assert(ехр) \

if (MyAssertFunc((int)(exp),__LINE__,__FILE__)) \
NatBreak();

// Режим без отладки:

#else

#define Assert(exp)

#endif // _DEBUG

При окончательной сборке все макросы Assert исключаются из компиляции. При сборке для отладки функция MyAssertFunc включается в библиотеку. Функция вычисляет первый аргумент и выводит окно сообщения, указывающее строку и файл, где сработало утверждение (последние два аргумента). После этого программист может принять решение продолжить или прервать выполнение. При выборе прерывания функция возвращает значение TRUE, и инструкция int 3 приведет к остановке отладчика на строке макроса Assert.

Узнать все о проекте Drakan вы сможете, заглянув на сайт www.psygnosis.com/drakan/.

Ричард Моу (Richard Moe), Humongous Entertainment

Ричард Моу, сотрудник компании Humongous Entertainment, привык выступать в самых разных амплуа: от руководителя проекта до (помимо прочих обязанностей) инженера-программиста. Все игры Humongous пишутся на собственном языке SCUMM, который был разработан соучредителем компании Роном Гилбертом (Ron Gilbert). Вот лишь некоторые проекты, отмеченные вниманием дизайнера и программиста Ричарда Моу (в хронологическом порядке): Junior Field Trips: Let's Explore the Airport, Pajama Sam in There's No Need to Hide When It's Dark Outside, Backyard Baseball и Putt-Putt Enters the Race.

Ричард утверждает, что каждая игра ставит перед дизайнером и программистом собственный набор проблем. Ниже он приводит примеры из своей практики.

При создании детских игр самое проблематичное - определиться со сложностью, чтобы игра получилась интересной и легкой как для четырехлетнего, так и для восьмилетнего ребенка. Очевидно, что уровень мастерства игроков в пределах этого возрастного диапазона существенно отличается. Например, в Pajama Sam входит простая игра типа крестиков-ноликов, Cheese and Crackers («Сыр и печенье»). Для игры используются доски трех размеров: 3x3, 5x5 и 7x7. Доска 3x3 - это классические крестики-нолики, три знака в ряд выигрывают. На досках 5x5 и 7x7 для выигрыша требуется поставить в ряд соответственно четыре или пять знаков. Легко понять, что первый из трех вариантов самый простой (меньше комбинаций), а остальные последовательно сложнее. Однако включив в игру все варианты, мы предоставили возможность приятно провести время игрокам с любыми навыками. Более того, оппонент в лице компьютера пытается подстроиться под возможности противника. Если игрок побеждает, в следующей партии компьютер будет играть более умело. Аналогично, если победа на стороне искусственного интеллекта, в следующей партии он будет играть чуть слабее.

А теперь небольшое отступление. Я считаю, что для игрового дизайнера, в отличие от программиста, самые главные вопросы - это знание аудитории, которой предназначается игра, и современных технологий. Первый пункт связан с предыдущим абзацем: работаешь для детей - обязан знать, что они любят; делаешь стратегическую игру на военно-историческую тему - будь любезен выяснить вкусы игроков, предпочитающих военные игры.

Очевидно, хороший программист должен постоянно следить за современными технологиями. Однако следует помнить, что эпоха Возрождения давно прошла, а вместе с ней исчезли и универсалы: сегодня быть программистом «на все руки» просто невозможно. Специализация обязательна. Уважающий себя игровой программист в первую очередь сосредотачивает внимание на областях, где чувствует себя сильнее всего, а остальное оставляет кому-нибудь другому. Я не смог бы написать хорошую подпрограмму для копирования большого массива битов из одной области памяти в другую, даже если б от этого зависела моя жизнь. Я - но не другие. Поэтому я предоставляю им делать их работу, а сам пользуюсь созданной ими библиотекой.

Должен ли программист разбираться в других областях «игростроения»?

Бюджет - страшная вещь. Действительно, по ходу проекта программисту часто приходится становиться мастером на все руки - что делать, специалистов не хватает. В других случаях возникающая проблема является уникальной для игры и используемого движка. Я не могу поручить человеку, хорошо знающему Си++, написать подпрограмму, которую можно будет использовать в моей игре, основанной на языке SCUMM. В этом случае незнакомый со спецификой инструментария программист может не справиться с заданием (чаще всего именно так и происходит). К слову, совсем недавно я столкнулся с подобной проблемой во время работы над Putt-Putt Enters the Race. В конце игры игрок должен провести свой автомобильчик (Putt-Putt) по псевдотрехмерной трассе. Чтобы все это правильно работало, я должен был отслеживать объекты в трехмерном виде. У меня не было практически никакого опыта в трехмерных преобразованиях, а рядом, увы, не оказалось ни одного человека, который мог бы прийти мне на помощь. В итоге ваш покорный слуга был вынужден делать все самостоятельно. К счастью, у меня есть несколько знакомых специалистов, и результаты оказались удовлетворительными. Конечно, это не Gran Turismo, но давайте вспомним основной вопрос: я понял, что мою аудиторию (дети 3-8 лет) не волнует реальность физических моделей и трехмерная визуализация в реальном времени. Вместо этого я поместил несколько забавно выглядящих уток, которые должны были крякать и улетать, если вы подъезжали к ним слишком близко.

А как лучше всего научиться программированию? «Зажмите нос и ныряйте прямо на самую глубину, - советует Ричард. - Начните с простого - игры вроде Minesweeper или тетриса. Или с клона Space Invaders. Еще немного, и вы доберетесь до трехмерных экшен-стратегий от третьего лица в реальном времени».

Курт Пфайфер (Kurt Pfeifer), Cavedog

Cavedog Entertainment - компания-партнер Humongous Entertainment, разработавшая в свое время стратегическую игру Total Annihilation, которая имела умопомрачительные продажи и была отмечена невероятным количеством наград со всего мира. Знакомьтесь: Курт Пфайфер, один из авторов Total Annihilation. Кроме того, в его послужном списке Microsoft Soccer, Powerslave, DinoPark Tycoon и Magic School Bus Across the Solar System, а также перенос Duke Nukem 3D на приставку Sega Saturn. На момент написания книги он занимал должность ведущего программиста проекта Good & Evil (увы, закрытого вместе с Cavedog в начале 2000 года. События в игровом мире происходят с невероятной быстротой. И не всегда приятные. - Примеч. ред.). Ниже Курт предлагает несколько полезных рекомендаций для тех, кто хочет заняться написанием программ для современных игр.

Подготовьте полный проект своей игры

Если вы хотите уложиться в запланированные сроки, прежде всего четко определите, что и как нужно получить в результате. «Игрописание» не столь сухо и канонично, как точные науки, здесь гораздо больше простора для импровизации, чем в любой другой области программирования. Но если вы в состоянии хотя бы приблизительно объяснить, что хотите в итоге получить, это позволит в будущем избежать работы вслепую и необоснованных задержек. Будет полезным даже просто просмотреть эскизы и сценарий – это даст вам возможность составить общее представление об игре, а также позволит подобрать оптимальный вид игры на экране (перспектива, двухмерная или трехмерная графика).

Курт приводит следующий пример:

Меньше всего вопросов, когда вы заняты переносом существующей игры на другую платформу. Так было, когда мы портировали Duke Nukem 3D и Quake на Sega Saturn (я тогда работал в Lobotomy): вместо проекта на бумаге, который мог быть изменен или неверно истолкован, у нас был ясный прототип в виде игры для ПК, которая к тому времени уже покорила рынок. Каждая картинка, каждый звук, каждый нюанс системы управления были уже готовы, оставалось лишь вписать все это в рамки, накладываемые приставкой Saturn. На все работы нам дали шесть месяцев (позже срок был увеличен до девяти, что позволило запрограммировать сетевую версию) и это заставило нас трудиться с максимальной эффективностью. Понимание «общей картины» игры позволило нам оптимально распределить задачи и спланировать график выполнения проекта.

Вовлекайте в работу как можно больше людей

Это проще сказать, чем сделать, так как программированию игр почти не учат, а вам необходимо найти людей с уже имеющимся опытом (таких всегда дефицит) или выбрать из тех, кто знает общее программирование и горит желанием погрузиться в игры. В такой ситуации даже простейшие задачи могут перерасти в фундаментальные и, если вы испытываете недостаток в рабочей силе, все сроки полетят в тартарары.

Выделяйте время на исследования и разработку

К сожалению, из-за жестких сроков сдачи проектов время для исследований выделяется нечасто. Если вы хотите сделать что-нибудь действительно уникальное, найдите возможность провести некоторые изыскания, в ходе которых можно будет подобрать готовые пакеты программ, отвечающие вашим потребностям (инструменты трехмерного моделирования, программы рисования, звуковые редакторы), а также создать необходимые собственные инструменты (редакторы карт, языки сценариев, инструменты для анимации и т.п.). В это же время художники, взяв за основу существующие инструменты трехмерной анимации и двумерного рисования, могут заняться созданием видеороликов (или отдельных рекламных кадров), моделирующих перспективу игры и ее динамику. В этом случае вы сразу сможете выяснить, все ли согласны с проектом, который вам предстоит воплощать, вместо того чтобы через пару лет вдруг обнаружить, что издатель или дизайнер видят игру совсем иначе, чем вы предполагали.

По мнению Курта Пфайфера очень важно поддерживать в коллективе, работающем над игрой, интерес к проекту, что в конечном итоге позволит довести дело до конца.

Я не раз видел, как дизайнер терял интерес к игре после первой половины проекта, когда «медовый месяц» начального проектирования уже прошел и настало время перейти к проработке «скучных» деталей. В этом случае я был вынужден брать на себя еще и роль дизайнера: ком забот рос, и в результате в той или иной степени начинало хромать программирование. Что касается завершения проекта, то сегодня потерпеть поражение проще, чем когда-либо: игры (и их бюджеты) становятся все больше, а списки технологических возможностей растут как на дрожжах.

В заключение Курт говорит: «Даже простое управление проектом может оказаться нелегкой задачей, однако игра в любом случае должна и может быть завершена. Если, конечно, вы заранее спланировали всю работу и должным образом распределили задания».

Джейми Фристром (Jamie Fristrom), Treyarch Invention

Джейми Фристром - старший программист в калифорнийской компании Treyarch Invention. Создание знаменитых экшен-игр Die by the Sword и Limb from Limb (издатель Interplay, 1998) - отчасти и его заслуга. Джейми делится с нами парой мыслей относительно программирования игр и модульности разработки.

Это настоящее искусство - написать исходный код, который совместит в себе сразу множество качеств. Программа должна быть не только легко читаемой, поддерживаемой и развиваемой, но и давать возможность быстро создать работающую демо-версию.

По сути, программист - это человек, который помогает дизайнеру в работе над игрой или уровнем игры. Поймите это, и игра только выиграет от такого подхода к делу.

Самое неприятное, когда в ходе работы возникает необходимость внести в игру новые, не запланированные ранее возможности. В случае с Die by the Sword примером такого рода может служить вдруг возникшая идея применения в качестве орудия оторванной конечности. Лучший способ справиться с этим - наверное, переписать инфраструктуру и добавить в нее новые возможности, но мы, помнится, просто скрестили пальцы и быстренько пропатчили исходную программу. Разумеется, это привело к массе огорчений и долгим часам отлова ошибок-«жучков», нами же и занесенных.

Поэтому последний совет Джейми Фристрома звучит так: «Насекомые в программе - это плохо. Давите их до того, как они начнут размножаться».

Майкл Саладино (Michael Saladino), Presto Studios

После ухода из компании Mobeus Designs, занимающейся созданием трехмерных графических движков, Майкл Саладино некоторое время работал в Volition (на ее счету игра Descent, слышали?), где вскоре стал ведущим программистом. В данный момент он снова программирует движки в Presto Studios. Ниже следует список заповедей, предложенных Майклом, и комментарии к каждой из них.

Нельзя недооценивать ассемблер

С появлением каждого нового поколения процессоров Intel в интернетовских группах новостей и курилках фирм, занимающихся разработкой ПО, вновь разгораются дискуссии относительно будущего языка ассемблер. Идея написать игру для ПК целиком на ассемблере уже никогда не осуществится, однако это вовсе не означает, что ассемблер перестал быть чрезвычайно полезным инструментом программирования. Интенсивно выполняющиеся циклы, которые потребляют львиную долю общего времени выполнения игры, всегда будут существовать в той или иной форме. Раньше они использовались для копирования больших битовых массивов, сейчас применяются для внутренних циклов отображения текстур. Что же дальше? Как насчет триангуляции сплайновых персонажей в реальном времени? Блок программы, который выполняет цикл сотни, тысячи или сотни тысяч раз для каждого кадра, часто будет работать гораздо быстрее, если он написан на ассемблере.

Я еще не встречал компиляторов, способных понять тонкие нюансы фрагмента программы так же хорошо, как опытный программист.

Как следствие: не следует надеяться, что применение ассемблера - это уже победа. Медленному алгоритму уготовано медленное выполнение как на ассемблере, так и на Си. Поэтому начинать всегда следует с оптимизации алгоритма. Если вы уверены, что нашли лучшее решение (либо если начался завершающий этап работы над проектом и продюсер не позволяет вам переписывать алгоритм обрезки полигонов в пятый раз), попробуйте применить ассемблер с целью выжать последние капли быстродействия.

Если же вы считаете, что игра не стоит свеч, то представьте себе, как вытянется ваше лицо, когда вы узнаете, что в команде конкурентов нашлись программисты, думающие иначе, а их игра выполняется несколько быстрее, что позволило использовать эти умопомрачительные точечные эффекты...

Не стоит оптимизировать программу раньше времени

Не занимайтесь оптимизацией раздела исходного кода до тех пор, пока не убедитесь, что он значительно замедляет выполнение. В противном случае вы сами, во-первых, потеряете на этом время, а во-вторых, замедлите разработку программы в будущем, когда другим потребуется разбираться в вашем фрагменте на ассемблере. Вот несколько классических примеров.

Оптимизация кода инициализации

Зачем это нужно? Он запускается один раз в начале программы. Разумеется, если из-за предварительной обработки крупных текстур запуск игры занимает полминуты, тогда что-то сделать нужно (скажем, вынести эту задачу как отдельный шаг в обработке уровней), но в 99,9% случаев, если код выполняется всего один раз, вообще не стоит об этом беспокоиться.

Оптимизация до анализа

С моим опытом в программировании, уходящим далеко в прошлое (я впервые сел за Apple II+ в семь лет), я по-прежнему часто ошибаюсь в определении, что замедляет, а что не замедляет мой код. К счастью, профайлеры (особенно VTune от Intel) стали обычным инструментом программирования. Они помогут вам быстро и легко определить, какие функции и даже какие строки являются причиной того, что ваш код выполняется столь вяло. После подобного анализа вы наверняка никогда не будете расточать время, оптимизируя что-то, что и так работает достаточно быстро.

Оптимизация быстрых программ

Вам никогда не попадались программисты, занятые преобразованием отлично читаемых программ на Си в крайне неуклюжие (хотя, возможно, и очень умные) программы на ассемблере, хотя все уже гарантированно работает с частотой 120 кадров в секунду? А мне попадались. Понятно желание сделать код настолько быстрым, насколько это в принципе возможно, но это уж слишком. Не стоит забывать и о том, что код должен легко читаться, что особенно актуально в современных компаниях, занимающихся разработкой ПО (вполне вероятно, что к тому или иному фрагменту вашей программы будут обращаться десятки людей). В большинстве случаев введение в игру кода, написанного на ассемблере, на начальной стадии реализации проекта является плохой идеей. Это сильно затрудняет обновление и дополнение программы.

Любите свою программу, но не обожествляйте ее

Невозможно даже приблизительно сказать, сколько времени тратится на подобные глупости! Программисты так привязываются к своему коду, что закрывают глаза на любые его недостатки. Писать программы - это, конечно, здорово, но не забывайте, что они, в конечном счете, всего лишь буковки на экране. Недостатки вашего кода - вовсе не ваши недостатки, не принимайте их на свой счет. Просто согласитесь с тем, что кто-то другой придумал, как заставить вашу программу работать быстрее. И с этого момента маленький прием, показанный вам другим человеком, стал и вашим тоже.

Кроме того, не устраивайте разборок насчет стилистических разногласий. Когда я слышу очередной спор по поводу того, использовать ли в тексте программы табуляцию или пробелы, мне кажется, что я готов вскрыть себе вены. Меня не волнует, как вы расставите свои пробелы или скобки, для меня важно исключительно содержание программы. Я думаю, каждая компания должна принять одно из двух решений: либо каждый пишет в своем стиле и никому не позволяется выражать по этому поводу недовольство, либо все должны придерживаться единожды принятого стандарта.

И вообще, программистам необходимо уметь отделять себя от своих программ.

Тодд Джонсон (Todd Johnson), Oddworld Inhabitants

Инженер-программист Тодд Джонсон работал в свое время над играми для Genesis (Sylvester n' Tweety in Cagey Capers, Demolition Man и Izzy's Olympic Quest) и PSX (Oddworld: Abe's Oddysee и Oddworld: Abe's Exoddus). Тодд считает, что самое важное для программиста - учитывать ограничения конечной системы. Он поясняет свою мысль:

Я начинал с игр для приставок, где мы постоянно мучились от недостатка оперативной памяти. Например, Oddworld: Abe's Exoddus должен постоянно подкачивать в ОЗУ анимацию, фоновые рисунки и даже фрагменты программы. А на ПК вы, вероятно, столкнетесь с проблемами быстродействия. В любом случае конечная система так или иначе влияет на игру.

«Во-вторых, уважайте игрока, - говорит Тодд, - в конце концов, это он платит за игру».

Иначе говоря, не стоит увлекаться излишним усложнением. Когда мы впервые начали работать над мудоканами (игра Oddworld: Abe's Exoddus), каждый из них обладал индивидуальными чертами характера и должен был реагировать по-разному. С точки же зрения игрока, их реакция казалась абсолютно случайной, так как внешне все они выглядели одинаково. Мы сохранили эмоции, но отбросили идею индивидуальности.

И последнее, что советует Тодд Джонсон: «Продумайте повторное использование кода».

На написание программы по готовому проекту требуется время, поэтому если игра перегружена уникальными возможностями, ее реализация займет годы. Другая крайность - полное однообразие, так что хитрость в том, чтобы найти оптимум. Добавляя простые параметры (например скорость или время) к существующим персонажам и механизмам, вы сможете извлечь массу преимуществ.

Что Тодд считает самым большим препятствием в работе программиста?

Коммуникационную пропасть между членами команды. Причем это не только наша проблема, те же несовершенства мучают бизнес в целом. В каждом проекте участвуют программисты, художники и дизайнеры, каждая группа обладает индивидуальностью и имеет свой собственный опыт. Конечно, гораздо проще наладить взаимодействие в пределах группы, чем вне ее, но именно в этом ключ к успешной реализации проекта. В школах, к сожалению, не обучают общению с людьми, а тем более с людьми, чье видение мира отличается от вашего.

Гонзо Суарес (Gonzo Suarez), Pyro Studios

Гонзо Суарес работает в компании Pyro Studios, которую основал в 1997 году вместе с другом и партнером по бизнесу Игнасио Пересом (Ignacio Perez). Именно здесь, в Испании, родилась игра Commandos: Behind Enemy Lines, ставшая позже международным бестселлером (издатель Eidos Interactive).

Гонзо Суарес делает ряд полезных подсказок начинающим программистам, только-только собирающимся приступить к созданию первой игры.

Прежде всего спросите себя: в какую игру ты хочешь играть? Вопрос кажется очевидным, но покрывает добрых 90% проблем, которые возникнут в ходе разработки. Как ни странно, в большинстве случаев ответ на этот вопрос выпаливают, не задумываясь (хотел бы я уметь отвечать так же быстро), однако обычно этот ответ сразу же вызывает беспокойство. «Это экшен-игра с элементами стратегии и духом приключений, и она отображает 30000 полигонов!..» Довольно странно, когда ответ на вопрос «в какую игру ты хочешь играть?» начинается со слов «это...», а уж упоминание о числе полигонов достойно пера Кафки.

Надеяться, что ответ останется неизменным на протяжении всего проекта, - роскошь, которая может быть подкреплена только опытом (не только знанием проблем, сопутствующих созданию видеоигр, но также пониманием их влияния на процесс разработки). В большинстве случаев на любую неясность будет искаться оправдание типа «открытого дизайна» и «привлекательности для всех», но для меня это прямой путь к самоубийству.

Примером могут служить Quake II и Half-Life. Кажется, что эти игры очень похожи, однако акценты, сделанные на том, где, как и когда нужно стрелять в Half-Life, контрастируют с быстрым окружением движущихся мишеней и точным прицелом Quake II, чувство силы оружия в игре id Software противопоставляется возможностям Half-Life скрываться от противника и снайперских выстрелов. Все это делает стратегию сетевой игры для них абсолютно различной.

В процессе работы над игрой возникают затруднительные ситуации, когда необходимо принести в жертву одну из конфликтующих возможностей, хотя каждая из них по своему хороша и при желании можно отстоять любую. Другими словами, мы все хотим получить самую красивую машину с наиболее мощным двигателем, минимальным расходом топлива и за наименьшую цену, но при разной расстановке приоритетов мы можем получить любую машину, начиная с BMW и кончая гоночным суперкаром или семейным лимузином.

Имея за плечами примерно пятнадцатилетний опыт программирования и разработки игр, Гонзо Суарес советует обратить внимание на следующие правила.

Игра

Основные элементы, которые образуют игровую логику, являются неприкосновенными для прочих моментов игры. Например, критерии логики игры предписывали, чтобы вся графика Age of Empires была согласована с основной сеткой игрового пространства. Другими словами, игровые объекты занимают одну или несколько клеток. Они никогда не могут занимать клетку совместно с другими объектами или размещаться между двумя клетками. Расстояния и координаты в логике игры измеряются по сетке. Поэтому графика должна следовать тем же самым правилам (более или менее скрытым). Несмотря на эти жертвы в области графики, у нас получилась выдающаяся игра, которая не смогла бы достигнуть такого успеха, если бы в процессе создания не была сохранена верность данным приоритетам.

Другим примером игровой логики является Commandos. Логический мир игры подразделяется на произвольные секторы с любым перемещением объектов в непрерывном трехмерном пространстве, при этом объект хранит информацию о своей трехмерной координате. Именно эта логика позволила создать столь нестандартную игровую графику (с помощью команды замечательных художников, конечно).

Структура пространства в игре Commandos, в отличие от StarCraft (Blizzard) или Age of Empires (Ensemble Studios), не основана на сетке или ячейках. Движок Commandos допускает асимметричное расположение объектов, что придает игре индивидуальность. (Приводится с разрешения компании Рут Studios, Inc.)

Логический интерфейс

Не менее важна проблема взаимосвязи логических элементов игры между пользователем и компьютером. Хорошим примером является курсор, при помощи которого пользователь получает доступ в игровой мир.

Все, что включено в игру, должно взаимодействовать с пользователем (более или менее явно) наиболее эффективным способом; любые действия, которые пользователь захочет совершить в игре, должны выполняться достаточно просто, без привлечения интуиции. Другими словами: а) если пользователь не может чего-то понять, это что-то лучше вообще исключить из игры; б) если пользователь не может выполнить какую-либо операцию, исключите ее из списка действий (особенно если она выглядит для игрока заманчиво).

Ощущение и отчуждение

Эти факторы включают в себя как элементы, посредством которых игра передает игроку ощущения (визуальные и звуковые), так и возможность игры создать для игрока атмосферу погружения, в которой он почувствует себя внутри игры.

И хотя игроки, по-видимому, ценят этот фактор больше всего, я бы поставил его на третье место по шкале приоритетов. Иначе после входа в игру вас ждет пять минут благоговения, а затем часы разочарования. Это, как правило, происходит, когда разработчик создал замечательный движок с уникальными возможностями, которые кажутся ему настолько привлекательными, что он не может отказать себе в удовольствии использовать их где надо и не надо, даже если они совсем не сочетаются с логикой игры.

Примеры таких проектов (некоторые из которых никогда не были завершены) у всех на слуху. Их программисты были безумно горды реалистичной и детальной физической моделью, где все вращалось и сталкивалось - ну прямо как в реальной жизни. Но когда эти потрясающие возможности применялись в игре, вдруг выяснялось, что вы не можете управлять персонажами, и ваше первоначальное любопытство вскоре превращалось в форменный кошмар. В качестве крайнего случая попробуйте представить себе игру в шахматы с видом от первого лица, трехмерной графикой и каждой фигурой, имеющей собственное лицо, причем сражение проходит в прекрасной долине, где игровое поле покрыто изумительно анимированной травой, под которой клетки доски едва различимы. Оценка «5+» за внешний вид гарантирована, и вашему удивлению нет границ, но я не знаю, каким должен быть интерфейс, чтобы играть в это чудо!

Особенности

Технология, лицензии и прочие «примочки», важные для рекламы продукта и подчеркивания его уникальности на рынке («Отображение 40000 полигонов в реальном времени!..»), должны касаться программиста в последнюю очередь. Весь мой опыт разработки видеоигр свидетельствует, что игры никогда не делают из «дополнительных возможностей», однако почему-то именно на них многие разработчики основывают свои представления об играх.

Когда, читая проектную документацию к игре, видишь лишь пространные псевдонаучные рассуждения, умело упрятавшие суть - идею игры, это выглядит несколько странно. Я сказал «псевдонаучные» поскольку, несмотря на вечные обещания точности, там растут лишь неясные научные дебри. Что означает фраза: «движение 40000 полигонов»? Или «захват движения»? Или «искусственный интеллект»? Даже если мы верим, что знаем, о чем говорим, последнее слово за реальностью. Я помню, когда мы работали над проектом HeadHunter, мой партнер Хавьер Аревало (Javier Arevalo) создал технологический прототип, содержащий множество трехмерных возможностей, от которых тогда просто отвисала челюсть: вспышки, цветное освещение, точечные эффекты. Люди, видевшие это, кричали: «Потрясающе! Теперь осталось придумать, как все это вставить в игру!» Сущие пустяки: всего лишь написать игру...

В заключение Гонзо Суарес приводит аналогию: «Приукрасить игру дополнительными функциями - это все равно, что поставить на машину спойлеры и литые диски: если автомобиль не удовлетворяет своему назначению, все эти аксессуары никому не нужны».


Искусственный интеллект

Глава 9

Искусственный интеллект

Искусственный интеллект (далее ИИ) - это попытка смоделировать мысли и поведение человека при помощи компьютера. В компьютерных играх роль ИИ сводится к тому, чтобы создать у играющих ощущение, будто они играют против реальных, разумных соперников. Программирование ИИ всегда было одной из самых сложных проблем при написании игр, поэтому мы решили не смешивать эту тему с другими вопросами, описанными в предыдущей главе, а посвятить созданию искусственного интеллекта отдельную главу.

Еще одна причина нашего пиетета к ИИ: мы хотим подчеркнуть, что одиночные игры по-прежнему заслуживают самого пристального внимания. Растущая не по дням, а по часам популярность многопользовательских развлечений наводит на грустные мысли о том, что разработчики, бросив все силы на отладку сетевого кода, могут попросту забыть о необходимости совершенствования ИИ. В конце концов, если ИИ будет действовать предсказуемо или, не дай бог, неразумно, большинство игроков предпочтут сетевые состязания с живыми соперниками. И задача - сделать игру, обладающую не только выдающимся сетевым механизмом, но и сверхреалистичной системой искусственного интеллекта (вы не забыли о тех, кто просто не может или не хочет позволить себе игру по сети?) - так никогда и не будет решена.

Призвав на помощь мощную группу специалистов, работающих над созданием искусственного интеллекта в разных игровых жанрах, мы обсудим здесь различные виды ИИ и приемы его создания.

Брайан Рейнольдс (Brian Reynolds), Firaxis Games

Один из лучших учеников Сида Мейера (Sid Meier), Брайан Рейнольдс принимал участие в создании таких классических стратегий, как Colonization и Civilization H. На момент написания этой книги Брайан являлся вице-президентом компании Firaxis Games по разработке программного обеспечения. Последняя его работа - военно-историческая игра Antietam! «Вопреки бытующему мнению, - говорит Брайан, - создание ИИ для компьютерной игры обходится без черной магии. Совершенно не обязательно доставать какие-то запатентованные алгоритмы или знакомиться с результатами последних исследований в области нейронных сетей. Все, что вам нужно, - это немного вдохновения и огромное упорство». В следующих трех параграфах описаны некоторые из излюбленных методов Брайана Рейнольдса.

Итеративный процесс разработки

Прежде всего в ходе создания ИИ, как и при создании самой игры, необходимо использовать «итеративный процесс разработки». Начните с простого моделирования передвижения вражеских фигурок, пусть даже ваш алгоритм окажется не сложнее, чем «switch(rnd(4))». Затем попробуйте сыграть против вашего ИИ и понаблюдайте за тем, какие ходы он делает. Дождитесь, пока система совершит какую-нибудь глупость (в первый раз это случится очень быстро), а затем подумайте вот над чем: а) какие ошибки допустил компьютер (предположим, пустил танки через лес, что замедлило их передвижение, или из всех родов войск начал «строить» исключительно артиллерию); б) как бы вы сами поступили на его месте (двигали бы танки по дороге, в разумных пропорциях «строили» пехоту, артиллерию, танки и самолеты...); в) какие данные заставили вас (помогли вам) принять это решение (юниты быстрее передвигаются по дороге; у вас уже имелась пушка, но не было ни одного пехотинца). Измените алгоритм с учетом этих данных.

Теперь начните игру заново - до очередной ошибки, после чего весь процесс повторяется. Раз от раза ваш ИИ будет становиться все умнее и умнее. Так на практике выглядит пресловутая «самообучающаяся система». Благодаря таким многократно повторяющимся циклам игры и исправления кода, ИИ набирает опыт и начинает играть все лучше и лучше.

Чтобы проиллюстрировать свою идею, Брайан Рейнольдс рассказал нам о том, как он, будучи молодым программистом, работал над своей первой игрой (Colonization).

По правде сказать, когда пришло время приступать к работе над искусственным интеллектом, я немного побаивался. Игра к тому моменту в общих чертах уже была готова: в нее можно было как-то играть, передвигать отряды, но ИИ совершенно не знал, как выполнять какие-либо действия. С чего же начать? Я до сих пор помню совет, данный мне Сидом Мейером: «Сначала научи компьютер делать один ход. Затем научи его делать два хода, и лишь потом думай о том, чтобы он сделал 10 ходов».

Брайан Рейнольдс рекомендует играть в создаваемую игру и наблюдать за поведением искусственного интеллекта. Когда система выкинет очередную глупость, определите, что вы от нее хотите, а затем вернитесь назад и исправьте свой алгоритм. Повторяйте этот процесс столько раз, сколько потребуется. (Приводится с разрешения компании Firaxis Games, Inc.)

Начните с простого

Начните с тривиальных компоновочных блоков. Например, для стратегической игры сначала полезно написать стандартную процедуру, задающую маршрут перемещения любого объекта из пункта «А» в пункт «Б». Обычно это называют алгоритмом поиска пути (или перемещения). Создание процедуры поиска пути - весьма подходящий замкнутый проект для начала работы: нужно только научить объект, как переходить «отсюда» «туда», и поначалу не обращать внимание на то, как он будет выбирать это самое «туда». Я не говорю, что написать хорошую процедуру поиска пути просто, но всегда легче начать работу с понятной задачи, а затем перейти к более сложной. Как только процедура поиска пути будет готова, можно приступать к другой задаче - определению, в какое место карты должны двигаться ваши фигурки. И теперь вам уже не надо будет заботиться о том, как именно они туда доберутся.

Процедура поиска пути отвечает за перемещение одного или нескольких юнитов из пункта «А» в пункт «Б», а также за выбор наиболее рационального маршрута движения. Вам когда-нибудь приходилось замечать, как в старых стратегиях, идущих в реальном времени, отряды застревают на полпути или выбирают длинные и неудачные маршруты?

Умножение и деление на двойку

В самом начале своей карьеры я научился у Сила Мейера еще одному замечательному приему. Подобно другим нашим уловкам, он одинаково хорошо применим и к разработке игр, и к созданию искусственного интеллекта. Метод состоит в следующем: если у вас есть какое-нибудь значение или эффект, и вы хотите его скорректировать, удвойте его или поделите пополам. Например, если танки кажутся вам слишком дешевыми, удвойте их стоимость. Не пытайтесь увеличивать значение с 10 до 11, гадая о том, возымеет ли это нужный эффект. Сразу «поднимите ставки» до 20, даже если это и кажется не совсем уместным. А теперь все внимание на игру: изменения от удорожания танков видны невооруженным взглядом - стало быть, вы получили четкое представление о роли этого параметра. Цена слишком велика? Отрегулируйте ее, уменьшив значение до 15. И так далее. Если вам кажется, что компьютер создает слишком много пехотинцев, сократите вероятность их производства сразу вдвое. Я помню сотни случаев, когда я увеличивал или уменьшал вдвое тот или иной параметр, ожидая увидеть слишком сильные изменения, а на поверку выходило, что для достижения желаемого эффекта нужно было еще раз умножать или делить на двойку. И снова повторюсь: итеративный метод здесь незаменим.

Брайан закончил интервью следующим советом: «Придерживайтесь простого алгоритма: попробовал - исправил - повторил. И не ошибетесь».

Марио Гримани (Mario Grimani), Ensemble Studios

Перед тем как перейти в Ensemble Studios, Марио Гримани работал в студии 7th Level над стратегией Dominion: Storm Over Gift 3 и другими играми. Сейчас он является штатным сотрудником компании Ensemble Studios по искусственному интеллекту (на момент написания книги Марио трудился над «железными мозгами» для игры Age of Empires II: The Age of Kings).

На что нужно прежде всего обращать внимание, работая над системой ИИ? Вот ответ Марио Гримани:

• Помните, что количество времени и усилий, затраченных на разработку ИИ, не всегда прямо пропорционально тому, как результат будет воспринят пользователем.

• Разрабатывайте искусственный интеллект итеративным путем. Создайте приблизительный вариант системы, проверьте его работу и начните вносить улучшения с той части, которая функционирует хуже всего.

• Сделайте систему максимально гибкой. Скорее всего, над игрой, для которой вы пишете ИИ, еще идет работа, поэтому у вас должна быть возможность изменять систему в ходе выполнения проекта.

Искусственный интеллект игры Age of Empires II: The Age of Kings позволяет контролировать поведение управляемого компьютером игрока с помощью легкого в использовании языка внешних команд. Компьютерные игроки могут играть как против людей, так и друг против друга. Это позволяет нам легко менять поведение ИИ в процессе разработки игры, а также дополнять систему на более поздних стадиях проекта.

Марио Гримани советует составлять игровой ИИ из отдельных программных модулей, так как вам, вероятно, еще придется возвращаться к ним и вносить изменения в течение цикла разработки. (Приводится с разрешения компании Microsoft.)

Далее Марио описал различные виды ИИ и некоторые проблемы, возникающие при его программировании.

Под термином «искусственный интеллект», широко использующимся в компьютерных играх, подразумевается набор решений для самых разных задач: от моделирования человеческого поведения персонажей ролевых игр до поиска пути в стратегиях в реальном времени.

Основные задачи, решаемые ИИ в стратегиях в реальном времени, - это поиск пути для отдельной боевой единицы, все прочие вопросы поведения боевой единицы, не связанные с движением, поведение группы юнитов и ИИ компьютерного игрока в целом. Последний сам по себе состоит из множества частей, которые определяют стратегию и тактику боя, назначают места для построек, оценивают угрозу, исходящую от противника, анализируют местность, а также выполняют массу других функций.

Некоторые из решаемых искусственным интеллектом задач требуют намного больше внимания, чем другие. Любая задача, основанная на четких математических данных, решается значительно проще, чем та, для которой приходится прибегать к общим, абстрактным понятиям. К сожалению, именно такие проблемы часто оказываются слабым местом ИИ, позволяющим человеку без особого труда обыгрывать компьютер.

В качестве примера Марио Гримани указывает на одно общее затруднение, которое возникает при создании стратегий в реальном времени.

Человеку нетрудно распознать, легко ли будет защитить определенную область карты. Для компьютерного игрока это весьма сложная задача. С другой стороны, управляемый компьютером игрок гораздо лучше человека контролирует действия всех боевых единиц и легко просчитывает их характеристики.

Итак, не думает ли Марио, что с ростом популярности сетевых игр и игр по Интернету уменьшится потребность в разработке систем ИИ?

Да, многопользовательские игры развиваются с ошеломляющей скоростью. Одна из причин - доступность «быстрого» Интернета. Но это не означает, что сетевые игры заменят искусственный интеллект. Ведь это совершенно разные вещи. Лично я получаю огромное удовольствие от сетевых игр, в которые играю уже два года. В то же время меня интересуют и одиночные игры.

Тоби Симпсон (Toby Simpson), CyberLife Technology

Тоби Симпсон - художественный директор всех проектов серии Creatures, созданных студией CyberLife Technology, расположенной в Кембридже (Великобритания). В качестве продюсера игр Creatures 1-3 Тоби приходилось работать над созданием принципиально нового типа ИИ, до сих пор не встречавшегося в других игровых жанрах. Дело в том, что вся изюминка сериала Creatures заключена в обучении виртуальных питомцев и уходе за ними.

Вам когда-нибудь хотелось узнать, почему эти милые норны, главные герои Creatures, ведут себя совсем как живые, причем каждый имеет собственный характер и сходные с человеческими эмоции и желания? Все вопросы к Тоби Симпсону, автору четырех заповедей, согласно которым «оживить» можно даже неодушевленные предметы.

Прежде всего освободитесь от стереотипного представления, будто ИИ - это некая отдельная сущность, которую кто-то специально программирует. Система ИИ, навешиваемая на игру в качестве таинственного «черного ящика», обычно очень поверхностна, полна ошибок и несогласованностей. Создание жизнеспособных систем для компьютерных игр требует совершенно иного подхода. И если бы меня попросили выделить самые важные моменты в этом деле, я, наверное, упомянул бы следующее...

Моделируйте, но не имитируйте

Создание модели и имитация - два совершенно разных подхода к проблеме. Имитируя, вы просто пытаетесь отразить внешний вид образца, тогда как модель претендует на то, чтобы воспроизводить принципиальную структуру и механизмы, лежащие в основе системы. И модели, и имитации имеют, по сути, одну и ту же задачу, но модель при этом обладает рядом определенных преимуществ.

• В цели имитирующих систем не входит задача создания собственного «интеллекта», или механизма самоуправления, ведь какая-либо логическая взаимосвязь параметров системы и ее внешнего поведения там отсутствует.

• Модели обеспечивают свободу выбора, поскольку они не являются абстрактным воспроизведением системы, а построены на основе глубокого понимания ее сути, т.е. на взгляде «изнутри». Имитации создаются на основе внешних представлений и в принципе не способны достичь полной достоверности.

• Модели имеют возможность расширения, их компоненты могут быть взаимозаменяемы. Можно разобрать модель и перестроить ее заново, чего никогда не удастся сделать с имитацией.

Занимайтесь структурой, а не поведением

Постарайтесь избавиться от привычки поверхностно подходить к проблемам. Вместо этого продумайте структуру программы, которая позволит вам добиться нужного поведения. Чтобы воспроизвести функциональность системы, вовсе не обязательно полностью понимать, как она работает! Представляя компьютер в виде некоторого набора отдельных механизмов, а не единого устройства обработки данных, вы уже делаете шаг в правильном направлении. Сегодня многие создают игровые движки со встроенными с самого начала «автономными агентами» (нужно отметить, что слово «агент» часто употребляется неправильно) - как расширение объектно-ориентированного подхода - а значит, переносят основное внимание с программы на данные. Такой сдвиг в сознании происходит везде, поскольку люди понимают, что создание сложных виртуальных миров развлекательной индустрии без изменения подхода практически невозможно.

Природа - великий подсказчик

Живой мозг до сих пор является самым потрясающим вычислительным устройством на нашей планете. Его способность адаптироваться к собственному уникальному набору задач, которые он сам себе и ставит, обобщать, моментально узнавать разницу между положительным и отрицательным никогда еще не была реализована в компьютере. Более того, разберите человека на составляющие, и вы увидите, как все просто: 10 триллионов простых клеток, построенных из 100 тысяч генов. Мы изучили строение клеток, но так и не можем понять, почему, упорядоченные определенным образом, они образуют живое разумное существо. Это самый сложный из известных нам процессов: 10 триллионов простых «агентов», действуя совместно, приводят к появлению сознания. При этом отсутствует центральная управляющая клетка. Нет никакой «главной программы».

Это способно многому научить, ведь если мы можем смоделировать, к примеру, мост или танк, то что нам мешает взять за основу строительные блоки биологического происхождения и конструировать из них искусственные организмы? Если вы хотите иметь в непротиворечивом виртуальном мире правдоподобную искусственную личность, то только биологические процессы и структуры могут управлять такой сложной системой. В отличие от матери Природы у нас нет трех с половиной миллиардов лет для исследования и подгонки инструментальной программы, которая позволит заново изобрести колесо, и без того прекрасно работающее.

В играх серии Creatures система ИИ моделирует реальные биологические законы. Эти миловидные существа, норны, могут думать и самостоятельно обучаться, а если понадобится, могут даже обратиться к вам со своими нуждами и желаниями. (Приводится с разрешения компании CyberLife Technologies, Inc.)

Будьте профессионалом

Невозможно разработать профессиональное программное обеспечение без соответствующей профессиональной практики! Самые изощренные технологии не спасут вашу душу, если ваша работа плохо организована или никакой организации вообще нет. Будьте профессионалом! Если у вас нет системы контроля качества, создайте ее. Продумайте все: планирование, тестирование модулей, эффективность работ и надлежащую документацию. Придерживайтесь графика и не пытайтесь срезать углы - плохо выполненная работа обязательно скажется потом!

Чтобы больше узнать о «кибербиологии» Тоби Симпсона и особенностях применения ИИ в продуктах Creatures, посетите следующие вебсайты: www.cyberlife.co.uk, www.creatures.co.uk, www.creatures2.com, www.cyberbiology.org.

Скотт Орр (Scott Orr), EA Sports

Исполнительный продюсер компании EA Sports Скотт Орр не только способствовал выходу в свет серии футбольных игр Madden, но и курировал разработку других популярных лицензионных игр компании, например NHL Hockey, Andretti Racing, NASCAR Racing, NCAA College Football, March Madness и Knockout Kings. «Гуру» в области создания искусственного интеллекта, Скотт Орр не раз и не два упоминался в процессе работы над этой главой.

Реализм

«Прежде всего, - отмечает Скотт, - искусственный интеллект должен быть реалистичным».

Я подразумеваю под этим следующее: компьютерные игроки должны действовать и реагировать на происходящее так же, как действовали бы, оказавшись на их месте, живые люди. Вот почему во всех играх компании EA Sports у игроков есть рейтинги, определяющие их понимание обстановки на поле, быстроту действий, умение бросать или ловить. Кроме того, мы часто пользуемся советами профессиональных спортсменов и тренеров, которые помогают нам добиться реалистичности. Затрудняюсь сказать, сколько раз Джон Мадден (John Madden) смотрел заложенную нами в программу схему игры, всякий раз подбегая к доске, чтобы показать, как она должна выглядеть в действительности.

Скотт Орр убежден: игры EA Sports потому и вне конкуренции, что всегда архивнимательны к деталям. Ну что ж, хорошо. А если у разработчика нет денег или связей, чтобы привлечь в консультанты самого Джона Маддена или других профессиональных спортсменов? Выполнение следующих двух советов Скотта не потребует огромных затрат.

Реализм или увлекательность?

«Не забывайте соблюдать равновесие между реалистичностью игры и удовольствием от нее», - советует Скотт Орр.

Искусственный интеллект развился до такой степени, что при желании можно было бы сделать из компьютера суперчемпиона. Но вы уверены, что это именно то, чего ждут игроки и издатели (которые неминуемо начнут терять покупателей)? Многие разработчики прибегают к маленьким хитростям, чтобы позволить компьютеру на равных соревноваться с играющим. Это может заключаться и в предугадывании вашей стратегии, и в более быстром движении персонажей, за которых играет компьютер. Однако в играх компании ЕА Sports такого рода «жульничество» вам никогда не встретится.

Чем проще, тем лучше

Искусственный интеллект должен быть простым с точки зрения программирования. Скотт Орр считает: «Чем больше вычислений вы используете, тем сильнее загружен процессор». Как это влияет на игру?

Это может снизить частоту кадров, что, конечно, скажется на игре. Используйте подстановочные таблицы для хранения упорядоченных данных и ускорения вычислений. Чем выше скорость вычислений, тем сообразительнее будет искусственный интеллект.

Насколько, по сравнению с другими жанрами, трудно программировать ИИ для спортивной игры? «И труднее, и проще...» И вот почему:

С одной стороны, поскольку наши программы строятся на основе известных правил, нам проще решить, что же, собственно, нужно делать. С другой стороны, покупатели тоже знакомы с тем, как этот вид спорта выглядит в реальности, и поэтому уровень их ожиданий повышен. Нельзя махнуть рукой на поведение компьютерного игрока только потому, что вам не удается добиться точности в его действиях. Если что-то происходит в реальной игре, это должно присутствовать и в компьютерной, иначе пользователь быстро решит, что его в чем-то обделили. Мощность современных ПК вполне позволяет создавать достаточно сложный интеллект. Просто диву даешься, сравнивая то, что вытворяют компьютерные игроки теперь (речь об игровой тактике и согласованности действий), с тем, что они могли пять лет назад. И все это непрерывно совершенствуется, ведь мы разрабатываем игры для все более мощных машин и закладываем в них опыт, полученный нами в то время, когда мы создавали предыдущие игры.

Мы напомнили Скотту, что наша книга планируется как «библия» для начинающего разработчика, мечтающего, быть может, программировать ИИ для условно-бесплатных и бесплатных игр, а может, и для полноценных коммерческих продуктов. Когда Скотта Орра попросили дать какой-нибудь совет по программированию ИИ на языке Си++, он ответил так:

Мастерство приходит с опытом. Используйте разные подходы и смотрите на результаты. В конце концов, у вас получится что-нибудь, что будет работать лучше того, с чего вы начинали. Создайте библиотеку стандартных подпрограмм, которые вы часто используете. После этого (будем надеяться, что собранные в вашей библиотеке программы окажутся эффективными и экономичными) вы сможете гораздо успешнее пользоваться предыдущими наработками. Кроме того, не забывайте о выгоде использования подстановочных таблиц. Это уменьшает необходимый объем вычислений, ускоряет обновление экрана и сам процесс игры.

Марк Обейнел (Marc Aubanel), ЕА Sports

Познакомьтесь с еще одним сотрудником ЕА Sports: Марк Обейнел, продюсер прекрасно раскупаемых и всемирно известных футбольных игр серии FIFA (включая игры World Cup).

Марк считает, что для командных спортивных игр приходится программировать довольно сложные системы искусственного интеллекта, ведь компьютер одновременно имеет дело с несколькими персонажами. «Люди обладают невероятной интуицией, они чувствуют, как должно выполняться то или иное действие, - говорит Марк. - У компьютера такого чувства нет, поэтому необходимо научить его моделировать интуицию». По словам Марка, сложнее всего программировать ИИ для бейсбола. Этому есть несколько причин.

Дело в том, что у пользователя есть подсознательное представление о том, что должен делать игрок. Если запрограммированные в ИИ действия отличаются от этого представления, считайте свою работу неудовлетворительной. Допустим, игрок, находящийся на дальней стороне поля, ловит мяч слева. Что он предпримет дальше? Бросит мяч в «дом»? На вторую базу? На третью? Не будет бросать вообще? Как предусмотреть все эти варианты при программировании? Ведь во внимание должны быть приняты десятки факторов: сколько людей находится на каждой базе, сколько аутов на счету команды и так далее...

«В футболе, - считает Марк Обейнел, - все основано на форме, пространстве и подчиненности единой цели». Марк признает, что без проблем не обходится и здесь, однако «футбольный» ИИ моделировать несколько легче, чем «бейсбольный».

Один из описанных Марком способов настройки системы ИИ в играх серии FIFA (например FIFA '99), состоит в том, что игрок бьет по воротам с вратарем, которым управляет компьютер. При этом подсчитывается: а) количество забитых мячей, которые должны были быть взяты, б) количество взятых мячей, которые должны были попасть в ворота. После тщательного анализа данных в алгоритм вводится наиболее реалистичное среднее значение.

Еще одна цель программиста - попытаться научить компьютерных игроков чувствовать пространство игрового поля. Марк утверждает, что это серьезная проблема:

Расставить футболистов на поле нетрудно. Гораздо труднее сделать так, чтобы игрок «осознавал», зачем его поставили на конкретную позицию, когда он должен оставаться на месте и в каких случаях может это место покидать, чтобы он умел правильно выбирать тактику игры и так далее. Одним словом, необходимо привить ему «чувство пространства».

Дополнительная задача для системы ИИ - компенсация потери игрока (в случае его удаления). «Игроки должны согласовано изменить свое расположение, чтобы «прикрыть» отсутствующего», - говорит Марк.

На этих экранах показано, каким образом Марк Обейнел и его сотрудники тестируют ИИ для серии игр FIFA. Обратите внимание на команды для каждого из игроков: «стремиться к мячу», «атаковать», «обороняться» и «пасовать». Номера обозначают позиции игроков на координатной сетке (поле). (Приводится с разрешения компании Electronic Arts, Inc.)

И еще совет: лучше всего создавать игровой ИИ в соответствующей тестовой среде. О чем идет речь?

Работая над искусственным интеллектом для игр FIFA, мы не использовали ни звуковых эффектов, ни графических «красивостей», - просто каркасные фигурки на плоском зеленом поле. Таким образом исключается путаница. Кроме того, на экран выводились разноцветные стрелки и линии, исходящие от игроков, которые отражали все решения ИИ при передаче мяча, определении траектории движения и т.п., - это сильно облегчало отладку программы. Не будь этого, ошибки ИИ мог распознать только программист. Словом, получилась очень эффективная и «демократичная» среда для тестирования игры, позволившая нам проводить отладку безостановочно.

«Главное - не путать реализм и интересность», - говорит Марк.

Хорошая система может выглядеть совершенно реальной, но на самом деле это далеко не так, и делается это нарочно, дабы игра стала лучше. Мы чаще нарушаем правила реального мира, чем следуем им. Например, настоящему футболисту требуется примерно 18 секунд, чтобы пробежать от одного края поля до другого; в играх FIFA это можно сделать в два раза быстрее, потому что 18 секунд для виртуального футбола - это слишком долго.

Вы еще встретитесь с Марком в главе 12, где он обсуждает интерфейс пользователя в спортивных играх.

Джей Уилсон (Jay Wilson), Monolith Productions

Джей Уилсон, ведущий дизайнер уровней игр Blood и Blood: Plasma Pak, а также руководитель проекта Blood 2: The Chosen, считает, что создание ИИ - один из самых важных этапов работы над 3D-шутерами.

По его убеждению, в индустрии игровых программ достигнут значительный прогресс в разработке ИИ. В качестве «передовиков» он называет игры Half-Life, Unreal и StarCraft. Тем не менее Джей согласен, что далеко не каждому нравятся сетевые игры, и говорит, что его отец, к примеру, играет в компьютерные игры, чтобы отдохнуть, а не посоревноваться (что предлагается в большинстве многопользовательских игр).

Что касается ИИ для шутеров от первого лица, Джей говорит, что персонажи игры обычно воспроизводят не реальных людей, а скорее виртуальных противников из сетевой битвы в дефматч-режиме. А именно:

Компьютерные персонажи современных шутеров, наделенных продвинутым ИИ, играют как боты, а не реальные люди. Увы, лично мне хочется, чтобы соперничающие со мной «железные мозги» вели себя, подобно живым людям: бежали в укрытие, роняли оружие, стреляли и промахивались и так далее.

Любителям веб-серфинга обязательно следует заглянуть на знаменитый веб-сайт www.cris.com/-swoodcoc/ai.html, посвященный искусственному интеллекту для компьютерных игр. На странице Game AI проблема создания ИИ обсуждается на примере ряда новых и классических игр для ПК. Кроме того, здесь есть раздел со множеством ссылок на другие веб-сайты по данному вопросу. Не проходите мимо!

Джею Уилсону хочется, чтобы враги в шутерах действовали, как люди, и время от времени допускали ошибки, а не были бы идеальными ботами из дефматч-режима. Внимание: враг прячется за стойкой (скриншот из игры Blood 2)! (Приводится с разрешения Monolith Productions, Inc.)


Игровая графика

Глава 10

Игровая графика

Создание графики, художественное оформление игры - один из важнейших моментов процесса разработки. На это уходит львиная доля бюджета игры, а сама графика в значительной степени определяет то, что называется «атмосферой игры». Кроме того, хорошая графика - это еще и одно из условий успешных продаж: вспомните броскую рекламу в журналах, построенную на реальной внутриигровой графике, скриншоты в Интернете и на коробках с играми.

Вообще говоря, понятие «игровая графика» включает в себя так называемый концепт-арт, то есть эскизы и наброски, во многом определяющие то, как игра будет выглядеть, и собственно компьютерную - внутриигровую - графику. Как правило, художники, занимающиеся эскизами, работают в тесном сотрудничестве с дизайнерами игры. Они помогают конкретизировать замысел, создавая наброски героев и декораций. Иногда при этом выполняется и трехмерное моделирование. Далее в дело вступают компьютерные художники, непосредственно занимающиеся созданием персонажей (точнее говоря, текстурами как для двухмерных спрайтов, так и для полигонов, из которых состоят 3D-объекты) и прорисовку задних планов (так называемого окружения), и художники-аниматоры (о них речь пойдет в следующей главе). В некоторых компаниях на помощь к ним приходят еще и специалисты, отвечающие за встраивание графики в движок игры.

Полтора десятка художников, работающих в самых разнообразных игровых жанрах, делятся в этой главе своим опытом создания игровой графики, советуют, какими инструментами лучше пользоваться, и рассказывают, как найти свое место в индустрии игр.

Марк Бернал (Mark Bernal), Bungle Software

Радующей глаз графикой игр Marathon 2, Myth: The Fallen Lords и Myth 2: Soulblighter мы обязаны Марку Берналу, ведущему художнику и художественному директору этих замечательных проектов (как для ПК, так и для «Макинтоша»), и, конечно же, его двенадцати коллегам, работающим в компании Bungie Software (включая отделение на западном побережье США).

Марк начинает разговор с обсуждения самых важных, по его мнению, моментов, на которые стоит обратить внимание начинающим художникам.

Ваши возможности не безграничны

«Разберитесь с ограничениями, которые игровой движок накладывает на разрешение спрайтов и текстур, на цветовые палитры, а также оцените их важность по отношению к другим спрайтам и текстурам», - советует Марк Бернал. Он приводит следующие примеры:

Видеоплаты на чипах 3dfx не поддерживают текстуры размером более 256x256 пикселей (сегодня это уже не так: чипсет Voodoo 4 умеет работать с текстурами размером 2048x2048 пикселей. - Примеч. ред.). В некоторых проектах используется одна общая 256-цветная палитра для всей игры, в других - своя палитра для каждого отдельного персонажа. Важно также правильно выбрать, какие элементы игры должны иметь большее разрешение, а какие - меньшее. Здесь решение зависит от важности элемента и его места в игре.

Программное обеспечение - это еще не все

«Самое главное, - подчеркивает Марк, - это художественное мастерство и организаторские способности».

Чтобы стать в нашей индустрии хорошим художником, недостаточно умения пользоваться такими программами, как Adobe Photoshop и Autodesk 3D Studio MAX. Программы никогда не будут рисовать за вас. Объем используемых в играх ресурсов (спрайтов, моделей, звуков и т.д.) увеличивается с выходом каждой новой игры, поэтому вам потребуется умение систематизировать создаваемую графику и правильно распределять рабочее время.

Работа в команде

«Над компьютерной игрой одновременно трудятся несколько человек, и каждому приходится полагаться на других, - говорит Марк Бернал. - Вот почему вы не сможете работать, отгородившись от остальных». Далее он поясняет эту мысль:

Налаженное взаимодействие между членами команды значительно облегчает разработку. Дизайнерам требуется, чтобы художники нарисовали разработанные ими уровни. Программистам необходимо, чтобы графика имела строго заданный формат, в противном случае в игре неизбежны ошибки. И так далее.

Марк говорит о разнице в создании двухмерных и трехмерных игровых объектов.

Современные игры отображают объекты двумя способами: в виде двухмерных спрайтов, либо в виде трехмерных полигонов (многоугольников). 2D-спрайты (персонажи, здания и т.п.) либо рисуются непосредственно в графическом редакторе, либо сначала с помощью соответствующего ПО создается трехмерный объект, а затем выполняется его визуализация (модель используется как двухмерный спрайт). Трехмерные объекты (персонажи, здания и т.п.) создаются в виде набора полигонов с помощью 3D-программы, а затем все данные объекта экспортируются из этой программы в игру. Текстуры, накладываемые на трехмерный объект, выполняются в Photoshop или любом другом графическом приложении.

Слева - модель монстра Миркридиа из Myth If: Soulblighter в виде проволочного каркаса. Она была создана при помощи Power Animator (Alias). Справа - готовая трехмерная модель того же персонажа. Правда, в игре она станет двухмерным спрайтом... (Приводится с разрешения Bungie Software Products Corp.)

Изображая персонаж в виде спрайта, вы должны прорисовать каждое его положение для тех движений, которые будут анимироваться. При создании 3D-персонажа достаточно нарисовать его всего один раз, а затем приступать к анимации. Разработка трехмерной модели и анимация ее движений отнимают гораздо меньше времени, нежели прорисовка каждого кадра 2D-спрайта. Впрочем, здесь нужно заметить, что зачастую время, сэкономленное благодаря использованию трехмерной модели, тратится на ее тестирование, а также на улучшение анимации, текстур и общей структуры модели.

Насколько сложно создавать трехмерную графику для таких игр, как Myth: The Fallen Lords или Myth II: Soulblighter?

Имея навык, нарисовать текстуру несложно, хотя всегда приходится искать компромисс между детализацией и разрешающей способностью. Скажем, у вас может появиться желание прорисовать каждый камешек мощеной дороги, но обычно разрешение ландшафтной текстуры не столь высоко, чтобы передать такие подробности (маленькие камни имели бы размер в один пиксель или еще меньше, сливаясь с окружающей землей, и вся ваша работа пошла бы насмарку).

Скриншот из Myth II: Soulblighter демонстрирует, насколько детально проработаны в этой игре «декорации». К сожалению, иллюстрации в книге не цветные, но, поверьте, как трава, так и тропинка представляют собой «смесь» нескольких текстур, что существенно прибавляет игре реализма. (Приводится с разрешения Bungie Software Products Corp.)

Задача текстуры, изображающей ландшафт, - передача игроку соответствующей информации; в то же время она не должна выпадать из стиля, в котором выполнены остальные игровые текстуры. Так, вершины отвесных скал должны по виду отличаться от склонов, чтобы у игрока создавалось впечатление труднопроходимой местности; тропинки и дороги являются ориентирами для навигации; цвета текстур, наложенных на те или иные объекты, должны дополнять друг друга и указывать на расположение источника освещения.

Марк Бернал перечисляет инструменты, с помощью которых в Bungie создается столь симпатичная игровая графика для обеих платформ - ПК и «Макинтоша» («...наряду с нашим собственным ПО, которое мы назвали "Страх, ненависть и азарт"»):

• Photoshop (Adobe);

• PowerAnimator и StudioPaint (SGI);

• 3D Studio MAX 2.5 и Character Studio (Autodesk - Kinetix);

• MeshPaint 3D (плагин для 3D Studio MAX, разработанный Positron Publishing).

Кроме того, добавляет Марк, хотя это и не обязательно, не помешает знакомство с любыми из перечисленных ниже приложений:

• LightWave (NewTek);

• trueSpace (Caligari);

• StudioPro (Strata);

• Infini-D (MetaCreations);

• Maya (SGI);

• SOFTIMAGE (Softimage Inc.);

• Electric Image (Electric Image Inc.);

• form*Z (auto*des*sys, Inc.);

• DeBabelizer (Equilibrium);

• Premiere, After Effects и Illustrator (Adobe);

• Painter (разработано Fractal Design, в настоящее время собственность MetaCreations);

• FreeHand (Macromedia).

Прощаясь с Марком, мы интересуемся его планами на будущее. Они таковы: студия на западном побережье США работает сейчас над Oni, трехмерной футуристической экшен-игрой в стиле «аниме», а сам Марк Бернал вовсю трудится над не менее многообещающим проектом Halo, научно-фантастическим 3D-шутером, чей выпуск запланирован на середину 2000 года.

Джошуа Стауб (Joshua Staub), Cyan

Джошуа Стауб - художественный директор отдела компьютерной графики студии Cyan, выпустившей классический квест Myst, одну из самых продаваемых игр за всю историю индустрии. Кроме того, он - один из авторов игры Riven, продолжения знаменитого Myst. Джошуа считает, что начинающие художники, приступающие к работе над играми, должны твердо придерживаться следующих правил.

Логика мироздания

По мнению Джошуа Стауба, на самых ранних этапах проекта важнее всего придерживаться логики создаваемого мира. Работая над игровым окружением, убедитесь, что придуманные вами персонажи находятся с ним в согласии. Какую одежду должны носить люди, живущие в подобной среде? Из чего должны быть построены дома? Из дерева, камня, металла? Тщательно проработайте все детали проекта, постарайтесь наделить свой мир культурой и историей.

Оригинальное фоновое освещение

Простейшая вещь, которую вы можете сделать для достижения реализма сцены - это отказаться от стандартного фонового освещения. Обратите на это особое внимание. При выключении фоновой подсветки вся сцена становится черной; ваша задача - привнести сюда свои источники света. Большинство программ по умолчанию устанавливают яркость фона в 5 или 10 единиц (иногда это определяется самой сценой, иногда материалом, из которого выполнены объекты), чтобы ни один участок не оставался неосвещенным. Даже если объект находится в полной темноте, он все равно будет слегка светиться, что, конечно же, снижает реализм сцены. Отказ от подсветки предоставляет вам полный контроль над освещением; все тени будут черными, пока вы не прибавите света, чтобы их «подсветить». Вы сможете вручную создать собственную фоновую или отраженную подсветку, что намного полезней, нежели отдавать эту работу программе. И в самом деле, нет ничего плохого в том, что угол комнаты останется совершенно неосвещенным - это только добавит игре интригу и настроение.

Наложение текстур

Текстуры - наиболее важный элемент игровой графики, непосредственно влияющий на восприятие игрока. Лично я, работая над любой моделью, на каждую минуту, уходящую на моделирование, трачу по крайней мере три на создание текстуры для нее. Этому есть несколько причин. Для начала, применение соответствующих текстур куда эффективнее собственно воссоздания настоящей геометрии игровой среды. Если вы способны воспроизвести скошенные края, бугристую поверхность или замысловатый узор, используя текстуру, честь вам и хвала: это значит, что ресурсы компьютера будут отвлечены на более полезные для игры цели. Этот принцип важен для игр с предварительно прорисованными сценами (Myst, Riven); но еще важнее придерживаться его в играх, чья графика визуализируется в реальном времени (здесь, впрочем, значительно меньше геометрии, которую нужно воссоздавать). Результат один - улучшение восприятия! Самый хороший способ получить реалистично выглядящую текстуру - найти ее образ в реальном мире. Поэтому не расставайтесь с камерой: фотографируйте кору деревьев, камни, ржавые металлические детали, различные архитектурные элементы и т.д. - все это пойдет затем в дело при создании текстур. У нас в Cyan есть собственная библиотека исходных текстур с сотнями образцов и материалов. Она постоянно используется и непрерывно пополняется.

А что делает художник в Cyan, найдя все необходимое в библиотеке текстур? Какой инструментарий использует?

Сейчас самое благоприятное время для работы с компьютерной графикой, особенно трехмерной. Непосредственно перед запуском в производство игры Riven мы тестировали различные аппаратные средства и пакеты программного обеспечения и поняли, что единственный способ получить необходимые скорость и качество графики - это пересесть с испытанных «Макинтошей» на мощные рабочие станции Silicon Graphics, работающие с лучшим на сегодня пакетом трехмерной графики, анимации и вывода SOFTIMAGE. Сегодня, когда быстродействие персональных компьютеров достигло 1000 МГц, когда появились программы, подобные 3D Studio MAX (Kinetix) и StudioPro (Strata), «играть во взрослые игры» можно при вполне разумных вложениях порядка $5000. Добавьте сюда Photoshop (отраслевой стандарт для работы с фотографиями и текстурами) и, возможно, Painter - и вы полностью экипированы для того, чтобы приступить к созданию фантастической, но реалистичной графики.

Текстура для кожи кресла, приведенного на левой иллюстрации, была создана на основе фотографии чьей-то руки, поскольку иного снимка, хорошо передающего структуру настоящей кожи, просто не нашлось. Правда, неплохо выглядит? Справа - один из ранних вариантов пресса «Firemarble» для конечного эпизода игры Riven. Шестеренки в окончательную версию не попали, но обратите внимание на проработку деталей, создающих впечатление древности механизма. (Приводится с разрешения компании Cyan, Inc.)

Если у вас, начинающего компьютерного художника, неважно с финансами, исключите пакет SOFTIMAGE из списка инструментов. Последняя версия SOFTIMAGE 3D (v.3.9) продается по цене примерно от 10000 до 15000 долларов США Для работы с ней необходима рабочая станция Silicon Graphics или мощный ПК на базе Pentium (с операционной системой Windows NT). Официальный веб-сайт продукта, www.softimage.com, содержит внушительный архив технических приемов работы с пакетом и графики, которую можно использовать с данным программным средством.

Брайс Кокрейн (Bryce Cochrane), ЕА Sports

29-летний Брайс Кокрейн является ведущим художником завоевавшей немало наград серии игр NHL, издаваемой канадским отделением компании Electronic Arts. Вот его советы в помощь начинающим игровым художникам.

Вы не одни

«Никогда не следует забывать, что вы работаете в команде, - говорит Брайс, - члены которой не всегда ладят между собой».

Вам придется работать с программистами, продюсерами, менеджерами и множеством других специалистов, объединенных общим делом - созданием игры. Будьте готовы отстаивать идеи, которые считаете удачными, но не забывайте, что вам предстоит общаться с этими людьми изо дня в день, так что не переходите на личности.

Держите марку

Брайс Кокрейн советует не забывать о классических художественных навыках (графика, живопись, скульптура).

Когда я просматриваю чьи-либо работы, то первым делом обращаю внимание на тех художников, которые умеют рисовать на бумаге, а не только щелкать кнопками в Photoshop и редактировать трехмерные модели. Я уверен, что могу за пару дней научить любого талантливого художника рисовать при помощи компьютера, а вот на то, чтобы сделать из человека художника, обычно уходят годы.

Будьте готовы к критике

«Когда дело доходит до критики, - говорит Брайс, - люди могут быть довольно жестокими, так что отнеситесь к их замечаниям адекватно и двигайтесь дальше».

Будьте готовы услышать неприятные слова от коллег-художников и программистов. Но самая резкая критика - это удел игроков и журналистов. Их не интересует, что на создание модели вам дали всего один день, или то, что ваш компьютер постоянно сбоил. Главное для них - конечный результат, насколько удалась работа. Помнится, однажды журналисты нашли такие слова об одной моей игре: «она не была выпущена, а просто удрала от разработчика», и далее: «играть в эту игру не забавнее, чем пинать дохлую кобылу». Словом, обязательно учитесь на своих ошибках.

Брайс говорит, что использует в работе как стандартные графические приложения, так и внутренние пакеты компании...

В Electronic Arts имеется множество собственных инструментальных средств для создания рисунков и их экспорта в игру, однако чаще всего используются несколько программ. Так, с 3D-графикой лучше всего работать с помощью Maya/Alias, Power Animator и 3D Studio MAX. Это довольно мощные пакеты, в которых я, впрочем, нуждаюсь далеко не всегда, поскольку в моих моделях не бывает больше 100-1000 полигонов. Тысячу полигонов способен «переработать» любой трехмерный пакет; при этом замечу, что не надо излишне усложнять - вы делаете игру, а не кинофильм. Ну а для 2D-графики используются Photoshop, Illustrator, After Effects и Painter, и для работы с ними справедливы те же советы, что и для трехмерной графики. Относитесь ко всему проще, не тратьте впустую время, создавая графику в самом высоком разрешении, - для игр куда важнее, чтобы объекты хорошо выглядели при использовании минимальных средств.

Брайс Кокрейн из ЕА Sports советует стремиться к простоте и не тратить впустую свое время на работу в сверхвысоком разрешении. Почему? Все просто: детально выполненная вратарская фуфайка имеет размер 600x800 пикселей, но когда текстура будет перенесена в игру, ее размер сократится до 120x160 пикселей. (Приводится с разрешения компании ЕА Sports.)

Николас Дж. Кориа (Nicholas J. Corea), Electronic Arts

Ник Кориа работает в компании Electronic Arts, он художник и специалист по компьютерной графике. Его рука коснулась множества игр всемирно известной серии Jane's Combat Simulations, в том числе US Navy Fighters '97 и WWII Fighters, где он был ведущим художником. Ник встретился с нами, чтобы поговорить о работе игрового художника, о необходимом инструментарии и о том, как занять свое место в игровой индустрии.

Готовьтесь к неожиданностям

Вы садитесь за графику для новой игры, думая, что знаете, как ее делать и сколько времени это займет, но обстоятельства могут сложиться самым неожиданным образом! Предположим, вам необходимо создать шесть спортивных автомобилей для очередной трехмерной гоночной игры. Работа знакомая: для предыдущей игры вы сделали 10 машин, на каждую ушло 15 дней (пять дней на 3D-модель, восемь на текстуру и два дня на сборку и исправления). Но! Вашего босса не устраивают старые модели, отныне ему надо «больше полигонов, больше жизни в модели и больше текстуры». Не беда, вы опытный компьютерный художник, вы и так знаете, что и как предстоит делать, и даже готовы предложить для новых задач лучшие решения. Исходя из опыта, вы выделяете на создание каждой машины те же 15 дней.

А потом... потом к вашему удивлению вдруг обнаруживается, что требование «больше полигонов» отнюдь не упростило определение формы - потребовался более аккуратный подход к моделированию (итого по четыре дополнительных дня на машину). «Больше жизни» вылилось в появление у автомобиля дверей. На то, чтобы двери должным образом открывались и закрывались, пришлось потратить лишних восемь дней. В конечном счете, вы добавили объект «закрытая дверь», который исчезает, когда дверь открывается, и объект «открытая дверь», прячущийся, когда дверь закрыта (еще по два дня на машину). Кроме того, в новой версии игры появились деформации от удара. При этом во внутриигровой 3D-системе применяется простой Z-буфер (массив, в котором хранится информация о глубине расположения точки на экране. Иными словами, Z-буфер отвечает за разрешение сцен по «оси глубины». - Примеч. ред.), в результате чего шины и крылья машин весьма несимпатично проникают друг в друга. Что делать? Надо идти к программистам, предлагающим новую, ни на что не похожую группировку этих объектов (крыла и шины), которую нужно применить ко всем автомобилям, включая те, что уже сделаны (а это плюс 10 дней). Наконец, «больше текстуры» означает, что отныне текстуру автомобилей приходится хранить не в одной, а в двух страницах памяти, поскольку автомобиль теперь имеет длину 500 пикселей, а максимальный размер текстуры - 256x256. «Тетрис с текстурами» (вырезание и перекомпоновка кусочков для максимально эффективного заполнения памяти, отведенной под хранение общей текстуры) существенно осложняется (плюс пара дней на каждое авто!).

Кроме того, начальник не желает, чтобы для обеих сторон машины использовалась одна и та же текстура. «Все замечательно, когда машина новая, - говорит он, - но когда бока помяты, они не могут выглядеть одинаково». Это так, но памяти, отведенной под текстуры, для таких новшеств не хватает, поэтому вам приходится сжимать текстуры и садиться за повторную партию в «тетрис» с тремя уже завершенными машинами (плюс 7 дней). Затем к списку заданий добавляется прорисовка дополнительных сторон (еще день на каждую машину). Вам остается лишь поблагодарить босса за столь «своевременную» постановку задачи.

Таким образом, задача, на выполнение которой изначально отводилось 90 дней, разрослась до 150 с лишним. Три незапланированных человеко-месяца! Хотите верьте, хотите нет, но подобное происходит сплошь и рядом. Некоторые из возникших затруднений, конечно, можно было предусмотреть, а другие - никак. (По-хорошему, вы могли догадаться о правилах вроде «больше полигонов = больше времени» и «больше текстуры = деление страниц памяти».)

Короче говоря, планируя работы с компьютерной графикой, постарайтесь предусмотреть все и вся. Создайте детальный перечень работ по каждому направлению, которое приходит в голову. Не забывайте и о времени на сборку моделей и экспорт графики в игру. После чего добавьте еще 20-40% на непредвиденные потери времени. Чем непривычней задача, тем больше времени следует отвести под «сюрпризы».

Научитесь наступать на горло собственной песне

Ник предупреждает: «Никто не желает этого слышать, но тем не менее компьютерные игры создаются для того, чтобы приносить деньги». К чему он клонит?

Наша индустрия во многом схожа с кинопроизводством. Некоммерческие фильмы обычно не окупаются. Создание игры ведется по жесткому графику, а конечный продукт обязан хорошо продаваться. Предлагаемые возможности и стоимость проекта перевешивают его художественную ценность.

Поясняя свою мысль, Ник предлагает следующий сценарий:

Предположим вы работаете над образами врагов для шутера от первого лица, который должен превзойти Quake XI. План предусматривает создание 20 различных, уже прорисованных в эскизах монстров для заполнения 10 уровней. Согласно графику, на каждого монстра отводится по 10 дней. Ваша «доля» - три монстра. Вы отдаете четыре дня на создание трехмерной 250-полигонной модели, пять дней на текстуру размером 256x256 пикселей и один день на сборку. Ваше первое творение - просто шедевр! Ужасный монстрище, покрытый чешуей, с огромной стальной булавой в лапе.

Ребята в восторге. Вы прорисовали монстра до мельчайших деталей, вплоть до капелек пота на лбу. Правда, вы потратили на это три лишних дня, но, разумеется, не напрасно! Второй злодей впечатляет еще больше. И вам уже не терпится увидеть игровые скриншоты с вашими монстрами в журнале Computer Gaming World. Но при всем том... вы уже на неделю отстаете от графика и даже получили от начальника нахлобучку. Впрочем, вы честно пообещали наверстать. Третье ваше творение - черепаха с гранатометом. Сделать ее в одном стиле с другими вашими персонажами - задача не из простых... Наконец, через 11 дней черепаха-убийца готова, при этом вам два раза пришлось сидеть в офисе до поздней ночи. А что у других членов команды? Программисты собрали работающий прототип игры и созвали всех посмотреть на него. И что вы видите? Ваши монстры выглядят в игре просто потрясающе, но... на них нет ни одной дополнительной детали, что отняли у вас столько времени и сил! К тому же в финальную версию игры не попал один из ваших злодеев...

Работайте быстрее!

Старайтесь укладываться в отведенное время, а лучше - делайте работу быстрее. Будьте уверены, ваши коллеги - художественный редактор, программист, продюсер и дизайнер игры - оценят это должным образом. При необходимости всегда можно «добавить оборотов». Не думайте о том, что вы работаете «на продажу». Хороший художник способен выполнить огромную работу за короткое время, и он знает, в каких случаях можно идти на компромиссы. Его работа, возможно, будет не идеальна, но она будет соответствовать требованиям производства. Можете считать это вызовом: насколько хорошо вы сумеете выполнить работу, будучи ограниченным во времени и средствах? Это очень ценное умение. Любая компания может потратить уйму денег на создание самой красивой на свете графики, но окупятся ли ее затраты?

Ник Кориа советует художникам научиться плодотворно работать в условиях нехватки времени, финансов и ограничений, накладываемых программной средой. (Приводится с разрешения Jane's Combat Simulations, Inc.)

Вероятно, многие обладатели симулятора Jane's WWII Fighters не раз любовались его превосходной графикой. Ниже Ник рассказывает о двухмерном и трехмерном инструментарии, который он использовал при создании этой игры.

Двухмерные инструменты

По словам Ника, общепринятым инструментом для создания изображений является мощный и гибкий Adobe Photoshop.

Постарайтесь как можно глубже изучить возможности этого пакета. Чем лучше вы будете знать эту программу, тем виртуозней сможете ее использовать. (Да, и не тратьте слишком много времени на фильтры эффектов, многие художники зачастую попадают от них в зависимость!) Photoshop использовался в WWII Fighters для создания текстур и почти всей остальной графики. Умение работать с Photoshop должно стоять в вашем резюме на первом месте.

DeBabelizer (производства Equilibrium) - распространенный инструмент для обработки изображений. Игровые дизайнеры обычно используют его для одновременной обработки большого количества изображений. Возможности пакетной обработки этой программы не имеют себе равных. В ней доступно поочередное применение методов сокращения палитры и фильтров. Набор изображений может быть сведен к некоей «суперпалитре», после чего все изображения отображаются на нее. Список полезных функций DeBabelizer можно продолжать бесконечно. Знание этого средства тоже украсит ваше резюме. В WWII Fighters DeBabelizer использовался для обработки текстур объектов и ландшафтов.

Fractal Design Painter (производства MetaCreations) - замечательный графический редактор. Он позволяет имитировать чернила, акварель, бумагу, мел, свет и массу других вещей. С ним можно «поиграть» в свое удовольствие, чтобы удивить результатом друзей. Искусные художники найдут, что с его помощью можно быстро создавать исключительно реалистичные текстуры. Планшет для рисования обязателен. Многие используют FD Painter для рисования, а затем экспортируют результаты в Photoshop - для подчистки и обработки пикселей.

Microsoft Paint (поставляется бесплатно в составе Windows 95/98) - отличный инструмент для желающих овладеть искусством рисования по точкам. Конечно, его набор инструментов ни в коей мере не сравним с имеющимся в Photoshop, но это прекрасное средство, если вы хотите ознакомиться с применением света в рисунках. Попробуйте загрузить пиктограмму или рисунок из игры и изменить их. Многие игровые дизайнеры в свое время начинали с одинаковых по простоте DPaint или Mac Paint. В любом случае, должен заметить, если вы талантливы - это сразу увидят.

Трехмерные инструменты

Николас считает 3D Studio MAX лучшей программой для моделирования, создания освещения и анимации.

Нельзя сказать, что эта программа лучшая во всех отношениях, но она довольно удобна с точки зрения универсальности. Сегодня 3D Studio MAX используется многими игровыми компаниями для создания высококачественной кинематики, трехмерных игровых объектов и пререндеренной спрайтовой графики. Это дорогой пакет, но если вам удастся «раздобыть» предыдущую версию программы, она послужит идеальным пособием для изучения работы с 3D-объектами. К тому же есть несколько неплохих книг с описанием этого продукта. 3D Studio MAX использовался в WWII Fighters для построения внутриигровых моделей.

Еще один превосходный инструмент - это LightWave 3D. В нем применена иная «теория» моделирования, очень мощная и гибкая. Многие художники считают эту программу отличным средством для визуализации и моделирования. В WWII Fighters мы использовали LightWave 3D для создания музейных моделей и изображений.

Начало вашей карьеры

Заключая свое интервью, Ник Кориа кратко останавливается на том, как художнику попасть в игровую индустрию. Отнеситесь с должным вниманием к его советам.

Обучаясь ремеслу компьютерного художника, выберите тему, которая вам по-настоящему интересна. Это значительно облегчит вашу задачу, поскольку изучение некоторых процессов может оказаться довольно утомительными. Кроме того, подлинный интерес к работе всегда позволяет обогатить ее дополнительными деталями.

Если вы только изучаете трехмерное моделирование, естественные формы могут оказаться для вас слишком сложными. Не стоит сразу браться за моделирование человека или животных, для начала лучше взять что-нибудь попроще. Имитация того, что вы увидели по телевизору или в кинотеатре (например космический корабль из Star Trek), - неплохое упражнение, но не стоит ограничиваться единственным сюжетом. Художественные редакторы просматривают множество демонстрационных роликов и эскизов, а многие начинающие художники выбирают одни и те же темы. Впрочем, поскольку компьютерная графика используется сейчас во многих телевизионных шоу и кинофильмах, телевидение стало неисчерпаемым источником образцов текстур, моделирования, световых и прочих эффектов.

Художественный редактор наверняка захочет увидеть не только примеры компьютерной графики. Его заинтересуют ваши карандашные наброски, фотографии, картины, скульптуры - в общем, все, что может продемонстрировать ваши профессиональные навыки. Большое внимание уделяется освещению, композиции, цветовым решениям, форме, интерпретации сюжета, деталям, манере исполнения, методике решения задач и достоверности.

Показывая готовую работу, не забудьте приложить к ней несколько предварительных вариантов, чтобы можно было оценить весь творческий процесс. Например, если вы создали фреску, представьте также карандашные наброски, композиции в цвете и фотографию с окончательным решением на стене. Демонстрируя видеоролик, не прокручивайте один и тот же сюжет несколько раз. Если ролик очень короткий, покажите его два раза с небольшой паузой. Если художественный редактор захочет посмотреть его еще раз, он перемотает ролик в начало. И еще: показывайте только лучшее. Если у вас есть 20 работ, но три из них не являются предметом вашей гордости, оставьте их дома. Это как раз тот случай, когда ложка дегтя испортит бочку меда. И не забывайте о времени! Если слишком затянуть показ, редактор может заскучать, а это хуже всего. Постарайтесь, чтобы демонстрация была краткой и эффектной. Пусть у редактора появится желание увидеть больше.

Хью Райли (Hugh Riley), Bethesda Softworks

Старший художник в компании Bethesda, Хью Райли за последние 13 лет участвовал в создании нескольких десятков игр для большинства моделей домашних ПК. Начинал с работы по контракту, а затем стал постоянным сотрудником компании. Хью говорит, что существуют три вещи, на которые должен обратить внимание начинающий художник.

• Экономия. Памяти всегда не хватает, особенно в приставках, поэтому постарайтесь добиваться максимального результата, работая с моделями с малым числом полигонов и с анимацией с низкой частотой кадров, а также научитесь создавать небольшие, но производящие хорошее впечатление текстуры.

• Понимание технологии. От вас будут ожидать, что вы привнесете свои идеи в процесс создания игры, но при этом ваша работа должна быть в рамках дизайн-проекта и согласовываться с движком игры. Если ваша графика окажется несовместимой с дизайном или программой, считайте, что вы потратили время впустую.

• Качество. В пределах имеющихся ограничений ваша работа должна быть лучшей из лучших.

Подробнее останавливаясь на первом пункте, Хью Райли отмечает, что чем больше полигонов содержит изображение персонажа, тем больше памяти он отнимет у игры. Почему? Чем больше персонажей находится на экране одновременно, тем ниже скорость вывода графики. Поэтому наш собеседник предлагает свести количество полигонов к минимуму всюду, где это возможно, что позволит более гибко управлять памятью.

То, что главный герой Redguard, последней игры Bethesda из ролевой серии The Elder Scrolls, выполнен с большей детализацией по сравнению с остальными персонажами, по словам Хью Райли, объясняется тем, что он постоянно находится «в кадре». Изображение Сайруса (так зовут главного героя) выполнено примерно из 550 полигонов - сравните с 350, ушедшими на гвардейцев, и около 380 для Лорда Ричтона, главного злодея Redguard.

Как минимизировать число полигонов? Хью Райли советует:

У каждой модели есть своя сетка (посмотрите на рисунок на следующей странице). Изменяемые части тела (лицо) выполнялись из треугольников, а статические (голова в целом) можно моделировать и с помощью прямоугольников.

Чтобы сэкономить память, в Redguard использовалась только одна модель гвардейца, но на нее накладывались три различные текстуры. В игре есть три женщины, носящие платья: проститутка, садовница и ювелир - все выполнены на основе одной модели. Равно как и 17 жителей острова, а еще одна модель стала базой для образов всех пиратов.

Далее Хью рассуждает о том, как проще всего устроиться художником в игровую компанию и чего следует ожидать.

Чтобы попасть в индустрию, не имея за плечами выпущенной игры, потребуется показать демонстрационный ролик. В Интернете можно найти множество веб-сайтов, содержащих советы относительно того, как лучше представить свою работу.

Обязательно умение работать с трехмерными приложениями, в особенности с 3D Studio MAX или SOFTIMAGE. Столь же важно знакомство с Photoshop и другими 2D-приложениями. Это заколдованный круг. Новичка не возьмут без доказательств знания одного или нескольких из этих пакетов, но все они очень дорого стоят и требуют немало усилий, чтобы овладеть ими. Если у вас нет доступа к этому ПО, возможно, лучшим выходом будет закончить институт.

Ну а получив место, будьте готовы к тому, что вам придется работать допоздна и быстро обучаться, но зато вы будете делать то, что любите.

Эти четыре рисунка иллюстрируют процесс создания и моделирования злобного Лорда Ричтона (игра Redguard). Рисунок вверху слева - первоначальный набросок, позднее он был детализирован (вверху справа). Проволочный каркас (внизу слева) - еще один этап создания персонажа до его раскраски и окончательного моделирования. Внизу справа вы видите Лорда Ричтона таким, каким он предстает в игре. (Приводится с разрешения компании Bethesda Softworks © 1999 Bethesda Softworks.)

А какая от всего этого выгода? Хью Райли отвечает так: «Не говоря уже о возможности продемонстрировать свое творчество широким массам, большинство людей в этом бизнесе, как минимум, хорошо обеспечены, а некоторые и вовсе - становятся суперзвездами».

Тед Бэкман (Ted Backman), Valve Software

Тед Бэкман - художник и аниматор в компании Valve Software. В течение двух лет он неустанно трудился над Half-Life, дебютной игрой Valve, вышедшей в конце 1998 года и ставшей во всех отношениях «первой»!

«Домашние компьютеры становятся все более мощными, а графика в играх все менее архаичной, а значит, все меньше зависящей от способа обработки данных», - говорит Тед. К счастью, развитие компьютерных технологий позволяет преодолеть многие ограничения, в том числе на объем информации, с которой можно работать. «Нам часто приходилось урезать цветовую палитру или использовать крайне низкое разрешение (а обычно и то и другое)», - жалуется Тед. В случае с Half-Life подобных проблем уже не было. Имея мощный графический движок, Тед Бэкман мог сосредоточиться на своих традиционных задачах и «не ломать голову над тем, как выполнить рисунок, используя лишь 16 или 32 цвета».

Итак, сбросив оковы технологии, наш собеседник смог: а) использовать в работе качественный справочный материал, б) позволить себе прислушиваться к обоснованной критике и в) вытерпеть все, чтобы довести дело до конца. Ниже Тед Бэкман кратко остановился на каждом из этих пунктов, подкрепляя их примерами из собственного опыта.

Прототипы

Это то, о чем многие художники почему-то забывают. Вспоминая работу над Half-Life, я могу привести немало случаев, когда мне нужно было просто сходить в библиотеку, вместо того чтобы ломать часами голову над поиском решения. Настоящий художник знает, что нельзя полагаться исключительно на фантазию. В качестве прообразов игровых объектов и персонажей сплошь и рядом приходится использовать реальные предметы. Так, при создании «быкокальмара» в поисках вдохновения я перелопатил множество источников. Чего я только не видел: от морских слизняков до ягуарьих шкур. Создавая изображение, вы общаетесь на языке зрительных образов; словарь этого языка - общедоступный набор изображений и знаний, известный каждому человеку. Поэтому, если пренебречь знакомыми всем ассоциациями, рискуешь оказаться непонятым. В случае «быкокальмара» окраска должна была подсказать большинству людей, что это животное ядовито. Желтые и черные метки - способ, который использует природа, чтобы сказать: «держись от меня подальше!»

Тед Бэкман раскрасил шкуру своего любимого «быкокальмара» желтыми и черными пятнами. Что означает это сочетание цветов? Конечно же, то, что хищник вооружен и очень опасен. (Приводится с разрешения компании Sierra Studios.)

Обоснованная критика

Критика - неотъемлемая часть традиционного искусства. Время от времени вы должны показывать неоконченную работу другу, чтобы он помог увидеть недочеты, которые вы могли пропустить. Скорее всего, в вашем произведении выделятся участки, которым вы будете придавать наибольшее значение, и, работая над этими областями, можно легко потерять общую перспективу. В этом случае роль критика - помочь вам заметить то, что вы упустили из виду. Постарайтесь как можно раньше получить первые критические отзывы и постоянно прибегайте к подобным проверкам в процессе работы - это только улучшит результат.

Настойчивость

Наконец, самое важное при работе над игровой графикой (как, впрочем, и любой другой) - это упорство, способность трудиться над проектом до тех пор, пока он не будет доведен до ума. Наберитесь терпения и закончите дело, причем не забывайте, что вам придется не раз все перекраивать: старайтесь работать в свободной, «исследовательской», манере. Например, когда вы начинаете создавать персонаж, сделайте множество набросков, чтобы зафиксировать интересные идеи. Затем упорядочите и переработайте их, всегда оставаясь готовым к изменению направления работы. Многие допускают ошибку, размышляя над конечным результатом, едва приступив к рисунку. Никогда нелишне напомнить: оставайтесь открытым для восприятия новых идей. Сделав множество рисунков, отбросьте их - и работайте дальше. Вдохновение обязательно посетит вас, как только будет готово к этому шагу. Не торопите его.

В Half-Life получились колоритные, запоминающиеся персонажи. Как они создавались? Какие инструментальные средства для этого использовались?

Чтобы создать нового монстра или героя, я работал с целым рядом программных продуктов: от двухмерных пакетов вроде Photoshop или Painter до инструментов трехмерного моделирования (3D Studio МАХ). В общем случае процесс выглядит примерно так: вы сканируете карандашные наброски в Painter и продолжаете работать над изображением, доводя фактуру и цвет до нужной кондиции. Кроме того, на этом этапе можно внести последние изменения в форму модели. Затем полученная цветная иллюстрация используется как основа для модели. Распечатайте ее и держите рядом с монитором.

Далее вы приступаете к созданию деталей, из которых, в конечном итоге, будет «собран» ваш персонаж. Для начала я использую плагин Clay Studio Pro (Digimation) для 3D Studio MAX, с помощью которого делаю предварительную модель мускулатуры для отдельных частей тела персонажа. Я всегда создаю персонаж по частям (или узлам, если это механизм). Если это человек, я рисую ногу отдельно от туловища, зеркально отображаю ее, чтобы получить вторую ногу, после чего проделываю то же самое для рук. Не забывайте на этом этапе сверяться с внешними образцами. Потом идет собственно «сборка» персонажа из отдельных частей и корректировка пропорций. Как правило, изображение на этом этапе получается в более высоком разрешении, чем нужно, поэтому я делю модель по всем осям симметрии, какие она может иметь, и удаляю несущественные грани.

Эскизы, на основе которых создавались монстры Half-Life, несомненно, должны привести поклонников этого великолепного шутера в священный трепет. Кроме того, обратите внимание: добрый художник поместил на рисунках объяснения того, как устроены некоторые из врагов: стероидный клещ (barnicle), борзоглаз (houndeye) и большая мама (big mama). (Приводится с разрешения компании Sierra Studios.)

Получив действующую модель, можно приступать к созданию ее «шкуры» (текстуры, покрывающей модель). На этом этапе я часто использую стандартную Windows-функцию сохранения изображения текущего экрана (Print Screen): выбираю в 3D Studio MAX набор поверхностей, проецирую их на некоторую плоскость, делаю скриншот соответствующего изображения (кнопка «Print Scrn») и использую его в качестве шаблона в Painter.

Тед говорит, что в будущем он надеется «создавать интересные виртуальные миры, неотразимых героев и занимательные сценарии для самых разных игровых жанров». Если судить по Half-Life, нам еще не раз предстоит услышать имя Теда Бэкмана.

Марк Хаджинс (Marc Hudgins), Yosemite Entertainment

Марк Хаджинс работает в студии Yosemite Entertainment (подразделение Sierra On-Line в Окхерсте, Калифорния, США) художественным директором и дизайнером. Мы уже встречались с ним в четвертой главе, где говорилось о создании персонажей, здесь же Марк рассказывает нам об игровой графике.

Технические ограничения

По мнению Марка Хаджинса, начинающим игровым художникам надо быть в курсе возможностей и ограничений современных компьютерных технологий. В силу чего он настоятельно рекомендует следить за последними достижениями в области аппаратных средств и программного обеспечения. В подкрепление своих слов Марк рассказал нам следующее:

Начиная работу над игрой Babylon 5 (ныне «покойной»), помимо использования преимуществ первого поколения 3D-ускорителей мы хотели создать достойный движок для программного рендеринга. Однако из-за задержек с лицензией и быстрого развития трехмерных плат нам пришлось отказаться от такого решения. К тому же программный рендеринг графики слишком сильно загружал процессор, поэтому его применение требовало резкого ограничения числа полигонов в моделях. Как только мы избавились от этого бремени, допустимый размер кораблей вырос вдвое. Этот пример, может быть, не самый яркий, но он четко показывает, как важно сохранять гибкость в процессе создания графики и идти в ногу с технологиями. Очевидно также, что необходимо быть знакомым с новейшими инструментальными средствами, дабы органично совмещать возможности ПО и игровой технологии.

Консультируйтесь с художниками

Создавая игру, человеку, отвечающему за ее графику, крайне важно как можно раньше установить тесный контакт с художниками, работающими над проектом. По мнению Марка Хаджинса, это поможет в решении многих вопросов, которые непременно возникнут в будущем.

При разработке King's Quest 7 именно вмешательство художников позволило нам решить одну довольно серьезную проблему. У нас было несколько королевств, каждое из которых отображалось множеством экранов. Мы обнаружили, что при решении головоломок легко запутаться, так как отдельные «помещения» королевств казались абсолютно не связанными друг с другом. Так вот, изменив визуальную композицию «комнат» и создав новые связи между их частями, мы смогли улучшить игру. Мораль такова: иногда разработчики обладают не самым острым зрительным восприятием; несмотря на стремление приложить все усилия для разрешения проблем, они зачастую выбирают далеко не самый надежный и элегантный вариант. А вот интерпретация, выполненная художником, человеком, «по определению» обладающим острым взглядом, нередко помогает упростить сценарий.

Программные средства

Основное оружие любого «цифрового» художника - редактор Photoshop: раздобудьте его, изучите его, живите им. Кроме Photoshop имеется еще несколько популярных инструментов. 3D Studio MAX, похоже, повсеместно используется в разработке игр; полезно также «знать и уметь» пакет Macromedia Director, незаменимое средство для создания презентаций, мультимедиа-приложений и разного рода графических эффектов. Есть, впрочем, и ряд других программ, однако перед начинающим компьютерным художником быстро встает самая большая проблема - цена. Работодатели часто настаивают на опыте работы с конкретным пакетом. Им, как правило, нужен человек, способный сразу приступить к работе. К сожалению, для этого необходимо получить доступ к весьма дорогостоящему ПО. Для тех же, кто не имеет такой возможности, я рекомендовал бы попробовать программы вроде Jasc Software's Paint Shop Pro - с их помощью вы овладеете по крайней мере основными понятиями и приемами работы.

Однако самый главный инструмент, без которого совершенно невозможно работать, - это глубокие классические художественные навыки, в частности, речь идет, конечно, об умении рисовать. Человеку, в совершенстве владеющему техникой рисования человеческого тела, по плечу любая задача. Работая над играми, художнику приходится иметь дело со многими дисциплинами, поэтому хороший вкус, чувство цвета и композиции также являются ценными качествами.

В работе над закрытым не так давно проектом Babylon 5, над которым трудился художник Марк Хаджинс, помимо Photoshop, ставшего стандартом индустрии, использовался пакет LightWave 3D компании Newtek. (Приведено с разрешения Yosemite Entertainment, Inc. Babylon 5, герои, названия и все связанные с ними знаки являются торговыми марками Time Warner Entertainment Co. L.P. © 1998 Time Warner Entertainment Co.)

На прощание Марк Хаджинс предложил несколько рекомендаций, которые могут пригодиться как ведущему дизайнеру, так и художникам, работающим над игрой.

• Чаще общайтесь друг с другом, собираясь всей командой.

• Добивайтесь от разработчиков предложений, касающихся проекта.

• Время от времени признавайтесь себе, что не знаете ответов на все вопросы.

• Не рассчитывайте, что у вас получится что-либо, если вы не проконсультировались предварительно с экспертами.

• Не превращайтесь в ретрограда. Будьте открыты для перемен (когда это необходимо).

• Не устраняйтесь от процесса разработки.

Марк Хаджинс имеет собственный веб-сайт, выполняющий роль интерактивной художественной галереи. Здесь представлены его работы, не вошедшие в игры, - эскизы и раскадровки. Непременно загляните на www.marchdesign.com.

Майк Николсон (Mike Nicholson), Dreamforge Intertainment

Старший художник и дизайнер Dreamforge Майк Николсон непосредственно ответствен за часть ваших ночных кошмаров: он был одной из движущих сил при создании великолепной «игры ужасов» Sanitarium.

Майк адресует свои слова дизайнерам, рассказывая о том, как они должны подходить к художественному оформлению игр.

Стержневая идея

Вы ОБЯЗАНЫ четко представлять себе, как будет выглядеть ваша игра. В процессе разработки очень легко попасть под влияние других стилей, почерпнутых из окружающего информационного пространства. Если у вас нет перед глазами конкретного образа и вы надумаете поменять стиль на полпути, игра потеряет целостность - противоречивые подходы к художественному оформлению просто разрушат ее.

Трудная любовь

Если вы привлекли к проекту сторонних художников (что в настоящее время практически неизбежно), может случиться так, что вам будет сложно браковать их работы (независимо от того, насколько хорошо они выполнены) только потому, что они не удовлетворяют сложившемуся в команде представлению об игре. Легко представить, что это способно привести к горячим спорам и, если не применить дипломатию, к катастрофе! С самого начала важно добиться взаимопонимания с штатными художниками, оставив за собой возможность отказа от рисунков из-за их несоответствия общему стилю. Если необходимо, покажите художественной группе фотографии, кинофильмы, книги, что-нибудь еще, что сможет передать то представление и ощущение от игры, которое вам требуется.

Идеи и исполнение

Теперь пара слов для художников:

Друзья, не забывайте, что почти все ваши художественные идеи уже были реализованы до вас или же реализуются именно сейчас и еще не раз будут повторены после вас. Как ни грустно, но это так. Причина, по которой я заостряю на этом внимание, - желание убедить вас в необходимости до конца оставаться верным своему решению. Когда одновременно разрабатывается так много игр, логично предположить, что та же самая «блестящая» идея пришла в голову еще кому-нибудь. Поэтому все зависит от реализации. Уверен, если вы придерживаетесь последовательного представления о своей игре, то все у вас получится. Пример из нашей практики: мы были уверены, что, несмотря на всеобщее увлечение 3D-движками, нам необходим традиционный двухмерный подход к игре, чтобы добиться должной степени детализации.

Создавая квест Sanitarium, Майк Николсон и его команда больше всего хотели добиться того, чтобы графика игры и стилизованные движения ее персонажей передавали ощущение пограничного состояния психики. (Приводится с разрешения компании Dreamforge Intertainment, Inc.)

Оцените свои возможности

«Вот лучший совет, который я могу дать: определите границы своих возможностей как можно раньше и работайте, не выходя за них», - говорит Майк Николсон.

Тщательное планирование уменьшит головную боль, неизбежную при технических ограничениях вроде небогатой палитры. Предположим, ваш главный герой должен быть нарисован с использованием 256-цветной палитры (включая фон). Выделите определенный цветовой диапазон (скажем 36 цветов) исключительно для героя, убрав эти цвета из палитры для фоновых рисунков. Если в дальнейшем вы решите внести изменения в фоновые рисунки или изображение героя, такой подход позволит избежать разрушающего «эффекта домино» в отношении остальной части графики.

Sanitarium - отличный пример грамотной работы с палитрой. К счастью, делая игру, мне пришлось сотрудничать с двумя чрезвычайно талантливыми людьми: Кейтом Лэшем (Keith Lash) и Джейсоном Александром (Jason Alexander). Перед нами стояла малоприятная задача: уместить цветовую гамму целых уровней Sanitarium в рамках 256 цветов. В эту палитру должны были попасть Макс (главный герой), все остальные персонажи, их анимация, активные предметы и фоновые изображения. Было очень трудно, но Кейт и Джейсон смогли так подобрать цветовые гаммы для отдельных компонентов, чтобы свести возможные наложения цветов к минимуму.

Как и большинство других художников, с которыми вы познакомились в данной главе, Майк Николсон утверждает, что Adobe Photoshop - лучшая программа для рисования и она широко использовалась в работе над Sanitarium. Майк полагает, что последняя версия Photoshop обладает большими возможностями по работе с цветовой палитрой, однако для большинства таких работ в Dreamforge Intertainment предпочитают использовать DeBabelizer Pro (производства Equilibrium).

Луис Касл (Louis Castle), Westwood Studios

За последние 14 лет Луису Каслу довелось работать над играми в качестве дизайнера, исполнительного продюсера, программиста, художника и художественного редактора. Луис является соучредителем всемирно известной Westwood Studios, одной из самых энергичных и успешных компаний индустрии. Как художникам Westwood удалось создать такую замечательную графику для игр Blade Runner, Lands of Lore III и серии Command & Conquer? Послушаем, что скажет Луис.

Наши художники работают в тесном контакте с дизайнерами, непосредственно создающими уровни и миссии. Они хотят быть уверены, что графика соответствует игре; впрочем, то, как игра выглядит, определяется именно художниками. Вам же будет лучше, если художники почувствуют себя полноправными хозяевами графической стороны дела, поэтому не стоит диктовать им условия во всем вплоть до мелочей. Если каждый шаг художника строго контролируется, вы никогда не получите тех моментов творческого вдохновения, которые так украшают любую игру.

Но должно же быть какое-то начальное общее представление, не так ли? Ведь игровая графика, в конце концов, обязана быть гармоничной?

Мы широко используем эскизы и раскадровки. Большинство штатных художников студии не прочь поучаствовать в создании стиля игры, но, знаете, я обнаружил, что для этого лучше использовать выделенных специалистов. Когда эскизы создает один художник, он может выразить собственный взгляд на игру и в то же время обеспечить последовательное воплощение своих идей; но как только графикой начинают заниматься слишком много людей, проект на глазах расползается в разные стороны. Если вы работаете над большим продуктом, возможно, стоит разделить его на некие логические области, отдав их отдельным художникам.

Исполнение проекта начинается сразу после утверждения его концепции. Повторяю еще раз: у нас приветствуется, когда любой художник выдвигает собственные идеи в любое время. В Westwood довольно короткая служебная лестница, продвигаться по ней особо некуда, поэтому соревноваться приходится только в качестве работы. Я думаю, это лишний раз помогает сосредоточиться на конкретном задании.

Мой главный совет состоит в том, что следует заранее и очень четко определить конечную цель и расписать весь процесс художественного оформления игры. Сюда же входят и любые технические ограничения. Имея план, вы всегда можете позволить художнику творчески работать над идеей, но не стоит ожидать, что кто-то другой сделает за вас главное - примет решение, о чем будет ваша игра и кому она будет адресована.

Все проекты компании Westwood Studios начинаются с создания концептуальных эскизов и раскадровок, при этом художникам предлагается творчески переработать предложения дизайнеров. На рисунках представлены наброски юнитов для орденоносной игры Command & Conquer: Tiberian Sun: справа юнит GDI, внизу - NOD. (Приводится с разрешения компании Westwood Studios.)

Джоэль Томас (Joel Thomas), Ritual Entertainment

Джоэль Томас работает в студии Ritual в Далласе (США), он художник, ответственный за эскизную проработку проектов. На счету его студии 3D-шутер Sin (издатель Activision) и игра Scourge of Armagon, официальный набор уровней к Quake.

В игровой индустрии изучение программных средств часто считают более важным, чем овладение обычными художественными навыками. Джоэль Томас объясняет, почему это неправильно.

Художник Джоэль Томас показывает нам эволюцию зловещего образа Элексис Синклер: от черно-белого наброска через рисунок в стиле комикса к трехмерному изображению. (Приводится с разрешения компании Ritual Entertainment, Inc.)

Одно из наиболее важных качеств для начинающего игрового художника - умение рисовать. Чем лучше вы рисуете, тем качественнее получится трехмерная модель: точно выполненный профессиональный рисунок даст разработчику модели дополнительные возможности и время для ее совершенствования.

Хорошо, предположим, человек обладает настоящим талантом художника, на что еще ему следует обратить внимание?

Нужно осознать, насколько важно хорошо знать реальный мир. Окружающий нас мир - неисчерпаемый источник идей для создания фантастических существ, оружия или предметов. Многие художники, особенно поначалу, боятся рисовать «с натуры», думая, что это нанесет ущерб их творческому реноме. На самом деле, все как раз наоборот: чем меньше вы используете внешние источники, тем менее вдохновенным получится ваш рисунок.

Нельзя также обойтись без знакомства с основами анатомии человека. Без знаний о расположении мышц и правильных пропорциях различных частей тела очень трудно добиться реалистичности персонажа. Все двуногие создания, независимо от роста или пола, имеют одинаковые мышцы и их расположение. Их индивидуальность - это результат исключительно эстетической трактовки.

Очень много людей, стремящихся стать художниками, учатся рисовать по комиксам. Преимущества такого подхода, если они и есть, незначительны, но зато ограничивается эффективность вашего видения. Сначала изучите анатомию, и только потом начинайте копировать образцы. Именно в таком порядке!

Далее Джоэль переходит к тому, что, по его мнению, может привести хорошего художника к полному краху:

Важнее всего запомнить следующее. Никогда не зазнавайтесь. Возможно, вы отлично работаете, но всегда найдется кто-то, кто сделает это лучше и быстрее. Удерживаться на передовых позициях очень непросто, поэтому следите за тем, кому и почему это не удалось. Учитесь у конкурентов. Никогда не обольщайтесь мыслью, что вы настолько «круты», что нет уже ничего, чему вы могли бы научиться. Жизнь любит ставить таким людям подножку, а падать всегда больно. Уважайте тех, кем восхищаетесь, и помогайте новичкам. Мало того, что вы сможете многому научиться, вы к тому же получите неоценимых союзников.

Может быть, вы полагаете, что Джоэль, художник, занимающийся концепт-артом, использует компьютер не так часто, как другие компьютерные художники? Это не совсем так.

Эскизы. Я рисую их с помощью пера и чернил. Не люблю карандаши, поскольку, как мне кажется, они приучают к небрежности: используя карандаш, можно по много раз наносить линии и стирать их. Напротив, рисуя пером, необходимо сначала подумать о том, что собираешься сделать. Поэтому в процессе работы приходится более ответственно относиться к каждому штриху. Закончив эскиз, я беру замазку и удаляю лишние линии. Или сканирую рисунок, после чего - уже в компьютерном виде - дорабатываю его, используя Photoshop.

Другой вариант - рисовать непосредственно в Photoshop. Для этой цели я использую планшет Wacom с цифровым пером. Мне кажется, данный способ дает несколько большую свободу, поскольку позволяет свободно изменять размеры и перемещать части эскиза. Это вносит в разработку непосредственность. Закончив эскиз, я отсылаю его разработчику модели. Работая над Heavy Metal: F.A.К.К.2(очередной проект Ritual, чей выпуск запланирован на середину 2000 г.), я больше времени уделяю цифровым рисункам и окончательной доводке изображений. Это поможет игроку проникнуться сюжетом и увидеть персонажи такими, какими вижу их я.

Джоэль Томас работает над мутантами Эоном и Пеоном для игры Sin. На верхнем рисунке показано, как монстры выглядят в Photoshop, на нижнем - различные фазы их создания: от наброска до готовой модели.

Кевин Клауд (Kevin Cloud), id Software

Кевин Клауд, совладелец знаменитой id Software, художник, начинавший в индустрии с классической игры Wolfenstein 3D, после которой участвовал в создании таких игр, как Doom, Doom II, Quake, Quake II и Quake III: Arena. Ниже Кевин делится с вами своим опытом создания графики для игр.

Мне всегда было трудно следовать чужим советам. Все люди разные, со своими талантами и своими обстоятельствами, поэтому каждый должен найти собственный путь. Но если вы хотите убедиться, что двигаетесь в правильном направлении, посмотрите, чем заняты другие художники, добившиеся успеха. Поэтому мой первый совет - учитесь у жизни. Всегда сохраняйте интерес к окружающему миру и делайте выводы из успехов и провалов других художников.

Золотое правило: чтобы добиться успеха в каком-то деле, необходимо, чтобы оно вам нравилось. Я понимаю, это банальность, но тем не менее так оно и есть. К сожалению, многие забывают это правило. Художники, работающие в нашей индустрии, должны любить компьютерные игры, получать удовольствие от работы в команде и ощущать себя частью процесса. Как художнику, вам придется воплощать чужие идеи, создавать графику, которая должна подчиняться множеству немыслимых ограничений, и находиться под постоянным прицелом критики. Но если вам по душе ваши игровые миры, ничего из этого вас не смутит. Да, это так - многие компьютерные художники равнодушны к играм. Но мой опыт говорит, что эти люди редко бывают счастливы от своей работы. А это, уж поверьте, самая необходимая составляющая успеха.

«Возможно, следующий совет звучит тоже достаточно банально, - говорит Кевин, - но в современной игровой индустрии его нередко упускают из виду». При этом Кевин признается, что даже ему пришлось с этим столкнуться...

Мало быть просто специалистом по компьютерной графике, необходима настоящая художественная подготовка. По образованию я политолог, и, хотя я посещал несколько художественных классов, теперь мне ясно, что, к сожалению, уделял этому не так много времени. Я горжусь своей способностью быстро осваивать новые инструменты и с их помощью создавать самую лучшую графику в минимально короткие сроки. Но по мере продвижения по этому пути мне пришлось овладеть многими основополагающими навыками. Если бы я сегодня пришел на работу с теми умениями, которые имел в 85-м, когда только-только начинал, меня, скорее всего, не взяли бы. Времена хоть и талантливых, но недоучек ушли в прошлое. Можно изучать основы рисования по книгам, можно пойти в художественную школу - но эти знания необходимо иметь. Вместе с тем, теория цвета, анимация, строение человеческого тела, рисование кистью и карандашом, основы композиции и прочее - это не те навыки, которые можно приобрети самостоятельно.

Что еще необходимо освоить? Какие инструменты нужно изучить в первую очередь и наиболее тщательно?

Практикуйтесь на домашнем компьютере. Невозможно выучиться на компьютерного художника, не проводя за ПК долгие часы. Купите старый компьютер, найдите в Интернете общедоступные (или «подержанные») программы; при этом не гонитесь сразу ни за последними версиями ПО, ни за новейшими операционными системами, но кое без чего все же не обойтись. Хороших программ довольно много, но две из них вы просто обязаны изучить - это Photoshop и 3D Studio. He найдя ни той ни другой, достаньте любую программу для рисования с палитрой в 32 бита и программу для полигонного моделирования. Ну а если совсем никак не получается завести компьютер дома, можно сидеть за экраном у друзей, использовать школьный компьютер или устроиться на работу (какую угодно), где есть компьютеры. В своей первой компьютерной компании Softdisk я хотел получить место художника, но мне сказали, что художник им не нужен. Вместо этого пришлось сидеть в службе технической поддержки и отвечать на звонки. Потребовалось время, чтобы убедить руководство компании, что художник им просто необходим, но прежде я наладил контакты с программистами и мог использовать их компьютеры для обучения.

Научившись чему-либо и приобретя практический опыт, непременно приступайте к совершенствованию своих художественных навыков. Кевин поясняет эту мысль:

Занимайтесь только тем, к чему более всего стремитесь, избегайте соблазнов, которые встретятся вам на пути. Этот урок я повторяю всю жизнь. Несмотря на то что я никогда не прекращал заниматься графикой, часто приходится отвлекаться на другие проекты, но примерно через год моя голова начинает разрываться. И мне приходится в очередной раз убеждать себя, что я художник, потому что это именно то, что нравится мне больше всего.

Не останавливайтесь на достигнутом, постоянно будьте нацелены на самосовершенствование. Читайте книги по специальности, посещайте достойные веб-сайты, просматривайте художественные коллекции на компакт-дисках. Кстати, о книгах. Есть масса прекрасно иллюстрированной биографической литературы, посвященной художникам. Уверен, что каждый художник должен отводить некоторое время на изучение биографий любимых мастеров и копирование их работ. Пытаясь подражать стилю знаменитости, вы очень многому научитесь и, в конце концов, приобретете гибкость, необходимую для выработки собственной манеры письма. Посещайте дискуссионные группы в Интернете, не стесняйтесь задавать там вопросы. Интересуйтесь мнением коллег, советуйтесь с ними. Дружите с людьми, которые заинтересованы в том, чтобы стать настоящими художниками. Сосредоточение на совершенствовании художественных навыков и возможностей поможет вам достичь своих целей.

Наконец, еще один совет: не бойтесь идти вперед, рисковать и стремиться... стать великим. Если возможно, завершите проект, над которым работаете, но если подвернулся лучший шанс, не упускайте его. Старайтесь окружить себя положительными и талантливыми людьми. Работая с лучшими, вы неизбежно и сами станете лучше. И имейте в виду, что ваше будущее находится в ваших руках. Не соглашайтесь играть роль лишь одного из многих. Делайте что-нибудь необычное, чтобы продемонстрировать свою неординарность. Разработайте стиль или технику, которые будут свойственны только вам.

Заключительными словами Кевина были: «Пытайтесь привнести в каждый проект, в котором участвуете, что-то свое, чтобы люди знали, что вы приложили к нему свою руку». Да будет так.

Брэд Кроу (Brad Crow), Ensemble Studios

Наш третий подряд художник из Техаса (честное слово, это просто совпадение!) создает захватывающие дух рисунки для совершенно другого жанра. Брэд Кроу - ведущий художник Ensemble Studios, энергичной молодой компании, разрабатывающей стратегические игры для Microsoft. Среди ее достижений неоднократно награжденные бестселлеры Age of Empires и The Rise of Rome (дополнительные миссии к Age of Empires II).

Интересно, что в этой главе почти все художники, независимо от игрового жанра, в котором они работают, дают начинающим очень похожие советы. Брэд Кроу не исключение. Он предлагает твердо придерживаться следующих принципов:

• Ясно представляйте себе, как должна выглядеть ваша игра. Это позволит очень быстро продвигаться вперед на ранних стадиях разработки.

• Проявляйте гибкость в подходе к видению игры, пока она находится на стадии разработки. Позвольте игре расти и развиваться, даже если результат отличается от вашего первоначального представления. Постоянно переоценивайте свое представление об игре и позволяйте новым методам, технологическим находкам и, самое главное, художественным талантам вашей группы благотворно влиять на вашу первоначальную концепцию.

• Прислушивайтесь к критике со стороны, более того - ищите ее. Вы хотите, чтобы ваша игра стала бестселлером? В таком случае нет никакого смысла ограничивать свой рынок, придерживаясь художественного стиля, который заведомо будет интересен лишь небольшому проценту игроков. Если у кого-то возникли претензии к тому, как выглядит часть вашей игры, оцените, насколько они доказательны. Возможно, и другие люди придерживаются такой же точки зрения.

В настоящее время Ensemble Studios использует главным образом 3D Studio MAX. Однако большая часть Age of Empires была выполнена в 4-й версии 3D Studio, так как пакет 3D Studio MAX появился лишь перед самым окончанием проекта. Зато всю графику и анимацию Age of Empires II: The Rise of Rome Брэд Кроу и его команда делали в 3D Studio MAX.

Джо Коберстин (Joe Koberstein), Raven Software

Джо Коберстин в индустрии компьютерных игр уже шесть лет (для игрового бизнеса это вечность!) и в настоящее время работает художником в Raven Software. Два последних продукта, выпущенных студией Raven в Мэдисоне (штат Висконсин, США), Heretic II и Soldier of Fortune (издатель Activision), были прекрасно встречены публикой.

В своих советах новичкам Джо Коберстин сразу же берет быка за рога:

• Компьютер - это всего лишь инструмент, как карандаш или кисть.

• Учитесь рисовать - это основа художественного мастерства (все равно, компьютерного или нет).

• Не считайте свою работу исключительно своей. Компьютерная графика не изящное искусство. Ваше представление может не совпадать с мнением руководителя проекта, но в этой индустрии могут преуспеть только люди, способные к адаптации. В нашем деле перемены происходят практически ежечасно. Это потрясающее ощущение, но неподготовленный человек может и оробеть. Просто не выпускайте свое эго из-под контроля и думайте, прежде чем бросаться в бой.

Джо Коберстин согласен с мнением большинства художников, выступивших в этой главе, относительно инструментария:

Photoshop и 3D Studio MAX стали общепринятым стандартом среди программ для рисования и это прекрасные средства в плане обучения. Поначалу их освоение идет довольно трудно, но это во многом связано с тем, что программы очень мощные и предлагают многочисленные возможности. Советую всем изучающим Photoshop: используйте слои. Это позволит вам экспериментировать с решениями, что недоступно в классической живописи. А вот рекомендация для овладевающих 3D Studio MAX: изучайте описание и начинайте практиковаться на простых задачах. Не пытайтесь в качестве первого проекта взяться за трилогию Star Wars.

В любом случае создание захватывающих дух картин, независимо от того, используется для этого компьютер или холст, кисть, масло, сводится к практике. К очень большой практике.

«Концепт-эскизы имеют решающее значение для разработки игры, независимо от того, будет ли это раскадровка, набросок на салфетке или полностью прорисованное трехмерное окружение. Важна целостность», - говорит Джо Коберстин. На рисунке приведен эскиз главного героя Heretic II Корвуса. (Использовано с разрешения компании Activision.)

Майк Николc (Mike Nichols), Surreal Software

Майк Николc - вице-президент, основатель и художественный руководитель компании Surreal Software, выпустившей в 1999 году игру Drakan: Order of The Flame (издатель Psygnosis), которая была высоко оценена и игроками, и критиками. Майк перечисляет три самых важных, по его мнению, момента в создании игровой графики, которые будут полезны начинающим разработчикам вообще и художникам в частности.

Композиция

Когда дело доходит до рисования ландшафта, дизайнер и художник должны уделить особое внимание композиции. Убедитесь, что все рисунки правильно размещены на сетке. Вы ведь не хотите, чтобы текстура грунта соседствовала с текстурой травы без какого бы то ни было перехода?

Эстетичность

Важно, чтобы разработчик обладал чувством прекрасного. Гора - это не просто конусообразный объект, покрытый текстурой. Здесь действительно необходимо с большим вниманием отнестись к форме. Еще до раскраски первой текстуры сама форма должна иметь определенное значение и передавать настроение игры. Ландшафт в Drakan столь же важен, как и герои. Некоторые даже утверждают, что это главный герой.

Внимание к деталям

Не забывайте о деталях. Именно они создают виртуальные миры, столь отличающиеся друг от друга, и игрок это ценит. Лично я проявляю больший интерес к играм, которые затягивают меня в очередную вселенную, а не просто помещают в нее.

Именно с этой точки зрения Майк Николc рассматривает свою игру:

Drakan содержит самые обширные ландшафты, когда-либо применявшиеся в компьютерных играх. Когда дизайнеры принимаются за очередной уровень, у них должно быть ясное понимание игрового процесса. С чего начинается уровень, как игрок должен пройти его? Сделайте так, чтобы пользователь «чувствовал», что он двигается правильно. От того, как выглядит карта, в большой степени зависит то, как ее будут исследовать.

Дизайнеры игры «мостили» исходную форму полигонами так, чтобы создать иллюзию естественности. Художник создавал набор тайлов, небольших точечных рисунков, из которых разработчик затем составлял декорации. Будучи собраны воедино, тайлы выглядят настоящим и весьма протяженным ландшафтом. Сами же тайлы создаются так, чтобы при их «укладке» в соседние ячейки сетки между ними не было заметно швов. Мы использовали этот метод, потому что для создания ОГРОМНЫХ тайлов, которые потребовались бы для текстурирования наших ландшафтов, просто не хватало памяти.

Работая над своими насыщенными деталями бесконечными пейзажами, художники Surreal использовали целый ряд инструментов.

3D Studio MAX и SOFTIMAGE (для 3D-графики)

«МАХ - отличный выбор сразу по нескольким причинам», - говорит Майк Николc...

Используя этот продукт, вы получаете все функции, которые вам понадобятся, что называется «в одном флаконе», а это выгодно экономически. (К сожалению, один из недостатков подобных программ заключается в том, что вы приобретаете ровно то, за что заплатили, причем далеко не все работает так, как хотелось бы. По мере использования программы это может вызывать все большее и большее раздражение.)

Кроме того, пакет 3D Studio MAX прост в обучении. Для начинающих это самый легкий способ попасть в мир трехмерной графики и заняться здесь поиском своего пути.

С другой стороны, пакет SOFTIMAGE работает гораздо надежнее. Это наш выбор №1 для анимации персонажей. Он предоставляет опытным художникам-аниматорам возможности управления, необходимые для создания работ высокого класса.

Photoshop (для 2D-графики)

«Это стандарт, - соглашается Майк Николc, - причем стандарт хороший. Без Photoshop не может обойтись ни один художник, работающий с двухмерной графикой. Программа имеет легко осваиваемый интерфейс и мощные инструменты, которые помогут вам создавать красивые текстуры».

Конечно же, список инструментов для художественного творчества с использованием компьютера этими средствами не исчерпывается. Существует множество других хороших программ. Выбор того или иного пакета в первую очередь зависит от степени вашего знакомства с конкретной программой и от того, насколько она будет способна удовлетворять ваши растущие потребности. Инструмент, который не в состоянии реализовать замысел, зародившийся в вашей голове, ничего не стоит.

Для художника, создающего или собирающегося создавать рисунки при помощи компьютера, важно остаться приверженным своему видению мира и не позволять программному обеспечению диктовать, как должны выглядеть его произведения. Вы должны командовать программами, а не они вами! Не жалейте времени, чтобы получить на экране именно то, что у вас в голове. Я не раз сталкивался с художниками, «подчинявшимися» программе; именно этим можно объяснить, почему многие работы выглядят одинаково и почему многие люди, не являющиеся художниками, полагают, что они легко могут ими стать.

Далее Майк Николc рассказывает о том, что, по его мнению, является «одним из самых важных навыков художника... этому учатся, но никогда не овладевают в совершенстве».

Чувство формы

Речь не о способности нарисовать абсолютно любую фигуру. Я имею в виду понимание и навыки наблюдения, требуемые для создания выразительных форм. Мастера на протяжении всей жизни пытаются овладеть всего лишь одним аспектом формы - фигурой человека, натюрмортом, пейзажем - и ни один не скажет вам, что достиг совершенства.

Поэтому расслабьтесь и наслаждайтесь тем, что создаете. Как говаривал мой учитель живописи: «Всегда ищите вдохновение, и не так важно, где вы его найдете - в работах коллег, на природе или в бутылке...»

Создание двухмерных текстур для ландшафта - не такое уж и легкое дело. Майк Николc говорит: «Вам необходимо нарисовать такую текстуру, чтобы при заполнении большого участка ландшафта не возникало швов. Чтобы избежать повторов узора, текстуры должны быть достаточно простыми». (Использовано с разрешения компании Surreal Software, Inc.)

Тони Лупиди (Tony Lupidi), EA Sports

Тони Лупиди - художественный директор Scoreboard Productions, подразделения компании Electronic Arts, которое специализируется на серии баскетбольных симуляторов March Madness (выходят под маркой EA Sports); кроме того, в Scoreboard были выпущены такие игры, как Knockout Kings, NASCAR Revolution и Hot Wheels. Наш собеседник работал над графикой и анимацией для множества игр, телепрограмм и кинофильмов, так что ему есть чем поделиться с новичками.

Не стоит попадать под очарование последних технологических «чудес» до такой степени, чтобы позволить им потрясти основы вашего мастерства. К примеру, из того, что новейшие 3D-ускорители наделены функцией бампмэппинга (bump-mapping), то есть умеют показывать на текстуре «рельеф» за счет наложения на нее дополнительных текстур с учетом направления на источник освещения, вовсе не следует, что отныне все игровые миры должны быть блестящими и бугристыми. Основы дизайна и композиции применимы к игровой графике в той же степени, что и к любой другой.

Не занимайтесь рисованием эскизов непосредственно на компьютере. Черновые наброски намного быстрее и эффективнее делать с помощью карандаша и бумаги. Кроме того, в этом случае вы вряд ли успеете эмоционально привязаться к эскизу, что в дальнейшем упростит его совершенствование.

Работая над рисунками, не забывайте об ограничениях, накладываемых движком игры. Вашу работу никогда не оценят по достоинству, если игра будет тормозить так, что играть станет неинтересно. Графика должна усиливать впечатление от игры, а не мешать получать удовольствие. Игровая графика - это вечный поиск компромисса между качеством и быстродействием.

Далее Тони Лупиди рассуждает об особенностях создания графики для спортивных симуляторов и объясняет, в чем ее отличие от графики игр других жанров.

Спортивные игры - это симуляторы, обычно имитирующие телевизионную трансляцию спортивных состязаний. Каждый, кто хотя бы раз смотрел телевизионный репортаж о баскетбольном матче, знает, как должна выглядеть такая игра. А вот шестнадцатируких фиолетовых инопланетян большинство людей не видели, поэтому в экшен-играх, стратегиях или квестах у вас, как у художника, гораздо больше простора для творчества.

Есть что-то общее между разработкой спортивных игр и автомобилей. Подобно автомобилям, новые версии спортивных симуляторов выпускаются ежегодно, так как они привязаны к игровому сезону соответствующих видов спорта. Как и автомобили, эти игры каждый год подвергаются все новым и новым техническим и художественным улучшениям. При этом людям нравится, что основные компоненты не меняются, а хороший, стильный дизайн в сочетании с отличными характеристиками наверняка удовлетворят любого заинтересованного покупателя.

Использует ли Тони те же самые инструменты, что и другие художники, работающие над играми? В общем да, подтверждает наш собеседник.

Наша текущая платформа для разработки игр - Windows 98/NT 4.0. В качестве инструментальных средств мы используем 3D Studio МАХ 2.5 (для трехмерного моделирования, анимации и наложения текстур), Character Studio 2.x с плагином Promotion, Photoshop 5.0 и Adobe Illustrator 8.0, а также целый набор программ собственной разработки.

А что вы посоветуете тем, кто хочет влиться в этот бизнес? Какие-нибудь секреты или методы?

Начинающим я могу посоветовать попробовать себя на движках для Doom, Quake или Quake II. Они легко расширяются и изменяются, предоставляя превосходный полигон для испытания своих сил. С их помощью вы можете создавать и редактировать все, что угодно: миры, текстуры, модели, звуки и т.д. Наборы инструментов для создания абсолютно новых игр, основанные на этих движках, свободно распространяются через Интернет (или же стоят очень недорого). Интернет полезен еще и вот с какой стороны: здесь можно пообщаться со знающими людьми, готовыми помочь советом новичкам. Так начиналась карьера многих моих коллег. Вот некоторые из часто используемых программ для работы с архивными файлами Quake: Paint Shop Pro (www.jasc.com), Worldcraft (www.worldcraft.com) и QPed (www.planetquake.com/qped).

В заключение Тони предсказывает: «Мы находимся на пороге возникновения новых интерактивных средств массовой информации». Причиной тому все ускоряющееся развитие технологии: появление новых графических плат, отображающих трехмерные объекты в реальном времени, широкополосных сетей (кабельных модемов массового применения), а также непрекращающаяся разработка все более быстрых и дешевых компьютеров. Лучшего момента, чтобы начать работу в этой области, трудно придумать, не так ли?

Тоби Симпсон (Toby Simpson), CyberLife Technologies

Художественный руководитель ряда проектов из серии Creatures, Тоби Симпсон рассказывает о своем подходе к графике для компьютерных игр и объясняет, чем он, возможно, уникален.

Чтобы избежать противоречий и согласовать все детали, мы объединяли разные игры серии Creatures не сюжетом, а скорее единой тематикой. Сначала разрабатывается нечто вроде общего руководства по стилю, определяются хронология и география так, чтобы на основе выбранной темы можно было создавать не противоречащие друг другу сюжеты. Это облегчает работу, направляя творчество в нужное русло. Подобный подход использовал Толкиен для создания «Властелина колец» и прочих историй из жизни Средиземья: сначала нужно сконструировать мир, в котором будут происходить события сюжета. Это экономит массу времени!

Итак, прежде всего мы решаем, какой «исторический момент» будет отражен в игре. Это автоматически определяет место действия, и мы начинаем рисовать эскизы нового Creatures-мира. Постепенно у нас появляется полный проект среды и ее обитателей, выполненный на старой доброй бумаге. Потом все материалы сканируются, переносятся в компьютер и помещаются в программу так, чтобы можно было выполнять разработку, в то время как художники постепенно заполняют рисунок компьютерной графикой.

В момент создания этой книги художники CyberLife Technologies занимались макетированием новых виртуальных миров для третьей игры из знаменитой серии Creatures.


Анимация

Глава 11

Анимация

Рука об руку с художественным оформлением игры идет анимация, ведь игровые объекты редко бывают неподвижны. Попросту говоря, анимация в играх, фильмах или на телевидении - это способ «оживить» изображение, показывая объекты в движении. К анимации в играх предъявляются наиболее жесткие требования, так как при воспроизведении движения живых существ (или механизмов) она должна быть синхронизирована как с искусственным интеллектом (отвечающим за реакции существ/механизмов), так и с действиями игрока, непосредственно управляющего существами/механизмами.

Впрочем, анимация в играх может не зависеть ни от искусственного интеллекта, ни от игрока. Это так называемая неинтерактивная анимация, выполненная на основе заранее прорисованных (пререндеренных) последовательностей кадров. Самый характерный пример неинтерактивной анимации -видеовставки, столь популярные в компьютерных играх и являющиеся прямыми родственниками обычных мультфильмов.

В этой главе рассматривается как классическая двухмерная анимация на основе спрайтов, так и трехмерное моделирование и визуализация с использованием традиционного метода опорных кадров, видеофиксации движений и прочих специальных и альтернативных методов анимации. Своими рекомендациями делятся аниматоры таких компаний, как Electronic Arts, Sierra, Valve Software, Treyarch Invention, Ubi Soft и Ensemble Studios.

Тед Бэкман (Ted Backman), Valve Software

Тед Бэкман, художник и аниматор компании Valve Software, рассказывает об анимации в играх, приводя в качестве примера свою работу над сверхуспешной и восторженно принятой критиками игрой Half-Life.

Советы и рекомендации Теда Бэкмана по художественному оформлению игр приводятся в главе 10.

Тед уверен, что в первую очередь разработчик должен уделять внимание связи анимации с искусственным интеллектом, изучению справочных материалов и тщательной синхронизации. Далее он излагает свои рекомендации более подробно.

Анимация и искусственный интеллект

Анимация персонажей в Half-Life - одно из внешних проявлений искусственного интеллекта игры наряду со звуковыми и визуальными эффектами. Я имею в виду, что характер анимации персонажа может кардинально изменить его поведение. Как часто ваш герой сможет атаковать, насколько быстро будет бегать, сколько времени ему понадобится, чтобы оправиться от ран, - все это зависит в том числе и от длины соответствующих анимационных роликов. Если относительная скорость этих действий персонажа задана неаккуратно, то и поведение его будет далеко от реальности. Так что не забывайте поддерживать связь с инженером, отвечающим за создание искусственного интеллекта.

Используйте справочный материал

Одной из наиболее сложных областей анимации, безусловно, является моделирование движений живых существ, и особенно человека. Если при анимации человека вы уделите недостаточно внимания мельчайшим жестам и естественности перемещения центра тяжести, это сразу же будет бросаться в глаза. Каждый из нас легко заметит малейшую фальшь в движении других людей. Единственный способ добиться правдоподобия - наблюдать за людьми в видео- и кинофильмах.

В качестве исключительно полезного пособия Тед Бэкман рекомендует книгу Идвирда Мюйбриджа (Eadweard Muybridge) «The Human Figure in Motion» (1989, Dover Pub.).

Тед Бэкман, сверяясь с книгой Идвирда Мюйбриджа, с помощью 3D Studio MAX создает боковой вид бегущего человека. Таким образом ему удается воспроизвести естественные и правдоподобные человеческие движения. (Приводится с разрешения компании Valve Software.)

Следите за синхронизацией

Мне часто приходится сталкиваться с тем, что авторы ролика создают его от начала до конца, не возвращаясь к предыдущим кадрам для доводки мельчайших деталей и синхронизации. У меня работа над синхронизацией и отточенностью движений занимает больше времени, чем любой другой этап создания анимации. Вот несколько основных правил, которых я придерживаюсь: а) выполнять анимацию следует, перемещаясь от центра масс к краям; б) начинать нужно с главных движений, а затем добавлять более мелкие; в) нельзя успокаиваться, пока синхронизация не станет идеальной.

Как Теду Бэкману удалось добиться плавности анимации в такой игре, как Half-Life, сделав ее столь правдоподобной, не используя технологии видеофиксации движения (motion capture)? В чем преимущества примененного им каркасного способа анимации?

Главное отличие Half-Life от других подобных игр - объем данных, предоставляемый анимационному движку. Как правило, для выполнения анимации художники выделяют набор опорных элементов («скелет», или каркас) персонажа. Half-Life отличается тем, что здесь в каждом кадре отслеживается положение только опорных элементов, а не всех точек растра. Благодаря этому описание каждого кадра требует намного меньшего объема данных, что позволяет повысить качество анимации, используя то же количество памяти. Это означает, что вы можете добиться тридцати кадров в секунду вместо обычных десяти, что в результате и обеспечивает плавную и более естественную анимацию.

Тед Бэкман дает несколько советов начинающим игровым аниматорам и рассказывает, какие программные средства он использует.

Для создания качественной анимации не требуется никаких хитростей. Просто надо быть терпеливым и наблюдательным. Не довольствуйтесь хорошим результатом, стремитесь к лучшему, продолжайте работать, пока не будете абсолютно удовлетворены. Подходите к делу основательно, четко представьте себе с самого начала, чего вы хотите добиться. Разыграйте движение перед зеркалом, посмотрите его на видео. И продолжайте работать над проектом, даже если до его окончания осталась всего неделя. Единственный способ хорошо воспроизвести движение - работать в полную силу, не давая себе поблажек.

Есть один универсальный совет, который я могу дать: посмотрите на то, что вы хотите анимировать, определите, где находится центр тяжести объекта, и решите, как он будет перемещаться по отношению к ногам. В действительности любое движение происходит именно так.

Для работы я использую совершенно стандартные программы: 3D Studio MAX от Autodesk и Character Studio (плагин Autodesk/Kinetix для 3D Studio MAX). Однако ни дополнительные модули, ни мощные интегрированные программы не позволяют упростить процесс создания анимации так, как хотелось бы.

Во время работы над этой книгой Тед Бэкман занимался художественным оформлением и анимацией игры Team Fortress 2, выпускаемой компанией Valve Software.

Питер Эйкман (Peter Akemann), Treyarch Invention

Доктор философии Питер Т. Эйкман - один из управляющих компании Treyarch Invention и руководитель группы разработчиков, создавших весьма известную игру Die by the Sword (издатель Interplay). Питер - автор системы VSIM, с помощью которой выполняется большая часть анимации в играх Die by the Sword и Limb from Limb. Плавность и естественность, гарантируемые его технологией, были высоко оценены всем игровым сообществом.

Есть ли разница между анимацией в играх и анимацией в теле- и кинофильмах? О чем стоит помнить начинающему аниматору? Питер Эйкман дал по этому поводу три совета: точность движения (его управляемость) более важна, чем плавность; реакция на действие не менее важна, чем само действие; наконец, не забывайте, что оценка вашей работы на 80% будет зависеть от 20% затраченных усилий (причем, скорее всего, от тех 20%, которые пришлись на самую легкую часть работы!), будьте готовы к этому и не переживайте!

Отвечая на вопрос, как функционирует знаменитая технология VSIM и каковы ее преимущества для игр, Питер сказал:

VSIM - это новый шаг в анимации. Мы использовали в этой технологии математическую модель движения персонажа, а не предварительное его описание с помощью опорных кадров или последовательности зафиксированных движений. Модель недотягивала до абсолютного физического соответствия, но это оказалось даже хорошо, потому что она была полностью привязана к игре, для которой создавалась (Die by the Sword), и больше подходила для работы художников, нежели абсолютно строгая модель.

Большинство аниматоров знакомы с моделированием обратного движения, реализованного, к примеру, в пакете 3D Studio MAX. Для достижения конечного результата (поставить ногу на землю, дотянуться до чего-нибудь рукой) здесь используется алгоритм, заставляющий шарнирно сочлененное тело двигаться естественным образом. VSIM делает еще один шаг вперед, позволяя не только получить конечный результат, но и воспроизвести необходимые для этого промежуточные движения. В значительной степени наша система представляет собой сочетание технологии обратного движения и физического моделирования движений мускулов и суставов.

При развитии каждой технологии степень ее автоматизации неминуемо возрастает. Однако вряд ли технологии оставят аниматоров без работы. Скорее наоборот - позволят облегчить их труд и повысить качество результатов...

Питер Эйкман из компании Treyarch Invention говорит: «Мы надеемся, что VSIM и аналогичные технологии могут быть развиты до такой степени, что будут включены в набор инструментов каждого аниматора, предоставляя мощные средства для анимации». Система VSIM применялась при создании игры Die by the Sword, скриншоты из которой вы видите. (Приводится с разрешения компании Interplay Productions.)

По словам Питера, большая часть анимации в компании Treyarch Invention создается с помощью их собственной разработки Move Editor - виртуальной студии для фиксации движений персонажей, конструируемых по технологии VSIM. «Да, и еще используется уйма загружаемых текстовых файлов с параметрами, что не очень удобно», - признает Питер Эйкман. Традиционная анимация на основе опорных кадров (для неинтерактивных видеофрагментов) делалась с помощью программы 3D Studio (а не 3D Studio MAX) сотрудником компании Interplay Майком Маккарти (Mike McCarthy). «Я считаю, что 3D Studio - вполне подходящая программа для создания заставок между уровнями. К тому же она недорогая, так как считается устаревшей», - продолжил Питер.

«Лучшее, что я могу посоветовать: размышляя над анимацией, постарайтесь представить себе математические модели, описывающие движение. Именно в этом заключался источник вдохновения при создании технологии VSIM и игры Die by the Sword», - заключил наше интервью Питер Эйкман.

Ротоскопия - еще один вид двух- или трехмерной анимации, правда, не так часто использующийся. Суть метода: актеры снимаются на кинопленку, а затем - поверх полученного изображения - проводится анимация. Именно по этой технологии была создана великолепная игра The Last Express компании Broderbund.

Знаменитый квест The Last Express (Broderbund) создан с помощью метода ротоскопии, при котором сначала снимается фильм с актерами, а затем поверх него выполняется анимация. (Приводится с разрешения компании The Learning Company, Inc. Все права защищены.)

Жан-Франсуа Малуэн (Jean-Francois Malouin), Ubi Soft

Жан-Франсуа Малуэн, художественный директор располагающейся в Монреале канадской штаб-квартиры компании Ubi Soft, в свое время работал над серией детских игр Playmobil, а в момент написания этой книги трудился над новым проектом, содержание которого пока не разглашается. Как и Питер Эйкман из Treyarch Invention, Жан-Франсуа обращает внимание читателей на принципиальную разницу между анимацией в играх и других видах развлекательной индустрии - например на телевидении и в кино.

Аниматор, работающий для игры, должен иметь в виду, что игрок будет управлять его персонажем (если это главный герой) или хотя бы взаимодействовать с ним (если это второстепенный персонаж).

У каждой игры свой собственный темп, набор персонажей и способ взаимодействия с окружением, так что единой методики анимации, пригодной для всех случаев, нет. В некоторых играх допустимо использование анимации с большим числом кадров - так можно добиться максимальной естественности, но обычно аниматоры обходятся минимальным количеством кадров. Это улучшает управление главным героем и положительно сказывается на «реакции» других персонажей. Лично я считаю, что разработчики игр, особенно трехмерных, не уделяют этому должного внимания.

Развлекательность важнее реализма

В качестве примера хорошей анимации, далеко не всегда придерживающейся законов реального мира, Жан-Франсуа привел игру Mario 64 компании Nintendo.

В первую очередь игра любопытна из-за особенностей управления главным персонажем, за которым просто забавно наблюдать. Если бы, анимируя движения Марио, авторы придерживались стандартных принципов, вряд ли игра получилась бы столь удачной. Весьма оживляют действие, например, его выдающиеся способности в области прыжков как в длину, так и в высоту. Аниматорам удалось сделать Марио исключительно живым и подвижным, но в то же время его движения не настолько быстры, чтобы это мешало их нормальному восприятию.

Впрочем, добавил Жан-Франсуа, для создания драматического эффекта аниматорам стоит время от времени использовать резкие изменения позы персонажа. Однако это не обязательно верно для всех игровых жанров.

Справа - пример неудачной анимации последствий нанесенного удара, слева - удачной. Анимация справа не годится, потому что она недостаточно выразительна: игроку требуется больше времени, чтобы понять, что же произошло. (Приводится с разрешения компании Ubi Soft, Inc.)

Понимание действий персонажа

«В распоряжении аниматора не так уж много кадров, чтобы прорисовать то или иное движение, поэтому необходимо сосредоточиться на том, что он хочет донести до игрока», - считает Жан-Франсуа Малуэн.

Игроку необходимо знать, что происходит с главным героем, хотя бы потому, что главный герой - это и есть он, игрок. К тому же он должен знать, что делают окружающие его люди, существа и объекты. Если игрок ударил врага, он должен сразу это видеть; не стоит давать повод для каких-либо сомнений на этот счет. Если в водоеме есть сильные течения, отразите это, чтобы игрок не надеялся, что ему придется плыть по спокойной воде. Пусть для него не окажется неприятной неожиданностью необходимость быстро двигаться, чтобы выжить. За этими моментами стоит следить особенно внимательно, ведь от них в значительной степени зависит взаимодействие между игроком и компьютером.

Я полагаю, что самое важное - не потерять интерес к игре, над которой работаешь. Необходимо помнить, что все, что делает аниматор, влияет на настроение игрока. У команд, которым нравятся создаваемые ими игры, обычно все и получается. Просто у них есть стимул.

Какие программы используют Жан-Франсуа Малуэн и его коллеги при создании анимации для игр компании Ubi Soft? Помимо ряда собственных разработок (для внутреннего употребления) они имеют дело со стандартными пакетами 3D Studio и 3D Studio MAX (все подробности об этих программах вы найдете на веб-сайте www.autodesk.com). Жан-Франсуа настоятельно рекомендует аниматорам, относящимся к своей работе действительно серьезно, побольше практиковаться в классической двухмерной анимации на бумаге или компьютере.

Скотт Исли (Scott Easley), Oddworld Inhabitants

Скотт Исли является старшим аниматором всемирно известной компании Oddworld Inhabitants, где работает со дня ее основания. В 1994 году Скотт дважды становился лауреатом премии Эмми (Emmy) за анимацию и создание телевизионных рекламных роликов. А в 1995 году он сделал для Marvel Comics первый плакат, в создании которого была использована компьютерная графика.

Скотт Исли полагает, что процесс игры, геймплей, важнее всего, даже анимации.

Дизайнер должен думать о том, как создать хорошую игру. Не следует злоупотреблять графикой и анимацией просто «для красоты». Мы нередко стараемся делать персонажей «крутыми» или сексуальными, но не это должно быть главной целью работы. Язык образов должен быть подчинен сюжету - это общее правило как для кино и рекламных роликов, так и для компьютерных и видеоигр. Если в очередной демо-версии я снова увижу хромированного монстра, то непременно выброшу телевизор в окно. Покажите мне сюжет с анимационными вставками, но при этом без всякой вращающейся камеры.

Не забывайте, что самое важное - донести информацию до адресата. К сожалению, возможности языка образов часто дурманят людей.

Мы спросили Скотта, как ему удалось добиться таких блестящих результатов в играх Oddworld: Abe's Oddysee и Oddworld: Abe's Exoddus, и попросили поделиться какими-нибудь секретами или методиками. Вот что он ответил:

Нет никаких секретов, нет никакой волшебной палочки или кнопки «Сделать автоматически». Просто изучайте движение как можно усерднее, следуя принципам, предложенным сотрудниками студии Диснея или Максом Флейшером (Max Fleischer). Просмотрите фотографии из книги Идвирда Мюйбриджа (Eadweard Muybridge) и возьмите их за основу, чтобы сохранить в ваших программах те же пропорции. Сделайте своему персонажу «кожу» из прямоугольников. Постарайтесь обойтись обычной блочной моделью, чтобы полностью сконцентрироваться на ее движении. Изучите ее со всех сторон, заставьте полноценно работать. Если, создав фрагмент ходьбы из 12 кадров, вы обошлись без недели изнурительного труда, значит, вы относитесь к работе более безразлично, чем парень, которого наймут вместо вас. Вот и все.

Изучайте движение, как это делаем все мы, занимайтесь этим каждый день. Понаблюдайте за жестикуляцией парочки на другой стороне улицы или в окне напротив. Любят они друг друга, ненавидят или просто безразличны друг другу? Старайтесь сначала уловить более выразительные вещи, а понимание тонкостей со временем придет само.

Какие программы использует Скотт Исли? Применял ли он метод видеофиксации движения, работая над своим Эйбом (главным героем игр серии Oddworld)?

Я твердо убежден, что хотя метод видеофиксации движения и нашел применение э футбольных и других спортивных симуляторах, его использование не дает полностью раскрыться способностям аниматора. Это всего лишь способ быстро произвести впечатление на свою семью, друзей и прочих непосвященных, но на самом деле это ведь не анимация, а, в лучшем случае, просто редактирование уже существующих данных.

Тем, кто занимается анимацией для игр, наверняка будет полезно заглядывать иногда в группы новостей Usenet сотр.graphics.animation и rec.arts.animation. Там работают интерактивные доски объявлений, где всегда можно найти единомышленников.

Вэнс Кук (Vance Cook), Sierra Sports

Разрабатывая симуляторы гольфа уже около десяти лет, Вэнс Кук не только наблюдал, как прогрессировала анимация в спортивных играх, но и сам принял заметное участие в этом процессе. Прежде чем основать собственную компанию Headgate, Inc. (впоследствии приобретенную Sierra), Вэнс работал над знаменитой серией симуляторов гольфа Links в компании Access Software.

Вэнс сразу же взялся объяснять, почему анимация персонажа - сложная задача.

Воспроизвести человеческие движения труднее всего, потому что каждый точно знает, как они обычно выглядят, и легко замечает даже малейшие отклонения. Наши персонажи, игроки в гольф, могут совершать сотни различных движений, но ничто не сравнится по сложности с ударами в гольфе. Я считаю, что это одно из наиболее изученных движений в спорте.

Вэнс Кук и его компания использовали метод видеофиксации движения в игре PGA Championship Golf. He такая уж это и простая работа, «захватывать» движение...

Мы направляемся в студию с парой актеров, режиссерами, способными снять нужные кадры, и сценарием на несколько сотен движений. Через неделю возвращаемся донельзя утомленные. После сеансов в студии работа, по сути, только начинается. Впереди у нас еще много недель монтажа.

Видеофиксация движения (motion capture) - это процесс, при котором движение реально существующего объекта (обычно человека) фиксируется (каким-либо образом запечатлевается и вводится в память компьютера), а затем накладывается на созданный компьютером объект.

Вэнс Кук предупреждает о невозможности воспроизведения человеческих движений без применения метода видео фиксации. Если это оказывается слишком дорого, воспользуйтесь библиотекой движений, как более дешевым вариантом. Обратите внимание на сетку из полигонов (многоугольников) для женщины-игрока и покрывающие ее текстуры на снимке вверху. Внизу - визуализация удара того же персонажа из игры PGA Championship Golf, выпуск 1999 года. (Приводится с разрешения компании Sierra Sports.)

Мы потратили немало времени на попытки обойтись без видеофиксации движений, но ни к чему хорошему не пришли. Затем родилась идея описать удар математическими формулами. Мы смогли заставить тело персонажа воспроизводить основные движения, но вскоре выяснилось, что эти движения ни в одной точке не были даже близки к реальным, ибо учесть все мелкие, почти незаметные особенности так и не удалось.

Можно ли зайти слишком далеко в стремлении к реализму? Ответ Вэнса Кука:

Думаю, что это не проблема - сделать игру слишком реалистичной. Во многих играх предпринимаются попытки воспроизвести все события, существующие в реальном мире. Я полагаю, что если вы начнете моделировать все отрицательные стороны действительности, игра станет чересчур реалистичной. В том же гольфе, если мы начнем принуждать вас составлять расписание игр на отдельных лунках и искать улетевший мяч, скажем, посреди леса, то, по-видимому, это будет уже слишком. Впрочем, я думаю, настолько основательно перестараться с реализмом тоже надо уметь. В конце концов, некоторые ограничения накладываются жанром, в котором вы работаете.

Игра компании Acclaim WWF: Attitude, по слухам, содержит целых 400 кадров с фиксированными движениями! У Acclaim есть студия для работы с видеофиксацией движения в городке Гленкоув, штат Нью-Йорк.

К несчастью, у многих начинающих аниматоров нет возможности (или денег), чтобы научиться работать с фиксацией движения, из-за ограниченного числа доступных студий и их ненормально высоких расценок.

Эван Хирш (Evan Hirsch), EA Sports

Эван Хирш, «гуру» в области видеофиксации движения, работает в канадском отделении компании Electronic Arts в Барнаби (Британская Колумбия, неподалеку от Ванкувера). Это отделение полностью отдано под студию для работы с видеофиксацией движения.

«Прежде всего, - говорит Эван, - следует помнить, что видеофиксация движения - это просто еще один метод анимации, сам по себе он не обеспечивает ни качественной анимации, ни хорошей игры». Далее Эван рассказывает о различиях двух вариантов этого метода и объясняет, какой из них предпочитают разработчики EA Sports и почему.

При оптическом методе фиксации движения применяется тригонометрическая съемка с помощью маркеров, прикрепленных к телу актера. Каждый маркер при получении данных используется как одна из точек треугольника наряду с двумя устройствами, фиксирующими его положение.

Магнитный метод проще, но при этом актер должен быть с головы до ног обмотан проводами. Очевидно, что при выполнении быстрых и сложных движений это небезопасно.

Компания ЕА использует оптический метод фиксации движения, потому что он позволяет получить более полные данные. На человека обычно устанавливается от двадцати до тридцати маркеров.

Маркеры наклеены на суставы и другие важные точки тела персонажа. При оптической фиксации движения тонки между маркерами вычисляются компьютером; при магнитной фиксации информация о положении и вращении частей тела снимается непосредственно с прибора.

Итак, Эван Хирш предпочитает метод видеофиксации движения, а не более традиционную анимацию по тем же причинам, что и Вэнс Кук?

Преимущества заключаются в следующем. Во-первых, это наиболее простой и быстрый способ передать данные в один из наших «Силиконов» (рабочие станции Silicon Graphics используются в компании ЕА для выполнения всех работ по анимации). Во-вторых, при этом улавливаются мельчайшие нюансы человеческих движений, придающие им естественность и выразительность. Эти особенности сохраняются и в самой игре.

В заключение Эван напоминает, что метод видеофиксации движения не панацея, он не способен сделать за дизайнера или аниматора всю работу.

Никто не говорит, что этот метод отменяет профессию аниматора. Фиксация движения - это всего лишь инструмент, и все определяется тем, как вы его применяете. Так как метод очень дорог, вы должны предварительно подготовиться: составить список движений, которые необходимо зафиксировать, разработать подробные инструкции и как следует все прорепетировать.

Никто не сможет оценить качество игры лучше ее игроков, так что загрузите последние версии Triple Play Baseball, NHL Hockey, Madden NFL, FIFA или NBA Live и обратите внимание на естественность и плавность анимации.

Брэд Кроу (Brad Crow), Ensemble Studios

Мы уже встречались с этим выдающимся художником в главе 10, где он объяснял некоторые методики художественного оформления игры. Здесь же сотрудник компании Ensemble Studios Брэд Кроу дает советы начинающим аниматорам. По мнению Брэда, при анимации персонажей особое внимание следует уделить деталям - или их отсутствию.

Реалистичность анимации персонажа главным образом зависит от точности воспроизведения трудноуловимых движений или жестов. Мы все специалисты по движениям человеческой фигуры, потому что изучаем их на своем собственном опыте. Именно этот повседневный опыт позволяет нам, наблюдая цифровую анимацию персонажа, сразу же видеть ее изъяны. Другой вопрос, что порою бывает трудно понять, какие именно мелкие детали, ставшие причиной проблем, были упущены при анимации...

В настоящее время в компании Ensemble Studios в качестве главной анимационной программы используется 3D Studio MAX. Игра Age of Empires, однако, была закончена с помощью 3D Studio, версии 4, так как основной цикл разработки завершился до выпуска 3D Studio MAX.

Поклонники Age of Empires, этого не видел никто! Вверху - фигурка всадника, анимированная с помощью программы 3D Studio MAX. Внизу - та же самая фигурка, в процессе перехода от эскиза через каркасное представление к окончательно прорисованному изображению. (Приводится с разрешения компании Ensemble Studios, Inc.)

В заключение Брэд Кроу сказал, что добился плавности движений людей, животных и оружия в играх Age of Empires и Age of Empires: The Rise of Rome, изучая кинофильмы и книги, а еще он «иногда сам разыгрывал движения, чтобы уловить все детали».

Анимация с помощью стоп-кадров - способ анимации посредством покадровой съемки. Эта классическая методика используется в играх нечасто, а идеальным примером ее применения является игра The Neverhood Chronicles компании DreamWorks Interactive.

Игра The Neverhood Chronicles - идеальный пример анимации методом стоп-кадров. Чтобы изобразить движение пластилиновых фигурок, их понемногу передвигали, фотографируя каждый кадр. (Приводится с разрешения компании DreamWorks Interactive, Inc.)


Интерфейс пользователя и управление игрой

Глава 12

Интерфейс пользователя и управление игрой

Игровая графика, дизайн уровней, анимация персонажей, искусственный интеллект - все это довольно субъективные вещи, чья реализация в играх может по разному оцениваться специалистами. Однако в одном все знатоки компьютерных игр обычно единодушны: неудачный интерфейс пользователя (ИП) может легко погубить любую игру, несмотря на все ее прочие достоинства.

Работая над книгой, мы задали целому ряду разработчиков один и тот же вопрос: верно ли, что успех или провал игры определяется ее интерфейсом? Большинство наших собеседников сразу согласились, что плохой интерфейс портит всю игру. Они также пришли к единому мнению, что если игра плоха, ее уже ничто не спасет, даже выдающийся интерфейс. Тем не менее нельзя забывать, что создание пользовательского интерфейса - один из важнейших этапов разработки, которым, к сожалению, часто пренебрегают.

Обратите внимание, что интерфейс игры, в сущности, состоит из двух частей. Первая - это интерфейс оболочки, представляющий собой набор различных меню: с его помощью настраиваются звук и изображение в игре, переназначаются клавиши управления, запускается сетевой режим, загружаются сохраненные игры, выполняется выход из игры и т.п. Вторая часть - это внутриигровой интерфейс, то есть то, что отображается на экране во время игры.

Не меньшее значение для игры имеет и система управления. Ее нередко путают с интерфейсом пользователя из-за их тесной взаимосвязи. Часто бывает, что игрок не может справиться с управлением персонажем (или юнитом, или машиной, или его не устраивают предлагаемые игрой положения камеры). В других случаях управление организовано прекрасно, но объекты на экране реагируют на команды игрока слишком медленно или неточно.

Многие согласятся, что труднее всего сделать хороший интерфейс для спортивных игр. В случае командных игр (футбол, баскетбол, хоккей) дело осложняется еще и тем, что нужно обеспечить возможность выбора любого игрока для управления, а в некоторых играх и вовсе - одновременно давать указания остальным членам команды. Ниже мы вернемся к командным играм, а пока давайте рассмотрим спортивные симуляторы с одним персонажем. Здесь тоже есть свои проблемы.

Вэнс Кук (Vance Cook), Sierra Sports

На наш вопрос о значении ИП для симуляторов гольфа отвечает Вэнс Кук, ведущий дизайнер игры PGA Championship Golf 1999 Edition (выпущена компанией Sierra Sports).

Хороший интерфейс важен для любых программных продуктов, а не только для игр. Выдающиеся игры должны быть первыми по всем показателям: интерфейсу оболочки, внутриигровому интерфейсу, графике, игровым настройкам, балансу игровых параметров, сюжету и т.д. Провал в исполнении хотя бы одного из этих элементов способен серьезно ослабить игру в целом. Нет смысла рассуждать о том, какая из частей игры важнее остальных. Разумеется, игровой интерфейс в любом случае должен быть исполнен безукоризненно.

Выражаясь образно, интерфейс - это точка соприкосновения колес и дороги, то, что связывает игру и пользователя.

Интерфейс оболочки

Настройки игры, по мнению Вэнса Кука, лучше всего оформить в виде отдельного меню или набора экранов в оболочке игры. В случае большого количества настроек это не даст игроку запутаться. «Показывайте только ту информацию, которая необходима в данный конкретный момент. Если определенный выбор исключает другие варианты, покажите их ненужность, затенив их или вовсе убрав с экрана».

Игровой интерфейс

«У каждой игры свой подход, - говорит Вэнс Кук, - но часто приходится сталкиваться с одной и той же проблемой: как увеличить размер игрового окна, сохранив при этом доступ ко всем командам интерфейса». Иначе говоря, дизайнеры пытаются одновременно скрыть элементы интерфейса, чтобы освободить экран, и оставить их легкодоступными.

Спрятать элементы интерфейса не составит никакого труда, если только вы не задумываетесь о том, как много действий должен сделать игрок, чтобы осуществить в игре то или иное движение. Точно так же ничего не стоит оставить все элементы интерфейса доступными, если не думать о том, какую часть экрана вы при этом займете. Поиск баланса между этими требованиями - постоянная забота дизайнеров. В начале проекта определите соотношение между реальной площадью экрана и площадью, отведенной под интерфейс. Разделите элементы интерфейса на две группы: постоянно используемые и те, что требуются реже. Первые должны быть доступны максимум за два шага (под шагом здесь понимается щелчок мышью, перетаскивание объекта мышью или нажатие клавиши). Вторые могут быть скрыты за кнопкой «Параметры» или соответствующей пиктограммой.

Рассмотрим на примере PGA Championship Golf 1999 Edition, как можно структурировать ИП по его функциональности и внешнему виду. По словам Вэнса Кука, игровой интерфейс этой игры состоит из четырех частей.

1. Интерфейс направления и силы удара расположен сразу под игроком и требует только одного шага.

2. Группа информации об ударе вынесена в правый нижний угол экрана. Все ее сведения доступны без выполнения каких-либо действий (вы всегда знаете расстояние между мячом и лункой и проч.). При желании можно получить более подробную информацию по тому или иному параметру, всего лишь щелкнув мышью (пример: вам надо узнать перепад высот между мячом и лункой - для этого достаточно кликнуть мышью на поле расстояния).

3. Часто используемые элементы ИП сгруппированы в левом нижнем углу. К ним относится выбор клюшки или настройка нестандартного удара. Такие действия требуют одного или двух шагов, и соответствующие элементы размещены для удобства рядом с фигуркой игрока.

4. Функции, необходимые реже (например поиск флажка), вызываются при нажатии на кнопку «Параметры», которая расположена в левом нижнем углу экрана. При этом отображаются только те параметры, которые доступны для выбора в данный момент. Для этой группы функций требуется один дополнительный шаг, но это не столь существенно, так как кнопка занимает мало места и нажимать ее приходится нечасто.

Вся информация, необходимая для выполнения удара, находится справа от игрока в гольф - не много, не мало, а в самый раз. (Использовано с разрешения компании Sierra Sports, Inc.)

Интерфейс управления игрой

Вэнс Кук замечает, что каждая игра имеет уникальное управление, а значит, советовать что-либо на эту тему или формулировать общие правила довольно трудно.

Тем не менее именно здесь зачастую рождается настоящее волшебство игры. Обычно применяется несколько вариантов управления: с помощью мыши, клавиатуры, джойстика, геймпада, руля и педалей. Есть и другие возможности, но большинство дизайнеров ограничиваются этим набором, чтобы сделать игру более доступной. Решите, какие устройства или их комбинации больше всего похожи на инструменты или системы управления в реальной ситуации, смоделированной в игре. Впрочем, в большинстве случаев оказывается, что ни один из компьютерных контроллеров и рядом не лежал с реальным аналогом.

Именно с этим мы столкнулись, разрабатывая систему управления для гольфа. Мы выбрали мышь, поскольку ее движения больше всего напоминают реальные движения клюшкой. Игрок может управлять траекторией и скоростью движения клюшки. Это дает нам возможность имитировать как очень мягкие, так и очень жесткие удары. Появляется возможность добавления бокового вращения (крученые и резаные удары), когда мышь соскальзывает в сторону от прямого направления движения. Наконец, это позволяет имитировать промахи по мячу, если мышь не возвращается в точку начала движения.

Особое внимание Вэнс Кук обращает на то, что качество управления игрой сильно сказывается на эффекте погружения:

Дайте пользователю «срастись» с игрой. Пусть он ощущает устройства управления как естественное продолжение собственного тела и манипулирует ими интуитивно. Любые напоминания о том, что это всего лишь игра, резко снижают удовольствие от процесса.

Вэнс утверждает, что симуляторы гольфа могут послужить примером того, как на практике выполняются эти требования. В качестве образца он, естественно, предлагает собственную игру:

Мои конкуренты могут со мной не согласиться, но я уверен, что задержка между движением мыши и началом движения персонажа на экране значительно снижает впечатление. В PGA Championship Golf фигурка игрока начинает движение одновременно с вами, а траектория движения клюшки аналогична траектории мыши. Если вы сдвигаете мышь вправо или влево, игрок смещает клюшку внутрь или наружу от направления замаха.

Как отмечает Вэнс Кук, у каждого из нас свое отношение к интерфейсу и управлению игрой, поэтому многие разработчики предоставляют пользователю возможность самостоятельной настройки управления. Так, в большинстве 3D-шутеров и симуляторов есть возможность выбрать, какую именно информацию надо выводить на экран; в играх почти всех жанров можно переназначить клавиши управления, а также определить «горячие клавиши» или макросы. Словом, обязательно разрешите игроку настраивать игру под себя!

«Вы должны постараться полностью погрузить пользователя в игру, заставить его забыть обо всем и слиться с персонажем на экране», - заключает Вэнс Кук.

Советы Вэнса Кука по интерфейсу меню и оболочки вполне применимы к играм любых жанров. Обратите внимание на упрощенный дизайн окна настройки знаменитой ролевой игры Baldur's Gate, разработанной Bio Ware и выпущенной компанией Interplay. (Использовано с разрешения компании Interplay Productions.)

Скотт Opp (Scott Orr), EA Sports

Проработав много лет в компании EA Sports, сначала дизайнером, затем продюсером и исполнительным продюсером, Скотт Орр прекрасно понимает важность хорошего ИП. Вот некоторые из игр и сериалов, над которыми ему приходилось трудиться: Madden Football, NHL Hockey, Andretti Racing, NASCAR Racing и NCAA College Football.

Скотт считает, что все гениальное должно быть просто.

Всем известно, что игроки не читают инструкций. Если они не могут быстро разобраться в игре, то разочаровываются в ней и ищут другую. Если же они не могут сразу добиться каких-то успехов, они откладывают игру и, само собой, снова ищут игровое счастье на стороне. Поэтому никогда не жалейте время на разработку пользовательского интерфейса и управления игрой. Добиться здесь успеха не так легко, как кажется, учитывая, что в спортивных играх для ПК и 32-битных приставок задействовано просто-таки огромное количество параметров.

Одно дело сказать, что надо постараться сделать простой интерфейс, а совсем другое - осуществить это на практике. Как с этим в компании ЕА Sports? Скотт Орр отвечает:

Работая над Madden 2000, я стремился, во-первых, сократить число действий в аркадном режиме, необходимых для подбора команды и начала матча, до одного - двух нажатий кнопки, а во-вторых - максимально урезать количество меню, которые приходится открывать в режиме симулятора. Мы потратили немало времени, стараясь упростить меню без уменьшения числа параметров, доступных пользователю.

ЕА Sports переделала интерфейс игры Madden NFL '99 так, чтобы все действия выполнялись одним нажатием кнопки. Это позволяет новичку начать игру немедленно, почти без обучения. (Использовано с разрешения компании ЕА Sports.)

Что касается управления игрой, Скотт Орр считает, что здесь работают те же принципы, что и при создании интерфейса: все упирается в простоту и интуитивность.

В качестве образца можно привести аркадные игры: они, как правило, используют крайне простые и понятные системы управления. Просмотрите аналогичные спортивные симуляторы, определите, существуют ли общепринятые стандарты оформления ИП и управления игрой, которых стоит придерживаться. Например, если самая популярная игра для конкретного вида спорта использует клавишу «X» в качестве кнопки «Действие», то вам, видимо, следует сделать то же самое, поскольку к этому привыкли игроки. Подобные приемы упрощают адаптацию и позволяют игроку быстрее войти в игру.

«Наконец, система управления должна работать вместе с искусственным интеллектом», - заключает Скотт Орр. Вместо того чтобы использовать для выполнения трех различных движений три разные кнопки, Скотт советует свести все к одной - и пусть искусственный интеллект сам выберет правильное действие в зависимости от ситуации (Скотт Орр и его коллеги из ЕА Sports называют это «контекстно-зависимым искусственным интеллектом»). «Отличное решение: игра по-прежнему многообразна, а управление все так же элементарно. Само собой, все это справедливо лишь при наличии хорошего искусственного интеллекта...»

Марк Обейнел (Marc Aubanel), EA Sports

Марк Обейнел - продюсер знаменитых футбольных серий FIFA и World Сир для ПК, PlayStation и Nintendo 64. Он работает в канадской студии Electronic Arts в Барнаби (провинция Британская Колумбия).

Почти все рекомендации Марка касаются футбольных симуляторов, поскольку именно на них он тратит все свое время, и рассказывает он в основном о проблемах разработки системы управления. Следует иметь в виду, что в большинстве случаев его советы применимы и к другим командным спортивным играм.

Управление камерой или персонажем?

В ЕА Sports всегда выбирают управление камерой, а не персонажем. Это означает, что при нажатии кнопки «вниз» фигурка игрока перемещается к нижней границе экрана. Напротив, если бы игра управлялась с точки зрения персонажа, то при нажатии кнопки «вниз» изображение на экране двигалось бы вниз относительно персонажа.

По мнению Марка, управление камерой интуитивно более удобно для пользователя, если только в игре не применяется вид от первого лица (когда вы видите игру глазами персонажа). «В FIFA и других футбольных симуляторах применяется именно такой подход, и мне кажется ошибочным разрабатывать управление относительно игрока в командной игре, которую мы привыкли видеть со стороны». Единственным исключением является тот момент, когда игрок с мячом выходит к воротам, - только тогда происходит переключение на управление, связанное с персонажем, и появляется возможность прицелиться и ударить куда надо.

Простота и совершенство

Другая проблема футбольных симуляторов: игроку приходится контролировать очень многое, а способ управления должен оставаться простым и интуитивно понятным.

Наша основная цель - имитировать сложность реальной игры (к примеру, учесть агрессивность соперников и изменение скорости бега футболистов), но в то же время мы просто обязаны предоставить простой и удобный интерфейс управления.

Мы вышли из положения с помощью искусственного интеллекта: программа сама определяет, какое из нескольких действий подходит для конкретной ситуации. Например, если вы хотите отобрать у соперника мяч с нарушением правил и при этом находитесь от него достаточно близко, то можете скрытно толкнуть его или ткнуть локтем; если же расстояние между вашим игроком и игроком противника превышает полтора метра, можно выполнить подкат. В любом случае используется одна и та же кнопка управления, которая работает по-разному в зависимости от сложившейся на экране ситуации. Точно так же происходит атака на ворота противника. Удар по пустым воротам будет отличаться от удара по воротам с вратарем или по тем же воротам, но с большого расстояния. Именно такие возможности и делают игру более реалистичной. Другими примерами являются особые движения, например удар в прыжке. Программа сама определяет, какое движение - головой или грудью - необходимо выполнить в конкретной ситуации. Вместо того чтобы бить по мячу головой в прыжке, игрок может ударить мяч в падении через спину, если находится спиной к воротам. Что дает такой метод управления? При минимуме управляющих клавиш достигается максимум движений футболистов.

Интерфейс игры FIFA '99 компании ЕА Sports контекстно-зависим: футболисты будут по-разному вести себя в зависимости от ситуации на поле. При этом игроку нет никакой необходимости учить дополнительные команды управления. (Использовано с разрешения компании Electronic Arts, Inc.)

Далее Марк Обейнел предлагает два совета разработчикам ИП и системы управления.

Доверяй (себе), но проверяй

«Реализуя свои идеи в интерфейсе, не забывайте учитывать пожелания других людей», - рекомендует Марк Обейнел. Самый правильный способ узнать, чего хочет пользователь, - посмотреть, как люди играют в вашу игру. При этом чем больше тестеров у вас будет, тем лучше. Нашу FIFA тестировали 60 человек, и мне пару раз приходилось отказываться от своего мнения в пользу мнения большинства. Повторюсь: несомненно, верьте себе, придерживайтесь первоначального замысла, но при этом не забывайте, что игра создается для игроков.

Разумно экспериментируйте

«Вот еще один важный совет: экспериментируя с управлением в спортивных играх, всегда оглядывайтесь на опыт коллег по цеху, на уже выпущенные игры. И, конечно же, не забывайте проверять свои новинки на большом количестве тестеров». Марк признает, что управление в футбольных симуляторах все еще далеко от совершенства.

Как убить двух зайцев

Заключительная часть советов Марка Обейнела в большей степени касается именно футбола и других командных симуляторов. Если говорить о той части ИП, которая не связана с управлением игроками, наиболее удобно максимальное удаление камеры: играть при этом проще, так как видны все игроки обеих команд. Впрочем, большое количество игроков на экране снижает скорость вывода графики, поэтому без компромиссов здесь не обойтись.

Многие любят максимально приближать камеру, чтобы оценить графику и анимацию, но это серьезно нарушает управление, так как часть команды находится вне поля вашего зрения. Поэтому, чтобы убить двух зайцев, в играх серии FIFA (как, впрочем, и в других играх ЕА Sports) принято показывать крупным планом отдельные фрагменты игры - после забитого гола, пенальти и т.п. Это увеличивает общий сценический эффект, а также грамотно заполняет игровые паузы.

В 9-й главе Марк Обейнел рассуждаете проблемах искусственного интеллекта и его применении в спортивных играх.

Ричард «Лорд Бритиш» Гэрриот (Richard «Lord British» Garriott), Origin Systems

Ричард Гэрриот, больше известный игрокам всего мира как Лорд Бритиш, - легенда индустрии, один из ее пионеров, автор выдающейся серии ролевых игр Ultima. Вышедшая в самом конце 1999 года Ultima:Ascension стала девятой игрой серии (не считая второго выпуска Ultima VII).

Ричард Гэрриот считает, что при создании интерфейса каждый разработчик придерживается собственных взглядов, но лично для него существуют два основных принципа, которым он следует в своем творчестве.

Старый друг лучше новых двух

«Чем более знакомым кажется интерфейс пользователю, тем лучше», - говорит Лорд Бритиш. Первая задача при разработке состоит в том, чтобы сделать, пусть не идеальный, но максимально привычный интерфейс.

Игроки привыкли к интерфейсу Windows 95/98 и его реакции на правую/левую кнопки мыши. Не то чтобы использование подобного интерфейса было обязательным, просто, повторюсь, это вошло в привычку. Если интерфейс вашей игры чем-то напоминает навигацию в Windows или заимствует из этой ОС какие-то функции, игроку будет проще разобраться в нем.

Синдром экскаваторщика

Второй принцип логически вытекает из первого, и к его выполнению должен стремиться любой разработчик. Речь идет о слиянии игрока со своим воплощением на экране. Лорд Бритиш называет это состояние «синдромом экскаваторщика». После привычности на втором месте стоит задача создания настолько прозрачного интерфейса, чтобы игрок вообще перестал его замечать.

Надеюсь, вы знаете, что такое экскаватор? Ну, это машина, которая копает землю... Так вот, через некоторое время машинист экскаватора перестает думать о том, как наклонить ковш и зачерпнуть землю, - он просто делает это.

Лорд Бритиш объясняет, что хороший интерфейс - это то, что позволяет игроку чувствовать себя персонажем на экране. В конце концов, девиз родной для Ричарда Origin Systems (увы, уже не родной, Ричард покинул компанию в начале 2000 г. - Примеч. ред.) - «Мы создаем миры».

Чтобы достигнуть такого уровня погружения в игру, вы должны максимально упростить интерфейс, но, понятно, без утраты им ключевых функций. Лорд Бритиш рассказал нам, что эта немудреная истина пришла к нему с годами работы над серией Ultima, он вспоминает, как сложность интерфейса поначалу росла от версии к версии, а затем снова стала уменьшаться.

В Ultima 1 (для компьютера Apple II) было всего лишь полдюжины команд - движение на север, юг, запад и восток, плюс пара клавиш с буквами («S» для сохранения игры и «L» для загрузки сохраненной игры). Задачи персонажей усложнялись с развитием серии. В Ultima VI все без исключения буквы на клавиатуре что-то означали, поэтому иногда определение той или иной клавиши уже не было очевидным: скажем, я использовал «Z» для отображения статистики героев, так как «S» была занята функцией сохранения. Проблема состояла в том, что нужно было добавлять все новые и новые команды, поэтому клавиши пришлось заменить метакомандами (к примеру, слово «use» позволяло открыть дверь или зажечь факел). В дальнейшем этот интерфейс, использующий существительные и глаголы, превратился в пять пиктограмм Ultima VII, но все действия оставались пока двухшаговыми, так как после нажатия кнопки «говорить» вы должны были выбрать своего собеседника. Игроку приходилось выполнять каждое действие за два шага, так что до «синдрома экскаваторщика» было еще далеко. В Ultima VIII и IX (Ascension) все действия выполняются уже одной командой с помощью мыши. Программа теперь сама определяет, что хочет сделать игрок. Например, если на экране есть компьютерный персонаж и вы хотите с ним поговорить, вы делаете это одним нажатием кнопки. Если ваш меч обнажен, герой начнет сражаться. Интерфейс стал контекстно-зависимым, а следя за формой курсора, вы можете проверить, действительно ли компьютер собирается сделать именно то, что вам нужно.

Лорд Бритиш упростил интерфейс игры Ultima: Ascension, сделав его интуитивно понятным. (Приводится с разрешения компании Origin Systems, Inc.)

По мнению Лорда Бритиша, интерфейсы, которые используются сейчас, технически можно было сделать и 20 лет назад, но было необходимо пройти полный цикл развития.

Рагнар Шейерман (Ragnar Scheuermann), Wombat Games

Наш следующий собеседник, Рагнар Шейерман, работал в Origin Systems в качестве инженера-программиста над Ultima: Ascension и Ultima Online, но затем покинул эту славную компанию, чтобы перейти во вновь созданную Wombat Games, Inc., где он одновременно является дизайнером, программистом и вице-президентом.

Рагнар согласен со своим бывшим начальником Ричардом Гэрриотом: «Если сомневаетесь, подражайте Windows: эта система знакома большинству людей». Однако отличие хорошего интерфейса от плохого заключается не только в привычности. «Лишь в немногих играх, выпущенных за последнее время, интерфейс сделан правильно, - говорит Рагнар и следом поясняет: - Если коротко, то цель интерфейса заключается в следующем: сделать выполнение всех действий игры легким как для начинающего, так и для опытного игрока».

К сожалению, большинство игр настроено только на одну из этих групп, и тогда либо новички оказываются сбитыми с толку, либо опытным игрокам, желающим добраться до нужных функций, приходится буквально продираться через бесконечные меню и красивые, но очень медленно открывающиеся окна с анимацией.

Всегда заботьтесь о том, чтобы на первом месте стояла не форма, а функциональность. Во многих классических играх это было доведено до предела за счет использования вместо меню исключительно команд с клавиатуры. Но сейчас я замечаю другую крайность: происходит снижение функциональности экрана, занятого милыми, но совершенно бесполезными картинками.

Примеры? Рагнар Шейерман указывает на следующие современные РПГ:

В некоторых играх обрамление окон и кнопок сделано слишком широким (Ultima Online), окна состояния и предметов загромождают половину экрана (Diablo), а меню раскрываются крайне медленно и требуют щелканья мышью при полном отсутствии «горячих клавиш» (Return to Krondor).

«Не забывайте, - говорит Рагнар, - что функциональность интерфейса должна стоять на первом месте! Художественное оформление и анимация - ничто, если они отменяют этот принцип».

Самый простой способ помочь новичкам - обеспечить доступ ко всем командам через какое-нибудь меню. «Если меню состоит из пиктограмм, - поясняет Рагнар Шейерман, - используйте подсказки или строку состояния, описывающие выбранную "иконку". И уж совсем прекрасно, если вы предложите дополнительный способ для вывода более полной справки - скажем, по щелчку правой кнопки мыши или нажатию клавиши "F1" при выбранном элементе».

В первую очередь необходимо думать о новичках, а не о хардкорных игроках. «Помочь «ветеранам» еще проще. Сначала назначьте клавиши для всех простых действий программы. Затем сделайте так, чтобы назначение можно было изменять, - говорит Рагнар. - Лучше всего это реализовано в Quake: стандартное назначение всех клавиш ИП собрано в скрипт, который опытные игроки могут легко настроить под себя, при этом разрешается создавать довольно сложные макросы».

И еще один совет: следуйте стандартам, чтобы сделать игру интуитивно понятной новым пользователям: клавиша «Esc» для выхода, «Enter» - для ввода, клавиши со стрелками - для просмотра меню и выбора элементов...

Насколько хорошо методы Рагнара Шейермана работают на практике, мы сможем узнать после выхода The DarkZion, глобальной многопользовательской ролевой онлайновой игры, которую смелая Wombat Games выбрала в качестве своего первого детища.

Том Холл (Tom Hall), ION Storm

Известнейший разработчик, соучредитель и вице-президент компании ION Storm, Том Холл готовит мир к выходу своей трехмерной ролевой игры Anachronox. Вы знакомы с этим человеком по его работе в компании id Software, где он участвовал в создании таких классических игр, как Doom и Wolfenstein 3D.

Не вызывает удивления, когда Том, как и другие разработчики, утверждает, что хороший интерфейс крайне важен и должен быть прост и интуитивно понятен. «Если вы выпустили демо-версию, а она трудна в управлении, люди разочаровываются, посылают вашу игру куда подальше и уже никогда не сядут за нее, какой бы содержательной она ни была», - говорит он.

Может ли Том привести примеры игр с хорошим/плохим интерфейсом и объяснить причины их успеха/провала?

Игры с удачными интерфейсами (и это в том числе и мои игры) - это Commander Keen in «Goodbye, Galaxy!», Wolfenstein 3D и Doom. Они просты и элегантны. Вам не придется искать описание клавиш управления или учить наизусть руководство. Вы просто садитесь за игру - и делаете в ней все, что хотите. Мне также нравятся интерфейсы всех квестов компании LucasArts. В них сразу понятно, как и что делать.

Я не хочу ругать игры конкурентов. Ну а у меня две игры имели плохие интерфейсы: это Keen Dreams, в которой меню было похоже на жуткий и запутанный кошмар, и Rise of the Triad (v. 1.0), персонажи которой плохо управлялись. Мы внесли исправления в версию 1.1, но, увы, к тому времени уже потеряли игроков, обжегшихся на первоначальной Rise of the Triad. Вам дается только один шанс привлечь игрока на свою сторону, не упустите его! Поддерживайте поклонников вашего любимого жанра и будьте требовательны к себе.

Игра должна быть настолько проста, чтобы в нее могла играть ваша мама, - даже если она не любит играть!

Игра Anachronox содержит более 100 уровней и 150 монстров. Спорим, что Том Холл не позволит неудачному интерфейсу пустить такую работу насмарку? (Использовано с разрешения компании ION Storm, Inc.)

Рон Гилберт (Ron Gilbert), Humongous Entertainment

Только что Том Холл хвалил квесты LucasArts, ставя в пример их удобные пользовательские интерфейсы. Комплимент Тома в значительной степени адресован Рону Гилберту, автору идеи Monkey Island, одной из наиболее популярных серий LucasArts. Впрочем, он в той же степени относится и к другим разработчикам этой компании, например к Тиму Шеферу (Tim Schafer).

Рон Гилберт ушел из LucasArts, чтобы стать соучредителем Humongous Entertainment, компании, быстро превратившейся в одного из ведущих разработчиков детских игр.

По мнению Рона, хороший интерфейс крайне важен для игры: «Ничто не раздражает меня больше, чем игра с плохим интерфейсом». Но хороший интерфейс не так легко создать, как думают некоторые. «Вот отличный метод, - говорит Рон Гилберт. - Интерфейс должен быть простым и понятным для игрока, но в то же время давать максимум власти над игрой, предоставлять ему множество возможностей. В наши дни очень редко встречаются игры с совсем уж плохим интерфейсом, но существует немало игр, где интерфейс довольно убог». В качестве примера отличного интерфейса Рон приводит Diablo, а также стратегическую фэнтези-игру в реальном времени Total Annihilation: Kingdoms производства Cavedog Entertainment (Cavedog и Humongous являются родственными компаниями).

По мнению Рона Гилберта, интерфейс игры Diablo компании Blizzard хорош тем, что он многофункционален, но в то же время прост в изучении. (Использовано с разрешения компании Blizzard Entertainment, Inc.)

Алекс Гарден (Alex Garden), Relic Entertainment

«С определенной точки зрения, каждая когда-либо выпущенная игра и каждая ее часть - это, по сути, один большой интерфейс пользователя», - говорит Алекс Гарден, исполнительный директор и ведущий дизайнер игры Homeworld (издатель Sierra Studios). - Главная цель игры и ее интерфейса состоит в том, чтобы ненавязчиво передать игроку некую идею».

Если каждая игра и есть интерфейс, нельзя ли в таком случае привести примеры хороших и плохих интерфейсных решений, обосновав свое мнение? Ответ Алекса:

Возьмем Quake. Пробежки по лабиринтам быстро становятся второй натурой игрока. Элементы управления игры не снижают уровня восприятия: каждый из них прост и понятен. С другой стороны, есть много прекрасных идей, не оправдавших надежд из-за того, что элементы игры и ее интерфейса оказались непрозрачными и слишком трудными для интерактивного восприятия. Примером неудачи является Star Wars: Rebellion. Эта игра основана на фантастической идее, но она похоронена под грудами меню, экранов, конфликтующих систем ввода и присыпана сверху тоннами информации, которая просто не дает играть.

Лучший интерфейс - это отсутствие интерфейса. Это мой девиз. Если вы можете обойтись без всплывающего меню, значит, оно вам вообще не нужно. Везде, где только можно, используйте для передачи информации естественный способ, взятый из реальной жизни. Например, если вы должны выбрать между всплывающим окном с текстом или проговариванием этого текста вслух, всегда выбирайте голос, а текстовую информацию используйте в качестве дополнения.

Игра Homeworld - само доказательство крылатой фразы Алекса Гардена из компании Relic: «Лучший интерфейс - это отсутствие интерфейса». (Использовано с разрешения компании Sierra Studios.)

Алекс Гарден настоятельно рекомендует начинающим разработчикам ознакомиться с главой, касающейся интерфейса пользователя, в книге «Computer Graphics: Principles and Practice», второе издание, авторы Foley, Van Dam, Feiner и Hughes (Addison-Wesley, 1996).

Марк Грин (Mark Green), Psygnosis

Прежде чем стать менеджером по связи между производством и разработчиками студии Psygnosis в Лидсе (Великобритания), Марк Грин был ведущим дизайнером игры Global Domination. В своих коротких замечаниях по разработке ИП и системы управления Марк обсуждает важность этого этапа в создании игры, различия между системой управления и общим интерфейсом и их взаимодействие.

И управление, и интерфейс жизненно важны для хорошей игры. Кто захочет играть в игру, основанную на скорости и точности реакции, если механизм управления откровенно тормозит? У кого хватит терпения продираться через запутанный и трудно воспринимаемый интерфейс, не позволяющий игроку понять, что происходит?

Вот вам два момента, которые в числе прочих отвечают на вопрос, почему в игровой индустрии так много дизайнеров. Программист пишет программы, художник рисует и создает модели, но никто из них не знает всех особенностей, которые необходимо учесть для создания игры. Это дело дизайнера.

В основе игры Global Domination одна из серий кинобондианы («Никогда не говори никогда»), настольная игра Risk и классическая аркада Missile Command. Неудачный интерфейс мог бы испортить эту трехмерную игру. (Использовано с разрешения компании Psygnosis, Inc.)

Управление игрой - это то, каким образом компьютер воспринимает ваши указания сделать что-либо. Простой пример: вы нажимаете кнопку перемещения персонажа, но компьютер реагирует столь медленно, что ваш герой заканчивает свои приключения в желудке гигантского волка.

Интерфейс - это способ, с помощью которого игрок приказывает компьютеру, что необходимо сделать, а компьютер сообщает игроку, что именно произошло. Если интерфейс не понятен интуитивно, значит, он никуда не годится. Нельзя рассчитывать, что пользователь быстро разберется в вашей сверхноваторской системе команд, если она создана без учета стандартных правил интуиции.

Короткие советы профессионалов

Вот еще несколько мнений профессиональных дизайнеров по поводу интерфейса. В целом они совпадают с остальными рекомендациями, приведенными в данной главе.

Сид Мейер (Sid Meier), Firaxis Games

Пользовательский интерфейс был важнейшим объектом размышлений Сида Мейера при создании Alpha Centauri, одной из последних игр мэтра. Сид старался сделать его удобным как для новичков, так и для ветеранов пошаговых стратегий.

Я искал возможность добиться от интерфейса игры предельной простоты, чтобы почти все было доступно с помощью мыши, но можно было использовать и клавиатуру. Создавая Alpha Centauri, мы поняли, что люди хотят знать больше об объектах на экране: модулях, ландшафте, зданиях. Поэтому, если вы щелкнете на нужном объекте правой кнопкой мыши, на экране появится окно дополнительной информации.

Щелчок правой кнопки мыши в игровом пространстве Alpha Centauri вызывает экраны дополнительной информации. Это интерфейсное решение позволяет игроку узнать больше, не прерывая игры. (Использовано с разрешения компании Firaxis Games, Inc.)

Мэтт Хаусхолдер (Matt Householder), Blizzard North

Несколько лаконичных советов для начинающих дизайнеров от продюсера Diablo II:

• Игроку нравится, когда компьютерный мир повинуется ему целиком и полностью; не разрушайте его иллюзий.

• Если игрок хотя бы на мгновение почувствует, что ситуация выходит у него из-под контроля, это будет означать ваш провал как разработчика.

• Пользовательский интерфейс должен быть интуитивно понятен и последователен.

И тогда новичкам будет проще обучаться, а опытные игроки почувствуют себя настоящими профессионалами.

Джей Уилсон (Jay Wilson), Monolith

По мнению Джея Уилсона из компании Monolith, и игровой интерфейс, и экранные меню крайне важны. Критически значимой является и возможность настройки интерфейса. Вот что говорит Джей:

Если я не могу играть в игру так, как хочу, я просто брошу ее. Не буду тыкать пальцем, но я полтора года ждал одну игру, а когда она все-таки вышла, выяснилась невероятная вещь: она совершенно не поддерживала мышь! Вы должны сделать методику игры понятной, а управление - дружественным для игрока.

Так, по мнению Джея Уилсона, экранные меню всегда должны содержать элемент «Справка», чтобы пользователь мог легко получить полную информацию по всем элементам игры. Прислушаются ли к нему другие разработчики, вот в чем вопрос...


Звуковое оформление

Глава 13

Звуковое оформление

Не так давно под «звуковыми эффектами в компьютерных играх» понимали короткое попискивание и забавное стрекотание, раздающиеся из встроенного динамика. Но минули годы, и сегодня, играя в Half-Life, можно явственно услышать шорох подкрадывающегося пришельца, от которого волосы становятся дыбом...

По мере развития программного обеспечения и технических средств для ПК звук в компьютерных играх приобретает все более важное значение. Новые аудиотехнологии появляются с невообразимой скоростью: менее чем за два года во весь голос заявили о себе такие системы объемного звучания, как Dolby Surround Sound, Dolby Digital (AC-3), Dolby Surround Pro Logic, Microsoft DirectSound и DirectSound 3D, Creative Lab's Environmental Audio, Aureal's A3D. Стали привычными однополосные и многополосные акустические системы объемного звучания, проигрыватели DVD, мощные сабвуферы, передача звуковых сигналов по шине USB, цифровые входы для музыкальной аппаратуры. Этот список пополняется буквально каждый день!

С передовой технологией пришло новое поколение специалистов по аудио-технике, давших второе дыхание индустрии интерактивных развлечений. В данной главе содержатся советы известных специалистов игровой индустрии, позволяющие заглянуть в увлекательный мир профессионального аудиодизайна, узнать о способах создания звуковых эффектов, использующихся в популярных играх с богатым звуковым оформлением, а также о том, каким образом звуковой дизайн вписывается в общую схему творческого процесса создания игр.

Мэтью Ли Джонстон (Matthew Lee Johnston), Microsoft

Мэтью Джонстон, ведущий аудиоинженер компании Microsoft, принимал участие в создании таких популярных игровых и мультимедийных проектов, как Flight Simulator 95и 98, Microsoft Golf 2.0,3.0, 98 и 99, Monster Truck Madness 1 и 2. На вопрос о том, что бы он мог посоветовать начинающим аудиоинженерам, желающим добиться успеха в игровой индустрии, Мэтью ответил следующее.

Загляните в мир разработчика

По мнению Мэтью Джонстона, большинство аудиодизайнеров, работающих сейчас в игровой индустрии, пришли из компаний, занимающихся озвучиванием готовой продукции, и среди них найдется немало несостоявшихся концертных звукооператоров и звукоинженеров мелких студий звукозаписи. «Сколько раз во время дискуссий на конференциях я слышал этот бесконечный скулеж о том, что разработчики их не понимают, не прислушиваются к их мнению и вообще всячески третируют», - говорит Мэтью.

Такое отношение действительно бытует, и, хотя оно, наверное, не всегда оправдано, его можно понять. Бесконечные самозабвенные рассуждения об общих концепциях звука наряду с неспособностью представить готовое звуковое решение игры вызывают оправданное раздражение специалистов, отдающих все свое время работе над общим процессом и не вдающимся в детали аудиодизайна. Хотите добиться успеха - расширьте свои знания по основам программирования, ознакомьтесь с принципами взаимодействия движка игры с ее звуковой частью, а еще - будьте дипломатичны в общении с командой разработчиков - от них зависит качество реализации ваших идей.

Будьте полезны

«Не думаю, что способен назвать много проектов звукового дизайна, так или иначе оказавшихся полезными», - замечает Мэтью Джонстон. Что он имел в виду? Вряд ли Мэтью хотел оскорбить своих коллег. Конечно, нет. Ему слово:

Нас приглашают в самый последний момент и предлагают список звуковых эффектов, намертво привязанных к соответствующим графическим элементам на экране. Такая технология типична для озвучивания фильмов, и ее корни кроются в недооценке роли звуков в жизни человека. Между тем, наша цель вовсе не мюзикл, а среда с визуальными и акустическими элементами, которая взаимодействует с игроком и отвечает на его действия, в результате чего у игрока появляется новый опыт. Поймите, звуковой дизайн - это нечто большее, чем озвучивание графики. Найдите способ сделать его одним из ключевых элементов игры. На сегодня игровая индустрия еще не доросла до понимания звука, но скоро появятся игры, в которых звук будет играть все большую роль. Проявите прозорливость прямо сейчас, и вы станете первым.

Мэтью приводит пример одной из своих игр, в которой действия игрока сильно зависят от звуковых эффектов. Рев чужих машин в игре CARТ Precision Racing (Microsoft) предупреждает игрока о том, что происходит сзади, а стереопанорамирование позволяет точно определить положение преследователя.

Скриншот из игры CART Precision Racing (Microsoft): лучше следить за дорогой, а не искать взглядом соперников! Тем более что в этом нет никакой нужды, поскольку пространственное распределение звуков других машин четко подсказывает, когда и с какой стороны появится преследователь. (Использовано с разрешения компании Microsoft Corp.)

Ломайте стереотипы

А вот что Мэтью Джонстон говорит об уважении, профессионализме и компетентности.

Я потратил десять лет жизни, чтобы стать экспертом в области аудио-дизайна, и терпеть не могу, когда меня называют «музыкантом» или, того хуже, «звуковиком». Создание звука - это только часть дела. Сложнее добиться уважения в этой индустрии, поскольку звук воздействует на потребителя мультимедийной продукции скорее подсознательно, не так явно, как изображение. Многие не понимают, насколько сильно звук влияет на восприятие, эмоции и степень погружения в игру. Добавьте к этому недостаток средств и неосознанное, но прочное представление о вас как о хиппи с гитарой - и проблема налицо. Поэтому будьте профессионалом, создайте себе прочные тылы, узнав все, что только можно узнать о проекте, частью которого будет ваш звук, и, ради всего святого, исключите из лексикона слово «пижон»! Доходчиво разъясняйте свои идеи и постарайтесь утвердиться в глазах тех, кто считает звуковое сопровождение «неплохой, но не слишком важной» деталью. Не прекращайте попыток, будьте настойчивы и последовательны, и рано или поздно ваш противник сдастся, выйдет, наконец, из видеокомы и признает, что звуковая грамотность есть неотъемлемая часть образования. Отныне вашим девизом должно стать доказательство вашей звуковой концепции.

А может ли звук влиять на зрительное восприятие? Конечно, считает Мэтью. В качестве примера он напоминает об исследовании, проведенном в Массачусетском технологическом институте, демонстрирующем сравнительную мощь звука и изображения. Коротко говоря, двум группам опрашиваемых показали два видеоклипа: один с бедным, а другой с великолепным звуковым содержанием. В итоге, подавляющее большинство зрителей посчитало, что клип с лучшим звуком - красивее. Следовательно, люди не всегда отделяют звуковое содержание и зрительные впечатления. А поскольку зрительное восприятие относится больше к сфере сознательной психической деятельности, то все лавры в случае успеха приписываются в основном визуальной части работы.

В университете Торонто был проведен аналогичный эксперимент: двум группам студентов-психологов показали один и тот же фрагмент записи дорожной аварии. В первом был звук сминаемого крыла автомобиля, записанный на месте аварии. Второй группе прокрутили обработанную запись, добавив визг покрышек и грохот от сильного удара при столкновении. Девяносто процентов студентов из второй группы и только двадцать процентов из первой сказали, что приближающаяся машина мчалась с большой скоростью.

На момент написания книги Мэтью Джонстон занимался окончательной доводкой звуковых эффектов для игр, выпуск которых был намечен на 1999 год. Среди них игра Flight Sim 2000 компании Microsoft и Midtown Madness, последняя из серии Madness.

Полуостров Олимпик, штат Вашингтон: Мэтт Ли Джонстон ведет запись, предназначенную для озвучивания игры Microsoft Golf 1998. Звуки природы, которые потом превратятся в фоновые шумы игры, улавливаются чутким «ухом» стереофонического микрофона Head фирмы Neumann. (Использовано с разрешения Мэтью Джонстона.)

Тим Ларкин (Tim Larkin), Yosemite Entertainment

Несомненно, самым блестящим звуком за всю историю существования компьютерных игр может гордиться классический квест Riven: The Sequel to Myst (Red Orb/Cyan, 1997). За создание большей части изумительного звукового сопровождения и аудиомонтаж игры отвечал Тим Ларкин, работающий ныне в принадлежащей Sierra Studios компании Yosemite Entertainment.

Как и Мэтью Джонстон, Тим считает, что разработчики недооценивают важность звука в игре. «Мы любим повторять, что звук создает 50% впечатлений, а отнимает 10% ресурсов», - горько шутит Тим. Другими словами, он уверен, что звук может наравне с видеорядом воздействовать на игрока, а ресурсы, которые обычно отводятся для звукового оформления, не превышают и десятой доли мощности ПК.

Тим Ларкин верит в грядущие перемены и говорит, что лед уже тронулся. «Вспомните, ведь технологии CD-ROM всего пять лет, поэтому мультимедиа - сущий младенец. Сравните с кино или телевидением, сколько времени созревали они». Далее он отмечает, что разработчики и издатели начинают признавать звук, и в то же время положительно отзывается о достижениях графики за последнее время. «К счастью, графика не стоит на месте, а значит, скоро публика пожелает и лучшего звука».

Ниже приведены советы Тима, которые он дает новичкам, вступающим в мир профессии звукоинженера.

Выработайте творческий подход

Тим Ларкин не имеет ничего против приобретения библиотек звуков на компакт-дисках. Например, ему очень нравится библиотеки компании Hollywood Edge. Однако он старается никогда не использовать готовые звуки в «сыром» виде. «Это просто недопустимо, - считает Тим. - Звуковой дизайнер всякий раз должен создавать из готовых звуков что-то новое путем редактирования, обработки и наложения».

Например, дребезжание трамваев, на которых персонажи Riven посещали острова, был получен с помощью смешивания нескольких отредактированных звуков. За основу был взят достаточно мягкий звук пригородного электропоезда. После ряда экспериментов по его редактированию поверх был наложен шум ветра, а затем - грохот.

В конечном итоге для точного воспроизведения звука трамвая потребовались все 24 дорожки. (Использовано с разрешения компании Cyan, Inc.)

Начните с качественного звука

По мнению Тима, хорошая аппаратура сейчас стоит недорого, поэтому нет оправдания тем, кто использует в играх некачественный звук, если только это не связано с нежеланием обсуждать с программистами вопросы полосы частот! «Старайтесь заниматься звуковым дизайном и монтажом игры так, будто идет озвучивание художественного фильма», - говорит Тим Ларкин. - Для начала можно купить несколько компакт-дисков по 50 долларов с библиотеками звуков, а цена программного обеспечения не превысит сейчас и пары сотен долларов».

Весь звук в игре Riven был создан с помощью пакетов программ для Macintosh - Macromedia's Deck II и Digidesign's Pro Tools. Пакет Macromedia's Deck II был приобретен компанией BIAS и сейчас известен как BIAS Deck 2.6. Сведения об этом продукте можно найти на www.bias-inc.com, а о пакете Pro Tools - на www.digidesign.com.

Тим признается, что часто пишет музыку и сочиняет эффекты вовсе не для игры, а для своих коллег и знатоков. «Я делаю это для аудиодизайнеров - тех, кто будет оценивать мою работу». Сейчас он работает в компании Sierra над онлайновой ролевой игрой Middle Earth по мотивам легендарного творения Д.Р.Р. Толкиена.

Крис Риппи (Chris Rippy), Ensemble Studios

Крис Риппи, директор по звуку компании Ensemble Studios, участвовал в. создании ряда игр серии Age of Empires. Большинство его советов начинающим аудиодизайнерам посвящено следующим темам: понимание своей роли в общей работе, знание достоинств и ограничений своего программного обеспечения и аппаратуры, получение практического опыта.

Занимаясь звуковым оформлением игры, всегда следует держать в голове ряд принципиальных моментов. Самое важное для музыкантов, звукорежиссеров, художников и других «узких» специалистов, принимающих участие в создании игры - понимание простой истины: игра в целом намного важнее той работы, над которой вы сейчас трудитесь. Иными словами, если конкретный звук мешает восприятию игры, от него следует отказаться. Кроме того, важно досконально изучить свое оборудование. Время, потраченное на освоение программ, аппаратуры DAT, микрофонов и других средств, будет сэкономлено при создании новых звуков и повысит их качество. И наконец, слушайте! Слушайте музыку, слушайте, как журчит вода, как стучит, захлопываясь, дверь машины, как звучат шаги, как дышит корова. Чем больше вы вслушиваетесь в окружающий мир, тем лучше будут созданные вами звуки.

Чтобы подкрепить эти советы, Крис вспоминает кое-что из своего опыта работы в Ensemble Studios. Бывали моменты, когда приходилось наступать на горло собственной песне, признавая приоритет игры над звуковыми эффектами, какими бы впечатляющими они ни были.

В Age of Empires, да и во многих других играх, нам приходилось урезать звуковые эффекты до минимума из-за технических ограничений, например объема доступной оперативной памяти или скорости, с которой ПК мог воспроизводить звук. Это сразу ограничило длительность звуков и их качество, так что часть моих задумок ушла в песок. Бывало так, что эффекты, которые при разработке звучали бесподобно, начинали раздражать меня и коллег при частом прослушивании во время самой игры. Так что еще раз повторю: первым делом игра, звуковые эффекты - потом.

Второе правило можно сформулировать так: изучайте материальную часть. Крис Риппи вспоминает: «Когда мне пришлось использовать для монтажа средства вроде Sound Forge, я еще плохо представлял их возможности. Только после долгих часов работы эти средства стали мне родными, я понял их плюсы и минусы. Сначала это требует огромных затрат времени, зато потом работа ускоряется, и качество созданных звуков повышается».

Третий совет больше относится к жизненному опыту, а не к профессии. Крис Риппи, например, вспоминает, как был получен звук катапульты в Age of Empires:

Он был собран из нескольких звуковых фрагментов, и не все из них мне запомнились. Но звук отскока плеча катапульты, хлопнувшего по перекладине, до сих пор стоит в ушах. Дело было так. Я прижал деревянную линейку к краю стола, оттянул свисающую часть и отпустил ее, так что она издала характерный звук. После этого я обработал его на компьютере, и вот - катапульта готова. Если бы я не вспомнил этот школьный «прием», то катапульта получилась бы на редкость тихой и безобидной!

Каждый раз при игре в Age of Empires вам будет вспоминаться, что звук катапульты обязан своим рождением баловству юного Криса Риппи на уроках.

Джефф Кирк (Geoff Kirk), Humongous Entertainment

Будучи дизайнером и программистом звуковых эффектов, Джефф Кирк приложил свои руки и талант ко всем детским играм компании Humongous Entertainment (серия Pajama Sam, Putt-Putt, Freddi-Fish и др.). Он работает над мультипликационными квестами, поэтому его советы в основном относятся к этому игровому жанру. «Смотрите мультфильмы», - рекомендует Джефф.

Самую лучшую подготовку к моим нынешним занятиям я прошел в детстве, когда безостановочно смотрел мультики, особенно из серии Bugs Bunny компании Warner Brothers. Использование музыки в этих мультфильмах по сей день можно считать новаторским и даже революционным. Фоновый звук в них опережает свое время и просто великолепен.

Взгляните на первую игру из серии Pajama Sam - There's No Need to Hide, When It's Dark Outside («He нужно прятаться, когда кругом темно»), и влияние мультфильмов на работу Джеффа Кирка станет очевидным.

Если идея кажется мне забавной, я пытаюсь ее применить, а затем смотрю, что получается. Например, в первой игре из Pajama Sam был куст, который хлопал листьями, когда по нему щелкали мышкой. Через некоторое время мне показалось, что было бы очень забавно, если бы при этом куст рявкнул по-тюленьи и шлепнул ластами, поскольку с самого начала он ужасно напоминал тюленя.

Джефф считает свои эксцентричные эффекты в играх компании Humongous баловством со звуком. То есть обычно берется нечто, меняется до неузнаваемости и смешивается с чем-нибудь еще. «Скажем, звериное рычание и рев часто используются именно так», - поясняет он.

Игра Pajama Sam была задумана как интерактивный мультфильм, и звуковые эффекты Джеффа Кирка напоминают нам о старых добрых мультиках по субботам.

Westwood Studious советует аудиодизайнерам экспериментировать и применять необычные звуки. По мнению специалистов этой уважаемой компании, искусственные звуки, которые являются гиперболизацией действительных, более предпочтительны, чем их первообразы. Аудиозаписи реальных звуковых эффектов звучат слишком пресно, что можно приписать влиянию кино- и телеиндустрии.

Конечно, не все звуки создаются путем подобных экспериментов.

Некоторые эффекты рождаются как отклик на то, что нарисовано. Если, например, есть детально проработанная фоновая сцена со множеством машин и устройств, в качестве звукового фона можно использовать результат смешивания отдельных звуков от множества работающих печатных станков или других агрегатов. Если в этих звуках отсутствует объем, их следует затем обработать с помощью эффектов эха или реверберации.

Джефф Кирк советует аудиодизайнерам не жалеть времени на изучение результатов обработки звука в таких звуковых редакторах, как Cool Edit Pro компании Syntrillium Software (www.syntrillium.com) или Sound Forge компании Sonic Foundry (www.sonicfoundry.com), а также попробовать поработать с синтезом звуков.

Келли Бейли (Kelly Bailey), Valve Software

В 1998 году игра Half-Life была выдвинута на соискание премии Gamespot в номинации за лучший звук в игре (www.gamespot.com/features/awards1998), уступив в итоговом голосовании лишь Thief: The Dark Project. Случайно ли это выдвижение? Отнюдь, компания Valve «умудрилась» в своей дебютной игре создать воистину невиданный (а точнее, неслыханный) звуковой дизайн. И все это благодаря Келли Бейли, который отвечал за музыкальное оформление Half-Life.

Сотрудничайте с коллегами

По мнению Келли Бейли, аудиодизайнер просто обязан тесно сотрудничать с инженерами, непосредственно занимающимися включением звука в игру.

Выгода от столь плотного взаимодействия со специалистами, сводящими звуки игровых персонажей, монстров и оружия, очевидна. Вы можете отдать только что созданный звук инженеру (иногда, впрочем, инженером был я сам), и через считанные минуты услышать его прямо в игре. Сразу же становится ясно, насколько он подходит для оружия или монстра и что нужно сделать: подстроить ли уровни громкости, высоту звука, частоту воспроизведения и т.п. Такая обратная связь идет на пользу качеству звука, да и времени экономит немало.

Творите и не повторяйтесь

Еще одна подсказка: при создании звуков смешивайте записанные и синтезированные звуковые элементы. Слово Келли Бейли:

Бывало так, что некоторые звуки, например звук шагов или отскока гильз от снарядов, сразу годились для игры. Но часто к исходным звукам приходилось для оживления добавлять дополнительные элементы. Так, записанный звук настоящего выстрела или взрыва при воспроизведении (если это только не сверхвысококачественная аппаратура) часто звучит, как сухой и короткий щелчок. Чтобы пальба была натуральнее, я нередко добавляю к записанному фрагменту низкочастотные синтезированные звуки: смешиваю несколько звуковых фронтов либо сжимаю или искажаю форму сигнала для расширения частотного спектра и увеличения кажущейся громкости.

Иначе говоря, чтобы исходные записи стали более агрессивными и захватывающими, приходилось немало над ними потрудиться. Кроме того, следует помнить, что игроки используют разную звуковую аппаратуру, поэтому найдите возможность прослушать звуковые эффекты на максимально широком классе динамиков, с сабвуферами и без. Создание и обработка звуков без учета различных типов динамиков или наушников может привести к неприятным сюрпризам.

Многократно проверяйте звук

Келли Бейли считает, что звуки должны немного пожить в игре, хотя бы во время тестирования, и только после этого их можно назвать окончательными. И далее приводит пример:

Отыграв 20 и более часов, игрок слышит некоторые звуки по тысяче раз. Для меня важно определить, имеются ли в игре звуки, которые после частого прослушивания начинают невыносимо раздражать. Чтобы избежать этого, многие наши звуки во время игры слегка изменяются с каждым воспроизведением с помощью генератора псевдослучайных чисел: немного варьируется высота звука, применяются несколько чуть отличающихся звуковых эффектов, двухкомпонентный звук смешивается в разных пропорциях. Немалая часть работы выполняется программным способом, однако почти все повторяющиеся звуки, например выстрелы, дорабатываются вручную - обычно требуется до пяти редакций, прежде чем остановишься на окончательном варианте. Зато, как правило, такие звуки быстро вписываются в игру и не вызывают раздражения даже при многократном прослушивании.

Умение выбрать нужный звук приходит только с опытом. Слушая неделями звуки, доносящиеся из соседних комнат, начинаешь поразительно верно понимать, что подойдет, а что не лезет ни в какие ворота. Уделяйте внимание тем звукам, которые зажигают участников игры. К своему детищу привыкаешь быстро, потому не пренебрегайте мнением окружающих - они могут указать на неудачные звуки или подсказать, звуки какого типа воспринимаются лучше.

Кевин Шилдер (Kevin Schilder), Raven Software

Кевин Шилдер работает руководителем отдела звукозаписи в компании Raven Software (Мэдисон, штат Висконсин, США). По своей значимости он - половина команды, отвечающей за аудиодизайн, музыку и иное звуковое оформление игр. На его счету Heretic I и II, Нехеп I и II, Mageslayer, а также многие другие игры.

Имея за плечами 30 лет стажа, Кевин завершает эту главу тремя заповедями о том, как аудиодизайнеру добиться успеха в игровой индустрии.

Мыслите творчески

Когда я впервые начал использовать готовые образцы звуков на компакт-дисках, оказалось, что содержание диска не всегда подходит для моих задач. Допустим, требуется создать звук тяжелой захлопывающейся двери. И вдруг я понимаю, что для этой цели вместо настоящего звука двери гораздо лучше подойдет определенным образом обработанный звук взрыва. Нужно четко представить, какой требуется звук, и рассмотреть все варианты его создания.

Гиперболизируйте эффекты

Во всех играх, над которыми я работал, звуковые эффекты были преувеличены по сравнению с реальными. Плохо, если пылающая стрела звучит с легким потрескиванием обычного костра. Нет, эта штука должна реветь, как крылатая ракета, и разрывать наушники!

Нежнее с обработкой!

Обработка звука требует большой осторожности. Известны случаи, когда прекрасные звуковые эффекты, увы, приходилось удалять из игры. И все из-за маленькой досадной ошибки в обработке, например слишком ранней обрезки, сделавшей звук неестественным.


Музыка в играх

Глава 14

Музыка в играх

Производство компьютерных игр, как, пожалуй, ни один другой сектор индустрии развлечений, словно магнитом, притягивает к себе самых талантливых представителей множества творческих профессий. Где еще писатели, программисты, художники, аниматоры, звукоинженеры и музыканты могут встретиться в одном сплоченном коллективе, устремленном к единой цели! Похоже, дружная, целенаправленная творческая работа - это одна из тех причин, по которой совсем молодая индустрия так бурно развивается. Причем возможности для ее развития фактически бесконечны.

К счастью, разработчики постепенно начинают понимать, какое значение для игры имеет хорошее музыкальное сопровождение, и в создание звука вкладывается все больше сил и средств. Конечно, деньги, идущие на звуковое оформление игры, ничто по сравнению с затратами на графику (и лицензирование, если это необходимо), однако доля этих расходов постоянно растет, и, кажется, здесь уже можно зарабатывать. Игра в обшарпанных барах или стабильный заработок - выбор за вами, господа музыканты.

Давайте познакомимся с людьми этой уважаемой профессии, добившимися успеха в игровой индустрии, и их советами тем, кто собирается работать в этой области.

Чэнс Томас (Chance Thomas), Yosemite Entertainment

Чэнс Томас является ведущим музыкальным продюсером принадлежащей компании Sierra студии Yosemite Entertainment в Окхерсте (Калифорния, США). Параллельно с созданием оркестровых аранжировок, сочинением рок-музыки и выпуском компакт-дисков с игровыми саундтреками он активно пропагандирует музыку к играм, надеясь что она в скором времени войдет в число номинаций ведущей американской музыкальной премии Грэмми.

Идеальное предисловие к советам Чэнса Томаса - его примечания к звуковому сопровождению игры Quest for Glory V компании Sierra. Он пишет:

Музыка загадочна, неуловима, интимна, капризна... Она - словно язык, который мы знали еще до своего рождения, ее близость к нам то удивительна, то очевидна. Сочинение музыки - это балансирование между безграничной фантазией и строгими законами, между необузданным желанием и вынужденным смирением. Композитор неистовствует, бьется, требует, уламывает, проклинает и, наконец, отступает. И часто в атмосфере смиренной готовности к поражению из своего укромного местечка вдруг появляется муза, удовлетворенная тем, что наши отчаянные усилия смягчили душу. Она разговаривает с нами изнутри, пробуждая эмоции так нежно и проникновенно, по мере того как ее голос неудержимо прорывается наружу из глубины сознания.

Первое, на что, по мнению Чэнса, следует обратить внимание начинающим музыкантам и разработчикам, подбирающим людей для звукового оформления игры, - это качество.

Всеми силами добивайтесь высочайшего качества музыки. Наши уши привыкли к превосходному звуку в кино и на телевидении, при прослушивании любимых музыкальных альбомов. И если игрок хотя бы раз скажет «это всего лишь музыка для игры...», с желанием воздействовать на него с помощью звука придется распрощаться. Музыке просто перестают доверять, и она уже не производит того эффекта, какой могла бы.

Чэнс Томас также рекомендует, если позволяют время и деньги, использовать «живые» музыкальные инструменты, а не синтезаторы.

Никакая, даже самая совершенная технология не сможет превзойти природную естественность оригинала. На микшерском пульте нет «регулятора эмоциональности». Вот почему среди нас появляется все больше и больше сторонников работы с настоящими, живыми, чувствующими и страстными музыкантами; пусть они играют для создаваемой игры столько, сколько мы можем себе позволить. Если говорить об исходном материале для работы, то ничто не сравнится с записью блестящего исполнения «разогретых» музыкантов, выражающих свои чувства звуками настоящих акустических инструментов.

Наши уши привыкли к превосходному звуку в кино и на телевидении, говорит Чэнс Томас, и если игрок хотя бы раз скажет «это всего лишь музыка для игры...», с желанием воздействовать на него с помощью звука придется распрощаться. (Использовано с разрешения Чэнса Томаса.)

Этот подход Чэнс постоянно применяет на практике. Например, для записи различных частей звукового сопровождения игры Quest for Glory V он использовал оркестры из 36 и 32 инструментов. «Чтобы создать звучание оркестра из 72 и 64 инструментов соответственно, мы записывали по два дубля на каждую звуковую дорожку, в каждом случае запись производилась много раз, пока мы не добивались превосходного звука. Дорожки, записанные с помощью синтезатора, ни в какое сравнение не идут с теми, что были сделаны с помощью "живых" инструментов. Разница огромна».

Все это очень хорошо, но у большинства музыкантов, работающих в игровой индустрии, нет возможности привлекать к работе целый оркестр. Чэнс поясняет: «Я только хочу сказать, что если вы хотите добиться особого эмоционального впечатления, подумайте прежде всего о музыке. Джордж Лукас (George Lucas) как-то сказал, что во время просмотра фильма половина впечатления зависит от звука. Не забывайте об этом при определении роли музыки в своей игре».

Итак, в какой же момент следует привлекать музыканта к разработке игры? «Чем раньше, тем лучше», - отвечает Чэнс Томас.

Постоянно сотрудничая с музыкантом с самого начала проекта, вы можете добиться поразительного слияния ваших помыслов. Мне случалось на ранней стадии разработки игры сочинять такие музыкальные отрывки, которые вдохновляли на создание абсолютно новых ее частей. Музыка в нужном месте может помочь актерам в более ярком и динамичном озвучивании персонажей. Не говоря уже о вдохновении, порождаемом воздействием мелодии или аранжировки.

В игре Quest for Glory V компания Sierra впервые использовала запись «живой» оркестровой музыки. Начинания такого рода помогают привлечь внимание к продукту. К моменту появления игры на магазинных полках в прессе было опубликовано свыше сорока статей, посвященных только одной музыке из этой игры. (Использовано с разрешения Чэнса Томаса.)

Музыка - это язык чувств. Ее воздействие не выразишь ни словами, ни зрительными образами. Чэнс Томас предлагает задаться вопросом: «Что должен чувствовать человек, играя в эту игру? Если композитор не зря ест свой хлеб, его музыка должна вызывать именно эти чувства».

Джордж «Толстяк» Сэнджер (George «The Fat Man» Sanger)

Джордж Алистер Сэнджер по прозвищу «Толстяк» сочиняет музыку к играм с 1983 года. Вместе с Team Fat («Командой Толстяка»), своей легендарной группой, состоящей из трех (помимо самого Джорджа) композиторов-ковбоев, он получил международное признание, создав музыку к более чем ста тридцати играм, в том числе к Wing Commander I и II, The 7th Guest I и II, NASCAR Racing, Putt-Putt Saves the Zoo, Tanarus и ATF...

Во время продолжительного телефонного интервью о профессиональном сочинении музыки для игр разговор постоянно возвращался к одной теме: увлеченности. По мнению Толстяка, именно то, что заставляет вас подскакивать посреди ночи с криком «Да!», и должно стать вашей профессией.

Если вам не слишком нравятся игры и музыка, бросьте это занятие. Нужно не просто любить игры, нужно быть помешанным на них. Вы ведь никогда не отправитесь попытать счастья в Голливуде, если не любите кино, не так ли? Делайте то, что у вас хорошо получается, будь то горы денег или музыка для игр. Не предавайте свою любовь даже при неудачах. Всякий раз, когда вы создаете игру или музыку к ней, делайте это для себя, а не для кого-нибудь еще. Забудьте обо всех остальных. Не принимайте решений, руководствуясь только расчетом. Прислушайтесь к себе, и если это обогащает вашу жизнь - вы на правильном пути. Необходимо подчиняться зову своего сердца, своей страсти, своего счастья.

«Команда Толстяка» по часовой стрелке, начиная слева вверху: «Шомпол» Джо Макдермот (Joe McDermott), Дэвид Говет (David Govett), «Профессор» К. Уэстон Фелан (К. Weston Phelan) и сам Джордж «Толстяк» Сэнджер. (Фото любезно предоставлено Spanki Avallone, Avallone Media.)

Как и Чэнс Томас, Толстяк признал, что крупные компании-разработчики не придают музыке большого значения, и предположил, что сумма, которую компания готова выделить на разработку музыки, прямо пропорциональна ее качеству и, соответственно, последующему ажиотажу вокруг нее. «Если вы вложите один процент ваших ресурсов (денег и времени) в создание музыкального сопровождения игры, это уже хорошо. А уж три процента - практически гарантия того, что народ придет в благоговейный трепет после первого же аккорда».

Но каким образом разработчику следует подойти к выбору музыки для своей игры? Толстяк настоятельно советует работать в первую очередь с людьми, которых вы знаете и которым доверяете, и быть честным во всем, что касается проекта.

Если вы ищете людей для создания музыки к вашей игре, будьте полностью честны с любым, с кем имеете дело, и предложите им любые деньги, какие только можете себе позволить, или проценты от доходов с игры. Дайте им хоть что-нибудь для начала... можно даже просто угостить их обедом. Убедитесь, что ваши друзья заинтересованы в успехе так же, как и вы.

Очевидно, если вы только начинаете, то «всего сразу и побольше» у вас вряд ли получится. Толстяк напоминает молодым разработчикам, что «как и у большинства специалистов в любой области, чем меньше опыта - тем меньше денег, но больше головной боли. С приобретением опыта затраты возрастают, но проблемы сокращаются».

Допустим, что вы не разработчик игры, ищущий музыканта, а сам музыкант. Какая вам нужна аппаратура? По мнению Толстяка, все, что необходимо для начала, - это любая домашняя звукозаписывающая техника и хороший компьютер. «Не забудьте только установить в ПК устройство для ввода музыки - звуковую плату Sound Blaster AWE 64 или Live!, или любую другую с приличным входом, если возможно, то стерео. Если вы работаете с WAV-файлами, вам понадобится устройство для записи компакт-дисков или магнитофон формата DAT (с цифровой записью)». Записанную таким образом музыку уже можно передать разработчикам в качестве демонстрационной версии.

Толстяк является ведущим ежегодного весеннего Марафона демо-записей музыки для игр на Конференции разработчиков игр. Присылайте демо-записи длительностью 90 с в следующих форматах (в порядке предпочтения):

• Компакт-диск (формат ПК, 44.1 кГц 16-бит стерео WAV)

• Аудиокомпакт-диск

• Аудиокассета DAT

• Обычная аудиокассета

Если вы собираетесь работать в индустрии игр, то это отличный способ начать. Полные правила, вводная информация и список компакт-дисков за прошлые годы находятся на официальном веб-сайте Толстяка www.fatman.com.

Кроме того, Толстяк председательствует на ежегодном собрании «Project Bar-B-Q», посвященном повышению качества музыки для компьютеров и компьютерных программ. Хотите стать его участником? Ищите информацию на упомянутом выше веб-сайте.

В заключение Толстяк напомнил нам, что музыка вносит свой вклад в общее восприятие игры, и, как и многие другие виды творчества, например поэзия или изобразительное искусство, превосходит возможности обычной речи, когда надо выразить что-то, рожденное сердцем. «Даже если содержание этих "посланий" не идет дальше "как это классно - мочить монстров"», - с улыбкой заключает Толстяк.

Игра - это средство душевного единения без помощи слов. Взаимодействие между разработчиком и игроком. Это глубокая связь, которая не поддается описанию.

Томми Талларико (Tommy Tallarico)

Эти три слова - «Музыка Томми Талларико» - вы можете найти в титрах свыше 140 игр. Феноменальная карьера! Вот лишь некоторые из самых известных работ Маэстро (общее количество проданных экземпляров - двадцать пять миллионов!): Prince of Persia, The Terminator, Cool Spot, Aladdin, Earthworm Jim 1 и 2, MDK, Wild 9, Test Drive 4 и 5, Messiah.

Томми поделился своим мнением о значении музыки в играх и ее вкладе в общее впечатление от игры.

Надеюсь, вы догадываетесь, что музыка в игре занимает далеко не последнее место. По моему принципиальному убеждению, музыка - это 25% всех впечатлений от игры. Наш взгляд на любую игру складывается, в основном, из четырех компонентов. Первый и самый очевидный - это художественное оформление, куда входит вся графика, визуальные эффекты, анимация и прочие «красивости». Вторая составляющая - программирование, без которого в игре ничего бы не двигалось, не было бы никакого действия, и нам даже не пришлось бы говорить об интерфейсе. Третий элемент - это дизайн игры, сюда относятся проектирование уровней, размещение «забавных элементов», доставляющих игроку удовольствие, и вообще работа над всеми составляющими игры, которые должны производить впечатление на игроков. Ну и, наконец, звук, создающий определенную атмосферу, настроение, подчеркивающий какое-то действие...

Короче говоря, я не знаю, как можно без звука придать эмоциональную окраску какой-либо сцене или уровню! К примеру, представьте себе картину: главный герой подбегает к краю огромной отвесной скалы и медленно наклоняется вперед, чтобы заглянуть в неведомую бездну. От того, какая музыка будет звучать в данном эпизоде, будет целиком зависеть реакция игрока на созданную ситуацию. Если музыка тревожная или пугающая, можно добиться впечатления погони, загнанности, тупика. Если музыка, наоборот, красивая, эпическая, то она вселит в игрока чувства гармонии, красоты и достигнутого совершенства. Ну а если в данном эпизоде из колонок забренчит нечто в стиле кантри, то у нормального человека возникнет только одно желание - немедленно остановить игру, выключить компьютер и выйти в соседнюю комнату. Чтобы тихонечко там застрелиться.

На вопрос, в чем ключ к успеху при создании саундтрека к игре, Томми Талларико ответил, что лично для него всегда было важно отойти от общепризнанных канонов, сделать все иначе.

Все саундтреки к играм, за которые я получил награды, отличает одно качество: такого типа музыку в играх вы услышали впервые. Например, в игре Global Gladiators для создания песни были использованы сэмплы барабанов, гитары, оркестра, живого голоса и т.д. До меня такого для Sega Genesis не делал никто. Сэмплы в то время применялись в основном для записи диалогов. В игре Terminator для приставки Sega-CD вы впервые могли услышать в игре живой звук акустической гитары и настоящую рок-музыку. В Skeleton Warriors впервые прозвучала музыка, исполненная большим симфоническим оркестром (95 инструментов). Treasures of the Deep вообще наполнена звуками акустических гитар и других «живых» инструментов. Для звукового сопровождения игры Wild 9 я взял бит и ритмы из индустриальной и техно-музыки, а потом объединил все это с симфоническим оркестром и гитарами. Бит очень важен для создания темпа в игре, а оркестр и гитары придают неповторимую мощь и мелодичность. Писать такое сродни созданию нового музыкального стиля!

Уникальность - вот, пожалуй, единственный секрет сочинения достойной игровой музыки. Просто надо пытаться сделать то, чего до вас еще никто никогда не делал, и это, по-видимому, самая увлекательная часть моей работы.

Чэнс Томас как-то заметил, что композитору было бы полезно сесть вместе с дизайнером игры в самом начале разработки и потихонечку начать сочинять музыку. Но, по словам Томми Талларико, обычно случается так, что игра попадает в его руки, когда разработка вступает в завершающую стадию. Приходится играть без звука до тех пор, пока не придет вдохновение. «В такую секунду, - продолжает Томми, - я взлетаю вверх по лестнице в свою студию и судорожно пытаюсь определить, каким же клавишам соответствуют те ноты и звуки, что звучали в моей голове несколько мгновений назад». Если игра или уровень еще не закончены, приходится изучать сценарий.

О выборе музыкального стиля. Это происходит по-разному для каждого заказчика. Иногда разработчики приходят с вполне конкретными предложениями (например: «Надо, чтобы в твоей музыке сочетались ритм-секция от Prodigy, звучание The Chemical Brothers и такой же драйв, как у Nine Inch Nails! Сможешь? Да, и еще не забудь вставить туда такой же звук, как у гитары Уэйлона Дженнингса!»), но чаще выбор того, что лучше подойдет для игры, остается за Томми.

На этом блокнотном листочке Томми Талларико записал музыкальные стили, запланированные им для различных тем игры Cool Spot 3: мир пиратов, мир ужаса, мир научной фантастики, мир приключений и т.д. (Использовано с разрешения Томми Талларико.)

Например, при создании музыки к Earthworm Jim Томми Талларико сначала пришлось пройти всю игру без звука. На первом призовом уровне есть эпизод, где Джим и Пси-Ворон гоняются друг за другом на ракетах. Каждый раз, когда Томми проходил это место, ему казалось, что они скачут на лошадях. «У меня в ушах постоянно звучало банджо, и музыка получилась соответствующей - в стиле кантри», - говорит Томми. В других случаях он смотрел, как Джим бегает и прыгает, и всякий раз находил новые ритмы, основанные на этих уморительных движениях. Наконец, большое значение имеет то, как выглядит фоновое окружение: «Например, для сцен в темноте хорошо подходит обволакивающая, медленная музыка».

Последняя часть нашего интервью с Маэстро была посвящена подбору инструментов для начинающих музыкантов и способам поиска работы в игровой индустрии.

Какие инструменты лучше использовать?

Для, так сказать, повседневного сочинительства подойдет абсолютно любой сэмплер (Roland, Akai и подобные), самый необходимый инструмент в работе композитора-одиночки. С его помощью вы сможете создать хорошую библиотеку разнообразных синтезированных и «живых» звуков. Если же подключить к сэмплеру устройство для чтения компакт-дисков, вы получите практически неиссякаемый источник сотен тысяч новых и абсолютно уникальных звуков. У каждого звукоинженера и специалиста по звуковым эффектам должен быть достаточно быстрый компьютер «Макинтош», «вооруженный» качественными программами редактирования звуков, вроде Sound Edit Pro, Alchemy, Digital Performer и т.д. Для убежденных поклонников ПК подойдет программа Sound Forge.

Теперь о том, с чего же все-таки начать...

Начните с записи демонстрационной кассеты с тремя или четырьмя вашими лучшими двух- или трехминутными композициями. Разошлите кассеты всем издателям и разработчикам, о которых знаете или слышали. Вы легко найдете их адреса в Интернете. Однако самый эффективный путь - поехать на Конференцию разработчиков игр (Game Developers Conference) или на выставку Е3 (Electronic Entertainment Exposition). Именно здесь у вас появится возможность лично встретиться с дизайнерами игр, продюсерами, президентами компаний и прочими шишками. По моему опыту, всегда лучше поговорить с кем-нибудь с глазу на глаз, чем заваливать людей кассетами по почте.

Томми «Король» Талларико говорит, что самое главное для музыкантов - не отставать от времени и участвовать в мероприятиях типа E3 или GDC. Спасибо, большое спасибо. (Использовано с разрешения Томми Талларико.)

Бобби Принс (Bobby Prince)

Вы могли и не слышать его имени, но если вы поклонник 3D-шутеров, то, вероятно, часто напеваете его мелодии. Бобби Принс, композитор и звукоинженер, автор музыки к таким знаменитым играм, как Wolfenstein 3D, Doom, Doom II и Duke Nukem 3D. Он особенно известен своей мелодичной музыкой в формате MIDI. Многие из его произведений, ставших классикой музыки к играм, можно услышать на его веб-сайте www.bpmusic.com.

Обычно Бобби приступает к работе в самом начале игрового проекта. «Мой первый опыт в игровой индустрии, музыка к Commander Keen, была написана задолго до того, как в игру можно было играть. Мне показали рисунки персонажей и рассказали о том, что планируется включить в игру. Так было практически со всеми проектами вплоть до Duke Nukem 3D».

На этой игре у Бобби Принса впервые появилась возможность прослушивать только что написанную музыку и звуковые эффекты непосредственно в работающем игровом окружении. «Даже с игрой Doom такого не было: мне приходилось просить программиста перекомпилировать код с новой музыкой или звуковыми эффектами. На это уходила уйма времени, да и вносить быстрые правки было невозможно».

Бобби считает, что написать подходящую музыку, не видя игры, можно, но лишь в том случае, если под руками находится документация с подробным изложением сюжета. Правда, весь предыдущий опыт работы Бобби говорит, что по ходу проекта сюжет и персонажи будут изменены, причем не раз. «В этом и состоит часть интереса и удовольствия от работы. Все немного напоминает ранний Голливуд: стандартные профессиональные приемы еще только формируются, и в рабочей команде царит забавная неразбериха».

Загляните на сайт Бобби Принса - там выложено множество его композиций в формате MIDI. Да, и обратите внимание на буквы «b» и «p» в логотипе его компании. Узнаете? Это половинные ноты. (Использовано с разрешения Бобби Принса.)

Бобби Принс любезно согласился сформулировать три основных совета музыкантам, стремящимся преуспеть в игровой индустрии.

1. Навыки работы с компьютером - это, как минимум, большой плюс для музыканта. По большей части, сочинение музыки для игр не является простым ремеслом типа «представьте музыку в формате X и получите чек». Это особенно справедливо для музыки в формате MIDI. Мне приходилось многократно отлаживать коды MIDI-команд, создавая секвенции для тестирования MIDI-проигрывателя игры. Как-то раз даже возникла ситуация, когда движок игнорировал ноты и обрабатывал менее значимые данные.

2. Общение с командой разработчиков. Будьте готовы к тому, что вам придется объяснять далеким от музыки людям все тонкости компьютерного озвучивания. Продюсеры и программисты - обычно толковые парни, но им, как и простым обывателям, часто не хватает знания основ. Они могут заказать музыку в цифровом формате аудио-CD или в формате Redbook, когда на диске с игрой уже не хватает места. Также важно научиться понимать, что эти «немузыканты» на самом деле подразумевают под тем или иным музыкальным термином. Были случаи, когда от меня требовали изменить громкость музыки, хотя на самом деле речь шла всего лишь о другом тембре. Часто путают и названия инструментов.

3. Не дожидайтесь какого-то особенного настроения, чтобы начать сочинять музыку. Удача приходит к тем, кто ее ищет. Но до этого момента будет потрачена не одна ночь на сочинение музыки и изучение аппаратуры.

Итак, о какой аппаратуре идет речь? По мнению Бобби Принса, композиторы, сочиняющие музыку в формате MIDI, могут с успехом записывать ее на следующем комплекте оборудования: приличный компьютер, базовые программы секвенсоров, звуковая плата с таблицей звуков, поддерживающая формат MIDI, MIDI-клавиатура, колонки и наушники. Для цифровой звукозаписи добавьте программное обеспечение записи, редактирования и создания звуковых эффектов, а также какое-нибудь записывающее цифровое оборудование для сведения записи (магнитофон DAT, устройство записи компакт-дисков и т.д.). Любая дополнительная техника - дело вкуса. Она, вероятно, облегчает работу, но не обязательна.

Майкл Лэнд (Michael Land), LucasArts

Майкл Лэнд является руководителем отдела звукового сопровождения и членом музыкальной команды одной из самых знаменитых компаний, разрабатывающих и издающих игры. Он сочинил музыку для целого ряда популярных игр середины 90-х годов, в их числе серия Monkey Island, X- Wing, TIE Fighter, The Dig, Day of the Tentacle. Когда Майкла попросили выделить три основных момента, о которых следует помнить музыкантам, пишущим музыку для игр, он дал следующий исчерпывающий ответ.

Играйте!

Это довольно очевидно, но так легко пренебречь этим, если вы спешите и в голове у вас «список пожеланий» в качестве плана работы. Запомните, кто бы ни подошел к вам с таким списком, он, по-видимому, не композитор. Хотя список пожеланий с описаниями игры задает главное направление для начала работы, практическое знакомство с самой игрой ничем заменить нельзя. Даже подглядывать из-за чужого плеча, хотя и лучше, чем ничего, далеко не так эффективно, как самому погрузиться в процесс взаимодействия с игрой. Вы не только сможете дополнить свой список так, чтобы лучше отразить интерактивную структуру игры, но, что еще более важно, опыт непосредственного общения с игрой неуловимым образом даст вам почувствовать, какую музыку надо написать, чтобы усилить впечатления игрока. И как только ваша музыка попадет в игру, тут же возвращайтесь к компьютеру - играйте и смотрите, как она звучит. Если понадобится что-то изменить - вы поймете это гораздо быстрее, чем если бы работали над музыкой отдельно от игры.

Аудитория - это «игрок», а не «слушатель» или «зритель»

Помните, что музыка пишется для усиления интерактивного воздействия, поэтому, какой бы прекрасной она ни была, нужно убедиться, что она хорошо вписывается в нелинейный интерактивный мир игры. Музыкальные приемы (повторы, закольцованные фрагменты, модуляции и т.д.), применяемые в интерактивной музыке, могут как мешать, так и помогать игроку. В окончательном варианте ваша музыка будет звучать гораздо лучше, если вы отнесетесь к этим проблемам как к творческой задаче, которую нужно не просто каким-то образом решить, но и усилить при этом воздействие на игрока. Начните с создания схемы взаимодействия отдельных музыкальных фрагментов между собой. Затем при написании каждого отдельного фрагмента проверьте, что он хорошо сочетается с соседними отрывками.

Изучайте используемую технологию

Необходимо четкое понимание программных и аппаратных возможностей музыкального сопровождения игры и имеющихся ограничений. Выясните, в каком виде нужно представить работу: формат данных, разрешение, допустимый объем на диске и т.д. Существует множество вариантов технического обеспечения, и в большинстве случаев от выбора того или иного решения зависят условия вашего творчества. В начале проекта не все варианты четко определены, поэтому чем раньше и глубже вы погрузитесь в технические вопросы, тем легче вам будет контролировать последующий процесс. Основной вопрос, который обязательно встает в самом начале работы, - формат звуковых данных (MIDI, Redbook, DLS и т.д.). При выборе любого из этих форматов сразу возникает цепочка дополнительных вопросов, касающихся конкретных деталей (за исключением, может быть, формата Redbook). Чем глубже вы все это проработаете, тем эффективней сможете использовать преимущества выбранной технологии и избежать проблем, связанных с ее ограничениями.

Когда Майкла попросили рассказать о том, откуда взялись идеи для классических саундтреков LucasArts, и спросили, почему его компания уделяет музыке так много внимания по сравнению с другими производителями игр, он ответил:

Источников вдохновения для написания звукового сопровождения много. Если перечислять в произвольном порядке, то это прекрасные сюжеты и чудесные персонажи в играх LucasArts, увлечение классическими кинофильмами и киномузыкой, творческая и пробуждающая воображение интуиция дизайнеров игр, глубокая любовь к различным музыкальным стилям, обстановка сотрудничества и соперничества трех композиторов, работающих в компании почти десять лет.

Келли Бейли (Kelly Bailey), Valve Software

Келли Бейли, как вы уже знаете из главы 13, отвечал за всю музыку и звуковые эффекты в суперпопулярной игре Half-Life. Он также написал программу, позволяющую персонажам разговаривать, и внедрил систему ПО, создающую эффекты эха и реверберации.

Ниже Келли Бейли объясняет, что, по его мнению, важно помнить начинающим композиторам, пишущим музыку для игр, а также делится личным опытом работы над игрой Half-Life.

Какое нужно настроение?

По мнению Келли, главное правило - создавать музыку в соответствии с характером разрабатываемой игры.

Одна из основных задач, с которой я столкнулся, делая звуковое сопровождение к игре Half-Life, состояла в том, что музыка в игре должна была постепенно нагнетать напряженность. Half-Life - ярко выраженный «ужастик», и я постарался выразить это в музыке. Я обнаружил, что действительно важно постоянно помнить, какого рода музыку я стараюсь написать, и очень тщательно выбирать мелодии. Рамки шутера, «отягощенного» ужасами, определенно помогли мне продвинуться вперед и не затеряться в джунглях подбора и создания звуков. Иногда, оставив законченную звуковую дорожку в покое на неделю или около того, я возвращался к ней и обнаруживал, что она, оказывается, не вполне соответствует настрою игры. Я перерабатывал ее или напрочь выбрасывал, начиная все заново. Конечно, тяжело отрекаться от готового звукового сопровождения только потому, что оно не вполне соответствует настрою игры. Я, однако, старался быть самокритичным, и в этом мне помогало ощущение того, сколь важно поддержать постоянное настроение музыки к Half-Life.

А еще я понял, что при сочинении музыки для игр длительность отрывков должна составлять от тридцати секунд до двух минут. Это ограничение, связанное с хроническим недостатком места на компакт-диске, постоянно вызывало затруднения и требовало жесткой самодисциплины и четкого планирования.

По утверждению Келли Бейли из Valve Software, главное - писать музыку, которая точно соответствует настрою игры. Half-Life насыщен двумя главными музыкальными темами: «Боевик» и «Ужасы». (Приводится с разрешения компании Sierra Studios.)

Удобное рабочее место

Номер два в списке - это, по мнению Келли Бейли, «удобное рабочее место, где вы будете писать музыку, экспериментировать со звуками и идеями. А также возможность отложить работу на время, чтобы потом вернуться к ней с новыми идеями».

При работе над звуковым сопровождением очень важен комфорт. Я усовершенствовал свою домашнюю студию звукозаписи и оснастил ее набором аналоговых и цифровых синтезаторов, сэмплеров, хорошим устройством записи на жесткий диск, высококачественным восьмиканальным микшером, несколькими выносными профессиональными аудиопроцессорами и рядом «живых» инструментов - гитарой, барабанами, флейтой и кларнетом. Возможность находиться в студии в любое время позволяет мне быть одинаково работоспособным, пытаюсь ли я создать новый звук глубокой ночью или редактирую и свожу звуковые дорожки ранним утром. На поздней стадии проекта, при довольно сильной спешке, домашняя студия была спасением, позволяя мне экономить время.

Работа в спешке

Третий и заключительный совет Келли Бейли - научиться продуктивно работать под давлением и в спешке.

Способность сочинять музыку в жестких временных рамках оказалась неожиданно важна. Я первоначально рассчитывал, что у меня есть еще несколько месяцев, чтобы закончить последние десять дорожек, но как же я ошибался! Я разрывался на части, занимаясь работой над самой игрой по восемнадцать часов в сутки в течение заключительных пяти месяцев, и вынужден был заканчивать сочинение музыки в «свободное время». Я справился с этим благодаря наличию прекрасной домашней студии и привычке принуждать себя к усердному творчеству. К самому концу проекта я работал над несколькими дорожками одновременно, что фактически помогло мне продуктивно использовать время, проведенное в студии. Если я застревал над какой-нибудь дорожкой (или хотя бы был «слишком близок» к этому), я мог быстро переключиться на другую дорожку и двигаться дальше. Было крайне важно иметь возможность на время оставить хоть что-то и вернуться к этому через несколько дней. Это позволяло моим «свежим» ушам точно определить, действительно ли я выдерживаю тему «шутера с ужасами».

В настоящее время Келли Бейли пишет музыку и создает новые звуковые эффекты для игры Team Fortress 2 (Valve).

Хайко Руттман (Haiko Ruttmann), Blue Byte Software

Заканчивая нашу беседу о музыке в играх, мы предлагаем высказаться Хайко Руттману, сотруднику компании Blue Byte. Хайко отвечает здесь за сочинение и запись звуковых дорожек ко всем компьютерным играм, а также создает звуковые эффекты и записывает наложение голоса.

Советы герра Руттмана новичкам конкретны и практичны. Он предупреждает: «Если вы хотите заняться созданием музыки для компьютерных игр, вам понадобится более чем один любимый музыкальный стиль. Одни игры могут потребовать музыку в стиле ритм-н-блюз, другие - симфоническую».

Понятно, что прежде чем музыкант начнет сочинять звуковое сопровождение, он должен узнать как можно больше об игре. Хайко Руттман говорит: «Вы должны понять концепцию, идею игры. Шутер или стратегия? Научная фантастика, ужасы или спорт? Выяснив это, послушайте саундтреки к фильмам или другим играм, посмотрите телевизор, сходите в театр, почитайте книги, поговорите с людьми... ну и поиграйте на музыкальных инструментах, конечно».

На протяжении игры Settlers III возникают темы нескольких цивилизаций - римской, азиатской и египетской. Естественно, музыка отражает культуру каждой из них. (Использовано с разрешения компании Blue Byte Software.)

Следующий шаг, считает Хайко, - создание демо-файлов из прежних наработок и обсуждение их с руководителем проекта. «Обычно я начинаю с записи аккордов, воспользовавшись электропианино или банальной клавиатурой. Секвенсер позволяет мне создать аранжировку с различными инструментами и эффектами - добавить, например, звуки струнных, медных или деревянных духовых инструментов. Для игры Incubation аранжировки оркестра были дополнены звуками природы, животных и некоторых технических эффектов. Вот так и рождаются шедевры, ребята!»

Элен Мейджерс-Гэбриел (Ellen Meijers-Gabriel), Oddworld Inhabitants

Композитор и звукорежиссер компании Oddworld Inhabitants, Элен Мейджерс-Гэбриел занималась музыкой и звуковыми эффектами для двух ее игр: Oddworld: Abe's Oddysee и Oddworld: Abe's Exoddus. Элен говорит, что композиторам, пишущим музыку для игр, надо помнить о нескольких важных правилах.

Во-первых, настройте оборудование (само собой, вы должны уметь на нем работать). Изучите свою аппаратуру и возможности платформы, для которой создается игра. Это позволит избежать принципиальных изменений выбранных настроек по ходу проекта. Неплохо также проявить организованность и сохранять копии своих работ.

Постарайтесь получить как можно больше информации об игре, над которой собираетесь работать. Если вы пишете музыку к еще не законченному проекту, начните с эскизов и видеороликов, просматривайте их по мере появления. Потом, когда игра будет близка к завершению, можно будет поиграть в нее, но к этому моменту ваша работа также должна быть почти закончена. Если же вы начинаете писать музыку после окончания разработки самой игры, у вас есть определенное преимущество: можно полностью изучить продукт, для которого пишется музыка, но очевидно, что в этом случае времени вам выделят куда меньше. Одно из преимуществ параллельной работы состоит в том, что у вас будет шанс тщательно все проверить и иногда даже изменить саму игру.

Подходите к работе творчески, разрушая стереотипы. Вместо того чтобы обдумывать отдельные отрывки, последовательно сочиняя мелодии, я предпочитаю воспринимать игру как цельное интерактивное музыкальное произведение. Характер музыки зависит как от самой игры, так и от тех, кто ее создает. Поговорив с разработчиками, вы получите четкое представление о музыкальном стиле, который им нужен. Затем напишите что-нибудь в этом стиле, стараясь как можно ближе придерживаться сюжета игры. Если сочиненная музыка соответствует настрою каждого уровня и персонажа и усиливает впечатление от игры, значит, вы работали не зря.

Эндрю Барнабас (Andrew Barnabas) руководит деятельностью творческого клуба, члены которого общаются друг с другом по Интернету. Вот его рассказ об этой организации.

Наш «Клуб по переписке музыкантов, сочиняющих музыку для видеоигр» открыт для любого, кто профессионально работает со звуком в игровой индустрии. В настоящее время у нас чуть больше ста членов, включая большинство крупных компаний по разработке программного обеспечения и множество независимых музыкантов. Главной целью было убедить музыкантов начать общаться друг с другом (ведь все мы отшельники). Эта сумасшедшая идея пришла ко мне потому, что я, под завязку наевшись профессиональных вопросов других музыкантов (будучи человеком общительным, я всего лишь звонил им и хотел поболтать), попытался подтолкнуть их к общению друге другом. У нас есть даже FTP-каталог для загрузки музыкальных файлов.

Темы разговоров варьируются от обсуждения готовых появиться на свет разработок в области интерактивного звука различных форматов и музыкальных стилей до вопросов типа «почему я не могу связать два устройства?» или «посоветуйте мне звуковую плату для ПК, которую можно синхронизировать с импульсами реального времени 44,1 кГц». В последние месяцы Клуб привлек внимание изготовителей оборудования и разработчиков неигрового ПО (Microsoft, Creative Labs, Cirrus Logic, Dolby) и заслужил внимание и положительные оценки на конференциях CGDC и BBQ (BBQ - детище Толстяка). Я даже знаю людей, которые нашли с помощью Клуба работу!

В настоящее время Клуб располагается по месту моей работы (компания Sony Computer Entertainment, Кембридж, Великобритания, мы как раз делали игру Medievil, если вы видели). Желающие присоединиться, жду ваших сообщений по следующим адресам: barney@scee.sony.co.uk, bar.ney@dial.pipex.com. Единственное условие: пожалуйста, напишите о себе пару абзацев - чем занимаетесь, какими средствами при этом пользуетесь, кто ваши заказчики...


Выпуск проекта

Часть III

Выпуск проекта

15 | Тестирование
16 | Маркетинг и работа с прессой
17 | Разработка веб-сайтов, посвященных играм
18 | Техническая поддержка и послепродажное обслуживание


Тестирование

Глава 15

Тестирование

Как уже не раз отмечалось, тестирование игры - это один из ключевых этапов разработки, требующий самого пристального внимания. Тогда почему в компьютерных играх так много ошибок? Почему стал привычным выпуск многочисленных патчей (исправлений) к уже вышедшим играм? В чем здесь дело - разработчики обленились? Считают, что практика пострелизных патчей эффективней тщательного тестирования еще не выпущенной игры?

Тому есть ряд объективных причин. Во-первых (и это самое главное), компьютерные игры - это далеко не то же самое, что игры для приставок, когда все конечные потребители используют одно и то же оборудование (приставки PlayStation, Dreamcast и Nintendo 64 абсолютно одинаковы, что в Америке, что в Европе, что в Азии, за исключением разве что используемого ПО).

А теперь попробуйте найти хотя бы двух пользователей, чьи ПК будут обладать одинаковой конфигурацией! Возможны тысячи самых разнообразных сочетаний программного и аппаратного обеспечения, поэтому задача достижения корректной работы игровой программы для каждого из таких сочетаний превращается в сложнейшую головоломку, а разработка игр для ПК начинает напоминать стрельбу по движущейся мишени.

Во-вторых, выпуск компьютерных игр - это в первую очередь бизнес. Если игра не поступит вовремя в продажу, производитель потеряет деньги (особенно в течение прибыльных сезонов продаж), а так как многие крупные издатели компьютерных игр являются открытыми акционерными обществами, то они обязаны публиковать ежеквартальные финансовые отчеты. Один неудачный квартал может самым неблагоприятным образом повлиять на курс акций компании. Под давлением обязательств перед прессой и торговой сетью многие фирмы выпускают откровенно «сырые» продукты, сопровождая их комментариями вроде «исправления будут доступны в Интернете через пару недель». В итоге, пользователь, разочаровавшийся в продукции компании, перестает быть ее покупателем...

По данным Мэтта Гравета (Matt Gravett), координатора известнейшей исследовательской службы PC Data, отвечающего за информацию по продажам видео- и компьютерных игр, каждый год за один только декабрь консольных игр реализуется свыше 30%, а игр для ПК - свыше 25% от годового объема продаж. Вот почему многие издательства выпускают свои игры преждевременно, лишь бы только попасть на полки магазинов в предрождественские дни.

Разнообразные подходы к тестированию игр на наличие ошибок и совместимость можно разбить на две группы.

• Бета-тестирование (тестирование предварительной версии) начинается, когда игра находится на стадии между поздней альфа- и ранней бета-версией, отсюда и название. Этот весьма трудоемкий этап в создании игры «на совести» собственно разработчика или издателя. В каждой компании его проводят по-разному. В ряде случаев бета-тестирование доверяют добровольцам из числа пользователей.

• Контроль качества (Quality Assurance, QA) осуществляется специалистами по тестированию, не имеющими отношения к разработке игры и не являющимися игроками. Он проводится по спецификации выпуска продукта, определяющей поддерживаемые конфигурации аппаратного и программного обеспечения, и завершает собой производственной цикл создания игры. Перед выпуском игры анализируются также присланные сообщения об ошибках и другие замечания. После выхода игры в свет группа технической поддержки рассматривает жалобы пользователей, а разработчики внимательно изучают группы новостей и веб-форумы. В результате составляется и систематизируется список замечаний, на базе которого выпускается первый патч. В ряде случаев исправления полностью оправданы - например при появлении новой видео- или аудиоплаты уже после выпуска игры.

В этой главе обсуждаются вопросы тестирования игр в процессе их создания. Советами по этому поводу делятся специалисты таких уважаемых компаний, как Acclaim Entertainment, Electronic Arts, Psygnosis, Interplay, Firaxis, Origin Systems, Humongous Entertainment и Blue Byte.

Кэрол Караккиоло (Carol Caracciolo), Acclaim Entertainment

Кэрол Караккиоло отвечает за контроль качества в отделении компании Acclaim Entertainment, располагающемся в городе Глен Коув (штат Нью-Йорк, США). Она участвовала в разработке множества игр, в том числе Mortal Kombat II, Turok: Dinosaur Hunter, Quarterback Club, All-Star Baseball, NBA Jam, WWF: Raw, WWF: Warzone, Alien Trilogy, Revolution X. В ее подчинении находятся около семидесяти пяти человек, обеспечивающих двухсменную непрерывную работу в течение семи дней в неделю.

По мнению Кэрол, тестируя игры, следует придерживаться трех важнейших правил: а) не отлынивайте от тщательного описания ошибок и не позволяйте никому отговорить вас от занесения ошибки в базу данных; б) прежде чем зафиксировать ошибку, тщательно исследуйте проблему; в) проверяйте, проверяйте и еще раз проверяйте.

Насколько сложен подбор сотрудников, занятых поиском ошибок в программном обеспечении? Трудно ли найти игроков, согласных и способных выступить тестерами? Ответ Кэрол:

Найти желающих не проблема. Страсть к играм заставляет этих людей проявлять инициативу - они сами найдут вас. Трудность заключается в том, чтобы выбрать из огромного числа претендентов тех немногих, кто любит игры настолько, что готов проводить за тестированием по восемь часов в день, пять дней в неделю в течение четырех-шести месяцев.

Далее Кэрол поделилась соображениями о том, сколько людей необходимо задействовать на этапе контроля качества и как она обеспечивает выявление и документирование ошибок.

Во время пиковой загрузки оптимальным является сочетание временных и постоянных сотрудников в отношении два к одному. Когда продукты идут в производство один за другим, к двадцати постоянным сотрудникам я добавляю от тридцати до сорока временных.

Контроль качества с помощью столь внушительной группы - дело не легкое. Однако у нас работают опытные руководители и ведущие технические сотрудники, буквально опекающие временно привлеченный персонал, а также, если это необходимо, участвующие в его обучении в период испытательного срока. За годы работы мы опробовали и внедрили в свой производственный процесс все самое лучшее из известных методик тестирования. Мы составляем подробные планы, осуществляем детальный анализ ошибок и их регистрацию с помощью специально предназначенных для этого программных средств. Чтобы обеспечить выполнение графика тестирования, мы постоянно ведем выборочную проверку таблиц ошибок и баз данных, полученных от каждого тестера. Все сотрудники в обязательном порядке посещают занятия по «переподготовке», чтобы быть в курсе всех новостей и изменений.

В заключение, Кэрол Караккиоло попросили подытожить сказанное каким-нибудь примером.

Последней игрой, которая заставила нас внести изменения в методику тестирования, была Bust-A-Move. Поначалу она выглядела совершенно безобидно, и мы были уверены, что игра с легкостью пройдет тестирование. Однако количество разветвлений ее сюжета оказалось почти бесконечным. Это вынудило нас устроить тщательный разбор всего процесса тестирования и составить его обширный предварительный план. Такой план необходим не только для контроля за ходом тестирования на этапе исполнения, он просто неоценим для планирования потребностей в персонале и оборудовании.

Шон Хауз (Sean House), Electronic Arts

Когда Шона Хауза, помощника продюсера отдела ЕА Sports, спросили, отличается ли тестирование игр в его компании от того, что принято у других производителей, он ответил, что да, и привел следующие веские причины:

Тестировать спортивные игры в конце их разработки (в последние три месяца или около того) - это единственно возможный способ. Причина в том, что график разработки, как правило, оказывается крайне напряженным (на весь проект отводится всего один год). Программисты обычно лезут из кожи вон, пытаясь осуществить все, что было намечено, и на ошибки, которые можно было бы выявить в процессе разработки, просто не обращают внимания. Время на отладку у них появляется только по завершении текущего этапа разработки (или его части).

Шон Хауз говорит, что процесс тестирования в Electronic Arts несколько отличается от общепринятого, потому что в их компании цикл разработки ускорен - на выпуск игры отводится только год. Вы видите игровой экран из игры Madden NFL '99. (Приводится с разрешения компании Electronic Arts.)

Шон признал, что такую ситуацию нельзя считать нормальной, и заметил, что в идеале следует постепенно увеличивать объемы тестирования по мере приближения проекта к финалу.

Это даст тестерам возможность «гонять» игру в течение нескольких месяцев, даже если при этом приходится постоянно переключаться с одной ее части на другую. Тестеры, к слову, не против таких переключений - чем меньше изматывающего однообразия, тем продуктивнее их работа. Процесс отладки при этом также становится ощутимо более действенным, ведь многие области игры взаимосвязаны. Ошибка в одном месте может вызвать несколько промахов в другом, поэтому тщательное «вылизывание» каждого фрагмента облегчает отладку последующих.

Далее Шон объяснил, как в ЕА Sports понимают разницу между бета-тестированием и контролем качества:

У нас контроль качества (QA) осуществляется группой штатных сотрудников, получающих продукт, после того как он прошел через отдел производственного тестирования. Группа контроля качества - последняя линия обороны перед выпуском игры. К этому моменту все ошибки в игре должны быть полностью устранены. Задача группы QA - поставить себя на место пользователя и высказать свое мнение о функциональных возможностях игры, выявляя при этом незамеченные ранее ошибки. Кроме того, группа занимается обеспечением юридической чистоты продукта (появляющиеся на экране уведомления, приведенные в лицензионных соглашениях сведения и т.п. - ее работа). Обычно это те же самые люди, которые потом будут осуществлять техническую поддержку, так что они напрямую заинтересованы в качестве продукта: больше пропущенных ошибок - сильнее головная боль после выпуска игры.

Бета-тестирование - это предварительный выпуск бета-версии игры (почти законченной, с очень небольшим количеством ошибок в продукте) и передача его либо всем желающим, либо специально отобранной группе. Эти люди проходят игру и сообщают об обнаруженных в ней ошибках. Резкое увеличение в очень короткое время круга лиц, видевших продукт, является кардинальным средством быстро устранить последние оставшиеся ошибки. Во время моей работы в ЕА Sports подобное бета-тестирование не проводилось ни для одной игры. Мы предпочитаем обычное производственное тестирование, начинающееся, как правило, за месяц до появления альфа-версии (все главные функции игры уже реализованы, хотя и с ошибками) и продолжающееся до самого выпуска игры.

По-моему, при создании любого программного продукта одинаково важны и производственное тестирование, и контроль качества. Отделы, отвечающие за эти этапы, прекрасно дополняют друг друга. Часто, особенно к концу проекта, тестеры изматываются (работать по шестнадцать часов в день очень тяжело), поэтому легко могут пропустить очевидные ошибки. И тут в дело вступает свежая группа контроля качества. Ее сила также в том, что она рассматривает игру с точки зрения конечного пользователя (не имеющего никакого отношения к разработке), а значит, вполне способна составить объективное представление о продукте.

Шон Хауз припоминает яркий пример из своего профессионального прошлого, доказывающий важность обоих видов тестирования. Это настоящий анекдот:

Пять лет назад я работал тестером в компании Media Vision во Фремонте (Калифорния). Велось тестирование сразу нескольких мультимедийных продуктов. Одну из игр надо было закончить к 26 декабря. Работа была почти сделана к 23-му, ибо никому из нас не хотелось сидеть на службе в Рождество, поэтому мы провели за ней все 23-е, закончив тестирование в шесть утра 24 декабря. Нечего и говорить, что мы здорово устали, а значит, были не особенно внимательны. Игра должна была распространяться на дискете. Окончательная версия была готова в три часа утра 25-го, и мне было поручено сделать ее мастер-копию. Оставалось лишь проверить, устранена ли последняя ошибка, что я быстренько и сделал, прежде чем раздать дискеты тестерам. При инсталляции требовалось ввести имя и название организации, и я, просто ради смеха, набил «Coitus Interruptus». Все без проблем установилось, ошибка была действительно исправлена, дискету можно было запускать в тираж. Погоняв игру еще немного, я передал свою копию руководителю группы. Отдела контроля качества у нас не было, поэтому он просто отправил ее в производство. Работа закончена! Мы были счастливы.

Недели через три, когда игра уже вовсю продавалась, начали поступать телефонные звонки. Пользователи в один голос жаловались, что не могут зарегистрировать игру, так как в графе «имя» стоит «Coitus Interruptus»... Нечего и говорить, что все дискеты были тут же отозваны. Это обошлось компании в 225 тысяч долларов. Основную ответственность понес мой начальник. Я, конечно, чувствовал себя просто ужасно, но зато получил хороший урок. Последняя линия обороны - полезная штука. Отдел контроля качества, будь он у нас, непременно отловил бы мой промах. Кроме того, моему начальнику, видимо, все же стоило хотя бы разок просмотреть игру с финальной дискеты. Но это уже другая история...

В заключение Шон Хауз сказал, что важность производственного тестирования, как и контроля качества, подтверждается множеством других примеров, и он не может представить себе процесс создания игры без этих этапов.

Марк Грин (Mark Green), Psygnosis

Марк Грин, с которым мы беседовали в филиале компании Psygnosis в Великобритании, рассказал о своем подходе к тестированию и хронологической последовательности действий, без которых Psygnosis не выпускает ни одной игры. Заодно он объяснил, как, когда и почему эти действия должны выполняться.

Заключительная фаза проекта, последние шесть месяцев работы - это время, когда становится ясно, чего ты стоишь. Именно этот этап разработки либо рождает игру, либо заканчивается провалом. Не имеет никакого значения, что до этого у вас все было в полном порядке: любое упущение на этом этапе чревато самыми серьезными последствиями.

Во-первых, следует быть достаточно сообразительным, чтобы поддерживать контакт с отделом контроля качества на протяжении всего проекта. Как правило, сотрудники отдела контроля качества - это самая тесная связь с игровым миром, какая у вас только есть. Все они - упертые игроки, и если что-то не в порядке, они непременно сообщат вам об этом.

Чувствую, вы сейчас скажете: «Я знаю, что такое хорошая игра. Я и сам вижу, что в игре плохо. Зачем мне рассказывать о том, что я и так знаю?» Увы, проблема в том, что разработчики так тесно связаны со своим детищем, что попросту не видят за деревьями леса. Разработчики делятся на две группы: одна половина думает, что их игра - нечто фантастическое, хотя на самом деле это дерьмо; другая уверена, что их игра никуда не годится, хотя она вполне удачна. Третьего не дано - разработчик не может быть беспристрастным. Сейчас мы все больше и больше привлекаем к сотрудничеству обозревателей из журналов, людей, несомненно, более объективных, чтобы они изучили игру до ее выпуска. В результате мы получаем замечательные по своему профессионализму отзывы. Разумное применение таких приемов позволяет в итоге получить не просто хорошую, а блестящую игру.

Спустя шесть месяцев после начала разработки игра переходит в стадию, которую мы называем альфа-версией. К этому моменту в продукте должно быть реализовано все, что вы хотели бы в нем видеть. При этом игра не обязана хорошо смотреться и идеально работать. Важно другое: вы наконец-то говорите «нет» всем добавлениям и новым возможностям. Ваша работа над альфа-версией (как и работа отдела контроля качества) заключается в том, чтобы проверить игру и добиться того, чтобы она неплохо выглядела, нормально игралась и перестала виснуть. Обычно это занимает около шести недель.

Следующий этап - бета-версия, или предварительная версия игры. И тут-то начинается самое трудное - Охота За Ошибками! Как правило, кое-кто (не будем говорить кто именно, хотя речь идет об этих проклятых продюсерах, чтоб им пусто было!) пытается тщательно спланировать, сколько это может отнять времени, хотя в любом случае все сводится к вопросу «сколько еще веревочке виться?»... Если у вас действительно хорошие программисты, проблем будет не так много; в противном случае неизбежны самые тяжелые времена. К тому же, как назло, именно в этот момент отделу распространения и маркетинга обычно взбредает в голову отправить разработчиков на какую-нибудь презентацию - поболтать с журналистами (короче говоря, оторвать их от работы над игрой). Обычно бета-тестирование длится около четырех недель.

Последняя стадия - передача изделия в производство. Если разработка ведется не для ПК, а для игровой приставки, это делается в два этапа: внутренний и внешний. Сначала ваш собственный отдел контроля качества завершает последнюю, самую тщательную проверку и дает вам возможность устранить недоработки. Затем вы отправляете игру изготовителю. Там потратят еще пару недель на проверку, не только на отсутствие ошибок, но и на соответствие игры внутренним стандартам компании. Найденные ошибки - это автоматическое возвращение игры разработчику и повторное прохождение всей процедуры. Судя по моему опыту, каждая попытка занимает в среднем две недели, так что неудача может здорово удлинить этот этап.

Наконец, дело доходит до мастер-копии (или «золота»). Вы можете вздохнуть с облегчением и снова окунуться в общение с внешним миром, которым вы жертвовали два последних года, работая над проектом. Месяц спустя полки магазинов заполняются вашей игрой, и вы молитесь, чтобы она заняла в хит-парадах первое место.

Одним из самых последних проектов, в котором Марк Грин принимал участие в качестве автора и продюсера, была игра Global Domination.

Чип Бамгарднер (Chip Bumgardner), Interplay Productions

Чип Бамгарднер - продюсер множества игр. Упомянем лишь некоторые из них: Chessmates, Lost Vikings 2, Earth 2140, Dragon Dice, Max 2 и серия Caesar's Palace. Кроме того, он помогал разрабатывать уровни для нашумевшей игры Redneck Rampage. Чип сказал, что тестирование игры начинается куда раньше, чем можно себе представить.

На самом деле, команда разработчиков тестирует игру в течение всего времени ее создания. Так гораздо проще находить ошибки, а заодно и настраивать игру.

Чип признается, что большая часть тестирования проводится в течение последних недель (или месяцев) работы над проектом, чтобы удостовериться, что все функционирует должным образом.

Крис Тэйлор (Chris Taylor), Interplay Productions

Крис Тэйлор, бывший ведущий дизайнер Fallout и Stonekeep и дизайнер-консультант Мах 2, говорит, что тестирование игры состоит из трех основных этапов: производственного тестирования, бета-тестирования и контроля качества.

Разработчики должны постоянно играть в игру и тем самым тестировать ее. Ведь они - единственные, кто по-настоящему знает игру и имеет представление о том, как она должна работать. Бета-тестирование - это мнение об игре посторонних. Они помогут найти узкие места и проверить продукт на совместимость. Что касается контроля качества - это просто более формализованное бета-тестирование с максимально подробным описанием ошибок и тщательной проверкой совместимости. Иногда группа контроля качества и в самом деле может помочь при разработке игр, а иногда там слишком заняты поиском ошибок, чтобы оказать реальную помощь. Я считаю, что требования к тестированию и подход к организации этого процесса сильно зависят от компании и продукта.

Во время написания этой книги Крис Тэйлор был занят проектом Star Trek: Starfleet Command. Несмотря на то что игра прошла довольно длительный этап тестирования, ее «завернули» на стадии контроля качества, что еще раз подчеркивает важность тестирования на раннем этапе разработки. (Приводится с разрешения компании Interplay Productions.)

Вольфганг Валк (Wolfgang Walk), Blue Byte

Вольфганг Валк работает в студии Blue Byte Software в Германии. Он был руководителем проекта Incubation. Его мнение о предмете обсуждения, по-видимому, совпадает с мнением других разработчиков:

Тестирование - наше все. Только оно может обнаружить все ошибки и недоработки, которые неизбежны на ранней стадии проекта, когда игра существует скорее в вашей голове и кое в каких документах, но пощупать это руками еще нельзя. Тестирование подскажет вам, интересна ли игра, что необходимо изменить, чтобы исчезли скучные, вгоняющие в тоску фрагменты, которые иногда появляются в процессе разработки.

А еще, оно, конечно, поможет найти ошибки. Правда, стоит помнить, что имей вы хоть сотню тестеров, все равно пятьдесят тысяч пользователей в первый же день после покупки найдут еще море ошибок. Все это дело случая. Игры сегодня столь сложны, что полностью избежать ошибок почти невозможно. Увы, журналисты и пользователи об этом часто забывают.

«Само собой, - заключил Вольфганг, - это не касается продуктов с грубыми ошибками, которые проявляются после двух минут игры на среднем уровне».

Ричард Гэрриот (Richard Garriott), I Origin Systems

Единственный и неповторимый Ричард «Лорд Бритиш» Гэрриот, автор идеи легендарной серии игр Ultima компании Origin Systems, рассказал, как много сил они затрачивают на тестирование игр, особенно сетевых, приведя в качестве примера Ultima Online. «Популярная сетевая игра должна разрабатываться как следует с самого начала; у вас должен быть отменный исходный текст. Если исходный текст хорош, группа контроля качества достойно выполнит свою работу».

К несчастью, нет иного способа тщательно протестировать принципиально новую игру вроде Ultima Online, рассчитанную на одновременное участие массы игроков, кроме как в процессе самой игры. Это могут засвидетельствовать несчастные, которым удалось вступить в игру первыми, сразу после ее выпуска. Впрочем, вскоре к игре были добавлены многочисленные дополнительные серверы по всему миру, а в Техасе вопросами снижения трафика занялась группа специально выделенных инженеров.

По мнению Лорда Бритиша (Ричарда Гэрриота), тестирование - это не только выявление ошибок, но и проверка работоспособности игры на всех типах компьютеров в бесконечном множестве возможных конфигураций. (Приводится с разрешения компании Origin Systems, Inc.)

Ричард Гэрриот рассказывает, что, тестируя игры внутри компании, они пытаются играть так, как играл бы человек, который видит игру первый раз в жизни. Кроме того, в обязательную программу тестирования входит проверка всех основных функций игры и их комбинаций, что часто превращается в довольно утомительную задачу. Он поясняет:

Предположим, в игре есть пятьдесят заклинаний. При этом тестер должен проверить действие всех заклинаний и всех их комбинаций на всех типах монстров, вспомогательных персонажах и предметах для каждого уровня. Это огромный объем работы, у нас половина офиса завалена томами с описаниями программ тестирования! И все это надо проделать с каждой версией игры, с каждой ее «сборкой».

Ну а в заключение, Лорд Бритиш напомнил нам, что все это должно быть проделано для максимального количества компьютерных конфигураций от максимального количества производителей. Весело, правда?

Сид Мейер (Sid Meier), Firaxis Games

Мэтр Мейер уже не раз появлялся на страницах этой книги, чтобы поделиться своими мыслями о разработке игр. Говоря о том, как следует тестировать игры, он проявил солидарность с мнением Ричарда Гэрриота.

Прежде всего - проверка на наличие ошибок, которая должна производиться как можно большим количеством людей и на самых разнообразных компьютерах. Важна также методика воспроизведения и записи ошибки.

Ошибка не стоит потраченного на нее времени до тех пор, пока она не будет тщательно описана и не будут выявлены условия ее воспроизведения. Чтобы облегчить воспроизведение ошибки, Сид Мейер использует самые разные способы, например встроенную в игру функцию автосохранения, фиксирующую ваше местоположение каждые десять секунд (или около того). Это позволяет воспроизвести ошибку, просто загрузив игру с нужного места.

Еще одна важная вещь, которая требует проверки, - выяснение того, не является ли игра слишком легкой или сложной.

К сожалению, разработчики здесь не помощники: они очень близки к проекту, чтобы иметь объективный взгляд на игру. Следовательно, надо предложить игру другим людям - чтобы поглядеть, что они будут делать, выяснить, где застрянут.

Наконец, Сид Мейер заметил, что наиболее важны первые полчаса игры новичка, когда решается вопрос, захочет ли он продолжить игру.

Рон Гилберт (Ron Gilbert), Humongous Entertainment

Всемогущий Рон Гилберт отвечал за разработку многих бестселлеров компаний LucasArts, Humongous Entertainment и Cavedog Entertainment. Когда мы заговорили с ним о тестировании, Рон напомнил, что в этом плане его любимые квесты стоят особняком. Что он имеет в виду?

Тестирование квестов - это в основном поиск ошибок, в отличие от игр других жанров. Вам не надо беспокоиться о сбалансированности игры, как в стратегиях, не надо тестировать многопользовательский режим. Квесты - это линейное развитие сюжета, неизменное расположение предметов, относительная игровая стабильность.

Что касается игр вроде Total Annihilation: Kingdoms, то, когда дело доходит до тестирования, в них играют целыми днями напролет, чтобы убедиться, что все юниты настроены как следует. А после схватки по сети разработчики собираются вместе, чтобы обсудить свои наблюдения. Это что, такой обычай?

Это единственно верный подход. Тестеры, конечно, опишут ошибки в соответствующих формах и тщательно их задокументируют, но когда вы проверяете, как играется в эту игру, ничто не может заменить живое обсуждение.

Рон привел пример нестыковки в игре, найденной при тестировании. «Если лучники создаются слишком быстро и вы излишне легко захватываете вражескую базу, мы увеличиваем время, необходимое на их создание, и снова переигрываем это место». И так до тех пор, пока игра не станет должным образом сбалансированной.

Напоследок Рон сообщил, что в Humongous и в родственной ей Cavedog внешнее тестирование не проводится, потому что весь контроль качества осуществляется соответствующими отделами внутри этих компаний. «Впрочем, - философски заметил Рон, - все течет, все изменяется...»

В компании Cavedog вошло в традицию по окончании тестирования проводить общие собрания разработчиков, на которых обсуждаются настройки игры. (Приводится с разрешения компании Cavedog Entertainment, Inc.)


Маркетинг и работа с прессой

Глава 16

Маркетинг и работа с прессой

Суровая реальность такова: если никто не знает о вашей игре, ее качество не имеет никакого значения, потому что игру просто не будут покупать. Сегодня, чтобы продать игру, необходимо: а) поднять вокруг нее шумиху; б) кричать о ней на каждом углу; в) торговать ею везде, где только можно. Впрочем, достаточно будет хотя бы одного из этих пунктов. (Последняя оговорка доказуема: игра Deer Hunter никак не рекламировалась и не упоминалась в журналах, зато ее можно было найти в каждом магазине по цене менее 20 долларов!)

У сотрудников пресс-службы (или, если угодно, PR-службы) и службы маркетинга цель одна и та же: сделать игру известной, но средства, которые они используют, совершенно разные. Если пресс-служба занимается исключительно вопросами обеспечения поддержки в различных СМИ, то служба маркетинга ориентирована на общение непосредственно с потребителем через рекламу, внешнее оформление и специальные предложения, не забывая и о торговой сети, решая вопросы сбыта, представления продукта на рынке и т.п.

Даг Ломбарди (Doug Lombardi), сотрудник службы маркетинга компании Sierra Studios, так описывает области деятельности работников каждого из этих подразделений:

Чтобы накопить нужную критическую массу общественного интереса к продукту, издателю необходимо обратить пристальное внимание на пресс-службу и отдел маркетинга.

Вообще говоря, сотрудники пресс-службы отвечают за все связи с прессой, через которую до конченых пользователей доводятся сведения о продукте путем предварительных обзоров, статей, очерков и т.п. В их обязанности входит организация пресс-туров, различных мероприятий, презентаций, студийных интервью и интервью с разработчиками. Вдобавок сотрудники службы по связям с общественностью занимаются выпуском пресс-релизов, посвященных игре, ее разработчикам и их компании, а также отвечают на все вопросы журналистов различных изданий по поводу интервью, иллюстративного материала и т.д.

С другой стороны, сотрудники службы маркетинга в основном занимаются более прямой работой с потребителями: рекламой, внешним оформлением продукта и т.п. В большинстве случаев руководитель службы маркетинга работает в тесной связи с рекламными студиями и отвечает за создание образа продукта. В эту задачу входит создание всех визуальных материалов, определяющих продукт для потребителя, включая узнаваемую упаковку и рекламные объявления. Руководитель службы маркетинга отвечает также за совместных рекламные программы и акции с другими компаниями, когда, например, производитель программного обеспечения совместно с производителем оборудования договариваются о мероприятиях по совместному продвижению на рынок продукции обеих компаний.

Многие разработчики и издатели для решения этих вопросов предпочитают обращаться к специализированным агентствам по работе с прессой или маркетингу. Далее мы рассмотрим доводы «за» и «против» такого подхода.

Цель этой главы – дать представление о роли маркетинга и работы с прессой, а также привести советы профессионалов своего дела, которые расскажут о наилучших способах ведения успешной информационно-рекламной и рациональной маркетинговой кампании.

Работа с прессой

Билл Линн (Bill Linn), Linn PR

Компания Linn Public Relations, Inc. была основана Биллом Линном, ветераном игровой индустрии по работе с прессой. В числе его клиентов - знаменитые компании-производители игр, среди которых достаточно назвать лишь несколько имен: Sierra Studios, THQ, Broderbund и 3DO Company.

По утверждению Билла Линна, собственно разработчики имеют гораздо больше возможностей при общении со СМИ, нежели издатели, и им следует это знать. Он говорит:

Мы считаем, что ключ к успеху пресс-кампании - это привлечение журналистов к тесной работе с создателями игры. Издатели часто упускают это. Мы стараемся работать именно в этом направлении, поскольку разработчики имеют громадные возможности без заметных затрат добиться превосходных результатов пресс-кампании.

Вот несколько золотых правил Билла Линна, умелое применение которых отличает хороших специалистов по работе с прессой.

Связи

Билл считает, что лучший материал следует ждать от того журнала, с редактором которого у вас хорошие отношения. Но как наладить эти отношения?

Если у вас нет своей пресс-службы, вы должны предпринять определенные усилия, чтобы предоставить нужную информацию нужному редактору в нужное время. Я подчеркиваю слово «нужное», потому что назойливость раздражает журналистов. Предположим, вы прочитали в журнале о некоей компании, делающей игру, похожую на вашу. Узнайте имя и электронный адрес редактора и отправьте ему письмо. Скажем, такое: «Я прочел в вашем журнале материал о <название игры> и хотел бы ознакомить вас с нашим продуктом...» Завершите свое письмо, непременно краткое, личным приглашением посмотреть на игру. Если вам не ответят, не падайте духом. В следующий раз, как только вы реализуете нечто стоящее, снова отправьте редактору небольшое сообщение со словами: «Привет, мы только что сделали то-то, то-то и то-то; может быть, вам будет интересно взглянуть?» Главное - быть простым в общении, ненавязчивым и открытым, не создавать напряжения и не «доставать» своего собеседника. Журналисты ненавидят самонадеянность, высокомерие, большие претензии, бесцеремонность и назойливость.

Рекламируйте образ

Признавая, что этот подход несколько отличается от того, чем обычно занимаются сотрудники пресс-служб, Билл тем не менее советует рекламировать нечто большее, чем просто описание игры.

С самого начала вы должны подавать в первую очередь образ своего детища. Что вдохновило вас? Какие игры повлияли на ваш проект? Какие личные качества авторов способствовали работе над проектом? Как вы собирали команду? Вот вопросы, которые всегда интересуют журналистов. Если вы забросаете их прилагательными в превосходной степени и обнаружите свои претензии, ничего хорошего они не напишут. Надо дать им то, чего они ждут, - помочь им создать о вас рассказ, например, описав процесс разработки вашей игры. Набросайте примерный план будущей публикации, опишите процесс создания игры в хронологическом порядке, с самого начала по сей день. Планируя беседу с журналистом, выделите наиболее яркие моменты, которые могут быть интересны для его издания, и используйте их во время разговора.

Не забывайте о команде

Наряду с правильной подачей образа игры Билл Линн рекомендует не забывать о том, что в работе с прессой могут помочь все члены команды разработчиков.

Мы всегда стараемся, чтобы журналист встретился с главным художником, ведущим программистом и даже с тестером. Пусть вся команда будет вовлечена в раскрутку игры. Сделайте так, чтобы все в этом участвовали. Однако прежде обязательно проведите с разработчиками ликбез по общению с журналистами, составьте план визита прессы. Вообще, для успешного проведения подобного мероприятия нужно иметь приличный опыт.

Дополнительные сведения о том, как работает Билл Линн, о его опыте и оказываемых им услугах, можно почерпнуть на сайте www.linnpr.com.

Женевьева Остергард (Genevieve Ostergard), Sierra Studios

Женевьева Остергард, руководитель пресс-службы компании Sierra Studios, работает как с изданиями для специалистов, так и со СМИ, рассчитанными на массового потребителя. Перед тем как перейти в Sierra Studios, она работала и в специализированном агентстве, и в таких крупных игровых издательствах, как Microsoft и Interplay.

Женевьева подтвердила, что хорошие связи - главное условие успешной карьеры сотрудника пресс-службы.

Пресс-служба - это связи и только связи. Если вы работаете с прессой, то должны лично знать редакторов нужных вам изданий. Познакомиться с ними можно на выставках, отраслевых мероприятиях, презентациях или просто назначив с ними встречу. Следует быть в курсе специализации их издания и представлять себе, за что отвечает тот или иной человек.

Помимо налаживания доверительных отношений с журналистами и редакторами Женевьева отметила еще несколько моментов, о которых следует помнить начинающим сотрудникам пресс-служб:

• Пресс-релизы. Они должны быть профессиональны и всегда к месту. Не перехваливайте. Полезно ознакомиться с имеющейся литературой, посвященной стилистике и приемам изложения для прессы.

Начинающим сотрудникам пресс-служб Женевьева Остергард рекомендует следующие книги: The Associated Press Stylebook and Libel Manual под редакцией Norm Goldstein (Perseus, 1998); Mervin Block, Writing Broadcast News: Shorter, Sharper, Stronger (Bonus Books, 1997), David R. Yale, Publicity Handbook (NTC, 1992).

• Продумайте свою стратегию. Разработайте план и следуйте ему. Не стоит, опубликовав материал, сидеть и ждать, что кто-то постучит в вашу дверь.

• Будьте отзывчивы и доступны. Перезванивайте или предлагайте другие способы связаться с вами. Это поможет вам создать доверительные отношения с журналистами.

• Мыслите творчески. На бесплатные сувениры и подарки люди падки всегда, но лучше всего устроить мероприятие и пригласить прессу. Помните, что в обычной вечеринке, даже если она удалась, нет ничего достойного освещения в печати. А мероприятие, связанное с вашей игрой, в котором приняла участие знаменитость или особый гость, обязательно привлечет внимание журналистов.

• Не забывайте о полной и точной базе данных. Если вы что-то кому-то пообещали, обязательно сделайте это.

Заполучить место на первой обложке популярного издания - само по себе здорово. И, конечно, это помогает в продвижении игры на рынок. Женевьева Остергард добилась появления информации об игре Half-Life на обложке журнала PC Accelerator. (Приводится с разрешения компаний Sierra Studios и Imagine Media, Inc.)

Майкл Мейерс (Michael Meyers), Acclaim Entertainment

Майкл Мейерс - руководитель пресс-службы компании Acclaim Entertainment, отвечающий за продвижение на рынок консольных игр. Вот три совета, которыми Майкл делится с новичками:

Изучите СМИ, с которыми работаете

Не предлагайте ничего изданию, телевизионному шоу, радиопрограмме или веб-сайту, пока не ознакомитесь как следует с их стилем, редакционными планами, концепцией и т.п. Если вы разберетесь в журналистской работе, у вас появится больше шансов заинтересовать СМИ своими продуктами.

Добейтесь взаимопонимания

Разработчики и пишущая братия разделяют общую страсть к играм. Один из самых приятных моментов в моей работе заключается в том, что я имею возможность обсуждать игры с журналистами, которые увлечены предметом разговора так же, как и я. Если они видят вашу увлеченность, то гораздо более охотно поверят вашим словам о том, что ваша игра - самая лучшая в таком-то жанре для такой-то платформы.

Знайте своих конкурентов

Одна из самых больших ошибок, которую только можно совершить, - проводить презентацию своего изделия, не изучив перед этим конкурирующие продукты. Кто-нибудь из журналистов обязательно захочет узнать, чем ваша игра отличается от близкой игры N. И если вы не знаете, в чем ваша игра превосходит конкурента, журналисту не о чем будет рассказать своим читателям.

Иллюстрируя свои советы, Майкл Мейерс поведал любопытную историю об одной недавней рекламной кампании.

Одной из самых больших рекламных акций, в которой я принимал участие, была кампания по раскрутке игры Turok: Dinosaur Hunter для Nintendo 64. Turok был одним из первых продуктов для этой приставки, выпущенных не изготовителем, а сторонними разработчиками. Что еще более важно, игра была первой серьезной попыткой Acclaim Entertainment перейти к выпуску новой для нее продукции. От ее успеха напрямую зависело выживание компании.

У каждого из нас, а также служащих агентства TSI, с которым мы сотрудничали, был свой участок в кампании по продвижению этой игры на рынок. Я отвечал за так называемую «атаку через Интернет», представлявшую собой адресную кампанию по работе с потенциальными покупателями. Она заключалась в том, что мы договаривались со всеми профессиональными и любительскими веб-сайтами, посвященными Nintendo 64, чтобы те уделяли нашей игре побольше внимания на своих первых страницах. «Атака» осуществлялась в течение восьми недель, предшествовавших выпуску игры. Каждый понедельник мы рассылали крупнейшим профессиональным веб-сайтам предназначенные только для них игровые скриншоты и ролики в формате QuickTime. У каждого из этих сайтов было исключительное право использования полученных ими материалов в течение трех-четырех дней. После этого все материалы помещались на сервер, с которого любой человек мог загрузить их на свой веб-сайт.

Поскольку посетители веб-сайтов, посвященных Nintendo 64, скорее всего, либо уже имеют приставку, либо планируют приобрести ее в ближайшее время, мы таким образом снабдили их всей информацией, необходимой для принятия решения о покупке нашей игры.

Здесь надо заметить, что многие игры, продвижением которых занимался Майкл Мейерс, пользовались весьма приличным спросом. В 1998 году это были South Park, Turok 2: Seeds of Evil и WWF: Warzone для приставок Nintendo 64 и Sony PlayStation.

Тем, кто стремится к овладению навыками работы с прессой, мы рекомендуем обратиться к Американскому обществу по связям с общественностью (The Public Relations Society of America, PRSA), его электронный адрес: www.prsa.com.

Адам Кан (Adam Kahn), Acclaim Entertainment

Еще один сотрудник компании Acclaim Entertainment, Адам Кан, отвечает за продвижение на рынок игр, предназначенных для ПК. До Acclaim Адам был сотрудником Shandwick International, фирмы по работе с прессой, где занимался продвижением игр компании Microsoft. Ниже он рассказывает о своем подходе к работе с игровой прессой и дает несколько советов новичкам.

О методичности, расторопности и практичности

Разработчикам следует знать несколько ключевых вещей о работе с игровой прессой. Прежде всего помните, что это не точная наука. Работа с журналистами требует методичности, расторопности и практичности, но ничего страшного в этом, конечно, нет. Высказав это утешение, я бы все-таки хотел отметить, что работу с прессой лучше всего поручать людям, которые отличаются этими качествами. Я имел дело со множеством мелких разработчиков и видел уйму людей, которые считали себя методичными, расторопными и практичными, хотя на самом деле таковыми не являлись. Существует немало примеров тому, что очень трудно быть сразу и разработчиком на полной ставке, и специалистом по связям с прессой. Служебные обязанности тех и других не имеют решительно ничего общего и, по-видимому, востребуют совершенно разные типы личности. Разработчикам следовало бы больше доверять работу с прессой тем, кто знает и любит эту профессию, а самим сосредоточиться на создании хороших игр.

Когда я говорю о методичности, расторопности и практичности, я имею в виду следующее.

Быть методичным - значит уметь смотреть на свою работу с высоты птичьего полета. Старайтесь планировать рекламную кампанию от начала до конца, заранее просчитывая, когда появится материал об игре, где он появится и каким будет. По моим наблюдениям, многие разработчики очень импульсивны. Что-нибудь идет не так, как хочется, - и у них внезапно возникает желание поместить материал прямо сейчас именно вот в этом журнале, или они видят Джона Ромеро (John Romero) в Rolling Stone и тут же решают, что им нужно ровно то же самое. Так не бывает. Если вы методичны, то у вас все распланировано заранее и, если не случится каких-либо крупных потрясений, вы сможете успешно справиться со всеми проблемами без особого беспокойства. Быть методичным - это значит принимать трудные решения заблаговременно. Допустим, у вас есть две игры, которые выпускаются в течение нескольких месяцев друг за другом. На какой из них надо сосредоточить главные усилия? Некоторые компании заявляют, что на раскрутку всех выпускаемых игр отводятся одинаковые средства, но это неправильно. Отдача от финансовых вложений в рекламу зависит от продукта. Методично мыслящий специалист рассмотрит все обстоятельства и примет решение, учитывая общую политику компании.

Быть расторопным означает знать, с кем сотрудничаешь, особенно в прессе. Журналисты имеют дело со множеством игр, редакторам и авторам статей приходится напряженно работать, чтобы со всем этим управиться. Если вы сможете хоть как-то облегчить их работу, это обязательно будет вознаграждено. Если они звонят вам и просят у вас скриншоты из игры, отправьте их как можно скорее. Здесь не может быть никаких отговорок. Это просто надо сделать. Быть расторопным означает также не выказывать пренебрежения в чей бы то ни было адрес. Редактор малюсенького веб-сайта, посвященного играм, может стать главным редактором одного из ведущих игровых журналов (что уже неоднократно случалось), а «послать» кого-нибудь - самый простой способ навсегда испортить отношения. Будьте внимательны ко всем без исключения.

Практичность в моем представлении противоположна методичности. Нельзя всегда витать в облаках, наступает момент, когда приходится сосредотачиваться на тактических вопросах, вроде организации презентаций, творческого подхода к их проведению и выбора подходящего для них времени. Гордитесь умением организовать большую презентацию так, чтобы журналисты потратили свое время с толком. Будьте изобретательны. Но никогда не отнимайте попусту время у представителей прессы. Это опять напоминает нам о расторопности. Вы же хотите, чтобы журналисты читали каждое ваше послание по электронной почте, а транжирить их время - самый легкий способ вынудить их игнорировать вас.

Контакты с прессой обходятся не так уж дорого, особенно если вы уже работали в игровой индустрии и знаете, к кому именно следует обратиться. Если вы не знаете нужных людей, вам будет тяжелее. В таком случае сначала следует тщательно изучить посвященные играм журналы и веб-сайты. Если же вы вовсе неизвестны в мире игр, придется походить по редакциям соответствующих изданий, не забыв о личной встрече с редакторами. Это самый эффективный способ оказаться замеченным.

Наконец, неплохая идея - обратиться к небольшому агентству по работе с прессой, работающему в этой отрасли. Эти люди потратили годы на установление и укрепление своих связей, и вы сможете воспользоваться тем, что оплачено всеми гонорарами, которые это агентство получило от других компаний. Использование профессиональных агентств позволит вам сосредоточиться на создании игр, что, по-видимому, получается у вас лучше всего, раз вы разработчик.

Финальная цитата из Адама Кана: «Если вы уже знакомы с редакторами игровых изданий, добиться от них публикации материала о вашей игре совсем несложно. Не забудьте лишь отправить им вовремя законченную игру, и они непременно опубликуют рецензию».

Следует ли разработчикам и издателям проводить рекламную кампанию своими силами, расширив свой штат, или лучше обратиться к специальному агентству? У каждого из этих вариантов есть свои преимущества и недостатки. С одной стороны, у штатных сотрудников пресс-службы компании есть возможность более тесного знакомства с игрой, не говоря уже о том, что они работают только на себя. Агентство, с другой стороны, обычно обходится дешевле, чем собственная пресс-служба, оно имеет опытный персонал и широкие связи в СМИ. Недостаток этого подхода в том, что у агентства несколько клиентов, и оно может не уделить вам достаточного внимания.

Маркетинг

Брэндон Смит (Brandon Smith), Cavedog Entertainment

Брэндон Смит был менеджером по работе с прессой в сенсационном проекте Total Annihilation (включая продолжения), где он, будьте уверены, сыграл огромную роль в успехе этой игры во всем мире. Слова Брэндона: «Я думаю, что при разработке плана продвижения игры на рынок самое главное для специалиста по маркетингу - знать ее потенциальных потребителей».

Когда я говорю «знать», я имею в виду знать по-настоящему. Знать, что они едят, где проводят время, чем занимаются помимо компьютерных игр - буквально все, абсолютно все. Я готов повторять это снова и снова. Если вы в этом не разберетесь, ваша работа превратится в ад, а жизнь вашего продукта на рынке сильно сократится.

Напротив, если вы как следует изучите своих покупателей, ваша жизнь существенно упростится, потому что вам сразу станет интуитивно ясно, что следует делать. Вы поймете, что побуждает ваших потенциальных клиентов делать покупки и как лучше всего соответствовать их устремлениям. Например, зная о том, что «ваши» покупатели предпочитают бейсболу футбол, вы сможете провести эффективную рекламную акцию совместно с NFL (National Football League). Если же «ваш» покупатель берет игры напрокат, то совместно с пунктом проката можно предложить специальную скидку при покупке игры тому, кто возьмет напрокат три игры.

На вопрос, как можно протолкнуть на рынок свою продукцию при минимальных затратах, Брэндон Смит ответил, что с каждым годом это становится все труднее и труднее из-за усиливающейся конкуренции. «По правде говоря, без сотрудничества с крупными издателями и дистрибьюторами просто не обойтись». Так что же делать мелкому разработчику? В ответ Брэндон предложил несколько идей:

Я думаю, есть несколько вещей, к которым можно прибегнуть в том случае, если нет возможности воспользоваться дистрибьюторской мощью уровня Electronic Arts или GT Interactive. Впрочем, эти советы справедливы для всех компаний, независимо от их величины.

• Выпускайте качественную продукцию! Без всяких оговорок. Никакой, даже самый мощный маркетинг, не спасет скверную игру. Конечно, и из этого правила бывают исключения, но я никогда не стал бы делать на это ставку.

• Если бюджет скромен, его лучше направить на установление связей с прессой. Это эффективнее всего, а потенциальная отдача огромна. Одно дело поместить объявление о том, что ваша игра – самая крутая и новаторская, и совсем другое, если то же самое скажет редактор Next Generation. Маркетинг и реклама - это стержень эффективной кампании, но они могут оказаться крайне дорогими (и первыми попадают под сокращение расходов). Положительные отзывы о вашей игре в прессе могут вызвать большие разговоры о ней, что приведет к тому, что ее станут покупать. Это поможет также в реализации следующего, последнего пункта.

• Заблаговременно создайте массовую поддержку снизу. Это поможет на целом ряде направлений. Дело в том, что одна из наиболее важных (и дорогих) задач маркетинга - убедить розничного торговца брать игру на реализацию (отсюда и необходимость в крупном издателе или дистрибьюторе), т.к. если вашей игры нет в магазинах, она не будет продаваться. Обычно для этого необходимо продемонстрировать торговым точкам, что игра будет поддержана МОЩНОЙ рекламной кампанией. К несчастью, это довольно дорого, и если у вас нет денег, обстоятельства складываются против вас. Но механизм традиционного прямолинейного проталкивания продукта на рынок именно таков: вы убеждаете розничную торговлю в том, что они должны брать у вас продукт, поскольку он будет хорошо продаваться благодаря вашей рекламной поддержке.

И тут Брэндон подробно останавливается на массовой поддержке продукта снизу.

Массовая поддержка вашего продукта может помочь (ключевое слово здесь «помочь», так как гарантии нет никакой) достичь той же цели, но другими способами. Вместо того чтобы самому убеждать торговую точку взять продукт на реализацию, вы можете предоставить эту роль потребителям. Возбудив в публике интерес к своему изделию, можно заставить ее работать на достижение вашей цели - застолбить место на магазинных полках и продать игру. Стратегия пролезания на рынок, доказавшая в ряде случаев свою эффективность, заключается в сочетании спроса «снизу» (когда люди начинают спрашивать ваш продукт в магазинах) с вашими собственными усилиями по работе с торговой сетью (когда вы с помощью вырезок из газет и т.д. уведомляете их о существовании большого спроса на ваш продукт). Эта стратегия имеет целью создать у торговой сети впечатление, что они лишатся части прибыли, если не возьмут игру на реализацию. К одной и той же цели можно прийти разными путями. Конечно, лучше всего сочетание обоих способов.

Все это, конечно, сильно упрощено, но в принципе дело обстоит именно так. Успех или неуспех отдельно взятой компании зависит именно от того, как именно она будет решать эти проблемы.

Мы попросили Брэндона Смита привести пример безукоризненно проведенной маркетинговой акции.

Меня глубоко впечатлила рекламная кампания Sony, предшествовавшая выпуску игровой приставки PlayStation несколько лет назад. Они сделали все как надо (конечно, у них был фактически бездонный бюджет). Они знали круг покупателей настолько хорошо, что обошли царившую тогда на рынке игровых приставок фирму SEGA и переманили к себе ее потребителей. Их приставка была великолепна.

При этом, благодаря грамотной рекламной кампании, для людей старше двадцати неожиданно стало модным иметь эту систему. То есть более старшие потребители с более высокими доходами обзаводились техникой, традиционными покупателями которой до этого были люди помоложе. Рекламные объявления были эффективны настолько, что потенциальные потребители записывали их с телевизора и вырывали из журналов, потому что компания прятала в них коды к будущим играм. Эти объявления просматривались вдоль и поперек и напряженно обсуждались на работе, дома и в Интернете. Как видите, с поддержкой снизу тут тоже все было в порядке.

Они создали PlayStation Underground, клуб поклонников, где можно было получить демонстрационные версии самых последних игр... опять-таки забота о поддержании интереса непосредственно в массах.

Я считаю, что это была одна из самых эффективных кампаний по выпуску нового массового продукта за всю историю (не только в игровой отрасли - это пример для любого товара).

Вине Дезидерио (Vince Desiderio), Running With Scissors

Вине «Дези» Дезидерио является исполнительным директором студии по разработке игр Running With Scissors (Тусон, штат Аризона, США). Первой игрой «Бегущих с ножницами» был вызвавший противоречивые отклики шутер Postal, где игрок брал на себя роль рассвирепевшего почтового работника, который расхаживал по собственному городу... с оружием. Можно утверждать, что успех игры Postal во многом объясняется сопровождавшей ее выпуск информационно-рекламной кампанией. Вот слова Дези о беспрецедентной шумихе в СМИ по поводу этой игры:

Postal завоевал множество наград и получил уйму хвалебных отзывов. Одна из моих любимых наград от сенатора от штата Коннектикут Джозефа Лейбермана (Joseph Leiberman) называется «худший продукт американского общества № 1». К слову, «номером вторым» был Мэрилин Мэнсон (Marilyn Manson), а третье место заняла реклама нижнего белья Калвина Кляйна (Calvin Klein). Еще одна впечатляющая награда - «Лучшая упаковка» от Ассоциации издателей программных продуктов (Software Publishers Association, SPA), довольно иронический приз, если учесть что игра исчезла с полок самых крупных магазинов через месяц.

По мнению Дези, при разработке большинства игр о маркетинге даже не думают. Он выделил вкратце основные моменты, на которые следует обратить внимание начинающему разработчику.

• Определите жанр игры. Для какой платформы предназначена игра, на какой круг потребителей рассчитана? Адресована ли ваша разработка многочисленным поклонникам ролевых игр или «простому смертному», среднестатистическому игроку с неопределенными пристрастиями? Другими словами, к какому жанру относится игра: экшен, спорт, головоломка? Для какой возрастной группы предназначена?

• Название. Running With Scissors - вот название, которое сразу говорит о том, что компания не имеет никакого отношения к обучающему ПО. Название игры Postal такое же простое и ясное, как Doom и Quake. Слов в названии может быть больше, чем одно, но они должны о чем-нибудь говорить, заинтриговать вас, вызвать желание поиграть.

• Сюжет. Хороший сюжет послужит не только для самой игры. Кто главный персонаж? Кого или что представляют собой враги? Тут стоит подумать о возможностях для лицензирования (книга, мультфильм, игрушки), дополнительных выпусках, продолжениях.

Дези вкратце рассказал нам о том, как Running With Scissors использовала свой нашумевший дебют для маркетинга игры.

Мы основали новую компанию и хотели, чтобы нас знали как разработчиков скандальных игр, отсюда и название - «Running With Scissors». На вопрос: «Что значит RWS?» - я обычно отвечаю: оно означает, что мы - это все, что вам запрещали делать в детстве.

У нас был один-единственный шанс сделать хит, потому что игра выпускалась на собственные деньги. Нам нужно было получить такую игру, которая бы моментально узнавалась и, естественно, сносила у потребителя крышу. Вот так он и появился, наш Postal. Мы нуждались в средстве для распространения информации об игре, которое не отождествлялось бы с кем-нибудь конкретно, поэтому мы создали вымышленный персонаж «Gimp», у которого и сейчас, вот уже год спустя, все еще около десяти тысяч подписчиков.

Гимп (Gimp) - талисман компании Running With Scissors и что-то вроде второго «я» ее сотрудников. Его автор - Дези, которому пришло в голову, что с точки зрения маркетинга было бы неплохо иметь инструмент для распространения новостей и формирования сети поклонников. Гимп по сей день продолжает выпускать еженедельные рассылки. «Короче говоря, - сказал Дези, - Гимп был очень даже реальной частью нашей маркетинговой кампании».

Мы известили мир о выходе игры Postal с помощью пресс-релизов, а также открыли веб-сайт RWS. На это немедленно отреагировала почтовая служба - мы получили письмо непосредственно от начальника почтовой службы США! Что я сделал? Я... использовал это письмо в следующем пресс-релизе! Все остальное описано в анналах - поднялась жуткая шумиха не только в игровой прессе, но и в центральных СМИ - вплоть до Австралии! Мы попали на первую полосу Wall Street Journal (там же потом были опубликованы еще два посвященных нам материала) и Sunday London Times, около пятидесяти раз выступали на телевидении по всем ведущим телеканалам, около ста постановок на радио, у нас были дебаты в прямом эфире CNN с губернатором Арканзаса и т.д. и т.п.

Несмотря на то что игра вышла уже довольно давно, Дези говорит, что, благодаря их рискованным ходам и хитрым приемам маркетинга, Postal до сих пор упоминается в СМИ, например в недавнем номере Reader's Digest. Внизу - кровавая сцена из игры Postal; справа - эскиз, дающий общее представление о главном... гм... герое. (Приводится с разрешения компании Running With Scissors, Inc.)

Так какой же из всей этой истории следует вывод? Дези ответил так:

Маркетинг делает игру известной, с помощью рекламы в печати или в Интернете, на радио или на телевидении, пресс-релизов или статей в газетах, и особенно - рождая молву. Возникает естественный вопрос, как добиться, чтобы об игре заговорили, не затратив ни единого доллара? Ответ: создавайте новости; наиболее экономичный метод - использовать Интернет для выпуска пресс-релизов, но определяющий фактор, который слишком часто упускают из вида даже состоявшиеся издатели и разработчики, - это активное продолжение кампании. Новости о выходе игры Postal и сопровождавшая его скандальная реклама, заглохли бы, если бы мы не поддерживали эту шумиху, постоянно изобретая все новые и новые поводы для нее. Были потрачены многие часы работы на написание ответов на тысячи электронных писем, на создание Гимпа и постоянный выпуск все новой и новой информации об игре. Когда я спрашиваю у себя, почему люди до сих пор интересуются игрой Postal (а на самом деле это вопрос о том, какую следующую игру готовит Running With Scissors), ответ абсолютно ясен: потому что мы создали культуру, мы создали потребность, желание получить что-то в этом роде!

Тем, кто задает такой же вопрос, интересно будет знать, что следующая игра компании будет называться Flesh & Wire.

Даг Ломбарди (Doug Lombardi), Sierra Studios

Даг Ломбарди, сотрудник Sierra Studios, обсуждая необходимость и своевременность выпуска через Интернет демо-версий игр, поможет нам более четко различить работу с прессой и маркетинг.

С точки зрения маркетинга одно из самых мощных средств продвижения новой игры - это распространение демонстрационной версии. Это особенно верно, если ваша игра еще не привлекла внимания широкой аудитории.

Иногда даже отличную игру по тем или иным причинам не выделяют из общей массы. В этом случае выпуск эффектной демонстрационной версии - за пару недель до выхода самой игры - дает публике возможность ознакомиться с нею, и игра получает достаточную известность благодаря самой эффективной рекламе, какая только известна человечеству, - слухам о ней. Все проведенные на эту тему исследования показывают, что большинство пользователей, прежде чем купить игру, предпочитают попробовать ее в виде демо-версии; а многие игроки никогда не купят игру, если не получат такой возможности. В наше время любому программному продукту предопределена короткая жизнь, поэтому крайне важно, чтобы играющей публике был доступен привлекательный образец, подчеркивающий достоинства игры. Захватывающая демо-версия игры позволяет увидеть лучшие стороны продукта, она заставляет потенциального покупателя подумать: «Ого, да они, кажется, не врут. Это и в самом деле неплохая игра. Хочу!».

А может ли случиться так, что появление демонстрационной версии вызовет обратный эффект? Даг ответил, что это вполне возможно:

Медаль оборачивается другой стороной в том случае (и тому масса примеров), если демо-версия просто не готова к нужному моменту или играбельна настолько, что публика решает, что демо-версии вполне достаточно.

Что касается выбора времени для выпуска демонстрационной версии, то ее появление до поступления в продажу полной игры может оказаться как эффективным, так и опасным. Конечно, в ряде классических случаев демо-версии не просто помогли, а сделали игру. Но есть и несколько примеров обратного свойства, когда издатели или разработчики выпускали свои демо-версии слишком рано, иногда за многие месяцы до релиза игры.

В последнее время все чаще можно наблюдать, как демонстрационные версии появляются после выпуска основного продукта. Такой вариант рискован, если об игре мало говорили до ее выхода. Но если у игры шумная реклама, то выложенная в Интернете не позднее трех месяцев после выпуска самой игры удачная демонстрационная версия поможет вам сорвать больший куш с продаж. Конечно, это верно лишь постольку, поскольку демо-версия будет интересна игроку, побуждая его хотеть большего.

Вольфганг Валк (Wolfgang Walk), Blue Byte

Руководитель проекта Вольфганг Валк объяснил, почему с точки зрения маркетинга следует обязательно продумать вопрос о выпуске демонстрационной версии.

Потребитель уверен, что демонстрационная версия - это лучший способ проверить игру и решить, стоит ли ее покупать. Это и есть самое главное ее предназначение, в том числе и для разработчика. Вы хотите, чтобы ваш потребитель был доволен игрой? Дайте ему демо-версию, и у вас будет полное моральное право сказать: «По крайней мере мы тебя предупреждали!»

С другой стороны, если игра слабая, выпуск демо-версии вовсе не гарантирует успеха основного продукта. «Формирование ожидания продукта с помощью Интернета - важная часть маркетинга, хотя я не думаю, что существует так уже много игр - не самого высокого качества или получивших недостаточную маркетинговую поддержку, - ставших популярными благодаря успеху демонстрационной версии».

Наконец, Вольфганг считает, что успех демонстрационной версии еще не означает успеха самой игры. Есть ли тому примеры из практики Blue Byte?

Игра Incubation вызвала некоторый интерес своей демо-версией, благодаря которой игру купило, быть может, несколько сотен человек, до этого никогда о ней не слышавших. Но до настоящей популярности тут далеко. Однако раз журнал PC Gamer назвал ее лучшей пошаговой стратегией США 1997 года, то, вероятно, причиной отсутствия интереса было отнюдь не низкое качество. Я, как руководитель проекта, могу сказать, что с качеством в игре все в порядке. До сих пор существуют веб-сайты поклонников Incubation и довольно часто появляются новые уровни, созданные в разных концах света.

Вольфганг Валк из компании Blue Byte говорит, что выпуск демонстрационной версии - это идеальный вариант, если игра того стоит, но предупреждает, что продажи игры могут не зависеть от успеха демонстрационной версии. Таковой была несчастливая судьба восторженно встреченной критиками, но провалившейся у игроков походовой стратегии Incubation. (Приводится с разрешения компании Blue Byte, Inc.)

Лиз Белл (Liz Bell), THQ

Лиз Белл из компании THQ высказала свое мнение по поводу необходимости выпуска бесплатных демо-версии игр для ПК как элемента эффективной маркетинговой стратегии.

Демо-версии должны выпускаться только для высококачественных игр, в отношении которых есть уверенность, что они получат положительную оценку. Демо-версии должны давать ясное представление обо всей игре, но включать в себя ровно столько материала, чтобы возбудить интерес к ней. И только. Воздержитесь от введения в демо-версию всех уровней, оружия, персонажей и возможности сетевой игры, чтобы потребитель по-прежнему стремился получить впечатление от полной игры. Оптимальный вариант - демо-версия и картинка из игры на диске журнала за восемь недель до выпуска продукта, распространение демонстрационной версии по Интернету, затем повторный выпуск журнальных демо-версии через четыре недели с одновременной подготовкой на демо-версии менеджеров по работе с розничной сетью. Если же вы выпускаете одну демонстрационную версию за четыре недели до выхода игры, можно будет ограничиться только распространением в Интернете.


Разработка веб-сайтов, посвященных играм

Глава 17

Разработка веб-сайтов, посвященных играм

Менее чем за пять лет Интернет из никому не известной «забавы» для научных сотрудников превратился в одно из самых захватывающих достижений двадцатого века. Количество пользователей Сети выросло с пары тысяч университетских ученых и правительственных чиновников до 50 с лишним миллионов человек и продолжает расти экспоненциально.

Рождение World Wide Web (WWW) ознаменовало начавшуюся с середины 90-х годов коммерциализацию Интернета. Простой и удобный интерфейс одного из первых браузеров Mosaic или более позднего Netscape позволил перемещаться по этой информационной вселенной проще, чем когда-либо. Появилась возможность доступа к миллионам документов и баз данных, не говоря уже о том, что вскоре ко всему этому прибавились мультимедиа-средства - фото, звук, музыка, анимация и видео.

Что же до игровой индустрии, то Сеть, несомненно, стала для нее настоящей находкой. WWW - практически идеальное место для игр, здесь вы можете сразиться один против всего мира, выбирая противников в любой точке земного шара. Сама собой отпала необходимость пересылки патчей (исправлений) к вновь вышедшим играм обычной почтой, на дискетках. В Интернете доступно огромное количество демо-версий самых свежих игр - скачивай и играй! Начинающие разработчики компьютерных игр - программисты, художники, дизайнеры, композиторы - могут, не выходя из дома, показывать свои творения всему миру. На игровое сообщество работает бесконечное множество электронных журналов (e-zines). Разработчики и издатели свободно распространяют дополнения к своим продуктам и средства разработки, позволяющие поклонникам создавать собственные варианты любимых игр. Веб-сайты энтузиастов, посвященные определенным игровым проектам или жанрам, объединяют на своих форумах и чатах десятки тысяч людей, являясь по сути этакими клубами по интересам. Разумеется, Сеть давным-давно стала местом торговли - вы можете заказать игру, и вам доставят ее прямо на дом. Чит-коды, попавшие в Сеть стараниями разработчиков, поддерживающих таким образом интерес к своим проектам, подробнейшие прохождения и советы по тем или иным играм, написанные самими игроками, появляются в Интернете во множестве и очень быстро, что зачастую затрудняет обоснование необходимости покупки официального путеводителя по игре (и это не считая доступа к интерактивным группам новостей и доскам объявлений, которые открыты для всех желающих). Журналисты, специализирующиеся на играх, имеют возможность работать на любое издание (как традиционное, так и электронное) и любой веб-сайт, находясь от него на расстоянии в тысячи километров, чему «виной» электронная почта, позволяющая мгновенно пересылать текстовые и графические файлы почти любых объемов (пример из НАШЕЙ жизни: в центральном, московском, журнале Game.EXE на ШТАТНЫХ должностях работали и работают журналисты, проживающие в Киеве, Воркуте, Санкт-Петербурге, Иркутске, Череповце и даже на Камчатке! - Примеч. ред.). Подобное перечисление возможностей, предоставляемых WWW, можно продолжать до бесконечности.

В этой главе обосновывается необходимость создания и поддержки веб-сайта, посвященного вновь выпускаемой игре - как вашей личной, распространяемой бесплатно (или условно-бесплатно), так и коммерческой. Ниже мы выслушаем рекомендации веб-мастеров и специалистов по маркетингу о том, как с выгодой использовать Интернет в своих целях. Вы узнаете, что сейчас принято размещать в Сети и чем интересный, яркий, умелый, изобретательный веб-сайт отличается от сайта формального и бесцветного.

Дэниел Брей (Daniel Bray), Cubik Media and Marketing

Дэниел Брей - художественный директор компании Cubik Media and Marketing, специализирующейся на разработке веб-сайтов. Один из самых крупных клиентов компании - всемирно известный издатель Eidos Interactive, Inc. Мы спросили Дэниела, почему создание игр сопровождается появлением их веб-сайтов? Что должно быть на таком сайте?

Насколько важно использование мультимедиа-средств (дополнительных плагинов и т.д.) и не боятся ли в таких случаях авторы сайта сетований на резкое увеличение времени загрузки страницы?

Классные веб-сайты идут рука об руку с классными играми. Игроманы отлично разбираются в технологии. Это одни из самых активных пользователей Сети, откуда они в основном и получают информацию о новых играх. Один из основных стимулов посещать те или иные сайты - демо-версии новых игр. На мой взгляд, выпуску игры всегда должна предшествовать демонстрационная версия. Кроме того, не менее важны скриншоты из игры, дающие игроку представление о том, как она выглядит.

Мультимедиа? То, что нужно! Средства мультимедиа вдыхают в веб-сайт жизнь, делают его захватывающим. Да, время загрузки все еще оказывает свое влияние, но с развитием пропускной способности линий связи эта проблема исчезнет.

Короче говоря, Дэниел Брей за плагины!

Дэниел Брей предсказывает, что игровые сайты скоро станут основным источником информации об играх. Поэтому он советует размещать на сайте столько мультимедиа, сколько возможно, чтобы произвести как можно большее впечатление на посетителей. (Приводится с разрешения Eidos Interactive, Inc.)

Саша Фернандес (Sacha Fernandes), Eidos Interactive

В то время как фирма Cubik занимается наполнением и оформлением веб-сайта компании Eidos Interactive, Саша Фернандес работает в последней менеджером по Интернет-маркетингу, отвечая как за сам сайт, так и за прямой маркетинг. Вот как она обосновывает необходимость создания и поддержания веб-сайта:

С появлением новых технологий WWW превратилась в очень важный инструмент, который, однако, многие не вполне признают как совершенно конкретное средство для извлечения прибыли. А между тем за свою относительно недолгую историю технологии Интернет-маркетинга превратили Сеть в чрезвычайно мощный инструмент именно маркетинга. Поклонники игр - прекрасно разбирающаяся в игровых технологиях аудитория, эти люди тратят большую часть своего длинного «рабочего дня» на разговоры в веб-форумах и навигацию по Интернету в поисках подсказок, чит-кодов и т.п.

Все больше и больше людей обращаются к Сети в поисках информации, для оформления туристических поездок, покупок и развлечений, в число которых входят, конечно же, и сетевые игры. Важно, чтобы ваш сайт реально соответствовал выпускаемому продукту. На самом деле игроки обычно ищут информацию за несколько месяцев до выпуска игры. Веб-сайт дает возможность издателю и разработчику поддерживать связь с потребителями, в силу чего становится эффективным инструментом влияния на рынок. В нашей индустрии проекты за время своей жизни зачастую претерпевают значительные изменения, и Сеть становится важным источником свежей информации. Цель заключается в том, чтобы вызвать у посетителей желание регулярно посещать ваш сайт, сделать его центром сообщества людей, которые имеют одинаковые интересы, превратить его в место, где можно обмениваться новостями, ссылками на другие игры и т.д. Это позволит реализовывать мощные программы перекрестного маркетинга (совместные программы, продвижение и закрепление на рынке других торговых марок и т.п.).

Саша считает, что веб-сайт, посвященный игре, должен содержать следующую информацию:

Все о продукте, включая сюжет и наиболее захватывающие особенности игры. Помните, это инструмент маркетинга. Разместите на нем все сведения, важные для продажи игры, не забыв при этом об эстетике.

Учтите, что вы соревнуетесь за внимание с уймой веб-сайтов, и чтобы выделиться, должны быть неотразимы. Чтобы удержать начальный уровень посещаемости, а затем увеличить его, необходимо превзойти всех по качеству дизайна и уровню использования программных средств. Dynamic (Shockwave) Flash, веб-сайты с поддержкой Java и т.п. - все это куда лучше работает на вас, чем обычный веб-сайт.

Наш опыт показывает, что основная масса посетителей имеет довольно мощные компьютеры, последние версии браузеров и хорошую связь (в основном T1, ISDN или DSL), так что размеры файлов не играют существенной роли. Мы полагаем, что содержание гораздо больше, чем время ожидания, определяет посещаемость сайта. Это доказывается тем, что демо-версии зачастую «весят» от 50 Мбайт и выше, а количество скачивании тем не менее огромно. Интерес к игре определяется поднятой вокруг нее шумихой. Если игра удалась, люди найдут способ заполучить демонстрационную версию или необходимый плагин для просмотра сайта.

Что касается скачивания файлов, то очень хорошо воспринимается наличие инструкций по их инсталляции и информация, указывающая примерное время загрузки файла с сайта разработчика/издателя, приведенное для различных скоростей связи.

Мы обсудили содержание, а насколько важна хорошая навигация? Саша Фернандес утверждает, что «навигация - это ключевой момент». Она продолжает: «Особенно это важно для коммерческих веб-сайтов, однако быстрая и эффективная навигация обязательна в любом случае. Если ваше «общение» с сайтом усложнено или допускает, чтобы посетитель, затратив много времени, ушел ни с чем, то шансы, что к вам вернутся, призрачны. Вы не сумели сделать посещение приятным».

В завершение разговора Саша упомянула о «конфетке», которую компания Eidos Interactive предложила своим пользователям на сайте Eidos TV.

Мы запустили Eidos TV в апреле 1998 г., используя технологию Flash. В дополнение к простому перечню информации о выпускаемых Eidos играх мы поддерживаем клубы поклонников, информационные бюллетени, комнату «стратегов» War Room и т.д. Все это делает веб-сайт приятной интерактивной средой для наших пользователей, заставляя их проводить здесь время и, что более важно, возвращаться к нам.

Обязательно загляните на www.eidos.com и попробуйте на вкус и цвет Eidos Interactive и Eidos TV.

К услугам посетителей eTV графика и музыка, созданные по мотивам компьютерных игр (как, например, это видео с Ларой Крофт), а также сетевые игры, ссылки на «фанатские» сайты и многое другое. (Приводится с разрешения Eidos Interactive, Inc.)

Мэтью Д'Андриа (Matthew D'Andria), CyberNation

Фирма CyberNation создает веб-сайты для таких культовых игровых компаний, как Capcom, Activision, Konami и Cendant Software. Ее главный веб-творец Мэтью Д'Андриа встретился с нами, чтобы обсудить значение веб-сайта в жизни игры и объяснить нам, что выделяет хороший узел в «толпе» ему подобных.

Сеть предоставляет возможности для продвижения любой новой игры. Игровая аудитория - одна из самых больших и технически подкованных, она вовсю стремится воспользоваться преимуществами Интернета, включая чаты, форумы, игру по Сети, мультимедиа-возможности и электронную торговлю.

Хороший игровой сайт предложит пользователю интересную эксклюзивную информацию, отсутствующую как в руководстве к игре, так и в других источниках. Это отличный способ обеспечения устойчивой посещаемости, которым грех не воспользоваться (к тому же именно эта аудитория - самый лучший рынок для сопутствующих товаров, символики и т.п.). Электронная торговля имеет чрезвычайно низкие накладные расходы и предлагает доставку по всему миру. CyberNation создала ряд успешно функционирующих электронных магазинов, в том числе для Capcom и Activision. Формировать постоянную аудиторию игровых сериалов, вроде Resident Evil, с помощью чатов, досок объявлений, списков почтовых рассылок и других инструментов - одно удовольствие.

А как насчет использования мультимедиа-средств? Как быть с теми, у кого медленная связь? Мэтт говорит, что, по наблюдениям его компании, большинство поклонников игр располагают мощными компьютерами и достаточно быстрым выходом в Интернет.

Выставка достижений видного веб-строителя CyberNation. Сайт может (и должен) содержать ключевую информацию об игре (Konami, вверху), предлагать возможности электронной торговли (Activision, в середине) или попросту сыграть в онлайне (Capcom, внизу). (Приведено с разрешения CyberNation.)

Вот почему мы предлагаем игровым компаниям веб-сайты, предъявляющие более высокие требования к скорости соединения. Если это возможно, мы реализуем мультимедийные эффекты без применения плагинов, стараясь добиться от них максимально возможной броскости. На нашем счету несколько интерактивных проектов, не использующих плагинов, например первая интерактивная демо-версия консольной игры Super Puzzle Fighter.

Многие начинающие разработчики не могут позволить себе заказать сайт в CyberNation, тогда, быть может, им будут полезны советы Мэтью, касающиеся содержания сайта и его раскрутки?

Хороший сайт вовсе не обязательно стоит больших денег, достаточно иметь хороших специалистов. Лучший способ сделать сайт популярным - предложить что-то, чего нет нигде. Содержание имеет ключевое значение. Если с деньгами совсем плохо, сделайте маленький сайт. Убедитесь, что ваш сайт внесен в список всех основных поисковых машин и порталов (это ничего не стоит). Свяжитесь с администраторами других, популярных, игровых веб-узлов и попробуйте договориться с ними об обмене ссылками. Лучшая реклама для веб-сайта - это людская молва, а она не зависит от содержания вашего кармана.

Полную информацию о проектах CyberNation, осуществленных для игровых компаний, можно найти на сайте, размещенном по адресу: www.cnation.com.

Крис Сивертсен (Chris Sivertsen), ЕА Sports

Крис Сивертсен, специалист по Интернет-маркетингу компании ЕА Sports, говорит, что по целому ряду причин веб-сайт - идеальная среда для продвижения и продажи игр для компьютеров и видеоприставок.

• Бюджет. Сайт можно создать при любых финансовых условиях. В зависимости от того, приходится ли вам раскручивать никому не известную игру или «Звездные войны», вы найдете соответствующий вариант подачи информации. В играх обычно нет недостатка в замечательных «цифровых» изюминках (текст, графика, звуки и т.п.), которые можно с успехом использовать на сайтах различной степени «навороченности». Очевидно, чем больше у игры бюджет, тем более замысловатое оформление можно себе позволить.

• Альтернативы. Поклонники компьютерных игр активно работают с Интернетом - это аксиома, и они привыкли использовать для получения информации различные источники. Вы, именно вы, можете предоставить более глубокую информацию по сравнению с любыми другими средствами. Вы просто обязаны часто обновлять эти данные и оснащать сайт новыми возможностями, чтобы вызвать желание возвращаться к вам снова и снова. Где же еще можно получить более подробные сведения о вашей игре? Вы вольны употребить в дело исключительную возможность использовать недоступный никому другому материал о создании игры - к примеру, публиковать рассказы на тему «как это делалось», чтобы дать людям представление о том, что вы вложили в свое детище, или раскрыть какой-то профессиональный секрет...

• Призыв к действию. Динамичный веб-сайт предлагает посетителям предпринять те или иные действия. На своем сайте вы можете продавать игру и сопутствующие товары, регистрировать пользователей, желающих получать обновления ваших программ посредством электронной почты, рекламировать турниры или веб-страницы поклонников игры, организовывать конкурсы, открывать странички со скриншотами или видеофрагментами игры, снятыми самими игроками, и т.д. Призыв к активности - средство установления контакта с вашими клиентами, способ дать им понять, что вы приветствуете и поощряете их участие и более тесное знакомство с вашими изделиями и компанией.

«Мы пытаемся сделать так, чтобы все необходимые сведения можно было получить всего лишь несколькими щелчками мыши», - говорит Крис Сивертсен. На верхней иллюстрации - основная страница веб-сайта ЕА Sports. На нижней - страница серии игр NHL. (Приводится с разрешения Electronic Arts, Inc.)

Далее Крис Сивертсен говорит о том, на что начинающие дизайнеры должны обращать внимание при создании веб-сайта игры:

Возможность скачивания демо-версии - обязательное условие для запуска заслуживающей доверия игры для ПК. Исследования доказывают, что демонстрационная версия играет ключевую роль в мотивации покупки. Потребители хотят знать, что они купят, и вы должны уважать это желание. Во всяком случае ваши конкуренты эту возможность не упускают.

Я активный сторонник простой навигации. Сгруппируйте связанные темы и не заставляйте людей «потеть» в поисках важной или новой информации. Напротив, ею надо кормить с ложечки!

Барри Дорф (Barry Dorf), EA Sports

Помощник продюсера в компании Electronic Arts, Барри Дорф работал над серией Madden Football, а также отвечал за представление популярной игры Fantasy Football на сайте EA Sports. Мы спросили его, почему издатель должен тщательно продумывать веб-страницы для каждой новой игры, которую предполагается выпустить, и учитывается ли в ЕА Sports время загрузки?

Это же бесплатная реклама, Ватсон! У ЕА обалденный сайт, который входит в первую сотню самых популярных сайтов всего Интернета. Было бы глупо не заниматься веб-представлением игры одновременно с ее разработкой и выпуском. Точнее говоря, веб-сайт должен появиться по крайней мере за шесть месяцев до ее выхода.

На сайте должно быть столько маркетинга, сколько можно уместить на одной странице. Сайт должен часто обновляться и привлекать внимание. Когда я работал над Madden Football, у нас не было возможности заполучить демонстрационную версию до выхода игры. Коммерческий продукт отличался от продукта, доступного через Сеть. Это было важно для нас, но не важнее, чем выпуск качественной игры. Сразу после выхода игры основным приоритетом стало получение демо-версии для ее выгодного представления в WWW.

Плагины, время загрузки и совместимость браузеров - все эти вопросы были для нас внове. Мы не хотели требовать от посетителей наличия плагинов, но у нас были строгие требования к браузеру. Мы думали, что люди будут загружать только Netscape или Explorer, поскольку они бесплатные, - и ошиблись. Кроме того, требовалась долгая предварительная загрузка всей статистики. Как только она завершалась - а для модема со скоростью соединения 56 Кбит/с на это уходило 2-3 минуты, - люди получали возможность навигации по веб-сайту. Тогда я считал, что это приемлемо: сайт содержал столько информации, что загрузиться в один прием было просто здорово. Мы полагали, что столь длительное время загрузки не такой уж серьезный изъян, если учесть те преимущества, которые получал пользователь, попавший на сайт. Это была наша основная проблема; сегодня, благодаря новым технологиям и иным скоростям связи, ее актуальность значительно уменьшилась.

Барри Дорф высказывает свое мнение по поводу необходимости простой навигации:

Навигация и интерфейс - два ключа к успеху любого веб-сайта. Люди любят бродить по Сети, но они хотят иметь возможность быстро найти то, что им нужно. Если вы находитесь на футбольном веб-узле, то, разумеется, должны иметь возможность получать результаты матчей, турнирную статистику и последние известия одним щелчком мыши.

Барри Дроф утверждает, что выкладывание бесплатных игр - хороший способ сделать свой сайт популярным. «Интернет устроен так, что по-настоящему хороший веб-сайт всегда будет на виду». (Приводится с разрешения Electronic Arts, Inc.)

Майкл Маккарт (Michael McCart), Ensemble Studios

В этой главе мы беседовали с людьми, представляющими либо большие издательства вроде Eidos Interactive или Electronic Arts, либо компании, занимающиеся исключительно созданием веб-узлов (Cubik Media и CyberNation). Но сейчас, заканчивая разговор о WWW, давайте дадим слово человеку непосредственно из среды разработчиков.

Майкл «Архангел» Маккарт, веб-мастер компании Ensemble Studios, излагает свое понимание представления игры в Интернете. Да! Обязательно обратите внимание на то, как Майкл попал в Ensemble: его наняли, увидев его работу над любительским - «фанатским» - сайтом Age of Empires!.

Майкл уверен, что для игры жизненно важно иметь хороший веб-сайт.

Мы полагаем, что разработчик должен завести сайт как можно раньше, чтобы представить основную идею компании и видение игры, которое имеет команда. Лишь только начав разработку, уже можно помещать на сайте имеющуюся на тот момент графику и подробности об игре. Это заинтересует прессу, а также станет первым шагом в создании собственной аудитории поклонников.

По ходу разработки на сайте должны появляться скриншоты из игры, все более подробные сведения и комментарии авторов. Еще раз повторю: подобная практика лучше всего формирует аудиторию будущих игроков и дает СМ И все необходимое для поддержания информационного интереса к игре.

Следующий этап - выпуск игры. На веб-сайте должно появиться максимальное количество информации, включая отзывы в прессе, свежие скриншоты, поступившие заказы и проч. При этом информация должна регулярно обновляться. И еще одно: часть веб-сайта, посвященная игре, не должна занимать более 8-12 страниц.

Насколько «навороченным» должен быть веб-сайт? Как насчет непременного использования Macromedia Flash?

Мы не сторонники мультимедиа-средств. Самое большее, что мы себе позволяем, - это музыка из игры в формате MIDI на главной странице. Основная причина нашего «консерватизма» заключается в следующем: чем больше графики из игры мы помещаем на сайте, тем дольше длится загрузка.

Что делать, если вы потратили все свои деньги на разработку игры и на поддержку ее в Интернете средств не хватает?

Лучший выход - разместить свой сайт на одном из крупных веб-узлов, посвященных игровым новостям (в свое время страничку Майкла Маккарта об игре Age of Empires «приютил» сайт GameStats, который вы можете найти по адресу: www.gamestats.com). В большинстве случаев вам предложат неограниченную пропускную способность (а пропускная способность стоит КУЧИ денег), которую, будьте уверены, ваше бесплатно или условно-бесплатно распространяемое ПО поглотит в процессе изрядного количества скачивании.

Другой вариант - обустроиться у крупного Интернет-провайдера, предлагающего бесплатный хостинг.

Если веб-страничка создана исключительно в целях распространения ваших программ (бесплатных или условно-бесплатных), не забудьте поместить на ней подробные сведения о своих продуктах (предназначение, тонкости инсталляции и проч.) и хотя бы минимальные сведения о компании и ее сотрудниках. Люди, пользующиеся ПО такого рода, обычно не читают readme-файлы, поэтому постарайтесь разместить на своем веб-сайте максимум возможной информации.

Вот несколько советов Майкла, касающихся навигации на сайте:

Я предпочитаю простой заголовок сверху, на котором располагается главное меню с основными разделами, и боковое меню, содержащее подразделы. Воздержитесь от применения апплетов и Java-скриптов без крайней необходимости, иногда это приводит к сбоям при использовании браузеров старых версий.

Майкл Маккарт из Ensemble Studios советует представлять информацию в как можно более простом виде. Лично он предпочитает сайты с главным меню и боковой панелью, содержащей подразделы. (Приводится с разрешения компании Ensemble Studios, Inc.)

Майкл Маккарт приглашает всех интересующихся посетить его личную страницу, которая располагается по адресу: www.electrosonic.net/resources/angel.html. Здесь вы сможете найти его весьма пространные соображения о создании игровых веб-сайтов. Кроме того, стоит ознакомиться с его работой на официальном веб-сайте Ensemble Studios (www.ensemblestudios.com).


Техническая поддержка и послепродажное обслуживание

Глава 18

Техническая поддержка и послепродажное обслуживание

Игра прошла цикл разработки, издана и наконец поступила в продажу - либо по обычным розничным каналам, либо через Интернет. Какова ее дальнейшая судьба?

Издатель обязан осуществлять поддержку игры. Эта часть работы, выполняемая уже после реализации продукта, - необходимый и весьма важный элемент полного цикла работы над игрой. Скажем больше, именно от того, насколько внимательно отнесутся к проблемам потребителя, в значительной степени зависит, захочет ли он в будущем снова иметь с вами дело.

Как и в любом другом сегменте рынка программного обеспечения, в игровой индустрии обслуживание пользователей разделено на две части. Техническая поддержка призвана обеспечить помощь при установке и запуске программного обеспечения или аппаратных средств. Самые распространенные проблемы, связанные с играми для ПК, - это конфликты драйверов, инсталляция 3D-ускорителей, режимы многопользовательской игры, конфигурирование контроллеров, а также более общие вопросы, касающиеся DirectX. Послепродажное обслуживание заключается в помощи с оформлением заказа (покупкой или возвратом), гарантийном обслуживании, проведении опросов, регистрации (если это онлайновая или сетевая игра) и решении других проблем, не связанных с техническими вопросами. И в том, и в другом случае цель обслуживания - полное удовлетворение запросов пользователя.

Большинство игровых компаний предпочитают иметь собственный отдел технической поддержки и послепродажного обслуживания, но в некоторых случаях они нанимают для этого сторонние агентства. По сложившейся традиции заботу о технической поддержке и послепродажном обслуживании берет на себя издатель, а не разработчик. Пример: всеми звонками, электронной почтой и факсами, связанными с технической поддержкой игры Baldur's Gate, занимается Interplay, а вовсе не BioWare, разработчик игры.

Эта небольшая глава содержит рекомендации по организации качественной технической поддержки и послепродажного обслуживания. При этом не важно, собираетесь вы осуществлять поддержку собственного ПО, распространяемого бесплатно или условно-бесплатно, или же хотите освоить этот аспект игровой отрасли в издательской компании.

Майкл Келли (Michael Kelly), Eidos Interactive

Мы спросили Майкла Келли, отвечающего за послепродажное обслуживание в компании Eidos Interactive, насколько важную роль играет эта часть работы и почему, уделяют ли игровые компании достаточно внимания этому вопросу? Слово Майклу Келли:

Эту работу нельзя оценить количественно. Даже если качество послепродажного обслуживания и технической поддержки приводит покупателей в полный восторг, измерению оно не поддается. Вы редко услышите рассказы о том, насколько замечателен был чей-то опыт общения с любым из этих отделов. Напротив, все, что я когда-либо читал, - это примеры плохого обслуживания. Это особенно относится к США, где потребители ожидают получить за свои деньги сервис высшего качества, даже если это абсолютно нереально. Мне кажется, что издатели компьютерных игр не придают большого значения послепродажному обслуживанию или технической поддержке, - в отличие от покупателей.

Отвечая на вопрос, что необходимо учесть, если собираешься создавать собственный отдел послепродажного обслуживания, Майкл Келли назвал три основных момента:

• Доступность. Дайте покупателю возможность связаться с вами без проблем.

• Своевременность. Покупатель должен получить ответ в приемлемые сроки.

• Точность. Потребитель ждет (и по праву), что полученная информация будет точной и полезной.

Майкл подчеркивает, что конечный пользователь обязательно должен получить ответ на свой запрос, причем по нужным каналам.

Я уверен, что факс и электронная почта - далеко не идеальные средства для оказания технической поддержки. Компьютер не столь прост, чтобы вы могли с их помощью решить все проблемы заказчика. Впрочем, они вполне подходят для передачи информации, которая не требует ответа от потребителя (скажем, для выяснения адреса, по которому надо послать диск для замены).

В заключение Майкл Келли напоминает о необходимости по мере возможности выпускать патчи, чтобы потребитель чувствовал постоянную заботу.

Марк Линн (Mark Linn), Interplay

Марк Линн - ведущий специалист группы технической поддержки компании Interplay (штаб-квартира в городе Ирвайн, Калифорния, США), где он работает более трех лет. По его словам, технические сотрудники Interplay, отвечающие на звонки потребителей, касающиеся послепродажного обслуживания, проходят специальное обучение, цель которого - оперативное решение возникающих технических вопросов. «Решение проблемы за один звонок - это хорошо и для покупателя, и для нас», - объясняет Марк. Он признает, что телефонные звонки более эффективны, чем электронная почта или запросы по факсу, и отнимают меньше времени у обеих сторон, поэтому такой вариант более выгоден для Interplay и удобен для заказчика.

Поскольку эта книга обращена к начинающим разработчикам, которые, возможно, захотят основать собственную фирму, или стремятся получить работу в уже существующих компаниях, мы попросили Марка поделиться своим опытом в организации службы технической поддержки. Вот его рассказ.

База данных

Согласно Марку Линну, самое важное на первом этапе - это создание клиентской базы данных и тщательное отслеживание звонков. В большой компании все техники должны быть объединены в сеть, т.к. покупатель каждый раз будет попадать на нового оператора. В Interplay все звонки регистрируются в базе данных Microsoft Access, в которую заносятся сведения о пользователе и конфигурации его компьютера, информация о неполадках, случившихся с момента последнего звонка, данные о том, имеет ли игра N какие-нибудь известные ошибки (и как с ними бороться), и т.д. Марк говорит, что зачастую один и тот же человек может звонить по нескольку раз, в этих случаях они, уточнив номер телефона потребителя, проверяют содержание его предыдущих звонков. «Большинство людей, звонящих в службу технической поддержки, недавно общаются с компьютером или же не знакомы со старыми операционными системами вроде DOS», - объясняет Марк Линн.

Правильно организованная база данных позволяет быстрее обнаружить источник проблемы и уменьшить время ожидания со стороны потребителя. «Они заплатили за это свои десять центов, поэтому мы пытаемся сделать все быстро и безболезненно».

Некоторые игры прошлых лет (например Redneck Rampage или Carmageddon), выпущенные Interplay, были написаны под DOS, но подразумевалось, что они будут работать в среде Windows 95/98. Марк Линн говорит, что из-за частых конфликтов драйверов может потребоваться завершить работу системы и перезагрузиться в DOS, чтобы все функционировало правильно. На фотографии приведена коробка игры Redneck Rampage. (Приводится с разрешения компании Interplay Productions.)

Квалификация

Марк также обращает внимание на наличие соответствующей квалификации. Большинство претендентов на получение подобной работы знакомы с компьютерами, однако важно, чтобы они, во-первых, хорошо знали операционные системы, относящиеся к игре, а во-вторых, разбирались в самих играх. Он поясняет свою мысль:

Мы не приглашаем кандидатов на собеседование до тех пор, пока они не пройдут проверку на общее знакомство с компьютерами в необходимом объеме (в частности, требуется определенный уровень знаний ОС Windows 95/98 и DOS). После этого в течение первых нескольких дней обучения мы усаживаем их за компьютер и заставляем играть в игры. Чем лучше они будут знать нашу продукцию, тем легче им будет помочь пользователю.

Будьте внимательным слушателем

Марк Линн придает огромное значение тому, чтобы его сотрудники были внимательными слушателями и обладали хорошими навыками работы с клиентом. Более того, они должны уметь не принимать слова клиента на свой счет. Охваченный праведным гневом пользователь редко склонен думать, что дело в его барахлящем/устаревшем компьютере. Как правило, он убежден, что «что-то не в порядке с вашей программой».

«Если твердо придерживаться этих трех правил, любой контакт с пользователем, нуждающимся в помощи, будет и приятен, и эффективен»,- говорит Марк Линн.

Том Баззано (Tom Bazzano), 3DO

Очень занятой человек Том Баззано, диспетчер службы поддержки компании 3DO, все же нашел время, чтобы поделиться своими соображениями относительно того, как следует осуществлять техническую поддержку и послепродажное обслуживание. Итак, для начала, насколько важны эти моменты в работе игровой компании и почему.

Техническая поддержка должна закладываться еще в процессе разработки игры, хотя в большинстве случаев о ней, конечно же, вспоминают с большим опозданием. Если работникам группы послепродажного сопровождения продукта позволить сотрудничать с авторами и тестерами игры на стадии ее альфа- и бета-тестирования, они, вполне возможно, будут в состоянии снабдить разработчиков ценной информацией о тех ситуациях, которые в будущем могут вызвать серьезные расходы на поддержку. В действительности же многие группы поддержки не имеют копии игры до момента ее появления в продаже!

Одна из наиболее досадных проблем - мелкие недоработки в программе установки игры или в интерфейсе, которые стабильно вызывают большое количество звонков со стороны покупателей. Как правило, здесь требуется всего лишь краткое объяснение по телефону или электронной почте, однако и этого можно было бы избежать, если бы группа поддержки была допущена до игры как можно раньше. Еще раз повторю: представители группы послепродажного обслуживания могут уже на ранних этапах проекта точно сообщить тестерам и разработчикам, как потребители прореагируют на сомнительную ситуацию, возникающую в игре. Они выявят те свойства программы, которые вызовут недовольство будущих игроков.

Наш отдел участвует почти в каждом этапе разработки продукта. Группа поддержки знает наизусть все печатные материалы, прилагающиеся к каждой выпускаемой игре. Здесь тщательно изучается коробка, руководство, иллюстрации, системные требования, ссылки на веб-сайты, путеводители по игре, раскладка клавиатуры, команды установки, а также, разумеется, само программное обеспечение. В нашей компании нет других сотрудников, которые будут с тем же тщанием, что и работники группы поддержки, искать несообразности в этих материалах. Почему? Все просто: хотя опечатки и ошибки допускают издатели и разработчики, отдуваться за них и отвечать на звонки приходится отделу поддержки.

Том Баззано уверен, если служащие подразделения технической поддержки и послепродажного обслуживания будут придерживаться следующих правил, их работа превратится в праздник.

Хорошая организация

Группа поддержки должна иметь все возможности для эффективного решения проблем пользователей. Для этого вам необходим надежный инструментарий и правильно продуманная политика. Без последовательной стратегии действий и надлежащих инструментов трудно добиться четкой организации труда. В противном случае вы обречены выслушивать от клиента, что «он звонит вам уже десятый раз, ему постоянно обещают перезвонить, а ни с кем из работников отдела поддержки ему поговорить так и не удалось».

Обменивайтесь информацией

Если вы действительно хотите обеспечить покупателю качественное обслуживание, принципиально важно, чтобы ваши сотрудники делились друг с другом всеми сведениями. Кроме того, необходимо всеми возможными способами доносить информацию до потребителей. Например, во время выхода Might and Magic 6 наша группа поддержки два раза в день проводила совещания, на которых мы обсуждали новые проблемы пользователей и выясняли, придумал ли кто-нибудь, как с ними справиться. Как только решение обнаруживалось и подтверждалось, мы немедленно рассылали его всем членам группы и помещали на сайте игры в разделе «Часто задаваемые вопросы». Это гарантировало, что хотя бы некоторые покупатели получали соответствующую информацию, а значит, заметно снижалось количество звонков по данной теме.

Будьте искренни и доброжелательны

Имея дело с покупателем, не ведите разговор так, будто это для вас пытка. Во время разговора постарайтесь казаться бодрым и радостным. Называйте его по имени, попробуйте сразу же установить с ним контакт. Нив коем случае не следует умышлено лгать и вводить клиента в заблуждение, скажите ему всю правду. Человек может примириться с проблемой, которая возникла с купленным продуктом, если вы будете вести с ним честный разговор, и он поверит, что компания уважает его требование исправить ситуацию. Нацеливая своих служащих на преднамеренную ложь или «отстаивание интересов компании» ради сохранения лица, вы только испортите настроение клиентам и деморализуете сотрудников службы поддержки.

Некоторые загруженные службы технической поддержки и послепродажного обслуживания полагаются на автоматизированные телефонные системы (например: «нажмите «1», чтобы получить информацию по игре X, «2» - по игре Y» и так далее); другие рассчитывают только на обратную связь с помощью Интернета (запросы по электронной почте и в группах новостей); а некоторые до сих пор делают ставку на старые добрые телефон и почту. Какие варианты использует 3DO и какие считает предпочтительными?

Нужно обеспечить поддержку, доступную по любому из существующих каналов связи. Предоставьте потребителям максимально возможную свободу выбора. Ниже вы найдете некоторые соображения «за» и «против» для каждого из методов связи с группой технической поддержки.

Телефон - самое оперативное средство технического сопровождения. Кроме того, когда сотрудник отвечает по телефону, он находится один на один с потребителем. Поэтому телефонная консультация будет и самой дорогой, так как в этом случае невозможно обслуживать сразу многих пользователей.

Электронная почта, факс или электронная доска объявлений службы технической поддержки - вторые по эффективности в списке. Они позволяют достаточно быстро связаться с пользователем. На основе интернетовского раздела «Часто задаваемые вопросы» готовятся стандартные ответы, весьма повышающие эффективность обслуживания. Недостаток электронной почты и доски объявлений в том, что решение одного вопроса может тянуться неделями, тогда как по телефону (при условии, что покупатель сидит за своим компьютером) дело заняло бы минут двадцать.

Обычная почта должна использоваться только в случае отсутствия других возможностей. Если кто-то вдруг попытается справиться с серьезной технической проблемой посредством обычной почты, непременно предложите ему хотя бы перезвонить.

Но что, если у издателя или небольшой фирмы-разработчика недостаточно ресурсов (времени и служащих) для полномасштабного сопровождения? Может ли игровая компания выжить с ограниченной поддержкой?

Нет, так дела не делаются. Небольшие компании должны соответствующим образом соизмерять свой уровень обслуживания. Поддерживайте контакт с покупателем через электронную или обычную почту, или даже факс. Использование заготовленных ответов на стандартные вопросы позволит обрабатывать большой поток звонков.

Повторяю, это тот случай, когда вступает в игру принцип одновременной работы со многими пользователями. Предоставьте своим покупателям максимально возможное количество информации с наименьшими трудозатратами. Наиболее очевидное решение - использовать Интернет. Создание веб-страницы поддержки для вашей игры займет минимум времени. Сюда можно поместить раздел «Часто задаваемые вопросы» и описание основных неисправностей, а также дать ссылки - например на страницы драйверов для различных аудио- и видеоплат и т.п.

Еще один способ работы в Интернете - использование доски объявлений: потребители оставляют свои вопросы, а ответственный за поддержку (вы не забыли, мы говорим о малобюджетной службе) отвечает на них. Это позволит другим потребителям просматривать доску и читать послания от людей со схожими неурядицами, а также делиться с коллегами по несчастью собственным опытом решения проблем.

Говоря об Интернете, Том Баззано затрагивает проблему своевременного выпуска патчей, исправляющих ошибки, и обновлений текущих версий игры.

Решение по выпуску патча должно приниматься с учетом каждого конкретного случая. НИКОГДА не выпускайте исправление слишком рано. Если вы обнаружили проблему, для решения которой требуется патч, и это случилось в первую пару недель после выхода игры, ПОДОЖДИТЕ! Существует вероятность, что обнаружатся другие недоработки, и все исправления можно будет объединить в общем файле.

Впрочем, существуют ситуации, которые требуют немедленного выпуска исправления. Если имеется недоделка или ошибка, которая не позволяет запустить или установить игру, ее нужно устранить как можно быстрее.

Общественное мнение может легко вынудить компанию выпускать патчи один за другим, но вы должны понимать, что оказываться в таком положении нежелательно. Вместо того чтобы выдавать исправления каждые две недели, следует искать творческие решения, которые успокоят ваших потребителей и позволят разработчикам устранить все известные проблемы.

Вот неплохая идея того, как справиться с подобной ситуацией: подключите вашу аудиторию к «тестированию» патчей, запустив бета-версии программ. Пусть потребители испытывают первые версии исправления и сообщают о том, как он работает и на каких аппаратных средствах проводились испытания. Это позволит: а) выиграть время, чтобы разработчики смогли выловить все ошибки программы и исправить их прежде, чем их обнаружат, и б) дать возможность вашим потребителям сыграть активную роль в разработке патча и показать им, что компания ценит их помощь.

Том Баззано призывает начинающих разработчиков посетить страницу 3DO Support, чтобы получить представление о том, как правильно организовать собственную техническую поддержку и послепродажное обслуживание. (Приводится с разрешения 3DO Company.)

Карин Локрем (Carin Lockrem), Purple Moon

Управляющая программой поддержки потребителей Карин Локрем работает в компании Purple Moon. Это студия по разработке программного обеспечения, специализирующаяся на создании игр для девочек от 8 до 12 лет. Серия Rockett's Adventure - текущий кормилец Purple Moon.

На вопрос, насколько важна техническая поддержка или послепродажное обслуживание как часть игрового цикла, Карин ответила: «Чрезвычайно!» - и дала подробные объяснения:

В компьютерном мире от уровня службы технической поддержки во многом зависит репутация компании: общее впечатление потребителя о ней, о качестве ее продукции и готовности отвечать за свой товар. В зависимости от опыта пользователя и его технических познаний ваш уровень поддержки может вызвать реакцию от благосклонного расположения до «я никогда больше не буду пользоваться продукцией этой компании». Игра или работа с программой доставят потребителю гораздо больше удовольствия, если вы найдете несколько минут, чтобы объяснить все на доступном уровне.

Основываясь на своем немалом опыте, Карин предлагает лучшие, по ее мнению, советы:

Убедитесь, что группа технической поддержки имеет связь с авторским коллективом и издателем в течение всего процесса разработки, а не только на заключительной стадии. Своевременно полученная от производителей информация может иногда устранить проблему совместимости с некоторыми системами или по крайней мере быть упомянута в файлах типа readme.

Как только игра вышла на стадию бета-тестирования, убедитесь, что группа технической поддержки не только координирует этот важнейший этап, но и полностью в курсе всех ситуаций (вплоть до самых незначительных проблем, решение которых отложено). Это обеспечит вашему персоналу необходимую практику и позволит подготовить документацию до выхода игры.

Своевременно запаситесь подходящей базой данных, чтобы немедленно приступить к сбору информации о пользователях.

Когда речь зашла о том, каким каналом связи следует пользоваться группе поддержки, Карин ответила: «Всеми».

Я убеждена, что для качественной поддержки необходимо использовать все виды связи, включая электронную почту, телефон и факс. Роль компьютеров для передачи информации все более и более возрастает. Если на вашем сайте отсутствуют ответы на вопросы, поступающие по электронной почте, обязательно используйте какую-нибудь интерактивную справочную систему с учетом проблем технической поддержки. Кроме того, вы должны иметь возможность «живого» разговора со своими потребителями.

Запомните: чем больше знаний вы можете дать своим штатным сотрудникам для общения с потребителями, тем лучше будут ваши продукты и уровень сервиса.

А что, если у издателя (разработчика) нет денег, а его продукт - это условно-бесплатно или бесплатно распространяемая игра? Справедливы ли в данном случае те же самые принципы, что и в случае с большими компаниями?

Вам все равно надо попробовать их в деле, соизмерив с масштабом своей компании. Вы должны установить критерий и приемлемый уровень поддержки потребителя. Например, отвечать на все звонки и электронную почту не позже установленных сроков или обрабатывать все вопросы, связанные с поддержкой, посредством электронной почты к некоторой ожидаемой дате. Если вы определите политику, а затем огласите ее перед аудиторией - в Интернете, на упаковке с игрой и т.п., ваши потребители это оценят.

Родни Ходж (Rodney Hodge), Imagic Online

Продюсер компании Imagic Online Родни Ходж повернул наш разговор в другое русло, так как он работает в основном с онлайновыми играми вроде сверхпопулярной WarBirds. Применимы ли в данном случае те же самые подходы? Действительно ли техническая поддержка так же важна для сетевых игр, как и для игр, продающихся в коробках? Родни считает, что для многопользовательских игр - даже важнее.

При нашей организации бизнеса послепродажное обслуживание имеет существенное значение. В отличие от розничных продаж, когда вы создаете продукт, выпускаете его, поддерживаете на протяжении какого-то времени, а затем переходите к следующему, мы стараемся не терять отношения с нашими потребителями. У нас есть постоянно пополняющаяся база данных, которую мы ведем уже четыре года, со дня открытия. Наша ежегодная программа - это в среднем три новых выпуска и/или обновления на игру. Мы постоянно улучшаем наши продукты, добавляя новую графику, функциональные возможности и т.п. А это значит, что нам приходится не только удовлетворять запросы вновь пришедших потребителей, но и пытаться сохранить старых пользователей, решая проблемы, с которыми они неизбежно сталкиваются при получении новых версий игры, установке другого ПО, сбоях жесткого диска и т.п.

Мы спросили Родни Ходжа, как в его компании принято отвечать на запросы по технической поддержке: по телефону, электронной почтой или факсом, и что удобнее?

В этой области я старомоден и считаю, что лучший вариант - «живое» общение, когда слышишь спокойные объяснения человеческим голосом. Мой опыт показывает, что в большинстве случаев потребитель начинает звонить, когда он уже сломал голову в попытке справиться с проблемой и его терпение лопнуло. Вот уж чего лично мне не хотелось бы в такой ситуации - так это сидеть и ждать, пока тебе перезвонят, или пытаться пробиться сквозь лабиринт кнопок в опциях меню. Все, о чем я сейчас мечтаю, - это сообщить кому-то о своей проблеме, чтобы мне подсказали, что делать. Другой неплохой вариант помощи - быстрый ответ по электронной почте.

Страницы технической поддержки на нашем сайте разделены на области, содержащие справки по каждой отдельной игре. В любой из них вы найдете номер телефона и сведения о персонале, подборку часто задаваемых вопросов и адреса полезных новостных конференций по поддержке, а также (что не менее важно) адрес электронной почты.

Мне особенно нравится современная форма помощи - группа новостей поддержки. Она чрезвычайно удобна, когда имеется устоявшееся ядро игроков. В этом случае вы получаете максимум преимуществ при минимуме усилий. Группа новостей - это область, куда потребитель может зайти в поисках нужной информации или для того, чтобы написать о проблеме, с которой столкнулся. Часто оказывается, что другой посетитель уже испытывал подобные затруднения и даже в подробностях описал, как от них избавиться, или же готов ответить на заданный вопрос. Кроме того, разработчик может просмотреть конференцию поддержки, чтобы снять проблемы, которые еще не были решены другими игроками, адресуясь сразу к большому числу людей. Это куда эффективней, нежели обзванивание пользователей или рассылка электронных писем. Группа поддержки поможет разработчику узнать, с какими ошибками или затруднениями сталкиваются его потребители, и использовать эту информацию при поиске ошибок или для улучшения потребительских качеств ПО.

Imagic Online может похвалиться еще одним приемом технической поддержки, которого не найдешь у большинства игровых компаний. Родни Ходж с удовольствием раскрывает нам этот секрет.

Еще один аспект поддержки заказчика, которого я пока даже не коснулся, - привлечение самых опытных пользователей со стороны для помощи в обучении новичков тонкостям ваших продуктов.

Эти страницы, размещенные на веб-сайте, были разработаны самими игроками и для игроков, а затраты ограничиваются предоставлением бесплатного Интернет-соединения волонтерам. Из этих энтузиастов также формируются обучающие команды, занимающиеся со штатными сотрудниками пять вечеров в неделю: каждый пользователь отдает на благо любимой фирмы и игры по два с половиной часа.

Компания Imagic при активном содействии ярых энтузиастов онлайнового авиасимулятора WarBirds организовала бесплатное обучение и форум технической поддержки для начинающих пилотов. Цель - помочь новичкам освоить опыт сетевой игры. (Приводится с разрешения Imagic Online, Inc.)

Родни согласен, что при отсутствии неограниченного финансирования, возможно, лучше ограничиться электронной почтой и файлами «часто задаваемых вопросов», так как установить линию поддержки и нанять операторов, принимающих звонки, стоит недешево. «Только не забывайте, - говорит он, - что в данном случае необходимы оперативность и профессионализм». И добавляет: «Ваша основная цель - держать марку среди потребителей. Они должны чувствовать, что вы заботитесь о них, хотите им помочь и готовы сделать все возможное для решения их проблем».


Чтоб сказку сделать былью...

Часть IV

Чтоб сказку сделать былью...

19 | Сделай сам, или Великая Условно-Бесплатная Революция
20 | Как найти свое место в игровой индустрии
21 | Агенты и вербовщики
22 | G.O.D. - божественное откровение
23 | Школы для разработчиков
24 | Ресурсы по разработке игр в Интернете
25 | Важнейшие мероприятия, организации и награды


Сделай сам, или Великая Условно-Бесплатная Революция

Глава 19

Сделай сам, или Великая Условно-Бесплатная Революция

Успех приходит не только к тем, кто получает работу в известной компании, создающей или выпускающей игры, и продвигается там по служебной лестнице. Конечно, трудиться рядом с такими легендами индустрии, как Сид Мейер (Sid Meier) или Ричард Гэрриот (Richard Garriott) -это уже огромное счастье, но многие тем не менее предпочитают работать дома, чтобы потом продавать свои творения через Интернет. Нечто подобное, кстати, происходит сейчас в музыкальной отрасли, где появляется множество независимых популярных коллективов.

Разумеется, производить, рекламировать и распространять свою продукцию можно и обычным путем - получив статус юридического лица, однако эта глава посвящена тем авторам, которые распространяют и продают свои игры через Интернет как УСЛОВНО-БЕСПЛАТНЫЕ, или shareware. Для непосвященных: условно-бесплатным можно назвать программное обеспечение, в самом деле бесплатно распространяемое через Интернет, но имеющее некоторые функциональные ограничения, связанные обычно либо с фиксированным временем использования (скажем, программа или прекращает работать через неделю, или весьма настойчиво - например в виде то и дело возникающей на экране надписи - предлагает зарегистрировать себя, заплатив автору некоторую, как правило, небольшую сумму), либо с урезанными возможностями (к примеру, доступны только три уровня игры вместо сорока трех). Основная маркетинговая идея такого способа распространения программ - это прямое воплощение принципа «попробуйте, прежде чем купить». Впрочем, нередко авторы распространяют и полные версии своего ПО (это называется freeware), рассчитывая на благородство пользователей: если вам это нравится, если вы активно этим пользуетесь - заплатите автору и живите с чувством выполненного долга. (В дополнение ко всему этому надо отметить и еще одну недавно появившуюся форму распространения ПО, которая, как нам кажется, со временем может стать такой же популярной, как и shareware: программа ничего не стоит ее пользователю, однако ее автор все равно получает денежное вознаграждение - от компании, разместившей в ней рекламные баннеры, с возможностью их обновления при любом Интернет-соединении. - Примеч. ред.)

Стоит ли продавать вашу любимую игру таким образом? Есть ли у этого способа распространения, если сравнивать его с «коробочным» вариантом, преимущества? а недостатки? Собранные ниже высказывания принадлежат тем, кто решился заниматься этим в одиночку и преуспел. Если вы хотите последовать примеру этих людей, отнеситесь к их советам с должным вниманием.

Джефф Фогель (Jeff Vogel), Spiderweb Software, Inc.

Джефф Фогель - президент маленькой компании Spiderweb Software, Inc. из Сиэтла (штат Вашингтон, США), в которой работают всего два человека. С помощью нескольких внештатных сотрудников они производят и продают условно-бесплатные игры в жанре «фэнтези» для «Макинтоша» и ПК и более всего, пожалуй, известны благодаря серии ролевых игр Exile. В 1998 году Exile III: Ruined World, no мнению журнала Computer Gaming World, стала лучшей игрой года среди shareware-проектов.

Джефф уверен, что условно-бесплатное распространение - это оптимальный вариант:

Вы окажете себе очень плохую услугу, если откажетесь от shareware. Вы только посмотрите на игровую отрасль - это безжалостный конкурентный мир большого бизнеса. Вам, как правило, придется ограничивать себя установленными рамками выбранного жанра, использовать только строго определенную графику, подстраиваться под модные стандарты (не менее такого-то числа треугольников, обязательно возможности сетевой игры и т.п.), и даже после всего этого вам придется наизнанку вывернуться, чтобы игра появилась в магазинах. Если же вы идете по условно-бесплатной дорожке, то можете делать все именно так, как хотите.

Но реально ли заработать таким образом хорошие деньги - много денег? «Согласен, нельзя, - отвечает Джефф Фогель. - Вы не станете миллионером... но сможете жить очень хорошо, действительно хорошо». Верно, shareware трудно назвать прекрасным способом быстрого обогащения, и вообще - игровая отрасль не самый прибыльный бизнес. Джефф высказался по этому поводу так: «Чтобы начать получать деньги, само собой, прежде надо написать приличную игру». Как известно, это не так-то просто. А после этого нужно, чтобы вашу игру заметили, чтобы ее начали достаточно активно скачивать... «Но если вам это удалось, условно-бесплатное распространение - потрясающий способ зарабатывать на жизнь в нашей индустрии».

И какой же примерно доход может принести shareware-игра? Джефф Фогель говорит, что его проекты, которые «выглядят недоработанными, не имеют возможности игры через Интернет, да и звук у них довольно примитивный», за год приносят доход, выражающийся шестизначными цифрами. И вот почему:

Во-первых, при всем своем графическом несовершенстве они сделаны очень тщательно. Во-вторых, я уделяю особое внимание маркетингу, чтобы люди знали о них. Рассылаю множество пресс-релизов; я не использую волшебных слов, чтобы заставить людей покупать мои игры, я просто вкалываю, разрабатывая их. Не забываю и о нашем веб-сайте и сети Usenet: разыскиваю посвященные играм публикации в журналах и связываюсь с их авторами.

Ваша игра должна затягивать. Не просто привлечь на минуту - она должна захватить по-настоящему. Захватить настолько, чтобы человек достал из бумажника кредитную карточку и заплатил вам. В этом смысл shareware. Люди начинают играть в демонстрационную версию. Вам некуда деться. Ваша игра обязана быть максимально интересной. Она может выглядеть грубовато, она может иметь неудачное звуковое оформление. Быть может, в ней есть даже ошибки. Но если она не захватывает людей и не заставляет их тянуться к карману за деньгами, она обречена. Повторяю: чтобы преуспеть, вы должны написать хорошую игру, и не важно, о чем она будет.

Условно-бесплатные продукты вовсе не обязаны демонстрировать самые передовые графические или звуковые технологии или иметь поддержку сетевой игры, говорит Джефф Фогель. (Приводится с разрешения компании Spiderweb Software.)

Spiderweb Software гордится этой цифрой: ее игры скачивались с официального сайта компании более 100 тысяч раз. Джефф Фогель получил множество просьб поместить его продукты на CD-сборники shareware-игр. Однако ни одного предложения от крупных издательств о коммерческом выпуске к нему пока не поступало. Как он объясняет это?

Я просто не делаю ничего такого, что могло бы их привлечь. Я пишу игры в стиле «старой школы», подобные Ultima IV или VI, они рассчитаны на одного игрока. Сетевые проекты мне не интересны, я не имею возможности вставлять в игру изощренные заставки или заниматься прочими подобными вещами. Вот почему мои игры не интересуют крупных издателей, и я на них не в обиде. Мои работы не соответствуют определенным стандартам, а значит, они не могут попасть на полки магазинов.

Игры Spiderweb Software можно найти как во множестве сетевых архивов условно-бесплатного ПО (они перечислены ниже), так и на официальном веб-сайте компании, размещенном по адресу: www.spidweb.com.

А теперь освободите побольше места на своем жестком диске - на приведенных ниже адресах хранятся миллионы условно-бесплатных игр для ПК и компьютеров «Макинтош», а так же бесплатно распространяемые (freeware) игры и демо-версии коммерческих продуктов:

• shareware.com www.shareware.com

• DOWNLOADS.COM www.downloads.com

• Happy Puppy www.happypuppy.com

• Games Domain www.gamesdomain.com

• Jumbo www.jumbo.com

• TuCows www.tucows.com

• ZDNet Software Library www.hotfiles.com

• WinSite www.winsite.com

• Filez www.filez.com

• File Mine www.filemine.com

• File Pile www.filepile.com

• 32bit.com www.32bit.com

• Softsite www.softsite.com

• Beyond.com www.beyond.com

Сет А. Робинсон (Seth A. Robinson), Robinson Technologies

25-летний Сет Робинсон является исполнительным директором Robinson Technologies, Inc. (www.rtsoft.com), небольшой игровой компании из американского штата Орегон. Возможно, вы слышали о ней, ведь о ее условно-бесплатной ролевой игре Dink Smallwood сообщалось во множестве публикаций по всему миру. По словам Сета, своим успехом его компания в значительной мере обязана Интернету как очень эффективной площадке для распространения игр.

Идея shareware сегодня гораздо более осмысленна, чем несколько лет назад, когда Интернет не был коммерциализирован. С помощью Сети вы можете моментально передать демо-версию вашей игры в руки 50000 пользователей. И если вы предлагаете простой и более быстрый (не нужно добираться до магазина) способ покупки программы, люди воспользуются им. Особенно если ваша игра заполнит нишу, еще не занятую «коробочным» ПО.

Самое привлекательное в таком проекте - это уровень затрат! Ваши вложения ограничиваются лишь личным временем и доступом к Сети (который сейчас есть уже у всех). Ваша программа продается плохо? Обновите ее или напишите другую.

Сет Робинсон из Robinson Technologies является ведущим дизайнером, а Грег Смит - программист и вообще «мастер - золотые руки». Кто занимается в этой компании графикой? Художники, которых нанимают для конкретного проекта. Именно так создавалась ролевая игра Dink Smallwood, скриншот из которой вы видите на этой иллюстрации. (Приводится с разрешения компании Robinson Technologies, Inc.)

Объяснив, почему разработчикам игр следует использовать условно-бесплатное распространение, Сет Робинсон говорит что еще более важно знать, как это сделать. Отвечая на вопрос, как правильно продавать свои продукты через Интернет, Сет отметил следующие моменты:

• Во-первых, у вас должны быть электронные адреса редакторов игровых веб-сайтов. Вовсе не обязательно, что они успели посмотреть вашу игру, поэтому не стоит ждать, что все сайты как один выложат ваше творение для свободного скачивания в первый же день после его получения. Это ваша работа - уведомлять прессу по списку о том, что у вас есть что-то новенькое. По мере того как вы будете приобретать друзей в игровой индустрии, этот список будет расти и позже станет для вас бесценным.

• Мы не нажили богатства на Dink Smallwood, но игра открыла нам многие двери. Если вы можете на встрече с потенциальным работодателем козырнуть чем-то реальным, это скажет ему о многом. Не говоря уже о том, что сам факт, что вы сделали игру, - дорогого стоит.

• Я слышу отовсюду стоны о невозможности проникнуть в игровую индустрию, что для этого нужен опыт... Нет ничего проще - работайте бесплатно. Найдите неподалеку компанию, занимающуюся играми, может быть, они возьмут вас на стажировку. Мой коллега Грег Смит (Greg Smith) начинал именно так - и теперь получает зарплату.

• Даже и не думайте принимать предварительные заказы на незаконченную игру, особенно, если это ваша первая игра. В свое время мы допустили подобную ошибку, и я долго жалел об этом. Два месяца, на которые мы опаздывали, стали для нас адом...

• Пусть вас не обескураживает низкий уровень продаж. После выхода LORD за первый год я продал только 7 копий. За следующие семь лет - еще 30000. Если ваша программа действительно хороша, слухи о ней сделают свое дело. Только не забывайте регулярно обновлять игру и (особенно) ее веб-сайт. Постоянное (по крайней мере ежемесячное) обновление демонстрирует, что вы продолжаете заботиться о программе и не бросите потребителя на произвол судьбы.

• Начните с малого. Оцените степень сложности своего проекта по десятибалльной шкале и никогда не начинайте следующую игру, если она будет более чем на 2 балла сложнее предыдущей. Это ваш первый проект? Остановитесь на 1 или 2 баллах. Это примерно уровень генератора случайных цитат или простой экранной заставки.

• Используйте Microsoft Visual C++ и DirectX.

• Попросите приятеля повозиться с вашей игрой, обязательно посмотрите, как он играет: обратите внимание на то, где путается, какие клавиши норовит нажать, чтобы выйти из меню, и тому подобное.

Завершая разговор, Сет Робинсон рассказывает, как можно напомнить игрокам о необходимости регистрации программы. Сет полагает, что все зависит от типа ПО:

Для часто применяемой утилиты (макрос, графическая программа и т.д.) отличное решение - показывать при каждом запуске оставшееся время использования с последующим отключением программы (после 30 дней или около того). Для игр это не годится. Позаботьтесь о том, чтобы начало игры не оказалось для пользователей слишком трудным. Если они не пройдут бесплатный этап, зачем им покупать полную версию? В общем, сделайте бесплатную часть несложной и увлекательной и оборвите ее на самом интересном месте.

То, что Сет Робинсон говорит об условно-бесплатном распространении, наверное, годится для ролевых игр вроде его Dink Smallwood. А как быть с классическими карточными играми? Применимы ли к ним те же принципы? Как в данном случае лучше напомнить игроку о необходимости зарегистрироваться? Давайте обратимся к опыту двух других компаний, которые зарабатывают на жизнь созданием и продажей компьютерных пасьянсов.

Джонас Стюарт (Jonas Stewart), Silver Creek Entertainment

«Что ж, скажем прямо, если ты мелкая рыбешка в пруду, то нужно либо тихо отдать свой завтрак, либо купить клетку для защиты от акул и забраться в нее», - тонко заметил Джонас Стюарт, вице-президент и «основная творческая сила» компании Silver Creek Entertainment (www.silvercrk.com). Ее флагманы - Hardwood Solitaire и Hardwood Solitaire II для ПК и «Макинтоша». Джонас рассуждает о том, насколько трудно пристроить свою программу в магазины и как мало получают те, чьими трудами, собственно, и создается игра.

Если вы хотите продавать игру в магазине, то прежде должны найти издателя (который заберет часть прибыли себе) и дистрибьютора (который тоже возьмет себе часть прибыли), после чего сидеть и ждать, что они найдут для вас место на полке в супермаркете. Вам повезет, если вы получите пару долларов с игры, но, скорее всего, и того меньше. Если вы неизвестны или ваша игра не укладывается в общепринятые стереотипы, вы, вероятно, сможете издаться по цене 5 долларов за диск. И после всех отчислений... ну, вы сами можете подсчитать это и прослезиться.

Что же в таком случае делать небольшой игровой компании? «Мой друг, остановите свой выбор на Сети, - говорит Джонас Стюарт. - Если вы уверены, что создали великолепную игру и весь мир будет от нее без ума, а издатели почему-то этого не понимают, ее место в Интернете».

По его мнению, модель условно-бесплатных продаж отлично действует через Интернет, поскольку позволяет разработчикам вроде Silver Creek создать веб-сайт и продавать свое творение как ни в чем не бывало. Джонас описывает это так: «В общем, все, что необходимо сделать, - это написать игру, открыть сайт, поддерживать его и, если ваша игра людям понравится,.. наблюдать за поступлением заказов».

Джонас Стюарт полагает, что от условно-бесплатного распространения выигрывают все. Игроки получают представление о полной версии игры, а разработчики - материальное вознаграждение, удовлетворив наилучшим образом пожелания потребителей. Поскольку вы будете работать с заказчиками напрямую, юридических сложностей будет меньше. Будет меньше и недовольных, так как, прежде чем лезть за кредитной карточкой, можно ознакомиться с тем, что покупаешь.

«Условно-бесплатное ПО, - продолжает Джонас, - позволяет вам обновлять продукт так часто, как вы того хотите, оставляя только за вами право решать, достаточно ли изменений сделано для того, чтобы приступить к распространению новой версии». Он вспоминает о решении начать продажи Hardwood Solitaire II: «Мы потратили много времени и, что гораздо важнее, внесли достаточно улучшений, чтобы назвать ее новой версией игры».

Сборник Hardwood Solitaire II позволит вам играть в свое удовольствие только в пасьянс Klondike. Остальные игры и дополнительные возможности становятся доступны только после регистрации. (Приводится с разрешения компании Silver Creek Entertainment.)

Джонас Стюарт предупреждает, что это довольно тяжелый труд - заставить игроков залезть в карман и потратиться на полную игру. «Они не отдадут вам свои деньги без боя. Здесь, похоже, неплохо работает правило «одной трети»: предоставьте им треть игры бесплатно, а если они захотят наслаждаться дальше, то пусть уж раскошеливаются».

По словам Джонаса, существует три основных способа собирать деньги от продажи игр. Первый - это завести счет с возможностями электронной торговли и принимать заказы на веб-сайте. Второй - воспользоваться услугами специальных компаний (собирающих за своих клиентов деньги с покупателей). Они займутся обработкой заказов (взяв за это порядка 25% с оборота). Третий - «рекламное программное обеспечение» (ad-ware), когда полный вариант игры раздается бесплатно, но в ней продается рекламное пространство. Последний вариант обычно используется в онлайновых играх.

Если вас интересуют методы маркетинга и другие полезные вещи из области shareware, загляните на сайт Ассоциации профессионалов условно-бесплатного ПО (Association of Shareware Professionals, ASP). Цели этой организации, ответы на часто задаваемые вопросы и условия членства в ней вы найдете по адресу: www.asp-shareware.org.

Брайан Хорлинг (Bryan Horling), Freeverse Software

Некоторые разработчики shareware-продуктов предпочитают более энергично напоминать о том, что за продолжение игры необходимо заплатить. Такова, например, компания Freeverse Software (www.freeverse.com). Если вы, читатель, никогда не слышали о Burning Monkey Solitaire, это значит, вы почти не посещаете архивы условно-бесплатного ПО. Наш собеседник Брайан Хорлинг - один из программистов, работавших над этой игрой (для ПК и «Макинтошей»). Брайан «ответствен» за анимирование этой коллекции пасьянсов, наделение ее множеством дополнительных возможностей и, что самое важное, за юмор.

Последняя версия пасьянса Burning Monkey Solitaire для ПК в первые две недели после появления в Интернете скачивалась с одного веб-сайта более 30000 раз. (Приводится с разрешения компании Freeverse Software.)

Если пользователь не зарегистрировал Burning Monkey Solitaire после 15 раскладов за игру, 16-я раздача будет уже невозможна. Например, если вы чаще раскладываете Klondike, то он станет недоступен первым. Затем, после следующих 15 раскладов за ним последуют, скажем, Strict Klondike или Pyramid Solitaire. Если не ввести код регистрации, со временем перестанут запускаться все игры. Почему был применен именно такой подход? Брайан Хорлинг отвечает:

Встройте в свою программу нечто, что или отсекает некоторые возможности, или раздражает играющего, если тот не заплатил за использование игры. Если не надавить, многие игроки не будут платить вообще - из принципа или из-за элементарной лени. Если вы занимаетесь shareware исключительно ради приобретения опыта, оплата не так важна, но если вы думаете обновить свой компьютер, то вам могут потребоваться для этого деньги.

Этот способ все еще более выгоден, чем продажа «с потрохами» для распространения через обычные каналы, считает Брайан, потому что он сводится к двум словам: «простота и контроль». Он говорит: «Модель условно-бесплатных продаж элементарна: вы просто пишете игру и выпускаете ее. При этом вы целиком контролируете распространение и забираете все деньги». Но как вообще можно зарабатывать деньги на выпуске тривиальных классических карточных игр? Пасьянсы Burning Monkey Solitaire компании Freeverse и Hardwood Solitaire Пот: Silver Creek Entertainment как раз и являются яркими примерами простого улучшения всем известной вещи. Другими словами, разработчикам условно-бесплатных игр не нужно бояться того, что они изобретают велосипед. Практика показывает, что на абсолютно тривиальной идее вполне можно создать продукт и спрос на него. Действительно ли Брайан Хорлинг верит, что это правда?

Да, безусловно. Только следите за конкурентами. Скачивайте все похожие программы и добивайтесь того, чтобы у вашей игры было больше возможностей, ниже цена или она была лучше реализована. В общем, я действительно думаю, что это хорошая идея. Ставка на улучшение позволит вам начать с того, что уже проверено, и работать только над усовершенствованиями. Это намного проще, чем начинать с нуля и пытаться одновременно обучать мир новой игре, убеждая всех, что она интересна.

Шемус Макнэлли (Seumas McNally), Longbow Digital Arts

Когда создавалась эта книга, самой популярной игрой почти на всех веб-сайтах с shareware-программами был арканоид DX-Ball 2 - продолжение игры Breakout, разработанной в свое время Майклом Велчем (Michael P. Welch). Компанию Longbow Digital Arts (www.longbowdigitalarts.com), создавшую и выпустившую на Интернет-просторы DX-Ball 2, представляет на этих страницах программист Шемус Макнэлли. Кстати, то, что Шемус (вместе с тремя другими Макнэлли - отцом Джимом, матерью Уэнди и братом Филиппом, которые и составляют эту семейную компанию) живет в небольшой островной деревушке на озере Гурон в самом центре канадской провинции Онтарио, а не в Кремниевой Долине, не имеет никакого значения для shareware-бизнеса.

Именно сейчас Интернет становится очень подходящей средой для самостоятельной рекламы и сбыта ПО. Сегодня почти у всех представителей среднего класса есть компьютер с доступом в Сеть, а крупные компании, выпускающие кредитные карточки, наконец-то сделали банальностью оплату через WWW. По телевизору в лучшее эфирное время превозносятся преимущества покупок «одним щелчком мыши». У потребителя пропадает необоснованный страх перед электронной торговлей, и все больше людей осознают, насколько просто и удобно совершать здесь покупки.

Шемус признает, что Интернет - захватывающий и практичный инструмент для разработчиков условно-бесплатного программного обеспечения, но предупреждает, что даже он не спасет вас, если игра выполнена не на должном уровне.

В конечном итоге все сводится к одному: хороша ли игра. Легко ослепнуть от любви к собственному творению, особенно, если это ваш первый опыт. Но вы должны научиться смотреть на игру объективно, должны постоянно сравнивать ее с другими представителями жанра, чтобы правильно оценить ее достоинства и недостатки. В свое время я вдоволь нагляделся на shareware-игры для Windows, которые, пожалуй, не стоило выпускать даже как бесплатные. Но пусть вас не обескураживают неудачи. Учитесь на собственных ошибках, и ваше следующее творение будет лучше.

Шемус Макнэлли считает, что если игра никак не может «поймать волну», несмотря на интенсивное продвижение и поддержку, это, вероятно, означает, что она либо недостаточно хороша, либо слишком сложна уже на первых уровнях, что не дает увлечься ею. (Приводится с разрешения компании Longbow Digital Arts.)

Шемус утверждает, что хорошая программа во многом сама позаботится о своем маркетинге. Игроки, которым она понравилась, разрекламируют ее своим знакомым, те своим, в итоге, может статься, о вас напишут в электронных журналах, и т.п. В конце концов, раскрутка в Интернете отнимает не так уж много времени, поэтому ею можно заняться самому. Шемус говорит: «Необходимо сделать две вещи: завести собственный веб-сайт, зарегистрировав для этого свой домен, и обеспечить демо-версии вашей игры как можно большую известность».

Для популяризации игры, возможно, стоит потратиться на AddWeb (www.cyberspacehq.com), программу, которая автоматически заносит ваш веб-сайт в сотни поисковых машин и каталогов. Предлагается бесплатная демонстрационная версия.

Мы уже познакомились с типичными способами, используемыми создателями ролевых и карточных игр, чтобы вынудить играющего заплатить. А как быть в случае с классическими аркадами, подобными DX-Ball 2? «Выложить полную версию программы и попросить заплатить - это самая альтруистическая форма распространения условно-бесплатного ПО. Таким способом вы себе и на еду не заработаете, - отвечает Шемус. - Лучше предоставить небольшую часть игры, едва достаточную для того, чтобы поймать игрока на крючок, а затем кротко сообщить, что всего лишь за N долларов, переведенных на такой-то счет, можно немедленно получить оставшуюся часть этого роскошного продукта». Для великолепного арканоида DX-Ball 2 подобная «наживка» - это 24 бесплатных уровня из 150, доступных в полной версии.

И еще одно. Оплата кредитной картой - это хорошо, но Шемус Макнэлли советует не отказываться и от обычных вариантов - чеком или денежным переводом на ваш адрес, дабы вселить в людей уверенность, что вы не какая-то там фирма-однодневка. К тому же, далеко не все пользователи Сети имеют кредитные карточки...

(Талантливый - действительно талантливый! - программист и разработчик Шемус Макнэлли умер 21 марта 2000 г. Умер после трех лет борьбы с тяжелой, практически неизлечимой болезнью. Еще раз перечитайте его рассказ в этой книге - это писал смертельно больной человек. Не заметили? И правильно, потому что это писал еще и очень, очень счастливый человек! Что позволяет нам говорить так о Шемусе? То, что эти три тяжелейших года он, еще вчера бывший ребенком, школьником, собрав в кулак всю свою недюжинную волю, занимался делом всей своей жизни (увы, и в прямом смысле тоже...): Шемус разрабатывал игры. Не только в самом деле отличный, очень заводной и остроумный DX-Ball 2 (скачайте его shareware-версию - гарантируем, вы не остановитесь, пока не пройдете ее до конца, а пройдя, обязательно захотите купить полную игру), но и настоящую Большую Игру - Tread Marks. Да, да, этот человек был настолько силен духом и талантлив, что сумел заставить говорить о своей Большой Игре все ведущие игровые издания мира. В начале 2000 года Tread Marks была закончена и издана силами маленькой семейной почти любительской Longbow Digital Arts - и получила блестящую профессиональную прессу! А потом, уже в марте, за десять дней до смерти Шемуса, и вовсе - стала обладателем трех призов, включая Гран-при, авторитетнейшего Фестиваля независимых игр! Шемус был там, и это была его звездная минута. Спасибо ему за радость общения с его Играми, спасибо его родным за ТАКОГО сына и брата. Ему было всего 21. - Примеч. ред.)

Стив Морафф (Steve Moraff), MoraffWare

Стив Морафф - один из первых независимых разработчиков, начавших распространение условно-бесплатных игр еще в начале 80-х, хотя сам он услышал об этом термине лишь спустя несколько лет. Вот некоторые из его продуктов, пользующихся наибольшим спросом: MoreJongg, SphereJongg и RingJongg - три варианта классической восточной игры маджонг, выпускаемых компанией MoraffWare из американского штата Флорида (www.moraff.com).

Когда Стива спросили, почему некоторые разработчики игр предпочитают идти по пути условно-бесплатного распространения, а не сотрудничать с профессиональными издательскими структурами, он нашел этому простое объяснение:

Человек сам выбирает свой образ жизни. «Самиздат» дает радость общения с теми, для кого ты работаешь, и здесь ты сам себе хозяин, но при этом, чтобы поддержать свой бизнес, нужно решать множество задач, не связанных с программированием. При работе с издателем приходится делать то, что говорят, к тому же ты отдан на милость прогнившей системе розничной торговли, но зато можно полностью отдаться творчеству.

Стив Морафф и его компания распространяют полные варианты своих игр, но с меньшим количеством фоновых картинок, музыки и более бедным оформлением. «Заставлять» платить деньги, по мнению Стива, нужно так:

Напоминания об оплате программы должны быть надоедливыми. Игры, которые перестают функционировать по истечении 30-дневного испытательного срока, - это, наверное, крайняя мера, поскольку слишком уж раздражает пользователя, а значит - ухудшает распространение. Я использую такие противные окошки-напоминания, которые необходимо закрывать в конце игры. Мне кажется, я нашел таким образом баланс: просьба о регистрации, высказанная в подобной форме, не отбивает желания играть дальше.

Впрочем, немного помолчав, Стив добавил: «Признаюсь... у меня есть еще одно окошко, особенно гнусное, оно появляется примерно после восьми часов игры...»

В играх Стива Мораффа, таких как MoreJongg (вверху) и Fancy Jiggler (внизу), классическая идея облагорожена музыкой, графикой и захватывающими дух фотографиями. (Приводится с разрешения компании Moraffware.)


Как найти свое место в игровой индустрии

Глава 20

Как найти свое место в игровой индустрии

Как следует из опубликованных в этой книге интервью, есть много способов найти свое место в игровой индустрии. Однако наиболее распространены такие: 1) получить место в уже существующей компании-разработчике или издательстве; 2) создав свою игру, предложить издателю или дистрибьютору купить на нее права. Что предпочтете вы, нам не ведомо, но реализовать свой выбор можно множеством способов.

В игровой индустрии полно людей, которые добились признания, ступив на один из этих путей. Первая часть этой главы посвящена тому, как лучше представить идею своей игры (или саму игру) издателю, а вторая - тому, как получить работу в компании-разработчике. При этом вам следует помнить, что вопросы художественного оформления игр, создания анимации, программирования и проч. рассматриваются в других главах.

Прежде чем окунуться в очерченную выше тему, обратим внимание на вдохновляющие и весьма полезные слова Джима Чарна (Jim Charne), президента и исполнительного директора Академии интерактивных наук и искусств (Academy of Interactive Arts and Sciences, AIAS). Он напоминает начинающим разработчикам, что игровая индустрия проделала путь от хобби одиночек до процветающей отрасли капиталистического хозяйства всего за десять с небольшим лет, и сейчас самое замечательное время для того, чтобы показать себя на этом поприще.

Иначе говоря, само время предоставляет серьезным и подготовленным людям весьма удобный случай сделать успешную карьеру разработчика или издателя. Само собой, как и везде, чтобы забраться на самую вершину, нужно обладать талантом, быть чрезвычайно трудолюбивым и настойчивым, а еще - хоть чуть-чуть влюбить в себя госпожу Удачу. Но, вне всякого сомнения, возможности очень велики.

Вот еще несколько советов Джима, к которым, право же, надо прислушаться:

Как можно более полное и всестороннее образование - стремитесь к нему! Аппаратные средства и программное обеспечение усложняются неимоверно, а значит, не окажется лишним ни высшее образование, ни аспирантура. Это особенно важно для технических областей индустрии (где просто необходимо хорошее знание математики), однако крепкое образование не помешает ни музыкантам, ни художникам, ни дизайнерам.

Постоянно читайте литературу по специальности и игровые издания. Старайтесь знакомиться с максимальным количеством игр. При этом не просто играйте в них, а исследуйте, пытаясь понять, что у разработчиков получилось, а что нет. Вырабатывайте свое собственное мнение и будьте способны внятно его выражать.

И последнее. Джим Чарн за то, чтобы вы не замыкались в собственной профессии:

Каждый день читайте центральные - серьезные - газеты. Вы должны уметь поддержать разговор о политике, религии, истории, литературе, музыке, текущих событиях. Ваша игра должна быть открыта для окружающего мира. Не отворачивайтесь от него.

Спасибо, Джим! Мы продолжаем главу...

Как продать игру издателю

Это здоровое решение, но осуществить его не так просто. На наш взгляд, пойдя по этому пути, разработчик имеет куда больше шансов увидеть свою игруна магазинных полках (к тому же намного быстрее), чем если бы он трудился над тем же проектом внутри какой-нибудь компании. Если вы выбрали именно этот вариант общения с индустрией, то приведенные ниже советы опытных людей непременно помогут вам удачно продать плод своих трудов. Внемлите им.

Митци Макгилврей (Mitzi McGilvray), Electronic Arts

Митци Макгилврей - ведущий продюсер компании Electronic Arts, на ее счету такие известные игры, как NCAA Football, March Madness и NHL Hockey. Митци говорит, что не раз участвовала в рассмотрении предложений начинающих разработчиков и рада возможности поделиться своими соображениями о том, как лучше всего преподносить игру или ее идею потенциальному издателю.

Однако прежде чем углубиться в детали, Митци настоятельно советует разработчикам обеспечить правовую защиту себя и своих идей:

Не стоит отправлять какие-либо предложения, идеи или даже готовые продукты, не связавшись предварительно с компанией. В некоторых компаниях до начала переговоров принято подписывать соглашение о неразглашении, в других с этим не торопятся. Помните, вам может казаться, что ваша идея - самая что ни на есть свежая и плодотворная, но есть большая вероятность, что она уже была реализована до вас, реализуется в данный момент или уже была однажды отвергнута. Грандиозные идеи приходят в голову легко, а вот их грандиозное воплощение требует тяжелой работы, таланта, подходящего времени и удачи!

Далее Митци заметила, что несколько раз сталкивалась с довольно небрежным оформлением предлагаемых игр, и это трудно назвать самым лучшим способом произвести впечатление на издателя. Она подчеркнула, что умелое представление идеи, ее «упаковка» очень важна, потому что «если вы не можете ясно изложить свои мысли и представить их так, чтобы воодушевить публикатора, то неужели ваша работа сможет понравиться потребителю?»

Дизайн-документ

Вы обязательно должны представить дизайн-документ, содержащий предложения по реализации и маркетингу, чтобы можно было понять, как будет выглядеть игра, и спланировать ее продвижение. Приветствуются также наметки для программистов. Дизайн-документ - это «живая» материя, допускающая возможность изменения и развития по мере работы над игрой.

Митци указала, на что, по ее мнению, следует обратить особое внимание при составлении дизайн-документа:

Подробности, подробности и еще раз подробности. Составляя дизайн-документ, помните, что игра будет создаваться без вас. Опишите все как можно тщательнее.

Будьте гибкими. По всей вероятности, после завершения дизайн-документа, вам понадобится регулярно возвращаться к нему и вносить изменения. Поэтому он должен быть составлен в виде отдельных модулей, чтобы исправления в одном из них не влияли на остальные. Он должен допускать добавление и удаление различных возможностей игры без нарушения ее целостности. Хорошо иметь несколько «жертвенных» возможностей, от которых можно будет отказаться при недостатке времени.

Слушайте, слушайте, слушайте! Перед тем как начать программирование, получите как можно больше отзывов на свой проект от широкого круга специалистов разного профиля. Вам расскажут о трудностях, с которыми, возможно, столкнется игра, о ее слабых сторонах, и покажут, как можно улучшить воплощение ваших идей.

Используйте графику! Может быть, это прозвучит банально, но рисунки, графики и диаграммы действительно помогают художникам и программистам, разбирающимся с чужими идеями.

Настойчивость или назойливость?

Представляя свою задумку на чужой суд, будьте настойчивы, но ни в коем случае не назойливы.

Грань между этими понятиями довольно тонка. Издатели обычно очень заняты, поэтому важно обращать на себя внимание, посылая иногда письма по электронной почте или связываясь по телефону, чтобы узнать, чем закончилось дело. Не становитесь, однако, зубной болью издателя.

Не пытайтесь брать его измором! Многие издатели очень вспыльчивы, и их выводит из себя, когда к ним приходят и утверждают, что могут сделать невозможное.

Идеальное предложение

Хотите знать, как увеличить шансы на успех? Митци Макгилврей рассказывает, каким, по ее мнению, должно быть убедительное дизайн-предложение:

В идеале это должен быть полностью законченный, безупречный проект. В реальности же у большинства разработчиков просто нет денег, чтобы завершить игру, и издатели это понимают.

Если готовой игры нет, годится прототип - работающий и имеющий такой вид, чтобы можно было получить представление о замысле. Игра-прототип должна сопровождаться кратким пояснением на одной странице о том, в чем заключается основная идея и как следует играть. Неплохо также представить «тыльную сторону коробки» - добавить несколько эскизов игровых экранов, а также описать наиболее впечатляющие особенности игры и ее отличия от аналогичных продуктов.

Не можете сделать прототип? Тогда ограничьтесь описанием и «тыльной стороной коробки», добавив несколько абзацев о том, как предполагается играть в вашу игру и рассказав, чем, как вам кажется, игра будет прежде всего интересна.

И последнее. Представляя продукт, будьте готовы дать дополнительную информацию, например более полный дизайн-документ. Если вы собираетесь разрабатывать игру самостоятельно (с художниками, программистами, звукоинженерами и т.д.), многие издатели затребуют бюджет игры, сроки разработки, доказательства прав собственности на разработку, а также информацию о финансовом положении вашей компании.

Митци мечтает когда-нибудь начать серию спортивных игр, предназначенных для игрока-девушки. У вас есть идеи на сей счет? Теперь вы знаете, как их оформить.

Джош Резник (Josh Resnick), Pandemic Studios

Работая в Activision, Джош Резник был продюсером игры Mechwarrior 2, руководителем проекта Dark Reign, а также курировал проект Battlezone. В 1998 году он покинул Activision, основав и возглавив компанию Pandemic Studios, работающую по контракту все с той же Activision.

За годы работы у Джоша сложились пять основных принципов, которыми следует руководствоваться, предлагая идею игры издателю. Но не стоит ли разработчикам попытаться сначала сделать игру самостоятельно и лишь затем попробовать продать ее? Разве Митци Макгилврей из компании ЕА не сказала, что было бы идеальным предложить уже законченную игру? Джош согласен, что, может быть, легче продать уже готовую или почти готовую игру, но он настоятельно советует разработчикам «сначала поучиться на чужом опыте», добавляя при этом, что «надо быть абсолютно сумасшедшим, чтобы делать все самостоятельно». В самом крайнем случае должна быть работающая демо-версия игры, говорит Джош. Не забывая об этом, перейдем к его пяти заповедям.

У вас должна быть команда

«В наше время одиночке становится все тяжелее прийти к публикатору с концепцией игры, - признал Джош Резник. - Издатели заинтересованы в работе с коллективами, при этом в вашей команде не должно быть случайных людей». В то же время он считает, что издатели перегибают палку, предпочитая брать на работу только подготовленных разработчиков. В большинстве отраслей индустрии развлечений (если не во всех), например в кино, музыке или на телевидении, наниматели хотят, чтобы у вас был опыт, но как приобрести этот опыт, если вы не востребованы? «Вот почему работа в команде - вещь принципиальная. Вы никогда не станете лучшим, корпя над игрой в одиночку».

Практичность и профессионализм

«Ни в коем случае не приходите к издателю с нереальными идеями вроде использования полноэкранного видео или игры с сотней миссий, - предупредил Джош Резник. - Выясните, какой объем работ можно выполнить за определенные деньги в определенное время, ведь вы должны выглядеть опытным человеком. Исключительно важно показать себя профессионалом, предлагающим реальные проекты». Продемонстрируйте удобный интерфейс, покажите, что реализация может конкурировать с уже известными играми.

Для сравнения: разработка игры масштаба Battlezone или Dark Reign «стоит» от одного до полутора миллионов долларов. «Если это тот самый случай, - говорит Джош, - покажите, что вы способны жить впроголодь целый год! Издателю важно видеть вашу решимость реализовать проект, вплоть до готовности ради этого не получать зарплату в течение года».

А как насчет франчайзинга - приобретения прав на создание игры по знаменитому сюжету?

«Прежде спросите себя: как этот сюжет будет обыгрываться в проекте?» - говорит Джош Резник. Издатели любят франчайзинговые игры, так как потребитель уже знаком с сюжетом, его особенностями и персонажами. Франчайзинг позволяет издателям более точно планировать бюджет и затраты на реализацию проекта. Когда они уверены, что гарантированно продадут не менее определенного количества копий, то могут точнее оценить свои затраты и предполагаемую прибыль. «В этом и заключается одно из различий между такими, например, играми, как Dark Reign и GoldenEye 007, - заметил Джош. - Впрочем, сейчас судьба распорядилась так, что Dark Reign тоже превратился во франчайзинг, получив признание публики».

Другая причина любви публикаторов к франчайзинговым играм, по словам Джоша Резника, состоит в том, что они получают на проект все права. Это стоит денег, но, по всей вероятности, себя оправдывает.

В главах 2 и 3 уже обсуждались преимущества и недостатки реализации франчайзинговых разработок. На эту тему высказывались создатели игр из серий Star Trek, Star Wars и Dungeons & Dragons.

Впрочем, иногда из идеи лицензировать известную тему не выходит ничего хорошего.

В конечном счете нам не следовало приобретать лицензию на Battlezone; как оказалось, в этом не было необходимости, ведь игра совершенно не походила на оригинал. Это даже работало против нас. Дело в том, что наша игра получилась совсем новой, нестандартной и сильно отличалась от исходной аркады. Это лишь вызвало путаницу.

Battlezone был, пожалуй, одним из первых проектов, где классическая стратегия в реальном времени слилась воедино с экшен-игрой от первого лица. Игры-аналоги - Uprising (3DO) и Urban Assault (Microsoft).

Защищайте свои права

«На сто процентов все равно не защитишься, - говорит Джош, - но, к счастью, у издателей есть другие проблемы помимо воровства ваших идей». Часто на взаимном соглашении о неразглашении настаивает именно публикатор, чтобы иметь возможность сказать, что эта игра или идея игры принадлежит разработчику. Готовые варианты такого соглашения можно приобрести в США практически в любом магазине канцелярских товаров.

Если сколько-нибудь заметных денег на защиту своих авторских прав тратить не хочется, то вы можете послать сами себе по почте игру (или ее дизайн-документ), а получив ее, сохранить не вскрывая. Зачем? На конверте будет штамп с датой отправки, который удостоверит, что уже к этому сроку идея вами была оформлена письменно или в виде прототипа. Конечно, это временная мера. Джош Резник советует разработчику, опасающемуся чьей-либо нечестности, пригласить адвоката, чтобы засвидетельствовать его идею. «На это уйдет до пары сотен долларов, но, возможно, это оправданные траты».

В заключение Джош посоветовал автору, которому повезло добиться подписания контракта, внимательно изучить, что, собственно, он подписывает.

Не попадите в кабалу на всю жизнь. Контракт может быть в высшей степени односторонен. Издатели, естественно, стремятся присвоить все, что смогут. Лучше всего заключить разовый контракт, по которому компания выпустит только одно издание игры, потому что при этом вы не обязаны работать на него всю оставшуюся жизнь. Если игра окажется успешной, вы всегда сможете продлить контракт или заключить его с другой компанией.

Как найти работу

По словам Джоша Резника, разработчикам благоприятствует то обстоятельство, что игровая индустрия все еще относительно молода. Он пояснил свою мысль:

К счастью, найти у нас работу еще не так трудно, как, например, в кино. Существует масса всяких конференций, выставок, презентаций, и, к счастью, до сих пор нет никакого высокомерия, так что вы можете спокойно подойти и поговорить с кем-нибудь из знаменитостей. И все принимающие решения лица тоже пока еще доступны и даже отвечают по электронной почте, как простые смертные.

Возможно, последний совет Джоша наиболее актуален: многие способны сделать хорошую игру, но лишь у немногих достанет желания и дерзости предложить популярному издателю себя, свою команду и свою игру. Ведь худшее, что может произойти (при условии, что ваша идея защищена), это всего лишь то, что она никого не заинтересует. Когда терять нечего, а возможности так велики, проигрывают только те, кто ничего не делает.

«Проверьте свои программистские способности, поработав с исходным кодом программы-эмулятора, позволяющей переносить старые аркадные игры на ПК, - советует Дэйв (Dave) с популярного веб-сайта Dave's Video Game Classics. - Открытость исходных текстов позволяет войти в дело любому, кого это интересует, и разработка проекта значительно ускоряется (при условии, что проект становится достаточно популярен, как это произошло с Multiple Arcade Machine Emulator, МАМЕ)». По словам Дэйва, несколько человек, начавших с переноса аркад на ПК при помощи эмулятора (скажем, того же МАМЕ), продолжили затем работу в больших компаниях. Веб-узел Dave's Video Game Classics находится по адресу: www.davesclassics.com.

Майкл Рубинелли (Michael Rubinelli), THQ

Вице-президент компании THQ, отвечающий за разработку игр, Майкл Рубинелли руководит людьми, которые, в свою очередь, возглавляют коллективы разработчиков. Кто может лучше него ответить на вопрос, как надо подписывать контракт с издателем!

Майкл считает, что все пройдет без сучка и задоринки, если выполняются три следующих условия (и хотя выполнение всех трех не является необходимым, чтобы вызвать интерес издателя, в этом деле лучше быть максималистом):

• Во-первых, неотразимый дизайн-документ. Или, другими словами, исчерпывающее описание всех функций игры и ее сценария, с информацией обо всех членах коллектива разработчиков.

• Во-вторых, набор игровых раскадровок в цвете или моделей персонажей. Стало быть, не обойтись без художника. Только так, по словам Майкла, издатель сможет составить четкое представление о видеоряде игры. Предоставьте ему предварительные наброски и уже готовые рисунки с тщательно прорисованными героями и задниками.

• В-третьих, «живая» демонстрация - работающий прототип игры или хотя бы движок.

Все это уже свидетельство того, что над игрой трудится талантливая команда, и это большое дело.

И последний совет Майкла Рубинелли: вы обязаны знать платформу, для которой делается игра, представлять себе все ее преимущества и недостатки и, конечно, суметь убедить издателя, что вы действительно в этом разбираетесь.

Согласно Майклу Рубинелли, комплект оборудования и программного обеспечения, с помощью которого можно разработать консольную игру, стоит от 20 до 25 тысяч долларов. Примерно во столько это обошлось бы издателю уровня THQ (зарплата разработчиков в эту экспресс-калькуляцию, само собой, не входит).

Отвечая на вопрос, на какие игры ставит компания THQ, Майкл Рубинелли признал, что его ответ прозвучит банально, но это чистая правда:

Мы ищем игры, которых ожидает успех. Именно поэтому я всегда интересуюсь, какими играми увлекается сам автор. Если теми же, что разрабатывает, то это сразу чувствуется: у таких команд игры получаются независимо от жанра.

Франц Ланзингер (Franz Lanzinger), Actual Entertainment

Франц Ланзингер, автор Gubble 1 и 2, ныне, после десяти лет вольных хлебов работающий в компании Actual Entertainment, с удовольствием делится своим опытом с новичками. Вполне возможно, кому-то эти советы помогут спуститься с небес на землю...

Мой главный совет честолюбивым авторам заключается в следующем: не бросайте свою постоянную работу. Зарабатывать деньги в игровой отрасли почти так же трудно, как в кино. Если вы любите игры и просто не видите для себя никакого другого занятия - тогда, конечно, дерзайте. Только не надейтесь разбогатеть сразу... если это вообще когда-нибудь случится.

Маркетинг и сбыт игры в одиночку - занятие не для робкого сердца или тощего кошелька. Будьте готовы к потере денег и времени, потраченных на игру. Часто нет другого способа реализовать свой замысел, кроме как рискнуть ввязаться в проект без уверенности в успехе, - зато процесс может быть захватывающим. Знайте, однако, что многие из этих попыток, включая и наши труды в компании Actual Entertainment, оборачиваются безвозмездной работой на голом энтузиазме, так и не превращаясь в успешные предприятия.

Пол О'Коннор (Paul O'Connor), Oddworld Inhabitants

Вы познакомились с Полом, дизайнером уровней, много лет работающим в индустрии, в 6-й главе этой книги, здесь же он говорит о том, с чего лучше всего начинать свой путь в профессии:

Стремитесь к разностороннему и основательному образованию. На каждую сыгранную вами игру должны приходиться три прочитанные книги. Вы непременно должны иметь высшее образование.

Развивайте способность к критическому анализу всех форм развлечения, изучайте механизмы явлений и вещей. Создание игр - это совместное творчество, и, если вы не умеете ладить с людьми, займитесь чем-нибудь другим. Этот труд предполагает коллективные обсуждения и постоянные компромиссы, так что если вы хотите работать, уединившись на чердаке, то лучше уж писать романы. Что же касается собственно старта в индустрии, то, по-видимому, большинство разработчиков начинали как тестеры. Это низкооплачиваемый труд и длиннющий рабочий день, но лучшей возможности продемонстрировать компании, что вы разбираетесь в играх, а значит, способны на большее, вам не найти.

Как получить работу в игровой компании

Да, это выглядит не слишком эффектно, но все же самый приятный, полезный и познавательный способ попасть в индустрию - это... устроиться на работу в игровую компанию. Только представьте себе: вы проводите время в отборной команде талантливых художников, аниматоров, программистов, дизайнеров, музыкантов и т.д., каждый член которой отвечает за свою часть проекта. Кроме того, вы с ног до головы обеспечены мощным инструментарием, так что работать в компании гораздо дешевле, чем сразу начинать собственное дело. Наконец, этот путь позволяет новичку понять, как складываются взаимоотношения между разработчиком и издателем.

Дело за малым - вам остается изучить нижеследующие советы, как получить работу в выбранной вами компании-разработчике или издательстве, - и стать звездой. Всего лишь.

Пол Джейкуэйз (Paul Jaquays), id Software

Пол Джейкуэйз, дизайнер уровней из прославленной id Software, а равно весьма заслуженный ветеран игровой индустрии, отдавший ей почти 24 года, с отеческой улыбкой на устах напоминает молодым и зеленым соискателям вакансий, что их ждет адова работа, и никаких гарантий того, что о них каждый день будут писать в газетах.

Из каждых десяти тысяч мальчишек и девчонок, мечтающих профессионально заниматься компьютерными играми, лишь немногие смогут стать настоящими асами. Еще меньше пробьются в звезды, даже в своей узкой области.

Как же узнать, ваше это или не ваше?

Еще раз оцените себя критически, говорит Пол, и честно ответьте на следующие вопросы:

• Есть ли у вас сильное стремление создавать игры?

• Вам больше нравится делать игры или играть в них?

• Нравится ли вам решать сложные проблемы каждый день?

• Готовы ли вы посвятить себя профессии, в которой ваш рабочий день будет длиннее, а иногда и значительно длиннее, чем у других?

• Обладаете ли вы творческими способностями в нескольких областях?

• Понимают ли ваши близкие, насколько ваша жизнь будет поглощена работой (и смогут ли они с этим смириться)?

Надо ли говорить, что единственным подходящим ответом на все эти вопросы должно быть категорическое «да».

У Пола, сотрудника одной из самых престижных игровых компаний этой планеты, часто спрашивают, какая подготовка нужна для работы в этой отрасли. И каков же ответ? «Разнообразная», - отвечает он.

Подходящий кандидат должен проявить разнообразные таланты и навыки. Предъявляемый нами список включает способности (но не ограничивается ими!) к сочинению сюжета, художественному оформлению 2D-текстур, 3D-моделированию, разработке персонажей, дизайну уровней, написанию сценария игры и диалогов, созданию музыкальных и звуковых эффектов, программированию, руководству проектом и коммерческой подготовке. Сосредоточьтесь на чем-нибудь одном, но старайтесь овладеть и другими полезными навыками - как уж получится. Наиболее ценные члены команды - это те, кто может работать по многим направлениям и выполнять сразу несколько функций.

Опыт - это прекрасно, но Пол Джейкуэйз настоятельно рекомендует учиться - где только можно, чтобы развить свои навыки.

Наниматели ищут обладателей творческих способностей, но на самом деле им необходимы не просто творческие люди, а люди с техническими навыками, позволяющими реализовать эти способности. Если вы хотите заниматься сочинительством, вам следует учиться литературному мастерству, а также, что немаловажно, машинописи. Если вы хотите заниматься художественным оформлением игры, поступите на курсы изобразительного искусства (и не важно, что они не будут иметь ничего общего с компьютерами). Если вы хотите создавать уровни трехмерной игры, в обязательном порядке пройдите курсы обучения компьютерной графике. Хотите сочинять музыку? Играйте в ансамбле!

Возвращаясь к пункту о необходимости приобретения нескольких профессий, Пол Джейкуэйз настойчиво повторяет, что даже если у вас нет навыков работы по всем перечисленным выше специальностям, вам все равно следует учиться тому, в чем вы слабы. «Ведь вам придется говорить с коллегами по будущей команде на одном языке, уверенно разбираться в том, что они делают».

Пол напоминает, что если вы рассчитываете на собеседование о приеме на работу, то должны быть полностью к нему готовы: «Держите под рукой отпечатанное резюме (в нескольких экземплярах) и презентацию вашего лучшего творения, чтобы выслать их нанимателю по первому требованию». В случае необходимости воспользуйтесь курьерской почтой, дабы предоставить любые запрошенные материалы о себе уже на следующий день.

Предположим, у вас есть прирожденные способности, дополненные соответствующим образованием. Когда следует начинать стучаться в двери? Пол ответил на это следующим образом:

Не ждите от потенциального работодателя немедленного признания ваших талантов. Сначала наберитесь опыта. Обычно это любительский опыт участия в некоммерческих переработках существующих игр. Отнеситесь к такому проекту так, будто он коммерческий. Продемонстрируйте, что вам по плечу профессиональная работа и, что самое важное, закончите свою часть проекта в точно установленный срок.

Если вы утвердились во мнении, что это ОНО, то, чем вам хотелось бы зарабатывать себе на жизнь, то что же - надо бросать все и тут же переключаться на разработку игр? «Как бы не так»,- говорит Пол Джейкуэйз.

Не спешите уходить со своей постоянной работы. Это важный момент. По всей вероятности, вы потратите много времени, обивая пороги. Даже если вы живете у родителей и не платите за жилье, вам будет необходим приличный компьютер.

Каждый мечтает о популярности. Но, по правде говоря, большинство людей, работающих в этой отрасли, не видят своих фотографий в Newsweek и своих цитат в Rolling Stone. У них нет дорогих спортивных автомобилей, они не могут позволить себе то и дело отдыхать на заморских тропических островах. Конечно, мечтать об этом не вредно, но вряд ли вы с самого начала окажетесь наверху или даже где-нибудь в середине. Индустрия кишит рассказами о быстром успехе, но большинству звезд пришлось пройти все ступени, начав с самой нижней. Это не значит, что вам не следует метить высоко только потому, что я все это сказал. От попытки устроиться в известную компанию от вас не убудет, но надо четко понимать, что эти компании успешны в том числе и потому, что берут на работу только опытных людей.

В качестве выхода из положения Пол порекомендовал подумать о временном контракте, так как это даст шанс продемонстрировать, что вы на самом деле умеете делать. Способный временный сотрудник часто находит возможность перейти на постоянную работу у того же нанимателя или даже получить рекомендацию в другую компанию. Вам нужен пример? Вот реальный случай из жизни:

Моя работа в игровой индустрии началась с девятинедельного контракта с компанией Coleco - попытки разработать фэнтези-РПГ, которая могла бы работать с примитивного устройства считывания штрих-кода. Когда этот проект закончился, я уже был художественным директором и под моим началом был целый штат разработчиков, создающих игры для компьютеров ColecoVision, Atari 2600, Intellivision и ADAM.

Да, и не ограничивайтесь в поиске работы только тем местом, где живете. При необходимости будьте готовы к переезду. Удостоверьтесь, что ваша спутница жизни понимает это. Компании в этой отрасли приходят и уходят. Не рассчитывайте, что задержитесь где бы то ни было надолго.

Многие люди поражены динамикой роста игровой индустрии и переживают, что не могут устроиться сюда на работу. Так как все-таки попасть сюда со стороны?

Старайтесь посещать все отраслевые мероприятия. «Не имей сто рублей, а имей сто друзей» - в этой пословице заключена большая доля истины. Довольно часто место предоставляется по рекомендации друга, знакомого или человека, с которым вы до этого хотя бы раз встречались лично. Как художественный директор, я с большей охотой отдал бы проект человеку, с которым знаком, нежели неведомому художнику, приславшему папку со своими работами. Имея это в виду, надо стараться быть там, где встречаются профессионалы. Встречи, конкурсы игр, семинары разработчиков - посещайте эти мероприятия, чтобы переговорить с людьми, которые уже работают в этой отрасли. Попробуйте представиться и, если возможно, убедите их посмотреть ваши творения.

А если вы уже попали туда, куда хотели? Что теперь? «Быть внимательными друг к другу», - отвечает Пол. А разве это не очевидно?

Не должен бы я это объяснять, но придется. Интернет быстро вытеснил фанатские журналы и бюллетени всяких там ассоциаций пользователей чего-либо, преобладавшие, когда я начинал свою карьеру. Раньше эти средства использовались как трибуна для выражения своего мнения по волнующим темам, причем аргументация была довольно эмоциональная, в пылу спора оппонент «испепелялся». Обмен мнениями происходил с периодом в несколько месяцев. Сейчас же участники дискуссии, интересующиеся тем или иным предметом, могут связаться друг с другом немедленно, хоть в чате, хоть на доске объявлений, хоть в сетевом форуме. Относительная анонимность такого общения часто наводит людей на мысль, что можно грубить, если хочется сказать что-то резкое. Однако невежливость может быстро войти в привычку. Грубое отношение к чьим-либо замечаниям, мнениям или опыту, выраженное в Сети, позволяет «выпустить пар» на короткое время, но мы ведь работаем (или надеемся работать) в маленькой отрасли. Мы все стремимся побольше узнать о своих коллегах, работающих в других компаниях. А они, в свою очередь, общаются друг с другом. Слухи мгновенно расходятся во все стороны. Поэтому следует считать само собой разумеющимся то, что вы должны относиться к каждому представителю игровой индустрии, как к человеку, который, возможно, когда-нибудь станет вашим начальником. Иными словами, уважайте его. Обращайтесь с уважением, подчеркивая тем самым и в себе, и в своих собеседниках профессионализм.

В общем, когда вы, в конце концов, получите работу в игровой индустрии, продолжайте относиться к каждому человеку, как к возможному начальнику (два парня, которых я нанял на работу в Coleco, до этого приютили меня в компании, в которой работали сами). И не забывайте протягивать руку помощи начинающим.

Но как узнать, подходите ли вы, чтобы хотя бы предпринять попытку? К кому можно обратиться за искренним советом?

Отнеситесь с осторожностью к похвалам друзей. Принимайте их во внимание, но не забывайте, что ваши друзья, скорее всего, не имеют достаточной квалификации, чтобы дать совет, необходимый вам для профессионального роста и развития своих навыков. Ищите возможность выслушать разумную критику от человека, который, как вы считаете, разбирается в этом лучше вас. Примите такую критику с благодарностью.

И наконец, есть ли у этой профессии изнанка, не слишком приятная сторона? (Ее не может не быть, верно?) Пол Джейкуэйз предостерегает:

Приготовьтесь напрочь отказаться от своего хобби - компьютерных игр на досуге и в свое удовольствие. Так было со мной, хотя, может быть, вам это не грозит. Когда я стал профессионалом, игры, подобные тем, над которыми я работал, больше не доставляли мне удовольствия в свободное время. Это началось тогда, когда я в первый раз делал приключенческую РПГ. Чем больше я сочинял игровых сценариев за деньги, тем меньше мне хотелось играть только ради удовольствия. Когда я перерабатывал одну аркаду для компании Coleco, то быстро утратил интерес к стрельбе по мишеням в аналогичных аркадных играх. Вернувшись к созданию приключенческих «ролевиков», я опять перестал играть ради удовольствия. И т.д. и т.п.

Сегодня я занят 3D-шутерами от первого лица, но, если честно, мне тяжело играть в них только ради удовольствия. Это не означает, что мне не нравится этот жанр, нет, просто я уже не могу играть, не изучая игру профессиональным взглядом: я не вижу самой игры, а смотрю, как она сделана...

Кевин Клауд (Kevin Cloud), id Software

Художник и совладелец компании id Software Кевин Клауд считает, что начинать работу в игровой отрасли можно с любой профессии.

Будущему разработчику не стоит сразу начинать с собственно создания игр. Потому что среди всех наших профессий наибольший опыт требуется именно от этой. Просто иметь хорошую идею недостаточно. Разработчики должны понимать весь процесс создания игры. Они должны ясно видеть, что достижимо, а что нет, и сколько потребуется для реализации проекта людей и времени. Словом, лучше сначала попробовать себя в качестве сценариста, менеджера проекта, художника, программиста, дизайнера уровней или тестера.

Питер Молиньё (Peter Molyneux), Lionhead Studios

Форменный гений, приложивший руку к таким классическим играм для ПК, как Populous, Syndicate, Dungeon Keeper и Magic Carpet, Питер Молиньё предложил нашему с вами вниманию ряд советов относительно того, как найти работу в игровой индустрии, а также немного порассуждал о том, что надо, а что не надо делать.

В игровую индустрию ведут три пути. Первый - получить образование и соответствующую ученую степень. Если вы хотите быть программистом, то следует сосредоточиться на математике, программировании или прикладной дисциплине; если же вы намереваетесь работать художником - получите степень в области изобразительных искусств. Чтобы проделать этот путь в Великобритании, вам понадобилось бы получить очень хорошее образование в очень хорошем университете.

Второй путь - начать с самого низа, с тестера или помощника, а затем продвинуться по служебной лестнице.

Третий путь, самый трудный сегодня, - объединиться с несколькими единомышленниками, помешанными на играх, и основать собственную компанию.

Мой совет такой: если вы хотите добиться в чем-нибудь успеха, в вашей жизни это должно стоять на первом месте. Не ждите фанфар и сладких пряников, если работаете строго с девяти до пяти. Посылая документы предполагаемому нанимателю, позаботьтесь об их краткости и... интересности - ваше резюме должно быть захватывающим! Это относится ко всему, начиная с автобиографии и кончая проектом игры; подробности могут оказаться неинтересными и сбивающими с толку.

«Верьте в себя! Если вы не верите в себя сами, то кто же в вас поверит!» - вдохновляюще восклицает на прощание Питер Молиньё.

Фил Штейнмейер (Phil Steinmeyer), РорТор Software

Президент, ведущий разработчик и программист вновь созданной компании РорТор Software (вы прекрасно помните ее замечательную, отмеченную множеством профессиональных призов игру Railroad Tycoon II) Фил Штейнмейер высказал несколько мудрых советов о том, как найти работу в игровой отрасли.

Ограничьтесь ясной и достижимой целью, особенно в своей первой игре

Интернет кишмя кишит заброшенными проектами групп, которые без всякого опыта намеревались создать нечто почище Quake. Если вы работаете над играми в свободное время и у вас мало опыта, вам вряд ли удастся превзойти профессиональные и хорошо финансируемые команды. Остановитесь на чем-нибудь доступном. Если вам нравится заниматься дизайном уровней, разработайте серию уровней для своего любимого шутера от первого лица или набор миссий для стратегии. Если вы программист, напишите новую версию своей любимой аркады, выпущенной в начале восьмидесятых (Рас Man, Space Invaders и т.д.). Если вы художник, создайте новый персонаж для Quake или анимацию 3D-героя своей любимой игры. А самое главное - доведите дело до конца!

Главная причина сдержанности, о которой я говорил выше, заключается в достижимости результата. Лично я с куда большим удовольствием посмотрел бы на полностью законченный вариант игры Рас Man, чем на очередной «Quake-киллер», завершенный только на 10% процентов и состоящий из неотесанных полигонов, грубо наляпанных на экран.

Занимаясь поисками места, будьте готовы показать свои работы

В наше Интернетообильное время не иметь своих творений в электронном виде, доступных любому потенциальному работодателю, просто стыдно. Отправляя резюме, не забудьте приложить к нему соответствующие файлы или указать адрес домашней страницы, где можно посмотреть на ваши разработки.

Для дизайнера уровней это, конечно же, должны быть уровни. Желательно - лучшие из того, к чему вы прикладывали руку, и к двум или более играм. Почему игр должно быть несколько? Это повышает вероятность того, что ваш наниматель будет знаком хотя бы с одной из них - а значит, возможно, заинтересуется вашими экзерсисами. Художнику или дизайнеру, думая об образцах, следует уделить внимание разнообразным видам художественного оформления игры (как двух-, так и трехмерной): наброски, варианты анимации, модели персонажей, механических объектов и т.д. Программисту как воздух необходима работающая демо-версия, желательно хоть с каким-нибудь оформлением (возможно, вам придется обратиться за этим к другу-художнику...).

И швец, и жнец...

Штат РорТор Software состоит всего из шести человек. У нас нет отдельных штатных единиц для каждого вида работы, которой мы занимаемся. Один художник, закончив рисовать, делает звуковые эффекты. Другой, завершив художественное оформление игры, занят видеоэффектами. Наш главный уровнестроитель помимо всего прочего является прекрасным художником и неплохим писателем, а значит...

Выбор темы

Наконец, у вас появилась возможность заняться созданием КОММЕРЧЕСКОЙ игры. Если это ваша первая игра, постарайтесь быть оригинальными (друзья мои, новички! запомните: задача должна быть оригинальной, но все же ВЫПОЛНИМОЙ). Скорее всего, бюджет у вас будет самый что ни на есть скромный, а навыков у вас и вашей команды пока еще может недоставать. Поэтому не пытайтесь превзойти игры высшей категории, с бюджетом в три миллиона долларов, разработанные полусотней человек, которых в шутерах от первого лица и стратегиях в реальном времени - что грязи. Выберите нишу с минимальной конкуренцией или же нишу, где соперничают в основном малобюджетные игры. Это могут быть варгеймы (war games), головоломки, ретро-аркады.

«Гораздо проще обратить на себя внимание там, где конкуренция мала, и только потом перейти к более претенциозным проектам», - заключил Фил.

Майкл Рубинелли (Michael Rubinelli), THQ

В начале этой главы Майкл Рубинелли обращался к разработчикам, намеревающимся предложить свои игры и идеи непосредственно издателям. Теперь он предлагает несколько советов на тему «Как получить работу в уже зарекомендовавшей себя компании».

Не стоит сразу метить на место дизайнера или продюсера, эти профессии требуют опыта и кое-каких заслуг. Начните свою карьеру, скажем, с отдела тестирования или службы технической поддержки. Не сомневайтесь, ваш час придет - ведь когда большая компания увеличивает штат, чаще всего поиск кандидатов на новые должности начинается внутри коллектива. Это и понятно: руководители стремятся, если это возможно, в первую очередь выдвинуть своих работников.

Джош Резник (Josh Resnick), Pandemic Studios

Джош Резник (вы с ним тоже знакомы - по первой части этой главы) сказал, что проще всего попасть на работу, показав свои уровни или карты. По словам Джоша, в свое время Activision даже заплатила нескольким авторам со стороны за использование их карт для игры Dark Reign.

Это и в самом деле один из лучших способов «проникнуть» в команду разработчиков. Начинающий дизайнер может создать уровень для экшен-игры или стратегии, используя бесплатные программы-редакторы; умелый программист в состоянии представить красивый кусок исходного кода; художник - показать нарисованных персонажей. Нет ничего проще. А еще это прекрасный способ «подлизаться» к издателю - показать, что вы любите игры этой компании настолько, что тратите все свое свободное время на создание дополнений к ним.

Наконец, хитрый Джош Резник посоветовал почаще заглядывать в Интернет: «Разработчики и издатели нередко ищут кадры через Сеть».

Алекс Гарден (Alex Garden), исполнительный директор и ведущий разработчик компании Relic Entertainment (Homeworld!), предложил следующий совет: «Есть хороший способ найти работу в игровой отрасли: надо написать рецензию на существующую игру, полностью пройти ее, составить дизайн-документ по ее усовершенствованию и отправить все это авторам. Есть немалый шанс, что кого-то это заинтересует всерьез. И даже если вас не возьмут на работу, вы все равно получите хорошую практику».

Сид Мейер (Sid Meier), Firaxis Games

«Начинайте тестером, но тестером деятельным и умным - демонстрируйте свои знания, не стесняйтесь выдвигать предложения по улучшению игры, - говорит гуру Мейер, описывая традиционный способ подъема по карьерной лестнице. - Другой вариант - принять участие в составлении руководства пользователя. Иными словами, делайте что-нибудь, связанное с играми, и если у вас есть способности, они обязательно будут замечены».

А как насчет самостоятельной разработки?

Этот путь, несомненно, самый быстрый, но он требует везения и невероятного таланта. Если это именно то, что вам по душе, и вы программист или имеете в своей группе программиста, скомпилируйте работающую демо-версию своей игры и ищите, куда бы ее пристроить. Наверное, всем известна легендарная история с игрой SimCity? Уилл Райт (Will Wright) послал ее восьми издателям, и все они, кроме компании Maxis, отвергли его труд. Сейчас публикаторы гораздо более восприимчивы, но вы все равно должны скомпилировать хороший прототип. В нем, кстати, совершенно не обязательны ни игровые видеоролики, ни тщательно отделанная графика.

Внимательно прочтите советы Сида Мейера по поводу общих принципов создания игр в главе 2.

Ричард «Лорд Бритиш» Гэрриот (Richard «Lord British» Garriott), Origin Systems

Лорд Бритиш, человек, уже давно не нуждающийся в представлениях, тоже дал несколько советов о том, как устроиться на работу в отрасли.

Найдите способ попасть в молодую растущую компанию. Для начала попробуйте получить работу в службе технической поддержки или в отделе тестирования - сразу оказаться в команде разработчиков очень тяжело. Может быть, это было возможно двадцать лет назад, но не сейчас... С другой стороны, наша отрасль очень молода, и для достижения в ней вершин имеются самые благоприятные возможности.

Двадцать лет назад, когда я начинал, никого не заботило, есть ли у вас высшее образование, но сейчас это очень важно. Менеджеры как черт ладана опасаются хакеров. Хакеры, кстати, тоже нужны, - они блестяще находят проблемы, но куда важнее прежде нанять высококвалифицированного инженера. Плюс вам понадобится более обширное, нежели классическое, образование. А еще вам нужно будет показать свои способности - приготовьте, например, кусок программы. Неплохо будет смотреться созданный вами модуль к Dungeons & Dragons или интерактивная книга.

И последнее. Почему каждый считает себя компетентным разработчиком ровно за пять лет до того, как на самом деле готов им стать?..

Ищете работу в игровой индустрии? В главе 24 «Чем может помочь Интернет при разработке игр» хозяин сайта GameJobs.com Рик Вандерворн (Rick Vandervoorn) рассказываете своей бесплатной службе «Вакансии разработчиков» и о том, как Интернет изменил способы поиска работы.

Тоби Гард (Toby Card), Confounding Factor

А теперь давайте дадим слово джентльмену, создавшему Лару Крофт! (Для непосвященных: Лара Крофт - главный герой серии игр Tomb Raider, разработчик Core Design, издатель Eidos Interactive.) По словам Тоби, лучший способ пробиться в отрасль с такой высокой конкуренцией - это пройти обучение в большой компании.

Чтение книг никогда не заменит подлинных знаний, полученных во время реальной работы над игрой. Кроме того, вы ведь не хотите, чтобы самым первым вашим проектом (а первые проекты редко бывают удачными) была ваша собственная игра, верно? Ведь чтобы не провалить дело, нужно так много узнать... Словом, сначала желательно поработать в команде и набраться опыта. К тому же, если вы уже участвовали в разработке от начала до конца, люди с большей серьезностью отнесутся к вашим собственным проектам.

Итак, я не стал бы беспокоиться о рассылке разработок, если вы только-только начинаете; займитесь этим, собрав приличный портфель собственных проектов. А пока хотя бы пару лет поучитесь у какого-нибудь мастера...

Джейн Дженсен (Jane Jensen), Sierra On-Line

Джейн Дженсен - звезда первой величины игровой индустрии, разработчик и сценарист трех интерактивных мистерий из популярнейшей серии Gabriel Knight: Sins of the Fathers, The Beast Within и Blood of the Sacred, Blood of the Damned (издатель Sierra).

Что сей заслуженный работник интерактивных искусств может сказать о том, как найти работу в игровой индустрии?

Это довольно трудно, поэтому обычно я рекомендую всем желающим сначала получить образование - например программистское или художественное. Получили? Теперь можно стучаться в соответствующие двери. Немногие компании возьмут на работу неопытного «дизайнера игр» прямо с улицы. У нас принято или нанимать высококвалифицированных людей, или продвигать своих (из своей же компании). Запомните, подавляющее большинство программистов или художников, работающих в игровой компании, мечтают о собственной игре, и они хотя бы имеют возможность продемонстрировать свои творческие способности и устремления. Другой способ - основать вместе с друзьями собственную маленькую компанию и скомпилировать прототип. Если он достаточно хорош, вас могут взять на работу в известную компанию или дать денег на завершение проекта. Учтите только, что на создание достойного прототипа (с отличной графикой и проч.) надо положить уйму труда и времени, а это, как вы догадываетесь, не так просто.

Мэтт Притчард (Matt Pritchard), Ensemble Studios

Программист компании Ensemble Studios Мэтт Притчард поделился с нами мыслями о самых лучших способах подготовки к работе в игровой индустрии. Но прежде чем вдаваться в подробности каждой профессии, Мэтт дал несколько общих советов. Если в двух словах, то вам необходимо: а) любить игры и б) интересоваться ими в большей степени, чем только игрой в них. Итак, согласно классификации Мэтта Притчарда, непосредственно в создании игр участвуют специалисты четырех основных профессий. Это:

Программисты. Специализируются на языках программирования (Си++, Ассемблер и проч.). Знатоки таких предметов, как разработка программного обеспечения, алгоритмы, структуры данных и математика.

Художники. Обладают навыками рисования двумерных и трехмерных объектов, используемых в играх. Они изучают живопись и совершенствуют свои художественные навыки, в которые входят умение работать с текстурой и композиция; кроме того, они должны хорошо знать некоторые программные средства (Photoshop, 3D Studio MAX и проч.).

Звукоинженеры и музыканты. Музыканты по образованию, эти специалисты занимаются созданием звуковых эффектов и музыкального сопровождения игр. Это одновременно и способные музыканты, и опытные пользователи самого новейшего оборудования, и знатоки специального ПО для преобразования звуков и сочинения музыки.

Наконец, собственно разработчики, дизайнеры, авторы игры. Досконально разбираются во всех практических и теоретических вопросах, связанных с созданием игр. Обычно играют во все, что только выпускается, - от головоломок до варгеймов и РПГ. Они отвечают за бесчисленное множество статистических данных, свойств и правил, которые входят в состав игры, и должны уравновесить все до мелочей, чтобы сделать игру интересной. Никаких специальных учебных предметов для разработчиков не существует, они изучают все: историю, точные науки, внутренние механизмы работы сотен игр... Эти люди тратят массу времени на создание того, из чего, собственно, и состоят игры: уровней, миссий, головоломок и т.д.


Агенты и вербовщики

Глава 21

Агенты и вербовщики

Прямо скажем, не у всех разработчиков хватает умения или смелости предложить себя или свои игры солидному издателю. Более того, во многих случаях разработчики принципиально предпочитают заниматься исключительно созданием игры, а всю «рутину» переложить на других.

По примеру других отраслей развлекательной индустрии, найти друг друга разработчикам и издателям помогают, соответственно, агенты и вербовщики. И хотя действуют они по-разному, цель у них одна - свести талантливых авторов и их творения с публикаторами и дистрибьюторами.

Эта глава посвящена работе указанных специалистов (как с той, так и с другой стороны «баррикад»), делая немаловажный для вас акцент на том, какие преимущества вы, уважаемый разработчик, можете получить, воспользовавшись их услугами.

Сьюзен Льюис (Susan Lewis), ThinkBIG

Сьюзен Льюис - основатель и президент агентства ThinkBIG, созданного для того, чтобы представлять и защищать интересы разработчиков и издателей игр. Агентство специализируется, в частности, на оказании помощи авторам, которые ищут издателей для распространения своей игры вне США, а равно американским публикаторам, которые желают расширить сбыт своей продукции за пределы своей страны.

Сьюзен объясняет, почему разработчику выгоднее воспользоваться услугами агента-посредника, вместо того чтобы напрямую обращаться с предложением к издателю, и что ему следует сделать перед тем, как связаться с агентом.

Компании стремятся работать с агентами, а не с разработчиками. И тут же первый совет разработчику: прежде чем обращаться к агенту, наберите команду. Далее, у вас на руках должен быть дизайн-документ игры или хотя бы предварительный его набросок, а также работающий прототип. Это не означает, что из этого правила не бывает исключений. Не так давно я подписала контракт с двумя увлеченными молодыми людьми, просто рвущимися создать очередную часть одной из самых нашумевших в 1998 году игр для ПК. Все, чем я располагала, - это две страницы с проектом игры, два исполнителя, да еще пачка обещаний их друзей присоединиться к команде, если я организую им контракт с издателем. Это была трудоемкая работа, почти с нуля. Тем не менее, благодаря хорошим резюме этих ребят, мы добились контракта с крупным издателем (игра должна выйти в 2000 году). Безусловно, это была необычная ситуация, исключение из правил. Если у вас нет проработанной идеи и прототипа, потребуется весьма впечатляющий послужной список, чтобы привлечь внимание агента.

Как именно все это работает? И как оплачиваются услуги агентства?

Процесс похож на представление проекта издателю. Я регулярно получаю проекты и прототипы игр, иногда по своему запросу, иногда присланные разработчиками по собственной инициативе. Если что-то из полученного может заинтересовать мою компанию, я вступаю в переговоры с этим автором, вникаю в суть игры, смотрю прототип, а также стараюсь получить представление о составе его команды, чтобы понять, на что она способна и в чем слаба. Прежде чем стать агентом, я занималась подбором кадров для игровой индустрии, поэтому могу быть весьма полезна для устранения слабых мест команды. Если мне нравится то, что я вижу, и я чувствую, что это можно продать, я заключаю с разработчиком контракт, по которому агентство ThinkBIG становится эксклюзивным распространителем его игр по всему миру. Есть большая разница между играми, которые нравятся лично мне, и теми играми, которые я, по моему мнению, смогу продать. Например, мне нравятся стратегии в реальном времени, сделанные на основе спрайтов, вроде WarCraft и Command & Conquer, но вряд ли я когда-нибудь соглашусь представлять такую игру. Причина очевидна: если на коробке с этой игрой не будет известной торговой марки, продажа хотя бы двадцати тысяч копий этого творения - уже удача. Большинство издателей не потрудятся даже взглянуть на нее.

Подписав контракт, я связываюсь с подходящим издателем и организую встречу с должностными лицами компании, демонстрирую им прототип и представляю идею игры. На стадии подписания контракта я продолжаю работу с адвокатом разработчика и юридическим отделом издателя, согласовывая условия контракта. После подписания контракта я остаюсь участником проекта, хотя и менее активным, выясняя состояние дел у разработчика, сверяясь с продюсером, отслеживая ход работы до последнего этапа или платежа и утрясая с издателем проблемы, если они возникают.

Размер моего вознаграждения зависит от того, сколько получит от издателя разработчик; то есть 10% от всех авансовых выплат на разработку и 10% от всех итоговых авторских гонораров и вознаграждений.

Сьюзен упоминает в своей биографии, что она работала с такими издателями, как Electronic Arts, Acclaim, Fox Interactive, Atari Games и BMG Interactive. Конечно, читателям было бы любопытно услышать от нее какую-нибудь историю потрясающего успеха.

Я горжусь, например, той работой, которую проделала для компании BMG Interactive с их баскетболом для приставки Nintendo 64. Когда ВМС закрывала свое отделение в США, меня наняли, чтобы продать права на издание некоторых их игр в США и заграницей. Баскетбол, разработанный компанией Z-Axis, был игрой NBA с лицензией без права передачи. Понимаете, лицензия NBA - это одна из тех лицензий, которую труднее всего приобрести, и фактически у всех издателей, у которых она есть, имеется свой собственный компьютерный баскетбол. Мы довольно быстро исчерпали свои возможности по продаже продукта как игры NBA (многие издатели хотели ее купить, но ни один из них не мог получить лицензию), поэтому было решено, что компания Z-Axis быстро переделает ее в чемпионат колледжей. Вновь возникшая проблема состояла в том, что этот проект оказался рискованно близок к игре March Madness, а в компании Nintendo процесс окончательного утверждения игры перед ее изготовлением и выпуском растянут по времени. В конце концов, я связалась с компанией Fox Interactive, которая как раз только что объявила о своем намерении начать выпуск спортивных игр; она приобрела игру и выпустила ее осенью 1998 года под названием Fox Sports College Hoops.

Чтобы получить более подробную информацию об агентстве ThinkBIG, посетите его веб-сайт www.thinkbigco.com. Если же вас интересуют проблемы общего характера, обратитесь непосредственно к списку часто задаваемых вопросов, который вы можете найти по адресу: www.thinkbigco.com/faq.html.

Мелани Кэмброн (Melanie Cambron), Virtual Search

Мелани Кэмброн из компании Virtual Search, без ложной скромности называющая себя «богиней вербовки игровых специалистов», занимается поиском кадров для таких небезызвестных компаний, как Electronic Arts, Micro Prose, Hasbro, Mattel, Accolade и многих, многих других. Мелани обрисовала в общих чертах, с какой стороны разработчику игр следует подходить к вербовщику:

Отправьте какому-нибудь одному, хорошо зарекомендовавшему себя вербовщику с умом написанное, тщательно вычитанное и проверенное резюме. Будьте разборчивы при выборе своего агента. Не вредно также показаться на Конференции разработчиков игр (GDC) или на одной из конференций Международной ассоциации разработчиков игр (IGDN).

Программист должен иметь при себе в качестве образца вычищенный, снабженный подробными комментариями исходный текст, приготовленный для показа. У художника должен быть впечатляющий демо-ролик, дополненный музыкальным сопровождением. Разработчику хорошо бы захватить для демонстрации дизайн-документ игры, который, естественно, перед рассылкой должен быть защищен соглашением о неразглашении. Получив ваше резюме, менеджер по найму персонала, скорее всего, тут же запросит образец программы или демонстрационный ролик.

А как оплачиваются услуги вербовщика? Мелани ответила следующим образом:

Я получаю вознаграждение от работодателя (компании-разработчика или издателя). Некоторые клиенты нанимают меня по контракту за фиксированную плату, другие предпочитают разовые платежи, когда мне причитается определенный процент от зарплаты нанятого сотрудника за первый год его работы.

Мелани рассказала и о других преимуществах работы с вербовщиком, помимо бесплатности его услуг (для нанимаемого):

Часто даже очень талантливые люди не имеют никакого понятия о том, как подать себя. Сколько раз я видела резюме с ужасными ошибками! Вечнозеленое изречение о первом впечатлении часто оказывается болезненно верным! К тому же у хороших вербовщиков есть масса связей в солидных компаниях по разработке игр, и часто он может передать ваше резюме именно тому менеджеру по кадрам, который и в самом деле вами заинтересуется.

Мелани предложила нам воспользоваться ее короткой статьей о том, как войти в игровую отрасль. Первоначально она была написана для программистов, но вполне может быть отнесена и к разработке игр в целом.

Резюме

Старайтесь быть лаконичным, не пропуская при этом важной информации. Резюме должно занимать не больше двух страниц, а в идеале - только одну. Еще раз: не надо перечислять все проекты, в которых вы участвовали. Сосредоточьтесь на той части сделанного вами, которая имеет отношение к вакансии, которую вы хотите получить в игровой индустрии. Если вы занимались разработкой или программированием игры без оплаты, обязательно укажите это в своем резюме. Первым делом следует упомянуть любой, я повторяю, любой опыт работы с компьютером, кроме разве что самого доисторического. Тем, кто получил диплом совсем недавно, следует поместить информацию об образовании в начале своего резюме; это отвлечет внимание читающего от мыслей об отсутствии у вас опыта. Самое главное, тщательно перечитайте свое резюме, прежде чем отправить его. Просто поразительно, как часто приходится иметь дело с резюме, кишащими элементарными орфографическими и синтаксическими ошибками, а также явными опечатками в датах работы и учебы. Первое впечатление о вас у компании или агента обычно складывается по вашему резюме. Да, может быть, вы неплохой программист, считающий, что знание родного языка не имеет значения при составлении программы, но компаниям требуются разносторонние, способные люди, которые внимательны ко всему, что они делают.

Резюме может оказаться глубоко личным документом, но все-таки, если у вас есть такая возможность, пусть друг, член семьи или доверенный агент прочитают ваше резюме перед его отправкой. Вы сами, возможно, просматривали его тысячи раз, но «свежий взгляд» легко выловит ошибки, которые вы пропустили из-за усталости. Наконец, избегайте редко используемых шрифтов и не раскрашивайте текст. Сегодня резюме зачастую сканируются, поэтому печатайте его обычным шрифтом (черным цветом) на белой бумаге. К тому же менеджер по кадрам хочет найти главную информацию сразу, а не блуждать по причудливым шрифтам и рисункам. Крайне важно, чтобы кроме резюме у вас были образцы программы, готовые к отсылке по запросу потенциального нанимателя. Образец должен представлять собой около трех страниц совершенно ясной, снабженной подробными комментариями программы. Опять-таки, пусть его вычитает кто-нибудь из ваших знакомых, разбирающихся в предмете.

Демонстрационная версия игры

Компаниям, занимающимся производством игр, необходимо знать, что вы не только умеете писать программы, но и страстно увлечены играми. Что вы настолько преданы этому делу, что создавали бы свою игру лишь из любви к искусству. И не важно, что ваша игра - жуткая мешанина пикселей и ничего более, зато видно, что вы старались и всерьез этим увлечены. Это имеет большое значение. Стоит вам только поговорить с теми, кто уже работает в игровой индустрии, и вы поймете, что большинство людей занимаются этим не ради денег.

Распространенные ошибки и простые советы

Случается, что особо усердные личности раз за разом бомбардируют компании своими резюме. Поймите, это только раздражает. В итоге вас сочтут «отчаявшимся неудачником или просто дураком», если цитировать менеджера по кадрам одной очень крупной компании-разработчика. Обязательно аккуратно записывайте, куда и когда вы послали свое резюме, чтобы избежать накладок. Другая непростительная ошибка - предлагать кадровикам в компаниях или вербовщикам «зайти на веб-сайт» и посмотреть на ваше резюме в Интернете. Эти люди получают такое большое количество резюме, что у них нет времени выискивать ваши писания в Интернете. Облегчите им задачу, и вероятность положительного ответа возрастет.

Более того, посылайте свои резюме только в те компании, где вы действительно хотите работать. Если вы не собираетесь переезжать во Флориду, не стоит отправлять свое резюме в Gainesville Games. При обращении к агенту обязательно поделитесь всей этой информацией, чтобы ему не пришлось получать отказ из компании, в которую вы уже посылали свое резюме, или, в свою очередь, отказывать заинтересовавшейся вами компании из-за того, что вас не устраивает ее местонахождение. Отказы не нравятся никому.

Приготовьтесь к большому собеседованию. Независимо от того, сидите ли вы у телефона или за столом напротив Генерального Технического Директора Всего На Свете, вы должны подготовиться. Убедитесь, что вы тщательно изучили, чем занимается компания, и приготовились ответить на вопросы о своих навыках и любимых играх. Что касается стиля одежды, то быть одетым слишком нарядно всегда лучше, чем выглядеть так, будто вы вышли за сэндвичем. Классические брюки или джинсы и рубашка вполне подойдут для собеседования в игровой индустрии. Если сомневаетесь, наденьте костюм.

Даже если вы считаете, что у вас есть просто потрясающая идея игры, не забывайте, что главное - это опыт. Игровая отрасль во многом похожа на производство кинофильмов - связи играют огромную роль. Каждый год сотни компаний возникают и исчезают, так и не выпустив ни одной игры. Чтобы уберечь себя от ненужных трат душевных сил, времени и денег, начинайте свою карьеру в солидной компании. Поступив так, поучитесь у тех, кто имеет за плечами конкретный положительный опыт. И, если у вас после всего этого сохранится горячее желание сделать собственную игру, удачи вам!

Более подробные сведения о компании Virtual Search приведены на веб-сайте www.vsearch.com, телефон компании: 1-800-779-3334.

Ищете работу? Обратите внимание на еще одно агентство - Game Agents (www.gameagents.com). Годовщину своей деятельности в январе 1999 года оно отметило успешно проведенными переговорами по лицензионному соглашению между компаниями Aztech New Media и Monolith о разработке набора дополнительных уровней к очень популярной игре Shogo: Mobile Armor Division (Monolith).


G.O.D. - божественное откровение

Глава 22

G.O.D. - божественное откровение

Как уже не раз говорилось в этой книге, существует несколько способов создать компанию по разработке игр и заключить соглашение с издателями или дистрибьюторами. Но, как выяснилось в середине 1998 года, есть и альтернатива - это появившаяся как раз в это время компания совершенно нового типа Gathering of Developers, или просто G.O.D. (в переводе с английского буквально «бог». - Примеч. перев.). Если коротко, в основе деятельности G.O.D. лежит совершенно новая бизнес-модель, суть которой в более справедливом отношении к разработчикам (как видите, название компании - «Объединение разработчиков» - отнюдь не случайно). Конкретно это означает более высокие лицензионные отчисления, большую творческую свободу и менее жесткие условия контрактов.

Эта глава рассказывает об истории создания G.O.D., ее партнерах, целях и даже будущем - ведь Gathering of Developers всерьез намеревается перестроить игровую индустрию.

Начала

Впервые с идеей организации объединения разработчиков выступил Майк Уилсон (Mike Wilson), бывший тогда сотрудником службы по работе с клиентами в компании id Software, ставшей впоследствии одним из самых выдающихся независимых разработчиков. Вы, конечно же, знаете (если только не провели последние шесть лет на необитаемом острове), что эта талантливая команда программистов и художников, выпустив Wolfenstein 3D и исключительно популярные серии Doom и Quake, произвела настоящую революцию в мире 3D-шутеров от первого лица.

Издателем id Software в те далекие времена была GT Interactive, могущественная сегодня, а тогда небольшая компания, известная в первую очередь своей экранной заставкой Fabio и компакт-диском Ричарда Симмонса (Richard Simmons) «Deal a Meal». Затем появился Doom 2, первая действительно революционная игра для ПК. Она была продана в количестве свыше двух миллионов экземпляров (заметьте, это произошло еще до того, как компания Cyan выпустила Myst). В итоге блокбастеры id Software превратили GT Interactive в компанию, чей первый выпуск акций принес ей один миллиард долларов (это, кстати, рекорд 1995 года). По словам Майка Уилсона, им заплатили довольно внушительные авторские гонорары, но, «если сейчас оглянуться назад, то понимаешь, что они были ужасающи низкими, учитывая, что только Doom 2 принес GT около восьмидесяти миллионов долларов прибыли».

И тогда родилась идея создания Gathering of Developers...

Предназначение

Цель G.O.D. - завоевать первенство среди издателей и стать мировым лидером по выпуску коммерчески успешного игрового ПО, предназначенного как для ПК, так и для игровых приставок. Как именно они собираются этого достичь? Исполнительный директор Gathering of Developers Майк Уилсон ответил: «Обеспечив долгосрочные связи с самыми выдающимися и талантливыми независимыми разработчиками».

Используя такой подход, G.O.D. стремится к установлению принципиально новых взаимоотношений между разработчиками и издателями. Эти принципы включают в себя следующие положения: объективное отношение к разработчикам; прямая зависимость между количеством проданных копий игры и размером авторских отчислений; объективная оценка игры с учетом мнения признанных в отрасли специалистов и разработчиков; обязательное наличие у персонала успешного опыта проведения маркетинговой, операционной и финансовой экспертизы.

Уникальность G.O.D.

Майк Уилсон уверен: самое главное, что требуется от издателя, - это заметить в человеке талант разработчика и установить с ним долговременные связи в расчете на успех его творений. «Это же заодно и самое трудное для издателя, причем (а иногда особенно) для издателя крупнейшего. Это происходит по двум причинам: из-за недоверия разработчиков к обычным бизнесменам и из-за недостаточного понимания разработчиков и их нужд», - продолжает Майк.

Преимущества G.O.D. заключаются в уникальном по своей полноте понимании этих проблем, а также в тесных связях компании с самыми выдающимися разработчиками. В отличие от других издателей, эта компания начала свою деятельность с заключения серии долгосрочных соглашений о создании игр, беспрецедентных для игровой индустрии.

Майк Уилсон хочет, чтобы его детище стало признанным лидером в установлении связей между разработчиками и производителями игр, и надеется, что остальные последуют их примеру.

Мы не стремимся выпускать игры для масс. Мы хотим издавать игры, которые будут названы шедеврами именно теми игроками, что не мыслят свое существование без этого развлечения. Если мы, действуя таким образом, докажем, что издатель может успешно вести дела, установив взаимовыгодные отношения с авторитетными мастерами, вместо того чтобы захватывать их компании, отчуждать и присваивать их интеллектуальную собственность или ослаблять их настолько, что они не могут настаивать на своих условиях, то, как мы надеемся, игровая индустрия станет с нами считаться. Даже если никто кроме нас не будет работать по такому принципу, мы все равно положим (уже положили!) начало очень важной тенденции в отношениях между издателями и разработчиками. По крайней мере мы будем уверены, что авторы знают себе истинную цену и могут выставлять свои условия, исходя из нее.

Действительно ли деловые отношения между разработчиками и издателями до такой степени односторонни? Отвечает президент G.O.D. Гарри Миллер (Harry A. Miller):

Разработчики сегодня угнетены издателями, они имеют очень слабое представление о принятых стандартах оплаты труда в индустрии и введены в заблуждение из-за отсутствия практической сметки в одних вопросах и из-за своих чересчур идеалистичных представлений о партнерстве - в других. Стратегия издателей заключается в том, чтобы платить скудные авансы и зарплаты, держать разработчиков «в черном теле», не давая им возможности настаивать на своих условиях при заключении контракта или искать работу в другом месте из-за неопределенности, возникающей при экономической зависимости от оплаты следующего этапа разработки. Заключить корректный и выгодный контракт может только независимый, крепко стоящий на ногах разработчик, хорошо информированный и имеющий полное представление о бизнесе. Наша стратегическая линия - постоянно информировать таких авторов, добиваясь, чтобы они знали, что всегда могут связаться с нами и удостовериться, что их творение дойдет до поклонников с минимальными препятствиями и в максимальной сохранности.

В январе 1999 года компании G.O.D. и Miller Freeman, Inc. объявили об учреждении Фестиваля независимых игр (Independent Games Festival), который вот уже второй год подряд проводится в рамках ежегодной Конференции разработчиков игр (Game Developers Conference). Основные цели Фестиваля: помочь развитию интерактивных развлечений как одной из форм искусства и предоставить независимым разработчикам со всего мира возможность публично показать свои работы, получить известность и встретиться с вероятными издателями. Подробнее об этом можно прочитать в главе 25.

Игры и их распространение

Многие издатели высказываются в том духе, что, дескать, программу G.O.D. приятно читать, но неплохо бы учесть в ней огромные расходы на распространение и маркетинг. G.O.D. настаивает на том, что эти расходы учтены. Так, компания Take 2 Interactive распространяет первые десять игр G.O.D. через свои дочерние предприятия в Европе, США и Канаде, используя те же самые розничные каналы, что и все остальные игроки на рынке. В их числе компании CompUSA, Wal-Mart, Best Buy, Electronics Boutique, Babbages/Software Etc., Computer City (ныне принадлежащая CompUSA), FRYs и другие. Майк Уилсон говорит, что в игровой отрасли девяносто процентов продаж обеспечивают порядка десяти распространителей, а остальное приходится на долю мелких дистрибьюторов и прямые продажи через Интернет.

G.O.D. начала свою работу с долгосрочными контрактами с шестью наиболее популярными студиями разработки. Это, в произвольном порядке, 3D Realms (в которой была создана популярная серия Duke Nukem); Ritual Entertainment (игры Sin и Quake: Scourge of Armagon), PopTop Software, возглавляемая ветераном индустрии Филом Штейнмейером (Phil Steinmeyer); Terminal Reality (серия Monster Truck Madness для компании Microsoft и многие другие игры); Epic Games (создатель знаменитого 3D-шутера Unreal) и компания-новичок Edge of Reality, специализирующаяся на играх для Nintendo 64 и PlayStation 2. Возглавляет Edge of Reality Роб Коэн (Rob Cohen), бывший ведущий программист игры Turok: Dinosaur Hunter (разработчик Iguana), разошедшейся тиражом в полтора миллиона экземпляров.

Все без исключения игры, выпущенные G.O.D. на сегодня, были очень тепло, а в некоторых случаях и восторженно, встречены критикой игроками. Вот эти проекты: Jazz Jackrabbit 2 (Epic Games), Railroad Tycoon II (PopTop Software), GTA: London 1969 (DMA Design), Fly! и Fly!2K (Terminal Reality), Darkstone (Delphine Software), Nocturne (Terminal Reality), Age of Wonders (Triumph Studios/Epic Games).

Сверху - сцена из игры Railroad Tycoon II (компания PopTop Software); снизу - лисенок Спаз, закадычный друг кролика Джаза, главного героя игры Jazz Jackrabbit 2 (компания Epic Games). (Приводится с разрешения Gathering of Developers.)

За дополнительной информацией о G.O.D., ее совете директоров и впечатляющей серии намеченных к выпуску игр обращайтесь на веб-сайт www.godgames.com. Кто знает, может быть, и ваша команда однажды соприкоснется с G.O.D.!


Школы для разработчиков

Глава 23

Школы для разработчиков

Как вы успели убедиться, десятки разработчиков, программистов и художников, добившихся успеха в своем деле, считают, что наличие высшего специального образования - это ценный капитал, крепкий фундамент для хорошей карьеры в индустрии интерактивных развлечений. Многие руководители проектов или продюсеры просто не возьмут на работу человека без соответствующего специального образования (к примеру, университетского или институтского диплома по вычислительной математике, если речь идет о программистах). Существуют сотни учебных курсов для программистов, художников, музыкантов и звукоинженеров, но лишь в очень немногих из них уделяется внимание тому, какое отношение изучаемый предмет имеет к компьютерным играм. И не удивительно, что специализируются в этой области и вовсе единицы.

Эта глава рассказывает о нескольких учебных заведениях и курсах, предназначенных исключительно для подготовки разработчиков компьютерных и видеоигр.

DigiPen Institute of Technology (www.digipen.edu)

Джейсон Чу (Jason Chu), секретарь Технологического института DigiPen, отвлекся на некоторое время от работы, чтобы рассказать нам о том, что представляет из себя это уникальное в своем роде учебное заведение.

Сначала немного истории. Корпорация DigiPen была основана Клодом Комэром (Claude Comair) в 1988 году в Ванкувере (провинция Британская Колумбия, Канада). В первое время своего существования компания предоставляла услуги по трехмерной компьютерной анимации и специальным эффектам для индустрии развлечений. Обратив внимание на острую нехватку специалистов по 3D-анимации, Клод Комэр и его коллеги решили исправить это положение. DigiPen занялась обучением художников методам трехмерной анимации.

В 1991 году состоялась встреча представителей DigiPen и компании Nintendo of America (NOA), на которой обсуждались перспективы обучения в DigiPen программированию видеоигр. Эта идея воплотилась в жизнь в сентябре 1994 года, когда в DigiPen при поддержке NOA была запущена уникальная для Канады и США программа обучения разработчиков компьютерных игр. Первоначально она была рассчитана на два года обучения. Однако по мере развития 3D-технологий игры становились все сложнее для программирования. Поэтому вскоре курс был расширен до четырехлетней программы подготовки бакалавров. В феврале 1998 года DigiPen открыла еще один, более крупный учебный центр в Редмонде (штат Вашингтон, США).

Джейсон Чу объяснил, что выпускники получают диплом бакалавра по интерактивному моделированию в режиме реального времени, так как именно этим, по мнению руководителей института, и являются все видеоигры.

Учебный план в настоящее время состоит из девяти курсов математики, двух - физики, четырех - компьютерной анимации и двадцати трех - информатики. Помимо этого студентам нужно выполнить четыре проекта по разработке игр. Для получения диплома необходимо сдать сто пятьдесят четыре зачета. DigiPen также предлагает студентам сокращенную двухлетнюю программу и летний курс.

Осенью 1999 года институт DigiPen начал обучение аниматоров с выдачей диплома в области прикладных искусств по специальности «трехмерная компьютерная анимация». В будущем предполагается также открыть аспирантуру для подготовки магистров и докторов наук.

Почему желающим научиться программированию игр или созданию трехмерной анимации следует поступать именно в DigiPen? Вот ответ Джейсона Чу:

Мы предлагаем узко специализированный учебный курс по программированию игр. Насколько нам известно, в настоящее время мы являемся единственным в мире учебным заведением, выпускающим дипломированных специалистов в области программирования видеоигр.

Для получения более полной информации, включая обзор учебных курсов, предварительные требования к поступающим, списки студентов, сведения об плате за обучение и финансовой помощи, посетите веб-сайт www.digipen.edu.

Правый снимок сделан во время церемонии официального открытия студенческого городка в Редмонде, штат Вашингтон, 18 февраля 1998 года. Слева направо: губернатор штата Вашингтон Гэри Лок (Gary Locke), президент компании Nintendo Минору Аракава (MinoruArakawa) и основатель компании DigiPen Клод Комэр (Claude Comair). Внизу: студенты работают над проектом в учебной аудитории. (Приводится с разрешения Джейсона Чу.)

Full Sail (www.fullsail.com)

Обучение разработке игр ведется еще в одном институте, специализирующемся на высоких технологиях, - Full Sail в городе Винтерпарк (штат Флорида, США). Девиз этого учебного заведения - «обучение для реальной жизни», причем разработка игр является только одной из учебных программ по компьютерным наукам. Курс с получением диплома по специальности «разработка игр» предназначен для обучения студентов навыкам, необходимым для разработки и создания всевозможных компьютерных игр: сетевых, для ПК и игровых приставок, для одного и нескольких игроков.

Обучение начинается с вводного курса, обеспечивающего базовые знания по математике и программированию. Здесь также преподается история развития компьютерных игр, имеющая целью изучение и анализ тенденций развития рынка, от которых зависит популярность оборудования и программного обеспечения, предназначенных для игр. Далее студенты переходят к основному курсу, в составе которого: математика и физика, программирование на Си++, технологии создания искусственного интеллекта для моделирования поведения противника, написание программ для многопользовательских игр и, в конце обучения, реальный проект по созданию игры. Естественно, обучение включает значительное число часов практической работы на компьютере.

В Full Sail есть отдел по трудоустройству, помогающий выпускникам устроиться на работу в компании-разработчики.

Для получения бесплатного каталога или более подробного описания каждой из 14 частей программы обучения, рассчитанной на пятьдесят восемь недель, загляните на веб-сайт Full Sail, расположенный по адресу: www.fullsail.com.

Весной 1999 года в Калифорнийском университете (город Ирвайн) был прочитан курс, посвященный разработке игр. Одним из преподавателей этого курса был Тим Кейн (Tim Cain), автор популярнейшей ролевой игры Fallout. Курс Тима Кейна включал в себя лекции по трехмерному программированию и использованию технологии OpenGL.

NBCC Miramichi (www.miramichi.nbcc.nb.ca)

Это канадское учебное заведение, расположенное на востоке страны, предлагает обучение по курсу «технология разработки электронных игр». Филиал New Brunswick Community College (NBCC) обучает студентов разработке, дизайну и написанию сценариев для различных электронных игр.

Судя по расписанию учебного курса, рассчитанного на восемьдесят недель (шесть семестров), главное его предназначение - научить студентов создавать интерактивные программные продукты, совмещающие развлечение и обучение (edutainment). В течение этих шести семестров изучаются программирование, игровая механика, дизайн игр, графика и анимация, тестирование программ, маркетинг, а также несколько полезных факультативных предметов. Основной упор делается на практическую работу. Ведь чтобы успешно закончить обучение, студенту необходимо создать такой программный продукт, который «индустрия и колледж сочтут готовым к продаже».

Подробная информация доступна на веб-сайте: www.miramichi.nbcc.nb.ca.

Другие учебные заведения, достойные вашего внимания

Ниже приведен список учебных заведений с их электронными адресами, на которые следует обратить внимание будущим разработчикам игр, программистам и аниматорам.

• Международный институт искусств (Art Institutes International) www.aii.edu

• Центр творческой коммуникации Bell при колледже Centennial (The Bell Centre for Creative Communications at Centennial College) www.bccc.com

• Центр сложных цифровых приложений при Нью-Йоркском университете (The Center for Advanced Digital Applications at New York University) www.sce.nyu.edu/cada

• Центр цифровых изображений и звука (The Center for Digital Imaging and Sound) www.artschool.com

• Национальный центр анимации и дизайна (Centre National d'animation et de Design) www.nad.qc.ca

• Политехнический колледж Cogswell (Cogswell Polytechnical College) www.cogswell.edu

• Технологический институт DeVry (DeVry Institute of Technology) www.devry.edu

• Восточный институт компьютеров для бизнеса, Колледж прикладных искусств и технологии (Eastern Business Computer Institute, College of Applied Arts and Technology) www.ebci.ca

• Институт Herzing (Herzing Institute) www.herzing.edu

• Квебекский институт информатики (L'Institut d'informatique de Quebec) www.iiq.qc.ca

• Международный университет Marycrest (Marycrest International University) www.mcrest.edu

• Лаборатория искусственного интеллекта MIT (MIT Artificial Intelligence Laboratory) www.ai.mit.edu

• Национальный центр компьютерной анимации при Борнмутском университете (National Centre for Computer Animation at Bournemouth University) http://ncca.bournemouth.ac.uk/

• Институт Pratt (Pratt Institute) www.pratt.edu/ad/cgim

• Рочестерский технологический институт (Rochester Institute of Technology) www.rit.edu

• Университет штата Сан-Франциско (San Francisco State University) www.cel.sfsu.edu/MSP/msp.html

• Школа коммуникационных искусств (School of Communication Arts) www.ncsca.com

• Школа компьютерных наук и Исследовательский центр познавательных наук (School of Computer Science and Cognitive Science Research Centre) www.cs.bham.ac.uk/~axs

• Школа компьютерных наук при Мидлсекском университете (School of Computing at Middlesex University) www.cs.mdx.ac.uk/cg/

• Университет Abertay Dundee (University of Abertay Dundee) www.abertay-dundee.ac.uk

• Калифорнийский университет (University of California, Los Angeles) www.ucla.edu

• Мичиганский университет (University of Michigan) http://ai.eecs.umich.edu/ugclasses.html

• Университет Северного Техаса (University of North Texas) www.cs.unt.edu

• Университет Южной Калифорнии (University of Southern California) www.use.edu/dept/cs/degree_programs/

• ViaGrafix www.viagrafix.com

Благодарим Алекса Данна (Alex Dunne), главного редактора журнала Game Developer и редактора веб-сайта Gamasutra (www.gamasutra.com) за помощь в составлении этого списка.


Ресурсы по разработке игр в Интернете

Глава 24

Ресурсы по разработке игр в Интернете

Эта книга довольно подробно освещает целый ряд вопросов, но она никоим образом не является истиной в последней инстанции, если речь идет о разработке игр и способах «инфильтрации» в эту бурно развивающуюся индустрию. Уникальной средой для взаимодействия начинающих и опытных разработчиков, а также всех, кто связан с играми, является Интернет. Цель этой главы - указать несколько познавательных и интересных остановок в путешествии по морю информации.

Ссылки на десятки полезных электронных адресов и групп новостей Usenet попадались вам и ранее - едва ли не на каждой странице этой книги. Эта глава посвящена WWW-ресурсам, касающимся общих вопросов разработки игр.

Нижеследующие веб-сайты и группы новостей Usenet перечислены в алфавитном порядке.

Computer Game Design

www.neversoft.com/christer/GR/design

Это электронное издание, организованное Кристером Эриксоном (Christer Ericson), содержит подборку статей специалистов индустрии интерактивных развлечений и ссылок на их веб-страницы. Вот лишь некоторые названия документов: «Краткий курс по разработке и производству игр» (A Crash Course in Game Design and Production), «Создание сетевых головоломок» (Designing Online Puzzle Games), «Проектирование искусственного интеллекта» (Project AI) и «Элементы стиля видеоигр» (Elements of Videogame Style). Здесь нет никакой графики, поэтому страница загружается почти мгновенно.

Computer Role-Playing Game Designer

www.ultranet.com/~melkior/crpg/index.htm

Здесь находится несколько дизайн-документов по созданию компьютерной ролевой игры. Автор - Стив Крокер (Steve Crocker). Рассматриваются цели, правила, вопросы программирования (на примере Си++) и вариант интерфейса пользователя.

DevGames.com

www.devgames.com

Это электронный журнал, посвященный разработке компьютерных игр и содержащий море полезной информации. Здесь есть новости, тематические статьи, редакционная колонка, рубрика «вопросы и ответы», ссылки на полезные книги и другая информация. Стоит почитать, например, «Руководство программиста DirectX в вопросах и ответах» (The DirectX Programmer's Q&A), «Основы искусственного интеллекта для игр» (The Basics of Game AI), «Игры: двухмерные или трехмерные» (2D vs. 3D). Кроме того, здесь всегда можно найти «дневники разработчиков» уже выпущенных и еще только создаваемых игр, а также материалы Microsoft о программировании под Windows и Direct3D. He пропустите этот веб-сайт.

Gamasutra

www.gamasutra.com

Один из лучших веб-сайтов, посвященных разработке игр. Его отличает изобилие охватываемых тем: программирование, художественное и звуковое оформление, музыка, есть даже части, посвященные производственным, юридическим и коммерческим сторонам игровой индустрии. В каждом разделе - регулярно обновляемые новости, редакционные статьи, интервью, постоянные колонки специалистов, объявления о работе, бесплатные программы и исходные тексты и многое, многое другое. Короче говоря, сделайте этот веб-сайт вашей начальной страницей при запуске Интернет-соединения.

Редактором и директором веб-сайта Gamasutra.com, издаваемого компанией Miller-Freeman, является Алекс Данн (Alex Dunne), главный редактор журнала Game Developer.

Game Design

http://members.aol.com/anarchyxi/gamedev.htm

На этой странице обсуждаются некоторые ключевые вехи в истории индустрии видеоигр и предлагаются лучшие способы начала работы над проектом. Немало места отводится разработке сюжета игры, выбору жанра и игровой перспективы, приводится много примеров.

Game Design (группа новостей)

rec.games.design

Разработчики игр просто обязаны заглядывать в группу новостей rec.games.design в сети Usenet - по крайней мере несколько раз в неделю, чтобы быть в курсе самых последних новостей. Здесь же можно обмениваться мнениями или задавать вопросы.

Вот заголовки некоторых сообщений: «Идея новой многопользовательской игры» (An idea for a new multiplayer game), «Ay, музыканты...» (Any game musicians out there?) и «Помогите создать правила для...» (Need help in creating rules for...).

Страница вопросов и ответов группы новостей rec.games.design находится по адресу: www.qucis.queensu.ca/home/dalamb/Games/design/design.html.

Game Design @ Gameslice

www.gameslice.com/vgd/index.shtml

Этот информационный веб-сайт прежде был известен под названием Video Games Design и находился по адресу: www.videogamesdesign.com. Теперь он разделен на четыре части: разработка игр, программирование, графика и звук. Каждая часть содержит множество интервью со знаменитыми разработчиками и серию хорошо написанных и вдохновляющих статей об индустрии. В конце этой главы редактор Game Design поделится с вами несколькими соображениями о своем электронном журнале и об Интернете как о среде общения разработчиков.

Game Developer Magazine

www.gdmag.com

Журнал Game Developer, вне всякого сомнения, является основным ежемесячным изданием для всех разработчиков. Редактируемый творческим вдохновителем веб-сайта Gamasutra Алексом Данном, журнал Game Developer и его электронный двойник - это всесторонний обзор всего, что связано с разработкой игр. Кроме всего прочего, здесь можно подписаться на журнал, провести поиск по его предыдущим выпускам и перейти на родственный веб-сайт Gamasutra.

Несмотря на то что эта глава посвящена Интернет-ресурсам для разработчиков и дизайнеров игр, мы не можем не упомянуть традиционный журнал Game Developer, ибо убеждены: его подшивка должна стать настольной книгой как у новичка индустрии, так и у ее ветерана. (Приводится с разрешения Алекса Данна.)

Game Developer Resourcium

www.resourcium.com

С момента своего появления в 1996 году веб-сайт Resourcium предлагает тысячам разработчиков игр, любителям и профессионалам, обзоры и ссылки на самые лучшие источники информации, какие только доступны в Интернете. Он выглядит и работает как стандартный поисковый узел с каталогом и полем для ввода ключевых слов.

Game Development (поисковый узел)

www.game-developer.com

Этот веб-сайт является отличной поисковой программой и каталогом со ссылками на множество ресурсов, предназначенных для разработчиков игр. Здесь можно найти новости, статьи, интервью, исходные тексты программ, графические приложения и многое, многое другое. Посетители могут либо воспользоваться окном запроса и ввести ключевое слово для поиска, либо выбрать каталог по интересам и оттуда просматривать нужные им веб-сайты. Внушительная конструкция!

Game Development Search Engine - это весьма удобный для использования веб-сайт, достойный того, чтобы занести его адрес на скрижали вашего компьютера. Посетители могут вести поиск по обширной базе данных, просматривая каталог или вводя ключевые слова. (Приводится с разрешения компании Dungeon Crawl Software.)

Gameslice

www.gameslice.com

Один из лучших «кулуарных» веб-сайтов для тех, кто хочет знать, что происходит в индустрии компьютерных игр. Его редактор Джефф Кейли (Geoff Keighley) держит руку на пульсе игрового бизнеса и с удовольствием потчует своих многочисленных читателей новостями, обзорами, впечатляющими передовицами, интервью со знаменитостями и сведениями о компаниях.

Gaming Insider

www.gaminginsider.com

Сплетни и пикантные слухи, имеющие отношение к игровой индустрии, в исполнении некоего BitchX, анонимного репортера с «ушками на макушке и острым языком наготове»! При чем здесь разработка игр? По сути, ни при чем, кроме того обстоятельства, что у вас есть возможность получить сомнительное удовольствие от созерцания ушатов грязи, выливаемых на кого-нибудь, кто, возможно, работает с вами рядом!

Happy Puppy: The Biz

http://happypuppy.com/biz/index.html

На исключительно популярном веб-сайте Happy Puppy существует страница, посвященная игровой индустрии. Здесь есть такие разделы, как «Кабинет разработчика» (Developer Den), «Компании, выпускающие игры» (Game Companies), «Списки вакансий» (Job Listings), «Объявления» (Classified) и проч. Основную часть этой страницы составляют сотни ссылок на другие источники информации о разработке, программировании, художественном оформлении и звуковом сопровождении игр.

I Have No Words and I Must Design

www.crossover.com/~costik/nowords.html

Эта хорошо написанная, и наводящая на размышления статья первоначально была опубликована в 1994 году в английском журнале Interactive Fantasy, посвященном ролевым играм. В очень длинном очерке анализируются игры и различные составляющие их разработки, включая такие темы, как цели, управление ресурсами, игровая символика и принятие решений. Есть также несколько предложений о том, как увеличить силу воздействия игры. Статья доступна в трех вариантах: на английском, японском и корейском языках.

Loony Games

www.loonygames.com

Один из новейших веб-сайтов, посвященных дизайну и разработке игр, Loony Games учрежден компанией Next Generation Online (www.next-generation.com), а выпускает и поддерживает его Blue's News (www.bluesnews.com), популярный веб-сайт, специализирующийся на экшен-играх.

Loony Games публикует как тематические статьи, так и постоянные колонки, авторами которых являются самые неординарные разработчики, программисты и художники. Вот названия нескольких материалов: «История условно-бесплатных игр» (The History of Shareware), «Что значит программировать для консоли Next-Generation» (What It's Really Like to Program for a Next-Generation Console), учебное пособие по ручной прорисовке текстуры... Как вы догадываетесь, это далеко не все!

Популярный электронный журнал Gamecenter (упомянутый в списке в конце этой главы) опубликовал серию из семи очерков под названием «101 совет по разработке игр: дизайн, начиная с первого полигона» (Game Design 101: Designing a Game from the Polygons Up). Запаситесь чашечкой кофе или стаканчиком чего-нибудь еще и направляйтесь на веб-сайт www.gamecenter.com/Features/Exclusives/Design.

Murphy's Rules

http://kovalic.com/Murphys/Murphys.html

Это нечто вроде «самого веселого домашнего кино» об игровой индустрии, здесь собраны всякие бессмыслицы и ошибки, найденные в компьютерных играх. Посетители могут прочесть историю этого веб-сайта, а потом сразу перейти к длиннющему списку игровых «глюков» (и пояснений к ним) или даже добавить что-нибудь свое. Там также есть юмористический мультфильм, посвященный некоторым наиболее запоминающимся ошибкам.

So, You Want to be a Computer Game Developer

www.makegames.com

Толково написанное и с умом скомпонованное Дианой Грубер (Diana Gruber) руководство, в котором шаг за шагом объясняется, как стать полноправным членом игрового сообщества, начиная с того, как надо подавать себя, как работать с другими людьми, и заканчивая объяснением сущности игровой индустрии. Много места посвящено тому, как лучше написать свою первую игру (да и последующие тоже), есть и список книг, которые помогут избежать некоторых творческих мучений при программировании.

Sweet Oblivion

www.sweetoblivion.com

Добро пожаловать на сайт с «наиболее полной информацией о разработке игр»! Этот содержательный веб-сайт предлагает все самое свежее и важное в области разработки игр, включая ежедневные новости, тематические статьи, семинар по разработке, множество файлов для загрузки, сетевой магазин и ссылки на другие заслуживающие внимания Интернет-ресурсы. Цель этого веб-сайта - стать «хранилищем абсолютно всей информации, необходимой целеустремленным программистам и разработчикам игр». Явно стоит посетить его прямо сейчас.

Ultimate Gaming Resource - Company Directory

www.ugr.net/listings/listings.htm

Здесь в алфавитном порядке перечислены сотни компаний-разработчиков и издателей компьютерных и видеоигр. Все записи содержат ссылки на официальные страницы, к тому же на многих из них указаны номера телефонов, почтовые адреса и адреса электронной почты (собирающиеся послать резюме или образец своей работы, это для вас!). Эта страница точно заслуживает своей закладки.

Прочие важные электронные издания, посвященные играм

Ниже в алфавитном порядке перечислены некоторые наиболее важные электронные издания, посвященные играм для ПК и приставок.

• Adrenaline Vault www.avault.com

• All Games Network www.allgames.com

• Computer Games Online www.cdmag.com

• Computer Gaming World www.gamespot.com/cgw

• Console Domain www.consoledomain.com

• Future Games Network www.futuregames.net

• Game Revolution www.game-revolution.com

• Gamecenter www.gamecenter.com

• Game Pen www.gamepen.com

• GamePower www.gamepower.com

• Game Pro www.gamepro.com

• Games Domain www.gamesdomain.com

• Gamesmania www.gamesmania.com

• Gamespot U.K. www.gamespot.co.uk

• Gamespot www.gamespot.com

• Gamestats www.gamestats.com

• Happy Puppy www.happypuppy.com

• Imagine Games Network www.imaginegames.com

• Meccaworld www.meccaworld.com

• Next Generation www.next-generation.com

• Online Gaming Review www.ogr.com

• PC Gamer www.pcgamer.com

• PC Games www.pcgames.com

• PC Multimedia & Entertainment www.pcme.com

• UGO Alliance www.ugo.com

• Videogames.com www.videogames.com

• Fastest Gaming News Online www.fgnonline.com

• Electric Playground www.elecplay.com

Робин Уорд (Robin Ward), GameSlice/Game Design

Робин Уорд - редактор страницы Game Design на веб-сайте GameSlice, пишущий также для других веб-сайтов, в том числе для Gamasutra. Он рассказал нам, что предлагает посетителям его Game Design, и поделился своими мыслями об Интернете как о среде общения для начинающих разработчиков.

Давным-давно я организовал веб-сайт, посвященный созданию игр и называвшийся videogamedesign.com. Несмотря на присутствовавшее в названии слово «видео», он имел дело со всеми аспектами создания компьютерных игр. Его изюминкой были интервью с выдающимися дизайнерами игр, программистами и художниками, причем вовсе не с вопросами типа «А какое ваше самое любимое блюдо?»: разговор шел о балансе в играх, дизайне и о том, как найти работу в нашей индустрии.

Нет необходимости говорить, как нужна была тогда такого рода информация. Веб-сайт посещало приличное количество людей. Впоследствии, когда обновление информации несколько замедлилось из-за моих личных трудностей, редактор GameSlice Джефф Кейли (Geoff Keighley) предложил мне сделать мой веб-сайт частью GameSlice.com. Таким образом, теперь он доступен по адресу: www.gameslice.com/vgd. Сохранены все старые интервью и статьи; само собой, время от времени к ним прибавляются новые материалы. Есть у нас и список часто задаваемых вопросов, из которого вы сможете узнать, где научиться созданию игр и т.п.

Игровая индустрия привлекает множество людей, но лишь немногие на самом деле знают, как делаются игры. Вот почему, когда мы берем интервью у дизайнеров, программистов, музыкантов и художников, обязательно задаем им те вопросы, которые больше всего интересуют наших посетителей: «Как устроиться на работу в вашу компанию?», «Разработка игр - это искусство?» и т.д. и т.п. Таким образом, вместо публикации материалов, скажем, об источниках освещения или числе игроков в сетевой версии самой последней игры мы рассматриваем вопросы, связанные с созданием игр. И люди действительно считают, что от этого гораздо больше пользы.

А еще мы стараемся отвечать на каждое письмо. Я, конечно, не могу гарантировать, что ответы даются на абсолютно все письма (так не бывает), но подавляющее большинство написавших остаются довольны общением с нами: мы стараемся отвечать настолько полно, насколько это возможно.

Какую именно информацию смогут найти посетители сайта Game Design?

По-видимому, их больше всего заинтересуют ответы на вопросы о том, как приступить к разработке игр. На свете есть много людей, желающих заниматься играми, но понять, как обычные обыватели становятся выдающимися разработчиками, не так-то просто.

«Мы сможем рассказать вам, как добились успеха некоторые из ведущих разработчиков, как лучше всего начинать в этом бизнесе, как вести дела в дальнейшем», - заметил в заключение Робин Уорд.

Рик Вандерворн (Rick Vandervoorn), GameJobs.com

Один из издателей CyberActive Media Group Рик Вандерворн рассказывает нам о веб-сайте GameJobs.com и его предназначении.

Сайт GameJobs.com (www.gamejobs.com) - это полный список компаний, занимающихся видеоиграми, со ссылками непосредственно на страницы их отделов кадров. Ту же самую информацию вы, кстати, можете найти в традиционном (бумажном) журнале GameWEEK, сетевым вариантом которого мы частично являемся. Наша задача - сделать GameJobs.com полнофункциональной интерактивной базой данных вакансий в игровой индустрии и других высокотехнологичных отраслях.

Рик считает, что Интернет несколько изменил положение начинающих разработчиков.

Во-первых, стало легче поступить на работу, если вы к этому стремитесь. Предоставляя услуги, подобные тем, что оказывает наш сайт, Интернет устраняет информационные барьеры между новичками и уже добившимися успеха разработчиками и издателями. По сути, Интернет сегодня выступает в роли этакого общественного издателя: вы демонстрируете здесь свои работы, и вас в конечном итоге замечают.

Во-вторых, Интернет облегчает положение тех начинающих разработчиков, которые либо не могут поступить на работу в компанию (хотя бы в силу географических причин), либо хотят разрабатывать что-нибудь свое, чтобы затем самостоятельно продвигать созданное на рынок. И опять Сеть выступает в качестве витрины для разработчика, желающего продавать свою игру по всему миру. С появлением возможности прямой продажи и распространения игр через Интернет организация розничной торговли больше не обязательна.


Важнейшие мероприятия, организации и награды

Глава 25

Важнейшие мероприятия, организации и награды

Мы уже не раз говорили о том, что информационная революция, которую переживает мир, делает возможными совершенно немыслимые ранее вещи: доступность файлов практически любых размеров через Интернет и относительная дешевизна услуг по срочной доставке корреспонденции практически не оставили причин, по которым программисты, художники и музыканты, работающие над игрой, обязаны сидеть в одной комнате, хотя, конечно, у такого, традиционного, способа организации работы есть явные преимущества.

Однако если вы намерены устроиться в компанию-разработчик, или пытаетесь продать свою игру издателю, или же просто хотите посмотреть, что там поделывают ваши конкуренты, то вам настоятельно рекомендуется выбраться в свет и поприветствовать игровое сообщество во плоти. И впрямь, вспомните, сколько раз авторы этой книги, разработчики со всего света, говорили о необходимости частых встреч лицом к лицу! Вот почему первая половина этой главы посвящена самым важным событиям индустрии, ее конференциям и выставкам. Каждый нижеследующий параграф - это довольно подробный рассказ о каком-нибудь мероприятии и его целях, со ссылкой на его официальный веб-сайт. Во второй части главы перечисляется ряд важнейших организаций игровой индустрии, в которые вы, возможно, захотите вступить, включая всевозможные академии и ассоциации, связанные с различными областями нашей любимой отрасли.

Конференции и выставки

Выставка электронных развлечений (E3)

Выставка электронных развлечений (Electronic Entertainment Expo, E3) является самым большим и самым экстравагантным событием игровой индустрии. В 1999 году, когда это ежегодное событие проводилось в пятый раз, E3 собрала около пятидесяти тысяч человек, связанных с компьютерными и консольными играми и образовательными программами. Но E3, как вы уже догадались, это не просто несколько фирм, собравшихся под одной крышей, чтобы продемонстрировать свое новейшее ПО и оборудование для игр средствам массовой информации и розничным торговцам. В первую очередь это место для обмена информацией на совещаниях и семинарах, которые проводят самые выдающиеся представители игровой индустрии. E3 организуется исключительно для профессионалов, поэтому сюда допускаются лишь работающие в отрасли специалисты.

Незабываемое феерическое зрелище! Музыка со всех сторон; сетевые турниры по компьютерным играм, демонстрирующиеся на 13-метровых мониторах; изобилие знаменитостей; множество персонажей компьютерных и видеоигр, расхаживающих по залам; вечерние концерты знаменитых групп, организованные такими компаниями, как Sony, Nintendo, Eidos Interactive...

Обычно это мероприятие проводится в конце мая каждого года. Первые два года выставка проходила в Лос-Анджелесе, затем на два года переехала в Атланту, а в 1999 году вновь вернулась в Лос-Анджелес. Для получения более подробной информации о E3 посетите веб-сайт www.e3expo.com, а также обязательно загляните на www.e3.net и www.e3daily.com.

Конференция разработчиков игр (GDC)

Еще одно очень важное событие, на которое разработчикам стоит обратить внимание, - это Конференция разработчиков игр (Game Developers Conference, GDC). Она проводится каждый год в конце зимы или в начале весны. На этой конференции обсуждается все, что имеет отношение к игровой индустрии: программирование, художественное оформление игр, их звуковое и музыкальное сопровождение, производство, общие вопросы разработки и даже коммерческая и юридическая стороны игрового бизнеса.

Все четыре дня этого мероприятия насыщены тематическими докладами, учебными курсами и рабочими совещаниями, семинарами, присуждением наград и экспозициями. Так, в 1999 году на конференции выступали: Брайан Фарго (Brian Fargo) из компании Interplay с докладом «Пятнадцать лет выживания на фронтах войны» («Surviving 15 on the Frontlines of the War»), Берни Столар (Bernie Stolar) из компании Sega - «Переориентация направления разработки игр и оборудования в процессе эволюции» («Redefining Game and Hardware Development through Evolution»), Томми Талларико (Tommy Tallarico) - «Музыка в видеоиграх: искусство ведения дел» («Music in Video Games: The Art of the Deal») и многие, многие другие. Адрес официального веб-сайта этой конференции: www.gdconf.com.

В 1999 году в рамках Конференции разработчиков были проведены еще одна конференция и фестиваль. Читайте о них ниже...

GAMEXecutive

Самая первая конференция по вопросам игрового бизнеса, названная GAMEXecutive, состоялась в 1999 году в рамках Конференции разработчиков игр (Game Developers Conference). Это двухдневное мероприятие для высшего руководства компаний, аналитиков, должностных лиц, ответственных за маркетинг, продажу, распространение, розничную торговлю и финансы, инвесторов и всех прочих, связанных с коммерческой стороной индустрии интерактивных развлечений с ее миллиардными оборотами. Во время этого мероприятия специалисты игровой индустрии обсуждают и анализируют статистику и многообразие тенденций производства и продажи программного и технического обеспечения для ПК и игровых приставок. Полный список докладчиков и тем их выступлений можно найти на веб-сайте www.gamexecutive.com.

Фестиваль независимых игр

Вторым дополнением к ежегодной Конференции разработчиков игр стал Фестиваль независимых игр (Independent Games Festival), организованный известной вам по главе 22 компанией Gathering of Developers. Фестиваль предназначен для того, чтобы помочь развитию интерактивных развлечений как одной из форм искусства и предоставить независимым разработчикам игр со всего света возможность публично показать свои работы, получить известность и встретиться с потенциальными издателями и дистрибьюторами.

Независимые разработчики могут побороться здесь за призы и возможность принятия их игр к рассмотрению экспертным советом Gathering of Developers для последующего издания. Игры делятся на категории в зависимости от платформы, для которой созданы: ПК, «Макинтош», Sony PlayStation, Nintendo и онлайновые игры. Помимо Гран-при предусмотрены награды за техническое совершенство, за художественное оформление, звуковое сопровождение и дизайн, а также приз зрительских симпатий. Информацию о Фестивале, его правилах и о том, как принять в нем участие, можно получить по адресу: www.indiegames.com.

Может быть, это ответ игровой индустрии на знаменитый голливудский Sundance Film Festival?

Торговая ярмарка электронных продуктов (ECTS)

ECTS (Electronic Consumer Trade Show) считается ведущим европейским мероприятием для специалистов по компьютерным и видеоиграм. Ярмарка проводится каждую осень, в начале сентября в Лондоне. Разработчики и издатели игр из Европы и со всего мира демонстрируют свои лучшие продукты (программное и техническое обеспечение), предназначенные к выпуску в четвертом квартале текущего года и в новом году. Как и E3, ECTS представляет собой захватывающую демонстрацию профессиональных достижений, предназначенную только для специалистов. Правда, в отличие от E3, у нее гораздо меньший размах - менее двух тысяч участников. На ECTS проходит церемония награждения лучших продуктов индустрии интерактивных развлечений по итогам года. Для получения более подробной информации посетите веб-сайт www.ects.com.

Milia Games

Milia, или Международная ярмарка интерактивных продуктов, ежегодно проводится в Каннах (Франция) и, разумеется, тоже представляет собой весьма захватывающее зрелище. В 1999 году в рамках Milia начала работу отдельная секция, посвященная исключительно игровой индустрии и названная Milia Games. Показы новых игр, информация о еще не законченных проектах, доклады и конференции по основным вопросам, а также церемония награждения от Milia Games - вот далеко не полный перечень событий этой выставки-ярмарки. Есть здесь и день разработчика, в котором участвуют сотни независимых программистов, художников, звукоинженеров и сценаристов, приглашенных со всего мира. Короче говоря, это мероприятие предназначено для того, чтобы доставить удовольствие всем, кто имеет отношение к игровой индустрии, в том числе разработчикам, издателям и распространителям. Более подробная информация об этом мероприятии находится по адресу: www.milia.com.

SIGGRAPH

SIGGRAPH - одна из самых важных ежегодных конференций, предназначенных для художников и аниматоров, работающих с компьютерной графикой. Ее главная цель - способствовать развитию «теории, дизайна, разработки, воплощения и применения компьютерной графики и интерактивных методик для облегчения общения и взаимопонимания». В рамках этого трехдневного мероприятия проходят десятки совещаний и семинаров, выставки компаний, производящих программное и техническое обеспечение, а также ярмарка вакансий для специалистов по компьютерной графике, стремящихся найти лучшее место работы. Чтобы узнать побольше о SIGGRAPH как организации и ежегодной конференции, посетите веб-сайт www.siggraph.org.

GamesCon

Как вы помните, выставки E3 и ECTS предназначены только для специалистов игровой индустрии, а для рядовых игроков существует GamesCon, «путешествующая E3», которая обычно устраивается раз в квартал в крупных городах на севере США. GamesCon состоит из трех частей, каждой из которых отведено по одному дню: демонстрация готовящихся к выпуску игр и технического обеспечения; одновременная игра по локальной сети сотен игроков, борющихся за призы; и рабочие совещания и семинары, которые проводят ведущие специалисты игровой индустрии. Официальный веб-сайт GamesCon находится по адресу: www.gamescon.com.

GenCon

GenCon - конференция для поклонников ролевых игр, которая проводится каждый год в городе Милуоки (США). Нам так и не удалось выяснить, есть ли у GenCon официальный веб-сайт и где его найти. Материалы уже прошедших конференций доступны на веб-сайте www.evilgeniuses.org/gaming/archive/index.html.

Comdex, CES, MacWorld Expo...

Наконец, разработчику стоит, пожалуй, обратить внимание на выставку Comdex (www.comdex.com), Выставку бытовой электроники (Consumer Electronics Show, www.cesweb.org), выставку MacWorld Expo и различные международные ярмарки игрушек. Они не имеют такого большого значения, как E3, GDC или ECTS, но и там можно увидеть что-нибудь, что натолкнет на вдохновляющую идею, или установить ценные контакты с другими специалистами индустрии.

Премия Flights of Fantasy Awards существует с 1995 года. Ее награды присуждаются выдающимся (проявившим «Полет фантазии»!) играм для ПК и игровых приставок в следующих номинациях: художественное оформление (или просто «графика»), текстурирование/освещение, сценарий, новаторство, дизайн персонажа, анимация персонажа, лучшая рекламная кампания по продвижению на рынок, музыкальное оформление, звуковое сопровождение и т.д. Обязательно посетите веб-сайт www.flightsoffantasy.com, где вы сможете ознакомиться с полным списком номинаций и победителей за несколько прошлых лет.

Организации

Академия интерактивных искусств и наук (AIAS)

Академия интерактивных искусств и наук (Academy of Interactive Arts and Sciences, AIAS) была основана в 1996 году как некоммерческая организация, ставящая своей целью развитие и популяризацию интерактивных наук и искусств. Как следует из опубликованного на веб-сайте устава Академии, ее официальное предназначение заключается в следующем:

• Способствовать развитию всемирного сообщества специалистов по интерактивным технологиям и содействовать его интересам.

• Отмечать выдающиеся достижения в создании интерактивных продуктов.

• Проводить ежегодные церемонии присуждения наград, повышать престиж и известность интерактивных искусств и наук.

Упомянутые выше ежегодные церемонии награждения проводятся в рамках выставки E3. Если вы хотите получить информацию о правилах приема в члены Академии, новостях, мероприятиях и лауреатах, посетите веб-сайт Академии www.interactive.org.

Международная ассоциация разработчиков игр (IGDN)

Международная ассоциация разработчиков игр (International Game Developers Network, IGDN) представляет собой некоммерческую организацию сообщества разработчиков. Ее главное предназначение - «быть для своих членов источником такой помощи, которую нелегко найти где-нибудь еще». Например, помочь с поиском, в случае необходимости, людей или денег для выполнения какой-либо работы, издателя, юриста, программного или технического обеспечения. Эта организация публикует информационный бюллетень и, чтобы собирать вместе разработчиков, организует для них конференции. Адрес ее официального веб-сайта: www.igdn.org.

Ассоциация индустрии программного обеспечения и информации (SIIA)

Ассоциация издателей программного обеспечения (Software Publishers Association, SPA) и Ассоциация информационной индустрии (Information Industry Association, IIA) слились 1 января 1999 года, образовав новое профессиональное объединение - Ассоциацию индустрии программного обеспечения и информации (Software and Information Industry Association, SIIA). О своем предназначении Ассоциация заявляет, в частности, следующее:

...объединить индустрии программного обеспечения и информации в мощный глобальный консорциум. Это объединение программ и содержания обеспечит невиданные доселе возможности для продвижения интересов индустрии, развития бизнеса, проведения исследований и получения образования для примерно полутора тысяч компаний-членов Ассоциации.

Усилия SIIA направлены на борьбу с нарушением авторских прав, поиск поддержки у государства, реализацию многих других программ, помощь в издании, организацию конференций и симпозиумов, а также награждение отличившихся призами. О двух наградах Ассоциации рассказано ниже. (За более подробной информацией о SIIA обратитесь на веб-сайт www.siia.net.)

Награды за лучшие программы (Codie Awards)

Это одна из самых старых ежегодных церемоний награждения в индустрии программного обеспечения. Награды присуждаются по тридцати девяти номинациям, объединенным в несколько групп в зависимости от предназначения ПО: общего назначения, сетевое, для крупных предприятий, деловое, потребительское, игровое и образовательное. В категории «игры» присуждаются награды по следующим номинациям: лучшая новая приключенческая/ролевая игра, лучшая аркада/экшен-игра, лучшая спортивная игра, лучшая стратегия и лучший симулятор, а также лучшая онлайновая многопользовательская игра. Чтобы ознакомиться с правилами и победителями прошлых лет, посетите веб-сайт www.siia.net/conf/codieawards/.

Награды за успешный маркетинг

Здесь награды присуждаются по двум номинациям: за лучшее внешнее оформление программного обеспечения и приз Immy за самую успешную маркетинговую кампанию. С подробностями можно ознакомиться на веб-сайте www.siia.net/conf/marketawards.htm.

Ассоциация художников компьютерных игр

Ассоциация художников компьютерных игр (Computer Game Artists Association), членами которой являются физические лица, существует в форме сообщества художников компьютерных игр, которые, таким образом, взаимодействуют и делятся друг с другом и со своей индустрией мнениями и информацией, учат друг друга и учатся друг у друга, а также влияют друг на друга и на свою индустрию. Что это за сообщество и как оно работает, более подробно можно узнать по адресу: www.vectorg.com/cga.

Ассоциация интерактивного компьютерного программного обеспечения (IDSA)

Образованная в 1994 году Ассоциация интерактивного компьютерного программного обеспечения (Interactive Digital Software Association, IDSA) является единственной американской организацией, предназначенной исключительно для обслуживания коммерческих и общественных интересов компаний, которые издают компьютерные и консольные игры. В настоящее время доля членов IDSA в издании развлекательного ПО на территории США превышает 85%. Если коротко, IDSA предлагает издателям игр различные услуги, в том числе энергичную борьбу с компьютерным пиратством, лоббирование в правительстве, коммерческие исследования и исследования потребительского рынка, усилия по защите прав и интеллектуальной собственности. Адрес официального веб-сайта IDSA: www.idsa.com.

Ассоциация разработчиков компьютерных игр (CGDA)

CGDA (Computer Games Developers Association) служит интересам мирового сообщества разработчиков компьютерных игр, предлагая им ряд льгот и услуг. О льготах и о том, как стать членом этой ассоциации, вы узнаете по адресу: www.cgda.org.

Американская ассоциация искусственного интеллекта (AAAI)

Основанная двадцать лет назад, Американская ассоциация искусственного интеллекта (American Association of Artificial Intelligence) является некоммерческим обществом, нацеленным на развитие научного понимания механизмов, лежащих в основе мышления и разумного поведения, и их воплощение в технике. В ее задачи входит: популяризация искусственного интеллекта (ИИ), повышение уровня обучения и тренировки всех, кто работает с ИИ, и поиск путей финансирования ключевых исследований в этой области. Как отмечено на официальном веб-сайте Ассоциации (www.aaai.org), она предоставляет своим членам многие услуги, в том числе конференции, симпозиумы и рабочие встречи, издание специализированных журналов и т.д.

Совет по оценке развлекательных программ (ESRB)

Возможно, вы обращали внимание на наличие в уголке большинства коробок с компьютерными играми наклейки с надписью «ESRB» и указанием рекомендуемого возраста игроков. Совет по оценке развлекательных программ (Entertainment Software Rating Board) - это независимая организация, разработавшая при поддержке индустрии стандартизованную систему оценки развлекательного интерактивного программного обеспечения, а сейчас еще и веб-сайтов. Оценки ESRB предназначены для того, чтобы дать потребителю информацию о содержании развлекательного интерактивного видео- или компьютерного продукта и о том, для какого возраста он предназначен. Для получения более полных сведений, в том числе и о различных возрастных цензах, посетите веб-сайт www.esrb.com.

Ассоциация продавцов интерактивной развлекательной продукции (IEMA)

Эта некоммерческая организация (Interactive Entertainment Merchants Association) обслуживает коммерческие и общественные интересы розничных торговцев развлекательной продукции. Какие обязательства она на себя взяла? Помочь членам IEMA, занимающимся розничной торговлей и распространением, повысить их эффективность, живучесть и прибыльность, как на данный момент, так и в будущем. IEMA также организует собственную конференцию; официальный веб-сайт Ассоциации и конференции находится по адресу: www.theiema.org.

Консультативный совет по развлекательному программному обеспечению в Интернете (RSACi)

Эта некоммерческая организация (Recreational Software Advisory Council on the Internet) ставит своей целью информировать общественность о насилии и эротике в электронных СМИ «с помощью открытого и беспристрастного обсуждения их содержимого». Разработанная RSACi система обеспечивает потребителей, особенно обеспокоенных родителей, информацией о наличии секса, насилия и грубой речи (нецензурных ругательств и агрессивных выражений, мотивированных чувством ненависти) в компьютерных играх и на веб-сайтах. Узнать больше о RSACi вы сможете по адресу: www.rsac.org.

Европейская ассоциация издателей развлекательного программного обеспечения (ELSPA)

Эта организация (European Leisure Software Publishers Association) была основана в 1989 году, чтобы объединить членов европейской индустрии компьютерных и видеоигр. ELSPA занимается изданием и распространением интерактивного ПО для отдыха и развлечения, продвижением интересов всех своих членов, а также выступает по вопросам, волнующим всю индустрию в целом. Посетите веб-сайт www.elspa.com, чтобы узнать побольше об Ассоциации.

Проект Бар-Би-Кью (Project Bar-B-Q)

Эта ежегодная конференция, проводимая знакомым вам по главе 14 Джорджем «Толстяком» Сэнджером (George «The Fat Man» Sanger) при поддержке компании Cirrus Logic, служит для совместного обсуждения идей компьютерных музыкантов и звукоинженеров. Цель этого собрания - сближение и претворение в жизнь взглядов его участников на благо изготовителей, разработчиков и прежде всего потребителей компьютерных или аудиопродуктов. Адрес ее веб-сайта: www.fatman.com/bbq.htm.


Биографические справки

Приложение

Биографические справки

Вот мы и добрались до конца книги. Самое время рассказать немного о тех людях, чьи мудрые советы и составили этот внушительный том. Увы, не все мастера игровой индустрии смогли снабдить нас своими биографическими данными, но большинство из них в данном разделе все же представлено. Кто знает, быть может, однажды в такой же книге появится и ваше имя...

Арнлунд, Курт (Kurt Arnlund), Accolade

Последняя из выпущенных на сегодня игр Курта Арнлунда, программиста компании Accolade, - Slave Zero. Кроме того, на его счету такие хиты, как Mechwarrior 2: NetMech, Interstate '76, The Interstate '76 Arsenal, The Interstate '76 Nitro Pack и Heavy Gear 2.

Планы на будущее? Курт хотел бы иметь дело с такими проектами, которые не просто используют последние достижения компьютерной технологии, но позволяют игрокам пережить нечто новое, чего в реальности они никогда не испытывали. «Мне нравится брать то, что было использовано чуть ли не во всех предыдущих играх, и изобретать из этого нечто более захватывающее, чего никто никогда не видел», - говорит Курт. А еще ему хотелось бы принять участие в проекте, где он попробовал бы себя в собственно разработке, оставив на время свою основную профессию.

Бамгарднер, Чип (Chip Bumgardner), Interplay Productions

Чип Бамгарднер продюсировал множество игр, включая Chessmates, Lost Vikings 2, Earth 2140, Dragon Dice, MAX 2 и серию Caesar's Palace. Сейчас он работает над продолжением довольно известной стратегии Conquest of the New World, а также над играми Star Trek: New Worlds и Caesar's Palace II для ПК, Sony PlayStation и Dreamcast.

Бейли, Келли (Kelly Bailey), Valve Software

Сотрудник Valve Software Келли Бейли - ведущий разработчик, а также автор всех музыкальных и звуковых эффектов игры Half-Life, для которой он также написал программу, позволяющую персонажам говорить, и запрограммировал систему цифровой обработки звука для добавления эффектов эха и реверберации. Музыкальный опыт Келли включает в себя несколько лет работы (в качестве вокалиста, гитариста и композитора) в разных ансамблях Сиэтла (США). Несмотря на то что в первое время его функции в Valve были чисто инженерными, он вскоре представил руководству компании демонстрационный диск с пятью собственными музыкальными композициями, в результате чего и оказался ответственным за звуковое оформление Half-Life.

Бейтс, Боб (Bob Bates), Legend Entertainment

Боб Бейтс, глава студии Legend Entertainment, руководит ею вместе с Майком Вердю (Mike Verdu), своим партнером еще со времени основания Legend в 1989 году. Боб начал свою карьеру в 1986 году в компании Infocom, где он написал два текстовых квеста Sherlock! The Riddle of the Crown Jewels и Arthur: The Quest for Excalibur. За время работы в Legend он создал такие игры, как TIMEQUEST, Eric The Unready и John Saul's Blackstone Chronicles.

В качестве дизайнера, соавтора и продюсера Боб Бейтс принял участие в создании более 20 игр, завоевавших в общей сложности свыше 30 наград (к примеру, его игра Eric The Unready была названа «Лучшим квестом 1992 года»).

Бернал, Марк (Mark Bernal), Bungle Software

Марк Бернал, ведущий художник и художественный директор компании Bungie Software, работал над играми Myth 2: Soulblighter, Myth: The Fallen Lords и Marathon 2. В будущем он собирается продолжить создание столь же увлекательных и популярных игр, а также исследовать и развивать компьютерные игры как с технической, так и с творческой стороны.

Биссман, Эрик (Eric Biessman), Raven Software

Эрик Биссман, координатор проектов и ведущий разработчик компании Raven Software, принимал участие в создании игр Heretic: Shadows of the Serpent Riders, Hexen, Hexen: Death Kings of the Dark Citadel, CyClones, Hexen 2 и Heretic 2. Его проекты завоевали множество наград, в числе которых «Самый ценный продукт», «Лучшая условно-бесплатная игра» (за Heretic) и Spotlight Award (Spotty) от Ассоциации разработчиков компьютерных игр (Computer Games Developers Association). И еще одна очень характерная черта: игры Эрика традиционно высоко оцениваются как критиками, так и широкой публикой, что, согласитесь, и есть самая высшая награда для любого разработчика.

По словам Эрика, его будущее - это хорошие игры. «Если для этого мне нужно буде работать в той же должности, что и сейчас, - говорит Эрик Биссман, - что ж, хорошо! Если придется сменить специальность и стать, к примеру, продюсером, - тоже неплохо. В любом случае я намерен сделать карьеру именно в игровой индустрии и надеюсь работать долго и счастливо».

Блежински, Клифф (Cliff Bleszinski), Epic Games

Сейчас Клиффу Блежински 25 лет, начинал же он в индустрии семнадцатилетним, с квестов, хотя позже нашел себя в совершенно других жанрах - классических аркадах и сверхсовременных 3D-шутерах от первого лица. Так, в 1993 году Клифф создал знаменитую платформную аркаду Jazz Jackrabbit (ее продолжение, встреченное куда спокойнее, было выпущено на ПК спустя почти пять лет). Чуть позже он начал работу над 3D-шутером Unreal и вместе с ним буквально вошел в историю, настолько успешным и рубежным оказался этот проект. В Unreal Клифф отвечал за создание практически всех уровней игры, а также приложил руку ко всему проекту в целом. Пожалуй, больше всего он известен как авто нашумевшего видеоролика со Скааржем и жутковатого уровня Vortex Rikers (первого уровня игры), ставшего образцом захватывающей кинематики.

Ну а потом в счастливо складывающейся судьбе Клиффа был Unreal Tournament, сумевший составить достойную конкуренцию самому Quake III: Arena и названный большинством профессионалов лучшей игрой 1999 года.

 | В журнале Game.EXE (май-2000) эта фотография, сделанная на Конференции разработчиков игр 2000 года, была озаглавлена как «Вангер и Тетрис». Ни убавить ни прибавить! Справа от Кранка (K-D Lab) - автор тетриса Алексей Пажитнов, ныне сотрудник игрового отдела корпорации Microsoft. Еще раз повторяем: этот человек написал тетрис! (Фото из архива журнала Game.EXE.)
Ведущий разработчик лучшей экшен-стратегии 1998 года Тот Clancy's Rainbow Six (Red Storm Entertainment) Карл Шнурр (Carl Schnurr) на выставке E3 1999 года.. В руках - приз от журнала Game.EXE. (Фото из архива журнала Game.EXE.) |
 | Брайан Рейнольде (Brian Reynolds) в собственном кабинете. Снимок сделан в июне 1998 года во время посещения корреспондентом журнала Game.EXE компании Firaxis. (Фото из архива журнала Game.EXE.)

Бруссард, Джордж (George Broussard), 3D Realms

Джордж Бруссард - президент и совладелец 3D Realms. Именно здесь были созданы такие всемирно известные игры, как Terminal Velocity (разработчик Terminal Reality) и Duke Nukem 3D. Сейчас 3D Realms работает над игрой Duke Nukem Forever, а также принимает некоторое участие в проекте Max Payne (разработчик Remedy Entertainment). 3D-шутер Duke Nukem был перенесен почти на все игровые платформы, и сегодня компания активно продает лицензии на использование своего знаменитого героя в чужих играх, в основном консольных. Впрочем, в ближайших планах 3D Realms - разработка сразу двух 3D-игр для ПК (пока не объявленных) и расширение как самой компании, так и продажи лицензий.

Бэкман, Тед (Ted Backman), Valve Software

Художник и аниматор Тед Бэкман работал над игрой Half-Life, для которой сделал большинство ее невероятных монстров. Закончив этот звездный проект и получив положенную ему толику славы, Тед занимается сегодня созданием новых моделей. «Не так-то просто выбросить из головы то, что ты делал целых два года, и начать работу над новым проектом». Ночи напролет он рисует и просматривает уйму материалов, пытаясь внести новую струю в свое творчество. Тед надеется, что ему удастся создать множество увлекательных миров, неотразимых персонажей и захватывающих сюжетов, причем он не собирается ограничивать себя каким-то одним жанром.

Гоу, Чарльз (Charles Gough), Bungie Software

Чарльз «Чаки» Гоу - штатный программист чикагской компании Bungie Software Products, Inc. с января 1998 года (ради поступления сюда он оставил колледж). Однако программировать Чаки начал с девяти лет, когда отец научил его основам языка Applesoft Basic. Его тогдашняя боевая машина - старенький компьютер Apple IIe. По словам Чарльза, в число его прошлых творений входят «несколько незаконченных, но классных условно-бесплатных игрушек, которые оказались бы просто завалены наградами, если бы о них кто-нибудь узнал». Сейчас он работает над научно-фантастическим 3D-шутером Halo, который «ураганом распространится по планете и продвинет Bungie еще дальше по дороге мирового господства». Согласно последним метеорологическим сводкам, ураган запланирован на середину 2000 года.

Гримани, Марио (Mario Grimani), Ensemble Studios

Марио Гримани отвечает в компании Ensemble Studios за создание систем искусственного интеллекта. Он участвовал в разработке таких игр, как квест Monty Python and the Quest for the Holy Grail (7th Level) и стратегия Dominion: Storm Over Gift 3 (ION Storm). Его последнее творение - искусственный интеллект для популярной стратегии Age of Empires II: The Age of Kings. Свои планы на будущее Марио связывает только с созданием искусственного интеллекта для стратегий в реальном времени.

Грин, Марк (Mark A.C. Green), Psygnosis

Марк Грин отвечает за связь между отделами выпуска и разработки в студии Psygnosis в городе Лидс (Великобритания). До конца 1998 года он был ведущим разработчиком проекта Global Domination, теперь же больше занимается маркетингом, внося свой вклад во все игры, выпускаемые студией. Марк начал работу в игровой индустрии летом 1993 года в компании Lore Design, которая создавала игры для приставки Atari Jaguar (вскоре прекратившей свое существование). На ее счету игра Highlander, вторая игра для Jaguar, выпущенная на компакт-диске. В ней, кстати, впервые был применен оптический метод фиксации движений (см. о нем в главе 11). Компания была небольшой, так что Марк совмещал множество должностей, от тестера и дизайнера до специалиста по анализу движений персонажей и координатора проекта. На одном из этапов разработки он даже успел побывать в шкуре ученика программиста. Столь разнообразная подготовка, несомненно, помогла Марку овладеть искусством создания игр.

Вот что Марк Грин говорит о своих планах на будущее: «Мы все мечтаем о сказочной стране, где разработчикам будут давать столько времени, сколько они захотят. У каждого из нас свое представление об идеальной игре, и было бы прекрасно дождаться того времени, когда я смогу реализовать свои задумки».

 | Знаменитый Dark Reign (Activision) уже в прошлом, продюсировавший его Джош Резник (Josh Resnick), попавший в объектив Михаила Новикова на выставке E3 образца 1998 года, только что учредил собственную компанию Pandemic Studios. В ближайших планах первооткрывателя экшен-стратегий - Dark Reign II и Battlezone II. (Фото из архива журнала Game.EXE.)
Cuд «Наше все» Мейер. Июнь 1998 года, штаб-квартира компании Firaxis (Хаит Вэли, Мэриленд, США). (Фото из архива журнала Game.EXE.) |
 | Левелорд (Richard « The Levelord» Gray). В журнале Game. EXE очень любят этого открытого, всегда готового к общению человека, называя его за глаза «Наш Портос». Между тем «Портос», ведущий дизайнер Sin (Ritual Entertainment/Activision), сегодня занят, пожалуй, одной из самых ожидаемых игр 2000 года - 3D-шутером Heavy Metal: F.A.K.K.2 (Ritual Entertainment/G.O.D.), разрабатываемым на технологии Quake III. (Фото из архива журнала Game.EXE.)

Дезидерио, Вине (Vince Desiderio), Running With Scissors

Вине «Дези» Дезидерио - исполнительный директор студии Running With Scissors, первой разработкой которой стала нашумевшая игра Postal. Сегодня «Бегущие с ножницами» с тем же энтузиазмом трудятся над не менее «неортодоксальной» игрой Flesh & Wire. Postal вызвал бурю откликов и эпитетов, но самой ценной Вине считает вот такую характеристику: «худший продукт американского общества № 1». Ее автор - сенатор от штата Коннектикут Джозеф Лейберман. Не обошла Postal и награда «Лучшая упаковка» от Ассоциации издателей программных продуктов (SPA), хотя уже через месяц после выхода игра исчезла с полок всех крупных магазинов.

Джейкуэйз, Пол (Paul Jaquays), id Software

Пол Джейкуэйз - дизайнер уровней в компании id Software, его последний проект - Quake III: Arena. В числе наиболее заметных прошлых работ Пола - создание сценария и карт для игры Lord of the Rings I (Interplay), дизайн игры 4x4 Off Road Racing (Expx), редактор сценариев для Bard's Tale IV (EA). Полу принадлежит идея игры Wargames для домашних компьютеров ColecoVision и ADAM, разработкой которой он занимался вместе с Джо Анджолилло (Joe Angiolillo). Он также участвовал в создании настольных аркад Рас-Man и Donkey Kong (Coleco).

Довольно долгое время Пол Джейкуэйз работал вне компьютерной индустрии: он был художником по обложкам и художественным директором в компании TSR, Inc. (издатель Dungeons & Dragons); независимым иллюстратором, разработчиком игр и редактором; директором по разработке продуктов в Penguin Products; директором по разработке игр в Coleco Industries, Inc.; дизайнером игр и иллюстратором в Judges Guild.

В числе достойных упоминания проектов Пола назовем следующие ролевые игры: Dark Tower; Caverns of Thracia; Book of Treasure Maps I; Hellpits of Nightfang; Griffin Mountain, которую он создавал вместе с Руди Крафтом (Rudy Kraft) и Грегом Стаффордом (Greg Stafford); The Savage Frontier, The Shattered Statue. Ему принадлежит идея книжной серии Central Casting по созданию персонажей (Пол является автором первых трех книг этой серии). Пол был продюсером серии книг City Books 4-6 для компании Flying Buffalo, Inc. Кроме того, он занимался разработкой настольной игры Marvel Super Heroes для TSR (все значки на кубиках - его работа), иллюстрировал множество приключенческих игр и создал художественное оформление игры Dragon Dice. Он же осуществлял руководство при разработке всех игр компании Coleco, кроме образовательных.

Дальнейшие планы? Продолжать получать удовольствие от создания новых игр!

Джексон, Аллен (Allen Jackson), Origin Systems

Аллеи Джексон - инженер по программному обеспечению в компании Origin Systems. Он участвовал в работе над рядом экшен-игр и космических симуляторов: Crusader: No Remorse, Crusader: No Regret, Wing Commander Prophecy и Wing Commander Prophecy: Secret Ops. Его основное занятие - высокоуровневое программирование игр, включая разработку интерфейса, приложений Win32 GUI, игровых объектов и сетевых режимов.

Дженсен, Джейн (Jane Jensen), Sierra On-Line

Джейн Дженсен, автор многочисленных квестов, отмеченных самыми разнообразными престижными наградами, работает в компании Sierra On-Line. Вместе со своими коллегами она участвовала в разработке игр EcoQuest: Search for Cetus и King's Quest VI, а затем, создав серию Gabriel Knight, стала ее ведущим разработчиком и выпустила три части этого проекта: Sins of the Fathers, The Beast Within и Blood of the Sacred, Blood of the Damned. По мотивам этой серии Джейн написала и опубликовала две повести: Gabriel Knight: Sins of the Fathers и Gabriel Knight: The Beast Within. Осенью 1999 года в издательстве Del Rey была выпущена ее книга Millennium Rising, а в конце 2000 года ожидается выход следующей. В отличие от ее предыдущих книг, это абсолютно самостоятельные произведения, не основанные на компьютерных играх.

В дальнейшем Джейн собирается продолжить заниматься как играми, так и книгами. Правда, в области игр ей хотелось бы остановиться на более творческой работе, а именно общем дизайне, проработке сюжета и основных сцен, отказавшись от воплощения конкретных деталей игры. Она считает, что ежедневное кропотливое сидение над программой - это явно не то, на что она хотела бы тратить силы, и предпочитает уделять больше времени писательской деятельности.

 | Художник и основатель знаменитой id Software Кевин Клауд (Kevin Cloud), чье имя неоднократно встречалось вам на страницах этой книги, в свободное от работы время любит многочасовые прогулки на мотоцикле. Как истинный байкер и патриот своей страны, он предпочитает исключительно раритетные американские chopper-модели. (Фото из архива журнала Game. EXE.)
А вот Алекс Гарден (Alex Garden) из Relic Entertainment, автор великолепного Homeworld (Relic Entertainment/Sierra Studios), лучшей стратегии в реальном времени 1999 года, отдает предпочтение сверхскоростным японским гоночным мотоциклам. (Фото из архива журнала Game.EXE.) |
 | Выставка E3 '98, легендарный Ричард «Лорд Бритиш» Гэрриот (Richard «Lord British» Garriott) только что получил из рук Михаила Новикова (справа) приз журнала Game.EXE за свою Ultima Online (Origin Systems), лучшую онлайновую игру 1997 года. (Фото из архива журнала Game.EXE.)

Джонстон, Мэтью Ли (Matthew Lee Johnston), Microsoft Corp.

Мэтт Джонстон - ведущий аудиодизайнер корпорации Microsoft. Еще подростком он увлекся музыкой и вообще звуком. Обычно днем его можно было найти либо на полу в наушниках - наслаждающимся оттенками звучания альбома «Стена» группы Pink Floyd, либо на ближайшем дереве, где он пытался подслушать, как обмениваются новостями разные гавайские птички. Кроме того, многие часы он просиживал за играми на своем Atari 2600 либо ездил на велосипеде в «Fun Factory», чтобы поиграть в Crazy Climber, Cliffhanger, Astro Fighter или что-нибудь новенькое (разумеется, на деньги, стянутые из родительской копилки). Посмотрев в восьмом классе фильм Wargames, он безнадежно увлекся компьютерами. С помощью своего Apple IIе Мэтту удалось «прославиться» на весь мир благодаря компьютерному пиратству, искусству взлома телефонных сетей и нападению на электронные доски объявлений.

Родители неоднократно пытались объяснить Мэтту все трудности карьеры музыканта и настаивали, чтобы он выбрал для дальнейшей деятельности что-нибудь более надежное, вроде тех же компьютеров, которыми он так увлекался. В колледже он наткнулся на местечко под названием «лаборатория компьютерной музыки», где гармонично сочетались два из трех его хобби. Большую часть свободного от занятий времени он проводил либо в лаборатории, работая с синтезатором Buchla Modular или программой Sound Designer 1.0, либо на радиостанции KAOS в колледже, где был музыкальным директором. Возвращаясь в «мрачный дом», он и его товарищи по комнате занимались исключительно тем, что «пили, курили и старались «сделать» друг друга, играя на Genesis, NES или Atari 2600». Короче, вся его жизнь была просто идеальной подготовкой к его теперешнему положению штатного малолетнего преступника в компании Microsoft.

В Microsoft Мэтью Джонстон работал над проектами Flight Simulator 95 и 98, Microsoft Golf 2.0, 3.0, 98 и 99, 3D Movie Maker, Cinemania 96, Reader's Digest Complete Do-It-Yourself Guide, Monster Truck Madness 1 и 2, CART Precision Racing, Combat Flight Simulator 1.0 и MS Digital Phone.

Его планы на будущее включают в себя дальнейшую работу по нынешней специальности и сотрудничество с Лорин Хилл (Lauryn Hill) по части создания интерактивных музыкальных проектов.

Дорф, Барри (Barry Dorf), Electronic Arts

Начиная с 1998 года, Барри Дорф был помощником продюсера серии игр Madden Football, после чего перешел к работе над онлайновыми проектами. Он участвовал в разработке The Edge, а сейчас занимается созданием веб-сайтов для таких новых продуктов компании Electronic Arts, как Fantasy Football и Madden Football Interactive. Ранее Барри работал на телевидении (в Лос-Анджелесе), так что переход в ЕА стал для него дебютом в области видеоигр. Неплохо для начала.

Зук, Джон (Jon Zuk), Raven Software

Джон Зук из Raven Software участвовал в создании игры Take No Prisoners, а также был ведущим разработчиком проектов Hexen II: Portal of Praevus и Heretic II. Работа в Raven Software доставляет Джону много удовольствия, и он считает, что ему стоит остаться здесь надолго.

 | Ли Шелдон (Lee Sheldon), сценарист большинства квестов компании Southpeak Interactive. Снимок сделан в июне 1998 года в штаб-квартире Southpeak Interactive (Кэри, Северная Каролина, США). (Фото из архива журнала Game. EXE.)
Гейб Ньюэлл (Gabe Newell): До старта Half-Life (Valve/Sierra) два месяца, потерпите! Снимок сделан на выставке ECTS 1998 года. (Фото из архива журнала Game.EXE.) |
 | Гейбу Ньюэллу почти теми же словами вторит Фил Штейнмейер (Phil Steinmeyer) из РорТор Software: Дорогие! Railroad Tycoon II (Pop Top Software/G.O.D.) появится в ноябре! И вскоре, добавим мы от себя, станет лучшей «настоящей стратегией» 1998 года по версии журнала Game.EXE. Снимок сделан на выставке ECTS 1998 года. (Фото из архива журнала Game.EXE.)

Кан, Адам (Adam Kahn), Acclaim Entertainment

Адам Кан - сотрудник пресс-службы компании Acclaim Entertainment, в которой он работает с зимы 1998 года. До этого он был сотрудником специализированного пресс-агентства Shandwick International, где отвечал за продукты Microsoft Games.

Караккиоло, Кэрол (Carol Caracciolo), Acclaim Entertainment

Кэрол Караккиоло - менеджер по контролю качества в компании Acclaim, выпустившей Mortal Kombat II, Turok, Quarterback Club, All-Star Baseball, NBA Jam, WWF: Raw, WWF: Warzone, Alien Trilogy, Revolution Х и многие другие игры. Четыре с половиной года назад Кэрол создала в компании отдел контроля качества, в котором тогда состояло три человека. Сейчас под ее началом находятся семьдесят пять сотрудников, работающих в две смены семь дней в неделю.

Касл, Луис (Louis Castle), Westwood Studios

Луис Касл - вице-президент и соучредитель Westwood Studios. За последние 14 лет ему довелось работать над играми в качестве дизайнера, исполнительного продюсера, программиста, художника и художественного редактора. В 1994 году он перенес знаменитую аркаду Lion King на Super Nintendo, а в 1995-м устроил давку в Интернете при помощи игры Monopoly CD-ROM. В 1997 году Луис Касл выпустил Lands of Lore: Guardians of Destiny и Blade Runner, а сегодня занят продюсированием экшен-игры Command & Conquer: Renegade, создаваемой по мотивам одноименной «стратегической» вселенной. Подготовка Луиса в области живописи и компьютерных наук позволяет творениям Westwood выглядеть настоящими произведениями искусства, выделяя их на фоне проектов других компаний.

Кирк, Джефф (Geoff Kirk), Humongous Entertainment

Джефф Кирк, звукоинженер и программист звуковых эффектов в компании Humongous Entertainment, работал со многими играми, включая Pajama Sam, Putt-Putt Travels Through Time, Spy Fox, Freddi Fish 3, Pajama Sam 2, Putt-Putt Enters the Race и Freddi Fish 4. Он написал фоновую музыку к некоторым призовым уровням игры Pajama Sam's Lost and Found и тему «Happy Fun Sub» для игры Spy Fox. Джефф Кирк - в первую очередь композитор, так что он не считает обучение программированию звуковых эффектов критически важным.

Кое-чему из того, что пригодилось ему при работе в Humongous, Джефф научился еще в колледже. В частности, там он освоил «классическое» программирование синтезаторов на примере таких инструментов, как Arp 2600, постиг основы технологии звукозаписи, научился редактировать записи на магнитофонных лентах (в то время это делалось еще при помощи бритвы и клея). Тогда же он впервые попробовал закольцовывать куски пленки с записью ударников и прочих звуков и использовать их в различных композициях. Позднее, когда Джефф занимался сведением звука в компании Muzak, он так же часто делал небольшие закольцованные записи со всякой ерундой, что и помогло ему развить навыки работы со звуком. Примерно тогда же Джефф начал собирать у себя дома небольшую звукозаписывающую студию, осваивая сэмплирование, MIDI-технологии и различные типы цифровых синтезаторов. Он говорит, что самую лучшую подготовку к нынешней работе прошел в детстве, когда безостановочно смотрел мультфильмы, в особенности серию про Багз Банни компании Warner Brothers. «Использование музыки в этих мультфильмах по сей день можно считать новаторским и даже революционным. Фоновый звук в них опережает свое время и просто великолепен».

В будущем Джефф Кирк планирует усилить роль фонового музыкального сопровождения в играх и заняться игровыми проектами для взрослой аудитории.

Обложка 2-го номера журнала Game.EXE за 1997 год. Дедушка Мейер (Sid Meier) не так давно ушел из MicroProse, его новая компания Firaxis уже функционирует, но ее первая игра Sid Meier's Gettysburg! пока даже не объявлена. Наши корреспонденты, участвовавшие в ночном (в Москве было четыре утра!) чате с Сидом Мейером, как ни старались, так и не смогли тогда узнать название этой игры... |
 | Анналы гласят, что маленький Джон Ромеро (John Romero, на снимке в центре) проводил дни напролет, играя либо на аркадных, либо на игровых автоматах. Воспоминание о детстве - партия в соккер с друзьями после сдачи издателю Doom II. Слева - еще один герой этой книги Майк Уилсон (Mike Wilson) из G. О. D., как и Джон, работавший тогда в id Software. (Фото из архива журнала Game.EXE.)

Клауд, Кевин (Kevin Cloud), id Software

Кевин Клауд - художник компании id Software, а также ее совладелец вместе с Андрианом и Джоном Кармаками (Adrian, John Carmack). В id Software его работа началась со знаменитой игры Wolfenstein 3D, ставшей сегодня классической. До этого Кевин был дизайнером и редактором небольшого ежемесячного электронного журнала Softdisk, распространявшегося на компакт-дисках. Каждый выпуск журнала содержал пять-семь программ, несколько статей, редакционную колонку об игровой индустрии и т.д. Из-за бурного развития id Software несколько последних лет Кевин провел, совмещая сразу несколько должностей и активно участвуя в повседневной работе компании. Однако сегодня он пытается отложить в сторону эти заботы и как можно больше уделять внимания своей основной специальности.

Коалльер, Стивен (Steven Coallier), Electronic Arts

Стивен Коалльер является менеджером по программному обеспечению в компании-разработчике Scoreboard Productions, являющейся внутренней структурой Electronic Arts и располагающейся в Редвуд Шорз (США), там же, где и основная штаб-квартира ЕА.

Стивен начал свою карьеру простым тестером в Sierra On-Line, но вскоре стал программистом, занимаясь в основном переносом графических квестов на компьютеры Amiga. В ЕА его работа была намного разнообразней: он выпустил для ПК шутер от первого лица Shadowcaster, ставший, по сути, первой игрой на движке Doom; перенес на PlayStation знаменитый Wing Commander III и пару версий баскетбольного симулятора NCAA March Madness. Сейчас Стивен работает продолжением довольно известного симулятора бокса Knockout Kings: игра Knockout Kings 2000 выйдет одновременно на двух платформах - PlayStation и Nintendo 64.

Коберстин, Джо (Joe Koberstein), Raven Software

Художник компании Raven Software Джо Коберстин занимается компьютерными играми около шести лет и успел поработать в Калифорнии, Висконсине и даже в Японии. В настоящее время он создает игры, хотя ранее занимался также издательством, рекламой и маркетингом видеоигр. Вот некоторые этапы его пути: журнал видеоигр Gamefun, несколько филиалов Activision (Raven Software), маркетинговые группы Disney и Sony PlayStation (ASCII Entertainment), а также собственное агентство Kdesign.

Кокрейн, Брайс (Вгусе Cochrane), Electronic Arts

В свои 29 лет Брайс Кокрейн является ведущим художником серии игр NHL для ПК, PSX и Nintendo 64, издаваемой канадским отделением компании Electronic Arts. He ограничиваясь работой художника, он также занимается моделированием, анимацией, дизайном карт и даже тестированием. Брайс выпускал игры для всех мыслимых платформ: NES (Nintendo Entertainment System), Saturn, 3DO, Genesis, ПК, Nintendo 64 и других. Список его работ включает James Bond Junior, Terminator, Bob, Wayne's World, Crash Test Dummies, Ren and Stimpy's Videots, NHL All-Star Hockey, MTV Sports, Foes of All, Phoenix 3, Perfect Weapon, Triple Play 99, NHL 98, NHL 99 и NHL 2000.

Кориа, Николас (Nicholas Corea), Electronic Arts

Ник Кориа - художник и специалист по компьютерной графике в компании Electronic Arts. Его впечатляющий послужной список включает в себя игры Virtual Pinball (для этой игры он создал все художественное оформление), US Navy Fighters (наземные объекты, кабины, трехмерные модели и фрагменты интерфейса), Marine Fighters (ведущий художник, наземные объекты, кабины и трехмерные модели), US Navy Fighters 97(ведущий художник, некоторые трехмерные модели) и WWII Fighters (ведущий художник).

Еще подростком Ник хотел заниматься разработкой видеоигр и даже самостоятельно сделал несколько пинболов для Atari 800, воспользовавшись программой Bill Budge's Pinball Construction Set. В 1983 году он отправил свои программы в ЕА, сопроводив их просьбой взять его на работу. Вскоре он, по его словам, открыл для себя «девушек, скейт и компьютер Amiga 2000», а «брат друга того парня, который делал доски для серфинга» оказался художественным редактором отделения компании Disney, занимающегося видеоиграми. Словом, в 1991 году Ник начал работать по контракту художником над проектом Un-Natural Selection в студии Disney (Buena Vista Software) в Бурбанке (штат Калифорния, США). Работа заключалась в разработке обширного интерфейса и «пластилиновой» анимации. Позже продюсер этого проекта перешел в ЕА и предложил Нику поработать вместе с Биллом Баджем (Bill Budge) над новым пинболом для Sega Genesis (всего-то через десять лет после известного письма!). Через год Ник стал постоянным сотрудником ЕА. Как раз тогда для проекта US Navy Fighters потребовался 3D-художник, чем Ник и занялся, одновременно уделяя внимание почти всем сторонам художественного оформления проекта. Поэтому уже над следующей частью игры он работал как ведущий художник.

Игра World War II Fighters, законченная в конце 1998 года и очень высоко оцененная как прессой, так и игроками, стала для Ника хорошей возможностью сделать шаг вперед. По его словам, он надеется стать однажды художественным руководителем сразу нескольких проектов.

 | ECTS '97, не нуждающаяся в представлениях звезда индустрии и мать графических квестов Роберта Вильяме (Roberta Williams) была отслежена корреспондентами Game.EXE, с пристрастием допрошена в тесном помещении стенда компании Sierra On-Line и сфотографирована на долгую память. (Фото из архива журнала Game. EXE.)
Заслуженный работник индустрии, дизайнер-стахановец Пол Джейкуэйз (PaulJaquays) из id Software, стараниями которого сделана чуть ли не половина уровней Quake III: Arena (id Software'Activision), почти мгновенно откликнулся на просьбу журнала Game.EXE показать личико. Дело в том, что интервью с ним во 2-м номере 2000 года пошло с фотографией, на которой Пол сидел в полоборота к камере, и читатели забросали редакцию письмами: мол, хотим видеть лицо своего кумира! (Фото из архива журнала Game.EXE.) |
 | Стараниями этого человека потрясающий Half-Life (Valve/Sierra), без всякого сомнения, лучшая игра 1998 года, стал первым в истории жанра 3D-шутером от первого лица, обладающим столь мощным и захватывающим сюжетом. Писатель Марк Лейдлоу (Marc Laidlaw) собственной персоной. Вам не кажется, что он поразительно похож на главного героя своей игры? Или наоборот - это герой похож на своего автора? (Фото из архива журнала Game.EXE.)

Кук, Вэнс (Vance Cook), Sierra On-Line

Вэнс Кук занимается созданием симуляторов гольфа свыше десяти лет, можно даже сказать, что это дело его жизни. На протяжении шести лет он вместе с другими талантливыми разработчиками трудился в Access Software над несколькими проектами, в том числе над знаменитыми играми Links и Links386 Pro. Около семи лет назад он ушел из Access Software, чтобы осуществить, наконец, свою мечту о создании собственной фирмы, и основал компанию Headgate, Inc. После нескольких лет возни с деловыми программами Вэнс вернулся к разработке симуляторов гольфа и, в конце концов, продал свою фирму компании Sierra On-Line, в штате которой с удовольствием сейчас состоит.

Ланзингер, Франц (Franz Lanzinger), Actual Entertainment

Франц Ланзингер - руководитель компании Actual Entertainment. Он работал программистом и разработчиком игр в Atari Games Inc. и Tengen, откуда ушел в 1990 году, чтобы стать соучредителем компании Bitmasters. В апреле 1995 года он вместе с Марком Робичеком (Mark Robichek) и Эриком Гиннером (Eric Ginner) основал Actual Entertainment.

Будучи великолепным игроком, в 1981 году Франц, играя в аркаду Centipede, установил мировой рекорд, который продержался около шести месяцев. 19 сентября 1997 года принесло ему еще большую известность: в этот день веб-сайт Gamasutra наградил его титулом Geek of the Week! Ему присвоено пожизненное звание мастера бриджа, а в один из своих лучших дней он, играя в гольф, уложился в 90 ударов. Наконец, Франц Ланзингер всю жизнь занимается программированием и разработкой игр, на его счету несколько известных проектов: Crystal Castles (для игровых автоматов), Toobin (эту игру он перенес на NES), Ms. Рас Man (портирование на NES), Krazy Kreatures (самостоятельно написана для той же NES), Rampart (портирование на NES и SNES), Championship Pool (написана для SNES) и NCAA Final Four Basketball (то же самое).

Ларкин, Тим (Tim Larkin), Yosemite Entertainment

Во время создания этой книги Тим Ларкин был старшим звукоинженером закрытой ныне студии Yosemite Entertainment, являвшейся отделением Sierra On-Line. В Yosemite он работал над звуковым сопровождением для проекта Middle Earth (также закрытого) по книге Толкиена. Ранее Тим озвучивал заставку и видеовставки к игре Quest for Glory V. До Yosemite Entertainment Тим Ларкин работал в компании Broderbund, где был ведущим звукоинженером и создателем звукового сопровождения к игре Riven: The Sequel to Myst (звуковые эффекты для более 900 анимаций и видеовставок, плюс почти часовой интерактивный фоновый звук). В той же Broderbund Тим создал музыку и звуковые эффекты для игр Rugrats, Warbreeds, серии Carmen Sandiego и многих других. Еще раньше он занимался аналогичной работой для многочисленных телевизионных, рекламных, мультимедийных и бизнес-проектов.

 | Крис Тэйлор (Chris Taylor) времен начала работ над Total Annihilation (Cavedog Entertainment/GT Interactive), лучшей стратегией в реальном времени 1997 года по версии журнала Game.EXE и десятков других профессиональных изданий по всему миру. На другой день после выхода этой игры он проснулся знаменитым... (Фото из архива журнала Game.EXE.)
Обратите внимание на правую руку маэстро Тома Холла (Тот Hall), который скоро порадует нас своей супер-3D-РПГ Anachronox (ION Storm/Eidos Interactive): no словам самого Тома, он будет пускать ее вход всякий раз, как только услышит об Anachronox хоть что-нибудь плохое. Живописный рассказ Тома об операции по пересадке ему этой, с позволения сказать, «руки», к сожалению, не вошел в интервью с ним, опубликованное во 2-м номере Game. EXE за 2000 г., но это чистая правда! (Фото из архива журнала Game.EXE.) |
 | Счастливые, расслабленные и немного похудевшие, они только что закончили Sanitarium (Dreamforge/ASC Games). «Команда Sanitarium» - так они назвали себя в интервью журналу Game.EXE, которое было опубликовано в 8-м номере за 1998 г. Слева направо: Эрик Раис (Eric Rice), Трейси Смит (Tracy Smith), один из героев этой книги Чэд Фримен (Chad Freeman) и Майк Николсон (Mike Nicholson). (Фото из архива журнала Game.EXE.)

Левелорд, Ричард Бейли Грей (The Levelord, Richard Bailey Gray), Ritual Entertainment

Как следует из его биографии, Левелорд родился в Нью-Хейвене (штат Коннектикут, США). Отслужив в ВМС США (где плавал на подводных лодках), он окончил несколько высших учебных заведений, получив в результате дипломы программиста для бизнес-приложений и компьютерного инженера. Созданием игровых уровней Левелорд занимается с 1994 года.

На его счету более половины уровней Duke Nukem 3D (The Abyss, Incubator, Warp Factor, Spin Cycle, Lunatic Fringe, Raw Meat, Bank Roll, Flood Zone, L.A. Rumble, The Movie Set, Rabid Transit, Fahrenheit, Hotel Hell и Tier Drops). В последнюю версию Scourge of Armagon (набор дополнительных миссий к Quake II) вошли его уровни The Lost Mine, Research Facility, The Crypt, Tur Torment и The Edge of Oblivion.

На этом официальная биографическая справка кончается, однако мы знаем, что Левелорд перешел в Ritual Entertainment, где был ведущим дизайнером уровней игры Sin, изданной компанией Activision, а сейчас вовсю трудится над игрой Heavy Metall: F.A.K.K.2 (будет издана в 2000 году компанией Gathering of Developers).

Левески, Адам (Adam Levesque), Blue Fang Games

Президент Blue Fang Games Адам Левески ранее работал в компании Papyrus, специализирующейся на гоночных автомобильных симуляторах, где был 3D-художником игры IndyCar Racing, продюсером и разработчиком игр NASCAR Racing 1 и 2, исполнительным продюсером всех проектов Papyrus, а также директором одного из подразделений компании. Адам основал компанию Blue Fang Games, чтобы заняться другими игровыми жанрами. Сейчас он работает над стратегическо-ролевой игрой Dragon Hoard, ведущейся «от лица» дракона.

Лейдлоу, Марк (Marc Laidlaw), Valve Software

Марк Лейдлоу - писатель и разработчик игр компании Valve Software. Он отвечал за координацию группы создания уровней для игры Half-Life. Марк автор следующих книг: The 37th Mandala (за которую получил премию International Horror Guild Award в номинации «Лучший роман года» за 1996 год), Kalifornia, The Orchid Eater, Dad's Nuke, Neon Lotus и The Third Force: A Novel of Gadget. Свое будущее Марк видит в пограничной области между литературой и разработкой игр.

Линн, Билл (Bill Linn), Linn Public Relations, Inc.

Билл Линн - ветеран той области игровой индустрии, которая посвящена работе с прессой. До открытия собственного агентства в середине 1997 года Билл Линн семь лет проработал старшим советником пресс-службы в компаниях Sierra, The Imagination Network и Accolade, имея дело с множеством широко известных ныне продуктов: King's Quest, Leisure Suit Larry, Daryl Gates' Police Quest, Hardball, Jack Nicklaus Golf, Prince of Persia, Riven, Uprising, Warlords и Test Drive. В общей сложности Билл приложил руку к выпуску более сотни игр для приставок, ПК и Интернета. Прежде чем заняться играми, Билл Линн специализировался в организации любых кампаний, от политических выборов до концертов, а также успел поработать журналистом в нескольких крупнейших американских газетах.

Игрок в душе, Билл Линн объединяет в своей работе страсть к интерактивным развлечениям с профессиональными навыками и опытом. В детстве он играл во все мыслимые игры, от Pong и Coleco Football no M.U.L.E. и Leisure Suit Larry. Билл и сейчас уделяет немало времени играм на ПК, PlayStation, Nintendo 64 и аркадных автоматах.

В списке его клиентов - знаменитые компании-разработчики игр, в том числе Sierra, THQ, Broderbund, The 3DO Company и ASCII Entertainment.

 | 12 марта 2000 г., Сан-Хосе, Game Developers Conference, первая и, увы, последняя Конференция разработчиков для Шемуса Макнэлли (Seumas McNally) из Longbow Digital Arts. Только что его игра Tread Marks стала обладателем Гран-при Фестиваля независимых игр. Спустя 10 дней его не станет. Отныне Фестиваль будет носить имя Шемуса... (Фото из архива журнала Game.EXE.)
Питер Молиньё (Peter Molyneux) из Lionhead Studios, о котором можно сказать, только одно: гений, и автор краснознаменных «Аллодов», один из самых успешных и именитых российских разработчиков Сергеи Орловский (справа) из компании «Нивал». Март-2000, Конференция разработчиков игр. (Фото из архива журнала Game.EXE.) |
 | Глава Shiny Entertainment, автор Aladdin, Earthworm Jim, MDK u еще пары десятков блестящих игр Дэвид Перри (David Perry) только что закончил неповторимую Messiah. Фотография сделана на Конференции разработчиков игр 2000 г. (Фото из архива журнала Game.EXE.)

Лупиди, Тони (Tony Lupidi), Electronic Arts

Тони Лупиди - художественный директор Scoreboard Productions, внутреннего подразделения Electronic Arts. На его счету две игры: March Madness '98 и March Madness '99 - симуляторы баскетбольных чемпионатов колледжей для PlayStation. «С моей точки зрения, мы находимся на пороге возникновения нового интерактивного средства массовой информации. Причиной тому все ускоряющееся развитие технологии: появление новых графических плат, отображающих трехмерные объекты в реальном времени, широкополосных сетей (кабельных модемов массового применения), а также непрекращающаяся разработка все более быстрых и дешевых компьютеров, - говорит Тони. - Киноиндустрии уже более ста лет, там освоили успешный способ добывания денег, так что из этой области не стоит ожидать инициатив или даже идей по разработке чего-нибудь более интерактивного. Поэтому-то я и переключился с анимации для телевизионных программ и кинофильмов на работу над видеоиграми. В истории возникновения каждого нового средства общения всегда был период активных экспериментов, новых разработок и рискованных предприятий, прежде чем устанавливались общепринятые стандарты. Это как раз то потрясающее время, когда вы почти не связаны никакими ограничениями. Я хочу участвовать в этом переходе на новую ступень развития».

Льюис, Сьюзен (Susan Lewis), ThinkBIG

Сьюзен Льюис - президент агентства ThinkBIG, которое представляет и защищает интересы разработчиков и издателей игр. Сьюзен тесно сотрудничала с компаниями Electronic Arts, Acclaim, Fox Interactive, Atari Games и ВМС Interactive. На самом же деле она работала практически со всеми издателями, информация о ее агентстве публиковалась в журналах Wired, Game Developer, SF Chronicle, Gamecenter, Salon и Screen Magazine (Германия), а также появлялась в телевизионной программе TV.Com/CNET. Сьюзен выступала с докладами на выставке E3 в 1997 году («The Art of the Pitch» вместе с Брайаном Найдером (Bryan Neider), вице-президентом Electronic Arts) и Конференции разработчиков игр (GDC) в 1998 году («The Art of the Pitch» вместе с Эдом Зоно (Ed Zono), президентом компании Zono Games).

Лэнд, Майкл (Michael Land), LucasArts

Майкл Лэнд - руководитель отдела звукового сопровождения и член музыкальной команды компании LucasArts. Он участвовал в создании целого ряда популярных игр, завоевавших немало наград: The Dig, X-Wing, TIE Fighter, Indiana Jones and the Fate of Atlantis, Day of the Tentacle, а также всей серии Monkey Island. Его планы на будущее - «просто продолжать писать музыку».

Макграт, Майкл (Michael D. McGrath), Dynamix

Майкл Макграт - инженер-программист компании Dynamix, являющейся подразделением Sierra On-Line. Список его работ включает Netrek (свободно распространяемая программа), Extreme Warfare (Trilobyte) и Red Baron 3D (Dynamix). Во время создания этой книги он работал над авиасимуляторами Desert Fighters и Aces of the Pacific II, а в будущем Майкл планирует заново переписать Netrek и заняться разработкой научно-фантастических боевых летных симуляторов и стратегических игр.

Маккарт, Майкл (Michael McCart), Ensemble Studios

История того, как Майкл получил должность веб-мастера в компании Ensemble Studios, вполне может вдохновить любого игромана, хоть раз делавшего веб-сайт, посвященный любимой игре. Так вот, Майкл создал свой веб-сайт Age of Empires: Heaven и вскоре был замечен компанией Ensemble Studios, руководителям которой очень понравились его талант и увлеченность. Более подробный вариант этой истории можно найти в этой книге и наличной веб-странице Майкла по адресу: www.electrosonic.net.

Мейджерс-Гэбриел, Элен (Ellen Meijers-Gabriel), Oddworld Inhabitants

Композитор и звукорежиссер Элен Мейджерс-Гэбриел написала музыку и создала звуковые эффекты к знаменитым играм Oddworld: Abe's Oddysee и Oddworld: Abe's Exoddus, разработчиком которых является компания Oddworld Inhabitants.

Впервые Элен соприкоснулась с музыкой, когда ей было шесть лет (она жила в то время в Голландии). Она обучалась игре на фортепьяно около двенадцати лет до тех пор, пока не обнаружила, что из-за проблем с позвоночником не может больше нормально репетировать. Это автоматически означало, что ей придется расстаться с мечтой о карьере профессиональной пианистки и пересмотреть свои планы на будущее. И Элен, не хотевшая совсем бросать занятия музыкой, обратилась к тем ее областям, которые не требуют столь интенсивных физических нагрузок. Она начала изучать музыковедение, но еще до окончания курса поняла, что ее больше привлекает техническая сторона музыки, поэтому параллельно поступила в другую школу по этой специальности. Вскоре Элен сдала экзамены в Королевскую школу изящных искусств в Великобритании, где получила диплом специалиста по интерактивным средствам мультимедиа. Сразу же после выпуска ей предложили работать над играми в американской компании.

В дальнейшем Элен Мейджерс-Гэбриел собирается заняться созданием звукового сопровождения и музыки для художественного кино, а также продолжать исследования в области синтеза и преобразования звука «с нуля» (вместо того чтобы редактировать уже записанные звуки). Для этого она собирается использовать помимо прочего такие инструменты, как Кута, языки программной обработки звука (например MSP) и синтез физических моделей.

Мейер, Сид (Sid Meier), Firaxis Games

Сид Мейер - председатель и директор по развитию компании Firaxis Games. В описании карьеры «родоначальника индустрии компьютерных игр», как нередко называют Сида Мейера, бросается в глаза обилие слов «первый». В начале 80-х годов он создал первый симулятор воздушного боя F15 Strike Eagle, который разошелся тиражом более миллиона экземпляров. Его игра Silent Service стала первым симулятором подводной лодки. Новаторская игра Pirates!, уникальное творение, соединившее черты исторического симулятора, аркады, стратегии и ролевой игры, открыла дорогу огромному количеству новых жанров. F19 Stealth Fighter был первым авиасимулятором, сочетавшим в себе систему бесконечной генерации миссий, основу всех современных симуляторов, и элементы стратегии, что сделало его одним из самых популярных авиасимуляторов в истории. Наконец, такие игры Сида, как Railroad Tycoon и Civilization возвестили приход новой эры «симуляторов Бога», дав начало еще одному игровому жанру. Сид Мейер, обладатель всех мыслимых наград индустрии, и сегодня по-прежнему остается в числе ее лидеров.

Мейерс, Майкл (Michael Meyers), Acclaim Entertainment

Майкл Мейерс - руководитель пресс-службы компании Acclaim Entertainment. Он участвовал или руководил кампаниями по продвижению на рынок игр Turok: Dinosaur Hunter, Turok 2: Seeds of Evil, NFL Quarterback Club '98 и '99, All-Star Baseball, Extreme-G, NBA Jam '99, WWF: Warzone, Jeremy McGrath Supercross и многих других.

Миямото, Сигеру (Shigeru Miyamoto), Nintendo

Сигеру Миямото - директор-распорядитель отдела анализа и разработки развлекательного ПО в компании Nintendo Co. Ltd. (Киото, Япония). С 1981 года по настоящее время он создал более 50 игр, причем в большинстве из проектов Сигеру выступал в роли продюсера, но нередко был и директором или контролировал разработку. Вот эти игры в хронологическом порядке: Donkey Kong, Donkey Kong Jr., Mario Bros., Popeye, Super Mario Bros., Wild Gunman, Duck Hunt, Hogan's Alley, Excite Bike, The Legend of Zelda, Volley Ball, Super Mario Bros. 2, Zelda II- The Adventure of Link, Ice Hockey, Super Mario Bros. 3, Kirby's Adventure, Super Mario World, Pilot Wings, F-Zero, Sim City, The Legend of Zelda: A Link to the Past, Super Mario Kart, Star Fox, Super Mario All Stars, Stunt Race FX, Super Donkey Kong, Earth Bound, Kirby's Dream Course, Super Mario World 2, Yoshi's Island, Super Mario RPG, Kirby Super Star, Radar Mission, Kirby's Dream Land, Wave Race, The Legend of Zelda: Link's Awaking, Kirby's Pinball Land, Donkey Kong, Mario's Picross, Kirby's Dream Land 2, Kirby's Blackball, Mole Mania, Super Mario 64, Pilot Wings 64, Wave Race 64, Mario Kart 64, Star Fox 64, Yoshi's Story, 1080 Snowboarding, F-Zero X и The Legend of Zelda: Ocarina of Time.

В списке легенд игровой индустрии, составленном Академией интерактивных наук и искусств (Academy of Interactive Arts and Sciences) в 1998 году к выставке Electronic Entertainment Exposition (E3), имя господина Миямото занимало первую строчку. В его планах на будущее - создание новых увлекательных игр для Nintendo.

Моу, Ричард (Richard Мое), Humongous Entertainment

Ричард Моу - руководитель проектов в компании Humongous Entertainment. «Эта загадочная должность означает, что я занимаюсь разработкой, производством и вообще осуществлением проекта с начала до конца». Область, где Ричард действительно является экспертом, - программирование; все игры в компании Humongous пишутся на особом языке SCUMM, созданном одним из основателей компании Роном Гилбертом (Ron Gilbert). Вот некоторые из проектов, над которыми Ричард Моу работал в качестве программиста и разработчика: Junior Field Trips: Let's Explore the Airport, Pajama Sam in There's No Need to Hide When It's Dark Outside, Backyard Baseball и Putt-Putt Enters the Race.

Николе, Майк (Mike Nichols), Surreal Software

Майк Николе - вице-президент, основатель и художественный руководитель компании Surreal Software. Он начал работать в игровой индустрии примерно одиннадцать лет назад. Одним из его первых проектов стала игра NY Warriors для Amiga, игровых автоматов и ПК (в 1989 году не было ничего круче, чем CGA- и EGA-режимы). С тех пор он работал художником и дизайнером в нескольких компаниях, выпустив в общей сложности около двадцати игр. Последним местом работы Майка была компания Boss Game Studios, где он был ведущим разработчиком игры Spider для PlayStation.

Обязанности Майка Николса в Surreal включают в себя не только руководство художниками, но и стратегическое планирование будущего Surreal и проектов, которыми собирается заниматься компания. И при этом у него еще остается время на художественное оформление игр. Surreal - это в первую очередь компания-разработчик. У нее нет стремления во что бы то ни стало стать самой крупной компанией в индустрии. Планы Майка на будущее просты: «Напряженно работать, делая то, что мы все любим, - игры».

Ньюэлл, Гейб (Gabe Newell), Valve Software

Гейб Ньюэлл - исполнительный директор компании Valve Software (Киркленд, штат Вашингтон, США). Игра Half-Life, первый продукт компании, получила множество наград как лучшая игра года от традиционных и онлайновых журналов, а также приз «Лучшая игра для ПК» (от влиятельного объединения независимых сайтов UnderGroundOnline, UGO) на выставке E3 в 1998 году.

О'Коннор, Пол (Paul O'Connor), Oddworld Inhabitants

Ведущий дизайнер компании Oddworld Inhabitants Пол О'Коннор возглавлял проекты Oddworld: Abe's Oddysee и Oddworld: Abe's Exoddus для ПК и Sony PlayStation. Созданием всевозможных игр (компьютерных, видео-, настольных и ролевых) он занимается с 1981 года, работая то по контракту, то на постоянной основе. Наконец, в свое время Пол был даже сочинителем комиксов, работая для издательств Malibu и Marvel Comics.

 | Исключительно редкий, уникальный кадр: Cud Мейер (Sid Meier) с мамой. Фото, разумеется, Михаила Новикова. (Фото из архива журнала Game.EXE.)
Майк Уилсон (Mike Wilson, слева) и Гарри Миллер (Harry A. Miller), соответственно исполнительный директор и президент единственной и неповторимой Gathering of Developers, компании, которой в этой книге посвящена отдельная глава! Снимок сделан на выставке E3 1999 года, чью странную эмблему вы видите за спинами наших героев. (Фото из архива журнала Game.EXE.) |
 | Рик Гудман (Rick Goodman), один из отцов-основателей Ensemble Studios, сегодня работает над стратегией Empire Earth (и опять в названии игры слово «empire»!) в компании Stainless Steel Studios. Фото сделано на выставке E3 '2000. (Фото из архива журнала Game.EXE.)

Остергард, Женевьева (Genevieve Ostergard), Sierra Studios

Женевьева Остергард, руководитель пресс-службы компании Sierra Studios, занимается работой с прессой уже семь лет, из них пять последних лет непосредственно в игровой индустрии. Сначала она была помощником руководителя пресс-службы в компании Interplay, где ей поручили отделы MacPlay и приставок. Через полгода Женевьева сама стала полноправным руководителем и продолжила заниматься связями со СМИ в области игр для ПК и приставок. Покинув Interplay, Женевьева перешла в специализированное агентство по работе с прессой Shandwick, где отвечала за всю продукцию Microsoft Games.

До работы в игровой индустрии Женевьева была сотрудником пресс-службы издательства Ziff-Davis Press, подразделения по изданию книг в одном из самых процветающих издательств компьютерных журналов в мире.

Пардо, Роб (Rob Pardo), Blizzard Entertainment

Продюсер и дизайнер компании Blizzard Entertainment Роб Пардо работал над играми StarCraft и StarCraft: Brood War, а до этого был продюсером игр Whiplash, Casper и Tempest X в компании Interplay. В ближайшем будущем он собирается продолжить работу по созданию и выпуску высококачественных игр в Blizzard Entertainment.

Перри, Дэвид (David Perry), Shiny Entertainment

Дэвид Перри руководил созданием множества популярных игр, в том числе MDK, Messiah и серии Earthworm Jim. Он приглашает всех желающих ознакомиться с подробностями его биографии на веб-странице www.shiny.com/company/meet_dp.htm. Читаете по-английски? Добро пожаловать!

Принс, Бобби (Bobby Prince), bobby prince Music

Композитор и звукоинженер Бобби Принс работает в собственной компании bobby prince Music (в логотипе его компании буквы «b» и «р» изображены как половинные ноты). В числе его проектов - Commander Keen, Wolfenstein 3D, Duke Nukem II и Duke Nukem 3D, Doom и Doom II, Zorro, Axis & Allies, а также бесчисленное множество условно-бесплатных игр и прочих продуктов. Давным-давно, в 1991 году, Бобби Принс занимался компьютерной музыкой и MIDI-проектами для Prodigy. Это было еще до того, как Интернет стал привычным средством общения. Однажды в апреле 1991 года, в субботу, какой-то парень по имени Скотт Миллер (Scott Miller) поместил объявление, где просил откликнуться людей, интересующихся созданием музыки для компьютерных игр. За пару недель до того Бобби Принс как раз скачал себе исходную версию Commander Keen, и она произвела на него большое впечатление. В то время он еще не знал, что распространением Commander Keen занималась именно компания Скотта, Apogee Software, так как Скотт не упоминал об этом в объявлении. Бобби подумал, что Скотт просто хочет устроиться куда-нибудь на работу, но тем не менее откликнулся. На следующий день Скотт позвонил ему, и, как только он упомянул Commander Keen, Бобби уже знал, что хочет с ним работать. Вот так его и приняли «без прослушивания». Несколько месяцев спустя Бобби Принс получил приглашение от Джона Ромеро (John Romero) из id Software и начал работать над музыкой ко второй части Commander Keen. Как говорится, остальное - уже история. Планы на будущее - «продолжать получать удовольствие всю оставшуюся жизнь».

Притчард, Мэтт (Matt Pritchard), Ensemble Studios

Мэтт Притчард программировал графику для ряда игр, перечисленных здесь в хронологическом порядке: Dragon Quest Pi, Overload, Age of Empires, Age of Empires: Rise of Rome и Age of Empires II: Age of Kings.

Пфайфер, Курт (Kurt Pfeifer), Cavedog Entertainment

Прежде чем стать ведущим программистом проекта Good & Evil компании Cavedog Entertainment (увы, и проект, и компания сегодня, когда выходит в свет русское издание этой книги, уже закрыты), Курт Пфайфер работал над играми Total Annihilation, Duke Nukem (перенос на Sega Saturn), Microsoft Soccer, Powerslave, DinoPark Tycoon и Magic School Bus Across the Solar System.

«Моя команда выиграла соревнования по боулингу, когда мне было 12. Сойдет ли это за посвящение в рыцари?»

Пэтмор, Алан (Alan Patmore), Surreal Software

Алан Пэтмор - президент и руководитель группы разработки компании Surreal Software. Именно он был ведущим разработчиком проекта Drakan. Алан увлекается компьютерными играми с восьми лет - конечно, поначалу он был просто игроком.

Райли, Хью (Hugh Riley), Bethesda Softworks

Хью Райли - старший художник компании Bethesda, за последние 12 лет участвовавший в создании нескольких десятков игр для большинства моделей домашних компьютеров.

Резник, Джош (Josh Resnick), Pandemic Studios

Джош Резник - президент собственной компании Pandemic Studios, до основания которой он был продюсером игры Mechwarrior 2, руководил проектом Dark Reign и курировал выпуск Battlezone. В игровой индустрии он работает более пяти лет, а свою карьеру начал помощником продюсера в Activision.

Рейнольде, Брайан (Brian Reynolds), Firaxis Games

Карьера Брайана Рейнольдса в игровой индустрии началась в компании MicroProse Software с работы над классической игрой Sid Meier's Colonization. Следующим проектом, в котором он принимал участие, была не менее классическая Civilization II, разошедшаяся по всему миру более чем миллионным тиражом, побив все рекорды по объему продаж. Брайан Рейнольде был одним из основателей Firaxis, где специализировался в области искусственного интеллекта. Во время подготовки к выпуску русского издания этой книги Брайан покинул Firaxis Games и вместе с друзьями основал собственную компанию Big Huge Games, Inc. (она располагается там же, где и компания Сида Мейера, в городе Хант Вэли, штат Мэриленд, США), которая, по его словам, будет заниматься «новым поколением стратегий в реальном времени». Будучи страстным любителем стратегических игр, Брайан пытается «научить компьютер играть не хуже, чем я сам». В числе прошлых достижений Брайана - диплом с отличием в области истории и философии Южного университета (University of the South), что в городе Сивани, штат Теннесси. А вот в компьютерной области он самоучка.

Риппи, Крис (Chris Rippy), Ensemble Studios

Крис Риппи - директор по звуку компании Ensemble Studios. Он участвовал в работе над серией игр Age of Empires. Как музыкант, Крис говорит, что попал в мир компьютерных игр «по ошибке». Конечно, игры всегда были его хобби, но он никогда не думал, что сможет совместить два увлечения - звук и игры - да еще неплохо зарабатывать на этом. Его брат Дэвид в течение нескольких лет работал вместе с президентом Ensemble Studios Тони Гудманом (Tony Goodman) и однажды узнал, что Тони собирается основать новую компанию. Что ж, Дэвид будет писать музыку, а Крис - разрабатывать звуковые эффекты. Имея опыт работы на радио и в студиях звукозаписи, Крис как нельзя лучше подходил для этой деятельности. «Это было в 1994 году, - говорит Крис, - и с тех пор я так и продолжаю напевать мелодии».

Робинсон, Сет (Seth Robinson), Robinson Technologies

В свои 25 лет Сет Робинсон - исполнительный директор Robinson Technologies, Inc., a также совладелец компании Nexgen Gaming, занимающейся сетевой розничной торговлей компьютерными играми в Салеме (штат Орегон, США). Он руководил разработкой таких игр, как Legend of the Red Dragon 1 и 2, Planets: The Exploration of Space и Dink Smallwood. Компания Robinson Technologies занимается распространением условно-бесплатного ПО уже более 11 лет. Во время создания этой книги она подписала контракт на разработку пары игр от ManMachine (издателем выступает Macmillan Digital Publishing). Об игре Dink Smallwood писали многие компьютерные журналы, в том числе крупнейшие и известнейшие PC Gamer и PC Games, и ее нередко называют лучшей условно-бесплатной ролевой игрой.

Роузмен, Стюарт (Stuart Roseman), nineCo

Стюарт Роузмен - технический директор компании nineCo, Inc., выпустившей сетевой продукт Gamesville. Он руководил разработкой многих онлайновых многопользовательских игр: The Bingo Zone, Picturama, AceyDeucey, Crystal Ball, Gridiron Madness, Pop Quiz, $100 Catch Up, CoverAll u E-mercial.

Руттман, Хайко (Haiko Ruttmann), Blue Byte Software

Хайко Руттман - музыкальный директор компании Blue Byte Software. Он отвечает за сочинение, аранжировку и запись музыки к компьютерным играм и видеопродуктам, а также создает звуковые эффекты и руководит записью голосов. Свою карьеру в компьютерной индустрии Хайко начал 11 лет назад, работая по контракту. Он участвовал в проектах Twin World, Тот & the Ghost, Historyline 1914-1918, Battle Isle I, II и III, Great Courts I и II, The Settlers I, II и III, Chewy ESC from F5, Dr Drago, Schleichfahrt, Extreme Assault, Ugh! и Incubation.

Саладино, Майкл (Michael Saladino), Presto Studios

Ведущий программист компании Presto Studios Майкл Саладино работает в игровой индустрии пять лет. Сначала он трудился в небольшой компании Mobeus Designs, где отвечал за создание трехмерного графического движка. Затем перешел в компанию Volition, которая выпустила игру Descent, здесь Майкл также был программистом графического движка. Позже он был назначен на должность ведущего программиста для проекта гоночной игры. В Presto Studios Майкл Саладино, продолжая заниматься созданием графических движков, руководит новым проектом, который находится еще на ранней стадии разработки.

Симпсон, Тоби (Toby Simpson), CyberLife Technologies

Тоби Симпсон - художественный руководитель всех проектов серии Creatures, разрабатываемой компанией CyberLife Technology Ltd. (Кембридж, Великобритания). Кроме того, он был продюсером игр Creatures 1, 2 и 3, а также опубликовал несколько книг, две из которых целиком посвящены все тому же проекту Creatures и подводят под него научную основу. Тоби Симпсон уверен, что занимается по-настоящему интересным делом и что системы моделирования биологических существ вполне могут положить начало будущим технологиям виртуальных миров.

Смит, Брэндон (Brandon Smith), Cavedog Entertainment

Во время работы над этой книгой Брэндон Смит был менеджером по работе с прессой в компании Cavedog Entertainment, ныне закрывшейся. Он отвечал за продвижение на рынок игр Total Annihilation (включая все наборы дополнительных миссий) и Total Annihilation: Kingdoms. «В прошлой жизни» Брэндон работал над Gex: Enter the Gecko, Blood Omen: Legacy of Kain, MDK, X-COM: Apocalypse, Worms 2 и многими другими играми.

 | Умница Тим «Верная правая рука Джона Кармака» Уиллитс (Tim Willits) из id Software. Начинающие дизайнеры уровней! Всенепременно внемлите его многочисленным советам, которые опубликованы в этой книге! Фото сделано на выставке E3 2000 г. (Фото из архива журнала Game.EXE.)
Лос-Анджелес, май 2000 г., выставка E3. Руководитель пресс-службы компании Sierra Studios Женевьева Остергард (Genevieve Ostergard) и издатель журнала Game. EXE Михаил Новиков. Народ и разработчики едины! (Фото из архива журнала Game.EXE.) |
 | Клифф Блежински (Cliff Bleszjnski, слева) и Тим Суини (Tim Sweeney), одни из основных авторов 3D-шутера Unreal Tournament (Epic Games/GT Interactive), повсеместно признанного лучшей игрой-99. Фотография сделана 11 мая 2000 г. на выставке E3. Обратите внимание на то, ЧТО держат в руках монстры насилия в компьютерных играх! Естественно, награды от Game.EXE, выполненные лучшими мастерами Холуйских художественных мастерских. (Фото из архива журнала Game.EXE.)

Стельмах, Тимоти (Timothy J. Stellmach), Looking Glass Studios

Тим Стельмах - ведущий разработчик компании Looking Glass Studios. Он был ведущим дизайнером проекта Thief: The Dark Project, где помимо общего руководства работ над геймплеем и миссиями отвечал за курирование разработчиков-новичков. Во время подготовки русской редакции этой книги вышла следующая игра Тима - Thief II: The Metal Age, где он также был ведущим дизайнером. В числе его предыдущих проектов - Ultima Underworld, Ultima Underworld II, System Shock и Terra Nova. Его планы на будущее - превратить Thief из успешной игры в целую серию игр, «обеспечив тем самым компании Looking Glass Studios заслуженную популярность». Но, увы, кажется, этой мечте не суждено сбыться: в конце мая 2000 г. появилась информация о закрытии Looking Glass Studios, подтвержденная в Интернете самим Тимом Стельмахом. Одна из причин - плохие продажи второй части «Вора»...

Стрит, Грег (Greg T. Street), Ensemble Studios

Доктор Грег Смит, дизайнер Ensemble Studios, принимавший участие в создании дополнительных миссий Rise of Rome к игре Age of Empires и игры Age of Empires II: The Age of Kings. В обоих проектах он отвечал за разработку кампаний и «случайных» карт, помогал настроить баланс юнитов и цивилизаций, а также, если это было необходимо, выступал в роли историка-консультанта.

Грег получил работу, обратившись по объявлению о найме на веб-сайт Ensemble Studios. До этого он был морским биологом (в Университете Южной Каролины) и не имел ровно никакого опыта работы в игровой индустрии. «Вот видите, теоретически это ВОЗМОЖНО», - говорит он. Однако, если быть точным, место он получил благодаря своему отличному образованию, писательскому таланту, эрудиции в области истории и практическому опыту игры на компьютере.

Суарес, Гонзо (Gonzo Suarez), Pyro Studios

Гонзо Суарес начал работу в индустрии видеоигр в 1984-85 годах в компании Opera Soft, где написал игру Goody для компьютеров Sinclair Spectrum, Amstrad CPC, MSX, Atari ST и Commodore Amiga. Распространением этой игры за пределами США занималась компания Alligata Soft. За первой игрой последовали Sol Negro, Mot, Crazy Billiards и Arantxa Super- Tennis. Приблизительно в 1989-90 гг. в испанской индустрии видеоигр начался кризис, и Гонзо переключился на неигровое ПО, в том числе на графические редакторы. В 1996 году вместе с группой коллег (большинство из которых составляют костяк команды, работающей над серией игр Commandos) он основал компанию Arvirago Entertainment и занялся разработкой видеоигры Head Hunter, за техническую сторону которой (программирование прототипа) отвечал Хавьер Аревало (Javier Arevalo). Arvirago Entertainment пыталась продать игру разным издателям, включая SCI, но безуспешно. В 1997 году Гонзо Суарес и Игнасио Перес (Ignacio Perez) основали Pyro Studios - так родилась знаменитая игра Commandos: Behind Enemy Lines, проданная на стадии альфа-версии издателю Eidos.

Сэнджер, Джордж «Толстяк» (George «The Fat Man» Sanger), Fatman Music

Джордж Алистер Сэнджер по прозвищу «Толстяк» сочиняет музыку к играм с 1983 года. Вместе со своей «Командой Толстяка» (Team Fat), в которую кроме него входят еще три музыканта, он известен всему миру как автор музыки к более чем 130 играм, включая такие шедевры, как Loom, Wing Commander I и II, The 7th Guest I и II, NASCAR Racing, Putt-Putt Saves the Zoo и ATF. Толстяк первым написал полный MIDI-саундтрек для компьютерной игры, впервые выполнил запись в студии непосредственно в MIDI-формате, впервые записал саундтрек к игре в формате Redbook на отдельном диске, первым написал такую музыку к компьютерной игре, что ее сочли произведением искусства, и, наконец, впервые создал саундтрек, из-за которого игру покупали.

«Команда Толстяка» пишет музыку к играм, не работая при этом на какую-либо конкретную компанию. Не раз и не два ее продукция выходила за рамки того, что обычно ждут от игрового саундтрека, что благотворно сказывалось на продажах. Ежегодно Толстяк проводит Техасскую конференцию по интерактивной музыке (Texas Interactive Music Conference) и конференцию Бар-Би-Кью (так называемый Проект Бар-Би-Кью, Project BBQ), самое престижное мероприятие в области компьютерной музыки, созывая гостей на собственное ранчо в районе реки Гуадалупе, что в Техасе.

 | Легендарный Рэй Музика (Ray Musyka, слева), автор лучшей РПГ-98 Baldur's Gate (BioWare/Interplay), и легендарный Андрей «Кранк» Кузьмин, автор лучшей экшен-игры-98 «Вангеры» (K-D Lab), обсуждают новую игру Кранка «Самогонки». Фото сделано на Конференции разработчиков игр 2000 г. (Фото из архива журнала Game.EXE.)
Ведущий дизайнер лучшего 3D-шутера от первого лица 1998 года Thief: The Dark Project (Looking Glass Technologies/Eidos Interactive) Тим Стельмах (Timothy J. Stellmach). Ha вора все равно не похож! (Фото из архива журнала Game.EXE.) |
 | Выставка E3 1998 года. Бог игры Рон Гилберт (Ron Gilbert, второй слева) среди коллег по Cavedog Entertainment, только что получивших от журнала Game.EXE приз за Total Annihilation (Cavedog Entertainment/GТ Interactive), названную лучшей стратегической игрой в реальном времени 1997 года. (Фото из архива журнала Game.EXE.)

Талларико, Томми (Tommy Tallarico), Tommy Tallarico Studios

Томми Талларико - президент собственной студии Tommy Tallarico Studios, Inc., одной из самых крупных компаний по компьютерной обработке звуков в мире. За 9 лет работы Томми создал музыку к 140 с лишним играм, в числе его важнейших работ - Prince of Persia, Global Gladiators, The Terminator, Cool Spot, Aladdin, Robocop vs. Terminator, Earthworm Jim 1 и 2, Skeleton Warriors, MDK, Treasures of the Deep, Wild 9, Test Drive 4 и 5, Tomorrow Never Dies, Messiah и Рас-Man 3D. За свои достижения Томми получил 19 наград, при этом он еще успевает вести еженедельное телевизионное шоу «Electric Playground».

Вот что он рассказывает о своем пути в игровую индустрию:

«Я родился в городе Спрингфилд, штат Массачусетс. Уже в раннем детстве я мечтал поселиться где-нибудь в Южной Калифорнии и стать музыкантом. Впрочем, кто об этом не мечтает! Но только в 21 год я смог покинуть родной штат и отправиться в долгий путь на машине через всю страну в эту самую Южную Калифорнию. Единственное место в тех краях, о котором я хоть что-нибудь знал, называлось Голливуд. Наверное, это название знакомо и вам. Словом, я не придумал ничего лучше, чем прикатить прямиком в Голливуд. Я тогда понятия не имел, где буду ночевать, ибо никого там не знал, у меня не было работы, но что печальнее всего, к концу путешествия я остался без копейки в кармане. Въехал я, значит, на своей колымаге в этот самый Голливуд, посмотрел направо-налево и сказал себе: «В какое ублюдочное захолустье меня занесло!» Те из вас, кому довелось побывать в Голливуде, знают, о чем я говорю. Голливуд - отнюдь не то потрясающее местечко, о котором вам изо дня в день твердят по телевизору. По большей части это самые настоящие трущобы. «Парень, ни за что на свете ты здесь жить не будешь», - сказал я себе. Но тут меня осенило, я вспомнил еще об одном месте, которое, по моим понятиям, должно было находиться тоже где-то в Калифорнии. Диснейленд, черт возьми. Я остановил на улице какого-то бомжа и поинтересовался, где в этих краях обитает старина Микки-Маус. Бомж махнул рукой куда-то на юг и пробурчал что-то про 45 минут и Орандж Каунти. Лишь добравшись до этого Орандж Каунти, я смог спокойно вздохнуть: это больше похоже на то, о чем я мечтал.

Первым делом я просмотрел все объявления о приеме на работу в газете, которую подобрал прямо на улице. Наследующий день меня взяли в музыкальный магазин продавцом клавишных инструментов. (Ночевал я в те дни или прямо в машине, или на берегу океана в Хантингтон Бич.) Какая-никакая, но это была работа. День спустя я пришел в свой магазин, и, хотите верьте - хотите нет, мой первый покупатель оказался... продюсером недавно созданной программистской компании под названием Virgin Mastertronic. Надо заметить, что музыку я обожал с детства. На фортепьяно начал играть, кажется, в три года. А второе мое самое сильное увлечение - они, видеоигры. Но мне и в голову не приходило, что эти две страсти можно как-то совместить. И вот оно - счастье! Уже на следующий день я стал тестером в Virgin. (Напомню вам: тестерам, этим счастливцам, платят деньги за то, что они играют в игры и отыскивают в них всякие ошибки.) В Virgin работало в то время всего 15 человек, и штатный музыкант им тогда не требовался. Но вскоре поступил заказ написать музыку для какой-то игры (а именно Prince of Persia для Game Boy), и мой час пробил! Днями и ночами я просиживал вместе с программистами, пытаясь вникнуть в суть того, чем они занимались. Тщетно. Но я не сдавался. Честно сказать, я и сейчас почти ничего не смыслю в программировании и компьютерах. Моя единственная специальность - музыка. В чем-то это даже мое преимущество: сами подумайте, каково корячиться над программированием блюза или рок-н-ролла, если это надо просто чувствовать. Как бы там ни было, но музыку к Prince of Persia я писал по выходным и после работы, причем совершенно бесплатно. Вице-президент компании был настолько потрясен результатом, что немедленно зачислил меня в штат главным специалистом по музыкальному оформлению игр!»

Томас, Чэнс (Chance Thomas), Yosemite Entertainment

Чэнс Томас - композитор, завоевавший немало наград (в том числе Emmy, Telly, Addy и Aurora), и музыкальный продюсер с большим опытом работы в рекламной индустрии. Ему довелось работать для таких всем известных компаний, организаций и ассоциаций, как McDonald's, Nissan, Tupperware, Rexall, Армия спасения, NBA (композиция Utah Jazz) и многих других. Его музыка транслировалась повсюду в Америке и на всех пяти континентах.

Заключив эксклюзивный контракт с компанией Sierra On-Line, Чэнс сочинял музыку для всех проектов ее подразделения Yosemite Entertainment, не так давно закрытого. Он отвечал за создание первой оркестровой аранжировки для игры Sierra On-Line, первого рок-сингла и выпуск альбома саундтреков к играм. Чэнс Томас одним из первых разработал интерактивную музыкальную систему, основанную на цифровых аудиопотоках, а не на привычных MIDI-технологиях. В число его работ входят игры Quest for Glory V, SWAT 2, The Realm и два закрытых проекта - Middle Earth и Navy SEALs.

Чэнс Томас постоянно ратует за поднятие качества музыки в играх. Воспользовавшись трибуной Академии интерактивных наук и искусств (Academy of Interactive Arts and Sciences, AIAS), он требует предоставить больше возможностей для композиторов и музыкантов в этой области искусства. Он не раз выступал и публиковал статьи о преимуществах hi-fi-звука в сочетании с интерактивными музыкальными разработками. Он же организовал и возглавил движение за номинирование музыки к играм на награды премии Grammy.

Когда-то Чэнс работал в индустрии развлечений и немало поездил с гастролями как солист и клавишник. Он также выступал как соло-пианист, причем в этом качестве работал с такими знаменитостями, как Том Круз, Джон Траволта, Брюс Виллис и Сара Вон (Sarah Vaughn). Чэнс закончил с отличием музыкальный колледж Университета Брайема Янга (Brigham Young University), получая во время учебы общеамериканскую стипендию.

Тошлог, Мэтью (Matthew Toschlog), Outrage Entertainment

Мэтью Тошлог - президент студии Outrage Entertainment, которая разработала игру Descent III, впоследствии изданную Interplay Productions. Ранее эта же группа разработчиков выпустила игры Descent и Descent II в компании Parallax Software. Мэтью Тошлог начал работать в игровой индустрии в 1986 году в корпорации Sublogic над проектами Flight Simulator и Jet для компьютеров на базе процессора Motorolla 68000 (Amiga, Atari ST и «Макинтош»). До основания Parallax Software в 1993 году он был руководителем проекта Car & Driver, выпущенного компанией Electronic Arts, а также слегка приложил руку к Ultima Underworld от Origin Systems.

Тэйлор, Крис (Chris Taylor), Gas Powered Games

Президент компании Gas Powered Games Крис Тэйлор занялся видеоиграми более одиннадцати лет назад; его первое творение называлось Hardball II, это было продолжение очень популярной в свое время игры Боба Уайтхеда (Bob Whitehead). Компания Distinctive Software, в которой тогда работал Крис, была хорошо известна благодаря своей игре Test Drive. Крис помогал делать Test Drive II в течение месяца или около того, когда команда отстала от графика. «Это было очень хорошее время», - вспоминает Крис. Когда выходил Hardball II, «наверное, ни одна роженица так не мучилась, как мы тогда. Начинать всегда трудно». Поступив в продажу, игра разошлась примерно сотней тысяч экземпляров и получила приз SPA как лучшая спортивная игра года. «Получить награду тогда было очень трудно, - говорит Крис, - так что мы страшно этим гордились».

Сразу после Hardball II Крис Тэйлор вместе с Джеем Макдональдом (Jay MacDonald) занялись проектом 4D Boxing. «Джей как никто понимал, что может дать игре технология видеофиксации движения. Я многому у него научился, и нам было очень приятно работать вместе», - вспоминает Крис. Следующим пунктом в списке его работ стала игра Triple Play, хотя он часто уверял, что никогда больше не возьмется делать симулятор бейсбола. «Это был гораздо более полезный опыт, чем я обычно признавал», - говорит Крис Тэйлор. Затем была игра Virtua Stadium Baseball, а чуть позже Крис познакомился с легендарным Роном Гилбертом (Ron Gilbert) и начал работу над Total Annihilation. «Это была игра, которая, как я надеялся, изменит многое... включая мое желание жить и продолжать работать в индустрии», - вспоминает Крис Тэйлор.

Впоследствии Крис Тэйлор оставил Cavedog/Humongous и основал собственную компанию, Gas Powered Games, которая недавно подписала издательское соглашение с Microsoft на игру Dungeon Siege, определяемую по жанру как «стратегическая РПГ».

 | Один из главных авторов замечательной стратегии Age of Empires (Ensemble Studios/ Microsoft) Брюс Шелли (Bruce С. Shelley, слева) и Джефф Бриггс (Jeff Briggs) из Firaxis на выставке E3 1998 года. Ниже здесь и на следующей странице все сплошь его ученики и сотрудники. (Фото из архива журнала Game.EXE.)
Крис Риппи (Chris Rippy), главный в Ensemble Studios no звуку. (Приводится с разрешения Ensemble Studios.) |
 | Брэд Кроу (Brad Crow), ведущий художник. (Приводится с разрешения Ensemble Studios.)

Тэйлор, Крис (Chris Taylor), Interplay Productions

Полный тезка знаменитого автора Total Annihilation Крис Тэйлор из Interplay Productions является ведущим разработчиком этой компании. Он руководил проектами Stonekeep и Fallout, создавал кампании для МАХ 2, а во время написания этой книги занимался игрой Star Trek: Starfleet Command, вышедшей в середине 1999 года, но лавров, увы, не снискавшей.

Уиллитс, Тим (Tim Willits), id Software

Тим Уиллитс - ведущий дизайнер уровней в компании id Software, где он работает уже более четырех лет. Первое знакомство Тима с продуктами id состоялось благодаря игре Doom. Едва сев за Doom, он уже знал, что это уникальная игра. Вскоре он обнаружил, что вполне может и сам создавать уровни и что их создание - это как раз то, чем он хотел бы заниматься. Подумано - сделано: Тим самостоятельно разработал серию уровней к Doom II под общим названием Raven, включающую как одиночные карты, так и дефматч-уровни.

К счастью Тима, как раз в это время id Software занималась поиском высококачественных «любительских» уровней для проекта Doom II Masters Levels. Так Тим Уиллитс и стал работать на id Software по контракту. В то же время компании Rogue Entertainment потребовался штатный дизайнер уровней для проекта Strife, и Тим переехал в Техас, чтобы работать в Rogue, находящейся буквально по соседству с id Software. Через некоторое время id понадобился на постоянную работу «уровнестроитель», и первым делом руководство компании вспомнило о Тиме. Уже придя в id, он работал над Ultimate Doom и помогал заканчивать Quake, а затем стал ведущим дизайнером уровней легендарных Quake II и Quake III: Arena.

Уилсон, Джей (Jay Wilson), Monolith Productions

Джей Уилсон - разработчик компании Monolith Productions. Он был ведущим дизайнером уровней в проектах Blood и Blood: Plasma Pak, а также руководителем разработки игры Blood 2: The Chosen и дополнительных миссий к ней.

Уоллс, Дэвид (David Walls), Hasbro Interactive

Уже более двух лет Дэвид Уоллс является художественным руководителем компании Hasbro Interactive. Под его руководством и при его непосредственном участии создается большинство игр компании, в том числе Frogger, Centipede, Game of Life, Jeopardy, Wheel of Fortune, Clue, серия Tonka. Дэвид и его компания собираются продолжать делать не менее качественные игры, надеясь пополнить их список оригинальными новинками.

Фогель, Джефф (Jeff Vogel), Spiderweb Software

Джефф Фогель - президент маленькой компании Spiderweb Software, в которой работают всего два человека. С помощью нескольких внештатных сотрудников они производят и продают условно-бесплатные игры в стиле фэнтези для «Макинтоша» и ПК. «Трудовой стаж» компании - около шести лет, ее доход от годовых продаж выражается шестизначной цифрой. Spiderweb Software самостоятельно разработала трилогию Exile, игры Blades of Exile и Nethergate, она же продает Ocean Bound, небольшую но «умную» игру для «Макинтоша». Игры Spiderweb Software упоминались практически во всех крупных игровых журналах, a Exile III получила награду «Лучшая условно-бесплатная игра года» от Computer Gaming World. Но, говоря об успехах, Джефф Фогель не забывает повторять: «Мы часто получаем более ценные для нас награды: те 25-30 с трудом заработанных долларов, которые люди отдают за наши игры».

 | Дизайнер Грег Стрит (Greg Т. Street). (Приводится с разрешения Ensemble Studios.)
Программист Мэтт Притчард (Matt Pritchard). (Приводится с разрешения Ensemble Studios.) |
 | Майкл Маккарт (Michael McCart), веб-мастер Ensemble Studios. (Приводится с разрешения Ensemble Studios.)

Фримен, Чэд (Chad Freeman), Dreamtorge Intertainment

Чэд Фримен - ведущий программист студии Dreamforge Intertainment, Inc. Он работал над такими играми, как Anvil of Dawn (New World Computing), Warwind (SSI), a его последней работой была игра Sanitarium, изданная компанией ASC Games. В будущем Чэд мечтает создать игру, превосходящую Sanitarium по динамичности и остроте сюжета.

Фристром, Джейми (Jamie Fristrom), Treyarch Invention

Джейми Фристром - старший программист компании Treyarch, на счету которой игры Magic Candle II, Magic Candle III, Bloodstone, Seige, Wheel of Fortune (для DOS и Windows), Beat The House (версия для Windows), Die by the Sword и Limb From Limb.

Хаджинс, Марк (Marc Hudgins), Yosemite Entertainment

Во время написания этой книги Марк Хаджинс был художественным руководителем ныне закрытой студии Yosemite Entertainment, принадлежащей компании Sierra On-Line. Когда Марка просят перечислить проекты, в которых он принимал участие, он обычно отвечает: «Да всех и не упомнишь!» Но кое-что из его основных работ мы назовем: Quest for Glory 1, 3 и 4, Slater and Charlie Go Camping, The Realm, King's Quest 7, а также закрытый (вместе с Yosemite) проект Babylon 5.

Хауз, Шон (Sean House), Electronic Arts

Помощник продюсера Шон Хауз отвечает в компании ЕА за серию игр Madden NFL Football для ПК. Его планы на будущее - «взбираться все выше и выше по лестнице мастерства, ставить перед собой все более серьезные задачи, создавать новые и при этом обязательно новаторские развлекательные программы».

Хаусхолдер, Мэтт (Matt Householder), Blizzard Software

За долгие годы работы в игровой индустрии Мэтт Хаусхолдер имел дело с играми практически для всех возможных платформ: для игровых автоматов (он участвовал в создании Q-Bert), приставок (от ColecoVision до NES, Game Boy, SNES, Genesis, 3DO Multiplayer и PSX) и домашних компьютеров (Apple II, С64, Amiga, Atari ST и DOS - еще со времен CGA-графики).

Мэтт начал программировать игры для игровых автоматов в 1981 году, а в 1983-м закончил свою первую игру Krull в жанре экшен/РПГ. В следующем году он перенес на ColecoVision игру Moon Patrol, в которой сам выполнил большую часть графики и звуковых эффектов. С 1985 по 1988 годы Мэтт создал множество игр для Ерух, в том числе Winter Games, World Games и California Games (он отвечал за создание, разработку и общее руководство этими проектами). С тех пор он выпускал различные игры для компаний Activision, Ерух, DTMC (ныне не существующей) и 3DO. В Blizzard North Мэтта пригласили в качестве ведущего разработчика/продюсера Diablo II и ответственного за подбор кадров для этого проекта - программистов, художников, специалистов по звуковому и музыкальному оформлению.

Хесс, Торстен (Torsten Hess), Blue Byte Software

Торстен Хесс - руководитель проекта и художник в студии Blue Byte Software, время от времени выступающий в качестве свободного художника. Он принимал участие в создании многих игр, в том числе Incubation (сюжетные эскизы) и Settlers III (руководитель проекта), а затем занялся работой над дополнительными миссиями к этой игре.

Холл, Том (Tom Hall), ION Storm

Том «Органон» Холл - очень известный разработчик, продюсер и вице-президент компании ION Storm. Он был одним из ее соучредителей, как и компании id Software незадолго до этого. Том Холл родился в Новом Берлине (штат Висконсин, США). Получив диплом программиста в университете родного штата, он превратил свое хобби, создание игр, в работу, о которой можно только мечтать. На счету этого талантливого человека такие игры, как серия Commander Keen, Wolfenstein 3D, Spear of Destiny, Doom, Duke Nukem II, Rise of the Triad, Terminal Velocity и, наконец, трехмерная научно-фантастическая ролевая игра Anachronox, которая должна увидеть свет в середине 2000 г.

Хорлинг, Брайан (Bryan С. Horling), Freeverse Software

Брайан Хорлинг - дипломированный специалист по многопользовательским системам, программист условно-бесплатных программ, создаваемых компанией Freeverse Software. Он один из авторов пасьянса Burning Monkey Solitaire для ПК и «Макинтоша» и игр Jared и Virtual Viagra; во время написания этой книги он заканчивал игру Mr. Relaxer. В будущем Брайан собирается обновить версию Burning Monkey Solitaire для «Макинтоша», возможно, добавив в нее игру по Интернету. Не исключено, что он напишет еще одну игрушку, главным героем которой будет безостановочно болтающая и совершающая случайные действия обезьянка.

Чарн, Джим (Jim Charne), Academy of Interactive Arts and Sciences

Джим Чарн - президент и исполнительный директор Академии интерактивных наук и искусств (www.interactive.org). Прежде чем занять этот высокий пост, Джим работал в городе Санта-Моника (штат Калифорния, США) юристом в сфере интерактивных развлечений и музыкальной продукции. В частности, в его послужном списке есть пост вице-президента по деловым и юридическим вопросам/главного юрисконсульта крупной студии по производству программного обеспечения для приставок, он занимался производством развлекательных и персональных программ для Activision, был штатным сотрудником группы технологических разработок в Merrill Lynch & Co., Inc. (Нью-Йорк), а в музыкальной индустрии Джим успел поработать руководителем отдела национального маркетинга в CBS Records (сейчас Sony Music) и штатным юристом в Arista Records. Джим Чарн имеет право на адвокатскую практику в Калифорнии, Нью-Йорке и Нью-Джерси. Он выступал с докладами на многих мероприятиях, в том числе на выставке E3, Конференции разработчиков компьютерных игр (Computer Game Developers Conference), съезде юристов Калифорнии, занятых в области искусств (California Lawyers for the Arts), и конференции «Цифровой Голливуд» (Digital Hollywood).

Шелдон, Ли (Lee Sheldon), Southpeak Interactive

Во время создания этой книги писатель и продюсер Ли Шелдон работал в компании Southpeak Interactive, где он участвовал в создании таких игр, Dark Side of the Moon, Temujin, The Riddle of Master Lu и 20000 Leagues: The Adventure Continues. До прихода в игровую индустрию Ли Шелдон работал на телевидении как сценарист и продюсер. На его счету более 200 самых разнообразных проектов, включая популярные сериалы Charlie's Angels и Star Trek: The Next Generation. Он неоднократно номинировался на награды от профессиональных писательских организаций Mystery Writers of America и Writers Guild of America. Осенью 1999 года Ли Шелдон перешел в компанию Imaginaria, Inc. (город Ривердейл, штат Мэриленд, США), где работает продюсером и главным сценаристом средневекового фэнтезийного многопользовательского квеста-вселенной The Gryphon Tapestry (www.gryphontapestry.com).

 | Большой друг России и журнала Game.EXE Тоби Симпсон (Toby Simpson), художественный руководитель всех игр знаменитой серии Creatures (CyberLife Technology/Mindscape). (Фото из архива журнала Game.EXE.)
Луис Касл (Louis Castle), вице-президент Westwood Studios, человек, который знает все о создании компьютерных игр. Еще немного, и он подарит нам первый в мире 3D-шутер по вселенной Command&Conquer! (Приводится с разрешения Westwood Studios.) |
 | Лондонская выставка-ярмарка ECTS 1999 года, официальная награда выставки от России. (Фото из архива журнала Game.EXE.)

Шелли, Брюс (Bruce С. Shelley), Ensemble Studios

Ведущий разработчик Ensemble Studios и один из ее руководителей, Брюс Шелли участвовал в создании многих легендарных компьютерных игр, в том числе Railroad Tycoon, Covert Action, Civilization, Age of Empires, Age of Empires II: Age of Kings. В настоящее время он работает над пока еще не объявленной стратегией в реальном времени, которая, это можно утверждать со стопроцентной гарантией, будет связана с историей, как и другие игры Ensemble Studios.

Шилдер, Кевин (Kevin Schilder), Raven Software

Кевин Шилдер руководит отделом звукозаписи в компании Raven Software (Мэдисон, штат Висконсин, США), состоящим помимо Кевина еще из одного сотрудника и отвечающим за аудиодизайн, музыку и иное звуковое оформление игр.

Кевин Шилдер тридцать с лишним лет работает с музыкой, он дипломированный музыкант. До Raven Software он в течение шести лет работал в сфере продажи музыкальных произведений, а также преподавал музыку в школах. Кевин является сотрудником Raven Software с момента основания компании, но официально был зачислен в штат только в 1994 году. В числе его работ - Black Crypt для Amiga (вся музыка), Cyclones (часть звуковых эффектов), а также музыка и звуковые эффекты для игр Heretic, Hexen, Necrodome, Hexen II, Portal of Praevus (набор дополнительных миссий к Hexen II), Mageslayer, Take No Prisoners и Heretic II. Кроме того, он был художественным директором игры Take No Prisoners.

Кевин Шилдер начал писать музыку к компьютерным играм благодаря своему знакомству с Брайаном и Стивом Раффелами (Brian, Steve Raffel), основателями Raven Software, когда он по-дружески предложил им сочинить музыку для их первой игры Black Crypt. Блестящее музыкальное образование Кевина, его интерес к компьютерам, любовь к фантастическим фильмам и компьютерным играм, а также желание сочинять музыку делают его очень значимой фигурой в этой области игровой индустрии.

Шнурр, Карл (Carl Schnurr), Red Storm Entertainment

«Моя мамочка утверждает, что я начал играть еще у нее в животе... Эх, помнил бы я правила!» Карл разрабатывает «антитеррористические» трехмерные игры и руководит проектом Тот Clancy's Rainbow Six. Карл - ярый сторонник реализма. Стремясь добиться максимально достоверных движений персонажей, он отправил всех своих сотрудников на огневой полигон, где они на практике изучали тонкости стрельбы и ведения боя.

До прихода в Red Storm Entertainment Карл Шнурр был вице-президентом по разработке игр в компании Fringe Multimedia, Inc., расположенной в Северной Каролине (США) и занимающейся выпуском программного обеспечения и созданием веб-сайтов. Отвечая за игры и образовательные программы, Карл также был редактором отмеченного наградами веб-сайта TheBlip.com. Его опыт в игровой области включает написание многочисленных приложений к ролевой игре Ars Magica от White Wolf.

Не менее интересными вещами Карл Шнурр занимался и вне игрового бизнеса. Физик, доктор наук Шнурр (он окончил Техасский университет и Университет Duke) является автором нескольких руководств для астронавтов.

Эйкман, Питер (Peter T. Akemann), Treyarch Invention

Доктор Питер Эйкман - один из управляющих компании Treyarch Invention и руководитель весьма успешного и интересного проекта Die by the Sword. Именно он разработал технологию VSIM, с помощью которой выполняется большая часть анимации в этой игре.